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Welcome to ViewletQuiz3.1 
 
ViewletQuiz3.1 provides an elegant and efficient way to create and deliver stunning 
interactive Flash quiz and survey Viewlets. Boasting over 10 question types, 
ViewletQuiz3.1 has the ability to import image files, audio clips and even movies, 
including Qarbon’s famous Viewlets. Built-in stylesheets are customizable for creation 
and application of global object properties to standardize and speed up ViewletQuiz3.1 
creations.  The format painter makes editing tasks easy and swift, reducing redundant 
formatting steps with just a single click.  Action types expand the possibilities of creativity 
without losing control over object timings throughout surveys and quizzes.  These are 
just a small sampling of the features you’ll discover in ViewletQuiz3.1. 
 
That’s not all.  With over three million presentations and interactive demonstrations 
accessed online and offline every month, Viewlets continue to be one of the leading 
media venues for sharing information, providing technical support, and presenting 
products and training.  In addition, ViewletQuiz3.1 supports SCORM 1.2 and SCORM 
2004 reporting. 
 
If you want to see what others are doing with ViewletQuiz3.1, browse through our 
customers’ case studies (www.qarbon.com/features/case-studies/).  Qarbon’s clients 
know ViewletQuiz3.1 gives you immediate access to valuable information to help you 
make well-informed business decisions. Go ahead and conduct your marketing surveys, 
perform product concept testing, train/test staff knowledge and/or measure customer 
satisfaction easily with ViewletQuiz3.1 as your foundation. 
 
This user manual is designed to introduce you to the world of Viewlet authoring and 
provide you with an overview of the most important ViewletQuiz3.1 features you will 
need to know to create your own interactive Flash quiz and survey Viewlets. 
 
Let’s get started. 
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New and Enhanced Features 
 
ViewletQuiz3.1 introduces some new features and many enhancements, making the 
program even more versatile, the creation process smoother and published content 
more compelling. Some of the new and enhanced features include: 
 

 Message Editing Preferences (Edit in Place; Message Editor) 
 Quiz Project (New Project Type Combining Quiz and Survey Project Types) 
 Arrange Layers via Drag and Drop Actions 
 Message Editor Dialog Window 
 Automatic Resize of Message Objects Feature 
 RAW Audio File Format Support 
 Play Sound Action Options (Synchronicity and Concurrency) 
 Auto Submit Key Option (Text Zones; Text Input Fields) 
 Resize Project 
 Crop Project 
 Page Layout Options – Balloons and Notes 
 Publishing Locations 
 Importing Slides with Different Sizes (Slide Alignment Window Options) 
 Additional Status Bar Selections  
 Disable JavaScript to Flash Interface Option 
 ViewletSkin Embedded Fonts 
 Zip File Options for SCORM 2004 and SCORM 1.2 LMS Publishing 

 
 
In this user manual it’s even easier to spot new and enhanced features and important 
Viewlet authoring tips within the manual. Just “skim” down the left margin and be on the 
lookout for one of these icons: 
 

  Read up for more information on a feature that is “new” or 
“enhanced” in ViewletQuiz3.1. 
 

  Don’t let this “tip” pass you by. Find out how to improve your Viewlet 
authoring skills with suggestions from the experts. 
 

 
If you have any questions, please contact us. Or, visit our web site (www.qarbon.com) 
for more information on all of Qarbon’s products. 
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Tech Specs 
 
The technical specifications, including minimum system requirements, for the effective 
use of ViewletQuiz3.1 will depend on various factors, including your operating system. 
Go to the ViewletQuiz3.1 product page (the link can be found on the Qarbon’s web site 
home page at www.qarbon.com). On the product page select the “Technical Specs” (or 
related) link for more information. 
 
If you have any questions after reviewing the technical specifications for ViewletQuiz3.1, 
contact us using the “Contact Us” or “Support” links on the home page 
(www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Download and Installation 
 
To download ViewletQuiz3.1, go to the Qarbon home page (www.qarbon.com). Click the 
“Downloads” link. On the “downloads” page, select ViewletQuiz3.1 as the product you 
want to download. Follow the instructions on the rest of the web pages that display to 
download the installation file. 
 
 
Remember the file name and folder location of the installation file so you can find it when 
you are ready to install ViewletQuiz3.1. 
 
 
After downloading the installation file, close the browser window. Then, locate and 
double click the installation file to launch the installation wizard. Follow the prompts in 
the installation wizard’s windows to install ViewletQuiz3.1. 
 

 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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License Activation and Deactivation 
 
You must purchase a license to activate ViewletQuiz3.1. To purchase a license online, 
go to the Qarbon web site (www.qarbon.com) and click the “Store” link and select a 
pricing option. Or, you can contact the Qarbon Sales Team (sales@qarbon.com) for 
current pricing and related purchasing information. 
 
Once you purchase a license, you will receive a confirmation email with your license and 
purchase information. Keep this email for your records. 

License Activation 
To activate ViewletQuiz3.1: 

 Make sure your computer is connected to the Internet. 
 Open the ViewletQuiz3.1 program. 
 Select Help > License Activation from the Menu bar. 

 

 
 

 Follow the instructions in the windows that display to complete the registration 
process. 

 
 
For best results, copy the license number directly from your email and paste it in the 
required field when registering ViewletQuiz3.1. 
 
 
To check license information: 

 Make sure your computer is connected to the Internet. 
 Open the ViewletQuiz3.1 program. 
 Select Help > About ViewletQuiz3.1… from the Menu bar. 
 Review the information in the About ViewletQuiz3.1 window that displays. 
 Click Close to exit the window. 
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License Deactivation 
There may be times when you will need to use your license on a different computer. To 
avoid any license abuse issues (such as registering a single use license on more than 
one machine at the same time, possibly resulting in your license being suspended), you 
can deactivate your license. The process is simple. 
 
To deactivate your ViewletQuiz3.1 license: 

 Make sure your computer is connected to the Internet. 
 Open the ViewletQuiz3.1 program. 
 Select Help > License Deactivation from the Menu bar. 

 

 
 

 Follow the instructions in the windows that display to complete the deactivation 
process. 

 Install ViewletQuiz3.1 the other computer. 
 Follow the “license activation” steps to activate the license on the other 

computer. 
 
 
If you do not have Internet access or encounter firewall issues, go through the 
activation/deactivation wizard as usual. On the last screen, you will find troubleshooting 
instructions to resolve/complete the activation/deactivation process.  
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Interface Overview 
 
It’s important to be comfortable when working in ViewletQuiz3.1. This chapter provides 
some quick snapshots of what the ViewletQuiz3.1 program GUI (Graphical User 
Interface) “looks like” before you open a project and when a project is first opened. It 
also contains a brief description of the most common features and tools displayed in 
each scenario to give you a good “jump start” into using ViewletQuiz3.1. 
 
Example of ViewletQuiz3.1 Interface – No Project Open 
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Example of ViewletQuiz3.1 Interface – Project Open 

 
 
 

Interface Features and Tools 
The ViewletQuiz3.1 GUI includes: 
 

 Start View Panels: When ViewletQuiz3.1 is launched the opening window 
displays a “Start View”, which is divided into individual “Panels”: 
 

o Start View – Actions Panel: Displays “action” links for New Project, Open 
Project and Check for Updates. 
 

o Start View – Recent Files Panel: Displays links for quick access to the 
most recent projects previously opened in ViewletQuiz3.1. 
 

o Start View – Help Panel: Displays links to help and training resources 
such as ViewletQuiz3.1 Help, User Guide and Webinars. A License 
Activation or License Deactivation “quick access link” is also available. 
 

o Start View – Publishing History Panel: Displays a list of Viewlets 
published to ViewletCentral. 
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o Start View – Tutorials Panel: Displays links to various self-help Viewlet 
authoring tutorials. 
 

o Start View – Start Panel: Dynamic (and fully customizable) page served 
from the Qarbon (or your company’s) server with important information 
regarding product updates (or information relevant to your company, if 
applicable). For a customized version of this page, contact 
sales@qarbon.com for more information. 
 

o Start View – Web Page Buttons Panel: Displays three buttons (left to 
right) to launch the Qarbon home page, the ViewletQuiz3.1 products page 
and/or the ViewletCentral home page. 

 
 Title Bar: This is the “bar” displayed at the top of the program window. 

Depending on whether the project is open or closed, it contains the program title, 
followed by the file name. It also includes three buttons to Minimize, Restore 
Down/Maximize and/or Close the program window. 
 

 Menu Toolbar: This toolbar “sits” below the Title Bar and contains menu titles 
that reveal additional drop-down menu options. The Menu bar offers access to: 
File, Edit, View, Insert, Project and Help operations. 
 

 Main Toolbar: This toolbar is below the Menu bar and displays a series of 
standard command buttons that offer quick “one-click” access to many tools in 
ViewletQuiz3.1. Many of these buttons on the Main Toolbar provide easier 
access to many options also available on the Menu bar. 
 

 Context Sensitive Toolbar: This toolbar displays when a project is open and is 
located below the Main Toolbar. The buttons displayed on this toolbar vary, 
depending on the current selection. This toolbar’s buttons change dynamically as 
you work within the project. 
 

 Tab Views: By default, different tabs for selected “views” (from the View menu) 
display to the left of or below the slide editing pane. Tab View selections include: 
Browser, Thumbnails, Stylesheets, Output, Timeline and Slide Notes. 
 

 Object Toolbar: Previously known as the “Tools Palette”, this toolbar displays to 
the right program window. It contains buttons for working with various objects 
such as: Balloons, Notes, Text Boxes, Cursors, Shapes, Images, Buttons, 
Movies, Pause Zones, Click Zones, Text Zones, Keystroke Zones and Questions 
while editing a project. 
 

 Slide Edit Area: This is the default panel view when a project is open. It displays 
the current slide for editing / viewing operations. The Slide Edit Area is hidden 
when any Tab View is maximized. 
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 Status Bar: Located at the bottom of the program window, this “bar” displays 
helpful information such as the number of the currently selected slide, the 
number of total slides in the project, the dimensions of the project, the “x” and “y” 
coordinates of your cursor as you work in the program window, the amount of 
system memory in use, and the zoom level currently selected. 

 
Each of these features and tools are discussed throughout this user manual. If you have 
any questions, contact us using the “Contact Us” or “Support” links on the home page 
(www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Program Preferences 
 
In ViewletQuiz3.1, you can set up program preferences for features such as language, 
spelling, proxy server, log files for error reporting, backup files and more. This chapter 
explains how to set up each of these global preferences for your Viewlet projects. 
 
 
You do not need to have a project open to set up program preferences. 
 
 
 
To access the program Preferences window: 

 Select Edit > Preferences from the Menu bar. 
 

 
 

 The Preferences window displays. Select the desired tab by clicking on it. 
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The General Tab 
 

 
 
 
Language
The General tab allows you to specify the language that is used in the interface. By 
default, ViewletQuiz3.1 will use your operating system’s default language preference, 
but you may switch to a different language for use in this program only. 
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To select the default language to use in the ViewletQuiz3.1 interface: 

 In the Preferences window, select the General tab. 
 In the Language area, click the Change Language button. 
 Select a language from the available list. 

 

 
 

 Click OK. 
 
 
Recording 
You can select a countdown timer to display before each recording session when adding 
audio to slides, shapes, images or message objects. 
 
To set recording preferences: 

 In the Preferences window, select the General tab. 
 In the Recording area, select the Display Countdown Timer option. 
 Type the number of seconds for the countdown to display in the Countdown 

Duration field, or use the up/down areas to set this value. 
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Message Editing Area (New in ViewletQuiz3.1) 
In the Preferences window in the General tab, there is a new area called Message 
Editing. In this area, there are two options for editing message objects. Select one of 
these options to set as the default preference to use while working with notes, balloons 
and text boxes. 
 
To set a default message editing preference: 
 

 In the Preferences window, select the General tab. 
 

 In the Message Editing area, select either: 
 

o Edit in Place: When editing a message object, this selection allows you 
to edit text directly in the balloon, note or text box. And, you can use the 
message object’s Context Sensitive Toolbar to edit other message object 
properties. 
 
or 
 

o Use Message Editor: When editing a message object’s text, this 
selection opens the Message Editor window when double clicking a 
balloon, note or text box. This selection also allows you to edit other 
message object properties directly in the Message Editor window. 

 
 
It’s easy to switch between “message editing” options while working with message 
objects. Simply right click on the message object and, from the shortcut menu, select 
either “Open in Message Editor” to work in the “Message Editor” window, or select “Edit 
Message” to edit text directly in the message object. 
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The Spelling Tab 

  
 
In ViewletQuiz3.1, you can set preferences for the spell checker tool, which will 
automatically proof text in all of the message objects throughout your project.  
 
To select a default dictionary language to use in ViewletQuiz3.1: 

 In the Preferences window, select the Spelling tab. 
 In the Spell Checker area, select a language from the list to use as the default for 

the program’s spell checker tool. 
 
To select additional options for the spell checker: 

 In the Preferences window, select the Spelling tab. 
 Under the language list, select any additional options to use with the spell 

checker including: 
o Ignore words in UPPERCASE 
o Ignore words with numbers 
o Ignore domain names 

 
To enable/disable the spell checker tool, select “View” from the Menu bar. Then 
select/deselect the “Spelling Mistakes” option. 
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The Proxy Tab 
 

 
 
There may be times when you encounter firewall issues while working with 
ViewletQuiz3.1. This may occur when activating your license or when updating the 
program. This is when a proxy server comes in handy, if your company has one 
available. The Proxy tab is where you can set up default proxy server information for the 
program to automatically use when encountering firewall issues. If, however, you do not 
know what a proxy server is, chances are you don’t need to worry about it. Some 
companies, however, actually require that software programs that access the Internet 
log on through a proxy server. In this case, your network administrator should have the 
information you will need to fill out this preference screen. 
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To set proxy server default information: 
 

 In the Preferences window, select the Proxy tab. 
 

 In the Preferences area: 
 

o Select the Use a proxy server. 
 Enter the proxy Address in the field provided. 
 Enter the proxy Port in the field provided. 

 
o Select the Use proxy authentication (if this is required by your server). 

 Enter the proxy Login in the field provided. 
 Enter the proxy Password in the field provided. 

 

The Logging Tab 
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While ViewletQuiz3.1 is running, it writes a log that describes in detail what is going on in 
the background. This is indispensable for tracking down software issues and making 
ViewletQuiz3.1 as bug-free as possible. In the Logging tab, you can set program 
defaults for how ViewletQuiz3.1 handles logging reports and files. 
 
Output
In the Output area of the Logging tab (Preferences window), you can set default options 
for the reporting of information in the Output tab, which can be viewed by selecting View 
> Output from the Menu bar.  
 
To select Output report options: 

 In the Preferences window, select the Logging tab. 
In the Output area, select an option from the Report list. These include: 

o Display Errors Only 
o Display Errors and Information 
o Display All Messages 

 

 
 
 

To clear the information in the Output tab: 
 In the Preferences window, select the Logging tab. 
 In the Output area, click the Clear Output Window button. 

 
 
Log File
In the Log File area of the Logging tab (Preferences window), you can set default 
options for the size of the logging file and the location where ViewletQuiz3.1 will save the 
file. 
 
To enable the Logging feature for ViewletQuiz3.1: 

 In the Preferences window, select the Logging tab. 
 In the Log File area, select the Enabled option. This will allow ViewletQuiz3.1 to 

create a record of information to help Qarbon find and correct program errors. 
 
To set the log report’s maximum file size: 

 In the Preferences window, select the Logging tab. 
 In the Log File area, type a number in the Size Limit field. This will be the 

maximum size (in KB) allowable for the log file. 
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To clear the log file: 

 In the Preferences window, select the Logging tab. 
 In the Log File area, click the Clear Log File button. 

 
To set the default location where the log file will be saved: 

 In the Preferences window, select the Logging tab. 
 In the Log File area, type the path to where you want log files to be saved. Or, 

click the “yellow folder” next to the File field. 
 A Select Log File window displays. Browse to locate and select a new save 

location for the log file. 
 Click Open to apply and to return to the Preferences window. 

 

The Backup Tab 
 

 
 
The Backup tab allows you to set program preferences for creating backup files while 
working on your Viewlet project.  
 
Backup Files on Save
When saving your project, ViewletQuiz3.1 can create and update a backup file. This file 
can be used to restore a corrupted project from the last “known” good save. 
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To enable ViewletQuiz3.1 to create a backup project file: 

 In the Preferences window, select the Backup tab. 
 In the Backup Files on Save area, select the Enable - .BAK appended 

extension option. 
 
 
ViewletQuiz3.1 creates backup files that end in “.vie.BAK”. To restore a project from a 
backup file, first rename the original project file’s extension to something like “.vieOLD”. 
Then, simply remove the “.BAK” extension from the backup file so that the file ends in 
“.vie”. It will become the new project file, which can be opened in ViewletQuiz3.1. 
 
 
To create backup files automatically as you work on the project: 

 In the Preferences window, select the Backup tab. 
 In the Backup Files on Save area, select the Backup Files on Automatic Save 

option. 
 
To save the backup files in the same folder where the original project file is saved: 

 In the Preferences window, select the Backup tab. 
 In the Backup Files on Save area, select the Store backups in local folder 

option. 
 
To select a location to save the backup file in (other than in the same folder as the 
original project file): 

 In the Preferences window, select the Backup tab. 
 Select the Store backups in common folder option. 
 Type the path where you want the backup file saved, or click the “yellow folder” 

button. In the Select Folder window, select a folder and click Open to save the 
new backup file location. 

 
Automatic Save
ViewletQuiz3.1 can create automatic backup files while you are working on your project. 
 
To enable ViewletQuiz3.1 to create automatic backup files and to set the automatic save 
intervals while working on your project: 

 In the Preferences window, select the Backup tab. 
 In the Automatic Save area, select the Enable Automatic Save option.  

o Enter a number in the field provided for when the project is automatically 
saved. 
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The Advanced Tab 
 

 
 
The Advanced tab displays the current virtual memory usage settings allowable when 
ViewletQuiz3.1 is in use. 
 
To view the current Java settings for ViewletQuiz3.1: 

 In the Preferences window, select the Advanced tab. 
 In the Java area, review the settings for initial and maximum memory allocations. 

 
 
To change the memory settings allowable for ViewletQuiz3.1: 

 In the Preferences window, select the Advanced tab. 
 In the Java area, click the Change Java Settings button. A Java Preferences 

window displays. 
 

ViewletQuiz3.1 User Manual Page 21 March 2009 



 
 
 

 
 

 In the Memory area (Java Preferences window): 
o Enter a number for the Initial memory to be used by ViewletQuiz3.1 in the 

field provided. 
o Enter a number for Maximum memory allowable in the field provided. 

 
 In the VM Options area (Java Preferences window), enter additional Virtual 

Memory options as needed. 
 

 Click OK to save the information and to close the Java Preferences window. 
 
Once you’ve set all your program preferences, click OK to save the settings and to close 
the Preferences window. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Creating a New Project Basics 
ViewletQuiz3.1’s foundation is its quizzing and surveying capability, but it actually offers 
three different project types. The new project types include: 
 

 Quiz Project: Use this new project type to create a project of scored slides to 
test user, or create survey questions to gather information from your user base. 
 

 Image Project: Create a presentation using one or more images (supported 
images: jpg, bmp, png, gif and tif). 
 

 Blank Project: Start from scratch by creating a project containing one or more 
blank slides. 

 

 
 
Each of the five new project types is covered in detail later in this user manual.  
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New Project First Steps 
When creating your new project, the first few steps are common to all new projects. This 
chapter focuses on the “first steps” all authors will need to take when creating new 
projects. 
 
Step 1: Select a New Project Type: 
The first step when creating any new project is to decide what type of project you will be 
creating. As mentioned earlier in this chapter, there are three different new project types 
to choose from in ViewletQuiz3.1. 
 

 Select File > New from the Menu bar. Or, click the New Project link (from the 
Start View), or click the New button from the Main Toolbar. 
 

 The Create New Project window displays. Select a new project type from the list 
on the left side of the window by clicking it to highlight it.  

 
Step 2: Select the New Project’s Slide Size: 
Once you’ve select a new project type, the second step is to determine the size (width 
and height) for all the slides in your project. There are two slide size options available for 
all new project types: 
 

 Custom: Set a custom width and height. 
 Standards: Select from a list of standard resolutions, or create a new “standard” 

to add to the available list. 
 
 
When selecting a slide size for your project, remember, this is also going to be the size 
that the Viewlet will be played back at when your audience views it. So, if a viewer has to 
scroll to view parts of the Viewlet that are “off-screen” then you may need to use a smaller 
size for your Viewlet. 
 
To select a slide size for your new project: 
 

 In the Create New Project window, make sure you’ve selected the desired New 
Project Type. 
 

 In the Slide Size area, select an option from the list of available slide sizes. 
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Working with the Various Slide Size Options 
Each of the various slide size options have some additional selections, depending on 
which side size you choose. Following are instructions for working with each of the 
available slide size options. 
 

 Custom: Select this option to create a custom project size. 
 

 
 

o Enter a number in the Width field. 
o Enter a number in the Height field. 

 
 

 Standards: Select this option to: 
 

 
  
 

o Create a project size based on a “standard” (monitor) resolution: 
 Select a preset standard resolution for your project size from the 

available list. 
 

o Create a “new” Standard: 
 Select a preset Standard from the list. 

 Click the Add Standard    button. The Standard Resolution 
window displays. 
 

 Enter a name for the new Standard in the field provided. 
 Enter a Width in the field provided. 
 Enter a Height in the field provided. 
 Click OK to save the settings and to close the Standard 

Resolution window. 
 

ViewletQuiz3.1 User Manual Page 25 March 2009 



 
 
 

 
 

o Modify an existing Standard: 
 Select a Standard from the list. 

 Click the Modify Standard   button. The Standard Resolution 
window displays. 

 Make your edits as needed and click OK to save the settings and 
to close the window. 
 

o Delete an existing Standard: 
 Select the Standard you want to remove from the list. 

 Click the Delete Standard  button. A Delete Standard warning 
window displays. 
 

 
 

 Click Yes to confirm the deletion. Click No to cancel the deletion. 
  

 
 
Step 3: Make the rest of your selections in the Create New Project window: 
After you complete the first two steps for creating a new project, the rest of the steps will 
differ depending on what you selected for your new project type. Please refer to the 
specific chapter for more information on creating a new project based on the type of new 
project you are creating. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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 Quiz Project 
(New in ViewletQuiz3.1) 
 
New in ViewletQuiz3.1, the Quiz Project now combines all of the powerful features of the 
old Quiz Projects and Survey Projects (in previous versions) into one new enhanced and 
redesigned Quiz Project type. The new Quiz Project type allows you to integrate scored 
slides and simple survey question slides into a single Viewlet project. Or, if you prefer, 
use the new Quiz Project to create an entire quiz project (for testing purposes) or an 
entire survey project (for gathering information from a user base). 
 
This chapter explains the steps for creating a new Quiz Project (with scored and/or non-
scored question types). It also provides an overview of the various question types 
available for your new Quiz Project. 
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1. Select the Project Type and Slide Size 
 Select File > New from the menu option. Or, in Start View, click the New Project 

link, or click the New button from the Main Toolbar. 
 

 The Create New Project window displays. Select Quiz Project from the New 
Project list. Additional options for creating a new Quiz Project will display in this 
window. 
 

 In the Slide Size area of the Create New Project window, select a width and 
height for your Viewlet project. 

 
For more information on selecting a New Project Type or selecting a Slide Size for your 
new Viewlet project, please refer to the Creating a New Project Basics chapter. 
 
 

2. Review Question Types 
There are 11 common question types available for your Quiz Project. These question 
types can be scored or not, depending upon how you want to use them. The option to 
set a question type as a “quiz question” (scored) or a “survey question” (not scored) is 
covered later in this chapter. For now, let’s take a look at each of these question types. 
 

Short Answer – Fill in the Blank 
This question type requires the user to fill in the blank with a single answer. 
 

 
 

Short Answer – Selection from List 
This question type requires the user to select a single answer from a list. 
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Short Answer – Rating 
This question type requires the user to select a single rating from a given scale. 
 

 
 

Short Answer – Essay 
This question type allows the user to type in one or more words, sentences or 
paragraphs (essay style) to respond. 
 

 
 

Multiple Choice – Single Answer 
This question type requires the user to select a single answer from a list with two or 
more choices. 
 

 
 

Multiple Choice – Multiple Answers 
This question type requires the user to select a single or multiple answers from a list with 
two or more choices. 
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Multiple Choice – Fill in the Blanks 
This question type requires the user to type in a response in one or more “fill in the 
blank” entry fields. 
 

 
 

Multiple Choice – Selection from Lists 
This question type requires the user to select an answer from one or more lists. 
 

  
 

Multiple Choice – Rating 
This question type requires the user to select one or more ratings from a single or 
multiple rating scales. 
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Multiple Choice – True/False 
This question type requires the user to select an answer from one of only two possible 
choices. 
 

 
 

Likert Scale 
This question type requires the user to select an answer based on their specific level of 
agreement to a specific statement. 
 

 
 
 
Many of these 11 question types can be used in quizzes or in surveys; the choice is up 
to you. 
 
 
A quiz requires a correct response (and is typically scored), whereas a survey does not 
require a correct response (and is not scored). 
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3. Select Quiz Questions 
Make sure before you begin adding questions for your Quiz Project that you review the 
previous section so that you understand the different question types available for your 
project. This will help you determine what questions will work best for you. Once you feel 
comfortable with the various question types, you are ready to start building a list of 
questions for your project. 
 
To create a new question for your project: 

 In the Quiz Questions area (Create New Project window), click the Add  
button. 
 

 The Question window displays. Click on a question in the Question Type list to 
select it. 
 

 
 

 Type a question in the field provided. 
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 In the Scoring Mode area, select either Quiz or Survey. 
 

 
 

 
If you want to quiz a user, but do NOT want to score the questions, select “Quiz: Scored – 
Requires the user to provide a correct answer” for the “Scoring Mode”. Then, when you 
edit your project, in the “Score” window, set the “Points” value to “zero”. This way, the 
user will be required to answer correctly, but no score will be applied. 
 
 

 Click OK to apply and to close the Question window. The new question will 
display in the Quiz Questions list. 
 

 Repeat these steps for each additional question you want to create for your 
project. 
 

 
 

 
To edit a question in the list: 
 

 Select the desired question in the list. 
 

 Click the Modify  button. 
 

 Make your edits in the Question window that displays. 
 

 Click OK to apply the changes and to close the Question window. 
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To move a question up or down in the list: 
 

 Select the desired question in the list. 
 

 Click the Move Up  button to move the question up in the list. Repeat this 
step to continue moving the selected question up in the list. 
 

 Click the Move Down  button to move the question down in the list. Repeat 
this step to continue moving the selected question down in the list. 

 
 
The position of questions in the list determines the order in which they will appear in the 
project. For example, the question at the top of the list will become slide 1 in the project, 
the second from the top will become slide 2 and so on. You can reorganize your slides 
once your project is created, but to save time, organize the list of questions as needed 
BEFORE creating your new Quiz Project. 
 
 
To remove a question from the list: 
 

 Select the desired question in the list. 
 

 Click the Delete  button. This will remove the selected question from the 
list. 

 
Be careful when deleting questions from the list. Once you delete them, you cannot 
“Undo” the deletion. Once deleted, the question must be recreated if you need to add it 
back to the list. 
 
 

4. Convert Questions to Slides 
Here are the last steps to perform to create your new Quiz Project: 
 

 In the Slide Size area, make sure the slide size you selected for your new project 
is the one you actually want to use. Though the slide size can be change after 
creating the project, it’s easier to select the proper size right at the beginning. 
 

 In the Quiz Questions area: 
 

o Review the list of questions and make sure they are in the order you want 
them to be when your new project is created. 
 

o Modify any of the questions as needed. 
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o Delete any extra questions from the list so that unnecessary slides are 
not created. 

 
 Once all of your selections are made and questions created, click OK. This will 

converts the questions in the list to slides. Once this operation is complete, your 
project will display, ready for editing. 

 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Image Project 
ViewletQuiz3.1 allows you to create a new project from one or more images on your 
system or from an available storage device. You can use images of different file formats 
and of varying sizes, combining them all into a single, standard size Viewlet project.  
 
Imported images are embedded on slides (one image per slide) as background frames. 
This chapter highlights the steps for creating a new Image Project. 
 

1. Select the Project Type and Slide Size 
 Select File > New from the menu option. Or, in Start View, click the New Project 

link, or click the New button from the Main Toolbar. 
 

 The Create New Project window displays. Select Image Project from the New 
Project list. Additional options for creating a new image project will display in this 
window. 
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 In the Slide Size area of the Create New Project window, select a width and 
height for your Viewlet project. 

 
For more information on selecting a New Project Type or selecting a Slide Size for your 
new Viewlet project, please refer to the Creating a New Project Basics chapter. 
 

2. Select Images 
Once the project type and slide size are selected for your new project, the next step is to 
select the image or images that will make up your new Image Project. Here’s a list of the 
various formats supported by ViewletQuiz3.1: 
 

 GIF: Graphics Interchange Format 
 JPG, JPEG: Joint Photographic Experts Group 
 PNG: Portable Network Graphics 
 BMP: Bitmap 
 TIF, TIFF: Tagged Image File Format 

 
Animated GIF images are not supported in ViewletQuiz3.1. If you import an animated GIF 
image into a project, it will display as a “static” image, showing the image’s first frame 
only. 

 
To select images for your new project: 
 

 In the Select Images area, click the Add button to search for image files. 
 

 
 

 In the Select Images File window that displays, select the files you want to 
import. 
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To select multiple image files, hold down the “Shift” key and click on the first and last file 
in a sequence to select all the files in the sequence, or hold down the “Ctrl” as you click to 
select multiple, non-adjacent files 
 
 

 After selecting the image files, click Open. Depending on the number and size of 
the image files selected, you may see a progress bar display on the screen 
indicating the status of the image files being imported into the Create New 
Project window. 
 

 
 

3. Preview and Select “Pre-Import” Image Options 
In the Select Images area (Create New Project window), the newly selected images 
display in a list. Before importing these images into a new project, you can preview each 
image, select its scaling option for the slide, change its position on the list and more. 
Let’s take a look at each of these options. 
 
To preview an image in the preview panel: 
 

 Click on the image in the list that you want to preview. 
 The selected image displays in the preview panel to the “right” of the list. While 

the image is displayed in the preview panel: 
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o Click the Rotate Left   button to rotate the image to the left. 
 

o Click the Rotate Right   button to rotate the image to the right. 
 
 
If you rotate the image prior to importing it into a new project, this is the “orientation” that 
will be used when it is embedded as a background frame on its applicable slide. 
 
 

o Below the “rotate buttons” view the selected image’s file Size and 
Dimensions. 

 
 
To add a new image to the list: 
 

 Click the Add  button. 
 

 In the Select Image Files window that displays, browse for and select the image 
files you want to import. 
 

 Click Open.  The newly selected images will be added at the bottom of the list. 
 
 
To move an image up or down in the list: 
 

 Select the desired image. 
 

 Click the Move Up  button. Each time you click this button, it will move the 
selected image one position “up” in the list. 
 

 Click the Move Down  button. Each time you click this button, it will move 
the selected image one position “down” in the list. 

 
 
The position of the images in the list determines their “slide” position in the project. The 
image at the “top” of the list will be converted to “slide 1”, the second from the top will 
become “slide 2” and so on down the list. 
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To remove an image from the list: 
 

 Select the desired image. 
 

 Click the Delete  button. This will remove the image from the list only. It will 
NOT delete the original image file. 

 
 
To modify the “size” of the image prior to importing it into a project: 
 

 Select the desired image from the list. 
 

 Preview the Dimensions of the image below the “rotation buttons”. If the image 
width and height is: 
 

o Larger than the project’s slide size, you don’t need to do anything. The 
image will fill the entire background frame of the slide. 
 

o Smaller than the project’s slide size: 
 

 
 
-Click the check box in the Stretch column next to the desired image. This 
will scale (stretch) the image to fill the slide proportionally. What this 
means is that it will scale it to “best fit” the slide, so the image may not fill 
the entire slide. 
 
-Deselect the check box in the Stretch column next to the desired image. 
The image will remain its original size and be embedded as the 
background frame in the middle of the slide. 
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4. Convert Images Files to Slides 
Here are the last steps to perform in order to create your new Image Project: 
 

 In the Slide Size area, make sure the slide size you selected for your new project 
is the one you actually want to use. Though the slide size can be change after 
creating the project, it’s easier to select the proper size right at the beginning. 
 

 In the Select Images area: 
 

o Review the images list and make sure you have all the images you want 
listed. 
 

o Make sure the images are listed in the order you want the slides to be 
created. Though you can rearrange slides once the project is created, it 
will save you a lot of work to list them in desired order right at the start. 
 

o Rotate any images as needed. 
 

o Select the check box in the Stretch column next to any images you want 
to “stretch” to fit the slide (only applicable to images smaller then the 
project’s slide size). 
 

o Delete any images you do NOT want to include in your new project. 
 

 Once all your selections are complete, click OK to convert the images to slide 
background frames in your new Image Project. 
 

If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Blank Project 
ViewletQuiz3.1 offers you the option of creating a new Blank Project containing one or 
more blank slides. This new project type is perfect for those not sure of what new project 
type to use or for those wanting to create a new project from scratch using a blank 
template. 
 

1. Select the Project Type and Slide Size 
 Select File > New from the menu option. Or, in Start View, click the New Project 

link, or click the New button from the Main Toolbar.  
 

 The Create New Project window displays. Select Blank Project from the New 
Project list. Additional options for creating a new Blank project will display in this 
window. 

 

 
 

 In the Slide Size area of the Create New Project window, select a width and 
height for your Viewlet project. 
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For more information on selecting a New Project Type or selecting a Slide Size for your 
new Viewlet project, please refer to the Creating a New Project Basics chapter. 
 

2. Select the Number of Slides 
Once you have set the options for the size of the slides for your new Blank Project, the 
next step is to decide the number of slides you would like to create for your new project. 
 

 In the Slide Count area, enter the number of slides you want to create for your 
new project in the field provided. 
 

o Click the Up Arrow  button to increase the number of slides. 
o Click the Down Arrow  button to decrease the number of slides. 

 
You may select from 1 to 999 slides for your new Blank Project. 
 
 
 

3. Create Blank Slides 
Here are the last steps to perform to create your new Blank Project: 
 

 In the Slide Size area, make sure the slide size you selected for your new project 
is the one you actually want to use. Though the slide size can be change after 
creating the project, it’s easier to select the proper size right at the beginning. 
 

 In the Slide Count area, make sure that the number you entered is the actual 
number of slides you want to initially use for the number of slides in your new 
Blank Project. 
 

 Click OK. The slides for your new project will display in ViewletQuiz3.1, ready for 
editing. 

 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Workspace Features and Tab Views 
While working on a project in ViewletQuiz3.1, there are various “workspace” features 
and views available to help you optimize your Viewlet authoring tasks. This chapter 
provides a look at: 
 

 The View Menu – At a Glance 
 Organizing Tab Views and Workspace Areas 

 

The View Menu – At a Glance 
 

 
 
The View menu is divided into three main sections, with selections for use while working 
in your project. These include: 
 

 Slide Zoom: This section contains various slide zoom options to use while 
working on your project, including Zoom In, Zoom Out, Fit to Slide and various 
percentage zooms. 
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 Miscellaneous Tools: This section contains selections to enable / disable tools 
such as: 
 

o ToolTips: Displays a “hint” near the button the cursor hovers over. 
  

 
 
 

o Spelling Mistakes: Displays a “red underline” under words that are not 
recognized by the dictionary. 
 

 
 

o Event Icons: Displays a “lightning bolt” over objects that have an “event” 
attached to them. 
 

 
 

o Attached Sound Icons: Displays a “speaker” near objects that have a 
sound file attached. 
 

 
 
 

o 
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PauseZone Icons: Displays a “red icon” in the bottom right of a slide that 
contains a Pause Zone. This “red icon” will not display in the published 
Viewlet. 
 

 
 

o Timing Links: Displays a link connecting two or more objects along the 
Timeline. 
 

 
 

o Status Bar: Displays at the bottom of the program window and displays 
various information about the project. 
 

 
 
 

 Tab Views: This section contains options called “Tab Views”. Each view can be 
displayed or hidden as desired and are used for specific operations. The list of 
Tab Views include: 
 

o Browser 
o Thumbnails 
o Stylesheets 
o Output 
o Timeline 
o Slide Notes 

 
Each of these Tab Views are discussed later in this manual, each in their own 
respective chapter. 
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Organizing Tab Views and Workspace Areas 
The project workspace area, by default, displays selected Tab Views to the left and 
below the slide edit area. The workspace can be reorganized as desired based on your 
authoring needs. 
 
To display / hide a Tab View from the View Menu: 

 Select View from the Menu bar. 
 To display a Tab View, select it from the list. When selected, a checkmark will 

display next to it. 
 To hide a Tab View, deselect it from the list to remove the checkmark next to it.  

 
By default, when first selected, the “Browser”, “Thumbnails” and “Stylesheets” Tab Views 
display to the left of the slide edit area. The “Output”, “Timeline” and “Slide Notes” Tab 
Views display below the slide edit area. 
 
 
Each Tab View contains buttons to expand or minimize / maximize the tab(s): 

 Select the Expand  button to expand the tab to full view. 
 Select the Minimize  button to minimize all active tabs. 
 Select the Maximize  button to restore all active tabs to their previous sizes. 
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To move between active Tab Views: 

 If multiple tabs are displayed, only one tab can be in view at a given time. Click 
on the tab you want to work on to bring it to the front of the active tabs. 

 Repeat this action to move between tabs. 
 
 
To close (hide) an active Tab View: 

 Select the desired tab to bring it to the front of the tabs. 
 Click the “X”    located at the right edge of the selected tab. This will close 

(hide) the Tab View, which must be reselected from the View menu to be 
displayed again. 

 
Instead of closing (hiding) a Tab View, click the “Minimize” button to neatly collapse it to 
the side (or bottom) of the workspace area. This way, it is out of the way, but can be easily 
accessed again when needed while working on the project. 
 
To move a Tab View from its default position: 

 Point your left mouse button over the desired Tab View. 
 Hold down your left mouse button and drag the Tab to the bottom or “opposite 

side” of the project workspace area. 
 When the area to where you are dragging the Tab View is surrounded by a 

“dotted rectangle”, let go of the left mouse button to drop it into place. 
 
If you move a Tab View to a new location on the screen, if you then close and reopen it, 
the Tab View will display in its last “remembered” location on the screen. 
 
 
To resize the “window area” of a Tab View: 

 Point your cursor over the right / left / top edge (whichever is applicable) until the 
cursor shape changes to a double arrow  shape.  

 Hold down the left mouse button and drag the edge of the Tab View window to 
resize it. 

 Let go of the left mouse button when done. 

 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Slide Edit Area and Zoom Tools 
In ViewletQuiz3.1, when a project is open, the workspace area consists of various 
toolbars, Tab Views and the traditional “Slide Edit” area. The Slide Edit area is where 
you directly add objects to a slide and edit them. This is also the areas where you will 
spend a majority of your time while working on your Viewlet project. 
 
As discussed in the previous chapter, when selected, Tab Views display (by default) to 
the left and below the Slide Edit area. These tabs can be minimized, repositioned or 
closed to allow more “working real estate” on the slide. When a Tab View is “maximized” 
the Slide Edit area is hidden from view until the active tab is resized, minimized or 
maximized. 
 

Zoom Tools 
While working on a slide, there may be times you want to zoom in or out on the slide. 
This can be done using the options from the View Menu or by clicking any of three 
“zoom” buttons along the Main Toolbar. 
 
To change the slide zoom level from the View Menu: 

 Select the desired slide. 
 Select View > Slide Zoom from the Menu bar. 
 Select the desired slide zoom from the available options. 
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To change the slide zoom using the zoom buttons on the Main Toolbar: 
 

 Select the desired slide. 
 

 Click the Zoom In  button to zoom in on a slide. 
 

 Click the Zoom Out  button to zoom out on a slide. 
 

 Click the Fit Slide  button to zoom the slide to fit to the size of the current 
Slide Edit area. 

 
Keep clicking the Zoom In or the Zoom Out button to continue zooming in or zooming out 
as desired on the selected slide. 
 
Other tasks, such as adding message objects, images, shapes, etc. will vary depending 
on the content of each project. These additional tasks performed in the Slide Edit area 
are covered in further detail throughout this user manual. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Browser Tab 
The Browser Tab allows you to easily organize access and manage the resources that 
are available to you while you author your Viewlets. You can open projects, drag and 
drop images and movies, add publishing targets, delete files or folders, and view 
statistics of your Viewlets published on ViewletCentral. This chapter highlights some of 
the features of the Browser Tab. 
 
To display the Browser Tab: 

 Select View from the Menu bar. 
 Select Browser. 

 

 
 
 
The Browser Tab contains a “tab” at the top of its window area with the title of “Browser” 
indicating what tab it is. A toolbar displays below the tab’s title with buttons applicable to 
tools available in this tab. 
 
To add a new “publishing target” from the Browser Tab: 
 

 Select the Browser Tab to make it the active tab. 
 

 Click the Add  button. 
 

 The publishing target options display. Select one from the list: 
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 In the additional windows that display, follow the instructions for creating the new 
publishing target. Please see the chapter on Publishing a Viewlet for more 
information on adding new and working with publishing targets. 

 
Publishing targets can also be added during the publishing process. 
 
 
To remove files or folders from the Browser Tab’s list: 
 

 Select the desired file or folder from the Browser Tab’s list. 
 

 Click the Delete  button.  
 

 A Delete window will display. Click Yes to confirm the deletion. Click No to 
cancel the deletion. 

 
Pay careful attention to the information in the “Delete” window that displays after you click 
the “Delete” button. In some cases, the deletion will NOT delete the actual file or folder
it is a shortcut). In other cases, the deletion WILL delete the actual file or folder from not 
only the “Browser Tab” but also from your system. 

 (if 

 
 
To navigate through files and folders in the Browser Tab’s list: 
 

 Select the desired file or folder to highlight it. 
 

 Click the Up One Level  button to move up to the next level in the list. 
 

 If a folder is selected and it contains a plus  symbol to the left of it, click this 
plus symbol to expand the list of files and additional folders contained in the 
folder. 
 

 If a folder contains a minus  symbol to the left of it, click this minus symbol to 
collapse the files and folders contained in the folder. 
 

 Click on a desired file or folder at any time to quickly navigate through the list. 
 
 
To refresh a selected folder in the Browser Tab: 
 

 Select the desired folder in the Browser Tab list. 
 

 Click the Refresh the current folder  button to refresh the list of files and 
folder contained in the selected folder. 
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The document “check in / out” and “undo document check out”    buttons on 
the Browser Tab’s button toolbar are only available when working with the “Self Hosted” 
version of ViewletCentral. Contact sales@qarbon.com for more information. 
 
  
To change how files and folders are displayed in the Browser Tab: 
 

 Select the Browser Tab to make it the active tab. 
 

 Click the Views  button on the toolbar. 
 

 The available view selections display. Select the: 
 

 
 

o Icon View: Displays an icon next to the file and folder in the lower portion 
of the Browser Tab. 
 

o Details View: Displays the file or folder name, type, number of slides, last 
modification date and file size. 

 
 
To sort files and folders displayed in the Browser Tab using the “Details View”, simply 
click the applicable column header.   
 

 
 
Available sorts include “Name” or “Description” columns. 
 
 

o Thumbnail View: Displays the file as a thumbnail. 
 
 
For more information on working with other Tab View options (such as expanding, 
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on 
Workspace Features and Tab Views. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Thumbnails Tab 
The Thumbnails Tab, when selected, displays (by default) to the left side of the Slide 
Edit area. This tab allows you to view all the slides in the entire project. Various tasks 
can be performed while viewing thumbnails including: navigating through the slides in 
the project, moving the order of slides, adding features to one or more slides at the same 
time, copying and / or deleting slides, zooming in and out on thumbnails and more. This 
chapter highlights the main features available while working in the Thumbnails Tab. 
 

 
 
To display the Thumbnail Tab: 

 Select View from the Menu bar. 
 Select Thumbnails from the list. 

 
The Thumbnails Tab contains a “tab” at the top of its window area with the title of 
“Thumbnails” indicating what tab it is. A toolbar displays below the tab’s title with buttons 
for additional features while working with thumbnails. 
 
 
To increase or decrease the zoom level of the thumbnails in the Thumbnail Tab: 
 

 To increase the size of the thumbnails, click the Zoom In  button. 
 

 To decrease the size of the thumbnails, click the Zoom Out  button. 
 
 
To update the thumbnail of a recently edited slide: 
 

 Select the desired thumbnail(s) from the list. 
 

 Click the Refresh Thumbnail  button to refresh the selected thumbnail. 
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To updated all of the thumbnails in the project: 
 

 Select the Thumbnails Tab to make it the active tab. 
 

 Click the Refresh All Thumbnails  button to refresh all thumbnails in the 
project. 

 
 
To move one or more slides within the project: 
 

 Select the Thumbnails Tab to make it the active tab. 
 

 Select one or more slide thumbnails by clicking on them to select them. 
 

 Hold down your left mouse button and drag the selected thumbnail(s) to the 
desired location. 
 

 Let go of the left mouse button to drop the selected thumbnail(s) into place. 
 
If you have to move slides within your project, click the “Expand” button in the 
Thumbnails Tab. This will expand the number of thumbnails viewable in your project and 
make moving slides (thumbnails) a lot easier. 
 
 
To copy one or more slides in the Thumbnails Tab: 
 

 Select the desired thumbnail(s) from the list of thumbnails. 
 

 Press Ctrl + C to copy the thumbnail(s). You can also select Edit > Copy from 
the Menu bar. Or, select the thumbnail(s) and right click then select Copy from 
the shortcut menu. 
 

 Select the thumbnail you want to use as the insertion point. Pasted thumbnails 
will be inserted “after” the selected thumbnail. 
 

 Press Ctrl + V to paste the copied thumbnail(s). You can also select Edit > 
Paste from the Menu bar, or right click on the “insertion point” thumbnail then 
select Paste from the shortcut menu. 
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To delete one or more slides from the Thumbnails Tab: 
 

 Select the desired thumbnail(s) from the list. 
 

 Press the Delete key from the keyboard. Or, select Edit > Delete from the Menu 
bar. Or, right click on the selected thumbnail(s) and select Delete from the 
shortcut menu. 

 
For more information on working with other Tab View options (such as expanding, 
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on 
Workspace Features and Tab Views. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Stylesheets Tab 
The Stylesheets Tab allows you to set properties of multiple objects using a template 
called a “stylesheet”.  A stylesheet can be used for new and existing projects and 
updated as needed. You can set up one or more stylesheets and then choose to apply 
to the entire project or just to a current selection.  Here’s an alphabetical list of the 
“properties” that can be set up in stylesheets: 
 

 Background Color: Set the background color of a slide or message object. 
 

 
 

 Button Style: Standardize the “look” of clickable buttons used in a project from 
a library of button images. 
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 Check Box Style: Set the “look” of check box selection fields used in question 
slides from a library of check box images. 
 

 
 

 
 ComboBox Style: Set the “look” used for combobox lists used in question 

slides from a library of combobox images. 
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 Message Style: Set the style used for message objects from a list of available 
“pre-defined” styles. 
 

 
 

 
 Message Type: Standardize the style and type of message objects such as 

notes, balloons and text boxes. 
 

 
 

 

ViewletQuiz3.1 User Manual Page 59 March 2009 



 
 
 

 Radio Button Style: Set the “look” of radio buttons used with question slides 
from a library of radio button images. 
 

 
 

 Rating Style: Standardize the “look” of survey question rating objects used on 
question slides from a library of rating style images. 
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 Text Field Style: Set the “look” for text input fields on question slides from a 
library of text field images. 
 

 
 

 Text Properties: Set text attributes, including: font, size, style, alignment and 
color for message objects. 
 

 
 
 
To display the Stylesheets Tab: 
 

 Select View from the Menu bar. 
 

 Select Stylesheets from the list. 
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ViewletQuiz3.1 starts you off with a “default” stylesheet, which can be modified based on 
your needs. Each stylesheet contains objects whose properties can be standardized for 
use in your current or new projects. These stylesheet elements include: 
 

 Slide:  Used to set slide background color. 
 

 
 

 Balloon: Used to set balloon message style, background color and text 
properties.  
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 Note: Used to set note message style, background color and text properties. 
 

 
 

 Text Box: Used to set text properties (font, size, style, alignment, color) for text 
box. 
 

 
 

 Button: Used to set button style from a library of button images. 
 

 
 

 Correct Message: Used to set correct message type, background color and text 
properties (font, size, style, alignment, color). 
 

 
 

 
 Incomplete Message: Used to set incomplete message type, background color 

and text properties (font, size, style, alignment, color). 
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 Incorrect Message: Used to set incorrect message type, background color and 
text properties (font, size, style, alignment, color). 
 

 
 

 
 Question Text: Used to set question text message type, background color and 

text properties (font, size, style, alignment, color). 
 

 
 

 
 Question Choice Text: Used to set question choice text message type, 

background color and text properties (font, size, style, alignment, color). 
 

 
 

 
 Question Row Text: Used to set question row text message type, background 

color and text properties (font, size, style, alignment, color). 
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 Question Column Text: Used to set question column text message type, 
background color and text properties (font, size, style, alignment, color). 
 

 
 

 Question Component Style: Used to set question slide “input” component 
styles for text fields, radio buttons, check boxes, comboboxes, and ratings from a 
library of component images. 
 

 
 

 
The Stylesheets Tab contains a “tab” at the top of its window area with the title of 
“Stylesheets” indicating what tab it is. A toolbar displays below the tab’s title with buttons 
applicable to tools available in this tab. 
 
Create your own custom stylesheets to standardize the different objects within new and 
existing Viewlet projects. 
 
To create a new stylesheet: 
 

 Select the Stylesheets Tab to make it the active tab. 
 

 Click the New Stylesheet  button on the tab’s toolbar. 
 

 The Stylesheet window displays. 
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o Enter a title for the new stylesheet in the Name field. 
 

o Select the Password Protect option and enter a password in the field 
provided.  
 

 Click OK. The new stylesheet is added to the list of stylesheets. 
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To select a stylesheet from the list: 
 

 Select the Stylesheet Tab to make it the active tab. 
 

 Make a selection from the Stylesheet drop-down list. 
 

 
 

 
 
To modify a stylesheet’s properties: 
 

 Select the Stylesheet Tab to make it the active tab. 
 

 Make a selection from the Stylesheet list. 
 

 Click the Modify Stylesheet  button on the tab’s toolbar. 
 

 The Stylesheet window displays. Make edits as needed and click OK to save the 
changes to the stylesheet’s properties. 

 
 
To modify any of the elements (objects) in a stylesheet: 
 

 Select the Stylesheet Tab to make it the active tab. 
 

 Select the desired stylesheet from the list. 
 

 Click the arrow  button to the left of the object you want to modify. 
 

 The arrow changes position and points down  to reveal the object’s 
“properties’ that area available for editing. 
 

 Click on the icon next to each of the “properties” listed below the selected 
stylesheet’s object and follow the instructions in the window(s) that display to edit 
and save the changes. 
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To apply a stylesheet to the entire project: 
 

 Select the desired stylesheet in the Stylesheet Tab. 
 

 Click the Apply Stylesheet to Project  button on the tab’s toolbar. 
 

 The Apply Stylesheet to Project window displays. Read the information and click 
Yes to apply the stylesheet to the project. 
 

 
  

 
 
To apply a stylesheet’s element to an object: 
 

 Select the desired stylesheet in the Stylesheet Tab. 
 

 Select the object to which you want to apply a stylesheet element. 
 

 Select the stylesheet object you want to use to apply to a selected slide object by 
clicking the icon to the left of the element on the stylesheet. 
 

 Click the Apply Stylesheet to Selection  button. The selected object will 
immediately be updated, based on the stylesheet’s settings. 

 
 
To update a stylesheet’s element based on a selection: 
 

 Select the desired stylesheet in the Stylesheet Tab. 
 

 Select the desired object you want to use when updating the stylesheet element. 
 

 The applicable object on the stylesheet is automatically selected. Click the 

Update Stylesheet with Selection  button and the stylesheet is 
automatically updated. 
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To remove a stylesheet from the list: 
 

 Select the desired stylesheet in the Stylesheet Tab. 
 

 Click the Delete Stylesheet  button from the tab’s toolbar. 
 

 A Delete Stylesheet window displays. Read the information in the window and 
click Yes to confirm the deletion. 
 

 
 

 
For more information on working with other Tab View options (such as expanding, 
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on 
Workspace Features and Tab Views. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Output Tab 
The Output Tab displays, by default, below the Slide Edit area at the bottom of the 
program window. This tab contains a record of information that can help Qarbon find and 
correct ViewletQuiz3.1 programming errors. The information that is recorded in the 
Output Tab is determined by preferences set up for ViewletQuiz3.1. 
 

 
 
To set preferences for the report information recorded in the Output Tab: 
 

 Select Edit > Preferences from the Menu bar. 
 

 The Preferences window displays. Select the Logging tab. 
 

 In the Output area, from the Reports list, select: 
 

 
 

o Display Errors Only 
o Display Errors and Information 
o Display All Messages 

 
 
 
ViewletQuiz3.1 creates an external log file with the information in the Output Tab that can 
be sent to Qarbon when program issues arise. 
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To display the Output Tab: 
 

 Select View from the Menu bar. 
 

 Select Output from the list. 
 

 
 
 
 
To locate the log file containing the information also displayed in the Output Tab: 
 

 Select Edit > Preferences from the Menu bar. 
 

 The Preferences window displays. Select the Logging tab. 
 

 In the Log File area, the path to where the log file is saved displays in the File 

field. If you can’t see the entire path to the file, click the Browse  button next 
to the File field. 
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 The Select Log File window displays, showing the log file, which end with the 
extension .log. To view the full path to where the file is located, click the down 
arrow next to the Look In list to see the entire path to the folder containing this 
log file. 
 

 
 
 

The location of the log file containing the report information also displayed in the Output 
Tab is determined when setting up ViewletQuiz3.1 program preferences. 
 
 
To clear the report information displayed in the Output Tab: 
 

 Select Edit > Preferences from the Menu bar. 
 

 The Preferences window displays. Select the Logging tab. 
 

 In the Output area, click the Clear Output Window  button. 
 
 
For more information on working with other Tab View options (such as expanding, 
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on 
Workspace Features and Tab Views. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
 
 
 

ViewletQuiz3.1 User Manual Page 72 March 2009 



 
 
 

Timeline Tab 
The Timeline Tab displays, by default, below the Slide Edit area at the bottom of the 
program window. The Timeline allows you to manage the start and duration times of all 
elements on each slide in your project. In addition to working with objects directly on a 
slide, the Timeline provides more enhancement options for your project as you hide, 
view, modify, group, sort and lock / unlock layers in the Timeline. But, that’s not all.  
Using the Timeline’s playhead tool you can scrub the Timeline to view your project’s 
animations. You can also preview your project as it plays back, noting where actions 
occur along the Timeline, allowing you to “tweak” any part of the project exactly where it 
needs it.  
 
This chapter highlights the main features while working in the Timeline Tab. For more 
information on how ViewletQuiz3.1 handles other timing aspects of a project’s elements, 
please see the Object Timing chapter. 
 
To display the Timeline Tab: 

 Select View from the Menu bar. 
 Select Timeline from the list. 
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The Timeline Tab contains the following elements: 
 

Layers 
The left side of the Timeline displays all the objects on the slide. Each object exists in a 
layer. These layers are “stacked” with “higher object layers” overlapping objects in lower 
layers. You can hide / unhide layers without deleting them from the project. You can lock 
layers to prevent them from being editing. You can also change the starting / ending 
points of objects as they display along the Timeline as well as their entire duration. You 
can work on single or multiple layers and group layers into one as needed. 
 
To expand / collapse layers: 

 Select the Timeline Tab. 
 On the left side of the Timeline, click the right arrow  next to the slide title. 
 The arrow now points down  indicating the layers are now expanded. 
 To collapse the layers, click the down arrow again. 

 
 
To select a single layer: 

 Select the Timeline Tab. 
 Expand the list of layers, if needed. 
 Click on the desired layer to select it. 

 
 
To select multiple layers: 

 For adjacent layers: 
o Click on the first layer to highlight it. 
o Hold down the Shift key. 
o Click on the last layer in the series of adjacent layers. This will select the 

first and last layers as well as all the layers in between them. 
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 For non-adjacent layers: 
o Click on a layer to highlight it. 
o Hold down the Ctrl key while clicking on other layers to select them. 

 

 
 

 
Select multiple layers to temporarily group them to speed up various authoring tasks that 
can be applied to all of the selected layers at the same time. 
 
 
 
 
 
Arrange Layers via Drag and Drop Action (New in ViewletQuiz3.1) 

The ability to arrange layers by dragging them up or down in the stack is a new feature 
in ViewletQuiz3.1. In the previous versions, the only way to rearrange layers while 
working directly in the Timeline was via a right click action. 
 
To drag (rearrange) a single layer up or down the stack in the Timeline: 
 

 Single click on the layer to select it. 
 

 Once the layer is highlighted, single click it again and hold down the left mouse 
button. 
 

 While holding down the left mouse button, drag the layer up or down in the stack. 
While dragging the layer, its icon will display. 
 

 Let go of the left mouse button to drop it into its new location in the stack. 
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While dragging a single layer, its icon is displayed until you drop the layer into its new 
location in the stack. 
 
 
To drag (rearrange) multiple layers up or down the stack in the Timeline: 
 

 Click on the desired layers while using the Shift or the Ctrl key to select multiple 
adjacent or nonadjacent layers to highlight them. 
 

 Once the layers are highlighted, single click on them again and hold down the left 
mouse button. 
 

 While holding down the left mouse button, drag the multiple layers up or down in 
the stack. While dragging the layers, their icons will display. 
 

 Let go of the left mouse button to drop the multiple layers into their new location 
in the stack. 
 

 
 
 
While dragging multiple layers, their icons will displayed “stacked” until you drop the 
layers into their new location in the stack. 
 
 
 
To hide / unhide a layer: 
 

 To hide a layer, click the Visible  button to hide the layer. This changes the 
“open eye” to a “closed eye” indicating the layer is hidden. 
 

 To unhide a layer, click the Hidden  button to display the layer. This changes 
the “closed eye” to an “open eye” indicating the layer is visible. 
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To lock / unlock a layer: 
 

 To lock a layer, click the Unlocked  button to lock the layer. This changes the 
“open padlock” to a “closed padlock” indicating the layer is locked. 
 

 To unlock a layer, click the Locked  button to unlock the layer. This changes 
the “closed padlock” to an “open padlock” indicating the layer is unlocked. 

 
 
To prevent a layer from being edited, click the open padlock to close it to lock the layer. 
 
 
 
To move an object to a new frame in the Timeline while working in its layer: 
 

 Point your cursor over the object’s rectangle (which indicates its position and 
duration along the frame in the Timeline). 
 

 Hold down your left mouse button to select the object’s rectangle and drag. 
 

 Let go of the left mouse button to drop the object into its new location in the 
Timeline. 
 

 
 

 
To increase or decrease an object’s duration in the Timeline while working in its layer: 
 

 Point your cursor over the left or right edge of the object’s rectangle. 
 

 When the cursor changes to a double arrow    hold down the left mouse 
button and drag to change the size (duration) of the rectangle. 
 

 
 
 

 Once the rectangle indicates the desired duration (by its new size) on the 
Timeline, let go of the left mouse button. 
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 If a Timing Rule window displays, read the information and click OK to complete 
the operation. 
 

 
 

 
To delete a layer: 

 Click on the layer to select it. 
 Press the Delete key on the keyboard, or right click and select Delete from the 

shortcut menu. 
 
 
If you accidentally delete a layer, try pressing “Ctrl + Z” to undo the action (if it was your 
last action) to restore the layer. 
 
 
 

Timing Links 
Timing Links are links that connect two or more objects in the Timeline. The benefit of 
this feature is that as you edit an object’s timing in the Timeline, the linked objects 
update accordingly. 
 
Timing Links are automatically added to notes, balloons and cursors as they are inserted 
in the Timeline if the Maintain Timing Links option is selected (Project Properties 
window > Timing section).  
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For best practice purposes, by default, when notes are added to a slide, they display first 
in the Timeline. When balloons are added to a slide, they display after all of the notes. 
The reason for this is because it is assumed that a note introduces an action, a balloon 
points out the action. Of course, the position of any object can be change in the Timeline 
at any time. 
 
To automatically update Timing Links: 

 Open a Viewlet project. 
 Select Project > Project Properties from the Menu bar. 
 The Project Properties window displays. Select Timing from the list (on the left 

side of the window). 
 In the Timing Links area, select the Maintain Timing Links option. 

 

 
 
 
The default order that message objects are displayed in the Timeline are “Notes” first 
(Note #1, Note #2, etc.) followed by “Balloons” second (Balloon #1, Balloon #2) no matter 
when the new balloon or note is inserted o a slide. 
 
 
To add a Timing Link to two objects in the Timeline: 

 Select the first object in the Timeline. 
 Hold down the Ctrl key and click to select the second object in the Timeline. 

 
The order in which the objects are selected is the order in which the Timing Links will be 
added to the objects. 
 

 Click the Add Timing Links  button on the Timeline’s toolbar. 
 

 The Timing Links window displays. Select a Link Type from the list: 
 

 
 

o End to Start: Links end of first object to front of second object. 
o Start to End: Links front of first object to end of second object. 
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o Start to Start: Links front of first object to front of second object. 
o End to End: Links end of first object to end of second object. 

 
 
To remove a Timing Link: 
 

 Select an object on the Timeline. 
 

 Hold down the Ctrl key to when clicking to select the second object that shares a 
Timing Link with the first selected object. 
 

 Click the Remove Timing Links  button. 
 
 
 
To remove all Timing Links on a slide at the same time: 
 

 Select all of the objects on the slide. 
 

 Click the Remove Timing Links  button. 
 
 
There may be times when you will be prompted to change an object to “Manual Timing” to 
allow a Timing Link to be added. And, there are some objects, such as an object on the 
main Timeline and an object inside a Question Slide or Interactive Zone, which cannot be 
connected by Timing Links. 
 
 

Frames 
The Timeline Tab contains a “guide bar” known as a Frames Reference Guide. Along 
this guide bar, there are small “sections” known as frames Each frame is divided by 
tickmarks into 1/10 of second intervals. The main sections of the Timeline are divided 
into 1 second intervals.  Use this guide bar to position objects in the Timeline to 
determine when each will display and for how long when the project is played back. 
 

 
 
 
The Background Layer contains special “key frames” where a background frame is 
“painted” over the entire slide. This, in combination with the Background Layer’s “non-key 
frames” (which paint over a smaller, specific area on top of the key frame), can produce 
some dynamic and “attention-getting” effects.  If you are interested in learning more about 
this topic, “key frames” are covered in more detail in the “Background Frames” chapter. 
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To select a frame on the Timeline: 

 Click on the desired frame to select it. All objects that display in that frame in the 
Timeline will display on the slide. 

 
 
There is a phrase called “scrubbing the Timeline” that translates to dragging the 
playhead along the frames in the Timeline to preview actions that occur in the project. 
This is a useful “trick” to know if you want to manually preview specific sections of the 
project in the Timeline for intricate “tweaking”. 
 
 
To “scrub the Timeline” along specific frames within a single slide: 
 

 If the Current Slide   button is displayed on the Timeline Tab’s 

toolbar, click it so that it changes to All Slides   . This will change the 
Timeline view from “All Slides” to “Current Slide”. 
 

 Click on the frame where you want to begin. 
 

 A playhead displays on the selected frame with a line that intersects the 
Timeline below the playhead. Hold down your left mouse button and drag the 
playhead along the frames and watch the actions as you move it along the 
Timeline. 
 

 
 

 Once you reach the end of the frames contained for the current slide, you will no 
longer be able to move the playhead. If you want to “jump” to the next slide, click 
on a frame in the next slide to display the playhead and repeat these steps to 
scrub the Timeline again. 
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To “scrub the Timeline” along specific frames across multiple frames: 
 

 If the All Slides  button is displayed on the Timeline Tab’s toolbar, 

click it so that it changes to Current Slide    . This will change the 
Timeline view from “Current Slide” to “All Slides”. 
 

 Click on the frame where you want to begin. 
 

 A playhead displays on the selected frame with a line that intersects the 
Timeline below the playhead. Hold down your left mouse button and drag the 
playhead along the frames and watch the actions as you move it along the 
Timeline. 
 

 

Miscellaneous Timeline Features and Tools 
The Timeline Tab contains some status information and tools right above the Frames 
Reference Guide, which are useful when working in the Timeline. These include: 
 

 Slide Numbers: Indicates current slide and number of slides in the project. 
 

 
 

 Clock Feature: Indicates the duration of current slide in relation to overall project 
duration. 
 

 
 

 Slide Duration of Current Slide: Indicates the full playtime for the current slide 
displayed in the Timeline, which can be increased / decreased by clicking the 
up / down arrows. 
 

 
 

 Zoom: Signifies the current zoom of the Timeline. Use the up / down arrows to 
increase / decrease the zoom level of the Timeline. 
 

 
 

 Views: There are two different views that can be used while working in the 
Timeline: All Slides or Current Slide. When the All Slides button displays, the 
Timeline view is “current slide”. When the Current Slide button displays, the 
view is “all slides”. Click this button to toggle between these views. 
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 Player Buttons: The “VCR style” buttons are used to navigate to the first slide, 
previous slide, next slide and last slide of the project.  
 

 
 
 

 Preview Menu: Use this list to select from one of four project preview options. 
 

 
 
 

 Slide Titles: Along the top of the Frames Reference Guide are boxes containing 
the titles for each of the slides in the project. By default, the titles are the slide 
number. By dragging the edge of the “title box” you can increase / decrease the 
duration of the slide in the Timeline. 
 

 
 
 
For more information on working with other Tab View options (such as expanding, 
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on 
Workspace Features and Tab Views. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Object Timing 
Understanding how ViewletQuiz3.1 handles the “timing aspects” of objects is essential to 
being able to effectively work in the Timeline or while setting the timing of objects 
through the use of dialog windows. There are two important “timing topics” that each 
Viewlet Author should review before creating any project: Timing Commands and 
Timing Rules. 
 
Timing Commands 
Timing commands can be applied to a single or multiple objects on a slide. An object’s 
timing will determine when it will display on a slide (or on the Timeline), how long it will 
remain displayed on a slide (or on the Timeline) and, if multiple objects display on the 
same slide, what timing command elements they may have in common. 
 
An object’s timing can be adjusted in two places, in its Properties window and while 
working directly in the Timeline. 
 
To adjust a message object’s timing in the Timeline: 
 

 Point your cursor over the left or right edge of the object’s rectangle in the 
Timeline. 
 

 When the cursor changes to a double arrow    hold down the left mouse 
button and drag to change the size (duration) of the rectangle. 
 

 
 
 

 Once the rectangle indicates the desired duration (by its new size) on the 
Timeline, let go of the left mouse button. 
 

 If a Timing Rule window displays, read the information and click OK to complete 
the operation. 
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To change an object’s timing using the object’s Properties window: 
 

 Click the desired object (from either the slide or in the Timeline) to select it. 
 

 Click the object’s Properties  button from the Context Sensitive Toolbar. 
 

 The object’s Properties window displays. In the Timing area, there are options for 
setting the object’s timing (there’s an additional selection for message objects). 
These include: 
 

o Reading Speed: Used (by default) for notes, balloons, and text boxes to 
display the message object from its set Start Time until the automatically 
calculated reading speed is reached. 
 

 
 
 

To set the default “Reading Speed” for ViewletQuiz3.1, select “Project > Project 
Properties” from the Menu bar. In the “Project Properties” window that displays, select 
“Timing” from the list (left side of window). In the “Reading Speed” area, enter a number 
for the “words per minute” reading speed. This value will be used when the program 
automatically calculates a message object’s reading speed based on the amount of text it 
contains. 
 
 

o Manual Timing:  Used to manually set the Start Time and Duration (in 
seconds) for the object.  
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o Until End of Slide: Used to display the object from its set Start Time (in 
seconds) until the end of the slide’s “play” time.  
 

 
 

 Select a Timing option for the object from the list. 
 

 Enter a number for the Start Time (in seconds). This will be the amount of time 
the object will be delayed before displaying on the slide. 
 

 For Manual Timing, enter a number for the Duration. This is the amount of time 
the object will display. 
 

 Click OK to apply the timing settings and to close the object’s Properties window. 
 
 
To synchronize timing for multiple objects on a slide: 
 

 Select the objects you want to synchronize the time of by clicking on each one 
while simultaneously holding down the Ctrl key. 

 
Be careful when selecting multiple objects for timing synchronization. The first object 
selected will be used as the “key object” from which the other times are calculated. 
 
 

 The Synchronization Context Sensitive Toolbar displays. Click one of the buttons 
to synchronize the selected objects timing: 
 

  Same Start Time: Set the same start time for selected objects. 

  Same End Time: Sets the same end time for selected objects. 

  Same Start and End Time: Sets the same start and end time for all 
objects based on the key object. 

  Display Until Last End Time: Sets the end time for all objects to object’s 
whose end time is the last on the slide (of those selected). 

  Sequence Times: Sets the objects to display sequentially based on the 
selection order. 
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To adjust timing for a “Display Object” action: 
 

 Select the desired object (note, balloon, text box, shape, image, etc.). 
 

 Click the Events  button on the Context Sensitive Toolbar. 
 

 The object’s Events widow displays. Select one of the three tabs: 
 

 
 

o On Click: Set actions to occur when user clicks the object. 
o On Rollover: Set actions to occur when user rolls mouse over object. 
o On Rollout: Set actions to occur when user rolls mouse off object. 

 

 Click the Add  button. 
 

 The Action window displays. Select Display Object from the Action Type list. 
 

 Select an object from the Select an object on the slide to display list. 
 

 In the Duration area, select a timing command.  
 

 Click OK to close the Action window. 
 

 Click OK to close the object’s Events window. 
 
 

Timing Rules 
Each object has a Timing Rule associated with it. Timing Rules automatically control 
how the timing for that object associated with it is calculated. Timing Rules differ from 
“timing synchronization commands” in that synchronization commands make a one-time 
adjustment where as Timing Rules are applied globally. 
 
To understand Timing Rules better, let’s take a look at an example. A simple timing rule 
is “Reading Speed”, which insures that the duration of a message object is calculated 
from the number of words in a message object and the reading speed set in the Project 
Properties window. This rule is automatically and globally applied to all message objects, 
so that each note, balloon and text box displays only as long as calculated reading 
speed allows.  
 
To help standardize object timing, there are several Timing Rules available (each 
described in the previous “Timing Commands” section of this chapter): 
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 Manual: An object’s timing is calculated manually, meaning the user has full 
control over the start time and duration. 
 

 Reading Speed: Applies to message objects (notes, balloons, text boxes), the 
duration is calculated based on the reading speed set in the Project Properties 
window and the number of words in the message object. The start time for the 
message object is adjustable without affecting this rule. 
 

 Until End of Slide: An object displays from a user-defined start time until the 
end of the slide. The start time is adjustable without affecting this rule. 
 

 Display Object Action: Used for objects displayed due to an event which 
triggers the “Display Object” action. You can use any “available” Timing Rule for 
the object that is to be displayed. 

 
Each time you attempt to change an object’s timing, a “Timing Rule Change” window will 
display if you are “breaking the rules” for the Timing Rule currently associated with the 
object. Read the information in the window carefully before proceeding. 
 
  
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Slide Notes Tab 
The Slide Notes tab displays, by default, below the Slide Edit area. In this tab, you can 
add presenter notes, which can be printed out for you and your audience. The Slide 
Notes tab can also be used as a collaboration tool by adding editing notes (not part of 
the actual slide) when working with a team of authors on the same project. These notes 
can be displayed or hidden inside ViewletQuiz3.1 (and printed) as needed.  
 

 
 
 
Did you know that you can use Slide Notes in combination with ViewletQuiz3.1’s 
JavaScript function to add a computer simulated voice-over to your project on a slide-per-
slide basis? For more information, contact support@qarbon.com for more information on 
this advanced Viewlet authoring trick. 
 
 
 
To display the Slide Notes Tab: 

 Select View from the Menu bar. 
 Select Slide Notes from the list. 

 
 
To add text in the Slide Notes Tab: 

 Select the desired slide so that it displays in the Slide Edit area. 
 Select the Slide Notes Tab to make it the active tab. 
 Click inside the Slide Notes field and type text as needed. 
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To print Slide Notes with your slides: 
 

 Select File > Page Layout from the Menu bar. 
 

 The Page Layout window displays. In the Options area, select the Slide Notes 
option. 
 

 
 

 Click OK to save this option. Each time you print slides, the Slide Notes will be 
added below the image of each slide. 

 
For more information on working with other Tab View options (such as expanding, 
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on 
Workspace Features and Tab Views. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Messages 
ViewletQuiz3.1 allows you to add impact to your Viewlet projects with Messages. These 
Messages come in the form of notes, balloons and text boxes. The purpose of each 
Message object is ultimately determined by you, the Viewlet author, but here some ideas 
for ways they are commonly used in a Viewlet: 
 

 Note: A note is used to “introduce” a topic or action that is about to occur. It is 
also used in situations when you want to make sure the viewer takes notice of 
some important content such as special information, a tip or trick, or even a 
“warning” of some type. 

 
 Balloon: A balloon is used to “point out” an area of the screen or an action. For 

example, a balloon may contain text that discusses different areas of the screen 
while using its “pointer” to point at the area being discussed. Or, more commonly, 
a balloon may point at a button or text entry field with instructions for the viewer 
to “interact” with the Viewlet. 

 
 Text Boxes: A text box is used to “seamlessly blend” text into its background, 

whether it be the slide itself, a shape or an image or even other text. Text boxes 
are also used as the “question” box for quiz and survey question types. 

 
 

Multiple Message objects may be added to the same slide. By default, however, no matter 
what order you insert them on a slide, the notes are added first along the Timeline 
followed by balloons. 
 
 
Now that you know the three different Message types available in ViewletQuiz3.1, the 
next thing you should decide is the method you want to use when editing the text inside 
your Message object.  
 
To set the default message editing preference for ViewletQuiz3.1: 
 

 Select Edit > Preferences from the Menu bar. 
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 The Preferences window displays. Select the General tab. 
 

 In the Message Editing area, select an editing preference. 
 

 Click OK to close the Preferences window. 
 

Message Editing Methods 
There are two “message editing” methods available in ViewletQuiz3.1. You can decide 
the default method to use by selecting it when setting up program preferences. 
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Edit in Place  
This is the “classic” message editing method used in previous versions of 
ViewletQuiz3.1. This method allows you to edit text directly in the note, balloon, or text 
box (without opening a dialog window). It also allows you to change the Message objects 
attributes using various buttons on the object’s Context Sensitive Toolbar (when the 
object is selected and not in text editing mode). 
 
Message Editor (New in ViewletQuiz3.1) 
A new message editing method available in ViewletQuiz3.1 is the Message Editor. This 
editor window displays when you are in text edit mode. Inside the Message Editor 
window, you can use the: 
 

 
 
 

 Message Type  button to change the object’s style and type. 
 

 Background Color  button to change the object’s fill color. 
 

 Font list and Font Size list to change the text font type and size. 
 

 Italic  , Underline  , or Bold   button to change text attributes. 
 

 Text Color  button to change selected text color. 
 

 One of the alignment buttons to Left Align  , Center Align  , or Right 

Align  selected text. 
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 Hyperlink  button to turn selected text into a clickable hyperlink. 
 

 Text edit field to select text to edit or to select text to apply any of the available 
text attributes (font, font size, italic, bold, underline, color, alignment, hyperlink). 
 

 OK button to save edits in the dialog window. 
 

 Cancel button to exit the dialog window without saving any changes. 
 

 Apply button to apply changes without exiting the dialog window. 
 
 
To open the “Message Editor” from the Context Sensitive Toolbar or “right click” menu: 
 

 Select the Message object you want to edit by single clicking it to select it. 
 

 Click the Message Editor button on the Context Sensitive Toolbar, 
 

 
 
OR 
 

 Right click on the Message object and select Open in Message Editor from the 
shortcut menu.  
 

 
 

 The Message Editor window displays. Make edits as needed and click OK to 
save changes and to close the window. 
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While working with Message objects, you will find the process and options used during 
the “editing” operation will be basically the same for each object whether it is a note, 
balloon or text box. 
 
To insert a Message object on a slide: 
 

Note: 

 Click the  Insert Note  button on the Object Toolbar. 
 

 If you selected for “message editing”: 
 

o Edit in Place: A note object will display on the slide with a “blinking cursor” 
in side it. This indicates the note is ready for you to start typing in it. 
 

o Message Editor: The Message Editor window displays. Make your 
selections for the text using the available buttons (font, font size, etc.) and 
type your text in the “text edit” field. Click OK to save the information and 
the note will be inserted on the slide. 
 

Balloon: 

 Click the Insert Balloon   button on the Object Toolbar. 
 

 If you selected for “message editing”: 
 

o Edit in Place: A balloon object will display on the slide with a “blinking 
cursor” in side it. This indicates the balloon is ready for you to start typing 
in it. 
 

o Message Editor: The Message Editor window displays. Make your 
selections for the text using the available buttons (font, font size, etc.) and 
type your text in the “text edit” field. Click OK to save the information and 
the balloon will be inserted on the slide. 

 
Text Box: 

 Click the Insert Text Box  button on the Object Toolbar. 
 

 The cursor changes to a cross-hair  shape. Move the cursor over the slide 
and click where you want to “anchor” one corner of the text box. Hold down the 
left mouse button and draw the text box on the slide. 
 

 If you selected for “message editing”: 
 

o Edit in Place: A text box object (surrounding by a “bounding box” that 
looks like a “dotted rectangle” with gnodes (grab handles) for resizing the 
box) will display on the slide with a “blinking cursor” in side it. This 
indicates the text box is ready for you to start typing in it. 
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o Message Editor: The Message Editor window displays. Make your 
selections for the text using the available buttons (font, font size, etc.) and 
type your text in the “text edit” field. Click OK to save the information and 
the text box will be inserted on the slide. 

 
 
To exit “text edit mode” while using the “Edit in Place” method, simply click off the note, 
balloon or text box to deselect it. 
 
 
Message Styles and Type 
Once you insert a Message object on a slide, you can change its “style” and its “type” at 
any time without recreating it from scratch. The process for doing this is the same for all 
Message objects. 
 
To change a Message object’s style and / or type: 
 

Using “Edit in Place” message editing: 
 
 Single click the message object to select it. 

 

 Click the Message Type  button on the Context Sensitive Toolbar. 
 

 The Message Type window displays. Select: 
 

o A “message style” from the first list. 
 

 
 
 

o A “message type” from the second list. 
 

 
 

 Click OK to save and apply the selections. 
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Using “Message Editor” message editing: 
 
 Double click the Message object. 

 

 The Message Editor window displays. Click the Message Type  button. 
 

 The Message Type window displays. Select: 
 

o A “message style” from the first list. 
 

o A “message type” from the second list. 
 

 Click OK to save selections and to close the Message Type window. 
 

 Click OK to close the Message Editor window and to apply changes. 
 
 

Select a new message type in the Message Type window to change a Message object from 
a note to a balloon to a text box and so on as needed without recreating the Message 
object from scratch. 
 
 
Message Object’s Background Color 
You can change the background color of a note or balloon while the Message object is 
selected (using the “Edit in Place” message editing method) or from inside the Message 
Editor window. 
 
To edit a note or balloon object’s background color while using “Edit in Place”: 
 

 Single click the note or balloon to select it. 
 

 Click the Background Color  button on the Context Sensitive Toolbar. 
 

 The Background Color window displays. Move your cursor over the palette and 

when the cursor changes to a “pointing hand”  shape, click to select a color. 
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 Click OK to apply the selected color to the Message object. 
 
 
To edit a note or balloon object’s background color while using “Message Editor”: 
 

 Double click the note or balloon to open the Message Editor. 
 

 In the Message Editor window, click the Background Color   button. 
 

 The Background Color window displays. Move your cursor over the palette and 

when the cursor changes to a “pointing hand”  shape, click to select a color. 
 

 Click OK to save the selection and to close the Background Color window. 
 

 Click OK to close the Message Editor window and to apply the selected color. 
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Message Object Alignment Tools 
When the Message object is selected (not in text edit mode), three object “alignment” 
buttons display on the Context Sensitive Toolbar. These buttons can be used to align a 
selected Message object on the slide. 
 
To align a Message object on a slide: 
 

 Single click on the desired Message object. 
 

 Click the:  
 

o Center Horizontally   button to horizontally center the selected 
object on the slide. 
 

o Center Vertically  button to vertically center the selected object on 
the slide. 
 

o Center  button to center (both horizontally and vertically) the 
selected object on the slide. 
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Message Text Options 
While working with Message objects (notes, balloons, text boxes), you will want to 
customize the various attributes that can be applied to the textual content. Text options 
include: font, font size, attributes (italic, bold, underline), text color, text alignment within 
the Message object and hyperlink capability.  Each of these options is available while  
editing using: 
 

 Edit in Place: Double click the Message object so that a “blinking cursor” 
displays inside it. This indicates you are in “text edit” mode and a Context 
Sensitive Toolbar is available with various buttons for text editing options.  
 

 
 

 Message Editor: Double click the Message object to open the Message Editor 
window. The text option tools are available within this window (as shown in the 
image below). 
 

 
 
 
To edit text in a Message object: 
 

 Double click on the Message object. Depending on the “message editing” 
method used, either a Context Sensitive Toolbar (for “Edit in Place” message 
editing) or a Message Editor window (for “Message Editor” message editing) 
displays. 
 

 Highlight the text you want to edit (either in the Message object itself or within the 
text edit field in the Message Editor window). 
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You MUST highlight the text you want to edit BEFORE applying any changes. 
 

 Click the applicable option to make the desired text edit: 
 

o Font: Select a new font from the Font list. 
 

 
 

If the desired font does not display in the “Font” list, but it is a font available on your 
computer, scroll down to the bottom of the list and select the “Show All Fonts” option. 
 
 

o Font Size: Select a new text size from the Font Size list. 
 

 
 

o Italic: Click the Italic  button to set the selected text in italics. 
 

o Underline: Click the Underline  button to underline the selected 
text. 
 

o Bold: Click the Bold  button to bold the selected text. 
 

o Text Color: Click the Text Color  button. In the Text Color window, 
select a color by clicking on it and then click OK to close the window. 
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o Left Align: Click the Left Align  button to left align the text in the 
Message object. 
 

o Center Align: Click the Center Align  button to center the text in the 
Message object. 
 

o Right Align: Click the Right Align  button to right align the text in 
the Message object. 

 
 
You do NOT have to highlight text in order to apply an alignment option. However, you 
must apply an alignment option to each section of text separated by a “carriage return” 
(each time you hit the “Enter” key to start a new paragraph or line of text). 
 

o Hyperlink: Click the Hyperlink  button. In the Hyperlink window that 
displays, make your selections as required and click OK to close the 
window. 

 
See the chapter on “Hyperlinks” for more information on creating clickable text links. 
 

 To exit text edit mode while using the message editing option: 
 

o Edit in Place: Click off the Message object to deselect it. 
 

o Message Editor: Click OK to save the changes and to close the 
Message Editor window. 

 
  
 
Automatic Resize of Message Objects (New in ViewletQuiz3.1) 
Now you no longer have to worry about “manually” resizing your Message object after 
you edit text, let ViewletQuiz3.1 do it for you! There is now a new “auto resize” feature 
when enabled on the Message object’s Context Sensitive Toolbar will automatically 
resize a Message object as you edit the text within it. This feature can be turned on and 
off as needed. 
 
To enable “automatic” resizing of a Message object as you edit text: 
 

 Click on the Message object to load its Context Sensitive Toolbar. 
 

 Click the Automatically size message to fit when editing  button. 
 

 Double click to Message object to enter “text edit” mode. 
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 If you selected for “message editing”: 
 

o Edit in Place: As you edit text, the object automatically resize as you type 
directly in the Message object. 
 

o Message Editor: The Message Editor displays. Once you click Apply or 
OK to save the text edits, the Message object will be automatically 
resized. 

 
If enabled, you can quickly “turn off” the auto-resize Message object feature by clicking it 
to deselect it on the Context Sensitive Toolbar at any time while editing a Message object. 
 
 
To manually resize a Message object: 
 

 Single click on the Message object to select the object itself (not in text edit 
mode). A “bounding box” (dotted rectangle) will display around it. 
 

 
 

 Move your cursor over one of the gnodes (grab handles). When the cursor 
changes to a “double arrow” shape, hold down the left mouse button and drag to 
resize the Message object. 
 

 
 
If you manually resize a Message object, if enabled, the “auto-resize” Message object 
feature will be disabled for that Message object only until it is again selected. 
 
 

 Let go of the left mouse button to complete the resizing action. 
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To move a Message object on a slide: 
 

 Click the object to select it so that a “bounding box” (dotted rectangle) displays 
around it. 
 

 Point your cursor over the selected Message object. When the cursor changes to 

a “hand”  shape, hold down your left mouse button and drag the object to its 
new location on the slide. 
 

 
 

 Let go of the left mouse button to drop the object into place. 
 
 
 
To attach audio to a Message object: 
 

 Click the object to select it so that a “bounding box” (dotted rectangle) displays 
around it. 
 

 Click the applicable Attach Sound button on the Context Sensitive Toolbar. 
 

  Attach Sound to Note 
 

  Attach Sound to Balloon 
 

  Attach Sound to Text Box 
 

 In the Sound window that displays, insert or record a sound file. 
 

 Click OK to save the sound file and attach it to the Message object. 
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To remove a Message object from a slide: 
 

 Click on the Message object to select it. 
 

 Click the Delete  button on the Context Sensitive Toolbar. The selected 
object will be deleted. 

 
 
If you accidentally delete a Message object and this was the last action you performed, 
click the “Undo” button or press “Ctrl + Z” to undo the deletion. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Format Painter 
The Format Painter may be used to quickly change text properties in notes, balloons and 
text boxes. It can also be used to change properties of a shape object’s border (color, 
width) and fill color based on another shape.  
 

 
 
To use the Format Painter to apply text attributes from one message object to another: 

 Make your changes to text in your message object. 
 Click on the text (or click anywhere inside the text) that will be copied from. 
 Click the Format Painter. 
 Click on subsequent text objects to apply this formatting from the first selection. 
 Continue clicking on text on the current or any other slide to apply the formatting. 
 When you are finished, click the Format Painter to deselect it. 

 
 
To use the Format Painter to copy a shape’s attributes and apply them to other shapes: 

 Make your changes to the shape as desired and then make sure it is selected. 
 Click the Format Painter. 
 Click on subsequent shapes to apply the formatting. 
 When you are finished, click the Format Painter to deselect it. 

 
 
Use the Format Painter to quickly match the format of a selected object or shape across 
multiple slides. 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Dictionary, Spell Check, Search and Replace 
ViewletQuiz3.1 offers various tools to help you make sure that your content is accurate, 
typos are caught and corrected, and grammar rules are followed. These features 
include: 
 

 Dictionary: Set your dictionary to one of several languages. The dictionary 
helps you catch unwanted typos and allows you to build it for more complex 
content by adding custom words. 
 

 Spell Check: Enable the “Spelling Mistakes” option from the View menu to 
automatically check text in message objects against the selected dictionary. 
Incorrectly spelled words, or words not recognized by the dictionary, will be 
quickly identified by a red, squiggly underline. 
 

 Search and Replace: Use this tool to quickly search for and replace a specific 
word (or even a phrase) on a message by message basis or throughout the 
entire project. 

 
 
To set your dictionary and spell check preferences: 

 Select Edit > Preferences from the Menu bar. 
 Select the Spelling tab. 
 Select a language to use for the spell check dictionary from the list. 
 Select additional options for the spell check as needed. 

 
 
To enable or disable the Spell Check tool: 
 

 To enable the Spell Check tool, select View > Spelling Mistakes from the Menu 
bar. 
 

 
 

 When a word is incorrectly spelled or is not recognized by the selected 
dictionary, it will be designated with a “red squiggly underline”.  
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 To disable the spell check tool, select View from the Menu bar. 
 

 If the Spelling Mistakes option has a checkmark next to it, click it to remove the 
checkmark to deselect the tool. 

 
 
To correct a typo using the right click menu: 
 

 Click anywhere in the text where the typo appears (as indicated by the red 
squiggly underline). 
 

 Right click to display the shortcut menu. 
 

 At the bottom of the shortcut menu, select the appropriate option: 
 

 
 

o Replace: Select this option to display a list of suggested words to use to 
replace the “selected” incorrect text. 
 

o Replace All: Select this option to display a listed of suggested words to 
use to replace all instances of the “selected” incorrect text throughout the 
entire project.  
 

o Ignore All: Select this option to ignore all instances of the “selected” 
incorrect text throughout the project. 
 

o Learn: Select this option to add the “selected” incorrect text to the 
dictionary. 

 
 
To add custom words not recognized by the Spell Check tool to the dictionary, select the 
“Learn” option from the shortcut menu. 
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To use the Search and Replace tool: 
 

 Click the Search and Replace   button on the Main Toolbar. 
 

 The Search and Replace window displays. Two tabs are available: Search and 
Replace.  
 

 
 

 To search for a specific word or phrase:  
 

o Select the Search tab if it is not already selected by default. 
 

o In the Text field, type in the word or phrase you want to search for. 
 

o Select the Case Sensitive option to narrow results. 
 

 
 

o In the Direction area, select Forwards to search from this point in the 
project forwards, or select Backwards to search from this point in the 
object backwards.  
 

 
 

o In the Slides area, select: 
 
-Current to search the current slide. 
-From and enter a number in each of the fields provided to search from a 
specific slide to a specific slide based. 
-All to search all slides within the project. 
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o Click the Find Next   button to start the search operation. 
 

 
 To replace a specific word or phrase: 

 
o Select the Replace tab. 

 
o In the Text field, type in the word or phrase you want to search for. 

 
o In the Replace With field, type in the word or phrase you want to use as 

the replacement text. 
 

o Select the Case Sensitive option to narrow results. 
 

 
  

o In the Direction area, select Forwards to search from this point in the 
project forwards, or select Backwards to search from this point in the 
object backwards.  
 

 
 

o In the Slides area, select: 
 
-Current to search the current slide. 
-From and enter a number in each of the fields provided to search from a 
specific slide to a specific slide based. 
-All to search all slides within the project. 
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o Once all the information is entered / selected in the Replace tab, click the: 
 

-Replace All  to search for and replace all instances of the 
text with the text provided. 
 

-Replace  to replace the currently “selected” text found after 
clicking the Find Next button. 
 

-Find Next  button to find the next instance of the desired 
word or phrase entered in the Text field. 
 

 Once you are finished using the Search and Replace tool, click the red “x”  to 
close the window. Or, click Cancel to end the search and replace operation. 

 
 
While performing a Search and Replace operation, use the “Replace All” button to quickly 
replace a single word or phrase throughout the entire project with a single click action. 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Working with Slides 
ViewletQuiz3.1 projects are made up of slides, so it’s important to understand how to 
work with the most common slide features while building your project. This chapter 
introduces some of the most common features available while working with slides within 
your Viewlet project. 

Slide Types 
There are essentially three types of slides that you may insert into existing projects: 
 

 Question Slides 
 Image slides 
 Blank Slide 

 
 

 
 
 
 
You can insert new slides into existing projects by selecting “Insert” from the Menu bar. 
Or, right click on a slide and select “Insert” from the shortcut menu. Either way, once you 
select “Insert” you will see a list of available new slide options for your project. 
 
 
These slide types may seem familiar. This is because these slide types are also the 
same options that are available when creating new projects. 
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To insert Question Slides: 
 

 Select a thumbnail. The Question Slides will be inserted right after this slide. 
 

 Select Insert > Question Slides from the Menu bar. 
 

 In the Add Questions window, make your question selections as you would when 
creating a new quiz project. 
 

 
 

 Click OK to insert the new question slides into your project. 
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To insert Image Slides: 
 

 Select a thumbnail. The new image(s) will be embedded onto slides right after 
this slide. 
 

 Select Insert > Image Slides from the Menu bar. 
 

 Follow the instructions in the Select Images to Import window that displays for 
locating and selecting your image files. 
 

 
 

 Once your images are selected, click OK to insert the new image slides into your 
existing project. 

 
 
 
To insert a Blank Slide: 
 

 Select a thumbnail. The inserted slide will be inserted right after this slide. 
 

 Select Insert  > Blank Slide from the Menu bar. Repeat these steps to insert 
additional blank slides. 
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To insert duplicate slides quickly: 
 

 Click on a slide so that it displays in slide edit view. 
 

 Press Ctrl + D on your keyboard, or select Edit > Duplicate Slide from the Menu 
bar. 
 

 
 

 

Slide Properties 
Slide properties can be set for each slide. These properties include the slide name, 
duration and whether to include the slide in the table of contents (for viewing purposes). 
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To access slide properties: 
 

▪ Right click on a slide. 
 

▪ Select Slide Properties from the shortcut menu. Or, double click directly on the 
slide to open the Slide Properties widow. 

 
 
To edit slide properties: 
 

 Select a slide by clicking on it. 
 

 Click the Slide Properties  button on the Context Sensitive Toolbar. 
 

 In the Slide Properties window, edit the: 
 

 
 
 

o Name: This is the title of the slide displayed at the top of the slide while in 
Thumbnail View and along the timeline. 
 

o Duration: The amount of time the slide displays. 
 

o Options: Select this option if you want it included in the Table of Contents 
when viewed as a Flash file. 
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Slide Color 
Slide color is applied directly to the slide and can be changed on one or multiple slides. 
The slide color appears behind slide objects and embedded images. The color chooser 
remembers recent and custom color selections and has buttons for adding and deleting 
custom colors to make that functionality easier to use. 
 

 
 
 
To change slide color: 
 

 Select the slide or slides you want to work with. 
 

 Click the Background Color  button from the toolbar. 
 

 In the Background Color window, select a color. 
 

 Click OK to apply it to the selected slide or slides. 
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Slide Background Frame 
You can embed an image directly to a slide background. In fact, you can do this to one 
or multiple slides using the same image. In addition, images can be aligned in various 
ways on the slide or stretched as needed. 
 

 
 
To add a background image to a slide or slides: 
 

 Select the slide or slides you want to work with. 
 

 Right click and select Background Frames. 
 

 In the Background Frames window, click Load Image  button. 
 

 Locate an image file, select it and click Open. 
 

 Select a Layout option. 
 

 Click OK. 
 
 
In the “Background Frames” window, click “Show Preview” to view a preview of the 
selected background frame image. 
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To delete a background frame: 
 

 Right click a slide and select Background Frames. 
 

 In the Background Frames window, click the Remove Background  button. 
 

 Click OK. 
 
 

Moving Slides 
There are various ways to move slides with in a project. The easiest way to do it is while 
working with thumbnails. 
 
To move slides using drop and drag: 
 

 Make sure the Thumbnails tab is displayed. You can work in this view or while it 
is expanded in full view so that only thumbnails are displayed. 
 

 Select the slide (or slides) you want to move by clicking on them. 
 

 Hold down the left mouse button and drag the slide(s) to the new location and 
drop into place. 

 
 
To move slides using cut and paste: 
 

 Make sure the Thumbnails tab is displayed. 
 

 Select the slide you want to move. 
 

 Click the Cut  button on the toolbar. 
 

 Click on the slide where you want to insert the “cut” slide next to. 
 

 Click the Paste  button on the toolbar. 
 

 

Click the “Undo”  button to immediately undo cut and paste operations. 
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Deleting Slides 
You can remove slides from a project while in Slide Edit view or while working with 
thumbnails. The choice is up to you. However, if you are deleting multiple slides at the 
same time, you will need to do this while working with in the Thumbnail tab. 
 
 
To delete a single slide: 
 

 Select the thumbnail or click on it while in slide edit view (so that it is the current 
slide). 
 

 Click the Delete  button on the toolbar. 
 

 A Delete warning window displays. Read the information in it and click the  

Yes  button to confirm and complete the deletion. 
 
 
 
To delete multiple slides: 
 

 Select the slides you want to delete while viewing thumbnails. 
 

 Click the Delete  button on the toolbar. 
 

 A Delete warning window displays. Read the information in it and click the  

Yes  button to confirm and complete the deletion. 
 
 

The Hidden Slide 
ViewletQuiz3.1 offers you the option of hiding a slide instead of deleting it. This feature is 
handy because instead of deleting the slide, it will hide it so that it will not display while 
previewing or publishing the project, but can later be unhidden when needed. 
 

 
 

ViewletQuiz3.1 User Manual Page 120 March 2009 



 
 
 
The main features of working with hidden slides include: 
 

 The thumbnail for a hidden slide has an X in the lower left corner. 
 

 
 
 

 If you select a hidden slide in thumbnails, it will display in slide edit view at 50% 
opacity. 
 

 If you use slide navigation arrows to go from slide to slide, hidden slides are 
skipped. 
 

 The duration of hidden slides is ignored in the times in the Timeline. 
 
 
To hide or unhide a slide: 
 

 Click on the slide (while in slide edit view) or slides in thumbnail view. 
 

 To hide a slide, click the Hide Slide  button on the Context Sensitive 
Toolbar to hide the slide. 

 
 
Hidden slides will not display (or be heard) when previewing a project; however, they will 
remain in the slide count. 
 

 To display a slide, click the Show Slide  button on the Context Sensitive 
Toolbar to display the slide. 

 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
 
 
 

ViewletQuiz3.1 User Manual Page 121 March 2009 



 
 
 

Audio 
ViewletQuiz3.1 allows you to add sound to your project. You can import sound files or 
record them directly while working in ViewletQuiz3.1. Audio files may be attached 
directly to a slide or various slide objects such as balloons, notes, text boxes and 
shapes. You may also export sound from projects. And, there is a feature that allows you 
to add a background sound track (independent of sound attached to slides or slide 
objects) to your project. 
 

 
 
 
To attach an external audio file to a slide or a slide object: 
 

 Click on the slide or slide object to select it. 
 

 Click the Attach Sound  button on the Context Sensitive Toolbar.  
 

 In the Sound window, click the Load Sound  button. 
 

 Select a sound file and click Open to return to the Sound window. 
 

Supported sound file formats include MP3, RAW, AIF, WAV and AU. 
 
 
 
The RAW Audio File Format (New in ViewletQuiz3.1) 
ViewletQuiz3.1 now supports the RAW audio format. A “raw” sound file can contain 
audio in any codec, but is usually used with PCM audio data. So, if you have “raw” audio 
files, you can now import them into your Viewlet projects. 
 
 

 Click Open to return to the Sound window. 
 

 In the Sound window, click OK. 
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To record sound inside ViewletQuiz3.1: 
 

 Click on the slide or slide object to select it. 
 

 Click the Attach Sound  button on the Context Sensitive Toolbar. 
 

 The Sound window displays. Click the Record   button. 
 

In order to record audio, your computer must have a sound card. ViewletQuiz3.1 records 
audio using the MP3 format. This reduces file sizes in projects containing audio. 
 

 Speak into your system’s microphone to record. 
 

 
A “Countdown Timer” will display prior to recording audio if you selected the “Display 
Countdown Timer” option when setting up program preferences (Edit > Preferences > 
General tab).  Start speaking after the timer countdown is complete. 
 

 
 
 

 Press the Stop  button to end the recording. 
 

 Click OK to attach the recording to the slide or slide object. 
 
 
To preview a sound file in the Sound window: 
 

 In the Sound window, press the Play  button to listen to the sound file 
attached to the slide or slide object. 
 

 Click OK to close the Sound window. 
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You can listen to sound files attached directly to slides by clicking on a slide. Then, click 
the “Attach Sound to Slide” button. In the “Sound” window that displays, click the 

“Previous Sound”  button or the “Next Sound”  button. This will move you 
automatically to the applicable slide and the sound attached to it in the “Sound” window. 
Click “Play” to preview the sound. Repeat these steps while in the “Sound” window to 
listen to slide sounds throughout the project without closing the “Sound” window. 
 
 
To remove sound attached to a slide or slide object: 
 

 Click on the slide or slide object to select it. 
 

 Click the Attach Sound button on the Context Sensitive Toolbar. 
 

 In the Sound window, click the Delete Sound  button. 
 

 Click OK to close the Sound window. 
 
 
To export sounds from your project: 
 

 Before exporting any sound files from your project, create a folder outside of 
ViewletQuiz3.1 to save your exported sound files in (recommended). 
 

 Select File > Export from the Menu bar. 
 

 Select Sounds. 
 In the Export Sounds window, select the slides to export: 
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o Current Slide: Only the sound attached to the current slide and any 
attached to slide objects will be exported. 
 

o From: Enter a starting slide number in the first field and an ending slide 
number in the second field. Sound attached to the slides (and objects on 
the slides) in this sequence will be exported. 
 

o All: All sound attached to slides and slide objects will be exported. 
 

 In the Save File In window, select a folder to save the exported audio files in. 
 

 Click Save. 
 

Exported sound files are saved in the same format (and with the same file name) as they 
have in the project prior to being exported. 
 
 

Play Sound Action Options 
When working with Events and Actions, you can add a “Play Sound” action to many 
different Events such as when a slide loads or unloads, when a mouse rolls over an 
object or area of the slide, when the user clicks and more. The “Player Sound” action 
has some synchronicity and concurrency features for ultimate sound control during 
Viewlet playback. 
 
Synchronicity (Play Sound Action) 
In the Action window, when the Action Type of Play Sound is selected you have the 
ability to determine when your sound file will end. 
 

 
 
In the Synchronicity area, select the Wait for the sound to complete before 
advancing to the next action or slide if desired. 
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Concurrency (Play Sound Action) (New in ViewletQuiz3.1) 
A new “Play Sound” action option includes selections for further controlling when the 
sound files plays along with other sounds on the slide. In the Concurrency area, select 
the desired option: 
 

 Concurrent Playback – Play concurrently with other sounds. 
 Privileged Playback – Stop all other event sounds. 
 Exclusive Playback – Stop all other sounds. 

 

 
 

Sound Quality for Published Project 
Please refer to the Project Properties chapter for information regarding how to set up 
sound quality options for your published project. 
 

Background Soundtrack 
As discussed previously in this chapter, audio may be attached directly to a slide as well 
as to other slide objects. You may also attach a background sound track to your 
published project. This sound track is independent of sound attached to slides and slide 
objects and plays in the background when the Viewlet is played. Please refer to the 
Project Properties chapter for more information on adding a background soundtrack to 
your Viewlet.  
 
A background sound track will loop and continue to play even when the Viewlet pauses on 
slides with interactive zones. However, if the viewer uses the player bar or clicks an object 
with a pause even, the sound track will stop until the Viewlet is back in “play” mode. 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Images 
Images may be used in projects in a few different ways. One option is to create an entire 
project made up of image files. When creating image projects or when inserting image 
slides, images are embedded as slide background frames.  When used in this way, 
images cannot be moved around the slide. 
 
Multiple images may be used as part of a slide’s background frames. See the chapter on 
“Background Frames” for more information. 
 
You may also insert images onto slides as slide objects. When inserted on the slide, 
images may be resized, moved on the slide, converted to a hyperlink object, become a 
rollover event, have its transparency level modified and more. And, multiple images may 
be inserted on the same slide. 
 
Let’s look at some ways to work with images and slides. 
 
To insert an image on to a slide: 
 

 Select the slide you want to insert the image on. 
 

 Click the Insert Image  button on the Object Toolbar. 
 

 In the Insert an Image window, browse to locate the image file. 
 
 
Supported image file formats include JPEG, GIF, TIFF, JPG, TIF, PNG and BMP. 
 
 

 Select the image file and click Open. The image is inserted on the slide, ready 
for editing. 
 

 
To move an image on a slide: 
 

 Select the image by clicking on it. 
 

 Move your cursor over the image and when the cursor changes to a hand shape, 
hold down the left mouse button. 

  
Drag the image (while holding down the left mouse button) to its new location on 
the slide. 
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To resize an image on a slide: 
 

 Select an image by clicking on it. 
 

 Point your cursor over one of the grab handles. 
 

 When the cursor changes to an arrow, hold down your left mouse button. 
 

 
 

 Drag the grab handle (while holding down the left mouse button) to resize the 
image. 

 
 
 
To change an image’s opacity level: 
 

 Select an image by clicking on it. 
 

 Enter a value in the Opacity field on the Context Sensitive Toolbar. 
 

 
 

 Press enter to apply the new opacity level. 
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To layer images (and other objects): 
 

 Right click on the image. 
 

 Select Arrange from the shortcut menu. 
 

 Select an arrangement option from the fly-out menu. 
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To view and/or modify image properties: 
 

 Click on the image to select it. 
 

 Click the Image Properties  button on the Context Sensitive Toolbar. 
 

 In the Image Properties window, view/edit the Name, Location & Size and Timing 
as desired. 
 

 
 

 Click OK to close the Image Properties window. 
 
 
 
To create an image event: 
 

 Click on the image to select it. 
 

 Click the Events  button on the Context Sensitive Toolbar. 
 

 In the Image Events window, select an events tab and choose the desired action. 
 

 Click OK to apply. 
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To delete an image: 
 

 Select the image. 
 

 Click the Delete  button on the Context Sensitive Toolbar.  
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
 
 
 

ViewletQuiz3.1 User Manual Page 131 March 2009 



 
 
 

Background Frames 
The most popular Viewlet projects have slides that contain embedded images as part of 
the background. These background images are known as Background Frames. This 
chapter discusses how to work with single and multiple slide background frames, an 
important component of many Viewlet projects. 

 

Background Frames – Single Frame 

 
 

To access the Background Frames window: 

• Select the desired slide in slide or thumbnail view. 
 

• Right click and select Background Frames. The Background Frames window 
displays. 
 

• You can also double click on the frame along the Timeline to display the 
Background Frames window. 
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To add a background frame to a slide with detailed settings: 
 

• In the Background Frames window, click the Add Frame button.  
 

 
 

• The Background Frame window displays. Click the folder button to search for 
and select an image for the frame. 
 

 
 

• Set Options, Location & Duration settings as desired. 
 

• Click OK. 
 

• Click OK in the Background Frames window to load the selected frame. 
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To directly load a frame from the Background Frames window: 
 

• In the Background Frames window, select the Load Image button. 
 

 
 

• Browse for and select an image. 
 

• Click Open. 
 

• Click OK. 
 
 
To delete a background frame: 
 

• In the Background Frames window, click the Remove Background button. 
 

 
 

• Click OK to remove the background frame. 
 
 
If you accidentally delete a background frame from a slide (and this was your last action), 
simply press “Ctrl + Z” to undo this last action. 
 
 
To expand/collapse the Background Frames window: 
 

• In the Background Frames window, click Show Preview  button 
to expand the window. 
 

To collapse the window, click the  Hide Preview  button. 
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To choose the layout for the frame: 
 

• In the Background Frames window, select an orientation for the image from the 
Layout list. 
 

 
 

• Click OK to close the Background Frames window. 
 
 
To change zoom selection of frame Preview: 
 

• To zoom in, click the Zoom In button. 
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• To zoom out, click the Zoom Out button. 
 

 
 

• To fit the image in the Preview panel, click the Scale to Fit button. 
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Background Frames – Multiple Frames 
Slides may be comprised of multiple background frames. This most commonly happens 
when creating projects using Smart Capture. Slides containing multiple background 
frames are animated during playback on the slide itself (similar to an animated GIF file). 
To edit a slide with multiple background frames, you will use the same steps as you 
would with the steps outlined for modifying a slide with a single background frame. There 
are, of course, a few additional options since you are working with multiple frames. 
 
For instance, following is an example of what a typical Background Frames window 
looks like when working with a slide containing multiple background frames. 
 

 
Background Frames Window with Preview Hidden 
 
 

ViewletQuiz3.1 User Manual Page 137 March 2009 



 
 
 

 
Background Frames window with Preview Displayed 
 

Key Frame 
Frames added after the first frame may or may not be key frames. If marked as a key 
frame, the key frame will completely replace the previous image in the sequence. If a 
frame is not marked as a key frame, the frame is just “painted” on top of the previous key 
frame, like an additional image layered on top of it. 
 
After creating a screenshot project or adding new screenshots using Smart Capture, if 
you look at a slide that has multiple animation frames on it, you will see that all but the 
first frame are NOT key frames. 
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To enable/disable a Key Frame: 
 

• In the Background Frames window, double click a frame. 
  

• In the Background Frame window, select the Key Frame option. 
 

 
 

• Click OK. 
 
 
 
To move a frame up/down within the list: 
 

• Select the frame in the list. 
 

• Click the Move Up  button to move the frame up in the list. 
 

• Click the Move Down  button to move the frame down in the list. 
 
 

 
To add a frame to the list of frames: 
 

• Click the Add  button. 
 

• In the Background Frame window, click Browse.  
 

 
 
 

• The Select Frame Image window displays. Select and image file and click Open. 
 

• In the Background Frame window, make other selections as needed and click 
OK. 
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To edit a background frame: 
 

• Select a frame in the list. 
 

• Click the Modify  button. 
 

• In the Background Frame window, make selections as desired. 
 

• Click OK. 
 
 
To delete a frame: 
 

• Select a frame in the list. 
 

• Click the Delete  button. 
 
If you accidentally delete a background frame from a slide (and this was your last action), 
simply press “Ctrl + Z” to undo this last action. 
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Previewing Multiple Background Frames 
When working with multiple background frames there are a few different features for 
navigating the Preview in addition to the zoom features previously covered. Use the 
following tools to quickly navigate through background frames. 
 
To navigate through multiple background frames: 
 

• In the Background Frames window, select a frame in the list. 
 

• Click the Show Preview  button, if applicable. 
 

• Click the appropriate button (below the preview pane): 
 

 
 
 

o First Frame 
o Previous Frame 
o Preview Background Frames 
o Next Frame 
o Last Frame 
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To highlight a selected frame: 
 

• In the Background Frames window, select a frame in the list. 
 

• Under the preview pane, select the Highlight Selected Frame option. 
 

 
 

 
If the selected background frame is a “Key Frame” the entire image will be highlighted. If it 
is not a Key Frame, only the image that “sits on top of the Key Frame” will be highlighted. 
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Using the Timeline to Access Background Frames 
If you prefer to edit your project using the Timeline, you can also easily access the 
Background Frames window to modify your background frames. 
 
Here’s an example of what a slide containing multiple background frames looks like 
along the Timeline: 
 

 
 
In the illustration above, Slide 27 contains multiple animation background frames. In fact, 
it contains three frames (as designated in the layer called “Background: 1 of 3). Frame 1 
is the selected frame and, in this example, is a Key Frame. Frame 2 and Frame 3 are 
part of the background frames, but will not display until selected along the Timeline. In 
this example, they are not selected. 
 
If you click on a specific background frame in the Timeline, it will display it in the Slide 
Edit area. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Shapes 
You may insert one or more shapes onto slides. This chapter provides an overview of 
the four basic tools for creating shapes and how to edit them. 
 

The Rectangle Tool   
The rectangle tool allows you to draw rectangles and squares on a slide. 
 

 
 
 
To insert a rectangle: 

 Click the Insert Shape  button on the Object Toolbar. 
 

 Click the Rectangle Tool  button on the Context Sensitive Toolbar. 
 

 Move the cursor over the slide until the cursor changes to a cross-hair  
shape. 
 

 Click on the slide and hold down the left mouse button. 
 

 Continue to hold down the left mouse button and drag to draw the rectangular 
shape. 
 

 Let go of the left mouse button to complete the shape. 
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The Ellipse Tool 
The ellipse tool allows you to draw circles or ovals on a slide. 
 

 
 
 
To insert an ellipse: 
 

 Click the Insert Shape  on the Object Toolbar. 

 Click the Ellipse Tool  button on the Context Sensitive Toolbar. 
 

 Move the cursor over the slide until the cursor until the cursor changes to a 

cross-hair   shape. 
 

 Click on the slide and hold down the left mouse button. 
 

 Continue to hold down the left mouse button and drag to draw the elliptical 
shape. 
 

 Let go of the left mouse button to complete the shape. 
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The Lasso Tool 
The lasso tool allows you to create free-form shapes. 
 

 
 
 
To create a free-form shape: 
 

 Click the Insert Shape  on the Object Toolbar. 
 

 Click the Lasso Tool  button on the Context Sensitive Toolbar. 
 

 Move the cursor over the slide until the cursor changes to a lasso  shape. 
 

 Hold down the left mouse button and draw your shape. 
 

 Let go of the left mouse button when the free-form shape is complete. 
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The Poly Lasso Tool 
The poly lasso tool allows you to create polygonal shapes. 
 

 
 
 
To create a polygonal shape: 
 

 Click the Insert Shape  button on the Object Toolbar. 
 

 Click the Poly Lasso Tool  button on the Context Sensitive Toolbar. 
 

 Move the cursor over the slide until the cursor changes to a poly lasso  
shape. 
 

 Click on the slide to insert the first “anchor” point. 
 

 Drag the cursor to form the first leg of the polygon. 
 

 Click again to insert the next anchor point. 
 

 Drag the cursor again to form the next leg of the polygon. 
 

 Continue repeating these steps until the polygon shape is formed. 
 
 
To close one of the lasso shapes, make sure to click back on the starting point. Or, double 
click when you are ready to close the shape. 
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Miscellaneous Shape Tool Features 
Once shapes are created, you may move, resize, recolor, and arrange them to create 
custom effects. 
 
 
To move a shape on a slide: 
 

 Click the shape to select it. 
 

 Move your cursor over the shape until the cursor becomes a grab hand  
shape. 
 

 Hold down the left mouse button and drag the shape to move it. 
 
 
To resize a shape: 
 

 Click the shape to select it. 
 

 Move your cursor over one of the grab handles until the cursor changes to an  
arrow shape. 
 

 Hold down the left mouse button and drag to resize the shape. 
 
 
To arrange the shape in a stack: 
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 Click the shape to select it. 
 

 Right click and select Arrange from the shortcut menu. 
 

 Select one of the arrange options to move the shape to that position in the stack. 
 

 
To delete a shape from the slide: 
 

 Click the shape to select it. 
 

 Click the Delete  button on the toolbar. 
 
 
Use the shape tools in ViewletQuiz3.1 to create custom slide effects for your Viewlet 
project. 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Grouped Objects Alignment, Distribution and Sizing 
ViewletQuiz3.1 offers various alignment, distribution and sizing tools when working with 
multiple objects. This chapter provides an overview of working with these options. 
 
Alignment Tools 
Alignment tools are available for selected objects. The alignment tools are divided into 
two sections: 
 

1. Aligning selected objects within the group’s “bounding” box (as indicated by the 
dotted rectangle surrounding the selected objects).  
 

2. Aligning selected objects on the slide. 
 

 
To align two or more selected objects within the group’s “bounding” box: 
 

 Click on the first object to select it. 
 

 Hold down the Ctrl key while clicking to select additional objects. A “bounding 
box” surrounds the selected objects. It will be inside this bounding box area that 
the alignment will occur. 
 

 Click the applicable “group alignment” button for the selected objects: 
 

 
 

  Align Left Edges 
 

  Align Top Edges 
 

  Align Right Edges 
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  Align Bottom Edges 
 

  Align Horizontal Center 
 

  Align Vertical Center 
 
 
To align a single or multiple objects on a slide: 
 

 Select the object to select it. 
 

 If selecting multiple objects, hold down the Ctrl key while clicking on additional 
objects to select them. 
 

 Click the applicable “slide alignment” button for the selected object(s). 
 

 
 

  Center Horizontally (on slide) 
 

  Center Vertically (on slide) 
 

  Center (horizontally and vertically on slide) 
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Distribution Tools 
Distribution tools are available for selected objects. In order to use the distribution tools, 
three or more objects must be selected. A “bounding box” (dotted rectangle) displays 
around the selected objects and it is inside the perimeter of this bounding box the 
distribution will be applied. 
 
To use the distribution tools: 
 

 Click on the first object to select it. 
 

 Hold down the Ctrl key when clicking to select the additional objects. 
 

Three or more objects must be selected in order to access the distribution tools. 
 
 

 A “bounding” box displays around the selected objects. Click the applicable 
“distribution” button on the Context Sensitive Toolbar to apply it to the object 
group. 
 

 
 

  Distribute Left Edges 
 

  Distribute Top Edges 
 

  Distribute Right Edges 
 

  Distribute Bottom Edges 
 

  Distribute Horizontal Center 
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  Distribute Vertical Center 
 
 
Sizing Tools 
Sizing tools are available for two or more selected objects. Use this tool if you want to 
quickly set all objects within a selected group to the same size. 
 
To resize two or more selected objects: 
 

 Click on the first object to select it. 
 
The order that you select your objects is IMPORTANT. The objects will be “resized” based 
on the first object selected in the group. 
 

 Hold down the Ctrl key when clicking to select the additional objects. 
 

 A “bounding” box displays around the selected objects. Click the applicable 
“sizing” button on the Context Sensitive Toolbar to apply it to the object group. 
 

 
 

  Make Same Width 
 

  Make Same Height 
 

  Make Same Size 
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Events and Actions – An Introduction 
ViewletQuiz3.1 offers a robust set of events and actions that may be associated with 
slides and slide objects such as shapes and images to produce greater dynamics and a 
higher user interactive experience than ever before. This chapter provides an 
introduction into ViewletQuiz3.1’s events and actions features. 

Events 
Events may be defined as what happens when a certain scenario occurs. For example, 
a slide event may be the “On Load” event. This means that when the slide “loads” or as 
it “loads” this “loading” is an event.  
 

 
 
To create a slide event: 
 

 
 

 Right click on a slide directly and select Events from the shortcut menu. 
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 In the Slide Events window, select a tab: 
 

 
 

o On Load: This is when a slide is loaded. 
o On Unload: This is when you leave the slide. 
o On Key Pressed: This is when a key is press while on a slide. 

 
 Select an action as desired. 

 
 
The selections you make for the selected “action” will depend upon the action you select. 
 
 

 Click OK. 
 
 
 
To create a shape event: 
 

 Right click on a shape. 
 

 Select Events from the shortcut menu. 
 

 In the Shape Events window, select a tab: 
 

 
 

o On Click: This is when the user clicks on the shape. 
o On Rollover: This is when the user moves the mouse over the shape. 
o On Rollout: This is when the user has moved the mouse off the shape. 

 
 Select an action as desired. 

 
 Click OK. 

 
Don’t forget, you can add multiple actions to an events tab! 
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To create image event: 
 

 Right click on an image. 
 

 Select Events from the shortcut menu. 
 

 In the Image Events window, select an events tab. 
 

 
 

o On Click: This is when the user clicks on the image. 
o On Rollover: This is when the user moves the mouse over the image. 
o On Rollout: This is when the user has moved the mouse off the image. 

 
 Select an action as desired. 

 
 Click OK. 

 

Actions 
Actions are associated with Events and are “what will take place” once a particular event 
occurs. For example, an “On Click” event may have a “Goto Slide” action attached to it. 
So, when a user clicks a shape, for example, the project will “go to” a predefined slide. 
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To attach an action to an event: 
 

 Select a slide, shape, image or other object (that supports events). 
 

 Right click and select Events from the shortcut menu. 
 

 In the Events window, select an events tab. 
 

 In the tab, click the Add  button. 
 

 In the Action window, select an action from the list. If applicable, make additional 
selections for the selected action as needed. 
 

 Click OK to close the Action window to return to the Events window. 
 

 Click OK to close the Events window. 
 
 
To arrange multiple actions for a given event: 
 

 In the Events window, select an events tab. 
 

 If multiple actions are listed in that tab, click an action to highlight it. 
 

 Click the Move Up  button to move the selected action up in the list. 
 

 Click the Move Down  button to move the selected action down in the list. 
 

 Click OK. 
 
 
To edit an action: 
 

 In the Events window, select an events tab. 
 

 Select the action to edit. 
 

 Click the Modify  button. 
 

 In the Action window, modify the action as needed. 
 

 Click OK to close the Action window. 
 

 Click OK to close the Events window. 
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To delete an action: 
 

 In the Events window, select an events tab. 
 

 Select the action to delete. 
 

 Click the Delete  button. 
 

 Click OK to close the Events window. 
 
 
If an event has multiple actions associated with it, the actions will be performed in the 
order in which they are listed in the “Action” window (from top to bottom). 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Buttons 
Buttons may be used to increase user interactivity within your Viewlet project. For 
example, if you want to give your viewer the control to advance through your Viewlet at 
their own pace, you can create your own series of customized buttons for them to do 
this. Or, you might provide buttons that, when clicked, will allow the viewer to skips 
ahead or to different parts of your project instead of just progressing through it in a linear 
fashion. 
 

 
 
 
To insert a button on to a slide: 
 

 Select the Insert Button  button on the Object Toolbar. 
 

 A button is inserted on the slide ready for editing. 
 
 
Don’t forget to add a “Pause Zone” to a slide that contains a button. This will give the 
viewer a chance to click the button for further navigation in the Viewlet. 
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To view/modify button properties: 
 

 Right click a button and select Button Properties from the shortcut menu. 
 

 In the Button Properties window in the: 
 

o Name area: Enter a name for the button in the field provided. Enter the 
Text to be displayed on the button in the field provided. 
 

 
 

o Location & Size area: Enter values for its Left and Top margin. Enter 
values for the Width and Height of the button. 
 

 
 

o Timing area: Select a timing option for the button to display on the slide 
from the drop down list. Enter values for any Start/Duration times as 
applicable. 
 

 Click OK. 
 
 
To move a button on a slide: 
 

 Click a button to select it. 

 Point your cursor over the button and when the cursor changes to a hand   
shape, hold down your left mouse button. 
 

 Continue to hold down the left mouse button and drag the button to its new 
location. 
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To select a button style: 
 

 Right click on the button and select Button Style. 
 

 In the Button Style window, select a style from the list. 
 

 Click OK. 
 
 
To add an event and action(s) to the button: 
 

 Right click on the button. 
 

 Select Events from the shortcut menu. 
 

 In the Button Events window, in the On Click tab, click the Add  icon. 
 

 
 

 In the Action window, select an action from the list. Make additional selections as 
needed. 
 

 Click OK to close the Action window. 
 

 Click OK to close the Button Events window. 
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To delete a button: 
 

 Select a button to delete. 
 

 Click the Delete  button on the toolbar. 
 
 
Use multiple buttons on a slide for non-linear navigation within the Viewlet. 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Hyperlinks 
A hyperlink allows a user, with a single click, to perform an action such as jump to 
another section of the project, open an email, go to a web page and more. In 
ViewletQuiz3.1, hyperlink functionality includes text links and the ability to make other 
objects work as “clickable” links. This chapter covers the basics steps for creating 
hyperlinks in your Viewlet projects. 
 

 
 

Message Hyperlinks 
While message objects themselves cannot be set up as a hyperlink, a portion or all of 
the text inside can. These types of hyperlinks are known as text links. 
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To create a text link within a message object: 
 

 Highlight the text you want to use for the link. 
 

 Right click the text and select Hyperlink from the shortcut menu. 
  

 In the Hyperlink window, make sure the On Click tab is selected. 
 

 Click the Add  button. 
 

 In the Action window, select an action from the list. Make additional selections as 
needed. 
 

 Click OK to close the Action window. 
 

 Click OK to close the Hyperlink window. 
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By default, a text hyperlink will be blue underlined text. Once a hyperlink is created, you 
can change the link’s text attributes as needed. 
 
 

Miscellaneous Hyperlinks 
Any object that requires the user to click may be considered a link of some sort. 
Message (text) hyperlinks work the same as when you are creating an Event/Action 
setup. Links can also be set up to occur when an image loads, etc. Please refer to the 
chapter on Events and Actions Overview.  
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Question Projects – Beyond the Basics 
Interactivity is key to all Quiz Projects in ViewletQuiz3. We’ve already covered the basics 
of each of these projects including: 
 

 Creating new Quiz Projects 
 The difference between a quiz (scored) and a survey (not scored) project 
 Various question types 
 Inserting question slides into existing projects 
 Editing various elements on slides, including buttons, events/actions, message 

objects, etc. 
 
In this chapter, we will go a bit further and introduce you to more features you will work 
with while editing your Quiz Projects.  
 

The One Zone Per Slide Rule 
Only one Question may be on the slide at a time. If you try to insert multiple Questions 
on the same slide, you will see a Warning window with the following options: 
 

 
 

 Remove it. 
 Add the Question to a new empty slide. 
 Add the Question to a copy of this slide. 

 
Select one of these options and click OK. 
 

Choice Boxes, Input Fields, ComboBoxes and Rating 
The question type determines the interactive element (choice box, input field, combobox 
or ratings) the user will respond to.  Let’s take a look at each of these interactive features 
based on the various question types. 
 

ViewletQuiz3.1 User Manual Page 166 March 2009 



 
 
 
Choice Boxes 
This question type requires users to select answers from a list of choice by selecting a 
radio button or check box next to each text option. The user then clicks a Submit button. 
If the question is a quiz, it will be scored. If the question is a survey, it will not be scored. 
So, this question type’s elements (by default) include: 
 

 
 

 Text box for the question 
 Radio buttons for users to select an answer 
 Text boxes containing possible answers 
 Submit button the user clicks to submit the response 
 Response message objects 

 
You can customize the default elements of any Question to best fit your project’s needs. 
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To modify the text box containing the Question zone’s question: 
 

 Double click the text box. 
 

 Edit the text as you would in any other message object. 
 
 
To add additional choices: 

 Click the Add Choice  button on the Context Sensitive Toolbar. 
 

 Repeat the step above for to add each new choice. 
 
 
To delete a choice option: 
 

 Select the radio button / check box or the text box of the choice you want to 
delete. 
 

 Press the Delete key on your keyboard. 
 
 
To set the correct responses: 
 

 Select the radio button / check box next to the choice you want to set as the 
correct response. 
 

 Click the Modify Choice  button on the Context Sensitive Toolbar. 
 

 Repeat these steps for each choice you want to set as the correct response. 
 

 If a choice is set as the correct response, click the Modify Choice button again 
to deselect it as the correct response. 

 
Each Question can contain one or more correct responses. The choice is up to you. 
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To change the radio button style: 
 

 Click on any of the radio buttons to select one. 
 

 Click the Choice Type  button on the Context Sensitive Toolbar to display 
a menu of options. 
 

 Select Radio Button   option from the list. 
 
 

Use the “Check Box” option as an alternative Choice Type for the Radio Button. 
 
 

 The Radio Button Style window displays. Select a style for the radio button from 
the list. 
 

 Click OK to apply the new style. 
 
 
To modify an answer text box: 
 

 Double click the text box. 
 

 Edit the text as you would in any other message object. 
 
 
To modify the Submit button properties: 
 

 Select the Submit button. 
 

 Click the Button Properties  button on the Context Sensitive Toolbar. 
 

 In the Button Properties window, edit the information as required. 
 

 Click OK. 
 
Refer to the chapter on Buttons for more information on modifying the “Submit” button. 
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To delete a Question from the slide: 
 

 Click the Insert Question   button on the Object Toolbar. 
 

 In the Warning window, select the Remove It option. 
 

 
 

 Click OK 
 

 
Text Input Fields 
This question type requires the user to respond to a question by typing a response into a 
text input field. The response is then submitted either automatically or by the user 
clicking the Submit button. This question may (quiz) or may not (survey) be scored.  
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This question’s default elements include: 
 

 Text box for the question 
 Text input field for users type their responses in 
 Submit button the user clicks to submit the response 
 Response message objects 

 
 
To modify the text box containing the Question zone’s question: 
 

 Double click the text box. 
 

 Edit the text as you would in any other message object. 
 
 
 
To modify the text input field: 
 

 Double click the text input field. 
 

 The Modify Text Field window displays. Enter information or make selections as 
follows: 
 

 
 

o Correct Answers – One Per Line:  If this question requires a correct 
response, type it in this field. This is what the user will need to type in the 
text input field in order to answer correctly.  For multiple answers, press 
the Enter key between each correct entry. 

 
Leave the “Correct Answers – One Per Line” field blank if the Question is not scored (a 
survey question). 
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o Case Sensitive: By default, user may enter responses using caps or not 
and the answers, if input otherwise properly, will be considered to be 
correct. To force a user to use capital letters (for proper nouns, etc.), 
select the Case Sensitive check box. 
 

o Wrap Text: Select the Wrap Text option to allow text to wrap inside the 
text field. 
 

o Password Field: To encrypt the user input while typing in the text field, 
select the Password Field check box. 
 

o Submit Key: Make a selection from the list. This will be what will be used 
for the user to submit the response. 
 

The Submit Key (New in ViewletQuiz3.1) 
There is a new option available for the Submit Key. If you do not want to require the 
user to press a button after typing in a response in the text field, use the new Auto 
option. When selected, once the user types in a response, after approximately three 
seconds, the Viewlet will automatically “submit” the input and respond accordingly. 
 

 
 
 
To force users to click the “Submit” button in order to submit the response, select “None” 
from the “Submit Key” list. 
 
 
 
 
To move the text field on the slide: 
 

 Select the text field. 
 

 Mouse your cursor over the text field until the cursor changes to a hand   
shape. 
 

 Hold down the left mouse button and move the text field to its new location. 
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To resize the text field: 
 

 Select the text field. 
 

 Mouse your cursor over one of the grab handles until the cursor changes to a 
double arrow shape. 
 

 Hold down your left mouse button and drag the grab handle to resize the text 
field. 

 
 
To delete an input field: 
 

 Select the text field. 
 

 Press the Delete key on your keyboard. 
 
 
 
ComboBoxes 
This question type requires users to answer a question by selecting a single answer 
from a list of answers contained within a drop-down list. Then the user clicks the Submit 
button to submit the response. So, this question type’s elements (by default) include: 
 

 
 

 Text box for the question 
 ComboBox for users to select an answer from a drop-down list 
 Submit button the user clicks to submit the response 
 Response message objects 
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To modify the text box containing the Question zone’s question: 
 

 Double click the text box. 
 

 Edit the text as you would in any other message object. 
 
 
To modify a ComboBox style: 
 

 Click the Choice Type  button on the Context Sensitive Toolbar. 
 

 Select ComboBox  from the list that displays. 
 

 In the ComboBox Style window, select a style from the list. 
 

 
 

 Click OK. 
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To set up and manage the ComboBox’s options list: 
 

 Double click on the Combobox. 
 

 The Modify ComboBox window displays. In this window: 
 

 
  
 

o To insert an answer: 

-Click the Add  button. 
-Type a value in the list area. 
 

o To modify an answer: 
-Select a value in the list. 

-Click the Modify  button. 
-Edit the highlighted value. 
 

o To set an answer as “correct”: 
-Click on the check box  next to the desired value. 
-Deselect the checkbox to remove the checkmark. 
 

o To move an answer up or down in the list: 
-Select the desired value. 

-Click the Move Up  button to move it up in the list. 

-Click the Move Down  button to move it down in the list. 
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o To remove an answer from the list. 
-Select a value in the list. 

-Click the Delete  button. 
 

 Click OK to save the list and to close the window. 
 
 
 
Ratings 
This question type gathers information from a user by posing a question such as “What 
is your overall level of satisfaction?” In response, the user is required to click along a 
“rating” scale and then click a Submit button to submit the response. This type of 
question is for surveys only and not scored.  
 

 
 
The (default) elements for this question type include: 
 

 Text box for the question 
 Rating scale the user clicks on in response to the question 
 Submit button the user clicks to submit the response 

 
 
 
To modify the text box containing the Question zone’s question: 
 

 Double click the text box. 
 

 Edit the text as you would in any other message object. 
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To change a Rating scale’s style: 
 

 Select the Rating object to select it. 
 

 Click the Modify Choice  button on the Context Sensitive Toolbar. 
 

 Select Rating  from the list. 
 

 The Rating Style window displays. Select a new style from the list. 
 

 
 

 Click OK to apply it. 
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To increase / decrease the rating scale: 
 

 Double click on the Rating object. 
 

 The Modify Rating window displays. Enter a number in the field provided for the 
Maximum Rating desired. 
 

 
 

 Click OK. 
 
 

The Submit Button 
Once the user provides a response to the question, the response must be submitted. By 
default, the user clicks a Submit button to submit the response. To learn more about 
working with this feature, see the chapter on Buttons. 
 

 
 

Response to User Input 
You have the opportunity to offer some type of response to the user after they’ve 
completed their input. In its simplest form, this response may simply be a message 
object that informs the user they’ve answered correctly. Or, it may be as elaborate as a 
combination of a message that, when the user answers incorrectly, a message appears 
telling them this and directing them to click a link to launch a quick training movie before 
continuing or to just continue without this option, etc. The choice as to how simple or 
complex the response will be is up to you. You even have the option to remove all 
responses to user input as well, if you desire.  
 
 

 
 
Response objects will only display when the user submits a response or the zone has 
“timed out”. 
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To create a response message object: 
 

 Insert an Interactive zone and, if applicable, three default response text 
messages will display. 
 

o Green message object: This will display if the user answers correctly. 
o Lime message object: This will display if the user did not complete the 

message. 
o Red message object: This will display if the user answers incorrectly. 

 
 Select a message object and edit as you would any other message object with 

regards to text and message type/style itself. 
 

 Move and stack the messages as desired on the slide. 
 
 
To edit a response object: 
You may change a response object from a message to an image or shape or none at all. 
In addition, you may change how this response object responds in reaction to a certain 
user action and the duration a response displays on a slide. These features are part of 
ViewletQuiz3.1’s events/actions tools. 
 

 Click the Events  button on the Context Sensitive Toolbar. 
 

 In the Slide Events window, click the appropriate tab. For example, to change the 
response that will display when the user answers correctly, select the On Correct 
tab. 
 

 
 

 Select the action to modify and click the Modify  button. 
  

 In the Action window, edit as desired and click OK. 
 

 In the Slide Events window, select another tab and repeat this process as 
desired for each of the response objects. 
 

 When complete, click OK to close the Slide Events window. 
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To delete a response object: 
 

 Click the response object. 
 

 Press Delete on your keyboard. 
 

Scoring Options 
For quiz questions, available scoring options include points, attempts and time to 
complete an answer. 
 

   
 
To set up scoring options for a quiz question: 
 

 
 

 Click on the zone’s input or zone field. 
 

 Click the Scoring  button on the Context Sensitive Toolbar. 
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 In the Score window, three scoring options are available. To set: 
 

o Points:  Enter a number that will be used for the point value if the user 
answers the question correctly. 
 

o Attempts: Enter a number of times the user has to answer the question 
correctly. After this number is reached and if the question is not answered 
correctly, it will be marked as incorrect and the Viewlet will continue. 
Select the option to allow the question to be reanswered if the user 
navigates backwards in the project, if desired.  
 

o Time: To limit the amount of time a user has to answer a question, select 
the Enable a time limit for the question check box. Then, enter the 
Hours/Minutes/Seconds as desired. 

o  
 Click OK to apply the scoring options and to close the Score window. 

 
 
 
Even though you do not score survey questions, you can use the “Score” window to set a 
time limit in which the user must respond. To do this, click the “Score” button and in the 
“Score” window that displays, set the time limit and click “OK” to apply it to the survey 
question. 
 
 
For more information on working with any of the topics covered in this chapter, please 
contact support@qarbon.com. 
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Pause Zone 
The Pause Zone is used to pause the Viewlet on a particular slide. These zones are 
easy to use on slide and are most commonly used on slides that contain hyperlinks or 
buttons that allow the user to click when they decide to continue to play the Viewlet. 
 
Question slides are automatically paused to allow the user time to respond. So, you do 
NOT have to add a Pause Zone to slides containing quiz or survey Questions. 
 
 

 
 
 
To insert a Pause Zone on a slide: 

 Click the Insert PauseZone  on the Object Toolbar. 
 

 A red triangle will be inserted in the bottom right corner of the slide. This triangle 
indicates the slide will pause, but this triangle will not display in the Viewlet. 

 
 
To move a Pause Zone in the Timeline: 
 

 Click the Pause Zone layer to select it. 
 

 Select the object’s “rectangle” in the Timeline by clicking on it. 
 

 Hold down your left mouse button and drag the zone. 
 

 Let go of the left mouse button to drop it into place. 
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 A Timing Rule Change window displays. Read the information and click OK to 
change the timing rule to manual timing. 
 

 
 

 
 
To remove a Pause Zone from a slide: 
 

 Click the Insert PauseZone   on the Object Toolbar. 
 

 In the Warning window, select the Remove It option. 
 

 
 

 Click OK. 
 
 
You must preview the project in a browser to view the results of the Pause Zone. 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Resize Project  
(New in ViewletQuiz3.1) 
Have you ever worked for hours on end perfecting your Viewlet only to realize its 
dimensions were either too small or too big for your viewers needs? In previous 
versions, when this happened, the only solution was to recreate the project from scratch 
starting with the correct slide size. That’s now a thing of the past! 
 
ViewletQuiz3.1 now offers a “Resize Project” tool that allows you to resize your current 
project. You can do this directly within the project, while inserting new screenshots, or 
even while importing slides from a project (whether or not the slides are the same size 
as the current project). Let’s take a look at how this works. 
 
 
Resizing the Current Project 
 

 Select Project > Resize Project from the Menu. 
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 The Project Resize window displays.  
 

o In the Current Project Size area, the project’s original size displays. 
Review this information.  
 

 
 

o In the New Project Size area: 
 
-Enter a number for the new Width and Height in the fields provided. 
 
-To maintain the correct ratio between the new width and height, select 
the Maintain Aspect Ratio option BEFORE entering a number in either 
the Width or the Height field.  
 

 
 

If the “Maintain Aspect Ratio” option is selected, just enter a number in either the “Width” 
or the “Height” field and press the “Enter” key and number for the “other” value will 
automatically be filled in the applicable field. 
 

o In the Scaling area, select one of the scaling options: 
 
-Scale to Fit: Scales the slide background image to “best fit” the new 
slide dimensions. 
 

 
 
 
-Align Slide: Maintains the current size of the slide’s background image 
and aligns it on the new slide based on the alignment selection. Normally 
used when the new project (slide) size is larger then the original project 
dimensions. After selecting this option, select an alignment option from 
the alignment menu. 
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 Click OK to resize the project. 
 
 
If a “Warning” window displays after clicking “OK”, read the information in it and click 
“OK” to close the window. Then, back in the “Resize Project” window, edit the selections 
as instructed by the warning and click “OK” to resize the project. 
 

 
 
 
 
 
Did you know the “Project Resize” feature also allows you to import slides from projects 
with dimensions “different” from the current, open project? For more information on this 
topic, review the “Importing Slides with Different Sizes” section of the “Export and Import 
Options” chapter. 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Crop Project 
(New in ViewletQuiz3.1) 
ViewletQuiz3.1 now offers you the ability to crop the dimensions of your project’s slide 
size. An alternative to the “Resize Project” feature, the “Crop Project” feature will crop 
the project’s slide without the need for scaling the background image. Let take a look at 
how this works. 
 
Cropping the project’s slide size 
 
The “Crop Project” operation cannot be undone, so make sure you create a backup copy 
of your project BEFORE you crop the original project’s slide size. 
 
 

 Select Project > Crop Project from the Menu bar. 
 

 
 

 A Crop Project warning window displays. Read the information in the window and 
click Yes to continue with the cropping task. 
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 In the “Slide Edit” area, four “shaded” sections surround the current slide. The 
area in the shaded portions of the slide will be “cropped” out and the areas of the 
slide that are NOT shaded will not be cropped. 
 

 
 

 To resize the “crop area”, point your cursor on one of the lines separating the 
shaded area and the unshaded slide area.  
 

 When your cursor changes to a “double arrow” shape, hold down the left mouse 
button and drag to resize the crop area. 
 

 Let go of the left mouse button when you are finished resizing one of the edges 
of the crop area. 
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 To view the current dimensions of the new slide size as you resize the crop area, 
look at the top of the slide area where the “Width” and the “Height” are displayed. 
 

 
 

 Once you’ve resized the crop area, click the Accept Crop  button. 
Depending on the size of the project, you may see a progress bar display the 
status of the cropping operation. 
 

 
 

 
If you decide you do not want to crop the project while viewing the shaded and unshaded 
slide areas, click the “Cancel” button. 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Page Layout 
The Page Layout feature is an often overlooked option in ViewletQuiz3.1. The settings in 
the Page Layout window determine what your hardcopy and electronic “printed” 
materials will look like.  You can set print (page layout) options for the page header, the 
layout of images on each page, what slide elements to include, page numbers and the 
slides to print. 
 

 
 
To access Page Layout: 
 

 Select File > Page Layout from the Menu bar. 
 

 The Page Layout window displays. 
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To edit options for Page Layout: 
 

 Open the Page Layout window. 
 

 In the Header area (if desired):  
 

 
 

o Select the Title option and type a title in the field. 
o Select the Display date and time option to add a date signature. 
o Select the Display slide border to add a border around each slide. 

 
 In the Layout area: 

 

 
 

o Select Landscape orientation and enter a number for the number of rows 
(slides) to include per page. 
 
or 
 

o Select Portrait orientation and enter a number for the number of columns 
(slides) to include per page. 
 

ViewletQuiz3.1 User Manual Page 191 March 2009 



 
 
 

 In the Options area, select the elements you want to include on the print 
materials, including: 
 

 
 

o Hidden slides 
o Slide Title 
o Balloons (now available in ViewletQuiz3.1) 
o Slide Notes 
o Notes (now available in ViewletQuiz3.1) 

 
Balloons & Notes (New in ViewletQuiz3.1) 
ViewletQuiz3.1 now offers new options for printing “Balloons” and “Notes” in the Page 
Layout window. If selected (Balloons or Notes), these message objects will now be 
included on print materials. 
 

 In the Footer area, select/deselect if you want Page Numbers to display. 
 

 As you make selections, view the slide Preview area. Use the “VCR style” 
buttons (First, Back, Next, Last) to navigate through the slides preview. 
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 In the Slides area, select which slides to print. 
 

 
 

 
o Current Slide: Select this option to print the slide selected prior to 

opening the Page Layout window. 
 

o From: Select this option and enter the number of the first slide to the last 
slide (in the fields provided) for the “series” of slide you want to print. 
 

o All Slides: Select this option to print all the slides in the project. 
 

 Click OK to save these as the default options for this project. Or, click Print to 
open the Print window. 

 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Printing 
There may be times you want to print your slides for users to view or as reference 
materials. Before you print your slides, review the Page Layout chapter for setting up 
layout options for printing your slides.  
 
To print a hardcopy of your slides: 
 

 Select File > Print from the Menu bar. 
 

 
 

 The Print window displays. Select the options in this window for your print job as 
desired. 

 
 
The options available in the “Print” window will vary from computer to computer. 
 
 

 Click the Print  button to print the selected slides. 
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To print an electronic copy of your slides: 
 

 Select File > Export > PDF from the Menu. 
 

 
 
 

 The Export PDF window displays.  
 

 
 

o In the Options area: Select Slide Title and / or Page Numbers if you 
want to include these in the electronic document. 
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o In the Slides area, select what slides to print: 
 
-Current Slide: Select this option to print the slide selected prior to 
opening the Page Layout window. 
 
-From: Select this option and enter the number of the first slide to the last 
slide (in the fields provided) for the “series” of slide you want to print. 
 
-All Slides: Select this option to print all the slides in the project. 
 

 Click the Export  button. 
 

 The Export PDF window displays. Select a folder to save the file in and give the 
file a name.  
 

 Click Save. Depending upon the size of your file, a progress bar may display. 
Once complete, you will be returned to your Viewlet project. 

 
 
Another way to print an electronic copy of your slides is by selecting a “PDF” printer from 
the “Print” window, if one is available on your system. 
 
 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Export and Import Options 
ViewletQuiz3.1 offers various export and import options. These include: 
 

Export Options 
 

 
 

 Text for Translation 
 Sounds 
 PDF 
 Slides to Images 
 QuestionMark 
 Publishing Locations (New in ViewletQuiz3.1) 

 
 
To export the project’s text for translation or other copywriting purposes: 
 

 Select File > Export > Text for Translation from the Menu bar. 
 
 In the Export Text window, select a location to save the file, which will be saved 

in “XML” format. 
 
Enter a name for the file and click Save. 
 

 If an Information window displays, click OK. 
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To export sounds from your project: 
 

 Create a folder outside of ViewletQuiz3.1 to save the exported sound file in. 
 

 Select File > Export > Sounds from the Menu bar. 
 

 In the Export Sounds window, select what slides you want to export audio from. 
 

 Click Export. The sound files will be saved in the designated folder with the 
same file names and as the same files types as they exist in your project. 
 

For more information on exporting sound from your project, review the chapter on 
“Audio”. 

 
 

 
To export slides as a PDF file: 
 

 Select File > Export > PDF from the Menu bar. 
 

 In the Export PDF window, make selections for Options and for Slides 
. 

 Click Export. 
 In the second Export PDF window that displays, select a folder to save the file in. 

 
 Enter a name for the file and click Save. 
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To export slides as image files: 
 

 Select File > Export > Slides to Images from the Menu bar. 
 

 Select Slides to Images. 
 In the Export Slides to Images window in the: 

 

 
 
 

o File area: Enter a Prefix (used for beginning of file names); select an 
Extension from the drop down list (this will determine the type of image 
file that will be saved when slides are exported); and, if applicable, select 
the Quality (for JPG files) from the drop down list. 
 

o Options area: Select additional options as desired. 
 

o Slides area: Select which slides to export as images. 
 
-Current to search the current slide. 
-From and enter a number in each of the fields provided to search from a 
specific slide to a specific slide based. 
-All to search all slides within the project. 
 

 Click Export. 
 

 In the Save File In window, select a folder to save the image files in. 
 

 Click Save. 
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Publishing Locations (New in ViewletQuiz3.1) 
In order to resolve possible conflicts that might occur when publishing the same project 
from different computers, ViewletQuiz3.1 now offers the ability to create a file 
(publish.dat) to list the publishing locations available for the project. This file can be 
“transported” with the source file when publishing from different computers. 
 
To create a publishing locations data file: 
 

 Select File > Export > Publishing Locations from the Menu bar. 
 

 In the Save File In window, select a folder to save the “publish.dat” file in. 
 

 Click Save. 
 

 An Information window displays. Read the information in it and click OK. 
 

 
When publishing your project from different computers, import the “publish.dat” file into 
the project while working the “different” computer. 
 
 
 

Import Options 
 

 
 

 Import Slides 
 Text for Translation 
 Publishing Locations (New in ViewletQuiz3.1) 
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To import slides (from another vie project): 
 

 Select a thumbnail as an insertion point for imported slides. Imported slides will 
be inserted after the selected slide. 
 

 Select File > Import > Import Slides from the Menu bar. 
 

 In the Import Slides window, click Browse. Locate and select a VIE file to load 
into the preview window. 
 

 Select the slide or slides to import. 
 

Importing Slides with Different Sizes (New in ViewletQuiz3.1) 
ViewletQuiz3.1 now allows you to import slides from projects with different slide sizes. In 
previous versions, if you wanted to import slides from one project into another, the slide 
size had to be the same in both projects. Now, if ViewletQuiz3.1 detects a difference in 
size, a Slide Alignment window displays with options for “matching up” the slide sizes for 
consistency when importing slides of a different size into your current project. 
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 If the slides you select to import are a different size, the Slide Alignment window 
displays requiring you to make some additional selections: 
 

o In the New Size area, select: 
 
-Project Size: This option will resize the imported slides to match the size 
of the current project. 
 
-Imported Slide Size: This option will resize the current project to match 
the size of the imported slides. 
 

o In the Imported Slides Alignment area, if you selected the Imported Slide 
Size option in the New Size area, select an alignment option for the 
imported slides: 
 
-Scale to Fit: This option will scale the imported slides to “best fit” the 
current project’s slide size and center the image on the slides.  
 
 

You must use the “Scale to Fit” alignment option if the imported slides are “larger” then 
the slide size of the current project. 
 
 

-Align Slide: This option will retain the original size of the imported 
slides, but will align the image on the slide based on your alignment 
selection.  

 
 Click OK and the slides will be imported into the current project. 

 
 
To import text for translation: 
 

 Select File > Import > Text for Translation from the Menu bar. 
 

 The Import Text window displays. Locate the text translation XML file. This is the 
file previously created from this Viewlet when using the “Export > Text for 
Translation” option. 
 

 Click Open. 
 

 If an Information window displays, click OK. 
 
In order to use the “Import > Text for Translation” option, you will have to create an XML 
file for this SAME Viewlet using the “Export > Text for Translation” option. 
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Publishing Locations (New in ViewletQuiz3.1) 
In order to resolve possible conflicts that might occur when publishing the same project 
from different computers, ViewletQuiz3.1 now offers the ability to create a file 
(publish.dat) to list the publishing locations available for the project. (See the “Export 
Options” section of this chapter for information on creating a “publish.dat” file.) This file 
can be “transported” with the source file when publishing from different computers. 
 
 
To publish a project from a different computer using the publish.dat file: 
 

 Select File > Import > Publishing Locations from the Menu bar. 
 

 The Import Publishing Locations window displays. Click the Browse  button. 
 

 Locate the publish.dat file previously created when working on your project on 
the original computer used to publish it. 

 
In order to use the “Import > Publishing Locations” option, you must first create a 
“publish.dat” file on the computer the project was originally published from by using the 
“Export > Publishing Locations” option. 
 
 

 Click Open. 
 

 Back in the Import Publishing Locations window, a list of available publishing 
locations display. Select the publishing location to use to publish the project by 
clicking the check box next to the desired location. 
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 Click OK to import the selected publishing locations in ViewletQuiz3.1 to use for 
the current project. 

 
Once you’ve imported the desired publishing locations for your project, click the “Publish 
Viewlet” button and the selected publishing locations will be available in the “Location” 
list. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Project Properties 
ViewletQuiz3.1 allows you to set up default properties for all of your Viewlet projects. 
These project properties may be modified on a project per project basis. The project 
properties set up in the Project Properties are used when the project is published.  
 

 
 
Project properties include: 
 

 Viewlet Profile 
 Sound Quality 
 Image Quality 
 Timing 
 Viewlet Options 
 Scoring Options 
 Packaging 
 Language 
 Flash 
 ViewletSkin 
 HTML Frame 

 
 
To set up project properties: 
 

 Select Project > Project Properties from the Menu bar. 
 

 In the Project Properties window, set up options for your project as needed. 
 
 
To save project properties as default settings: 
 

 Select Project > Project Properties from the Menu bar. 
 

 In the Project Properties window, edit the properties as desired. 
 

 Click the Save as Default Properties  button. 
 

 Click OK to close the Project Properties window. 
 

 
The ”Save As Default Properties” button does NOT save other changes to the project, only 
edits made in the “Project Properties” window. 
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Viewlet Profile – Project Properties 
Information entered in the Viewlet Profile section of the Project Properties window will be 
embedded into the Viewlet. 
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To set up Viewlet Profile details: 
 

 Select Project > Project Properties from the Menu bar. 
 

 Select Viewlet Profile from the left navigation menu. 
 
 
In the Viewlet area: 
 

 Enter a Title. This information will display in the browser’s title bar when the 
Viewlet is played back and will also be included in the Viewlet’s metatag 
information. 
 

 
 

 Enter a Description. This information will be included in the Viewlet’s metatag 
information. 

 
 
 
In the Author area: 
 

 Enter an author Name. 
 

 Enter an Email. 
 

 Enter additional Comments. 
 
 
Use the “Author” information to promote your Viewlet. The author’s name, email and 
comments display Viewlet’s information window. 
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In the Company area: 
 

 Enter a Company name. 
 

 Enter a Department. 
 

 Enter a company Web Site. 
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Sound Quality – Project Properties 
The sound quality selected in the Sound Quality section of the Project Properties window 
will be what is used when the Viewlet is published. 
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To select Sound Quality options: 
 

 Select Project > Project Properties from the Menu bar. 
 

 Select Sound Quality from the left navigation menu. 
 

 Select one of the sound quality options: 
 

o CD quality: Highest sound quality option, which is recommended for 
music and subtle audio effects. Results in biggest file size. 
 

o High quality: This is the second best sound quality choice, which is 
suitable for good qualify audio effects and high quality voice-overs. Best 
choice for viewers using high speed or network connections. 
 

o Standard quality:  This is the third best sound quality choice, which is 
recommended for average voice narration quality. Results in lowest file 
size possible (with projects containing audio) and is suitable for most 
bandwidths. 
 

o Strip all sounds: Removes all sound when publishing the project. 
 

o Use stereo sound (default): Publishes audio using “stereo” quality 
sound, if applicable. 

 
 
The sound quality selection you make in the “Project Properties” will not affect the sound 
in the “pre-published” source vie file. 
 
 

ViewletQuiz3.1 User Manual Page 210 March 2009 



 
 
 

Image Quality – Project Properties 
The image quality select in the Image Quality section of the Project Properties window 
will be the setting used when the Viewlet is published. 
 

 
 
To select Image Quality options: 
 

 Select Project > Project Properties from the Menu bar. 
 

 Select Image Quality from the left navigation menu. 
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 There are several image settings to choose from. Select the radio button next to 
the image quality of your choice: 
 

 
o Highest Quality:  This option is best suited for photographic quality 

images, but results in the biggest file size. 
 

o High Quality: This selection is recommended for images created in 
graphic design software and for lossless images.  Results in a file size 
best suited for high speed connections. 
 

o Medium Quality:  This is the default setting for all professional training 
and online help content. Acceptable file size for most connections. 
 

o Low Quality: This selection creates the smallest file size by reducing the 
image quality as much as possible. Not recommended for professional 
demonstrations, but is optimized for dial-up connections. 

 
The selection made for image quality in the “Project Properties” window will not affect the 
image quality of the source file. 
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Timing – Project Properties 
In the Timing section of the Project Properties window, you can set minimum defaults for 
timing features throughout your project. These settings serve as a baseline for your 
project and may be modified on a slide-per-slide or object-per-object basis, where 
applicable, as needed. 
 

 
 
To set up Timing options: 
 

 Select Project > Project Properties from the Menu bar. 
 

 Select Timing from the left navigation menu. 
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In the Minimum Slide Duration area: 
 

 Enter a value for the minimum number of seconds a slide will be displayed. 
 
In the Reading Speed area: 
 

 Enter a default reading speed (words per minute) for your project. 
 
 
Changing the reading speed maintains the timing on slides, including manual gaps added 
at the end of the slide. 
 
 
 
In the Introductory Delay area: 
 

 Enter a default delay (in seconds) before a message object is displayed. 
 
In the Timing Links area: 
 

 Select the Maintain Timing Links check box to automatically add and maintain 
timing between elements along the Timeline while editing a project. For more 
information on “Timing Links”, see the Timeline Tab chapter. 
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Viewlet Options – Project Properties 
In the Viewlet Options section of the Project Properties window, you may set up 
additional miscellaneous features for your published Viewlet. 
 

 
 
To set up Viewlet Options: 
 

 Select Project > Project Properties from the Menu bar. 
 

 Select Viewlet Options from the left navigation menu. 
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In the Login Options area: 
 

 Select the option to require viewers to login before viewing your Viewlet. 
 

 Select the password option and enter a password (that you will provide to 
viewers) in the password field. 

 
In the Display Options area: 
 

 Select the option to display Table of Contents when the Viewlet is viewed. 
 

 
Status Bar Options (New in ViewletQuiz3.1) 
There are now additional options (new in ViewletQuiz3.1) to select if you select the 
Display Status Bar option in Project Properties window. 
 
 

 Select a Status Bar to be displayed as the Viewlet is playing. Select additional 
options for the status bar as desired: 
 

o Display Quiz Progress: Displays progress of the Viewlet as it plays. 
Requires at least one question slide. 
 

o Display Quiz Score: Displays the current score. Requires at least one 
scored question. 
 

o Display Time Remaining: If the Viewlet is set with a time limit, the 
remaining time displays. 
 

 Select the display score option if you want the “final” score displayed at the end 
of the Viewlet. 
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In the Soundtrack area: 
 

 Click the Load Soundtrack  button to locate and select a sound file that will 
play in the background when the Viewlet plays. 
 

 To remove a soundtrack, click the Delete Soundtrack  button. 
 
 
The Viewlet’s background soundtrack will continue to play asynchronously even if the 
slide contains an interactive zone.  
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Scoring Options – Project Properties 
The Scoring Options section of the Project Properties window offers scoring selections 
for your Viewlet project. 
 

 
 
 
In the Scoring Options area: 
 

 Select a Pass / Fail percentage and its value in the field provided. 
 

 Limit the amount of time the viewer has to answer a question in the fields 
provided. 
 

 Select Allow Repeat if you will allow the viewer to play the Viewlet again. 
 
You can set a global “on time out” event by selecting an action to occur in the “Actions to 
perform when the Viewlet time limit is reached” area of the Scoring Options section. The 
action triggers when the Viewlet’s global time limit is reached. 
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Packaging – Project Properties 
The Packaging section of the Project Properties window offers additional publishing 
selections for your Viewlet project. 
 

 
 
To select additional Viewlet file Packaging options: 
 

 Select Project > Project Properties from the Menu bar. 
 

 Select Packaging from the left navigation menu. 
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In the Standalone Projector area: 
 

 Select options for creating “standalone Viewlets” that play in their own viewer 
(according to the operating system selected). 
 

 Select the Play executable file fullscreen if you want the standalone Viewlet to 
launch fullscreen (filling the entire viewing area of the user’s monitor) when 
played. 

 
 
In the Miscellaneous area: 
 

 Select the Create a zip file option to create a copy of the Viewlet files contained 
in a zip file. 
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Language – Project Properties 
In the Language section of the Project Properties window, you may set default language 
preferences for your Viewlet. 
 

 
 
To set up Language details: 
 

 Select Project > Project Properties from the Menu bar. 
 

 Select Language from the left navigation menu. 
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In the Viewlet language area: 
 

 By default, the compiling language used by ViewletQuiz3.1 is the same as your 
computer’s operating system. To change it, select a new language from the list. 

 
To change default language or text details for various Viewlet panels: 
 

 Login Panel: If you require viewers to log into the Viewlet, you can change the 
text displayed in the login panel in the fields provided. 
 

 Table of Contents Panel: If you choose to display a Table of Contents with the 
Viewlet, you may edit this panel’s text in the fields provided. 
 

 Results Panel: If your Viewlet is scored, you may modify the text that displays in 
the results panel in the fields provided. 
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Flash – Project Properties 
In the Flash section of the Project Properties window, you may set up your default Flash 
settings for your Viewlet. 
 

 
 
To set up Flash defaults: 
 

 Select Project > Project Properties from the Menu bar. 
 

 Select Flash from the left navigation menu. 
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In the Size area: 
 

 Enter a value for the final Width and Height of your SWF file, or 
 

 Select the Scale to Fit Web Page option. 
 
In the Options area: 
 

 Select additional options for your Flash file including: 
 

o Compress Movie: Recommended for smaller file size. 
 

o Loop Mode: Recommended for tradeshow Viewlets to play continuously. 
 

o Reduce Flash Context Menus: Displays abbreviated right click Flash 
shortcut menu options. 
 

o Rapid Fading Effects on Messages: Fades message objects in / out on 
slides. 
 

o Local Access Mode: Allows Viewlet to have access to local files. 
 
Disable JavaScript to Flash Interface (New in ViewletQuiz3.1) 
If your Viewlet contains JavaScript function, they may conflict with Flash. Now, in 
ViewletQuiz3.1, you now have a feature (found in the Project Properties window in the 
“Flash” section) that will allow you to avoid such conflicts by selecting the Disable 
JavaScript to Flash Interface option. 
 

 
 

o Disable JavaScript to Flash Interface: Select this option if your Viewlet 
contains JavaScript functions that might conflict with the Flash interface. 
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n the Preloader area: 
 

 Select Display a waiting animation while the Viewlet is being loaded option 
is you want a Preloader animation to display while the Viewlet streams in the 
background. 
 

 If a Preloader is selected, select how long the Preloader will “wait” by selecting a 
radio button next to the desired option. 

 
 
In the Animated Extras area: 
 

 To display a SWF movie before the Viewlet plays and/or after the Viewlet is 

played, click the Load Movie  folder next to the Beginning and/or Ending 
field. Locate the SWF movie, select it and click Open. 
 

 To delete a Beginning and/or Ending SWF movie file, click the Delete Movie  
button next to the Beginning and/or Ending field. 
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ViewletSkin – Project Properties 
 In the ViewletSkin section of the Project Properties window, you may select a wrapper 
that will display around your Viewlet. 
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To select a ViewletSkin: 
 

 Select Project > Project Properties from the Menu bar. 
 

 Select ViewletSkin from the left navigation menu. 
 

 Select a ViewletSkin from the list. Once a skin is selected, you may preview it in 
the preview area below the list. 

 
 
ViewletSkin Embedded Fonts (New in ViewletQuiz3.1) 
To insure your Viewlet “looks” the same across multiple platforms, ViewletQuiz3.1 has a 
new feature that allows you to use “embedded fonts” in your ViewletSkin. This feature 
will standardize the look of your Viewlet across platforms, but will also significantly 
increase the size of your Viewlet file. 
 
To embed fonts in your ViewletSkin: 
 

 Select your ViewletSkin from the available list. 
 

 In the Options area, select the Use Embedded Fonts option to embed fonts in 
the selected ViewletSkin. 
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HTML Frame – Project Properties 
In the HTML Frame section of the Project Properties window, you may choose and 
modify the HTML Frame that is published with your Viewlet. 
 

 
 
To select HTML Frame options: 
 

 Select Project > Project Properties from the Menu bar. 
 

 Select HTML Frame from the left navigation menu. 
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To select the frame that is published with your project: 
 

 In the HTML Frame section of the Project Properties window, select a default 
frame from the list. 
 

 The frame will be added to the Files field area below the list. 
 
 
To add a custom frame: 

 In the HTML Frame section, click the Add  button.  
 

 In the HTML Frame Properties window, enter a Name for the new frame. 
 

 Click OK. 
 

 Double click inside the “coding” field area. In the Resource Properties window 
that displays, edit as needed. 
 

 Click OK. 
 
 
 
To edit or delete an HTML frame: 
 

 Select an HTML Frame from the list. 
 

 To modify an HTML Frame: 
 

o Click the Modify  button. 
  

o In the HTML Frame Properties window, edit the Name and click OK. 
 

o Double click in the “coding” field. 
 

o In the Resource Properties window, edit as needed and click OK. 
 

 
 To delete an HTML Frame: 

 
o Select a frame from the list. 

 

o Click the Delete  button. 
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A warning displays if the HTML Frame entry point is not set correctly. 
 
 
To Save Project Properties 
Once all of the options are set up in the Project Properties window, click OK. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Previewing a Viewlet 
There are various ways to preview your Viewlet project. For example, any place you see 
these buttons: 
 

 
 
 
You may use them to navigate through your project while inside ViewletQuiz3.1. These 
buttons will allow you to go to the: 
 

 First Slide  
 

 Previous Slide  
 

 Next Slide  
 

 Last Slide  
 

 
You can preview the slide background soundtrack, audio attached to objects, cursor click 
sounds and key click background frame sounds within ViewletQuiz3.1 without publishing 
the project. 
 
 
Additionally, you may access preview options: 
 
From the Timeline: 
 

 
 

 Click the Preview button at the top right of the Timeline to preview the project, or 
 

 Click the down arrow and select a preview option from the menu list. 
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From the Menu bar: 
 

 
 

 Select Project from the Menu bar. 
 

 Select a preview option: 
 

o Preview Current Slide: Plays the current slide inside ViewletQuiz3.1. 
 

o Preview From Current Slide: Plays the project inside ViewletQuiz3.1 
from the selected slide to the end of the project. 
 

o Preview All Slides: Plays the entire project while inside ViewletQuiz3.1. 
 

o Preview in Browser: Quickly compiles (publishes) the file to SWF 
(Flash) format and launches it (from a temp folder) in a browser. 

 
 

Displaying the informational “About” window during Viewlet playback pauses the Viewlet. 
Closing the window returns the Viewlet to play mode. 
 
 
After publishing a project: 
 

 Select Project > Publish Viewlet from the Menu bar. 
 

 Complete the information in the windows that display to publish your project. 
 

 In the last Publish Viewlet window, click the View button to preview the published 
Viewlet. 

 

ViewletQuiz3.1 User Manual Page 232 March 2009 



 
 
 
Outside of ViewletQuiz3.1: 
Once you’ve published a Viewlet file, a folder containing the published files is created. 
Locate this folder and open it. Double click the HTML or the SWF file to preview the 
Viewlet. 
 
If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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Publishing a Viewlet 
In order to create the final Flash Viewlet your audience will see, you must publish your 
Viewlet source (vie) file. ViewletQuiz3.1 allows you to publish your Viewlets to a several 
locations, some are preinstalled with the program while others you can add to the list. 
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To add a publishing location to the list: 
 

 Click the Add  button. 
 

 Select a location type from the menu list that displays: 
 

 
 
 

o Local or Network Folder: This includes your hard drive, a network drive, 
or any other external file storage device (such as a floppy disk, CD, jump 
drive, etc.). 
 

o FTP Server 
 

o Qarbon ViewletCentral 
 

o Corporate ViewletCentral 
 

 If, for the publishing location you select: 
 

o Add Local or Network Folder: This includes folders on your hard drive, 
a network drive or any other external file storage device (floppy disk, CD, 
jump drive, etc.). 
 
-In the Select Folder window, locate and select a folder from a local or 
network drive. 
 

-Click the Select Folder  button. You will be returned to 
the Publish Viewlet window and the new local or network folder will be 
displayed in the “Location” list. 
 

 
When selecting a publish folder, if an “Allow Publishing to Folder” window displays, read 
the information and click “Yes” to create the location. 
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o FTP Server: The FTP Server window displays. Make sure the required 
fields and selections are complete: 
 
-Name: This is the name that will display in the “Location” list for the FTP 
Server. 
 
-Server: This is the path to your FTP Server. (for example: 
ftp.qarbon.com). 
 
-Directory: This is the folder on the server where you will publish your 
files. 
 
-Login: Enter the login information for your server. 
 
-Password: Enter the password required to access your server. 
 
-Port: This is the port used by the server, by default it is “21”. 
 
-Passive: Select the Passive mode is required to get through some 
firewalls option is your server is behind a firewall. 

 
 
When configuring an FTP Server for a publishing location, click the “Text Connection” 
button. An information window will display letting you know if the connection passed. 
 

 
 

-Click OK to save the information. The FTP Server will be added to the 
“Location” list in the Publish Viewlet window. 
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o Qarbon ViewletCentral: The Qarbon ViewletCentral window displays. 
 

 
 
-In the Email Address field, type in the email address used when signing 
up for Qarbon ViewletCentral. 
 
-In the Password field, type in the applicable password to sign into 
ViewletCentral. 
 
-Click OK to save this information. The Qarbon ViewletCentral publishing 
location is added to the list in the Publish Viewlet window.  
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o Corporate ViewletCentral: The Corporate ViewletCentral window 
displays. This option is available to organizations who subscribed for a 
Self-Hosted ViewletCentral. Fill in the following fields with information 
provided by your ViewletCentral Administrator: 
 
-In the Name field, type in the name of the ViewletCentral account. 
 
-In the Server field, type in the server information. 
 
-In the Login field, type in the login used to access ViewletCentral. 
 
-In Password field, type in the password required to access 
ViewletCentral. 
 
-Click OK to save the information. The Corporate ViewletCentral 
publishing location is added to the list in the Publish Viewlet window. 
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To edit a publishing location: 
 

 Select the desired location from the list. 
 

 Click the Modify  button. 
 

 Make edits in the windows that display as needed. 
 

 Click OK to save edits and to return to the Publish Viewlet window. 
 
 
 
To move a publishing location up or down in the list: 
 

 Select the desired publishing location. 
 

 Click the Move Up  button to move the selection up in the list. 
 

 Click the Move Down  button to move the selection down in the list. 
 
 
 
To remove a publishing location from the list: 
 

 Select the desired publishing location. 
 

 Click the Delete  button.  
 

 A Warning window displays. Read the information and click Yes to confirm the 
deletion. The selection is removed from the list. 
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If you remove all of your publishing locations, the next time you try to publish your 
project, you will be prompted to add a new publishing location. 
 

 
 
To publish a project to a local or network folder: 
 

 Make sure you’ve completed all your edits and save your file. 
 

 Select Project > Publish Viewlet from the Menu bar. 
 

 The Publish Viewlet window displays. Select a local or network publishing 
location from the “Location” list. 
 

 Click Next. 
 

 Select a “Reporting” or “Learning Management System” from the list:  
 

o None: Select this option if you do not have any reporting or LMS options.  
 

 
 

o Qarbon Email Reporting System: Select this option to have an email of 
Viewlet results sent to the email or emails specified. 
 
-Enter an email address in the field provided. 
 
-Select HTML Format to send email results in HTML format. 
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When using multiple email addresses, separate each email with a semi-colon. 
 

o SCORM 2004 Learning Management System:  Select this option to 
publish files to meet SCORM 2004 compliancy for your LMS. 
 

 
 
Create a ZIP File for SCORM 2004 LMS (New in ViewletQuiz3.1) 
When publishing files to a SCORM 2004 compliant LMS, you now have the option to 
allow ViewletQuiz3.1 automatically create a zip file with all the published files you will 
need for the Viewlet to play back on your LMS. 
 

-Select the Create a zip file option to have ViewletQuiz3.1 create a zip 
file containing copies of all of the published files when using the SCORM 
2004 LMS option. 
 
 

o SCORM 1.2 Learning Management System: Select this option to 
publish files to meet SCORM 1.2 compliancy for your LMS. 
 

 
 

Create a ZIP File for SCORM 1.2 LMS (New in ViewletQuiz3.1) 
When publishing files to a SCORM 1.2 compliant LMS, you now have the option to allow 
ViewletQuiz3.1 automatically create a zip file with all the published files you will need for 
the Viewlet to play back on your LMS. 

 
-Select the Create a zip file option to create a zip file containing copies of 
all the published files when using the SCORM 1.2 LMS option. 
 
-Select Include Saba compatibility features if applicable for compliancy 
and compatibility requirements for your LMS. 
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o AICC Learning Management System:  Select this option to publish files 
to meet AICC compliancy requirements for your LMS. 
 

 
 
 

 Once you’ve selected a “Reporting” or “Learning Management System” option 
from the list, click Next. 
 

 In the Publish Viewlet window, a “Folder Publish Complete” information screen 
will display once the Viewlet has been successfully published. 
 

 
 

o Click the View button to view the Viewlet in your default browser. 
 

o Click the Browse button to view the published project files. 
 
If your computer displays the “path” to folder when displaying operating system windows, 
when you click the “Browse” button, a path to the folder containing the published project 
files displays. Use this information to quickly locate these files when needed. 
 
 

o Click Finish to close the Publish Viewlet window once publication is 
complete. 
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To publish a project to a Qarbon ViewletCentral or Corporate ViewletCentral account: 
 

 Make sure you’ve completed all the edits to your project and save the file. 
 

 Select Project > Publish Viewlet from the Menu bar. 
 

 The Publish Viewlet window displays. Select a “ViewletCentral” account from the 
publishing location list. 
 

 Click Next. 
 

 The “Reporting Options” screen displays. Keep the default selected and click 
Next. 
 

 The “ViewletCentral – Space Available” screen displays. Read the information 
about the space available in the ViewletCentral account. Then, click Next. 
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 Once the project a published, a “Publish Complete” screen displays.  
 

 
 

o In the Viewlet URL area, a path to the Flash file displays. Click the View 
button next to this field to launch the Viewlet in your default browser. 
 

o In The Viewlet statistics can be viewed at the following URL:  field, a path 
to an information page showing your Viewlet’s stats displays. Click the 
View button next to this field to go to your Viewlet’s stats’ page on 
ViewletCentral. 
 

o Click Finish to close the Publish Viewlet window. 
 
 
Each time you publish your project, as long as the file name remains the same, the Viewlet 
will be updated on ViewletCentral. 
 
 

ViewletQuiz3.1 User Manual Page 244 March 2009 



 
 
 
To view publishing information for your Viewlet: 
 

 Select Project > Display Publishing Profile from the Menu bar. 
 

 
 
 

 In the Publishing Profile window that displays: 
 

o In the Location area, select a publishing location from the publishing 
history list. 
 

 
 

o In the General area, review the Viewlet’s publishing information, including 
date of publishing, time of publishing and reporting type. 
 

 
 

o In the Viewlet URL area: 
 
-Click the View button to launch the Viewlet in the default browser. 
-Click the Browse button to open the folder containing the published files. 
 

o Click Close to close the Publishing Profile window. 
 
 

If you have any questions, contact us using the “Contact Us” or “Support” links on the 
home page (www.qarbon.com). Or, if you prefer, email support@qarbon.com. 
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ViewletCentral – General Information 
Are you looking for a solution for publishing your Viewlets on the Web? Why not check 
out Qarbon’s ViewletCentral. ViewletCentral is a server-based application that provides 
centralized reporting, management and deployment of your valuable Viewlets and other 
Flash-content files. 
 

 
 
To discover all the features of ViewletCentral, you can immediately open a Free account, 
which will give you ample disk space to store your Viewlets. For more information about 
ViewletCentral information, please visit our web site at: 
 
http://www.qarbon.com/presentation-software/viewletcentral/ 
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Viewlet Central Self-Hosted Server 
When you purchase a Self-Hosted ViewletCentral server license, you not only get all of 
the same features that the Qarbon-Hosted version has, but you gain the ability to 
perform account and project management activities easily and efficiently from one single 
location.  
 
http://www.qarbon.com/presentation-software/viewletcentral/host_server.php 
 
If you are interested in learning more about Self-Hosted ViewletCentral, please contact 
our sales group (sales@qarbon.com) or support (support@qarbon.com). 
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Support and Self-Help Options 
Qarbon offers a support plan to fit your needs. Standard Support is offered to all 
customers at no charge. You can also purchase Platinum Membership, which is a 
software maintenance plan with enhanced support benefits. 
 
For more information on support plans and options available, visit us online at: 
 
http://www.qarbon.com/help/support_plans.php 
 
Qarbon also offers users online, self-help resources in the form of Viewlet tutorials, user 
manuals and FAQs. For access to these self-help aids, please visit our site at: 
 
http://www.qarbon.com/help/ 
 
You may also contact support@qarbon.com with any support questions you may have. 
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Webinars and Training Opportunities 
Take advantage of all the features in ViewletQuiz3.1 by signing up for Qarbon’s training 
classes. Learn how to get the most out of your Viewlet authoring tool to create stunning 
Flash demonstrations and interactive movies in no time. For information on how to learn 
from the Viewlet experts, visit us online at: 
 
https://qarbon.on.intercall.com/confmgr/ 
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Sales and General Customer Service 
Customer support is our top priority at Qarbon! Please feel free to contact our Sales or 
Support staff at any time if you have ANY ViewletQuiz3.1 (or other product related) 
questions or concerns or for options to discuss additional training needs. 
 
For current contact information, visit our web site: 
 
http://www.qarbon.com/about_us/contact_us/ 
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Qarbon User Forum 
Want to share ideas on Viewlet Authoring? Are you hunting for a specific authoring trick 
to take your Viewlets to the next level? Qarbon offers a Viewlet user forum just for you. 
It’s free to join and free to use. It’s a great place to meet other Viewlet enthusiasts from 
across the globe and spotlight your own great Viewlet ideas too!  
 
Go to: http://forum.qarbon.com/ 
 
Sign up and join in the fun! 
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