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Introduction – A Note About This Guide 
Welcome to the ViewletCentral Self-Hosted user guide.  
 
Qarbon’s products and services are very flexible. So, as you work in your authoring app 
(ViewletBuilder or ViewletQuiz) or within the ViewletCentral Self-Hosted web-based 
interface, you will find there are usually a few different ways to access the same features 
and tools. Why is this important to you? 
 
Qarbon designs its products and services to provide multiple workflow options to meet 
many different authoring styles. So, for example, if you are a newbie, you might feel 
more comfortable working with menus and toolbars. As you gain experience, you may 
realize using keyboard shortcuts, right click menus or even double click actions for 
instant dialog access helps you ‘speed things up’ – use what’s right for you! 
 
That said, we need to point out that this guide provides detailed instructions for working 
within your Qarbon authoring app in combination with your ViewletCentral Self-Hosted 
account. But, the examples shown throughout this guide are NOT all inclusive, however, 
they should provide you with a solid foundation as you create, share, design, edit, save, 
publish and deploy your eLearning Viewlet assets. 
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Getting Started 
This Getting Started chapter provides an overview of ViewletCentral Self-Hosted along 
with important information to help you familiarize yourself with this service. 
 

WHAT IS VIEWLET CENTRAL SELF-HOSTED 

 
 
ViewletCentral Self-Hosted is a highly secure, server-based system where you can 
perform account and project management activities easily and efficiently from one single 
location. It allows Viewlet project sharing and publishing directly to your Self-Hosted 
server.  
 
The ViewletCentral Self-Hosted solution offers via: 
 
 
ViewletBuilder and ViewletQuiz  
 

• Viewlet project creation and editing 
• Project storage with valuable check-in and check-out tools (project sharing) 
• Publishing directly to the ViewletCentral Self-Hosted server 

 
 
Online Web Interface 

• A convenient landing page for quick access to published Viewlets (My Viewlets) 
• Student assignment and tracking (My Assignments) 
• Utilization and statistical data (My Dashboard) 
• Certificate template design (My Certificates) 
• Project (source file) audit trails for information and history (My Projects) 
• User profiles and subscription management (My Account) 
 
 

Each Viewlet published to ViewletCentral Self-Hosted has its own unique URL so 
viewers can access your Viewlet content online from an LMS, web links, chat windows, 
emails, social networks, etc. Every time you republish your Viewlet to ViewletCentral 
Self-Hosted, the newly published Viewlet will automatically be available to viewers 
without sacrificing the integrity of the original link. A publishing history provides an audit 
trail for each Viewlet for revision history review.  
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TECHNICAL REQUIREMENTS 
In order to run ViewletCentral Self-Hosted, it is necessary to purchase the applicable 
software to run on the users’ server. ViewletCentral Self-Hosted is normally installed on 
a distinct server within the organization’s network and provides a secure centralized 
storage area for Viewlets project files. 
 

Server Software Requirements 
Currently, Microsoft Windows and Linux operating systems are supported (see versions 
below). On both, Java SE (version 6) Runtime Environment (JRE) is required to run 
ViewletCentral Self-Hosted. An existing SMTP mail server and PostgreSQL database 
server (version 8.3 or newer) are also required (either on the same server or on the 
network). 
 
Microsoft Windows 

• Windows Server 2008 (Standard or Enterprise) 
• Windows Server 2003 (Standard or Enterprise) 
• Windows 2000 Server (Standard or Enterprise) 

 
Linux 

• Mandrake version 8 and up 
• Red Hat version 8 and up 
• SuSE version 8 and up 
• Debian version 2.2 and up 
• Gentoo version 1.2 and up 

 

Hardware Requirements 
• Server Processor Type: 

o Intel Pentium 4 or Xeon 
o AMD Athlon or Opteron 

• Server Processor Speed: 2GHz or more* 

• Server Memory: 1GB or more 

• Server Storage: 100GB or more** 
*Dual Processors recommended 
**External backup and internal RAID recommended  
 

Client Requirements 
• Administration: The ViewletCentral Management Client is web browser-based 

and supports any client platform that can run Microsoft Internet Explorer 5.x (and 
up), Netscape 6.x (and up) or Firefox 1.x (and up) browsers. 

• Authoring apps: ViewletBuilder8, ViewletBuilder7, ViewletBuilder6, 
ViewletBuilder5 (any version), ViewletBuilder4 Pro (version 4.4.9 or later), 
ViewletQuiz5, ViewletQuiz4, ViewletQuiz3, ViewletQuiz2 
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ViewletCentral Self-Hosted is sold on a per-server license model and includes the 
ViewletCentral Server Application, Management Client and installation instructions. Each 
additional server running ViewletCentral Self-Hosted requires the purchase f a license of 
the ViewletCentral Server Application. 

Visit us online for the most recent information regarding ViewletCentral Self-Hosted 
features, limits and supported applications as well as client-side technical requirements. 
 

 
Contact us at 1-855-VIEWLET or through our Contact Form for current pricing and 
related ViewletCentral Self-Hosted information. 
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Admin Account Access 
This Admin Account Access chapter provides information on accessing ViewletCentral 
Self-Hosted from the web-based interface. 
 

INITIAL ADMINISTRATOR (WEB-BASED) ACCESS 
When the ViewletCentral Self-Hosted server is first installed, only a single user account 
for the administrator is provided. The default login information is: 
 
Email: change@me.com 
Password: admin 
 
To prevent unauthorized access, we suggest you change the administrator email and 
password as soon as possible. To do this: 
 

1. Make sure you are connected to the Internet (or your internal ViewletCentral Self-
Hosted server, whichever is applicable). 

2. Use a web browser to access the login page for your ViewletCentral Self-Hosted 
account. This URL can be provided to you by the person responsible for installing 
your ViewletCentral client. 

3. Enter in the default login information (email: change@me.com; password: admin) 
and click the Login button. 

4. On the My Account > Users page that displays, click the Edit Account (pencil) 
icon inline with the account administrator’s name. 

5. On the page that displays, modify the administrator’s information as needed. 

6. Click the Update User button. 

7. When the information page displays, click the Back button to return to the list of 
users. 

Further information about users, groups and profiles management is discussed later in 
this guide in the My Account section. 
 
LOGGING OUT OF VIEWLETCENTRAL SELF-HOSTED 
Once you are finished working in your ViewletCentral Self-Hosted account, it’s 
recommended (as a best practice) that you log out BEFORE closing your browser. Click 
the Logout link in the navigation menu.  
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Accessing ViewletCentral Self-Hosted 
ViewletCentral Self-Hosted allows you to: 

• Check Viewlet project source files in and out from your authoring app 
• Publish Viewlets directly to your account from your authoring app 
• Manage users within your account 
• Perform other various user management and Viewlet hosting tasks 

 
 

BROWSER TAB (VIEWLETBUILDER OR VIEWLETQUIZ) ACCESS 
In order to check projects in and out of ViewletCentral Self-Hosted, you will need to 
establish an online connection to your account via the Browser tab. You can also 
perform other tasks from this view such as publishing your Viewlets to your server. 

1. Make sure you are connected to the Internet (or your internal ViewletCentral Self-
Hosted server, whichever is applicable). 

2. Launch your Qarbon authoring app (ViewletBuilder or ViewletQuiz). 

3. Open your Browser tab. If it is not displayed, select View > Tabs > Browser from 
the menu. 

4. Right click on the ViewletCentral Self-Hosted icon and select Properties from the 
shortcut menu. 
 

 
 

5. In the window that displays, enter your information in the requested fields (Name, 
Server, Login, Password). 

6. Optional: Select the Secure Connection check box, if applicable. 
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7. Click OK. Once authenticated, your access information will be saved and you will 
be returned to your previous view. 

Note: Adding ViewletCentral Self-Hosted to the Browser tab will make it accessible in the Publishing Dialog 
and visa versa. 

 

PUBLISHING DIALOG (VIEWLETBUILDER OR VIEWLETQUIZ) ACCESS 
To publish your Viewlets to your ViewletCentral Self-Hosted account from within your 
authoring app, you will need to configure it as a publishing target from inside the 
Publishing Dialog. 

1. Make sure you are connected to the Internet (or your internal ViewletCentral Self-
Hosted server, whichever is applicable). 

2. Launch your Viewlet authoring app (ViewletBuilder or ViewletQuiz). 

3. Open a project. You will need to do this step in order to have access to the 
Publishing Dialog whether or not you are publishing the project. 

4. Select Project > Publish Viewlet from the menu. 

5. In the Publish Viewlet window that displays, click the Add (green plus sign) 
button open the list of publishing targets. 
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6. Select ViewletCentral Self-Hosted (previously referred to as ‘Corporate 
ViewletCentral’) from the list. 

7. In the window that displays, enter your information in the requested fields (Name, 
Server, Login, Password). 

8. Optional: Select the Secure Connection check box, if applicable. 
 

 
 

9. Click OK. Once authenticated, this dialog will close and your ViewletCentral Self-
Hosted server will be added to your list of publishing targets. 
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WEB-BASED ACCESS 
You will need to access your ViewletCentral Self-Hosted account from the applicable 
web page login interface. The URL for this page will be provided to you by the person 
responsible for installing your ViewletCentral client. The web interface is used to manage 
your users, groups and profiles as well as other Viewlet management tasks (not 
performed directly from your Viewlet authoring app). 

1. Make sure you are connected to the Internet (or your internal ViewletCentral Self-
Hosted server, whichever is applicable). 

2. Open your browser and enter the URL to your ViewletCentral Self-Hosted 
server’s login page. (You will need to get this information from the person 
responsible for installing your ViewletCentral client.) 

3. Enter your login information (email and password). 
 

 
 

4. Click the Login button to access your ViewletCentral Self-Hosted account. 
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Content (Project) Management 
When working in your Viewlet authoring app while connected to your ViewletCentral 
Self-Hosted account, you have access to content management tools for your own 
projects as well as those within your group (depending on access permissions). Content 
management may include: 
 

• Creating and Editing Projects 
• Project Check-In and Check-Out 
• Sharing Projects with Your Group 
• Publishing Projects 

 
Let’s take a look at each of these separately. 
 
 

CREATING AND EDITING PROJECTS 
All Viewlet project creation and editing occurs within your Qarbon authoring app. Please 
refer to your ViewletBuilder or ViewletQuiz user guide for more information creating 
Viewlets. Once you create and edit your new project, save it to your local computer. 
Then you will add the new project to your ViewletCentral Self-Hosted account 
(instructions to do this covered next). 
 

PROJECT CHECK-IN AND CHECK-OUT 
At the core of ViewletCentral Self-Hosted content management is its document 
management features. These include adding new projects, document check-in/check-out 
controls and time-stamped audit history for each project. 
 

Tree Menu & Toolbar Options (Browser View) 
Access to your ViewletCentral Self-Hosted project files is accomplished through your 
Qarbon authoring app via the Browser view. The project files and folders are displayed 
in a tree menu with icons along a toolbar (located at the top of the Browser tab) for 
working with selected items.  
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Tree Menu – Folders & Files 

 
The image above shows an example of a ViewletCentral Self-Hosted account’s Tree Menu as displayed in a 
Browser tab. The number of panes (two are shown above) and how the folders and files are displayed 
depend on the options selected in the ‘Views’ menu. 

 

To display the Tree Menu: 

1. While connected to the Internet, open the Browser tab within your Qarbon 
authoring app (ViewletBuilder or ViewletQuiz). 

2. Click on the ViewletCentral Self-Hosted icon. This will expand the files and 
folders available to you on the server. 

3. Select a folder (from the top pane). Child folders and/or project files contained 
within the selected folder will display both in the top pane as well as the bottom 
pane. 
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Toolbar Options 

 

When you have the ViewletCentral Self-Hosted icon selected, you will find various 
buttons along the top of the Browser tab available for working with folder and files in the 
Tree Menu. These buttons include: 

  Add... 
Adds new file to the server. 

  Delete 
Deletes selected file from the server. 

  Up One Level 
Moves up one folder level from the selected folder. 

  Refresh Current Folder 
Refreshes the selected folder. 

  Check the Selected Files into ViewletCentral 
Uploads/checks the selected files into the server. 

  Check the Selected Files Out of ViewletCentral 
Downloads/check the selected files out of the server. 

  Undo the Check Out of the Selected Files 
Undoes the action of checking out the selected files from the server. 
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  Views 
Provides options for how the ViewletCentral Self-Hosted folders and files are 
displayed in the Browser tab in the Qarbon authoring app (ViewletBuilder or 
ViewletQuiz). 
 

 
Options available on the ‘Views’ menu. 
 
 

Adding a New Project 
Viewlet projects are created in your Qarbon authoring app (ViewletBuilder or 
ViewletQuiz) and initially saved locally. Once saved, you can add the source file to your 
ViewletCentral Self-Hosted account. 

1. Make sure you are connected to the Internet (or your internal ViewletCentral Self-
Hosted server, whichever is applicable).  

2. Open your Qarbon authoring app (ViewletBuilder or ViewletQuiz). 

3. Display the Browser tab. If it is not displayed, select View > Tabs > Browser 
from the menu bar. 

4. Click the ‘+’ icon next to ViewletCentral Self-Hosted to expand the tree menu of 
folders available in your account. 

5. Select the folder where you want to add your Viewlet project’s source file. 

6. Click the Add (green plus) icon on the toolbar. 
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7. In the Add a file to the ViewletCentral dialog that displays: 

a. Click the folder icon to locate and select your file. 

b. Enter a title for your project. 

c. Enter a description. 

d. Enter in text for keywords (words/phrases separated by commas). 

e. Click OK. 
 

 
8. Verify the project is added to the list of files in your account projects folder. 

 
 

SHARING PROJECTS WITH YOUR GROUP 
A collaborative aspect of ViewletCentral Self-Hosted is project sharing with those in your 
group. What this means is that you can not only check out your own project files, but 
those you have access to from other team members within your group. Once a 
document is checked out, access to it is locked by other authors until the project is 
checked back in. 

1. Make sure you are connected to the Internet (or your internal ViewletCentral Self-
Hosted server, whichever is applicable).  

2. Open your Qarbon authoring app (ViewletBuilder or ViewletQuiz). 

3. Display the Browser tab. If it is not displayed, select View > Tabs > Browser 
from the menu bar. 

4. Click the ‘+’ icon next to ViewletCentral Self-Hosted to expand the tree menu of 
folders available in your account. 
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File Check Out 
Note: The instructions explain how to check out a single file from the server, but you can select multiple files 
to check out at the same time. 

1. Select the file you want to check out. 

2. Click the Check the Selected Files Out of ViewletCentral (blue down arrow) 
icon on the toolbar.  

3. In the Check Out dialog, select a location where you want to check the file out to 
on your local machine. If needed, click the Browse button to select a different 
folder location. 
 

 
4. Click OK. 

5. The file is downloaded to the selected location. 

6. Once the download is complete, a ‘padlock’ displays on the project’s icon (in the 
list) in the Qarbon app indicating the file is ‘checked out’ from the server and 
unavailable until it is checked back in.  
 

 
 

File Check In 
Note: The instructions explain how to check a single file back into the server, but you can select multiple files 
to check into the server at the same time. 

1. Select the file you want to check in.. 

2. Click the Check the Selected Files into ViewletCentral (blue up arrow) icon on 
the toolbar. 

3. Enter the changes made to the project in the Check In dialog that displays. 
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4. Click OK. The file is checked back into the server, the padlock is removed from 
the file name icon and the description of changes is added to project’s history. 

 
 

PROJECT HISTORY & PROPERTIES 
ViewletCentral Self-Hosted provides you with a vital audit trail of projects as they are 
added to the server and checked in and out. In addition, you can view the properties 
associated with folders and files on the server. 
 

Project History 
In the History dialog, you can view a versioning audit trail of your project, including 
version number, date/time stamp, author and comments (if applicable). 
 

 
 
To view a project’s history: 

1. In the Browser tab, select the ViewletCentral Self-Hosted icon to display all the 
folders and files you have access to on the server. 

2. Locate the desired file and right click on it to display its shortcut menu. 
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3. Select ViewletCentral File History... from the menu. 
 

 
4. The History dialog displays. When you are finished reviewing the information, 

Close the dialog. 

 

Properties 
The Properties dialog displays the ‘attributes’ of the selected folder or file. 

 

Folder Properties 
A folder’s Properties dialog includes an image of a folder and General Attributes (folder 
name, description and dimensions). 

 
 
To view a folder’s properties: 

1. In the Browser tab, select the ViewletCentral Self-Hosted icon to display all the 
folders and files you have access to on the server. 

2. Right click on the desired folder to display its shortcut menu. 
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3. Select Properties... from the menu. 
 

 
 

4. The Properties dialog displays. When you are finished reviewing the information, 
Close the dialog. 

Project Properties 
A project’s Properties dialog includes a thumbnail of the project’s first slide, General 
Attributes (file name, description, date/time stamp the last time the project was modified, 
size, and slide dimensions), Project Attributes (description, original creation date and 
number of slides in the project), and Managed File Attributes (version number and check 
out status). 
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To view a project’s properties: 

1. In the Browser tab, select the ViewletCentral Self-Hosted icon to display all the 
folders and files you have access to on the server. 

2. Right click on the desired file to display its shortcut menu. 

3. Select Properties... from the menu. 
 

 
 

4. The Properties dialog displays. When you are finished reviewing the information, 
Close the dialog. 

 

PUBLISHING PROJECTS 
Projects can be published directly to your ViewletCentral Self-Hosted server from your 
Qarbon authoring app (ViewletBuilder or ViewletQuiz). Keep in mind, any time you make 
any changes to your project source file, you MUST publish it again to updated the 
published files. 
 
To publish a project to ViewletCentral Self-Hosted: 

1. Make sure you are connected to the Internet (or your internal ViewletCentral Self-
Hosted server, whichever is applicable). 

2. Launch your Viewlet authoring app (ViewletBuilder or ViewletQuiz). 

3. In the Browser tab, select the ViewletCentral Self-Hosted icon to display all the 
folders and files you have access to on the server. 

4. Check out the desired project to your local machine. If prompted, save the file. 

5. Open the project (from your local machine) inside your Qarbon authoring app 
(ViewletBuilder or ViewletQuiz). 

6. Make modifications to the project as needed and save it. 

7. Select Project > Publish Viewlet from the menu. 
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8. In the Publish Viewlet window that displays, select the ViewletCentral Self-
Hosted publishing target. 
 
Note: If you do not have ‘ViewletCentral Self-Hosted’ as a publishing target, you will need to add it 
to your list. For more information, review the steps outlined in the ‘Publishing Dialog (ViewletBuilder 
or ViewletQuiz) Access’ section found earlier in this guide. 
 

9. Click the Publish button 

10. Once published, a URL displays to path to where your project is published on the 
server. Click View to play the Viewlet back from the server location, or copy the 
URL to share with others (LMS, emails, web site, social networks, chats, etc.). 

11. Close the dialog to return to your Qarbon authoring app (ViewletBuilder or 
ViewletQuiz). 

12. Close your project so that you can view your list of projects in the Browser tab. 

13. Select the file and click the Check the Selected Files into ViewletCentral (blue 
up arrow) button.  

14. In the Check In dialog, enter in the changes made to the file in the field provided. 

15. Click OK. The padlock is removed from the icon over the file name (in the list) 
indicating the project is uploaded/checked back into the server. 
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ViewletCentral Self-Hosted Views 
ViewletCentral Self-Hosted is organized into different areas: 

• My Viewlets 
• My Assignments 
• My Dashboard 
• My Certificates 
• My Projects 
• My Account 

 
Each of these areas is referred to as a view and features its own unique set of Viewlet 
management tools. 
 

NAVIGATION TIPS 

 
Most of the time when you are working in ViewletCentral Self-Hosted, navigation menus 
and buttons are straightforward. There may be times, though, when you get to a page 
within ViewletCentral Self-Hosted and it may not be obvious where you are in your 
account or how to return to a previous page, one a few levels up, etc. In these cases, 
here are some additional (and often less obvious) navigational elements you can use. 
 
Breadcrumbs 

 
As you navigate through your ViewletCentral Self-Hosted account, you will notice that 
there is a path (also known as breadcrumbs) right below the menu links. These 
breadcrumbs show you where you currently are within your account. Mouse over the 
different pages in the navigational (breadcrumbs) path and, if the cursor changes to a 
hand shape, you can click that page to revisit it. 
 
Back Button 
Another option, when you want to quickly revisit the previous page, is via a browser 
button. Simply click your browser’s Back button to reload the last page you visited in 
your ViewletCentral Self-Hosted account. 
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THE SEARCH TOOL 
While in some of the different views, you will see a search tool that will allow you to 
narrow down the list of what you are looking for.  

 
The image above shows an example of a Search tool available in a ‘drill down’ view within My Dashboard. 
Depending on your location within ViewletCentral Self-Hosted, search options will vary. 
 
 
The views included are: 
 

My Viewlets and My Dashboard Views 
In My Viewlets and My Dashboard, you can narrow down the list of Viewlets by 
performing searches by title, author or description. 

1. Type in a key word(s) in the search field. 

2. Select the search type you want to perform from the drop-down list (Title, 
Author, Description). 

3. Click the Search button to display results. 
 

My Account View 
In My Account, you can narrow down the list of users by performing searches by first 
name, last name, or email. 

1. Type in a key word(s) in the search field. 

2. Select the search type you want to perform from the drop-down list (First Name, 
Last Name, E-mail). 

3. Click the Search button to display results. 
Note: Additional Search tools may be available (in addition to those mentioned above) the further 
you drill down into pages within your ViewletCentral Self-Hosted account. 
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THE SELECT TOOL (TABLE LISTS) 

 
 
If you are working with table lists, you will see a selection tool (when available). This 
option gives you the ability to select one or more items in a list. Or, you can even select 
all or deselect all listed items too. Here’s how it works: 

1. To select one item in the list, click the check box next to the desired item. 

2. To select multiple items in the list, click the check box next to each of the 
desired items. 

3. To select all items in the list, click the top box (above the divider that’s inline with 
the column headers).  

4. To deselect all items in the list, click the top box (above the divider that’s inline 
with the column headers). Note: This will only work if ALL the items in the list are 
already selected. 

 

EXPORT DATA 
ViewletCentral Self-Hosted offers you the option of exporting utilization data and related 
details throughout the different views. If needed, you can use this tool to export this 
information out of ViewletCentral Self-Hosted and backend it to your own database 
application.  

 
 
Export to CSV 
In My Viewlets and My Dashboard you will see Export to CSV (or similar) buttons that 
will allow you to export the data on the current page out to a CSV (comma separated 
values) file. To use this feature: 

1. While in your ViewletCentral Self-Hosted account, if you need to export data on 
any of the pages while in either My Viewlets or My Dashboard, look for an export 
button. 

2. Click the Export to CSV (or similar export) button. 

3. A File Download dialog window displays. Click the Save button. 

4. In the Save As dialog window that displays, browse to the location where you 
want to save the file and click the Save button. 

5. Import the CSV file into your own database application for editing and data 
manipulation. 

 

ViewletCentral Self-Hosted Page 23  © 2014 rev. 0702 



 
 
 
 

MY VIEWLETS 
The My Viewlets view contains a list (in table format) of all the Viewlets published in your 
account. 

 
 

Viewlet Title & Statistics 
• Title: This data is extracted from the information entered in your source file’s 

Viewlet Profile (Project > Project Properties > Viewlet Profile > Viewlet area > 
Title field). If the Title field is left blank in the source file, the project’s file name 
will be used as its title in ViewletCentral Self-Hosted. 

• Statistics: Click the [Viewlet’s title] to drill down into the Dashboard to view 
detailed statistics for this Viewlet. 

   

Size 
This is the size of your published file. 
 

Last Modified 
This is the date and time the Viewlet was published. If the Viewlet was published 
multiple times, the last publication date and time displays. 
 

Author 
The email address of the registered author who published the Viewlet to this account is 
listed here. 
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Assign Certificate 
You can assign custom certificates to any of the Viewlet published in your ViewletCentral 
Self-Hosted account. Certificates are created in My Certificates. Also, you will need to 
create a slide (or slides) with some custom ‘text input’ fields in order to generate a 
certificate. 

Add Fields to Viewlet Source File to Generate a Basic Certificate: 
Note: The following instructions provide a basic example for inserting fields into your Viewlet 
project to generate a certificate; however, you can customize the design based on your needs. 

1. Open a project in your Viewlet authoring app (ViewletBuilder or ViewletQuiz). 

2. The next few steps will differ depending on the version of your Viewlet authoring 
app, but must be completed prior to publishing the Viewlet to ViewletCentral Self-
Hosted. With your project open in: 
 
ViewletBuilder Enterprise or ViewletQuiz 

 
Sample Slide Setup (ViewletBuilder Enterprise / ViewletQuiz) for Capturing Viewer Information for a 
ViewletCentral Self-Hosted Certificate  
 

a. Insert a Question Slide (Insert > Slides > Question Slides...). 

b. In the Add Question window, click the Add button. 

c. In the Question window:  

i. Select the Multiple Choice – Fill in the Blanks question type. 

ii. Type: Please provide the following information: in the Question 
field. [Optional: Replace the text in this step with your own if 
desired.] 
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iii. Set the Scoring Mode to Survey: Not scored – Does not require 
a correct answer. 

iv. Click OK to accept these settings. 

v. Click OK to close the Question window and generate the slide. 

d. Delete the last answer (text box and its associated text input field). 

e. Replace the text for ‘Choice 1’ to: Name: 
f. Replace the text for ‘Choice 2’ to: Email: 
g. Make any other slide design edits as desired. 

h. Rename the slide to: NAME (using all uppercase letters). 

 
ViewletBuilder Professional 

 
Sample Slides Setup (ViewletBuilder Professional) for Capturing Viewer Information for a ViewletCentral 
Self-Hosted Certificate 
 

a. Create two (2) blank slides. 

b. On the first slide: 

i. Rename this slide to: NAME (using all uppercase letters). 

ii. Insert a Text Zone. 

iii. Add a slide text box with the following text: Please type your 
Name in the field below and press the Enter key. Place this text 
box above the text input field. [Optional: Replace the text in this 
step with your own if desired.] 
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iv. Delete the three (3) feedback message objects. 

v. Click the Scoring button on the Context Sensitive toolbar. 

vi. In the Score window: 

1. Select the Override Settings in Project Properties 
option. 

2. In the Points area, set the point value to zero (0). 

3. In the Attempts area, set the value to one (1). 

4. Deselect the check boxes in the Reanswer and Time 
areas. 

5. Click OK to save these settings. 

c. On the second slide: 

i. Rename this slide to: EMAIL (using all uppercase letters). 

ii. Insert a Text Zone. 

iii. Add a slide text box with the following text: Please type your 
email in the field below and press the Enter key. Place this text 
box above the text input field. [Optional: Replace the text in this 
step with your own if desired.] 

iv. Delete the three (3) feedback message objects. 

v. Click the Scoring button on the Context Sensitive toolbar. 

vi. In the Score window: 

1. Select the Override Settings in Project Properties 
option. 

2. In the Points area, set the point value to zero (0). 

3. In the Attempts area, set the value to one (1). 

4. Deselect the check boxes in the Reanswer and Time 
areas. 

5. Click OK to save these settings. 
 

3. Save your project and publish it to ViewletCentral Self-Hosted. 
 
 

Assign Certificate to a Published Viewlet in ViewletCentral Self-Hosted 

 
Note: The following provides instructions for assigning fields from a published Viewlet to create a 
basic certificate. The Viewlet must contain all the fields necessary to complete this process. 
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1. Log into your ViewletCentral Self-Hosted account. 

2. Click the Assign Certificate icon that is inline with the Viewlet you want to 
assign a certificate. 

3. Verify the Title and Description information is correct. 

4. Select a Certificate from the drop-down list. Custom certificates can be created 
in My Certificates. 

5. Click Next.  
6. Verify the Compatibility status, which should be PASSED. If not, you will see 

details for fixing the compatibility issues next to the status. You will need to 
resolve these issues before continuing, if applicable. 

7. Select a field to be used to collect the viewer’s name for the certificate from the 
Name Field drop-down list. 

8. Select a field to be used to collect the viewer’s email for the certificate to be 
mailed to from the Email Field drop-down list. 

9. Optional: Select the check box next to Copy Author if you want a copy of the 
certificate emailed to the Viewlet’s author. 

10. Click the Update button to save (and update) all of the selections for assigning a 
certificate to this Viewlet. 

 

Preview Assigned Certificate 
Once you update the certificate information, you will be returned to My Viewlets. You can 
easily preview any assigned certificates while in ViewletCentral Self-Hosted. This feature 
also allows you to manually recreate a certificate (without the student having to retake 
the assessment). 

1. In My Viewlets, click on the title of the desired Viewlet. 

2. On the My Dashboard page the displays, click the Views link (top of the page). 

3. Optional: You may need to enter in the date range and statuses 
(completed/passed) information to perform a search to locate information on your 
particular Viewlet if you do not see any listed. 
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4. Look at the table at the bottom of the page and click the appropriate Create 
Certificate icon that’s inline with the desired viewer whose certificate you want to 
view.  

Note: You must have at least one (1) view of this Viewlet in order to view a viewer’s certificate. Also, the 
Viewlet may have multiple viewers, so you need to make sure you click the applicable Create 
Certificate icon.)   

 

Manage Assignments 

 
 
This feature allows you to manage assignments for a selected Viewlet.  

1. Click the Manage Assignments icon inline with the desired Viewlet you want to 
manage. The Viewlet Assignments page displays where you create and remove 
assignments for the selected Viewlet. You will see all of your account users 
either assigned to this Viewlet (top list) or available to be assigned to it (bottom 
list). 

 
2. In the Username area: 

a. Review the students assigned to this Viewlet and their utilization statuses. 

b. To remove an assignment: 

i. Select the check box(es) next to the desired student(s). 

ii. Click the Remove Selected button.  
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3. In the Create Assignments for Individual Users area: 

a. To make an assignment: 

i. Select the check box(es) next to the desired student(s). 

ii. Click the Assign Selected button. 

 

Viewlet Privacy 

 
 
Toggle between Unlisted and Private access modes for the selected Viewlet.  
 

• Unlisted mode: Any viewer with the URL can view this Viewlet. 

• Private mode: Used in combination with Assignments, blocks general access to 
viewers who are ‘not assigned’ to this Viewlet. 

 

To change access mode (permission) to a Viewlet: 

1. To determine the current access mode for a Viewlet, take a look at the 
padlock icon inline with it, and the padlock is: 

 Open (unlocked), this indicates the Viewlet is Unlisted 

 Closed (locked), this indicates the Viewlet is Private 

2. To change the access mode (or toggle between modes), click the Toggle 
Privacy icon inline with the desired Viewlet. 

 

Viewlet Information 

 
 
ViewletCentral Self-Hosted stores important information specific to each of your 
Viewlets. To drill down into this data: 

1. Click the Viewlet Information icon inline with the desired Viewlet. 

2. The Viewlet Information page displays with: 
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a. Author 
b. Title 
c. Size 
d. Description 
e. Content ID 
f. Filename 
g. Number of slides 
h. Dimensions 
i. Privacy 
j. Viewlet URL 

3. After reviewing the Viewlet information, you may opt to: 

a. Click the History button to drill further down into the Viewlet information 
 
OR 
 

b. Click the Delete button to remove the Viewlet from your account while in 
this view. 
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Viewlet Stats 

 
 
You can view ‘high-level’ statistics on a particular Viewlet. To do this: 

1. Click the Viewlet Stats icon inline with the desired Viewlet. 

2. Review the information in My Dashboard >> [Viewlet] view for the selected 
Viewlet: 

 
a. Version (Date) 

b. Viewlets Viewed 
i. Views 
ii. Avg Time 

c. Viewlets Completed 
i. Views 
ii. Avg time 
iii. Avg Score 

d. Stats 

e. Viewers 

3. Version Date: This detailed list provides information of each time you modified 
and republished the Viewlet. To remove the audit trail data for earlier versions, 
click the applicable Delete link. 

4. Stats: You can view additional statistics on the selected Viewlet. To do this: 

a. Click the Stats link.  

b. Review the detailed Viewlet statistics: 
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i. Views: This is the number of times the Viewlet was viewed. To 
see how many times the Viewlet was viewed during a specific time 
frame (along with additional details): 
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1. Click the Views link.  

2. Use the search tool to narrow results (optional). 

3. Review the list details that display (Viewer, User, Date, 
Score, Time and Passed/Completed statuses). 

4. Viewer details: You can drill further down into a particular 
viewer’s details. To do this: 

a. Click the viewer name or IP address (in the Viewer 
column) or click the magnifying glass icon at the 
end of the row. On the page that displays: 
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i. If the viewer is an assigned user in your 

ViewletCentral Self-Hosted account, you 
can click the User link to display a page to: 

1. Narrow results by a date range 
search. 

2. Review assignments related to the 
user. 

3. Drill down further into statistics by 
clicking the Viewlet title link (in the 
table). 

4. View high-level summaries of the 
slides and viewer interactions by 
clicking the ‘number/number’ link in 
the Completed column (in the 
table). 

ii. Review the additional details for the 
selected viewer including the high-level 
stats from the previous page along with 
expanded results/details for how the viewer 
interacted with the Viewlet. 

5. User details: If the viewer is an assigned user in your 
ViewletCentral Self-Hosted account, you can: 

a. Click the User link to display a page to: 
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i. Narrow results by a date range search. 

ii. Review assignments related to the user. 

iii. Drill down further into statistics by clicking 
the Viewlet title link (in the table). 

iv. View high-level summaries of the slides and 
viewer interactions by clicking the 
‘number/number’ link in the Completed 
column (in the table). 

6. Completed details: You can find out more information 
about the slides the viewer completed. 
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To do this: 

a. Click the ‘number/number’ link in the Completed 
column.  

b. On the page that displays, review the Slide, Type, 
Correct (status) and Time details for the 
slides/questions in the order in which the viewer 
interacted with them.  

Preview 

 
 
This feature allows you to launch the published Viewlet in its own browser window for 
previewing purposes. To do this: 

1. Click the Preview icon inline with the Viewlet you want to view. 

2. The selected Viewlet will display in a new browser window on top of your current 
ViewletCentral Self-Hosted page.  In this window: 

a. Preview the Viewlet as desired. 
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b. Copy the URL of the Viewlet, if needed, to use on your web site, in your 
emails, chats, etc. 

3. Close the browser window in which the Viewlet is playing to return to the 
ViewletCentral Self-Hosted page. 

 

MY DASHBOARD 
The My Dashboard is where you will access all of your published Viewlets statistical 
information. To access this view: 

1. Log into your ViewletCentral Self-Hosted account.  

2. Click the My Dashboard link from the navigation menu (near the top of the 
page). 

 
This view contains a list (in table format) of all the Viewlets published in your account: 
 

Title 
This data is extracted from the information entered in your source file’s Viewlet Profile 
(Project > Project Properties > Viewlet Profile) > Viewlet area > Title field). If the Title 
field is left blank in the source file, the project’s file name will be used as its title in 
ViewletCentral Self-Hosted. 
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Viewlets Viewed 
Organized in two columns, this data provides high-level stats on the number of times the 
Viewlet was viewed (partially or completely). Information includes: 

• # Views: Number of times the Viewlet was either partially or completely viewed 

• Avg. Time: The average viewing time for ‘all’ viewers 

 

Viewlets Completed 
Organized in two columns, this data provides high-level stats for all the Viewlets in your 
ViewletCentral Self-Hosted account that were completely viewed. Information includes: 

• # Views: Number of times the Viewlet was completely viewed by ‘all’ viewers 

• Avg. Time: The average viewing time for ‘all’ viewers to view the entire Viewlet 

 

Stats 
View additional utilization information about the specific Viewlet.  

 
To do this: 

1. Click the Stats link inline with the desired Viewlet. 

2. Review the information in the My Dashboard >> [Viewlet] view for the selected 
Viewlet. 

a. Version (Date): This detailed list provides information of each time you 
modified and republished the Viewlet. To remove the audit trail data for 
earlier versions, click the applicable Delete link. 

b. Viewlets Viewed: Organized into two (2) columns, this data provides 
information on the number of times the Viewlet was viewed (partially or 
completely). Stats include: 

i. Views: Number of times the Viewlet was either partially or 
completely viewed 

ii. Avg. Time: The average viewing time for ‘all’ viewers 

c. Viewlets Completed: Organize into three (3) columns, this data provides 
information on the number of times the Viewlet was completely viewed. 
Stats include: 

i. Views: Number of times the Viewlet was completed viewed by ‘all’ 
viewers 
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ii. Avg. Time: The average viewing time for ‘all’ viewers to view the 
entire Viewlet  

iii. Avg. Score: If the Viewlet contained quiz (scored) slides, the 
average score / passing score is displayed for ‘all’ viewers 
completing the Viewlet 

d. Stats: You can view detailed information on how the viewers interacted 
with the Viewlet and responded to specific assessment questions. To do 
this: 

i. Click the Stats link. 

ii. Review the detailed Viewlet statistics: 

 
1. Views: This is the number of times the Viewlet was viewed. 

To see how many times the Viewlet was viewed during a 
specific time frame (along with additional details): 

a. Click the Views link. 

b. The Viewers details displays. 
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c. Use the search tool to narrow results (optional). 

d. Review the list details that display (Viewer, User, 
Date, Score, Time and Passed/Completed 
statuses). 

e. Viewer details: You can drill down further into a 
particular viewer’s details. To do this: 

i. Click the viewer name or IP address (in the 
Viewer column) or click the magnifying 
glass icon at the end of the row. On the 
page that displays: 

1. If the viewer is an assigned user in 
your ViewletCentral Self-Hosted 
account, you can click the User link 
to display a page to: 

ViewletCentral Self-Hosted Page 41  © 2014 rev. 0702 



 
 
 

 
a. Narrow results by a date 

range search. 

b. Review assignments related 
to the user. 

c. Drill down further into 
statistics by click the Viewlet 
title link (in the table). 

d. View high-level summaries of 
the slides and viewer 
interactions by click the 
‘number/number’ link in the 
Completed column (in the 
table). 

2. Review the additional details for the 
selected viewer including the high-
level stats from the previous page 
along with expanded results/details 
for how the viewer interacted with 
the Viewlet. 

f. User details: If the viewer is an assigned user in 
your ViewletCentral Self-Hosted account, you can: 

i. Click the User link to display a page to: 
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1. Narrow results by a date range 
search. 

2. Review assignments related to the 
user. 

3. Drill down further into statistics by 
clicking the Viewlet title link (in the 
table). 

4. View high-level summaries of the 
slides and viewer interactions by 
clicking the ‘number/number’ link in 
the Completed column (in the 
table). 

g. Completed details: You can find out more 
information about the slides the viewer completed. 
To do this: 

i. Click the ‘number/number’ link in the 
Completed column. 

ii. On the page that displays, review the Slide, 
Type, Correct (status) and Time details for 
the slides/questions in the order in which 
the viewer interacted with them. 

 
 

MY CERTIFICATES 
The My Certificates view provides you with a basic (default) certificate that you can 
assign to Viewlets. For advanced users, there are additional features for creating custom 
certificates.  
Note: You must create a slide (or slides) with some custom ‘text input’ fields within the Viewlet 
you want to assign a certificate to in order for this feature to work. Instructions for meeting these 
requirements are provided earlier in this guide under ‘Assign Certificate’. 
 
To access My Certificates: 

1. Log into your ViewletCentral Self-Hosted account. 

2. Click the My Certificates link from the navigation menu (near the top of the 
page). 

ViewletCentral Self-Hosted Page 43  © 2014 rev. 0702 



 
 
 

 
 
This view contains a list (in table format) of all your available certificate templates: 

• Template Title: This column provides a list (by title) of all available 
certificate templates. 

• Last Modified: Displays the last date and time the certificate template was 
modified. 

• Author: This is the email address of the account user (author) who 
created the certificate template. 

• Magnifying Glass Icon: Launches a preview of the certificate template in a 
new browser window. 

 
 
Create a New Certificate Template 
ViewletCentral Self-Hosted allows you to create new custom certificates that you can 
apply to your Viewlets based on user interactions. To create a new certificate template: 

1. Log into your ViewletCentral Self-Hosted account and click on My Certificates to 
switch to this view. 

2. Below the list certificate templates currently available, click the New button. 

3. The page refreshes with options for creating a new certificate template. To do 
this: 
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a. Title: Enter a new title in this field for the certificate template. 

b. Frame: Select a frame style from the drop-down list. 

c. Certificate Text: Modify the HTML coding (if needed). The default coding 
works just fine for most certificates and may not require any edits. 

d. Email Subject: Enter in text for the email’s subject line. 

e. Email Body: Modify the text and variables (if needed). The default 
content works just fine for most emails and may not require any edits. 

f. Optional steps: 

i. Select a Viewlet: Assign the new certificate to a Viewlet by select 
the Viewlet from the drop-down list. 

ii. Select a field: When modifying content within the Certificate Text 
or the Email Body field: 

1. Place your cursor at the point you want to insert a variable 
in the desired field. 

2. Select a variable from the drop-down list. 

3. Click the Insert button. 

ViewletCentral Self-Hosted Page 45  © 2014 rev. 0702 



 
 
 

4. Repeat steps 1-3 as needed for each new variable you 
want to insert in either of these fields.  

4. Click Update to create the new certificate template. 

5. An information page displays information if the certificate was successfully 
created (updated). Click the Back button to return to the certificate templates list 
page. 

 
Edit a Certificate Template 
To modify or update an existing certificate template: 

1. In My Certificates, click on the title of the certificate template you want to edit. 

2. Make all of your edits as needed on the page that displays. 

3. Click the Update button to apply / save the changes. An information page 
displays. 

4. Click the Back button to return to the certificate templates list. 

 
Delete a Certificate Template 
To permanently remove a certificate template from the list: 

1. In My Certificates, select the check box next to the certificate template(s) you 
want to remove from the list. 

2. Click the Delete button. 

3. When the page refreshes, click Continue to confirm the deletion. 

4. The page refresh with deletion confirmation. Click the Back button to return to 
the certificate templates list. 
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MY PROJECTS 
The My Projects view displays a list (in table format) of all the projects (source files) you 
have access to within your group. The list includes: 

• Project Title 
• Size 
• Last Modified 
• Author 

 

 
 
To access My Projects: 

1. Log into your ViewletCentral Self-Hosted account. 

2. Click the My Projects link from the navigation menu (near the top of the page) to 
access My Projects. 

 

Project Title 
This is the title of your source file pulled from the information you entered in the Title 
field for your project in the Project Properties > Viewlet Profile dialog of your Qarbon 
authoring app (ViewletBuilder or ViewletQuiz). If this Title field is left blank, the source 
file name will be listed instead. 
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Project Information & History 
ViewletCentral Self-Hosted provides a detailed list of your project’s information as well 
as an audit trail of revisions and related information for your review. To access this data: 

1. Click on the Project Title. 

2. When the page refreshes, the project’s information displays. 
 

 
a. Author 
b. Title 
c. Size 
d. Description 
e. Content ID 
f. Filename 
g. Number of slides 
h. Dimensions 

3. Click the History button to drill down into the revision (and related information) 
history of this project’s source file. 

4. When the page refreshes, the project’s history is listed. 
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Each time the project is modified, another line item is added to the list, making 
this feature a handy audit trail for reviewing revision histories. This history list 
includes: 

a. Date (revision date) 

b. Author (author adding file to server/author making revisions) 

c. Event (project actions) 

d. Path (path to file on server, if available) 

e. Comment (project notes added by author working on file) 

5. Click on the My Projects link to return to list of projects. 

 
Size 
This is the size of the project’s source file. 

Last Modified 
This column lists the date and time stamp of the last time the project was modified. For 
more information on the date and time other revisions were modified (and related 
information), you will need to drill down into the project’s history information (as 
previously described in the Project Information & History section). 

Author 
This is the email address of the user (author) who originally added the project to the 
ViewletCentral Self-Hosted server. You can click the email link to launch your default 
email software (if available) with the author’s email address auto-filled in the TO: field. 

 

MY ACCOUNT 
The My Account provides you with user management tools. To access this view: 

1. Log into your ViewletCentral Self-Hosted account. 

2. By default, your landing page will be My Account > Users tab. If you are in a 
different location while working in your account, click the My Account link from 
the navigation menu (near the top of the page) to access My Account. 

 
My Account is organized into three sections: Users, Groups and Profiles. 
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Users 
A list (in table format) displays all of the users in your ViewletCentral Self-Hosted 
account and includes: 
 

 
 

• First Name 
• Last Name 
• Email 
• Pencil icon (used to edit user account information) 
• Magnifying Glass icon (used to access user details and assignments) 
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Create a New User 
To create a new user in your ViewletCentral Self-Hosted account: 
 

 
1. In My Account > Users click the New button. 

2. On the page that displays, complete the following fields for the new user: 

a. First Name 

b. Last Name 

c. Email 

d. Password 

e. Password Verification 

f. Profile: Assign the user a profile from the drop-down list. This profile will 
determine what areas and features they will have access permissions to 
within ViewletCentral Self-Hosted. 

g. Group: Assign the user to a group. This will determine what projects this 
user will have access to within ViewletCentral Self-Hosted. 

3. Click the Create User button. 

4. An information page displays. Click the Back button to return to the list of users. 
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Import Multiple Users 
Multiple user accounts can be created by importing a CSV file containing user details 
such as first name, last name and email information.  
 

1. Create a CSV file containing the following user information: 

a. First Name 

b. Last Name 

c. Email 

2. In My Account > Users click the Import button. 
 

 
3. When the page refreshes, click the Choose File button.  

 

 
 
In the dialog that displays: 

a. Browse to locate and select the CSV file. 

b. Click the Open button to load the file. 

c. The file name displays on the web page. Verify the file is the correct one 
before continuing. 
 

 
 

4. If the CSV file contains a header row, select the check box next to The CSV file 
has a header row option. DO NOT check this box if the CSV file does NOT have 
a header row. 
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5. Next, you will need to choose a ‘column’ option so ViewletCentral knows how to 
read the file to import the information contained within it properly. Follow the 
instructions using one of the desired column formats: 

a. Fixed Column Order 
 

 
 

i. Select the radio button next to Fixed Column Order. 
ii. Specify the column order in the fields provided next to First 

Name, Last Name and Email Address. 

OR 
 

b. Named Columns 
 

 
 

i. Select the radio button next to Named Columns. If you use this 
option, the CSV file MUST have a header row. 

ii. Specify the column names in the fields provided next to First 
Name, Last Name and Email Address. 

6. The page refreshes with instructions for verifying the CSV file was read correctly. 
Read through this (and any other) information provided to you by ViewletCentral, 
including reviewing the information located in the Preview area before 
continuing. If any warnings are displayed, review the details and address them 
before continuing. 
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7. Select a Profile from the drop-down list. This is the profile that will be assigned to 
all of the imported users, but it can be changed when editing user information. 
 

 
 

8. Click the Confirm button. 
 

 
 

9. After the page refreshes, review the information to verify the CSV file was 
successfully imported. Click the Back button to return to the list of all your 
ViewletCentral account users. 
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Edit a User Account 
To modify a user’s account information: 

 
1. In My Account > Users, click the Edit Account (pencil) icon inline with the user 

you want to edit. (You can also click on either the user’s first or last name to 
access account information.) 

2. On the page that displays, update the information as needed. 

3. Click the Update User button. 

4. An information page displays. Click the Back button to return to the list of users. 

 

Email an Account User 
To email an account user in the list: 

1. In My Account > Users click the email address of the desired user you want to 
email. 

2. Your computer’s default email application will launch with the user’s email 
address pre-filled in the ‘TO’ line, ready for you to create/send the email. 
 

Delete a User 
To permanently remove one or more users from your ViewletCentral Self-Hosted 
account: 

1. In My Account > Users, select the check box next to the user you want to remove 
from your ViewletCentral Self-Hosted account.  

2. Optional: To delete multiple users, select the check box next to each. 

3. Click the Delete button. 

4. When the page refreshes, click Continue to confirm the deletion. 

5. The page refresh with deletion confirmation. Click the Back button to return to 
the users’ list. 
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Access User Details and Assignments 
You can access a user’s details and assignments from the Users tab. To do this: 

• In My Account > Users, click the User Details & Assignments (magnifying 
glass) icon inline with the desired user. 

 
On the page that displays, you will see at least one list (in table format) of the user’s 
assignments. Use the search tool to narrow each list’s results (optional). 

 
 

Top (First) List: 
A main list containing all of the user’s assignments displays above the search tool. Use 
this table to review the following information: 

• Current Assignments: This is a list of current Viewlets assigned to the user. 
• Attempted: Shows status of user accessing the Viewlet. 
• Completed: Shows ‘completion’ status of the Viewlet. 
• Passed: Shows ‘passed’ status of the Viewlet. 
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Bottom (Second) List: 
A second list, containing all of the Viewlets with any type of question slides that the 
viewer attempted, displays at the bottom of the page. Use this table to review the 
following information: 

• Viewlet: This is the title of the Viewlet assigned to the user. You can click on a 
[Viewlet title] link to view detailed information on how the user interacted with the 
Viewlet. 

• Date: Displays the date and time the user attempted the Viewlet. 

• Duration: The amount of time the user interacted with the Viewlet. 

• Score: The final score the user obtained after exiting the Viewlet. 

• Completed: Displays the number of slides the user completed/number of 
question slides in the Viewlet. You can click on the [number/number] link to 
display additional details associated with this status. 

 
Groups 
ViewletCentral Self-Hosted administrators can create different groups within the account 
based on an organization’s structure and needs. Users assigned to the same group can 
share both their Viewlet project (source) files and their published Viewlet files. Users can 
be assigned to one or multiple groups. Additionally, a Group Manager can be assigned 
to each group and be responsible for managing the group’s user accounts. 
 

 
 
The Groups tab includes a list of all the available groups within your ViewletCentral Self-
Hosted account along with some high level summary information: 

• Group (title) 
• Description (abstract) 
• Users (number of users) 
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Create a New Group 
1. In My Account > Groups, click the New button. 

2. Enter in the information (when the page refreshes) for the new group: 
 

 
a. Name (unique) 
b. Description 

3. Click the Create Group button. 

4. An information page displays. Click the Back button to return to the list of groups 
where you will see the new group added to the list. 

Update Group Information 
1. In My Account > Groups, click the title of the group you want to update. 

2. When the page refreshes, modify the Name (unique) and Descriptions fields. 
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3. Click the Update button. 

4. An information page displays. Click the Back button to return to the list of groups. 

 

Delete a Group 
1. In My Account > Groups, select the check box next to the title of the group you 

want to remove from the list. 

2. Optional: To delete multiple groups, select the check box next to each. 

3. Click the Delete button. 

4. When the page refreshes, click the Continue button to confirm the deletion. 
 

 
 

5. An information page displays. Click the Back button to return to the list of groups. 
The selected group is no longer listed. 

 

Profiles 
The Profiles tab includes a list of all the current profiles within your ViewletCentral Self-
Hosted account along with some high level summary information: 

• Profile (title) 
• Description (abstract) 
• Users (number of users) 

 

A Duplicate this Profile    button is located to the right of the list, which provides 
you the opportunity to duplicate any of the available profiles.   
 
ViewletCentral Self-Hosted provides several different pre-installed ‘permission’ profiles. 
These built-in profiles cannot be editor nor deleted, however you can duplicate any of 
these profiles and permission options as needed. 
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Use the following pre-installed profiles as a guideline when creating/modifying your own 
profiles: 
 

• Global Administrator: This profile provides permissions to manage the 
installation of the ViewletCentral Self-Hosted client. We recommend since this 
profile grants FULL permission (access) to the ViewletCentral Self-Hosted 
server, there should only be one administrator account assigned to this profile. 

• Group Manager: This profile provides permissions to manage other users by 
creating, modifying and deleting user accounts within the group. Since 
permissions are limited to the group level to which the assignee belongs, it 
includes the ability to delete Viewlets, assign profiles for newly created accounts 
(other than Global Administrator) and share Viewlet projects. Sharing projects 
includes adding new projects to the server, checking projects in and out and 
deleting projects and published Viewlets. 

• Reviewer: This profile is considered a ‘non-authoring’ account type with a limited 
set of permissions. Users assigned this profile can access reporting data, but 
cannot publish or delete Viewlets. 

• Student: This profile is considered a ‘non-authoring’ account type with a limited 
set of permissions. Users assigned this profile will only have access to their My 
Assignments page. This profile is mainly used (as indicated by its title) for those 
users in your account who are strictly considered learners or ‘students’. 

• Viewlet Author: This profile provides permissions to add new projects to the 
server, check projects in and out and delete projects and Viewlets. It also allows 
the assignee to publish Viewlets to the server, view utilization statistics and 
access projects and published Viewlets by other authors within the group.  
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Profile Permissions 
When you create a new profile or duplicate/modify an existing one, you will see a list of 
Permissions that determine access to the various areas and features within 
ViewletCentral Self-Hosted. 
 
The available list of permissions includes: 
 

Profile Permissions 

Add Projects 

 

Add Viewlets 

 

Change Project Ownership 

 

Change Viewlet Ownership 

 

Create New Profiles 
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Profile Permissions 

Create New Users 

 

Delete Profiles 

 

Delete Projects 

 

Delete Users 

 

Delete Viewlets 
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Profile Permissions 

Edit Profiles 

 

Edit User Information 

 

Manage Groups 

 

Search Projects 

 

Search Users 
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Profile Permissions 

Search Viewlets 

 

Server Setup 

 

Update Projects 

 

Update Viewlets 

 

View Assignments 
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Profile Permissions 

View Project Information 

 

View Statistics 

 

View User Information 

 

View Viewlet Information 

 

 

Create a New Profile 
1. In  My Account > Profiles, click the New button. 

2. When the page refreshes, enter in the new profile information: 

a. Name (unique): This is the tile of the profile. 

b. Description: This is a summary of the profile. 
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c. Landing page: This is the page the user assigned to this profile will first 
see when logging into the web-based interface of ViewletCentral Self-
Hosted. 
 
Here are some suggestions for assigning landing pages to profiles: 

i. user_show.html – Global Administrators 
(My Account > Users) 

ii. content_show.html – Group Mgrs/Reviewers/Viewlet Authors 
(My Viewlets) 

iii. assignment_show.html - Student 
(My Assignments) 

d. Permissions: Set the access options you want to associate with this 
profile. The permission settings chosen determine what pages and 
features the user assigned to this profile will have in ViewletCentral Self-
Hosted. 

3. Click the Create Profile button. 

4. An information page displays. Click the Back button to return to the profiles’ list. 

 

Duplicate a Profile 
1. In My Account > Profiles, click the Duplicate this Profile button inline with the 

desired profile. 

2. The duplicated profile displays in the list followed by a number in parenthesis. 
So, for example, if you duplicate the built-in (default) ‘Student’ profile three times, 
it will list the three duplicate profiles (one right after the other) in the list, 
numbering them (1), (2), (3) respectively. 
 

 
The image above shows what the Profile list might look light directly after duplicating the 
built-in (default) ‘Student’ profile three times in a row. 
 

3. Click the duplicated profile’s title to edit the profile. 
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Update a Profile 

1. In My Account > Profiles, click the title of the profile you want to update. 

2. When the page refreshes, update the profile information as needed. 

3. Click the Update button. 

4. An information page displays. Click the Back button to return to the profiles’ list. 

 

Delete a Profile 
1. In My Account > Profiles, select the check box next to the profile you want to 

remove from the list. 

2. Optional: To remove multiple profiles at the same time, select the check box next 
to each profile. 

3. Click the Delete button. 

4. When the page refreshes, click the Continue button to confirm the deletion. 
 

 
 

5. An information page displays. Click the Back button to return to the profiles’ list. 
The selected profile is removed. 
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About 
To learn more about ViewletCentral Self-Hosted, you can click the About link in the 
navigation menu (near the top of the page). The ViewletCentral product information page 
will launch in a new browser window. It contains the latest product descriptions and 
details on ViewletCentral for your review.  

 
 
You can also review current ViewletCentral product information by visiting our site at:  
 
http://www.qarbon.com/presentation-software/viewletcentral/ 
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Self-Help Resources 
In addition to this user guide, additional self-help resources are available online. Just 
click the Help link in the navigation menu. The Qarbon Learning Center will open in a 
new browser window. The Learning Center contains access to product user guides, 
FAQs, Viewlet tutorials and the Qarbon User Forum. 

 
 
You can also access the online Learning Center by visiting our site at: 
 
http://www.qarbon.com/help/ 
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Training 
Qarbon offers several different types of training opportunities to its clients, depending on 
your needs. Start with a FREE webinar for an overview on the product of your choice. If 
this isn’t enough, sign up for one of several product-specific workshops. Workshops are 
offered as two 90-minute sessions and are limited to 10 students each. This is a great 
way to brush up on the basics and even learn a new trick or two. Qarbon also offers 
private coaching tailored to meet your needs. Offered on an hourly basis, meet with us 
for a free consultation and we’ll design a training session just for you! 

 
 
For current training opportunities, email us or visit our site: 
 
http://www.qarbon.com 
 
And, click the ‘Services’ link in the navigation menu and choose a current training 
opportunity from the available list. 
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Sales 
If you have any questions on ViewletCentral Self-Hosted (or other Qarbon products and 
services), please feel free to contact our Sales, Customer Service or Support staff at any 
time.  

 
 
For current contact information, visit our site at:  
 
http://www.qarbon.com/about_us/contact_us/ 
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