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Welcome to ViewletCam2 
ViewletCam2 lets you create animated interactive Viewlets (SWF files) while capturing 
actions on your computer screen in real time. And, it’s a lot easier then you might think. 
In addition, you can use the ViewletCam2 Add-on for PowerPoint to capture your 
slideshow presentation as it plays on your screen. 
 
Record synchronous voice narration then edit notes along the Timeline. Add notes, 
pictures, interactive buttons and many more elements to engage your audience and 
encourage their input. Once you finish building your project inside ViewletCam2, select 
from a variety of export options, including SWF, AVI, GIF and EXE, to create dynamic 
presentations ready for integration into your web site, training environment or help desk 
system. 
 
ViewletCam2 is the perfect tool to quickly create simple Flash movies and beyond! Let’s 
get started. 
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System Requirements 
ViewletCam2 is available for the Microsoft® Windows operating systems. For current 
guidelines for the minimum system requirements for authoring and viewing ViewletCam2 
Viewlets, please visit the ViewletCam2 products page: 
 
http://www.qarbon.com/presentation-software/vc/ 
 
This page contains ViewletCam2 product information. For system requirements, click the 
“Technical Specs” link. 
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Installation 
A trial version of ViewletCam2 is available for download from Qarbon for evaluation 
purposes. The trial version is fully functional, however, it expires after 30 days (from date 
of installation) and Viewlets created in the trial version contain advertising logos. To 
remove the logos, you must purchase a license and activate your ViewletCam2 program 
with it. 
 
To download ViewletCam2: 

▪ Go to the Qarbon site: http://www.qarbon.com. 
▪ Look for and select the “Downloads” link from the home page. 

 

 
 

▪ Once you reach the products downloads page, select ViewletCam2. 
▪ When prompted, “Save” the installer file to your computer. 
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To install ViewletCam2: 
▪ Double click the ViewletCam2 installer file ending in “.exe”. 
▪ The ViewletCam2 setup wizard will display. Follow the prompts throughout the 

windows in the wizard to complete the ViewletCam2 installation process. 
 

 
 
If you have any questions or encounter any problems while downloading or installing 
ViewletCam2, please contact support@qarbon.com. 
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License Activation 
To publish Viewlets without advertising logos, you must activate your license in 
ViewletCam2. Once you purchase a license, the information needed to convert 
ViewletCam2 to the licensed version is sent to you via email. Remember to activate 
ViewletCam2 before the 30-day trial period ends. 
 
To activate ViewletCam2: 
 

 
 

▪ Make sure you are connected to the Internet and launch ViewletCam2. 
▪ In the Activate ViewletCam2 window, complete the fields: 

o Code: In the email you received after purchasing your license, look for 
the “License Code” and copy/paste the string of data after it into this field. 

o Name: Type your full name in this field. 
o Company: Type in your company name. 
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o Email: Type in the email address you use at your company. 
o How did you hear about ViewletCam2: Make a selection from the list. 
o Would you like to receive our newsletter: Select this option if you want 

to receive Qarbon’s newsletter. 
▪ Click Activate. 

 
Web Activation 
If you experience any issues while trying to activate your ViewletCam2 license, trying 
using the Web activation button to complete the activation process in a few simple 
steps: 
 

▪ Make sure you are connected to the Internet and complete the information in the 
fields provided in the Activate ViewletCam2 window. 

▪ Click the Web activation button. 
▪ A Web Activation window displays. Follow the instructions at the top of the 

window; copy the URL and click the Open button. 
▪ Your computer’s default browser will display a web page with all the information 

you filled in the fields in the activation window. Review this information for 
accuracy and click Submit. 

▪ The web page will refresh with information you will need to complete the 
activation. Copy the long string of data in the field next to Confirmation Code. 

▪ Go back to the ViewletCam2 Web Activation window and paste the confirmation 
code you just copied into the field provided. 
 

 
 

▪ Once you’ve paste the confirmation code data in the Web Activation window, 
click Activate. 

▪ If all the information is correct, a successful activation window will display. Click 
OK to close this window to complete the activation process. 
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License Deactivation 
If you need to move your license to another computer or remove it from your system for 
whatever reason, use the following steps to complete the deactivation process: 

▪ Make sure you are connected to the Internet. 
▪ Launch ViewletCam2. 
▪ Select Help > Deactivate from the menu bar. 

 

 
 

▪ When prompted, “Are you sure you want to deactivate?” click Yes. 
 

 
 

▪ If you clicked Yes, a success window will display. Click OK to close it and to 
return to ViewletCam2. 

▪ Close ViewletCam2. 
 
If you have any questions or issues with activating your ViewletCam2 license, please 
email support@qarbon.com. 
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GUI Language 
ViewletCam2 supports many different languages for the GUI (Graphical User Interface). 
By default, it will use the language of your operating system, but this can easily be 
changed. 
 

▪ Select Language from the menu bar. 
 

 
 

▪ Select a different language from the list. 
▪ An information window prompting you that ViewletCam2 will need to be restarted 

for the new language option to take effect will display. Click OK. 
 

 
 

▪ Close and reopen ViewletCam2 and the interface will display using the newly 
selected language choice. 

 
If you have any questions about using different languages for the interface, please 
contact support@qarbon.com. 
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Interface Overview 
A basic understanding of the ViewletCam2 interface is important so that you know what 
tools you have available to successfully complete your Viewlet projects. This chapter 
provides an overview of the ViewletCam2 interface (with a project open). Many of these 
features are also discussed in more detail later in this manual. 
 

 
 
 
The Basics Parts of the ViewletCam2 Interface 
As shown in the diagram above, the interface is organized into several sections. Tools 
are easily available along the top and side of the screen while the canvas area and 
Timeline serve as the primary focus for editing and preview playback. Let’s explore 
some of these features. 
 

▪ Title Bar: At the top of the program window, you will see the software title 
“ViewletCam2”. If a file is open, the title bar will also contain the name of the file. 
If the file name is followed by an asterisk (*), this indicates that changes have 
been made to the file and the file needs to be saved. If your ViewletCam2 
window is NOT full screen, you can move it around your screen by pointing your 
cursor over the blue title bar and dragging the window. 
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▪ Menu Bar: By default, this is the bar that sits right below the title bar and 
contains menu selections that reveal additional options. The menu bar offers 
access to: File, Edit, View, Insert, Control, Tools, Language, Window and 
Help operations. 

 
▪ Standard Toolbar: By default, below the menu bar is the standard button toolbar 

containing a series of command buttons. These buttons offer quick one-click 
access to the most common features in ViewletCam2. In many cases, these 
buttons provide quicker access to tools also found on the menu bar. 

 
▪ Ruler Bars: Along the left side of the screen and the top of the stage area (right 

below the main button toolbar) are rulers. Use these for fine-turning placement of 
objects on the stage. 

 
▪ Edit Toolbar: By default, this toolbar, used for choosing the selection tool or to 

insert objects on the stage along the Timeline, is loaded on the right side of the 
screen. 

 
▪ Stage or Staging Area: ViewletCam2’s staging area (main editing area) is the 

canvas area where the actual project is displayed. It is in this area that you can 
apply all of your edits, such as adding notes, buttons, fine tune cursor animations 
and more. While inside ViewletCam2, you can preview the playback of your 
project and everything that plays “on the stage” is what will be visible in the 
published file. 

 
▪ Offstage Area: The gray area that surrounds the stage is the offstage area. This 

will not be visible during playback in the published file. 
 

▪ Timeline: By default, the Timeline is loaded at the bottom of the screen below 
the stage. The Timeline is used for editing project elements and for viewing 
actions during playback. 

 
▪ Status Bar: The status bar is located at the bottom of the screen and displays 

some information regarding the feature you are working on and a “hint” as to 
what to do if more help is needed. There are also buttons along the status bar 
with the name of each file currently open inside ViewletCam2. To switch between 
open files, simply click the desired project button on the status bar.  
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Floating Toolbars 
The Menu Bar, Standard Toolbar, Edit Toolbar and Timeline are also known as “floating 
toolbars”. The advantage of floating toolbars is that they can be shown, hidden or moved 
around the workspace while editing a ViewletCam2 project. 
 

 
 
 
To display a floating toolbar: 

▪ If one of the floating toolbars is not displayed, select View from the menu bar. 
▪ Select the desired toolbar from the menu selections. Once selected, it will display 

in the workspace area in its last “remembered” position. So, for instance, if you 
moved the toolbar and then closed it, when reopened, it will display in the last 
position it was in before it was closed. 

 
To hide (close) a floating toolbar: 

▪ Select View from the menu bar. 
▪ Remove the checkmark next to the applicable toolbar by clicking (deselecting) it 

from the menu selections. 
 
OR 
 

▪ Click the “red x”  located in the right edge of the toolbar’s blue title bar. 
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To move an “anchored” toolbar: 
▪ If the toolbar is anchored along an edge of the screen (not floating), point your 

cursor over the left or top edge of the toolbar where the “dashed lines” display. 
 

 
 

▪ Hold down the left mouse button and drag the toolbar to its new location. 
▪ Let go of the left mouse button to drop it into place. 

 
To move a floating toolbar: 

▪ If the toolbar is not anchored along the edge of the screen, point your cursor over 
the toolbar’s blue title bar. 

▪ Hold down the left mouse button and drag the toolbar to its new location. 
▪ Let go of the left mouse button to drop it into place. 
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Right Click Shortcut Options  
Many of ViewletCam2’s menu and toolbar options can be accessed by right clicking. To 
access a shortcut menu, right click on the object or workspace area you wish to edit and 
a shortcut menu (if available) will display. 
 

 
 
 
If you have any questions or issues with the ViewletCam2’s interface and related 
features, please email support@qarbon.com. 
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ViewletCam2 Program Preferences 
Before starting any screen capture session, whether it is capturing onscreen actions of 
an active program window or recording your PowerPoint presentation as it plays so you 
can later edit it in ViewletCam2, you should set some screen capture preferences to be 
used for all new projects. These preferences (ViewletCam2 options) will be used as the 
defaults for all new projects, but can easily be modified as needed. 
 
To access ViewletCam2 options (preferences) for screen captures: 

▪ Select Tools > Options from the menu bar. 
 

 
 

▪ The ViewleCam2 Options window displays. 
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The ViewletCam2 Options Window 
The ViewletCam2 Options window contains three distinct tabs. In each of these tabs, 
you can set default ViewletCam2 preferences for capture mode, hotkeys, audio, 
disabling specific screen actions that might occur during capture and various options to 
control capture settings when playing back a PowerPoint presentation.  
 

 

 
 
Now, let’s explore each of the tabs found in the ViewletCam2 Options window inside 
ViewletCam2. 
 

Stop!  
Did you install the ViewletCam2 Add-On for PowerPoint option when you 
installed ViewletCam2? If so, the settings found in the ViewletCam and 
PowerPoint tabs can also be modified from within PowerPoint. To access them: 
 

▪ Inside PowerPoint, locate the ViewletCam2 toolbar. 
▪ On that toolbar, click the ViewletCam2 plug-in configuration options 

button. 
 

  
 

▪ The ViewletCam2 Add-On Options window displays. You can modify 
these settings just like you would inside ViewletCam2 only here you can 
do it right before launching your PowerPoint presentation right from within 
PowerPoint! 

 
The ViewletCAm2 Add-On for PowerPoint is covered in more detail later in this 
manual. 
 



 
 
 

 
ViewletCam2 User Manual page 17 rev. 02/15/2010 

The ViewletCam Tab 
This tab offers selections for setting up preferences for the capture mode, record hotkey 
and audio.  These preferences may be modified in other areas of the program window 
prior to capturing new screenshots. 
 
In the Capture Mode area: 
 

 
 

▪ Select a “mode” for your computer to use while capturing screenshots: 
o DirectX (Default): DirectX is a collection of APIs (application programming 

interfaces) for handling tasks related to multimedia, including video, on 
Microsoft platforms. 

o GDI: GDI (graphical device interface) is a Microsoft Windows interface for 
representing graphical objects and transmitting them to output devices like 
monitors. 

▪ If you are unsure as to which capture mode to use, click the Select the mode 
automatically and let ViewletCam2 test your system to make the best selection. 

▪ To set the Capture times per second (frame rate) default (how many seconds 
will pass between screen captures), drag the handle along the sliding bar to set 
the number of seconds. 

 
In the Record Hotkey area: 
 

 
 
ViewletCam2 uses predefined keystroke combinations or “hotkeys” to allow you to Start 
/ Stop and Pause / Resume your onscreen capture recording sessions. You can set the 
default preferences for these hotkeys in this tab. You can also change the hotkey 
combinations prior to starting each new project. 
 
Start / Stop hotkeys: 

▪ To set the Start / Stop hotkeys, which are used to begin and end a screenshot 
session, click the button to the right of the “Start / Stop” text. The Select Hot key 
window displays. 
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▪ Follow the instructions in the Select Hot Key window. The new hotkey 
combination will display in the screen if it is able to be used for a hotkey. 

▪ Click OK to apply.  
 

This hotkey combination works like a toggle. When first used, the screenshot session will 
begin. When the hotkey combination is used again, the screenshot session will end. 

 

Pause / Resume hotkeys: 
▪ To set the Pause / Resume hotkeys, which are used to pause and resume an 

active screen capture session, click the button to the right of the “Pause / 
Resume” text.  

▪ Follow the instructions in the Select Hot Key window. The new hotkey 
combination will display in the screen if it is able to be used for a hotkey. 

▪ Click OK to apply. 
 

This hotkey combination works like a toggle. When first pressed during an active 
recording session, the recording will pause. When the hotkey combination is pressed 
again, the recording session will resume (continue) for that same session. 

 
  
In the Audio area: 
 

 
 
ViewletCam2 offers several ways to enhance your Viewlet project with the addition of 
sound. These features are detailed in the chapter on Sound Recording. In this section, 
you will learn how to set up default sound recording preferences for all existing and new 
projects. As previously mentioned, these sound recording preferences can be modified 
in other areas of the program prior to creating new projects or recording new sound 
tracks. 
 
To set sound recording defaults for new projects: 

▪ Select the Record sound option. 
▪ Click the Setup button. The Sound window displays. 
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▪ In the Sample size area, select either 8 bit or 16 bit. 
▪ In the Sample rate area, select a rate to use when recording audio. The higher 

the sample rate, the better quality the sound file, but the bigger the resulting file 
size. 

▪ In the Sound source area select where the sound will be recorded from. If you 
want to record computer sounds while capturing onscreen actions, select 
“Computer” as the sound source. However, you can only capture EITHER 
computer sounds or microphone input, not both, during an onscreen capture 
session. 

▪ Click OK to apply the default settings. 
 
 
The Capture Setting Tab 
In the Capture Setting tab, ViewletCam2 allows you to set preferences for screen 
captures that will be used for onscreen capture sessions for your new projects. You can 
choose to disable single or multiple screen actions to help reduce the final size of your 
published presentation. Or, if you encounter issues while attempting to record onscreen 
actions, you can set “hardware acceleration” preferences to resolve the issue. Let’s take 
a look at the two main features offered in this tab. 
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In the “disable certain interface effects” area (top section of tab): 
▪ If you don’t know what to disable, select the Disable all possible effects option. 

 

 
 

▪ You can also select individual effects that may occur while capturing onscreen 
actions as desired. Only selected items will be disabled and can help reduce the 
file size of the published project. 

 
In the “recording session issues / troubleshooting” area (bottom section of tab): 

▪ If you experience computer slowdown or your screen freezes while capturing 
onscreen actions, use the slider bar next to the words Hardware acceleration. 
There are six settings from None to Full that you can set as the default. As you 
drag the bar to change the setting, a brief description of how this setting will 
impact your computer during capture sessions is displayed. 
 
Hardware acceleration settings: 

o Level 1: Bar is set to “None”. This setting disables all hardware 
accelerations. 
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o Level 2: Bar is set one level up from “None”. This setting disables all but 
the most basic hardware accelerations. 
 

 
 

o Level 3: Bar is set two levels above “None”. This setting disables all 
DirectDraw, Direct 3D, and cursor and advanced drawing hardware 
accelerations. 
 

 
 

 
o Level 4: Bar is set two levels below “Full”. This setting disables all cursor 

and advanced drawing hardware accelerations. 
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o Level 5: Bar is set one level below “Full”.  This setting disables cursor 
and bitmap hardware accelerations. 
 

 
 

 
o Level 6: Bar is set to “Full”. This setting enables all hardware 

accelerations. 
 

 
 

 
The PowerPoint Tab 
If you installed the ViewletCam2 Add-On for PowerPoint, use this tab to set capture 
defaults directly from within ViewletCam2 to control the size the presentation window 
runs in while recording your PowerPoint presentation. As previously mentioned, you can 
also modify these settings prior to launching a PowerPoint presentation right from inside 
PowerPoint. 
 
To set the “window size” that will be used while recording your presentation (top of tab): 

▪ Select FullScreen to launch the presentation full screen. ViewletCam2 will 
capture everything visible on your monitor during the capture session. 
 

 
 

▪ If you want to set a custom size for the recording session, make sure the 
FullScreen options is deselected and change the Width and Height in the fields 
provided. If the dimensions are smaller than your monitor settings, the 
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PowerPoint presentation will play back centered on your screen during the 
capture session. 

 
In the Record mode area: 
 
This section (located at the middle to bottom of the tab) contains several options all 
related to recording mode settings. 
 

▪ Select Launch Presentation and Start recording to have ViewletCam2 begin 
the capture session as soon as the presentation starts playing. 
 

 
 

▪ Select Launch Presentation and press hotkey to start recording to manually 
begin the capture session of your presentation by pressing a predefined hotkey 
combination. 
 
If you select the second mode option, you will be prompted to use your hotkey. 
Click OK to close the window before pressing your hotkey. 
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If you don’t want the “tip” window to display before starting a PowerPoint capture session 
using a hotkey combination, deselect the Show tip again option. 
 

▪ Select the Hide mouse track option if you do not want to include cursor 
animation. 

▪ Select the Show hotkey tip next time option if you want a tip window displayed 
before initiating a capture session of your presentation using a hotkey 
combination. 

▪ Click Browse to locate the folder where you want your ViewletCam2 project to 
be saved. This is the project ViewletCam2 creates automatically once your 
capture session is finished. 

▪ Click OK to save these settings. 
 
If you have any questions regarding setting up ViewletCam2 default options 
(preferences), please contact support@qarbon.com. 
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Creating a New Project Basics 
ViewletCam2 offers several ways to create a new project based on your capture mode 
selection or if you are planning to record a PowerPoint presentation. Each of the new 
project types are covered in further detail later in the manual. This chapter will focus on 
“project types” and the basic process for recording a capture session common to all new 
projects. 
 
New Project Types 
Essentially new projects can be divided into two categories: 
 

▪ New projects based on capture mode selection 
▪ New projects created from PowerPoint presentations 

 
New Projects Based on Capture Mode Selection 
When creating a new project in ViewletCam2, you will be prompted as to what “capture 
mode” you want to use during your onscreen capture session. Your selection will 
determine what options you will need to review/set up right before taking screenshots.  
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There are basically three new project types based on the capture selection: 
 

▪ Active Window Capture (Capture a single window): Use this option to capture a 
selected “active” program or operating system window. This mode will record all 
actions within the window chosen. 
 

▪ Screen Area Capture (Capture an area of the screen): Use this option to 
capture a “user defined” area of the screen. This mode will record all onscreen 
actions within the defined rectangle (capture) area. 
 

▪ Full Screen Capture (Capture full screen): Use this option to capture everything 
viewable on the entire screen. This mode will record all actions you seen on your 
monitor during the capture session. 

 
To create a new Active Window, Screen Area or Full Screen Capture project: 
 

▪ Launch ViewletCam2. 
▪ Select File > New from the menu. 
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▪ In the Create new project window that displays: 
 

 
 

 
o Type in a file name for the new project in the field provided. The .vcp 

extension (used for all ViewletCam2 source files) will be added to the file 
name automatically once the project is created. 
 

o Review the path for the Project directory. If you want to change it, click 
the Browse button and select a new folder location. 
 

o Click Next. The Choose capture mode window displays. 
 

▪ For the final steps and additional information on creating a new project, please 
refer to one of these chapters (whichever is applicable): 
 

o Active Window Capture (New Project) 
o Screen Area Capture (New Project) 
o Full Screen Capture (New Project) 

 
These chapters are found later in this user manual. 
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New Projects Created from PowerPoint Presentations 
The ViewletCam2 Add-On for PowerPoint makes it easy to create new projects from 
existing PowerPoint presentations. Here’s how it works. When installing ViewletCam2, 
you will be prompted to install the ViewletCam2 Add-On for PowerPoint. 
 

 
 
In the Select Additional Tasks window, under the Add-on for Microsoft PowerPoint area, 
make sure the checkbox next to Enable ViewletCam2 Add-on for Microsoft 
PowerPoint is selected. This will place a ViewletCam2 button toolbar inside your 
PowerPoint program. 
 

 
 
You will use this toolbar in conjunction with PowerPoint to capture your presentation. 
See the chapter PowerPoint Presentation (New Project) for more information on creating 
new Viewlets from presentations. 
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Active Window Capture (New Project) 
As discussed previously in the chapter Creating a New Project Basics, the Active 
Window Capture project type is used to capture a single, active program or operating 
system window. During the recording session, all actions in that window are recorded. 
 

   
 
To create a new project using a single, active window: 

▪ Make sure the program or operating system window you want to capture is open. 
▪ Switch to ViewletCam2 and select File > New from the menu bar. 
▪ In the Create new project window, type in a file name and select a project 

directory to save the project in.  
▪ Click Next. 
▪ In the Choose capture mode window that displays, select Capture a single 

window. 
▪ Click Next. 
▪ In the Capture from window screen that displays, point your cursor over the 

Select tool and, while holding down the left mouse button, drag it until it outlines 
the single, active window you want to use during your recording session. Let go 
of the mouse button to select the window. 
 

 
 

Before letting go of the left mouse button, move your mouse over different parts of the 
active window and notice how it outlines different portions of it. You can capture “sub-
portions” of a single window if needed. Make sure the entire window is outlined if you 
want to capture the entire active window. 
 

▪ In the Capture mode area, select either DirectX (Default) or GDI for the mode of 
capture. For best results, let ViewletCam2 examine your system and select the 
best capture mode automatically by clicking the Select a mode automatically 
button. 
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▪ The next step is to define a hotkey combination for the Start / Stop action of a 
recording session. To change the hotkeys used to begin and end a capture 
session, click the button next to the words “Start / Stop”. 
 

 
 

▪ In the Select Hot Key window, press the key combination that you want to use to 
start and stop the capture session. 
 

 
 

▪ Once the hotkey combination is selected, click OK to return to the previous 
window. 

▪ To change the hotkeys used to Pause / Resume a capture session, click the 
button next to the words “Pause / Resume”. 
 

 
 

▪ In the Select Hot Key window, press the key combination that you want to use to 
pause and resume the capture session. 
 

 
 

▪ Once the hotkey combination is selected, click OK to return to the previous 
window. 

Changing hotkeys for Start / Stop and for Pause / Resume when creating a new project will 
NOT change the default hotkey preferences set in the Tools > Options > ViewletCam tab. 
 

▪ To record sound during the capture session, select the Record Sound option. 
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▪ Click the Setup button next to words “Record sound”. 
▪ In the Sound window that displays, select the Sample size, Sound source and 

the Sample rate for the sound preferences. For more information on sound 
features, see the chapter on Sound Recording Preferences. 
 

 
 

▪ Click OK to apply the sound preferences. 

 
Changing the sound preferences when creating a new project will NOT change the default 
sound preferences set in the Tools > Options > ViewletCam tab. 
 

▪ To change the Capture times per second (frame rate) setting (how many 
seconds will pass between screen captures), drag the handle along the sliding 
bar to set the number of seconds. 
 

 
 

Changing the capture rate when creating a new project will NOT change the default 
capture rate setting set in the Tools > Options > ViewletCam tab. 
 

▪ In the Information area, there are no actions to take. Information displayed in this 
area is determined by what single, active window is selected for capture. 
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▪ Click Finish. The Capture from window screen will close and you are ready to 
start your capture session. 

▪ Right before you begin your capture session, a hint will display above your 
system tray, prompting you to press the applicable hotkey combination to start 
your capture session. 
 

 
 

▪ Press the applicable hotkey combination to start your screenshot session. 
▪ Perform the tasks as needed during your recording session. 
▪ If you need to pause the capture session, press the applicable hotkey 

combination. To resume, press the same hotkey combination and the session will 
continue. 

▪ Once you are finished with the capture session, press the Start / Stop hotkey 
combination to end your capture session. 

▪ ViewletCam2 will display your new project. At this point, save the project before 
you begin working on it. 

 
If you have any questions about creating new Active Window projects, contact 
support@qarbon.com. 
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Screen Area Capture (New Project) 
The Screen Area Capture project type is used to record onscreen actions in a “user-
defined area” of the screen. This method is useful when you don’t want to capture an 
entire active window, but you don’t want to capture everything viewable on your monitor 
either. 
 

 
 
To create a new project using an area of the screen: 

▪ Select File > New from the menu bar. 
▪ In the Create new project window, type in a file name and select a project 

directory to save the project in. 
▪ Click Next. 
▪ In the Choose capture mode widow that displays, select Capture an area of the 

screen. 
▪ Click Next.  
▪ The Capture from rectangle window displays. Move this window out of the way, if 

needed, before drawing the rectangle that will define the capture area. 
▪ Click the Select tool. The cursor will change to a cross-hair shape.  

 

 
 

▪ Move the cursor to where a “corner” of the screen area will be. Click on the 
screen and, while holding down the left mouse button, draw a rectangle over the 
area of the screen that you want to define as your capture area. 

▪ Let go of the left mouse button. The screen capture area will be shaded. 
▪ If you need to resize the screen area at this point, use the grab handles along the 

edge of the shaded rectangle and drag them to resize as needed. 
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▪ Click OK to set the screen capture area. 
 

 
 

▪ In the Capture mode area, select either DirectX (Default) or GDI for the mode of 
capture. For best results, let ViewletCam2 examine your system and select the 
best capture mode automatically by clicking the Select a mode automatically 
button. 
 

 
 

▪ The next step is to define a hotkey combination for the Start / Stop action of a 
recording session. To change the hotkeys used to begin and end a capture 
session, click the button next to the words “Start / Stop”. 
 

 
 

▪ In the Select Hot Key window, press the key combination that you want to use to 
start and stop the capture session. 
 

 
 

▪ Once the hotkey combination is selected, click OK to return to the previous 
window. 

▪ To change the hotkeys used to Pause / Resume a capture session, click the 
button next to the words “Pause / Resume”. 
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▪ In the Select Hot Key window, press the key combination that you want to use to 
pause and resume the capture session. 
 

 
 

▪ Once the hotkey combination is selected, click OK to return to the previous 
window. 
 

Changing hotkeys for Start / Stop and for Pause / Resume when creating a new project will 
NOT change the default hotkey preferences set in the Tools > Options > ViewletCam tab. 
 

▪ To record sound during the capture session, select the Record Sound option. 
 

 
 

▪ Click the Setup button next to words “Record sound”. 
▪ In the Sound window that displays, select the Sample size, Sound source and 

the Sample rate for the sound preferences. For more information on sound 
features, see the chapter on Sound Recording Preferences. 
 

 
 

▪ Click OK to apply the sound preferences. 
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Changing the sound preferences when creating a new project will NOT change the default 
sound preferences set in the Tools > Options > ViewletCam tab. 
 

▪ To change the Capture times per second (frame rate) setting (how many 
seconds will pass between screen captures), drag the handle along the sliding 
bar to set the number of seconds. 
 

 
 

Changing the capture rate when creating a new project will NOT change the default 
capture rate setting set in the Tools > Options > ViewletCam tab. 
 

▪ In the Information area, there are no actions to take. Information displayed in this 
area is determined by what single, active window is selected for capture. 
 

 
 

▪ Click Finish. The Capture from rectangle window will close and you are ready to 
start your capture session. 

▪ Right before you begin your capture session, a hint will display above your 
system tray, prompting you to press the applicable hotkey combination to start 
your capture session. 
 

 
 

▪ Press the applicable hotkey combination to start your screenshot session. 
▪ Perform the tasks as needed during your recording session. 
▪ If you need to pause the capture session, press the applicable hotkey 

combination. To resume, press the same hotkey combination and the session will 
continue. 

▪ Once you are finished with the capture session, press the Start / Stop hotkey 
combination to end your capture session. 
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▪ ViewletCam2 will display your new project. At this point, save the project before 
you begin working on it. 

 

 
 
If you have any questions about creating a new Screen Capture Area project, contact 
support@qarbon.com. 
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Full Screen Capture (New Project) 
As discussed in the chapter Creating a New Project Basics, the Full Screen Capture 
project type is used to capture all onscreen actions. Be careful when using this method 
since the resulting dimensions for your project (height and width) will be determined by 
what your monitor’s resolution is. For example, if your monitor’s resolution is 800 x 600 
and you use the Full Screen Capture option, your project’s playback area will be the 
same. 
 

 
 
To create a new project using full screen capture: 

▪ Select File > New from the menu bar. 
▪ In the Create new project window, type in a file name and select a project 

directory. 
▪ Click Next. 
▪ In the Choose capture mode window that displays, select Capture full screen. 
▪ Click Next. The Capture full screen window displays. 
▪ Since the capture session will capture all onscreen actions, you will not need to 

use the Select tool to select an active window nor to define a capture area as in 
previous new project types previously covered prior to this chapter. 
 

 
 

▪ In the Capture mode area, select either DirectX (Default) or GDI for the mode of 
capture. For best results, let ViewletCam2 examine your system and select the 
best capture mode automatically by clicking the Select a mode automatically 
button. 
 

 
 

▪ The next step is to define a hotkey combination for the Start / Stop action of a 
recording session. To change the hotkeys used to begin and end a capture 
session, click the button next to the words “Start / Stop”. 
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▪ In the Select Hot Key window, press the key combination that you want to use to 
start and stop the capture session. 
 

 
 

▪ Once the hotkey combination is selected, click OK to return to the previous 
window. 

▪ To change the hotkeys used to Pause / Resume a capture session, click the 
button next to the words “Pause / Resume”. 
 

 
 

▪ In the Select Hot Key window, press the key combination that you want to use to 
pause and resume the capture session. 
 

 
 

▪ Once the hotkey combination is selected, click OK to return to the previous 
window. 
 

Changing the hotkeys for Start / Stop and for Pause / Resume when creating a new project 
will NOT change the default hotkey preferences set in the Tools > Options > ViewletCam 
tab. 
 

▪ To record sound during the capture session, select the Record Sound option. 
 

 
 

▪ Click the Setup button next to words “Record sound”. 
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▪ In the Sound window that displays, select the Sample size, Sound source and 
the Sample rate for the sound preferences. For more information on sound 
features, see the chapter on Sound Recording Preferences. 
 

 
 

▪ Click OK to apply the sound preferences. 
 

Changing the sound preferences when creating a new project will NOT change the default 
sound preferences set in the Tools > Options > ViewletCam tab. 
 

▪ To change the Capture times per second (frame rate) setting (how many 
seconds will pass between screen captures), drag the handle along the sliding 
bar to set the number of seconds. 
 

 
 

Changing the capture rate when creating a new project will NOT change the default 
capture rate setting set in the Tools > Options > ViewletCam tab. 
 

▪ In the Information area, there are no actions to take. And since you are NOT 
selecting an active window or a screen area, this area will be blank. 
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▪ Click Finish. The Capture full screen window will minimize and you are ready to 
start your capture session. 

▪ By default, right before you begin your capture session, a hint will display above 
your system tray, prompting you to press the applicable hotkey combination to 
start your capture session. 
 

 
 

▪ Press the applicable hotkey combination to start your screenshot session. 
▪ Perform the tasks as needed during your recording session. 
▪ If you need to pause the capture session, press the applicable hotkey 

combination. To resume, press the same hotkey combination and the session will 
continue. 

▪ Once you are finished with the capture session, press the Start / Stop hotkey 
combination to end your capture session. 

▪ ViewletCam2 will display your new project. At this point, save the project before 
you begin working on it. 

 
If you have any questions about creating new Full Screen Area projects, contact 
support@qarbon.com. 
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PowerPoint Presentation (New Project) 
The ViewletCam2 Add-On for PowerPoint makes it easy to capture PowerPoint 
presentations and turn them into Flash movies. Just install the ViewletCam2 Add-On for 
PowerPoint and configure it. Then, right from within PowerPoint, use the “add-on” to 
record your project. Finish up in ViewletCam2 to edit and publish your captured 
presentation as a Flash movie. It’s that simple. 
 

Review the chapter on Creating a New Project Basics for some introductory information 
on creating projects from PowerPoint presentations first and then continue with the steps 
outlined here. 

 
There are four basic steps to creating a new project from a PowerPoint presentation: 

1. Install the ViewletCam2 Add-On for PowerPoint 
2. Configure the ViewletCam2 Add-On for PowerPoint 
3. Record the presentation using the ViewletCam2 Add-On for PowerPoint 
4. Save, edit and publish the project to Flash 

 
Let’s walk through each of these steps: 
 
1.  Install the ViewletCam Add-On for PowerPoint. 

▪ Open your PowerPoint program and look for the ViewletCam2 Add-On for 
PowerPoint toolbar. 
 

 
 

▪ If the toolbar is NOT installed, double check the toolbars available in PowerPoint 
to make sure it is not hidden. To do this, right click on any toolbar in PowerPoint 
and check the list for menu for the ViewletCam toolbar. If there is no checkmark 
next to it, the toolbar, though installed, is hidden. Click it to display it with the 
other toolbars. 
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▪ If the ViewletCam toolbar is not in the list, you will need to install it by running 

the ViewletCam2 installation wizard again. 
 

▪ If running the installation wizard again, make sure PowerPoint and ViewletCam2 
are both closed.  

 
▪ Run the ViewletCam2 installation wizard. When you get to the Select Additional 

Tasks setup window, select the Enable ViewletCam2 Add-on for Microsoft 
PowerPoint. 
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▪ Click Next and follow the wizard screens to complete the reinstallation process. 
▪ Open Microsoft PowerPoint and verify that the ViewletCam2 Add-On for 

PowerPoint toolbar is now installed. 
 
 
2.  Configure the ViewletCam2 Add-On for PowerPoint. 
The next step to creating a new project from a PowerPoint presentation is to configure 
the add-on. This can be accomplished from within ViewletCam2 (as discussed in the 
ViewletCam2 Options chapter) or directly from within PowerPoint. In this chapter, we will 
discuss configuring the add-on from inside PowerPoint. 
 

▪ Inside PowerPoint, locate the ViewletCam2 Add-On for PowerPoint toolbar. 
▪ Click on the ViewletCam plug-in configuration options button. 

 

 
 

▪ The ViewletCam2 Add-On Options window displays with two available tabs for 
configuration settings. 
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▪ Select the ViewletCam tab. 
o In the Capture Mode area: 

 

 
 

a. Select a “mode” for your computer to use while capturing 
screenshots: 
 DirectX (Default): DirectX is a collection of APIs (application 

programming interfaces) for handling tasks related to 
multimedia, including video, on Microsoft platforms. 

 GDI: GDI (graphical device interface) is a Microsoft Windows 
interface for representing graphical objects and transmitting 
them to output devices like monitors. 

 
b. If you are unsure as to which capture mode to use, click the 

Select the mode automatically and let ViewletCam2 test your 
system to make the best selection. 

c. To set the Capture times per second (frame rate) default (how 
many seconds will pass between screen captures), drag the 
handle along the sliding bar to set the number of seconds. 

 
o In the Record Hotkey area: 
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ViewletCam2 uses predefined keystroke combinations or “hotkeys” to 
allow you to Start / Stop and Pause / Resume your capture session 
while running the presentation. Settings made in the add-on from within 
PowerPoint will NOT change the default options set inside ViewletCam2. 

 
a. Start / Stop hotkeys: 
 To set the Start / Stop hotkeys, which are used to begin and 

end a screenshot session, click the button to the right of the 
“Start / Stop” text. The Select Hot key window displays. 
 

 
 

 Follow the instructions in the Select Hot Key window. The new 
hotkey combination will display in the screen if it is able to be 
used for a hotkey. 

 Click OK to apply.  
 

This hotkey combination works like a toggle. When first pressed, the screenshot session 
will begin. When the hotkey combination is pressed again, the screenshot session will 
end. 

 
b. Pause / Resume hotkeys: 
 To set the Pause / Resume hotkeys, which are used to pause 

and resume an active screen capture session, click the button 
to the right of the “Pause / Resume” text.  

 Follow the instructions in the Select Hot Key window. The new 
hotkey combination will display in the screen if it is able to be 
used for a hotkey. 

 Click OK to apply. 
 

This hotkey combination works like a toggle. When first pressed during an active 
recording session, the recording will pause. When the hotkey combination is pressed 
again, the recording session will resume (continue) for that same session. 
 
 
You can also press the Esc key at anytime to end the PowerPoint presentation recording 
session. 
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o In the Audio area: 
 

 
 

ViewletCam2 offers several ways to enhance your Viewlet project with the 
addition of sound. These features are detailed in the chapter on Sound 
Recording. In this section, you will learn how to set up default sound 
recording preferences for all existing and new projects. As previously 
mentioned, these sound recording preferences can be modified in other 
areas of the program prior to creating new projects or recording new 
sound tracks. 

 
To capture sound while capturing a presentation: 
 Select the Record sound option. 
 Click the Setup button. The Sound window displays. 

 

 
 

 In the Sample size area, select either 8 bit or 16 bit. 
 In the Sample rate area, select a rate to use when recording 

audio. The higher the sample rate, the better quality the sound file, 
but the bigger the resulting file size. 

 In the Sound source area select where the sound will be recorded 
from. If you want to record computer sounds while capturing 
onscreen actions, select “Computer” as the sound source. 
However, you can only capture EITHER computer sounds or 
microphone input, not both, during an onscreen capture session. 

 Click OK to apply. 
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o In the PowerPoint tab, if you select the Launch Presentation and Start 
recording “record mode” option, and you want a “tip” to display each time 
your capture session begins, select the Show record trackbar tip next 
time option. 
 

 
 

▪ Select the PowerPoint tab. 
o To set the “window size” that will be used while recording your 

presentation (top of tab): 
a. Select FullScreen to launch the presentation full screen.  

 

 
 

b. If you want to set a custom size for the recording session, make 
sure the FullScreen option is deselected and change the Width 
and Height in the fields provided. If the dimensions are smaller 
than your monitor settings, the PowerPoint presentation will play 
back centered on your screen during the capture session with 
black around the edges. 

 
o In the Record mode area: 

This section (located at the middle to bottom of the tab) contains several 
options all related to recording mode settings. 

a. Select Launch Presentation and Start recording to have the 
capture session begin when the presentation is launched. 
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b. Select Launch Presentation and press hotkey to start 
recording to manually begin the capture session of your 
presentation by pressing a predefined hotkey combination. 
 
If you select the second mode option, you will be prompted to use 
your hotkey. Click OK to close the window before pressing your 
hotkey. 
 

 
 

If you don’t want the “tip” window to display before starting a PowerPoint capture session 
using a hotkey combination, deselect the Show tip again option. 
 

o Select the Hide mouse track option if you do not want to include cursor 
animation. 

o Select the Show hotkey tip next time option if you want a tip window 
displayed before initiating a capture session of your presentation using a 
hotkey combination. 

o Click Browse to locate the folder where you want your ViewletCam2 
project to be saved. This is the project ViewletCam2 creates automatically 
once your capture session is finished. 
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▪ Click OK to save the settings in the ViewletCam2 Add-On Options window. 
 
3.  Record the presentation using the ViewletCam2 Add-On for PowerPoint. 
Once you’ve configured all of your options for the add-on, you are now ready to capture 
your PowerPoint presentation. To do this: 
 

▪ Click the ViewletCam (Launch slideshow and start ViewletCam recording) 
button. 
 

 
 

▪ If a tip displays, click OK to close it. We suggest deselecting all tip options for 
more efficiency during the capture session, but the choice is up to you. 

▪ If you set your “record mode” to automatically launch the PowerPoint 
presentation, the screen capture session will begin immediately. 

▪ If you set your “record mode” to use a hotkey to start the capture session, click 
the applicable hotkey combination to begin your onscreen capture session. 

▪ Let the presentation run while ViewletCam2 captures it. Use the Pause / 
Resume hotkey combination to pause / resume the capture session as needed. 
Use the Start / Stop hotkey combination to quickly end the capture session. 
 

You can end the capture session by pressing the Esc key. 
 

 
4.  Save, edit, preview and publish to Flash. 
Once the capture session ends, ViewletCam2 will open, producing a source file ending 
in .vcp. This file contains all of the elements of the capture session, including all 
onscreen animations and audio, if applicable. At this point, you should: 
 

▪ Save your new ViewletCam2 source file. To do this, select File > Save from the 
menu options or press Ctrl + S on your keyboard. The project is saved in the 
location set for the “project directory” when configuration the add-on in the 
ViewletCam2 Add-On Options window in the PowerPoint tab. 

▪ Edit your project along the Timeline as needed. 
▪ Use the “VCR-style” button on the button toolbar to preview your project inside 

ViewletCam2. 
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▪ Select File > Export SWF from the menu bar. 
 

 
 

▪ The Export SWF window displays.  Select options for the quality of graphics and 
sound; select a location to publish the Flash (.swf) file to; and select a 
compression setting. 

▪ Click OK to publish the source file to Flash format. 
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▪ The newly published Flash file displays in a window in your default browser. 
Watch the Flash file play. When done, close the browser window to return to 
ViewletCam2. 

 
If you have any question about creating new projects from PowerPoint presentations, 
contact support@qarbon.com. 
 



 
 
 

 
ViewletCam2 User Manual page 53 rev. 02/15/2010 

Defining Capture Hotkeys 
ViewletCam2 allows you to define keystroke combinations or “hotkeys” to start, stop, 
pause and resume onscreen capture sessions. These can be set up as global defaults 
and changed for new projects as needed. 
 

▪ Defining hotkeys when setting up ViewletCam2 Options (program preferences): 
When setting up ViewletCam2 preferences (from the menu bar Tools > 
Options), in the ViewletCam tab, you can set up hotkey combinations to use to 
Start / Stop and to Pause / Resume the capture session. The hotkey 
combinations set up in this tab become the default hotkeys for all new capture 
sessions. 
 

▪ Defining hotkeys when creating a new project: When you create a new project, 
you will have the opportunity to change the default hotkey combinations defined 
when creating program preferences. This can be done: 

o In the Capture window when creating a new project using an Active 
Window, Screen Area or Full Screen capture project type. 
Note: For more information on setting hotkey combination defaults in 
ViewletCam2, see the chapter on Screen Capture Preferences. 
 

o When creating a new project from a PowerPoint presentation; select the 
ViewletCam plug-in configuration options button on the ViewletCam 
toolbar and edit the hotkeys in the ViewletCam tab. 
Note: For more information on setting hotkey combinations when 
creating new projects, please review one of the chapters on new 
projects. 

 
If you have any questions, please contact support@qarbon.com. 
 



 
 
 

 
ViewletCam2 User Manual page 54 rev. 02/15/2010 

Sound 
ViewletCam2 offers several ways to enhance your Viewlet project with the addition of 
sound. Sound features include recording sound for narration purposes while capturing 
onscreen actions for synchronous sound across the project. Or, if you prefer, you have 
the ability to capture sound effects produced by the computer (mouse clicks, for 
example) while capturing onscreen actions to produce an even more realistic 
demonstration. Additional sound options (such as inserting external sound files) are also 
available while editing the project inside ViewletCam2. 
 
This chapter provides information on setting up program sound preferences for new 
projects, understanding sound options, inserting sound files into a project while editing 
and working with the sound layer. 
 
Sound Recording Preferences 
Sound recording preferences can be set up as program defaults or when creating a new 
project: 
 
 Setting sound preference program defaults: Inside ViewletCam2, select Tools > 

Options from the menu bar. Select the ViewletCam tab. In the Audio area, select 
the Record Sound option then click the Settings button. The Sound window 
displays where you can set program defaults for sample size, sound source and 
sample rate. 
 

 Setting sound preferences when creating a new project: When you create a new 
project, you will have the opportunity to change the default sound recording 
preferences. This can be done: 

o In the Capture window when creating a new project using an Active 
Window, Screen Area or Full Screen capture project type. 
Note: For more information on setting sound recording defaults in 
ViewletCam2, see the chapter on Screen Capture Preferences. 
 

o When creating a new project from a PowerPoint presentation; select the 
ViewletCam plug-in configuration options button on the ViewletCam 
toolbar. Select the ViewletCam tab. In the Audio area, select the Record 
Sound option then click the Settings button. The Sound window displays 
where you can edit sound recording preferences as needed. 
Note: For more information on setting sound recording preferences when 
creating new projects, please review one of the chapters on new projects. 
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Understanding Sound Recording Options (Sound window) 
You will see various options when selecting sound recording preferences in the Sound 
window whether you are setting program defaults or modifying these settings when 
creating a new project. Here’s some information to help you decide what settings will 
work best for you: 
 
Sample Size: This is the number of bits of data sampled and, for audio, is often 
expressed as 8 bits or 16 bits. The 8 bit sample is best suited for strict voice narration, 
not music. The 16 bit sample provides a better sample quality and is suited for both 
voice and music. The greater the audio sample size, the bigger the resulting file size. 
 

 
 

In most cases, keeping the default 16 bit sample size selected works fine for most 
ViewletCam2 projects. 

 
Sample Rate:  This is the frequency at which the bits of data are sampled. The 
frequency is measured in kHz and often expressed in 11.025 kHz, 22.050 kHz, 44.1 kHz 
and 48 kHz. The higher the sample rate, the better the quality, but the bigger the 
resulting file size.  
 

 
 

If you are unsure as to what sample rate to use and will be deploying your demonstrations 
via the web, select 22050 Samples per sec for a good balance between sound quality and 
playback (file size) performance. 

 
Sound Source: This is the source from which the sound will be captured. ViewletCam2 
offers three options for this: 
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 Microphone: Select this option if you will use a PC or external microphone to 

capture sound (usually for voice narration) during the capture session. 
 

 Computer: Select this option if you want to capture computer sounds during the 
capture session. You would also use this option when capturing sound while 
recording PowerPoint presentations. 
 

 Default: If you want to use the default audio recording device configured for your 
system, select this option. 
 

You can capture EITHER microphone input or computer sounds, not both, during a 
capture session. 

 
For more information on sound recording preferences in the Sound window, please refer 
to any of the chapters on new projects or the chapter on Screen Capture Preferences. 
 
Inserting Sound 
Once you create a project, you have the ability to insert sound from an external audio file 
or by recording it directly inside ViewletCam2. The first step for both processes is to: 
 
 Select a frame along the Timeline. This is the point where the sound file will be 

inserted into the project. 
 

 Select Insert > Sound from the menu options. 
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 The Sound window displays. To select an external sound file: 
 

o Select the Sound from wav file option. 
 

 
 

o Click the Browse button to locate and select your sound file. Supported 
sound files include .wav and .mp3. 

o Once the sound file is selected, back in the Sound window, click Play to 
preview the sound. 

 
 To record a sound file: 

o Select the Record sound from microphone option. 
 

 
 

o Click the Setup button to review the sound preferences and modify the 
settings in the window that displays as needed. 

o Click Record and start recording your audio file. Each time you click 
Record, a new recording file will be started and the previous one will be 
wiped out. 

o Click Stop to end the recording. 
o Click Play to preview the new recording. 

 
 If this will be the “main” sound file to play across all frames during the 

demonstration, select the Synchronized Streaming Sound option. 
 

 
 
Only one sound layer may be synchronized with the main Graphics layer. If one 
sound layer is already set to be synchronized with the Graphics layer and you try 
to sync up a second one, a warning window will display. 
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 Click OK to insert the sound into the project. A sound layer will be added a long 
the Timeline to the project. 

 
The Dub Tool 
You can add voice narration easily while previewing the project inside ViewletCam2. 
This can be done using the traditional steps to insert a new sound file. Or, skip 
unnecessary steps by using a new feature called the “Dub” tool. To insert voice 
narration: 
 
 Select the frame along the Timeline where you want the voice narration to start. 
 Click the Dub button on the toolbar. 

 

 
 

 Start recording your voice narration as the project plays along the Timeline. To 
stop the voice recording, click the Dub button again. 

 A new Sound layer will display along the Timeline. To make it synch with the 
main Graphics layer, right click on the Sound layer. 

 In the Sound window that displays, select the Synchronized Streaming Sound 
option. 

 Click OK to close the window. 
 

Be prepared to start speaking immediately after clicking the Dub button since the sound 
recording session will start as soon as you press the button. 

 
 
The Sound Layer 
If you record sound when creating a new project or insert a sound file into an existing 
project, the sound file itself will be represented along the Timeline in its own layer.  
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The sound file itself is not directly embedded into the source .vcp project. So, if you need 
to edit it, look for the file in the project folder, open it in an external audio editor, edit as 
needed and then reinsert the edited file into the project. If you do this, you should 
remove the original file from the project to avoid confusion. 
 

If you delete frames along the Timeline, the associated frames along the Sound Layer will 
also be deleted whether or not the layer is synched with the Graphics layer. Once frames 
are deleted, this action cannot be undone. 

 
Once the file is published, all audio is directly embedded into the published file. 
 
Synchronized Sound 
It’s important to sync your main Sound layer with the “Graphics” layer for optimal 
playback results. If you are not sure if the sound layer is synced with the Graphics layer: 
 
 Right click on the Sound layer to display a right click shortcut menu. 
 Select Properties from the menu. 
 The Sound window displays. Select the Synchronized Streaming Sound 

option. 
 Click OK.  

Note: A warning will display if another Sound layer is already synced with the 
Graphics layer and you will be prompted to cancel the action or to apply it.  
 

 
 

 
As mentioned earlier in this chapter, only one Sound layer may be synchronized with the 
Graphics later at a time. So, what happens if you have multiple Sound layers in your 
project and want all of them in sync with the Graphics layer? No problem. There is a new 
feature that will allow you to merge Sound layers: 
 
 Start by holding down the Ctrl key while selecting the Sound layers you want to 

merge together into one Sound layer. 
 Right click to display the shortcut menu. 
 Select the Mix audio layers option from the right click menu. 
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 The result will be the selected Sound layers will be merged into a single Sound 

layer displayed along the Timeline. Right Click on this layer and select 
Properties.  

 In the Sound window, make sure the Synchronized Stream Sound option is 
selected and click OK. 

 Play back the project, starting from the first frame. As you listen to the 
demonstration, you will “hear” where the single Sound layer plays back all the 
sounds now merged into this single layer AND this layer is (most importantly) 
now synced with the Graphics layer for optimal playback performance. 

 

When merging movies that contain sound layers, if the audio was created using 
ViewletCam2, when merged, the sound layers will automatically merge into a single layer 
into the newly merged project IF all sound attributes are the same for both sound layers. 

 
Moving, Disabling and Deleting a Sound Layer 
While working with the Sound layer, you can also move the interval at which the Sound 
will start playing along the time: 
 
 Point your cursor over the left edge of the Sound layer’s “frequency” wave. When 

the cursor changes to a double-headed arrow, hold down the left mouse button. 
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 Drag the “sound wave” along the Timeline. 
 Let go of the left mouse button to drop it into its new location along the Timeline. 

 
If you temporarily want to turn a Sound layer “off” in your project, that’s easy to do: 
 
 Select the Sound layer. 
 Next to the word “Sound” at the left of the layer, deselect the check box. This will 

disable the layer so that it will not play, nor will it include the Sound in the 
published file if this option is left deselected. 
 

 
 

 To turn the Sound layer back on, select the check box again. 
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There may be times you want to remove a Sound layer from the project. To do this: 
 
 Select the Sound layer. 
 Right click and select Delete from the right click menu. Or, press Delete on your 

keyboard. 
 

 
 
If you have any questions about working with Sound in ViewletCam2, please contact 
support@qarbon.com. 
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Timeline Overview 
ViewletCam2 uses a “Flash-styled” editing environment. One of its main features is the 
Timeline that, by default, sits below the staging area. And, it is along the Timeline where 
most of your project editing will occur. The Timeline contains layers that make up your 
ViewletCam2 project. Each of these layers work together so when the project is played 
back, the result is a dynamic presentation. You can edit the objects and actions in each 
layer along the Timeline as needed, as well as hide and lock layers.  
 

 
 
Timeline Components 
The Timeline is comprised of various components that you will use while editing your 
project. These include: 
 
 Frames Reference Guide 
 Frames and Key Frames 
 Playhead 
 Layers 
 Objects (notes, graphics, cursor, sound, buttons) 
 Flags, Actions, Labels 

 
The Timeline components listed above are discussed in more detail in the chapters that 
follow.  If you have any general questions about Timeline features, please contact 
support@qarbon.com. 
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Frames 
At the top of the Timeline, you will see a “guide bar” known as the Frames Reference 
Guide. Along this guide bar, there are small “sections” known as frames, divided by 
tickmarks into 1/10 of second intervals. Special key frames occur along the Timeline, 
which are “key points” along the Timeline where an animation begins or ends. When you 
select a frame, a playhead displays, marking the current frame on the Timeline. 
 

 
 
To select a single frame: 
 Point your cursor over a tickmark on the guide. 
 Click your left mouse button to select the frame. 

 
To select multiple frames: 

 Point your cursor over a frame. 
 Hold down your left mouse button and drag along the Timeline to highlight the 

desired frames. 
 

 
 
 
To delete frames: 
 Select the frames you want to delete. 
 Press the Delete key on your keyboard, or select Edit > Delete from the menu 

bar. 
 A window will display asking, “Are you sure to delete this part of the move?” Click 

Yes to confirm the deletion or click No to cancel the action. 
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Note: Once you delete frames you cannot undo the action. 

 
To disable key frames: 
 Select the Graphics layer. 
 Point your cursor over a “key frame” indicator found along the layer until your 

cursor changes to a “grab hand” shape. 
 

 
 

 Hold down the Ctrl + Shift keys while clicking on the key frame to disable it. 
When the project plays back, there will be no animation change on the Graphics 
layer at this point along the Timeline since the key frame is now disable.  

 To enable the key frame, hold down the Ctrl + Shift keys while clicking on the 
key frame. 
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To add a frame label to a frame: 
 

Frame labels can be added to a frame to give you more control for viewer interaction on 
determining where the viewer will be directed along the Timeline during playback. This can 
be an essential element in an effective Viewlet demonstration. 

 
 Select the frame where the label will be inserted. 
 Right click and select Insert frame label from the shortcut menu. 

 

 
 

 A Frame Label window displays. Type a name for the label in the field provided. 
 

 
 

 Click OK. A small circle will display on the selected frame on the Timeline 
indicating the frame label has been added. 
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To rename a frame label: 
 Right click on the “small circle” frame label indicator on the Timeline. 
 The Frame Label window displays. Edit the frame label name as needed. 
 Click OK to save the changes. 

 
To manually advance along the Timeline: 
 Click on a frame to display the playhead.  
 Point your cursor over the playhead and when the cursor changes to a double-

headed arrow, drag the playhead along the guide. This action is called 
“scrubbing” the Timeline. 

 To stop on a specific frame, let go of the left mouse button. 
 
To play a project to preview it along the Timeline: 
 Click on the frame where you want to start previewing the project along the 

Timeline. 
 There are two ways to play back the project inside ViewletCam2: 

o Select Control from the menu bar and select one of the playback options. 

 
 
OR 
 

o Click one of the “VCR-style” navigation buttons on the button toolbar. 
 

 
 

 
To “jump” to the last frame: 
 Select the Jump to the end button on the button toolbar. 

 

 
 
OR 
 

 Select Control > End from the menu bar. 
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To “jump” to the first frame: 
 Select the Jump to the beginning button on the button toolbar. 

 

 
 
OR 
 

 Select Control > Beginning from the menu bar. 
 
If you have any questions about working with frames, please contact 
support@qarbon.com. 
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Layers 
Layers, a major component of the Timeline, make up the foundation of the project. 
Layers help separate graphics and objects so if one object is moving one way and 
another is moving another, they won’t run into each other because they are on different 
layers. Further, layers help arrange foreground and background and which objects will 
move behind and in front of other objects. Layers can be locked to prevent editing it from 
the stage. Also, a layer’s visibility can be turned on or off while working on the project. 
While working on complex projects, turning off a layer helps reduce clutter so that you 
can better see what you are doing. 
 
At a minimum, when a new project is first created, there are two basic layers: 
 
 Mouse layer: This layer contains all of the project’s cursor animation.  
 Graphics layer: This layer contains the main background images captured during 

the onscreen capture session. All other components, such as the cursor 
animation, notes, shapes, buttons, etc. sit on top of this layer. 

 
And, there is one additional layer if the Record Sound option is selected for new 
projects: 
 Sound layer: This layer contains the sound recorded during the capture session. 

 

 
 
These are displayed (top to bottom) in this order and cannot be changed: 
 Mouse layer 
 Graphics layer 
 Sound layer 

 

While editing a project, new layers are automatically added to the stack of layers. These 
include layers for notes, shapes, buttons and additional sound layers. 
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Additional layers that are added to the project while editing display between the Mouse 
and the Graphics layer, with the exception of new Sound layers. If new sound files are 
inserted into the project, new Sound layers (one for each sound file) are inserted at the 
bottom of the Timeline. 
 

 
 
To edit a layer: 
 Click on a layer to select it. 
 If the layer is an object such as a note or a button, double click the object to edit 

its contents.  
 You can also right click on a layer and select an edit option from the shortcut 

menu. 
 
To display / hide a layer: 
 By default, all new layers are displayed (or enabled) for editing and playback 

purposes. This is indicated by the checkmark in the box along the layer above 
the “eye” icon at the bottom of the stack of layers. 
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 To hide (disable) a layer, deselect this check box above the “eye” icon (next to 
the layer’s title). 

 To display (enable) a layer, select the check box. 
 
To lock / unlock a layer: 
 By default, all new layers are unlocked so that they can be edited. This is 

indicated by an “unchecked” box on the layer above the “padlock” at the bottom 
of the stack of layers. 
 

 
 

 To lock a layer (to prevent it from being edited from the stage), select the check 
box on the layer in the “padlock” column. 

 To unlock a layer (so it can be edited), deselect the check box. 
 

 

Locking a layer prevents you from editing it by clicking on it from the stage (canvas area). 
You can still edit a locked layer using Timeline editing (such as moving it along the 
Timeline, changing its persistence / duration along the Timeline and right clicking it on the 
Timeline to select Properties to edit it).
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To move layers in the stack: 

 Select the layer to highlight it. 
 Right click to display the shortcut menu. 
 Select Layer from the shortcut menu. 
 Select an option to move the layer as needed. 

 

 
 

Not all layers can be moved. For example, the Mouse and Graphics layers cannot be 
moved. And, the Sound layer that is synched with the Graphics layer cannot be reordered 
in the stack either. All other layers can be moved within their stacks. 

 
To mix audio layers: 
Since you can only synch one Sound layer with the main Graphics layer at a time, you 
may need to “merge” additional Sound layers to create one Sound layer. To do this: 
 
 Select the Sound layers that you want to merge. To do this, hold down the Ctrl 

key while clicking on Sound layers to select them. 
 Right click and select Mix audio layers from the shortcut menu. By default, this 

new merged Sound layer is synched with the main Graphics layer. 
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To delete a layer: 
 Select the layer. 
 Press the Delete key on your keyboard. Or, select Edit > Delete from the menu 

bar. 
 

If you accidentally delete a layer and this was your last action, press Ctrl + Z to undo the 
deletion. 
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To collapse / expand a group of layers: 
There are two subgroups of layers that can be collapsed or expanded as needed. These 
are the layers created for: 
 Note, Image, Text, Ellipse, Rectangle, Line, Text Field, Colorful Note, and Button 

objects 
 
AND 
 

 Sound files 
 

 
 

 To collapse one of these subgroups of layers, click the “box” to the left of the 
layers. 

 To expand these layers, click the “box” to the left again. 
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To group / ungroup layers: 
 Select the desired layers. 
 Right click and select Group from the shortcut menu. This will group the layers 

into one layer with the title “Group”.  
 

Objects in grouped layers will all start / end on the same frames. Do NOT use this option to 
mix audio layers.  
 

 To ungroup layers, right click a “Group” layer to display the shortcut menu. 
 Select Ungroup from the shortcut menu. 

 
If you have any questions about working with layers, contact support@qarbon.com. 
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Message Objects 
ViewletCam2 offers several ways to enhance the “message” you are trying to get across 
to viewers through the use of text objects. These text objects (also referred to as 
message objects) can be added to frames and come in three main forms: 
 
 Note 
 Colorful Note 
 Text Box 

 
You can impact with the careful addition of message objects throughout your project. 
These are especially useful when no audio narration is included. Of course, you can 
“kick it up a notch” by supplementing existing audio narration with message objects too! 
 
Let’s take a look at each of these message objects. 
 
Note 
The first message object is the plain-style Note. It comes in two types: rectangular or 
elliptical shape. A Note can be added to any frame in the project. As a “vector” object, 
you can customize its text content, size, border, fill, pointer position and location on the 
slide. Additionally, if you use the “Movie Size” option (Tools > Movie Size) to scale your 
project’s dimensions, the Note object, including the text inside of it, will scale 
proportionally. 
 
To create a Note: 
 Select a frame to insert the Note on. 
 Click the Insert note button on the Edit toolbar. 
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 The Note Properties window displays. Before typing in your text, set the 
properties for the text to display in this Note. 
 

 
 

 
 Select a font from the Font list. 
 Select a text size from the Size list. 

 Click the Bold   button to bold text, if desired. 

 Click the Italics  button to italicize text, if desired. 

 Click the Underline  button to underline text, if desired. 

 Click one of the alignment buttons to Left Align  , Center Align , or  

Right Align  text within the Note. 
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 To change the text color: 

o Click the Color   button. 
o In the Colors window that displays, select a color from the Standard or 

Custom tab. 
 

 
 

o Click OK to apply the color and to return to the Note Properties window. 
 Once the text attributes are set, type your text in the field provided. 
 Select a basic note Type by clicking the radio button next to the desired shape. 

 

 
 

 If you want to select additional options for your text, click the Font button. 
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 In the Font window that displays, select additional font attributes as desired. 
 

 
 

 Click OK to save the font attributes and to return to the Note Properties window. 
 Click OK to save the information and to close the Note Properties window. 

 The cursor will change to a cross-hair    shape. Position your cursor over the 
area of the stage where you want to start drawing the Note. 

 Hold down the left mouse button and drag to form the Note shape. 
 Let go of the left mouse button to drop the Note into place. 

 

 
 



 
 
 

 
ViewletCam2 User Manual page 81 rev. 02/15/2010 

 

Don’t worry if you don’t get the size or position of the Note “just right” the first time you 
draw it. You can fix this after you draw the Note. 
 
 

To resize a Note: 
 Select the Note object. A bounding box will display around the message object. 
 Point your cursor over one of the “grab handles” (gnodes). 

 

 
 

 When the cursor changes to a double-arrow shape, hold down the left mouse 
button and drag to resize the Note. 

 
To change the position of the Note’s pointer: 
 Select the Note. 
 Point your cursor over the grab handle at the edge of the Note’s pointer. 
 When the cursor changes to a four-headed arrow, hold down your left button and 

drag the pointer to a new location. You will see the pointer’s outline displayed as 
you drag it. 
 

 
 

 Let go of the left mouse button to drop the pointer into its new position. 
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To remove the Note’s pointer: 

 Select the Note. 
 Point your cursor over the grab handle at the edge of the Note’s pointer. 
 When the cursor changes to a four-headed arrow, hold down your left mouse 

button and drag it until you are over one of the corner grab handles. As you do 
this, you should see the pointer disappear into the outline of the shape. 

 Let go of the left mouse button to finish the operation. 
 
To move the Note’s location: 

 Select the Note. 
 Point your cursor over the Note and hold down your left mouse button. 
 Drag the Note to its new position. 
 Let go of the left mouse button to drop the Note into place. 

 

To “fine tune” the placement of a message object, select the message object and then use 
the arrow keys on your keyboard to move the object one pixel at a time. 

 
To change the fill color of the Note: 

 Select the Note. 
 Click the Select fill color button on the toolbar. 

 

 
 

 Select a color from the palette. Or: 
o Click Custom. 
o In the Colors window that displays, select a color from the Standard or 

Custom tab. 
o Click OK to apply the selected color. 
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To change the transparency level of a Note’s fill color: 
 Select the Note. 
 Click the Select fill color button. 
 At the top of the drop-down menu of colors that displays, hold down your left 

mouse button and drag your cursor over the “transparency box”. Watch the fill 
color’s transparency change as you move the cursor in this box. 
 

 
 

 Let go of the left mouse button to set the new transparency level. 
 

To make the fill color “more solid”, drag the cursor to the left. To make it more 
“transparent”, drag the cursor to the right. 

 
 
To change the line width of the Note: 

 Select the Note. 
 Click the Select line width button on the toolbar. 

 

 
 

 Select a new line width from the drop-down menu that displays. 
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To change the Note’s line color: 
 Select the Note. 
 Click the Select line color button from the toolbar. 

 

 
 

 Select a color from the palette. Or: 
o Click Custom. 
o In the Colors window that displays, select a color from the Standard or 

Custom tab. 
o Click OK to apply the selected color. 

 
To change the transparency level of a Note’s line color: 

 Select the Note. 
 Click the Select line color button. 
 At the top of the drop-down menu of colors that displays, hold down your left 

mouse button and drag your cursor over the “transparency box”. Watch the line 
color’s transparency change as you move the cursor in this box. 
 

 
 

 Let go of the left mouse button to set the new transparency level. 
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To make the line color “more solid”, drag the cursor to the left. To make it more 
“transparent”, drag the cursor to the right. 

 
To edit the Note’s text or other properties: 

 Double click the Note. 
 The Note Properties window displays. Change the settings or text as desired. 
 Click OK to save the changes. 

 
To delete a Note: 

 Select the Note. 
 Press the Delete key on your keyboard. Or, select Edit > Cut from the menu 

bar. 
 

If you accidentally delete a Note, and it’s the last action you performed, simply press  
Ctrl+ Z to undo your last action to restore the Note. 

 
Colorful Note 
The next message object is the Colorful Note. It comes in a variety of styles and can be 
added to any frame in the project. Though you can edit most of its properties as you 
would a plain Note, since it is a “bitmap” object, unlike a plain Note, you will NOT be able 
to edit a Color Note’s line width, or the transparency levels of the fill or line color. 
Additionally, if you use the “Movie Size” option (Tools > Movie Size) to scale your 
project’s dimensions, the Colorful Note object will scale proportionally with the exception 
of the text within it. The text will need to be manually resized after the project is scaled 
for best results. 
 
To create a Colorful Note: 
 Select a frame to insert the Colorful Note on. 
 Click the Insert Color note button on the Edit toolbar. 
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 The Colorful Note Properties window displays. Before typing in your text, set the 
properties for the text to display in this Colorful Note. 
 

 
 
 Select a shape for the Colorful Note by clicking on an image in the Style list to 

the left of the window. Scroll through the options as needed. 
 If you want the Colorful Note to have a pointer, select the Show arrow option 

below the Style list. Deselect Show arrow if you do not want a pointer. 
 Select a font from the Font list. 
 Select a text size from the Size list. 

 Click the Bold   button to bold text, if desired. 

 Click the Italics  button to italicize text, if desired. 

 Click the Underline  button to underline text, if desired. 

 Click one of the alignment buttons to Left Align  , Center Align , or  

Right Align  text within the Note. 
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 To change the text color: 

o Click the Color   button. 
o In the Colors window that displays, select a color from the Standard or 

Custom tab. 
 

 
 

o Click OK to apply the color and to return to the Colorful Note Properties 
window. 

 Once the text attributes are set, type your text in the field provided. 
 Click OK to save the information and to close the Colorful Note Properties 

window. 

 The cursor will change to a cross-hair    shape. Position your cursor over the 
area of the stage where you want to start drawing the Colorful Note. 

 Hold down the left mouse button and drag to form the Colorful Note shape. 
 Let go of the left mouse button to drop the Colorful Note into place. 
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Don’t worry if you don’t get the size or position of the Colorful Note “just right” the first 
time you draw it. You can fix this after you draw it. 
 
 

To resize a Colorful Note: 
 Select the Colorful Note object. A bounding box will display around the message 

object. 
 Point your cursor over one of the “grab handles” (gnodes). 
 When the cursor changes to a double-arrow shape, hold down the left mouse 

button and drag to resize the Colorful Note. 
 
To change the position of the Colorful Note’s pointer: 
 Select the Colorful Note. 
 Point your cursor over the grab handle at the edge of the Colorful Note’s pointer. 
 When the cursor changes to a four-headed arrow, hold down your left button and 

drag the pointer to a new location. You will see the pointer’s outline displayed as 
you drag it. 

 Let go of the left mouse button to drop the pointer into its new position. 
 
To remove the Note’s pointer: 

 Double click the Colorful Note. 
 The Colorful Note Properties window displays. 
 Deselect the Show arrow option. 

 

 
 

 Click OK to save the changes and to close the Colorful Note Properties window. 
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To move the Colorful Note’s location within a frame: 
 Select the Note. 
 Point your cursor over the Colorful Note and hold down your left mouse button. 
 Drag the Colorful Note to its new position. 
 Let go of the left mouse button to drop the Colorful Note into place. 

 

To “fine tune” the placement of a message object, select the message object and then use 
the arrow keys on your keyboard to move the object one pixel at a time. 

 
To change the fill color of the Colorful Note: 

 Select the Colorful Note. 
 Click the Select fill color button on the toolbar. 

 

 
 

 Select a color from the palette. Or: 
o Click Custom. 
o In the Colors window that displays, select a color from the Standard or 

Custom tab. 
o Click OK to apply the selected color. 
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To change the Colorful Note’s line color: 
 Select the Colorful Note. 
 Click the Select line color button from the toolbar. 

 

 
 

 Select a color from the palette. Or: 
o Click Custom. 
o In the Colors window that displays, select a color from the Standard or 

Custom tab. 
o Click OK to apply the selected color. 

 
To edit the Colorful Note’s text or other properties: 

 Double click the Colorful Note. 
 The Colorful Note Properties window displays. Change the settings or text as 

desired. 
 Click OK to save the changes. 

 
To delete a Colorful Note: 

 Select the Colorful Note. 
 Press the Delete key on your keyboard. Or, select Edit > Cut from the menu 

bar. 
 

If you accidentally delete a Colorful Note, and it’s the last action you performed, simply 
press Ctrl+ Z to undo your last action to restore the Colorful Note. 
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Text Box 
The next message object is the Text Box (also known as a text frame). Use this 
message object to blend the text seamlessly with the background image of any frame. 
As a “vector” object, you can customize its text content, size, border, fill, and location on 
the slide. Additionally, if you use the “Movie Size” option (Tools > Movie Size) to scale 
your project’s dimensions, the Text Box object, including the text inside of it, will scale 
proportionally. 
 
To create a Text Box: 
 Select a frame to insert the Text Box on. 
 Click the Insert text button on the Edit toolbar. 

 

 
 

 The Text Box Properties window displays. Before typing in your text, set the 
properties for the text to display in this Text Box. 
 

 
 

 
 Select a font from the Font list. 
 Select a text size from the Size list. 

 Click the Bold   button to bold text, if desired. 

 Click the Italics  button to italicize text, if desired. 

 Click the Underline  button to underline text, if desired. 

 Click one of the alignment buttons to Left Align  , Center Align , or  

Right Align  text within the Note. 
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 To change the text color: 

o Click the Color   button. 
o In the Colors window that displays, select a color from the Standard or 

Custom tab. 
 

 
 

o Click OK to apply the color and to return to the Text Box Properties 
window. 

 Once the text attributes are set, type your text in the field provided. 
 If you want to select additional options for your text, click the Font button. 
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 In the Font window that displays, select additional font attributes as desired. 
 

 
 

 Click OK to save the font attributes and to return to the Text Box Properties 
window. 

 Click OK to save the information and to close the Text Box Properties window. 

 The cursor will change to a cross-hair    shape. Position your cursor over the 
area of the stage where you want to start drawing the Text Box. 

 Hold down the left mouse button and drag to form the Text Box shape. 
 Let go of the left mouse button to drop the Text Box into place. 

 

 
 

Don’t worry if you don’t get the size or position of the Text Box “just right” the first time 
you draw it. You can fix this after you draw it. 
 
 

To resize a Text Box: 
 Select the Text Box object. A bounding box will display around the message 

object. 
 Point your cursor over one of the “grab handles” (gnodes). 
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 When the cursor changes to a double-arrow shape, hold down the left mouse 
button and drag to resize the Text Box. 

 
To move the Text Box’s location within a frame: 

 Select the Text Box. 
 Point your cursor over the Text and hold down your left mouse button. 
 Drag the Text Box to its new position. 
 Let go of the left mouse button to drop the Text Box into place. 

 

To “fine tune” the placement of a message object, select the message object and then use 
the arrow keys on your keyboard to move the object one pixel at a time. 

 
To change the fill color of the Text Box: 

 Select the Text Box. 
 Click the Select fill color button on the toolbar. 

 

 
 

 Select a color from the palette. Or: 
o Click Custom. 
o In the Colors window that displays, select a color from the Standard or 

Custom tab. 
o Click OK to apply the selected color. 
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To change the transparency level of a Text Box’s fill color: 
 Select the Text Box. 
 Click the Select fill color button. 
 At the top of the drop-down menu of colors that displays, hold down your left 

mouse button and drag your cursor over the “transparency box”. Watch the fill 
color’s transparency change as you move the cursor in this box. 
 

 
 

 Let go of the left mouse button to set the new transparency level. 
 

To make the fill color “more solid”, drag the cursor to the left. To make it more 
“transparent”, drag the cursor to the right. 

 
 
To change the line width of the Text Box: 

 Select the Text Box. 
 Click the Select line width button on the toolbar. 

 

 
 

 Select a new line width from the drop-down menu that displays. 
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To change the Text Box’s line color: 
 Select the Text Box. 
 Click the Select line color button from the toolbar. 

 

 
 

 Select a color from the palette. Or: 
o Click Custom. 
o In the Colors window that displays, select a color from the Standard or 

Custom tab. 
o Click OK to apply the selected color. 

 
To change the transparency level of a Text Box’s line color: 

 Select the Text Box. 
 Click the Select line color button. 
 At the top of the drop-down menu of colors that displays, hold down your left 

mouse button and drag your cursor over the “transparency box”. Watch the line 
color’s transparency change as you move the cursor in this box. 
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 Let go of the left mouse button to set the new transparency level. 
 

To make the line color “more solid”, drag the cursor to the left. To make it more 
“transparent”, drag the cursor to the right. 

 
To edit the Text Box’s properties: 

 Double click the Text Box. 
 The Text Box Properties window displays. Make edits as desired. 
 Click OK to save the changes. 

 
To delete a Text Box: 

 Select the Text Box. 
 Press the Delete key on your keyboard. Or, select Edit > Cut from the menu 

bar. 
 

If you accidentally delete a Note, and it’s the last action you performed, simply press  
Ctrl+ Z to undo your last action to restore the Note. 

 
If you have any questions about message objects, please contact support@qarbon.com. 
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Shape Objects 
ViewletCam2 allows you to draw creative custom designs in your project through the use 
of shape objects. The shape objects available are: 
 

 Straight Lines 
 Rectangles 
 Ellipses 

 
These shapes can be drawn, colored, resized, layered, etc. to add visual impact to your 
demonstration. This chapter provides an overview to get you starting working with these 
shape tools. 
 
Straight Line 
Use the line tool to draw straight lines directly on the canvas. You can also draw multiple 
lines on the canvas in the same frame and then group them into an individual layer if 
desired to form one shape. Let’s look at some of the ways to work with the line tool. 
 
To draw a line: 

 Select the frame where you want to insert the line object. 
 Click the Insert line button on the Edit toolbar. 

 

 
 

 Move your cursor over the canvas and when your cursor changes to a cross-
hair, hold down your left mouse button and drag to draw the line. 
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 Let go of the left mouse button to drop the line into place. 
 

 
 
To resize a line: 
 Select the line so that the bounding box displays around it. 
 Point your cursor over one of the grab handles (gnodes) until the cursor changes 

to an arrows shape. 
 Hold down the left mouse button and drag to resize the line. 
 Let go of the left mouse button to complete the resizing action. 

 
To move a line within a frame: 
 Select the line. 
 Point your cursor over the line, hold down the left mouse button, and drag the 

line to its new position. 
 Let go of the left mouse button to drop the line into place. 
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To change the line’s thickness: 
 Select the line. 
 Click the Select line width button from the toolbar. 

 

 
 

 Select a new width from the menu options. 
 
 
To change the line’s border color: 
 

Depending upon the thickness of the line, when using this option, the line’s border color 
may “appear” to also be the line’s fill color.  

 
 Select the line. 
 Click the Select line color button on the toolbar. 
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 Select a color from the palette of colors. Or: 
o Click Custom. 
o In the Colors window that displays, select a color from the Standard or 

Custom tab. 
o Click OK to apply the selected color. 

 
To change the transparency level of a line’s border color: 

 Select the line. 
 Click the Select line color button. 
 At the top of the drop-down menu of colors that displays, hold down your left 

mouse button and drag your cursor over the “transparency box”. Watch the line’s 
border color transparency change as you move the cursor in this box. 
 

 
 

 Let go of the left mouse button to set the new transparency level. 
 

To make the line color “more solid”, drag the cursor to the left. To make it more 
“transparent”, drag the cursor to the right. 
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To change the line’s fill color: 
 Select the line. 
 Click the Select line fill color button. 

 

 
 

 Select a color from the palette of colors. Or: 
o Click Custom. 
o In the Colors window that displays, select a color from the Standard or 

Custom tab. 
o Click OK to apply the selected color. 

 
To change the transparency level of a line’s fill color: 

 Select the line. 
 Click the Select fill color button. 
 At the top of the drop-down menu of colors that displays, hold down your left 

mouse button and drag your cursor over the “transparency box”. Watch the line’s 
fill color transparency change as you move the cursor in this box. 
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 Let go of the left mouse button to set the new transparency level. 
 

To make the line color “more solid”, drag the cursor to the left. To make it more 
“transparent”, drag the cursor to the right. 
 

To change the line type (and other line properties): 
 Right click on the line and select Properties from the shortcut menu, or double 

click the line object. The Line window displays. 
 

 
 

 Select a new Line width, Fill color and Border Color as needed. 
 To change the line type, in the Type area, click the radio button next to the new 

line type as desired. These include a straight line, single arrowhead, and a 
double arrowhead. 

 Click OK to apply the changes. 
 
To delete a line: 
 Select the line. 
 Press Delete on your keyboard. Or, select Edit > Delete from the menu bar. 

 
Rectangle 
Use the rectangle tool to create shapes with right angles such as squares and 
rectangles. You can also start with right angles and then change the type to smooth 
corners. Let’s take a look at how to work with rectangle shapes. 
 
To draw a rectangle: 

 Select the frame where you want to insert the rectangle object. 
 Click the Insert rectangle button on the Edit toolbar. 
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 Move your cursor over the canvas and when your cursor changes to a cross-
hair, hold down your left mouse button and drag to draw the rectangle. 

 Let go of the left mouse button to drop the rectangle into place. 
 

 
 
To resize a rectangle: 
 Select the rectangle so that the bounding box displays around it. 
 Point your cursor over one of the grab handles (gnodes) until the cursor changes 

to an arrows shape. 
 Hold down the left mouse button and drag to resize the rectangle. 
 Let go of the left mouse button to complete the resizing action. 

 
To move a rectangle within a frame: 
 Select the rectangle. 
 Point your cursor over the rectangle, hold down the left mouse button, and drag 

the rectangle to its new position. 
 Let go of the left mouse button to drop the rectangle into place. 

 
To change the rectangle’s border thickness: 
 Select the rectangle. 
 Click the Select line width button from the toolbar. 
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 Select a new width from the menu options. 
 
 
To change the rectangle’s border color: 
 Select the rectangle. 
 Click the Select line color button on the toolbar. 

 

 
 

 Select a color from the palette of colors. Or: 
o Click Custom. 
o In the Colors window that displays, select a color from the Standard or 

Custom tab. 
o Click OK to apply the selected color. 
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To change the transparency level of a rectangle’s border color: 
 Select the rectangle. 
 Click the Select line color button. 
 At the top of the drop-down menu of colors that displays, hold down your left 

mouse button and drag your cursor over the “transparency box”. Watch the 
rectangle’s border color transparency change as you move the cursor in this 
box. 
 

 
 

 Let go of the left mouse button to set the new transparency level. 
 

To make the line color “more solid”, drag the cursor to the left. To make it more 
“transparent”, drag the cursor to the right. 

 
To change the rectangle’s fill color: 
 Select the rectangle. 
 Click the Select line fill color button. 
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 Select a color from the palette of colors. Or: 
o Click Custom. 
o In the Colors window that displays, select a color from the Standard or 

Custom tab. 
o Click OK to apply the selected color. 

 
To change the transparency level of a rectangle’s fill color: 

 Select the rectangle. 
 Click the Select fill color button. 
 At the top of the drop-down menu of colors that displays, hold down your left 

mouse button and drag your cursor over the “transparency box”. Watch the 
rectangle’s fill color transparency change as you move the cursor in this box. 
 

 
 

 Let go of the left mouse button to set the new transparency level. 
 

To make the line color “more solid”, drag the cursor to the left. To make it more 
“transparent”, drag the cursor to the right. 
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To change the rectangle properties: 
 Right click on the rectangle and select Properties from the shortcut menu, or 

double click the line object. The Rectangle window displays. 
 

 
 

 Select a new Line width, Fill color and Border Color as needed. 
 In the Type area, you can change the shape of the rectangle from sharp right 

angle corners to smooth rounded corners. Just select the radio button next to the 
desired shape type. 

 Click OK to apply the changes. 
 
To delete a rectangle: 
 Select the rectangle. 
 Press Delete on your keyboard. Or, select Edit > Delete from the menu bar. 

 
 
Ellipse 
Use the ellipse tool to create round shapes such as ovals and circles. Let’s take a look at 
how to work with elliptical shapes. 
 
To draw an ellipse: 

 Select the frame where you want to insert the ellipse. 
 Click the Insert ellipse button on the Edit toolbar. 

 

 
 

 Move your cursor over the canvas and when your cursor changes to a cross-
hair, hold down your left mouse button and drag to draw the ellipse. 
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 Let go of the left mouse button to drop the ellipse into place. 
 

 
 
To resize an ellipse: 
 Select the ellipse so that the bounding box displays around it. 
 Point your cursor over one of the grab handles (gnodes) until the cursor changes 

to an arrows shape. 
 Hold down the left mouse button and drag to resize the ellipse. 
 Let go of the left mouse button to complete the resizing action. 

 
To move an ellipse within a frame: 
 Select the ellipse. 
 Point your cursor over the ellipse, hold down the left mouse button, and drag the 

ellipse to its new position. 
 Let go of the left mouse button to drop the ellipse into place. 
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To change the ellipse’s border thickness: 
 Select the ellipse. 
 Click the Select line width button from the toolbar. 

 

 
 

 Select a new width from the menu options. 
 
To change the ellipse’s border color: 
 Select the ellipse. 
 Click the Select line color button on the toolbar. 
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 Select a color from the palette of colors. Or: 
o Click Custom. 
o In the Colors window that displays, select a color from the Standard or 

Custom tab. 
o Click OK to apply the selected color. 

 
To change the transparency level of an ellipse’s border color: 

 Select the ellipse. 
 Click the Select line color button. 
 At the top of the drop-down menu of colors that displays, hold down your left 

mouse button and drag your cursor over the “transparency box”. Watch the 
ellipse’s border color transparency change as you move the cursor in this box. 
 

 
 

 Let go of the left mouse button to set the new transparency level. 
 

To make the line color “more solid”, drag the cursor to the left. To make it more 
“transparent”, drag the cursor to the right. 
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To change the ellipse’s fill color: 
 Select the ellipse. 
 Click the Select line fill color button. 

 

 
 

 Select a color from the palette of colors. Or: 
o Click Custom. 
o In the Colors window that displays, select a color from the Standard or 

Custom tab. 
o Click OK to apply the selected color. 

 
To change the transparency level of an ellipse’s fill color: 

 Select the ellipse. 
 Click the Select fill color button. 
 At the top of the drop-down menu of colors that displays, hold down your left 

mouse button and drag your cursor over the “transparency box”. Watch the 
ellipse’s fill color transparency change as you move the cursor in this box. 
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 Let go of the left mouse button to set the new transparency level. 
 

To make the line color “more solid”, drag the cursor to the left. To make it more 
“transparent”, drag the cursor to the right. 
 

To change the ellipse’s properties: 
 Right click on the ellipse and select Properties from the shortcut menu, or 

double click the line object. The Ellipse window displays. 
 

 
 

 Select a new Line width, Fill color and Border Color as needed. 
 Click OK to apply the changes. 

 
To delete an ellipse: 
 Select the ellipse. 
 Press Delete on your keyboard. Or, select Edit > Delete from the menu bar. 

 
If you have any questions while working with shape objects, please contact 
support@qarbon.com. 
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Image Objects 
ViewletCam2 allows you to insert image files directly onto frames in your project. The 
supported image formats include: 
 
 JPEG 
 PNG 
 BMP 
 TARGA 
 GIF 

 
Once an image is inserted into a project, its own unique layer is created. You can work 
with the Image layer as you would any other object layer within your project. 
 
To insert an image file: 
 Select the frame where you want to insert the image file on. 
 Select Insert > Image from the menu bar. 

 

 
 

 The Image window displays. Click Browse and search for and select your image 
file. Click OK. 
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 The Image window displays a preview of the image. Click OK to close this 
window to insert the image. 
 

 
 

 The cursor will change to a cross-hair shape. Place it over the canvas where you 
want to insert the image and click once to insert the image on the canvas. 
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To resize an image: 
 Select the image. 
 A bounding box displays around the image. Position your cursor over one of the 

grab handles (gnodes). 
 Hold down your left mouse button and drag to resize the image. 
 Let go of the left mouse button to complete the resizing action. 

 
To move an image within a frame: 
 Select the image. 
 Point your cursor over the image, hold down the left mouse button and drag the 

image to its new location. 
 Let go of the image to drop it into place. 

 
To delete an image: 
 Select the image. 
 Press the Delete key on your keyboard, or select Edit > Delete from the menu 

bar. 
 
If you have any questions while working with images, please contact 
support@qarbon.com. 
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Grouping & Ungrouping Objects 
For easier manipulation of individual objects or a group of objects, you can group them 
together and ungroup them.  This technique DIFFERS from the “Group / Ungroup” 
functionality of layers. Here we are talking about grouping the objects themselves 
without combining their layers. 
 
To group / ungroup objects: 
 Hold down the Shift + Ctrl keys while clicking to select each object. As you 

select objects in this manner, you will notice that a dotted rectangle surrounds 
the selected objects indicating they are now in a group. 
 

 
 

 To ungroup objects, click outside of the dotted rectangle anywhere on the frame 
to deselect the objects. 

 
Use the alignment buttons on the Alignment toolbar that displays when objects are 
grouped to realign objects simultaneously. 
 
If you have any questions about grouping objects, please contact support@qarbon.com. 
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Moving Objects on the Timeline 
There are two different ways to move an object. As discussed in previous chapters, you 
can move objects within a frame. This chapter describes how to move objects across 
frames while working with the Timeline. There are several ways to do this, so let’s 
explore a few of them now. 
 
To move an object by dragging it on the Timeline: 
 Select the object by selecting its layer. 
 Point your cursor over the “yellow box” that indicates where the object will appear 

along the Timeline. 
 When the cursor changes to a grab-hand shape, hold down the left mouse button 

and drag the yellow box along the Timeline. 
 

 
 

 Let go of the left mouse button to drop the object into its new frame location. 
 
 
To move an object to a specific time interval or frame on the Timeline: 
 Select the object so that a bounding box appears around it. 
 Right click on the object and select Moving to a frame from the shortcut menu. 

The Moving to a frame window displays. 
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 In the Moving to a frame area, there are several options for moving the object to 
a specific interval (frame) on the Timeline: 
 

 
 

o To move the object to a specific second interval: 
-Take the number of seconds and multiple it by 1000 and enter the result 
in the field provided. So, for example, if you want to move the object to 
the 5 second interval, type 5000 in the field. 
-Select Resume. 
 

o Select To the head to move the object to the beginning of the Timeline. 
o Select To the end to move the object to the end of the Timeline. 
o To move the object to a specific frame for which you’ve created a frame 

label: 
-Click the down arrow for the Goto a label list. 
-Make a selection from the list as desired. 
 

 Click OK to close Moving to a frame window and to move the object accordingly. 
 
If you have any questions about moving objects on the Timeline please contact 
support@qarbon.com. 
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Persistent Objects 
ViewletCam2 offers you the ability to increase or decrease the length of time objects are 
displayed on the Timeline. These objects are known as “persistent objects” and you can 
increase or decrease their duration directly in the object’s layer itself or via right click 
shortcut menu options. Let’s look at some ways to work with this feature. 
 
To change the duration of an object by dragging it along the Timeline: 
 Select the object by selecting its layer. 
 Point your cursor over the edge of the “yellow box” that indicates where the 

object will appear along the Timeline. 
 When the cursor changes to a double arrow, hold down the left mouse button 

and drag the cursor either left or right to change the duration of the object. The 
“smaller” the yellow box becomes, the shorter the duration, and the “bigger” the 
yellow box becomes, the longer the duration. 
 

 
 

 Let go of the left mouse button to complete the action. 
 
To increase an object’s duration (persistence) on the Timeline: 
 Select the object so that a bounding box appears around it. 
 Right click on the object and select Moving to a frame from the shortcut menu. 

The Moving to a frame window displays. 
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 In the Duration area, there are several options for modifying the duration or 
persistence of an object on the Timeline: 
 

 
 

o To change the object’s duration by increasing/decreasing seconds:  
-Take the number of seconds and multiple it by 1000 and enter the result 
in the field provided. So, for example, if you want the object to persist on 
the Timeline for 5 seconds, type 5000 in the field. 
-Select Resume. 
 

o To make the object persistent from its starting point to the end of the 
project: 
-Select the Over all frames option. This will extend the duration of the 
object from its current starting point to the last frame of the project. 

 
o To make the object persistent from its starting point to a specific frame on 

the Timeline for which you’ve created a frame label: 
-Click the down arrow for the Goto a label list. 
-Make a selection from the list as desired. This will extend the duration of 
the object from its current starting point to the last frame of the project. 
 

 Click OK to close Moving to a frame window and to change the duration of the 
object accordingly. 

 
If you have any question about persistent objects, please contact support@qarbon.com. 
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Cursor Animation on the Mouse Layer 
ViewletCam2 creates a Mouse layer in each of your projects whether or not the project 
contains any cursors in it. This layer contains all of the cursor images and movement 
that occurred during the capture session. It contains key frames indicating cursor click 
and also keyboard press actions. This chapter provides information to help you 
understand the function of the Mouse layer and covers: 
 
 The Mouse layer as viewed along the Timeline 
 Cursor animation 
 Cursor pointers (shapes) 
 Cursor click and keyboard press sounds 

 
Note: The words “mouse” and “cursor” are used interchangeable throughout this 
chapter. 
 
The Mouse Layer as Viewed Along the Timeline 
The Mouse layer is the top layer of every ViewletCam2 project and cannot be moved. 
This layer contains elements common to other layers as well as two additional “key 
frame” indicators. It is on this layer where all the cursor action occurs. 
 

 
 
You can hide, unhide, lock (disable), and unlock (enable) this layer as you would any 
other layer. You cannot, however, disable key frames along thing this layer. The key 
frames include: 
 
 Cursor key frame: This is indicated by the white box along the Mouse layer. It is 

at this point along the Mouse layer that the position of the cursor changes on the 
stage. In some cases, the background image may also change if a key frame is 
indicated at the same point in the main Graphics layer. 

 Mouse click action key frame: This is indicated by the red box along the Mouse 
layer. It is at this point (frame) where a mouse click action occurs (and was 
recorded during the screen capture session). 
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 Keyboard press action key frame: This is indicated by the green box along the 
Mouse layer. It is at this point (frame) where a keyboard press action occurs (and 
was recorded during the screen capture session). 

 
To move a key frame along the Mouse layer: 
 Point your cursor over the key frame on the Mouse layer. 
 When the cursor changes to a grab-hand shape, hold down you left mouse 

button. 
 Drag the key frame along the Timeline. All of the key frames AFTER this key 

frame will move in relation to this key frame. 
 

 
  

 Let go of the left mouse button to drop the key frame into its new location on the 
Timeline. 

 
 
Cursor Animation 
If cursor movement was recorded during the screen capture session, it will display in the 
staging area as you move along the Timeline. The position of the cursor may not change 
frame-to-frame, but its path will be illustrated by a red line. Along the cursor path, there 
are red “points” that indicate where the cursor momentarily stops while traveling along its 
path. Cursor animation occurs at each key frame (white box indicator) along the Mouse 
layer on the Timeline. 
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To change the “red point” along the cursor path: 
 Point your cursor over the red point on the cursor path. 
 When the cursor changes to a grab-hand shape, hold down the left mouse 

button. 
 Drag the red point as needed. 

 

 
 

 Let go of the left mouse button to drop the red point in its new location along the 
newly modified cursor path. 

 

To remove “excessive” cursor movement along the cursor path, simply delete the frames 
containing the applicable key frame. Or, move any red points in the middle of the cursor 
path on top of the ending red point. 

 
 
Cursor Pointers (Shapes) 
Click on a key frame contained in the Mouse layer then look up at the staging area. You 
will see the cursor shape that will display during this part of the demonstration along the 
Timeline. As you play back the project, the shape of this cursor may change. You are not 
“stuck” with only the cursors captured during the screen capture session. You can easily 
change the shape of any cursor with ViewletCam2’s built-in pointers and you can also 
view all the cursors that will be used in the project in one glance. Let’s take a look at 
some of the cursor pointer options available. 
 
To view all the cursors used in the project: 
 Right click on a cursor or on the Mouse layer and select Properties from the 

shortcut menu. The Mouse window displays. 
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 In the Pointers tab, you will see a list of cursor shapes being used throughout the 
project in the Pointers list. 

 
To change a cursor pointer: 
 In the Mouse window, select the Pointers tab. 
 In the list that displays under Pointers, select a cursor shape by clicking it. 
 In the Customize list, select a new replacement shape by clicking it. 
 Click the Replace button. 

 

 
 
 Click OK and the selected cursors will be replaced with the replacement shape. 
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To restore a cursor pointer to its original shape: 
 In the Mouse window, select the Pointers tab. 
 Select the desired shape from the Pointers list. 
 Click the Resume button to remove the replacement cursor. 
 Click OK and all of the selected cursors will be restored to the original pointer 

shape. 
 
To add a custom pointer to the Customize list: 
 In the Mouse window, select the Pointers tab. 
 Click the Browse button. 
 Select the image file that contains the desired pointer shape. 
 Click Open. 
 Click Add to add it to the list. 

 
To delete a custom pointer: 
 In the Mouse window, select the Pointers tab. 
 Select a pointer from the Customize list. 
 Click the Delete button. 

 
 
Mouse Click and Keyboard Press Actions 
When you look along the Mouse layer, you may see some “green” and “red” boxes. As 
previously discussed at the beginning of this chapter, these indicate key frames. The 
“red” box indicates where a mouse click action occurs. The “green” box indicates where 
a keyboard press action occurs. These actions were recorded during the screen capture 
session. You can move the point along the Timeline where these actions occur as you 
would any other key frame. You can also add sound to these actions. 
 
To add sound to a mouse click action: 
 Right click on the Mouse layer and select Properties from the shortcut menu. 
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 The Mouse window displays. Select the Sound tab. 
 

 
 

 For the Mouse event area, select either Click or Double Click. 
 For the Sound file select an option from the list. 

 

 
  

 To listen to the sound file, click Play. 
 To add a custom sound file to the list of options, click Browse and search for and 

select the sound file to add to the list. 
 Click OK and the sound file will now play at each “red” mouse click action key 

frame point along the Timeline. 
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To add sound to a keyboard press action: 
 Right click on the Mouse layer and select Properties from the shortcut menu. 
 The Mouse window displays. Select the Sound tab. 
 For the Mouse event area, select Press key. 
 For the Sound file select an option from the list. 

 

 
  

 To listen to the sound file, click Play. 
 To add a custom sound file to the list of options, click Browse and search for and 

select the sound file to add to the list. 
 Click OK and the sound file will now play at each “green” keyboard press action 

key frame point along the Timeline. 
 
To create a sound “scheme” for mouse click and keyboard press actions: 
 In the Mouse window, select the Sound tab. 
 Make a selection for the Mouse event. 
 Make a selection for the Sound file. 
 Once the selections are made for each mouse event and its associated sound 

file, in the Scheme field, type in a name for the new scheme. 
 Click the Save button to add it to the list. 

 

 
 

 Click OK to close the Mouse window. 
 
To delete a sound “scheme”: 
 In the Mouse window, select the Sound tab. 
 Select a Scheme from the list. 
 Click the Delete button. 

 
If you have any questions working with the Mouse layer or cursors, please email 
support@qarbon.com. 
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Stop Flags, Actions & Events 
Are you ready to take your demonstration to the next level? ViewletCam2 offers you 
features that give you almost total control over your project and the ability to force user 
interaction. This way you can engage your viewer and turn your demonstration from a 
“how to” to a “this I can do” presentation for your audience. 
 
There are several ways to control what happens when you play back your demonstration 
beyond the basic “video” portion. This chapter provides an overview of some of the tools 
you can use to enhance interactivity in your project, which include stop flags and events 
/ actions. 
 
Stop Flags 
The stop flag option gives you the control to determine where the demonstration will stop 
along the Timeline during playback. This feature, when combined with other interactive 
elements (an interactive button, for example), is essential for any effective Viewlet 
presentation. 
 
To add a stop flag to a frame: 
 Select the desired frame where the stop action will occur. 
 Right click on the frame’s tickmark along the guide and select Insert stop flag 

from the shortcut menu. 
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 This will insert a red arrowhead on the selected frame on the Timeline. This 
indicates where the demonstration will stop, requiring some type of viewer 
interaction or “action” to occur for the Viewlet to continue. 
 

 
 

 
To move a stop flag on the Timeline: 
 Point your cursor over the stop flag indicator. 
 When the cursor changes to a grab-hand shape, hold down the left mouse 

button. 
 Drag the stop flag along the Timeline. 
 Let go of the left mouse button to drop the stop flag on to a new frame. 

 
To search for stops flags along the Timeline: 
 Right click on any frame along the Timeline to display the shortcut menu. 
 Select Next flag to move to the next flag along the Timeline. 
 Select Prev flag to move to the previous flag along the Timeline. 
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To delete a stop flag on the Timeline: 
 Select the stop flag. 
 Right click and select Delete flag from the shortcut menu. 

 
To delete all stop flags along the Timeline: 
 Right click a frame tickmark on the Timeline. 
 Select Remove all flags from the shortcut menu. 

 
Actions & Events 
Think of an Action as something that the viewer does to interact with the project or 
something that occurs while the project plays. For example, as the project plays, it may 
stop on a frame that contains a stop flag. On this frame, there may be a button. The 
action that the user might take is to “click the button”. An actions should have at least 
one Event associated with it. So, we can think of an event as something that happens 
as the result of an action. So, for example, when the viewer clicks the button, the event 
associated with the click action might be “play” (the project continues to play). 
 
Actions and events can be associated with various interactive objects available in 
ViewletCam2, a few of which are discussed in the chapter on Interactive Objects. For 
this example, let’s take a look at add actions and events directly to a frame on the 
Timeline. 
 
To add an action to a frame: 
 Right click on the frame where you want to add an action. 
 Select Insert action from the shortcut menu. 
 In the window that displays, click the  
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 Click the Add Event button. 
 Select one of the events to add to the Action list. To add multiple events for the 

same action, click the Add Event button and select another event. The order in 
which the events are listed from top to bottom is the order in which they will occur 
during playback. 

 Click Finish to add the action with its associated events to the selected frame. 
Now when the Viewlet plays this frame (the action), the selected events will 
occur. 
 
Note: An ”a” will display on the frame where the action is inserted on the 
Timeline. 
 

 
 

 
To reorder events in the Action list: 
 Point your cursor over the “a” in the frame that indicates an action has been 

inserted on the frame. 
 When the cursor changes to a grab-hand shape, right click and select Modify 

action from the shortcut menu. 
 In the window that displays, select an event from the Action list. 
 Click the Up / Down button to move the select event Up / Down in the list. 
 Click Finish to save the changes. 

 
To move an action to another frame on the Timeline: 

 Point your cursor over the “a” in the frame that indicates an action has been 
inserted on the frame. 

 When the cursor changes to a grab-hand shape, hold down the left mouse 
button. 

 Drag the “a” to a different frame. 
 Let go of the left mouse button to insert the action on a new frame. 

 
To delete an action from a frame on the Timeline: 

 Point your cursor over the “a” in the frame that indicates an action has been 
inserted on the frame. 

 When the cursor changes to a grab-hand shape, right click and select Delete 
flag from the shortcut menu. 

 
To remove all actions added directly to frames on the Timeline: 
 Right click on any tickmark along the guide on the Timeline. 
 Select Remove all flag from the shortcut menu. 

 
If you have any questions about stop flags, or actions and events, please contact 
support@qarbon.com. 
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Interactive Objects 
ViewletCam2 offers tools for advanced authors to force user input by including 
interactive objects throughout the project. These can come in the form of buttons, text 
fields and more. In this chapter, we will take a look at a few of these interactive objects 
that you can use to make your project more engaging for the viewer. 
 
Buttons 
You can force viewer interaction by including button objects throughout your 
ViewletCam2 project. Buttons can be used to switch from pause to play, to jump to 
different sections of a Viewlet, or even to go to a specific web page and more. There are 
four types of buttons available: 
 
 Simple button: This is a clickable 2-D button rendered as a flat image. 
 Special button: This is a clickable 3-D button rendered as an enhanced image 

selected from a list of available styles inside ViewletCam2. 
 Custom button: This is a clickable custom button created from an external image 

file. 
 Invisible button: This is a clickable “hidden” area that works like a hotspot. 

 
The simple, special and custom buttons have three “states” with images associated with 
them. These states are: 
 
 Up: This is the “state” when the button has no mouse hovering over it and is not 

being clicked. 
 Over: This is the “state” when the button has a mouse hovering over it, but is not 

being clicked. 
 Down: This is the “state” when the button is being clicked (pressed in). 

 
Let’s take a look at how to work with each of these button objects. 
 
To create a Simple button: 
 Select the frame where you want to insert the button. 
 Click the Insert button icon on the Edit toolbar. 
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 The Button window displays. Select Simple Button and click Next. 
 

 
 

 
 The Simple Button window displays. In the Caption field, type in the text to be 

used on the button. 
 

 
 

 Click the Font button. In the Font window that displays, make your font selection 
and click OK to save the information and to return to the previous window. 
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 In the Label Color area, to change the color of the text on the button, click each 
of the buttons for the various button states: Up, Over, and Down. In the Color 
windows that display, select a color from the Standard or Custom tabs. Click OK 
to apply and to return to the Simple Button window. 
 

 
 

 In the Fill Color area, to change the button’s fill color, click each of the buttons for 
the various button states: Up, Over, and Down. In the Color windows that 
display, select a color from the Standard or Custom tabs. Click OK to apply and 
to return to the Simple Button window. 
 

 
 

 In the Border area: 
 

 
 

o To change the button’s border color, click each of the buttons for the 
various button states: Up, Over, and Down. In the Color windows that 
display, select a color from the Standard or Custom tabs. Click OK to 
apply and to return to the Simple Button window. 

o To select a shape for the button, select the radio button next to one of the 
rectangle shapes of your choice (sharp edges or round edges). 

o To set the thickness of the border, enter a number in the Width field. 
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  In the Test Button area, preview the button “states” by previewing, rolling your 
mouse over and clicking the button image in the area provided. 
 

 
 

 Click Next. 
 The Event window displays. To have the Viewlet “do something” when the button 

is clicked: 
o For the Hotkey select Left button. 

 

 
 

o For the button state, select the radio button next to Up. 
 

 
 

o Click the Event button. Select an event from the list to add to the Action 
list. For example, if you want the Viewlet to continue when the viewer 
clicks the button, you would select Play from the events menu. 
 

 
 

 Click Finish. 
 The cursor will change to a cross-hair shape. Position the cursor on the canvas 

where you want the button to be and hold down the left mouse button. 
 Drag the mouse button to draw the shape of the button.  
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 Let go of the left mouse button to create the button. Resize and reposition the 
button as you would any other shape object. 
 

 
 

 
 
To create a Special button: 
 Select the frame where you want to insert the button. 
 Click the Insert button icon on the Edit toolbar. 
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 The Button window displays. Select Special Button and click Next. 
 

 
 

 
 The Special Button window displays. In the Caption field, type in the text to be 

used on the button. 
 

 
 

 Click the Font button. In the Font window that displays, make your font selection 
and click OK to save the information and to return to the previous window. 
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 In the Style area, select a button image for the button style from the list. 
 

 
 

 
 In the Label Color area: 

o To change the color of the text on the button, click each of the buttons for 
the various button states: Up, Over, and Down. In the Color windows that 
display, select a color from the Standard or Custom tabs. 
 

 
 

o To apply a shadow to the text that will be used as the label on the button, 
select the Shadow option. 

o To add change the text shadow color, click the Color button. Select a 
color as desired and click OK. 

 
 In the Test Button area, preview the button “states” by previewing, rolling your 

mouse over and clicking the button image in the area provided. 
 

 
 

 Click Next. 
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 The Event window displays. To have the Viewlet “do something” when the button 
is clicked: 

o For the Hotkey select Left button. 
 

 
 

o For the button state, select the radio button next to Up. 
 

 
 

o Click the Event button. Select an event from the list to add to the Action 
list. For example, if you want the Viewlet to continue when the viewer 
clicks the button, you would select Play from the events menu. 
 

 
 

 Click Finish. 
 The cursor will change to a cross-hair shape. Position the cursor on the canvas 

where you want the button to be and hold down the left mouse button. 
 Drag the mouse button to draw the shape of the button.  
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Let go of the left mouse button to create the button. Resize and reposition the button as 
you would any other shape object. 
 

 
 
 
 
To create a Custom button: 
 Select the frame where you want to insert the button. 
 Click the Insert button icon on the Edit toolbar. 
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 The Button window displays. Select Custom Button and click Next. 
 

 
 

 
 The Custom Button window displays.  

o To change the button image, click the Browse button for the various 
button states: Up, Over, and Down. 
 

 
 
Search for a button image and select it. Click Open and then click OK to 
return to the Custom Button window.  
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You can find premade button images in ViewletCam2 in the “Program 
Files\Qarbon\ViewletCam2\Images” folder. These buttons do not contain any text, but you 
can use the Text Box option to add text to the button once it is inserted on the frame. 
 

o Click the Add button to add the custom button to the list. The button 
shows in the preview area next to the button state. 
 

 
 

To remove a custom button from the list, select it and click Remove. 
 

 In the Test Button area, preview the button “states” by previewing, rolling your 
mouse over and clicking the button image in the area provided. 
 

 
 

 Click Next. 
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 The Event window displays. To have the Viewlet “do something” when the button 
is clicked: 

o For the Hotkey select Left button. 
 

 
 

o For the button state, select the radio button next to Up. 
 

 
 

o Click the Event button. Select an event from the list to add to the Action 
list. For example, if you want the Viewlet to continue when the viewer 
clicks the button, you would select Play from the events menu. 
 

 
 

 Click Finish. 
 The cursor will change to a cross-hair shape. Position the cursor on the canvas 

where you want the button to be and hold down the left mouse button. 
 Drag the mouse button to draw the shape of the button.  
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 Let go of the left mouse button to create the button. Resize and reposition the 
button as you would any other shape object. 

 
 If your Custom button does NOT have any text label on it, you can create the text 

label using a Text Box object. Place the Text Box over the button and make the 
Text Box border color and fill color totally transparent. See the chapter on 
Message Objects for more information on working with Text Box objects. 
 

 
 
 
To create an Invisible button: 
 Select the frame where you want to insert the button. 
 Click the Insert button icon on the Edit toolbar. 
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 The Button window displays. Select Invisible Button and click Next. 
 

 
 

 
 The Event window displays. To have the Viewlet “do something” when the 

invisible button is clicked: 
o For the Hotkey select Left button. 

 

 
 

o For the button state, select the radio button next to Up. 
 

 
 

o Click the Event button. Select an event from the list to add to the Action 
list. For example, if you want the Viewlet to continue when the viewer 
clicks this hotspot area, you would select Play from the events menu. 
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 Click Finish. 
 The cursor will change to a cross-hair shape. Position the cursor on the canvas 

where you want the invisible (hotspot) button to be and hold down the left mouse 
button. 

 Drag the mouse to draw the shape of the hotspot.  
 Let go of the left mouse button to create the button. Resize and reposition the 

invisible button as you would any other shape object. 
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To resize a button: 
 Select the button object so that the bounding box displays around it. 
 Point your cursor over one of the grab handles (gnodes) when the cursor 

changes to a double arrow, hold down the left mouse button. 
 Drag to resize the button as needed. 
 Let go of the left mouse button to complete the resizing action. 

 
To move the button on a frame: 
 Select the button object. 
 Point your cursor over the button and hold down the left mouse button. 
 Drag the button on the stage to its new location. 
 Let go of the left mouse button to drop it into place. 

 
To change the button properties: 
 Double click the button object. 
 The Button window displays. Go through the screens as needed to make your 

edits. 
 
To delete a button: 
 Select the button object or its layer. 
 Press the Delete key on your keyboard, or select Edit > Cut from the menu bar. 

 
 
Text Fields 
The Text Field is an advanced interactive feature that can be used to force the viewer to 
input data into a text field in order to continue with the demonstration. This is an example 
at its simplest form. When used in conjunction with an Invisible Button, the results can 
be very effective. Let’s take a look at one example of how to use a Text Field along with 
an Invisible Button to make the viewer input specific data in order to play the project. 
 
(Sample Lesson on Using a Text Field as a Password Input Field) 
How to Force the Viewer to Enter a Password in Order to Play the Viewlet: 

 
For this example we will be creating two text fields and one invisible button. The first 
text field will act as the “instructions to the viewer” box. The second text field will be 
used as an “input field”. The invisible button will handle the “actions and events” 
associated with the user input. 

 
▪ Select the first frame of your project and insert a stop flag so that the project 

stops on the first frame when it is played back. 
▪ While still on the first frame, select the Insert Text field button on the Edit 

toolbar. 
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▪ The cursor changes to a cross-hair shape. Click on the canvas area and hold 
down the left mouse button to draw the text field shape. Let go of the left mouse 
button to complete the shape. At this point, don’t worry about the size or 
placement of the box that can be fixed later. 
 

 
 

 
▪ Double click the Text Field. 
▪ The Text Field Properties window displays. In this window: 

 

 
 

o Select the Read Only option. This will prevent viewers from entering data 
in this Text Field since we want it to displays instructions to the user only. 

o Click the Text Color button and select a new color from the windows that 
display as needed. 

o Click the Font button and select font attributes as needed. 
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o In the Name field, give this Text Box a name. Remember this name 
because we will use it as a “variable” when creating the Invisible Button. 

o Select an alignment option for the text from one of the available buttons to 
Left Align, Center Align or Right Align the text in the box. 

o In the Default Entry field, type in the text you want to display in this Text 
Field. 
  

▪ Click OK to save the information for this first Text Field. 
▪ Make sure the Text Field is selected. You can resize it as needed. Also, at this 

point, as long as the Text Field is selected, you can use the various buttons 
along the Standard toolbar to change the Text Field’s border color, fill color and 
the font attributes for the text. 
 

 
 

▪ Now, let’s create the second Text Field that will be used for the viewer to input a 
password. Click the Insert Text field button on the Edit toolbar. 

▪ When the cursor changes to a cross-hair shape, hold down the left mouse button 
and draw the Text Field. 

▪ Double click the second Text Field box.  
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▪ The Text Field Properties window displays. In this window: 
 

 
 

o Select the Password option. When the user enters text into this field, the 
data will display as encrypted. 

o Select a Text Color and / or Font attributes if desired. 
o In the Name field, input a name for this Text Field. Remember this name 

because it will be used later when selecting a “variable” for the Invisible 
Button. 

o Select an alignment option by clicking one of the alignment buttons. 
o Leave the Default Entry field blank. 

▪ Click OK. 
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▪ Select the Text Field. Resize and reposition the field as needed. You can also 
improve the “look” of the field by using any of the buttons along the Standard 
toolbar to change the border’s width and color, or the object’s fill color, etc. as 
needed. 
 

 
 

▪ In order for these two fields to work together, we now need to insert an Invisible 
Button on this same frame. Click Insert button from the Edit toolbar. 

▪ In the Button window, select Invisible Button and click Next. 
▪ The Events window displays. In this window: 

o For the Hotkey, select Enter. 
 

 
 

o For the “button state”, make sure Up is selected. 
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o Click the Add Event button and select If else… from the list. 
 

 
 

o In the Action list, make sure that the IF option is selected. Make sure that 
it is followed by the variable name you used for the name of the second 
Text Field previously created. For this example, our second Text Field 
was named “input box”. 
 

 
 

o In the IF field, type in correct password the user will need to input in this 
field when prompted at the beginning of the demonstration during 
playback. 
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o Click the Add Event button and select Play from the list. In the Action list, 
the event Play should now be listed right below the “IF” statement. So, if 
the password is entered correctly, the Viewlet will play. 
 

 
 

o Select the ELSE statement in the Action list. Click the Add Event button 
and select Set variable… from the list. 
 

 
 

o From the Variable name list, select the variable name you used for the 
first Text Field previously created that will be used for “instructions” to the 
viewer. 
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o In the Set field, type in the text you want to be displayed to the viewer if 
they enter an incorrect password. 
 

 
 

▪ Click Finish to save these settings. 
▪ The cursor changes to a cross-hair shape. Point your cursor over the canvas 

area and hold down your left mouse button to drag and draw the Invisible Button 
shape. 

▪ Let go of the left mouse button to drop the Invisible Button into place. Make sure 
that it is not sitting over either of the Text Box fields. 

 
During the playback of the Flash file, this is what should occur: 

▪ Viewlet stops on first frame displaying both Text Fields, asking for the viewer to 
enter a password. 

▪ If the Viewer: 
o Correctly inputs the password, after pressing the Enter key, the Viewlet 

will play. 
o Incorrectly inputs the password, after pressing the Enter key, the alternate 

text set up when configuring the “ELSE” statement will display in the first 
Text Field. 

 
This is just one example of how Text Fields and Invisible Buttons can be used to force 
user input. If you have any questions about working with buttons, text fields or any 
interactive objects, please email support@qarbon.com. 
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Movie & Canvas Tools 
ViewletCam2 offers many options for polishing and optimizing your project beyond the 
tools available for working with objects and while editing along the Timeline. Among 
those covered in this chapter are: 
 

 Changing the canvas background color 
 Adjusting the canvas size 
 Cropping the movie 
 Scaling the movie 
 Adjusting the playback speed 
 Compressing your movie file 

 
All of these tools can be used BEFORE publishing your project. Let’s explore each of 
them now. 
 
Changing the Canvas Background Color 
When you look at the staging area, you see the main Graphics layer (and everything that 
is embedded on that layer captured during the onscreen recording session). This 
Graphics layer, which cannot be hidden in ViewletCam2, actually sits “on top” of the 
staging area’s canvas. This canvas area has a solid color that cannot be seen in most 
projects because of the Graphics layer on top of it. However, if you use the “Canvas 
Size” tool and resize the canvas area “larger” then the original project size, the Graphics 
layer will remain the original size, but the canvas behind it will become larger and its 
color will fill in around the images from the Graphics layer.  
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To change the canvas background color: 
 

 Select the Graphics layer. It doesn’t matter what frame is selected along the 
Timeline since the canvas background color is applied to the entire project. 

 Right click and select Properties from the shortcut menu. 
 

 
 

 The Properties window displays. Click the Background Color button. 
 

 
 

 The Colors window displays. Select a new background color from the Standard 
or the Custom tab and click OK to return to the Properties window. 
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 In the Properties window, click OK to apply the background color to the canvas. 
 
 

Adjusting the Canvas Size 
(Warning: Once you resize the canvas area, the action cannot be undone!) 
 
There is a tool that allows you to adjust the size of the staging area’s canvas size. Keep 
in mind that the main Graphics layer, which cannot be hidden, sits on top of the canvas. 
So, when you adjust the canvas size to make it bigger, the Graphics layer will remain the 
same size and the canvas behind it will increase. 
 
The option you will use to make the canvas larger is in the Canvas Size window. You 
can use this feature to make the canvas larger only. It will not make the canvas smaller 
(you will use a different tool for this, which is explained later in this chapter). 
 
To make the canvas larger: 

 Select Tools > Canvas Size from the menu bar. 
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 The Canvas Size window displays. In the Current Size area, you will see the 
Width and Height of the current project. 
 

 
 

 In the New Size area: 
o Input a number for the new Width. 
o Input a number for the new Height. 

 

To the right of the width and the height numbers, you will see a “+” symbol followed by a 
number. This number indicates how many pixels the canvas size has increased for each 
(width and height). 
 

o The Anchor is where the Graphics layer will be “anchored” as the canvas 
is resized. So, for example, if you want the Graphics layer centered when 
the canvas is resized, click in the middle of the “9 boxes” for the anchor. 
Then, the canvas will be resized and the Graphics layer centered on the 
new canvas area. 
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 Click OK to resize the canvas. The canvas is resized larger around the Graphics 
layer and, since the canvas is now bigger then the Graphics layer, the canvas’ 
background color displays around the Graphics layer. 

 
 
Cropping the Movie 
(Warning: Once you crop the movie, the action cannot be undone!) 
 
The Graphics layer, which sits on top of the canvas area, cannot be hidden. So, when 
you make the canvas area SMALLER then the current dimensions (width and height), 
the Graphics layer will be cut off. The tool to resizing the canvas area smaller is referred 
to as the Crop Movie option. So, essentially, when you use this tool to crop the movie, 
you are actually cropping the canvas area for the entire project. Let’s take a look at how 
this works. 
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To crop the canvas: 
 Select Tools > Crop Movie from the menu bar. 

 

 
 

 The canvas (staging area) will change. Everything in the red area will be 
cropped; everything inside the box (not highlight in red) will not be affected. 
Point your cursor over one of the edges of the “crop box”. When the cursor 
changes to a double arrow shape, hold down the left mouse button and drag to 
resize the canvas. 

 Once the canvas area is resized (cropped) as desired, let go of the left mouse 
button. 

 Click the green checkmark to complete the cropping action. Click the red X to 
cancel the action. 
 

Objects sitting “on top” of the staging area may need to be repositioned if they are no 
longer positioned “on stage” due to the cropping operation. 
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Scaling the Movie 
(Warning: Once you resize the movie, the action cannot be undone!) 
 
There is a feature in ViewletCam2 that will allow you to resize your movie by scaling it 
instead of cropping it. This is extremely handy when you need to resize your entire 
project without having to recapture it at a smaller capture size. 
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To scale the project: 
 Select Tools > Movie Size from the menu bar. 

 

 
 

 The Movie Size window displays. Change the Width and Height by typing a 
number in the fields provided. You can also change the size by typing a number 
in the Percent fields. 

 To maintain proper proportions when you change the width and height, select the 
Constrain Proportions option. 
 

 
 

 Select one of the image quality options as desired. 
 Click OK to change the movie size according to these new settings. 
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Adjusting the Playback Speed 
You can adjust the playback speed of your project without having to re-record it. You can 
slow the playback down to half-speed or increase the speed by up to two times. To do 
this: 
 
 Select the Graphics layer. 
 Right click on the staging area and select Properties from the shortcut menu. 
 In the Properties window, in the Play speed area: 

o Drag the bar to the left to decrease the playback speed. 
o Drag the bar to the right to increase the playback speed. 

 

 
 

 Click OK. The playback speed is adjusted at this point (prior to compilation) and 
you are returned to the project. 
 

If you have audio in your project, increasing or decreasing the playback speed will NOT 
increase or decrease the audio playback, which may cause the Viewlet to be out of 
synch. 
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Compress the Movie File 
ViewletCam2’s compression tool allows you to automatically compress your project into 
a smaller file size even before you publish. To do this: 
 
 Select Tools > Compress Movie from the menu bar. 

 

 
 

 Depending on the project size, you may see a status window briefly display. 
Then, you will see a window displaying the compression results. Click OK to 
close it and to return to the project. 
 

 
 

 
If you have any questions about working with the movie and canvas tools, please 
contact support@qarbon.com. 
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Splitting & Merging Projects 
What happens if your project is just too big? Or, perhaps you have smaller projects that 
you want to combine into one master demonstration without having to record everything 
all over again. Is this possible? In ViewletCam2, yes it is. 
 
ViewletCam2 offers tools for: 
 
 Splitting projects: Use this feature to break a big project into two smaller ones. 

You can also use this option to delete a section of the project permanently or 
save it to an entirely new project file for later use. 
 

 Merging projects: Use this feature to merge smaller projects into one big one 
even if the projects have different widths and heights. 

 
To split a project: 
 Select the frame along the Timeline where you want to split the project. 
 Select Tools > Split Movie from the menu bar. 
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 The Split movie from current position window displays:  
 

 
 

o In the Which part to cut area, select either: 
-Former: Cuts everything in front of the selected frame. 
-Latter:  Cuts every thing after the selected frame. 
 

o In the How to dispose cut part area, select either: 
-Throw away: Permanently deletes cut away frames. 
-Save as…: Saves the cut away frames into a new file. 
 

o If you selected Save as… in the How to dispose cut part area: 
-In the Project name field, type in a file name. 
-For the Project directory, click the Browse button to select a location to 
save the new file in. 
 

 Once all the selections are made, click OK to split the movie. 
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To merge projects: 
 Open the first project in ViewletCam2. 
 Select Tools > Merge Movie from the menu bar. 

 

 
 

 The Merge movie window displays: 
 

 
 

o In the Where to insert the movie area, select either: 
-At the beginning: The second movie will be inserted at the beginning of 
this project. 
-At the end: The second movie will be inserted at the end of this project. 
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o In the Aligning style area, select an alignment option for the movie that 
will be inserted. For example, if you want the inserted movie’s Graphics 
layer to be inserted from the center point in the canvas area in the 
merged project, select the “center box”. 

 
o Click the Browse button to locate and select the project you want to use 

to merge with this project. The path to the second project will display in 
the Choosing a movie you want to insert field. 

 
 Click OK to merge the selected file with the current project. 

 
The process of splitting or merging files can be as simple or as complex as you want to 
make it. Once you perform the action, you will still need to “tweak” the project to make 
sure everything plays back effectively in the new project(s). If you have any questions 
while working with these features, please contact support@qarbon.com. 
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Document Properties 
ViewletCam2 allows you to add authoring information and a project description to your 
project. To add or edit the document’s properties information: 
 
 Select File > Document Properties from the menu bar. 

 

 
 

 The Document Properties window displays: 
o In the Author field, type in the author’s name. 
o In the Description field, type in a summary of the project. 

 

 
 
This information is only available inside the source .vcp file from inside ViewletCam2.  If 
you have any question with document properties, please contact support@qarbon.com. 
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Player Control Bar & Preloader 
ViewletCam2 gives you the option to choose between several different player control 
bars that viewers can use when watching the published Flash file. You can also choose 
no player bar. To go along with the player control bar, you can select a “loading screen” 
(preloader). For bigger projects, a preloader is a smart choice because it will display the 
progress of the project as it is loading while the Viewlet streams in the background. 
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To select a player control bar and preloader for your project: 
 
 Select Tools > Play Control Bar from the menu bar. 

 

 
 

 The Control bar window displays: 
o Select a control player bar from the Style list.  
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o To add a “loading screen” (preloader) at the beginning of the movie 
during playback, select the Add Loading screen at the beginning of 
your movie option. 

o If you are selecting a preloader, in the percentage field, type in the 
percentage of the demonstration that you want to download (stream) 
before the Viewlet will start playing. 
 

 
 

If you use the loading screen option, the preloader, matching the style of the control 
player bar, will display at the beginning of the Flash file. 
 

 Click OK to save these settings and to close the Control bar window. 
 
If you have any questions regarding the control player bar or the loading frame 
(preloader) options, please contact support@qarbon.com. 
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Publishing (Export) Options 
Once you’ve finished editing your project, the final step is to publish it. The most 
common publishing option is exporting the project the Flash (.swf) format, but there are 
several to choose from.  You can export your files to: 
 

 SWF: This will publish your project to the Shockwave Flash format. 
 AVI: This will publish your project to the Audio Video Interleave format. 
 GIF: This will publish your project to an animated Graphics Interchange format. 
 EXE: The will package your SWF file with the standalone Flash player in an 

Executable file so it can be played without a browser.  
 
You can also export a single frame from the project to a BMP (bitmap) image file using 
the Screenshot option (Edit > Screenshot) from the menu bar. 
 
The files created during the export operation are the Viewlet files you will publish to your 
web site, transfer to CD, email to users, etc. for your viewers to watch. Let’s take a look 
at each publishing feature. 
 
To export a project to Flash format: 

 Once you’ve completed your project, save it. 
 Select File > Export SWF from the menu bar. 
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 The Export SWF window displays: 
o In the Graphics area, the default option is High graphics quality. This 

option is fine for most published projects. 
 

 
 
To reduce the file size, select Low graphics quality and select colors to 
use for the images from the Palette drop-down list. If you use this option, 
make sure to preview after publishing to make sure the graphics quality 
are sufficient for your needs. 
 

 
 

o In the Sound area, select either High quality or Low quality for the 
exported sound, if the project contains audio. 
 

 
 

o If your project contains cursor animation, select the Smooth mouse 
track option. 
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o If you do NOT want your project to automatically loop (repeat), or if your 
project contains interactive objects such as buttons, you can have 
ViewletCam2 automatically add a stop flag to the end of the project (to 
stop it from looping) and to each frame containing a button. To do this, 
select the Audio add stop flag option. 
 

 
 
You can also manually add a stop flag to frames containing buttons and 
to the last frame of your project if you do not want to use the Auto add 
stop flag feature. 
 

 
o By default, the published files will be saved in the project folder. To 

change the location and / or the file name of the published files, click 
Browse and make your selections as desired. 
 

 
 

o For the compression settings to use during the compilation (publishing) 
process, select either Standard or Screen Video Bitstream from the 
Compressor list. Select Compress SWF file. 
 

 
  

In most cases, the Standard compression selection is just fine. If most of your viewers will 
be using Flash 7 or later to view your Viewlets, you might select the Screen Video 
Bitstream compression option. New in Flash 7, this additional video format is a simple 
lossless sequential-bitmap format specifically designed to optimize captures of computer 
screen actions.  
 

 Click OK to publish the project. The Viewlet will immediately launch in your 
default browser for you to preview. Repeat this process each time you edit and 
resave your project. 
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To export a project to AVI format: 
 Save your project. 
 Select File > Export AVI from the menu bar. 

 

 
 

 The Export AVI window displays: 
o In the Select video compressor area, select a compression option from 

the list. By default, Uncompressed RGB is selected and works fine for 
most projects. 
 

 
 
If you select a different option, the Configure button may become 
available. If it does, click it and select additional options as needed for 
your compression option. To learn more about a compression selection, 
click the About button, if it is available. 
 
Select a Frame compression quality percentage in the field provided. 
 

o If your project has cursor animation, select the Export mouse action 
option. 
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o If your project has audio, select the Export sound option. 
 

 
 

o By default, the published files will be saved in the project folder. To 
change the location and / or the file name of the published files, click 
Browse and make your selections as desired. 
 

 
 

 Click OK to publish the project. The demonstration will immediately launch in 
your default player for AVI files for you to preview. Repeat this process each 
time you edit and resave your project. 

 

If your AVI has sound and you cannot hear it when playing your file, go back to your VCP 
file, right click on the “Sound” layer, select “Properties” and make sure the Sound layer is 
synchronized with the “Graphics” layer. Then, export your project to AVI again to resolve 
the audio issue. 

 
 
To export a project to GIF format: 

 Save your project. 
 Select File > Export GIF from the menu bar. 
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 The Export GIF window displays: 
o For the colors to use, select a scheme from the Palette list. 

 

 
 

o If your project contains cursor animation, select Export cursor. 
 

 
 

o By default, the published files will be saved in the project folder. To 
change the location and / or the file name of the published files, click 
Browse and make your selections as desired. 
 

 
 

 Click OK to publish the project. You will see the file play back in your system’s 
default GIF viewer. Repeat this process each time you edit and resave your 
project. 
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To export a project to an EXE file: 
 Save your project. 
 Export your project to SWF format. 
 Close any open browser windows that occur after exporting to SWF. 
 Select File > Convert swf to exe from the menu bar. 

 

 
 

 The Convert SWF to EXE window displays: 
o In the Input area, select: 

-Play the movie full screen to play the movie full screen when 
launched. 
 
-Show menu to display the Flash menu options if viewer right clicks on 
demo. 
 
-Play movie automatically for the movie to start playing when launched. 
 
-Loop movie for the movie to continually replay. 
 
-100% for 100% frame compression quality. 
 
-Click Browse to locate and select the SWF file. The path to the file will 
display in the SWF file field. 
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-In the Caption field, type in a “title” for the demonstration. This caption 
will display in the blue title bar of the Flash player when the demonstration 
is played. By default, the file name is filled in after you select the SWF file. 
 

 
 

 
o In the Output area, by default, the published file will be saved in the 

project folder. To change the location and / or the file name of the 
published file, click Browse and make your selections as desired. 
 

 
 

 Click OK to publish the project. 
 A Run this executable file? (Yes/No) window will display. Click Yes to run the 

executable or click No to close the window without running the published file. 
 

 
 
The published executable file is saved to the same file as the project folder, 
unless you specified a different location.  
 
Repeat this process each time you edit and resave your project. 
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To export a frame to a BMP file: 
 Select the frame that you want to export out as an image file. 
 Select Edit > Screenshot from the menu bar. 

 

 
 

 The Save As window displays: 
o Select a folder to save the image file in. 
o Type in a file name in the field provided for the file, which will be saved 

as a bitmap image with the .bmp extension. 
o Click Save to save the frame as a bitmap image file. 

 
If you have questions about publishing or export options, please contact 
support@qarbon.com. 
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Project Files & Final Web Publishing Tips 
Each ViewletCam2 project is saved in its own project folder, which is named based on 
the name you designated when saving your project for the first time. By default, at a 
minimum, each project folder will contain the following files, if published to Flash: 
 

 .vcp: This is the project’s source file, which is opened and edited inside the 
ViewletCam2 program. 
 

 .wav: If the project’s source file contains a sound layer, this is its external file. A 
.wav file is created if sound is captured during a recording session. 
 

 .mp3: If your project contains audio, an external .mp3 file is created after 
publishing for each sound layer. 
 

 .swf: This is the Shockwave Flash file (actual Viewlet file) that is created when 
you publish to Flash. If your demonstration contains audio, it is embedded into 
this file. 
 

 .html: This is an HTML file that is used to launch the Viewlet file in its proper 
dimensions. This is the file you link to in order to play back the file. 
 

 .js: This is a javascript file that contains additional playback controls and works 
with the Viewlet’s HTML launcher file.  

 
Additional files may be included in the project folder if you select a different publishing 
(export) option.   
 
Some Final Publishing Tips 
Since there are many different web design programs out on the market, we cannot 
provide specific instructions or provide any recommendations as to what will work best 
for you. We can, however, provide some “best practice” tips to help you when you 
publish your projects: 
 

 Never upload your project’s source file to the web server, nor copy it to a CD. 
This file is for the author’s use only and is not part of the published files. 
 

 Copy all of your published files to the web server or to CD. 
 

 Provide a link to the project’s .HTML file. When the link is clicked, the Viewlet will 
launch in the proper size. 
 

 We do NOT recommend launching or link to the .swf file directly since, 
depending on the browser it launches in, the Viewlet may “scale-to-fit” in the 
browser’s window and resize as the user resizes the window.  

 
For more information on this topic, please contact support@qarbon.com. 
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Support and Self-Help 
Qarbon offers a support plan to fit your needs. Standard Support is offered to all 
customers at no charge. For more information on support plans and options available, 
visit us online at: 
 
http://www.qarbon.com/help/support_plans.php 
 
Qarbon also offers users online, self-help resources in the form of Viewlet tutorials, user 
manuals and FAQs. For access to these self-help aids, please visit our site at: 
 
http://www.qarbon.com/help/ 
 
You may also contact support@qarbon.com with any support questions you may have. 
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Training 
Take advantage of all the features in ViewletCam2 by signing up for Qarbon’s training 
classes. Learn how to get the most out of your Viewlet authoring tool to create stunning 
Flash demonstrations and interactive movies in no time. For information on how to learn 
from the Viewlet experts, to our home page: 
 
http://www.qarbon.com 
 
Look for the “Services” link and view your training options, which include Live Webinars, 
On Demand Webinars and customized workshops. 
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Qarbon User Forum 
Want to share ideas on Viewlet Authoring? Are you hunting for a specific authoring trick 
to take your Viewlets to the next level? Qarbon offers a Viewlet user forum just for you. 
It’s free to join and free to use. It’s a great place to meet other Viewlet enthusiasts from 
across the globe and spotlight your own great Viewlet ideas too!  
 
Go to: http://forum.qarbon.com/ 
 
Sign up and join in the fun! 
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Sales and General Customer Service 
Customer support is our top priority at Qarbon! Please feel free to contact our Sales or 
Support staff at any time if you have ANY ViewletCam2 (or other product related) 
questions or concerns or for options to discuss additional training needs. 
 
For current contact information, visit our web site: 
 
http://www.qarbon.com/about_us/contact_us/ 
 
 
 


	Welcome to ViewletCam2
	System Requirements
	Installation
	License Activation
	GUI Language
	Interface Overview
	ViewletCam2 Program Preferences
	Creating a New Project Basics
	Active Window Capture (New Project)
	Screen Area Capture (New Project)
	Full Screen Capture (New Project)
	PowerPoint Presentation (New Project)
	Defining Capture Hotkeys
	Sound
	Timeline Overview
	Frames
	Layers
	Message Objects
	Shape Objects
	Image Objects
	Grouping & Ungrouping Objects
	Moving Objects on the Timeline
	Persistent Objects
	Cursor Animation on the Mouse Layer
	Stop Flags, Actions & Events
	Interactive Objects
	Movie & Canvas Tools
	Splitting & Merging Projects
	Document Properties
	Player Control Bar & Preloader
	Publishing (Export) Options
	Project Files & Final Web Publishing Tips
	Support and Self-Help
	Training
	Qarbon User Forum
	Sales and General Customer Service

