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Getting Started 
This Getting Started chapter provides a general overview of important information for 
setting up and working with ViewletBuilder8 Enterprise. It contains the following sections 
for your reference: 
 
 What is ViewletBuilder8 Enterprise 
 Technical Specifications 
 Download and Installation 
 License Activation and Reactivation 

 

WHAT IS VIEWLETBUILDER8 ENTERPRISE 
ViewletBuilder8 Enterprise is an eLearning authoring application suite produced by 
Qarbon. This Enterprise software version combines all the patented screen capture 
technology found in ViewletBuilder8 Professional along with all the assessment features 
(including 11+ additional question types) available in ViewletQuiz4 Professional. Please 
visit the product’s page for more information.  
 
 
TECHNICAL SPECIFICATIONS 
You can find the current suggested system requirements for ViewletBuilder8 Enterprise 
on the product’s Technical Specs page. Once online, just select your operating system 
to review the related technical information. 

 
DOWNLOAD AND INSTALLATION 
To download ViewletBuilder8 Enterprise, go to the Qarbon.com. Click the “Downloads” 
link. On the “downloads” page, select ViewletBuilder8 Enterprise as the product you 
want to download. Follow the instructions on the rest of the web pages that display to 
download the installation file. 
 
Note: Remember the file name and folder location of the installation file so you can find it when 
you are ready to install ViewletBuilder8 Enterprise. 
 
After downloading the installation file, close the browser dialog. Then, locate and double 
click the installation file to launch the Installation dialog.  
 
Note: If a prior installation of the software is detected, you will be prompted to either update the 
existing installation or install in a new directory. 
 
On the last screen of the installation, click Finish to complete the installation. 
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LICENSE ACTIVATION AND DEACTIVATION 
You will need to purchase a license to activate ViewletBuilder8 Enterprise. There are 
several options available to purchase a license: 
 
 Go to Qarbon.com, click the “Store” link and select a pricing option. 

 
OR 
 
 Select Help > Buy ViewletBuilder8 from the menu bar inside your app. 

 
OR 
 
 Contact Qarbon Sales. 

 
 
Once you purchase a license, you will receive a confirmation email with your license and 
purchase information. Keep this email for your records. 
 

License Activation 
 

 
 
To activate ViewletBuilder8 Enterprise: 

1. Make sure your computer is connected to the Internet. 

2. Open the ViewletBuilder8 Enterprise program. 

3. Select Help > License Activation from the menu bar. 

4. Follow the instructions in the dialogs that display to complete the registration 
process. 

 
Note: For best results, copy the license number directly from your email and paste it in the 
required field when registering ViewletBuilder8 Enterprise. 
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License Verification 
To check license information: 

1. Make sure your computer is connected to the Internet. 

2. Open the ViewletBuilder8 Enterprise program. 

3. Select Help > About ViewletBuilder8… from the menu bar. 

4. Review the information in the About ViewletBuilder8 Enterprise dialog that 
displays. 

5. Click Close to exit. 
 

License Deactivation 
To deactivate your ViewletBuilder8 Enterprise license: 

1. Make sure your computer is connected to the Internet. 

2. Open the ViewletBuilder8 Enterprise program. 

3. Select Help > License Deactivation from the menu bar. 

4. Follow the instructions in the screens that display to complete the deactivation 
process. Once the license is deactivated, it can be activated on a different 
computer. 

 

Web (License) Activation & Deactivation 
If you encounter firewall issues when trying to activate or deactivate your 
ViewletBuilder8 Enterprise license, you can use the alternative web activation or 
deactivation process. 

Web Activation 
1. Open ViewletBuilder8 Enterprise. 

2. Select Help > License Activation from the menu bar. 

3. In the Activation dialog, enter your license number in the field provided. 

4. Click the “Web Activation” link. 
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5. Enter in the requested information for name, company, email, etc. and then click 
the Next button. 

6. In the “Web Activation” screen of the dialog, you will see a set of instructions with 
three steps. Follow these steps carefully: 

a. Step 1:  
To open the web activation page, copy the URL in the field shown into 
your browser’s address line OR click on the folder icon (this latter action 
will open your default browser with the URL already loaded in the address 
line). 

b. Step 2:  
Verify the information on the page that displays in the browser and then 
click the Submit button. When the page refreshes, you will see a 
“Confirmation Code” field. Highlight ALL the string of characters/numbers 
contained in the confirmation code field and copy them (Ctrl+C). You will 
need ALL of this data to complete your web activation. 

c. Step 3:  
Return back to the “Web Activation” dialog (in ViewletBuilder8 Enterprise) 
and paste (Ctrl+V) the Confirmation Code you JUST copied from the web 
page. 

d. Click the Next button. 

7. Information as to the status of the web activation will display in the last screen of 
the dialog. Review the information carefully then click Finish to close the dialog. 
If successful, once you close this dialog, your ViewletBuilder8 Enterprise 
application is now activated. 
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Web Deactivation 

1. Open ViewletBuilder8 Enterprise. 

2. Select Help > License Deactivation from the menu bar. 

3. In the License Deactivation dialog, click the “Web Deactivation” link. 

4. In the “Web Deactivation” screen of the dialog, you will see a set of instructions 
with three steps. Follow these steps carefully: 

a. Step 1:  
To open the web deactivation page, copy the URL in the field shown into 
your browser’s address line OR click on the folder icon (this latter action 
will open your default browser with the URL already loaded in the address 
line). 

b. Step 2:  
Verify the information on the page that displays in the browser and then 
click the Submit button. When the page refreshes, you will see a 
“Confirmation Code” field. Highlight ALL the string of characters/numbers 
contained in the confirmation code field and copy them (Ctrl+C). You will 
need ALL of this data to complete your web deactivation. 

c. Step 3:  
Return back to the “Web Deactivation” dialog (in ViewletBuilder8 
Enterprise) and paste (Ctrl+V) the Confirmation Code you JUST copied 
from the web page. 

d. Click the Next button. 

5. Information as to the status of the web deactivation will display in the last screen 
of the dialog. Review the information carefully then click Finish to close the 
dialog. If successful, once you close this dialog, your ViewletBuilder8 Enterprise 
application is now deactivated. You can now activate your license on this, or 
another, computer. 
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Program Preferences 
We recommend that before diving into creating your first Viewlet projects take some time 
to set up some baseline options for your authoring application. This is accomplished in 
the Preferences dialog. Once you set these preferences, you can always modify them as 
needed as you get more comfortable working in ViewletBuilder8 Enterprise. 
 
To access the Preferences dialog select Edit > Preferences from the menu bar. This 
dialog is organized into several different tabs. Let’s take a look at each. 
 

GENERAL 
The General tab includes options for the user interface language, documents storage 
location and text editing style. 
 

 
 

Language 
ViewletBuilder8 Enterprise will use your operating system’s default language preference, 
but you may switch to a different language for use in this program only. 
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To select the default language to use in the ViewletBuilder8 Enterprise interface: 

1. In the Preferences dialog, select the General tab. 

2. In the Language area, click the Change Language button. 

3. Select a language from the available list. 

4. Click OK. 
 
Note: You must relaunch ViewletBuilder8 Enterprise in order for the newly selected language to 
take effect. 
 

Documents Directory 
Select the directory (folder) where you want to store your Viewlet project files and 
assets. This will be the default location for projects’ storage, but you can redirect your 
project to a different location at the time of the actual save operation. 
 
To change the default documents directory: 

1. In the Preferences dialog, select the General tab. 

2. In the Documents Directory area, click the folder icon. 

3. Locate and select the directory (folder) you want to use. 

4. Click Open. 
 

Text Editing 
There are two different approaches for editing text in notes, balloons and slide text (also 
known as ‘messages’ or ‘message objects’). While working on a project, the setting you 
choose as your baseline preference will determine the initial method ViewletBuilder8 
Enterprise will use you edit text. You can, however, switch between either text editing 
style as you work in your project. 
 
To set the baseline preference for text editing: 

1. In the Preferences dialog, select the General tab. 

2. In the Text Editing area, select either: 
 

o Edit in Place: When editing a text object, this selection allows you to edit 
text directly in the balloon, note, text box or button. You can also use the 
message object’s Context Sensitive Toolbar to edit other message object 
properties. 
 
or 
 

o Use Text Editor: When editing a message object’s text, this selection 
opens the Text Editor dialog when double clicking a balloon, note or text 
box. This selection also allows you to edit other message object 
properties directly in the Text Editor dialog. 
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Note: It’s easy to switch between “text editing” options while working with message objects. 
Simply right click on the message object and, from the shortcut menu, select either “Open in Text 
Editor” to work in the “Text Editor” dialog, or select “Edit Text” to edit text directly in the message 
object. 
 

Restore Preferences to Default 
After you install ViewletBuilder8 Enterprise, you will find that it already has many ‘factory 
settings’ already in place throughout the application, including in the Preferences dialog 
tabs. No matter how many changes you make to your preferences, you can set them 
back to the original settings at the time of installation by clicking the Restore 
Preferences to Default... button (Preferences dialog > General tab). A Warning dialog 
will display with information regarding resetting your preferences. Click OK to apply and 
close that dialog. 
 

TABLE OF CONTENTS 
In the Table of Contents tab, set your preferences for how ViewletBuilder8 Enterprise will 
automatically handle a table of contents for default slides as well as displaying it in the 
published Viewlet. These settings, like other preferences, may be overridden while 
working on your project prior to publication. 
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To set options for default slides: 

1. In the Preferences dialog, select the Table of Contents tab. 

2. In the Default Slides area, select the slides you want to automatically include in 
the table of contents: 

a. Question Slides 

b. Click Zones, Text Zones, Keystroke Zones 

c. Pause Zones 
 
To configure when a table of contents will be auto-enabled in the published Viewlet: 

1. In the Preferences dialog, select the Table of Content tab. 

2. In the Auto Enable area, select your preference: 

a. Whenever a slide is included 

b. Never 

c. Ask Me 
 

SPELLING 
In ViewletBuilder8 Enterprise, you can set preferences for the spell checker.  
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To select a default dictionary language to use in ViewletBuilder8 Enterprise: 

1. In the Preferences dialog, select the Spelling tab. 

2. In the Spell Checker area, select a dictionary to use from the drop-down list. 

3. Select the checkbox next to any additional settings as needed: 

a. Ignore words in UPPERCASE 

b. Ignore words with numbers 

c. Ignore domain names 
 
Note: To enable/disable the spell checker while working on a Viewlet project, select ‘View’ from 
the menu bar. Then select/deselect the ‘Spelling Mistakes’ option. 
 
ViewletBuilder8 Enterprise has a baseline dictionary pre-installed with it. You will ‘grow’ 
your dictionary as you work with the spell checker in your Viewlet projects. 
 

PROXY 
The Proxy tab can be used if you encounter firewall issues while activating/deactivating 
your license, obtaining program updates, etc. while online. Following is information for 
configuring your proxy server, however, we highly recommend you have your network IT 
staff handle this if you need to use it. 
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Auto Detect Proxy 
By default, the first option, Auto Detect Proxy, is selected. This feature will allow the 
program to search for and use a proxy server if required (for example, when a firewall 
prevents license activation or program updates). 

No Proxy 
If you do not have access to a proxy server or do not want the program to search for it if 
firewall issues are encountered during license activation or program updates, select the 
No Proxy option. 

Manually Configure Proxy 
If your company requires you to use a proxy server for any reason, or if you encounter 
firewall issues while activating your license or obtaining program updates, select the 
Manually Configure Proxy option. Then, after obtaining the applicable information from 
your network or IT group: 
 
 Enter the proxy server Address in the field provided. 
 Enter the proxy server Port in the field provided. 
 Enter the User Name in the field provided. 
 Enter the Password in the field provided. 

 
Once you click OK to apply changes in the Preferences dialog, if you’ve made any 
changes in the Proxy tab, a Warning will display, prompting you to restart 
ViewletBuilder8 Enterprise. 
 
Note: You must restart ViewletBuilder8 Enterprise each time you change the proxy server 
settings in the “Preferences” dialog in order for the new settings to take effect. 
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LOGGING 
While ViewletBuilder8 Enterprise is running, it writes a log that describes in detail what is 
going on in the background. This is indispensable for tracking down software issues and 
making ViewletBuilder8 Enterprise as bug-free as possible. In the Logging tab, you can 
set program defaults for how ViewletBuilder8 handles logging reports and files. 
 

 
 

Output 
In the Output area of the Logging tab (Preferences dialog), you can set default options 
for the reporting of information in the Output tab, which can be viewed by selecting View 
> Output from the menu bar.  
 
To select Output report options: 

1. In the Preferences dialog, select the Logging tab. 

2. In the Output area, select an option from the Report list. These include: 

a. Display Errors Only 

b. Display Errors and Information 

c. Display All Messages 

3. Optional: Click the Clear Output Dialog button to clear the information displayed 
in the Output tab. 
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Log File 
In the Log File area of the Logging tab (Preferences dialog), you can enable or disable 
logging and specify the location where ViewletBuilder8 Enterprise will save the file. 
 
To enable the Logging feature for ViewletBuilder8 Enterprise: 

 In the Preferences dialog, select the Logging tab. 

 In the Log File area: 

o Select the Enabled option to create a record of information to help 
Qarbon find and correct program errors. 

o Click the folder icon to locate and select a directory (folder) location to 
store the log file. 

 
Note: If you ever encounter any issues when working with ViewletBuilder8 Enterprise, you may 
be requested to send a log file to Qarbon. This location is where your log file is stored. 

 

BACKUP 
Set preferences for creating automatic backup files. 
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Backup Files on Save 
ViewletBuilder can create and update a backup file that can be used to restore a 
corrupted project from the last ‘known’ good save. To enable this feature: 

1. In the Preferences dialog, select the Backup tab. 

2. In the Backup Files on Save area, select the Enable - .BAK appended 
extension option. 

 

START VIEW 
When you launch ViewletBuilder8 Enterprise, a dynamic start page loads and is 
organized into several quadrants (Actions, Recent Files, Help, Publishing History and 
News). In the Start View tab, you can customize the look of this page (Preferences > 
Start View).  
 

 
 
This tab is organized into two areas: 

View 
In the View area, select the options to display on Start View: 
 
 Display Publishing History: Displays the publishing history of all items 

published using the Publishing Dialog. 

 Display News: Displays recent news on the Start View page. 
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 Recent File Count: Set the number of files to display under ‘Recent Files’. 

 Maximum Local History Items: Set the number of “locally” (non-ViewletCentral) 
published files to display in the ‘Publishing History’. 

 History Items Per Page: Set the number of published items to display on each 
page of the ‘Publishing History’. 

Publishing History: Include the following location 
The available publishing locations in the list are determined by your selections in the 
Publishing Dialog (covered later in this user guide). Place a checkmark next to each 
publishing location you want displayed on the Start View page. 

 

ADVANCED 
The Advanced tab displays the current virtual memory usage settings allowable when 
ViewletBuilder8 Enterprise is active. 
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Java 
In the Java area of this tab, you can review the current settings. To modify these options, 
click the Change Java Settings button. In the Java Preferences dialog that displays, in 
the: 
 
 Memory area: 

o Enter a number for the Initial memory. 
o Enter a number for Maximum memory. 

 
 VM Options area: 

o Enter any additional VM scripting as desired. 
 
Once you are finished entering in your information, click OK to close this dialog. 
 

APPLYING PREFERENCES 
Once you’ve set all your program preferences, click OK to save the settings and to close 
the Preferences dialog. 
 
Note: As described earlier, you can set software preferences back to factory settings by clicking 
the Reset Preferences to Default... button (Preferences dialog > General tab). 
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Graphical User Interface (GUI) 
This chapter outlines ViewletBuilder8 Enterprise’s Graphical User Interface (GUI) to help 
you familiarize yourself with the features and tools you will use while creating your 
Viewlets. 
 

START VIEW 
The Start View is what you will see each time you open ViewletBuilder8 Enterprise or 
fully close a project. It is organized into various areas for quick access to specific 
features. 
 

 
 
Note: You can customize the Start View in the Preferences dialog (Edit > Preferences). 
 

Actions 
The Actions area allows you to quickly access new project types, open recent files, 
check for software updates and manage product licensing. 
 

Recent Files 
The Recent Files area provides one-click access to previously opened recent projects. 
 

Help 
In the Help area, you can access Qarbon’s Learning Center for self-help resources such 
as FAQs, user guides and Viewlet tutorials; find out more about training opportunities via 
webinars and workshops; join and participate in Qarbon’s own user forum; and/or get 
support help using the support ticket option. 
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Publishing History 
The Publishing History area provides a high level summary list of anything published 
from ViewletBuilder8 Enterprise. The items displayed in this list are determined by the 
options you set in the Preferences dialog (Preferences > Start View). 
 

News 
The News area is a dynamic page loaded from Qarbon’s servers. It contains information 
about the latest product releases, an online chat and more! 
 

Refreshing the Start View 
There is a Refresh (curved arrow) button available at the right side of the Start View 
page next to the Publishing History and the News areas. Click one of these buttons to 
refresh the applicable area to obtain the current publishing history list and/or the latest 
news from Qarbon. 
 

TOOLBARS, KEYBOARD SHORTCUTS & COMMAND BUTTONS 
While working in ViewletBuilder8 Enterprise, you will find various toolbars and buttons 
available. This section provides a high level view of each. 
 

Title Bar 
Displayed at the top of the program window is the Title bar. When there is no project 
open, it contains the title of the software application (ViewletBuilder8 Enterprise); 
however, when you have an open project, it also contains the title of the project file. 
 

 
 
Note: When the project title is followed by an asterisk (*), this indicates the file needs to be saved. 
 
On the right side of this bar there are three buttons to minimize, restore down/maximize 
and close the program window. 
 

Keyboard Shortcuts 
ViewletBuilder8 Enterprise provides access to its features and tools via various keyboard 
shortcuts. You can find keyboard shortcuts listed next to the regular Menu toolbar 
options (when available) and next to options listed on Shortcut menus (when available). 
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Here is a list of some of the most commonly used keyboard shortcuts: 

File Command Shortcuts 
Description Keyboard Shortcut  

New Ctrl+N 

Open Ctrl+O 

Save Ctrl+S 

Save As Ctrl+Shift+S 

Print Ctrl+Shift+P 

Exit Ctrl+Q 
 

Edit Command Shortcuts 
Description Keyboard Shortcut  

Undo Ctrl+Z 

Redo Ctrl+Y 

Cut Ctrl+X 

Copy Ctrl+C 

Paste Ctrl+V 

Delete Delete 

Duplicate Slide Ctrl+D 

Select All Ctrl+A 

Search and Replace Ctrl+F 

Run Macro Ctrl+K 

Jump Down Shift+Down 

Jump Left Shift+Left 

Jump Right Shift+Right 

Jump Up Shift+Up 

Move Down Down 

Move Left Left 

Move Right Right 

Move Up Up 

Arrange > Forward Ctrl+Right 

Arrange > Foreground Ctrl+Up 

Arrange > Backward Ctrl+Left 

Arrange > Background Ctrl+Down 

Edit Next Text Alt+Right 

Edit Previous Text Alt+Left 
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Insert Command Shortcuts 
Description Keyboard Shortcut  

Balloon Ctrl+Alt+B 

Text Box Ctrl+Alt+B 

Shape Ctrl+Alt+B 

Line Ctrl+Alt+L 

Image Ctrl+Alt+P 

Movie Ctrl+Alt+M 

Click Zone Ctrl+Alt+I 

Cursor Path Ctrl+Alt+C 

Pause Zone Ctrl+Alt+A 

Text Zone Ctrl+Alt+E 

Keystroke Zone Ctrl+Alt+K 

Question Ctrl+Alt+Q 

Button Ctrl+Alt+O 

Zoom Zone Ctrl+Alt+Z 

Sound Ctrl+Alt+D 

Project Command Shortcuts 
Description Keyboard Shortcut  

Project Properties Ctrl+M 

Publish Viewlet Ctrl+P 

First Slide Ctrl+Home 

Previous Slide Ctrl+Page Up 

Next Slide Ctrl+Page Down 

Last Slide Ctrl+End 

Preview Current Slide Ctrl+Period 

Preview from Current Slide Ctrl+Space 

Preview All Slides Ctrl+Slash 

Preview in Browser Ctrl+L 

Miscellaneous Command Shortcuts 
Description Keyboard Shortcut  

Help F1 

Bold Ctrl+B 

Italic Ctrl+I 

Underline Ctrl+U 
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Menu Toolbar 
Nested below the Title bar is the Menu toolbar. This toolbar is organized according to 
categories, offering access to the following operations via a drop-down menu list. 
 

 

File Menu 
The File menu offers options for working with basic file operations. 

Menu Option Description 

File > New Create a new project. 

File > Open Open an existing project 

File > Recent Files Open a recently accessed project from a short list. 

File > Close Close an open project. 

File > Save Save the project. 

File > Save As Save the project to a new file name. 

File > Create Archive: QVP, VIE Create an archive (compressed file) of the project’s 
files and folders. 

File > Page Layout Access page layout (publishing) options. 

File > Print Print project slides. 

File > Import > Import Slides Import slides from another project into the current one. 

File > Import > Import Question Bank Import question bank slides from another project into 
the current one. 

File > Import > Text for Translation Import text coding from an XML file previously 
exported from the project for translation purposes. 

File > Import > Publishing Locations Import publishing locations. 

File > Import > Capture Session Import a QCS* (Qarbon Capture Session) file. 
*Note: If a screen capture session fails, a qcs file is 
automatically created on the back end. 

File > Import > Video Capture 
Session 

Import a VCS (Video Capture Session) file. 

File > Export > Text for Translation Exports an XML file with the entire project’s text and 
text attributes for translation purposes. 

File > Export > Sounds Export sounds from the project. 

File > Export > Publishing Locations Export currently selected publishing locations. 

File > Exit Exit from the authoring application. 
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Edit Menu 
The Edit menu offers project editing options. 

Menu Option Description 

Edit > Undo Undo the last action. 

Edit > Redo Redo the last Undo action. 

Edit > Cut Cut the selection to the clipboard. 

Edit > Copy Copy the selection to the clipboard. 

Edit > Paste Paste the last element cut/copied from the clipboard. 

Edit > Delete Delete the selection. 

Edit > Duplicate Slide Duplicate the selected slide. 

Edit > Select All Select all elements. 

Edit > Clear Selection Clear all selections. 

Edit > Search and Replace Search for (and replace) text. 

Edit > Rotate > Rotate 90O Right Rotate the selection 90O right. 

Edit > Rotate > Rotate 90O Left. Rotate the selection 90O left. 

Edit > Load Macro Load the selected macro. 

Edit > Run Macro Run the loaded macro. 

Edit > Arrange > Foreground Move the selection to the top of the stack. 

Edit > Arrange > Forward Move the selection forward in the stack. 

Edit > Arrange > Backward Move the selection backward in the stack. 

Edit > Arrange > Background Move the selection to the bottom of the stack. 

Edit > Distribute > Left Edges Distribute selections along left edges. 

Edit > Distribute > Top Edges Distribute selections along top edges. 

Edit > Distribute > Right Edges Distribute selections along right edges. 

Edit > Distribute > Bottom Edges Distribute selections along bottom edges. 

Edit > Distribute > Horizontal Center Distribute selections along horizontal center. 

Edit > Distribute > Vertical Center Distribute selections along vertical center. 

Edit > Size > Make Same Width Make selections the same width. 

Edit > Size > Make Same Height Make selections the same height. 

Edit > Size > Make Same Size Make selections the same size. 

Edit > Timing > Same Start Time Display selections using the same start time. 

Edit > Timing > Same End Time Display selections using the same end time. 

Edit > Timing > Same Start and End 
Time 

Display selections using the same start and end 
times. 

Edit > Timing > Display Until Last End 
Time 

Display selections until the last end time (for all 
selections). 
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Menu Option Description 

Edit > Timing > Sequence Times Display selections in a sequence. 

Edit > StyleBuilder Pack and unpack style files. 

Edit > Preferences Set/modify baseline program preferences. 

View Menu 
The View menu offers project viewing options. 

Menu Option Description 

View > Zoom In Zoom in on the slide. 

View > Zoom Out Zoom out from the slide. 

View > Fit Slide Adjust zoom level so entire slide is in view. 

View > Zoom Level > 200% Zoom to 200%. 

View > Zoom Level > 175% Zoom to 175%. 

View > Zoom Level > 150% Zoom to 150%. 

View > Zoom Level > 125% Zoom to 125%. 

View > Zoom Level > 100% Zoom to 100%. 

View > Zoom Level > 75% Zoom to 75%. 

View > Zoom Level > 50% Zoom to 50%. 

View > Zoom Level > 25% Zoom to 25%. 

View > Cursor Path Display/hide cursor path. 

View > Spelling Mistakes Enable/disable spell checker. 

View > Event Icons Display/hide event icons. 

View > Attached Sound Icons Display/hide sound icons. 

View > Pair Links Display/hide pair links. 

View > Floating Guides Display/hide floating guides. 

View > PauseZone Icons Display/hide PauseZone icons. 

View > Master Layer Display/hide the master layer applied to the slide. 

View > Timing Links Display/hide timing links. 

View > ToolTips Display/hide tooltips. 

View > Status Bar Display/hide status bar. 

View > Tabs > Slides Display/hide the Slides tab. 

View > Tabs > Stylesheets Display/hide the Stylesheets tab. 

View > Tabs > Browser Display/hide the Browser tab. 

View > Tabs > Timeline Display/hide the Timeline tab. 

View > Tabs > Slide Notes Display/hide the Slide Notes tab. 

View > Tabs > Masters Display/hide the Masters tab. 
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Menu Option Description 

View > Tabs > Question Banks Display/hide the Question Banks tab. 

View > Tabs > Output Display/hide the Output tab. 

View > Tabs > Problems Display/hide the Problems tab. 

Insert Menu 
The Insert menu offers options for inserting slides, elements, media, effects and 
interactive elements. 

Menu Option Description 

Insert > Slides > Blank Slide Insert blank slide. 

Insert > Slides > Screenshots Insert screenshot slides. 

Insert > Slides > Video Insert video capture slides. 

Insert > Slides > Image Slides Insert image slides. 

Insert > Slides > PowerPoint Slides Insert slides created from a PowerPoint file. 

Insert > Slides > Question Slides Insert question (quiz or survey) slides. 

Insert > Slides > Question Bank Create a new question bank. 

Insert > Elements > Balloon Insert a balloon. 

Insert > Elements > Note Insert a note. 

Insert > Elements > Text Box Insert a text box. 

Insert > Elements > Closed Caption Insert a closed caption element 

Insert > Elements >Shape Insert a shape. 

Insert > Elements > Line or Arrow Insert a line or arrow. 

Insert > Elements > Color Highlight Create a color highlight. 

Insert > Elements > Matte Create a matte highlight. 

Insert > Media > Cursor Hide/display the cursor. 

Insert > Media > Sound Insert a sound. 

Insert > Media > Image Insert an image. 

Insert > Media > Movie Embed a movie (SWF or FLV) file. 

Insert > Effects > Popout Highlight Create a popout highlight. 

Insert > Effects > Zoom Zone Create a zoom zone. 

Insert > Interactive > Button Create an interactive button. 

Insert > Interactive > PauseZone Insert a pause. 

Insert > Interactive > ClickZone Create a click zone. 

Insert > Interactive > TextZone Create a text zone. 

Insert > Interactive > Keystroke Zone Create a keystroke zone. 

Insert > Interactive > Question Insert a question (quiz or survey). 
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Project Menu 
The Project menu offers options for accessing project properties; previewing, publishing, 
resizing and cropping project; splitting and merging slides; and running project 
validation. 

Menu Option Description 

Project > Project Properties Open the Project Properties dialog. 

Project > Publish Viewlet Open the Publish dialog. 

Project > Display Publishing Profile Display project’s publishing information. 

Project > Open Project Folder Open the project folder. 

Project > Preview Current Slide Preview the current slide. 

Project > Preview from Current Slide Preview the project from the current slide to the end. 

Project > Preview All Slides Preview all the project slides. 

Project > Preview in Browser Preview the compiled project without publishing. 

Project > First Slide Go to first slide. 

Project > Previous Slide Go to previous slide. 

Project > Next Slide Go to next slide. 

Project > Last Slide Go to last slide. 

Project > Resize Project Resize the project and project elements. 

Project > Crop Project Crop the height and width of the project slides. 

Project > Split Slide Split a slide into two slides. 

Project > Merge Slides Merge two slides into one slide. 

Project > Validate Project Check the project for common design errors. 

Help Menu 
The Help menu offers options for self-help resources, ViewletCentral publishing, 
additional training, creation/branding, license activation/deactivation, program updates, 
support and ‘About’ information. 

Menu Option Description 

Help > Learning Center Access Qarbon’s online Learning Center. 

Help > User Forum Access Qarbon’s online User Forum. 

Help > ViewletCentral Access Qarbon ViewletCentral. 

Help > Webinars Open Qarbon’s online FREE webinars schedule. 

Help > Workshops Review current workshop training opportunities. 

Help > Creating & Branding Contact Qarbon for ViewletDesign services such as 
ViewletCreation, ViewletPolishing, creating custom 
skins and related ‘branding’ services. 

Help > License 
Activation/Deactivation 

Activate/deactivate the program license. 
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Menu Option Description 

Help > Check for Updates Check for and install current program updates. 

Help > Submit Support Ticket Submit a support issue to Qarbon. 

Help > About ViewletBuilder8 Access additional information about the program in 
the About dialog. 

 

Main Toolbar 
The Main toolbar sits below the Menu bar. It is a static toolbar (meaning its options never 
change) with buttons providing one-click access to many features found in the Menu bar. 
When a button is grayed out, it indicates that option is not currently available. 
 

 
 
Buttons include: 
 
MAIN TOOLBAR 
Button Description 

   
New Create a new project. 

  
Open Open a project. 

  
Save Save a project. 

  
Print Print a project. 

  
Cut Cut the selection to the clipboard. 

  
Copy Copy the selection to the clipboard. 

  
Paste Paste the last item cut/copied from the clipboard. 

  
Delete Deletes the selection. 

  
Undo Undo the last action. 

  
Redo Redo the last Undo action. 

 
Insert Blank Slide Insert a blank slide. 

  
Insert Screenshots Insert screen capture slides. 

  
Insert Video Slides Insert video capture slides. 
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MAIN TOOLBAR 
Button Description 

  
Insert Image Slides Insert image slides. 

  
Insert PowerPoint Slides Insert slides created from a PowerPoint file. 

  
Insert Question Slides Insert new quiz or survey question slides. 

  
Format Painter Open the Format Painter tool. 

  
Stylesheets Display/hide the Stylesheets tab. 

  
Search and Replace Search for (and replace) text. 

   
Zoom In Zoom in on a slide. 

  
Zoom Out Zoom out from a slide. 

  
Fit Slide Adjust zoom level so entire slide is in view. 

  
First Slide Go to first slide. 

  
Previous Slide Go to previous slide. 

  
Next Slide Go to next slide. 

  
Last Slide Go to last slide. 

  
Preview Current Slide Preview the current slide. 

  
Preview from Current Slide Preview the project from the current slide to the end. 

  
Preview All Slides Preview all the slides in the project. 

  
Preview in Browser Preview the compiled project without publishing. 

  
Stop Preview Stop the preview mode. 

  
Project Properties Open the Project Properties dialog. 

  
Publish Viewlet Open the Publish Viewlet dialog. 
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Context Sensitive Toolbars 
The Context Sensitive (second-level) toolbar is a dynamic toolbar located below the 
Main toolbar. Its button options change depending on what is selected. And, like other 
toolbars, if a button is grayed out, it indicates the tool is not currently available. 
 
An example of one of the most common of these is the Slide Context Sensitive toolbar, 
which displays when a slide along the Main Timeline is selected. 
 

 
Sample Context Sensitive Toolbar (with options for working with selected slide on the Main Timeline) 
 
The various Context Sensitive toolbars found throughout ViewletBuilder8 Enterprise are 
too numerous to adequately cover in this overview section, so each is detailed (where 
applicable) in its respective chapter. 
 
  

Object Toolbar 
The Object toolbar (located at the right side of application window) contains buttons for 
working with different slide objects. Like the other toolbars, if a button is grayed out, it 
indicates the tool is not currently available. 
 
Buttons include: 
 
OBJECT TOOLBAR 
Button Description 

   
Insert Balloon Insert a balloon. 

 
Insert Note Insert a note. 

 
Insert Text Box Insert a text box. 

 
Insert Closed Caption Insert closed caption text. 

 
Insert Cursor Display/hide cursors. 

 
Insert Sound Open the Sound dialog. 

 
Insert Shape Insert a (rectangle, ellipse, lasso, poly lasso) shape. 

 
Insert Line or Arrow Insert a line or an arrow. 

 
Insert Color Highlight Insert a color highlight. 
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OBJECT TOOLBAR 
Button Description 

 
Insert Matte Insert a matte highlight. 

 
Insert Image Insert an image file. 

 
Insert Movie Open the Insert Movie dialog. 

 
Insert Popout Highlight Insert a popout highlight. 

 
Insert Zoom Zone Insert a zoom zone. 

 
Insert Button. Insert an interactive button. 

 
Insert PauseZone Insert a pause zone. 

 
Insert ClickZone Insert a click zone. 

 
Insert TextZone Insert a text zone. 

 
Insert Keystroke Zone Insert a keystroke zone. 

 
Insert Question Insert a question. 

  
 

Status Bar 
The Status Bar is located at the bottom of the application window and displays the status 
of project information such as: 

 Language preference (for the application interface) 
 Currently selected slide number of total number of slides 
 Slide size (width and height) 
 Zoom level 
 Percent of available memory used 
 x and y coordinates of selection cursor 

 
 

 
Note: To display/hide the Status Bar, select/deselect it from the View menu. 
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SLIDE EDITING AREA 
The active slide is displayed in the Slide Editing area. This is where you edit slide 
objects directly on the slide itself, can preview the project animation/playback inside the 
application and perform related project editing/reviewing operations. This area is hidden 
when any of the other tabs are maximized. 
 

 
 
 

TAB VIEWS 
The workspace areas inside ViewletBuilder8 Enterprise are organized into Tab views. 
Each Tab view is provides access to specific project editing tools such as: 

 Slides 
 Stylesheets 
 Browser 
 Timeline 
 Slide Notes 
 Masters 
 Question Banks 
 Output 
 Problems 

 
You can opt to display/hide a Tab view by selecting/deselecting it from the View > Tabs 
menu bar. Tabs can be docked to the left, bottom or right of the application window. 
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Organizing Workspace Tab Views 
This section provides instructions for organizing your workspace for optimal workflow 
with Tab views. 
 
To DISPLAY / HIDE a tab: 

1. Select View > Tabs from the Menu bar. 

2. To display a tab, select it from the list. When selected, a checkmark will display 
next to it. 

3. To hide a tab, deselect it from the list to remove the checkmark next to it.  

 

To EXPAND / MINIMIZE / MAXIMIZE a tab: 

1. Select the Expand button to expand the tab to full view. 

2. Select the Minimize button to minimize all active tabs. 

3. Select the Maximize button to restore all active tabs to their previous states. 
 
 
To RELOCATE a tab: 

1. Point your left mouse button over the desired tab. 

2. Hold down your left mouse button and drag the tab to the desired location (left, 
right, bottom of workspace). 

3. Let go of the left mouse button to drop the tab in its new docked location. 
 
 
To RESIZE a tab: 

1. Point your cursor over the edge of the tab until the cursor shape changes to a 
double arrow shape. 

2. Hold down the left mouse button and drag the edge to resize it. 

3. Let go of the left mouse button to finish the resize operation. 

 

TO MOVE between active tabs: 

1. If multiple tabs are displayed, only one tab can be in view at a given time. Click 
on the tab you want to work on to bring it to the front of the active tabs. 

2. Repeat this action to move between tabs. 
 
 
To CLOSE (hide) a tab: 

1. Select the desired tab to bring it to the front of the tabs. 
 Click the “X” (top right edge) to close the tab. 

 
 
Each Tab view is discussed in further detail throughout this guide. 
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Create New Project Dialog 
There are several different project types available in ViewletBuilder8 Enterprise: 
 
 Screen Capture Project 
 Video Capture Project 
 Image Project 
 PowerPoint Project 
 Question Project 
 Blank Project 
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SCREEN CAPTURE PROJECT 
The Screen Capture Project option allows you to capture a running application to create 
a product demonstration, simulation or a user training assessment. 
 

 
 

Capture Options Setup 
This section provides information on setting up options that will be used for the capture 
session. 

1. Open the Create New Project dialog. There are several ways to do this: 

a. Select File > New from the Menu bar, or 

b. Click the New Project link (Start View page > Actions area), or 

c. Click the New button from the Main toolbar. 

2. The Create New Project dialog displays a list of new project types. Select Screen 
Capture Project then click the Create button to continue to the next screen. 

3. Select the Capture tab to choose options for: 

a. Capture Area: Here you will find options to choose for setting the capture 
area during the capture session. The dimensions chosen here will also be 
the same as your slide size (width and height) when the screenshots are 
converted to project slides.  
 
Capture Area Methods and Instructions 

i. Custom: Set a custom width and height. 

1. Enter a number in the Width field. 

2. Enter a number in the Height field. 
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ii. Standards: Select from a list of standard resolutions, or create a 
new standard to add to the list.  

1. To CREATE a new Standard Resolution: 

a. Select the Standards – Select a standard 
window size option from the list. 

b. Click the Add Standard button. The Standard 
Resolution dialog displays. 

c. Enter a Name for the new standard. 

d. Enter a number for both the Width and the Height. 

e. Click OK. 
 

2. To MODIFY an existing Standard Resolution: 

a. Select Standards – Select a standard window 
size option from the list. 

b. Click the Modify Standard button. The Standard 
Resolutions dialog displays. 

c. Edit your options as needed. 

d. Click OK to save the changes. 
 

3. To DELETE an existing Standard Resolution: 

a. Select Standards – Select a standard window 
size option from the list. 

b. Select the standard you want to remove. 

c. Click the Delete button. 

d. Click Yes to confirm the deletion. 
 

iii. Application: Capture an open application and use its window size 
(width and height) as your new project’s slide size. 

1. Select an active program or operating system window from 
the list. If you don’t see your target window listed, open it 
and then click the Refresh Applications button to refresh 
the list. 

2. To resize the target window: 

a. Select the Resize Application to: option. 

b. Click the button next to the Resize Application to: 
option. The Application Size dialog displays. 

i. Select Custom or Standards from the list. 
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ii. Select a Standard Resolution from the list, 
or (following the instructions from the 
previous section) create a custom Standard 
Resolution. 

iii. Click OK. 
 

iv. Area: Capture an area of the screen predefined by you prior to the 
capture session. To use this option: 

1. Select Area – Capture an area of the screen from the list. 

2. Make sure you have set all additional capture session 
options in the Capture and Options tabs. 

3. Click OK to start the capture recording session. 

4. Before the recording session begins, you will be prompted 
to define the capture area: 

a. Hold down your left mouse button and drag to 
define the capture area. 

b. Let go of the mouse button to set the area indicated 
by a rectangle with dotted lines. Everything INSIDE 
this rectangle will be included in the screenshot. 
 

v. Window: Select an open window prior to your capture session 
and its size will determine the resulting slide size for your project. 
To use this option: 

1. Select Window – Select a window to capture from the 
list. 

2. Make sure you have set all additional capture session 
options in the Capture and Options tabs. 

3. Click OK to start the capture recording session. 

4. Before the recording session begins, you will be prompted 
to choose a window (or portion of a window): 

a. A red border outlines the window (or portion of the 
window) that can be used for the recording area. 
Roll you mouse over the window and click to set 
the area. 

b. Once the area is set, it will be surrounded by a 
rectangle with dotted lines. Everything INSIDE this 
rectangle will be included in the screenshot. 

vi. Full Screen: Capture everything visible on your computer’s 
screen. If you: 

1. Use the Current screen resolution from the list, no 
resolution changes will occur when you go into your 
capture session. 
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2. Use another screen resolution (different from your current 
resolution) from the list, your monitor’s resolution will 
automatically change to the selected resolution going into 
the capture session. It will change back to its prior setting 
once you’ve successfully ended your screen capture 
session. 
 

b. Capture Profile: This is where you select a Capture Profile to use during 
the recording session. 
 
Capture Profiles – Quick FAQs 
 
What is a Capture Profile? 
It is a way to organize all the “capture options” chosen for your recording 
session into one place or “profile”. 
 
Does the Capture Profile “title” signify anything? 
Yes and no. The “title” of the Capture Profile is like the title of a 
document. It just gives you an idea of what the profile would be used for. 
You can change the title of the profile at any time. 
 
Can Capture Profiles be created, modified and/or deleted? 
Yes, several Capture Profiles are installed with your authoring tool. You 
can, however, create new profiles from scratch, or modify any from the 
list. And, if your list of profiles becomes too long, you can also delete any 
profiles you no longer need. 
 
Working with Capture Profiles 
Use the following steps when creating a new Screen Capture Project or 
when inserting new screenshot slides. 

i. To CREATE a Capture Profile: 

1. Open the Capture Profile dialog. 

2. Click the Add button. The Capture Options dialog displays. 

3. Select a Capture Mode from the list (Smart Capture or 
Manual Capture). 

4. Smart Capture automatically captures all changes that 
occur on your computer’s screen during a screenshot 
session. When the screenshots are converted to project 
slides, a minimum of three background frames (the last 
three screen changes captures) will be added to each 
project slide. 

a. General tab: 

i. In the Identification area, enter a: 

1. Name for the profile. This name will 
display in the Capture Profiles list. 
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2. Description or a short summary for 
the profile. This will display below 
the profile title in the Capture 
Profiles list. 

ii. In the Timing area: 

1. Select the Maintain Timing Links to 
maintain links between applicable 
objects (message objects, cursors, 
etc.) along the Timeline on each 
slide.  

2. Enter the number (of seconds) for an 
Introductory Delay default before the 
first note or balloon is displayed on a 
slide. 

iii. In the Hotkeys area are several hotkeys 
available. To change a hotkey, click the 
applicable button next to the hotkey’s 
description and press the new hotkey(s) to 
be used for the desired hotkey option. 
 
Capture hotkey options include: 

 Capture Screenshot: Capture a 
screenshot manually... 

 Capture Background Frame: 
Capture an animation frame. 

 Pause Capture: Pause the 
capture session. 

 Stop Capture: End the capture 
session and convert screenshots 
to project slides. 

 Cancel Capture: Cancel capture 
session without saving any 
screenshots. 

b. Feedback tab: 

i. In the During Capture area, select / deselect 
(as needed): 

• Hide Tray Icon 
• Tray Icon Blinks 
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ii. In the Play Sound area, select the sounds to 
play during the capture session: 

• On Screen Capture 
• On Background Frame Capture 
• On Key Capture 
• Use Microsoft DirectSound for 

Playback 

c. Mouse tab: 

i. In the On Mouse Click – Add to Slide area, 
select: 

• Click Here Annotations: To enable 
ViewletBuilder8 Enterprise to 
automatically insert balloons for click 
instructions during the capture 
session. 

• Cursor Simulation: To add various 
cursor animation effects to your 
project, which might include Mouse 
Click Sound, Drag to Here 
Annotations, Mouse Drag 
Animation, Curved Cursor Path 
and Transition Cursors. 

• Click Zone Assessment: To 
automatically insert Click Zones to 
the project during the capture 
session. 

• Don’t Add Cursor Simulation or 
Click Zone: To disable all cursor 
simulation or Click Zone additions 
when clicking your mouse during the 
capture session. 

ii. In the Mouse Timing area, enter the number 
(in seconds) for how long you want to 
“delay” for mouse click captures, to set the 
double click speed and to set the “delay” for 
drag captures. Options include: Delay 
Before Click, Delay After Click, Double 
Click Speed and Delay After Drag. 
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d. Wheel tab: 

i. In the On Mouse Wheel – Add to Slide area, 
select / deselect mouse wheel options for 
the capture session, including: 

• Scroll Wheel Up / Down 
Annotations 

• Mouse Wheel Simulation 

• Don’t Add Mouse Wheel 
Simulation 
 

ii. In the Wheel Timing area, enter a number 
for: 

• Wheel Speed (for clicks per 
seconds) 

• Delay After Wheel (for capture 
delay in seconds) 

e. Keyboard tab: 

i. In the On Text Entered area, select: 

• Type Text Here Annotations: To 
enable ViewletBuilder8 Enterprise to 
automatically add balloon 
instructions during text input in the 
capture session. 

• Typing Simulation: To add typing 
animation to your project. 

• Key Click Sound: To include sound 
effects with the typing animation. 

• Text Zone Assessment: To 
automatically add Text Zones to the 
project during the capture session 
(where applicable). 

• Don’t Add Typing Simulation or 
Text Zone: To disable all typing 
simulation or Text Zone additions to 
the project when typing during the 
capture session. 
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ii. In the On Text Entered – Add to Slide area, 
click the Modify button next to the 
Completion Keys field: 

• The Completion Keys dialog 
displays. The Key list displays the 
keyboard keys that ViewletBuilder8 
Enterprise will recognize as a 
“completion key” hotkey when text 
simulation is captured. Basically, 
after typing text, when one of these 
hotkeys is pressed, a new 
screenshot will be captured. 

• Click the Add button to add a new 
Completion Key to the list. 

• Select a key and click the Delete 
button to remove it from the list. 

• Select a key and click the Move Up 
button to move it up in the list. 

• Select a key and click the Move 
Down button to move it down in the 
list. 

• Click OK to close the Completion 
Keys dialog. 
 

iii. In the Keyboard Timing area, enter a 
number for the: 

• Typing Speed (rate of capture in 
words per minute) 

• Typing Variability (percentage to 
be used to vary the typing effects 
during playback for the most realistic 
simulation) 

• Delay After Typing (number of 
seconds of delay after typing 
simulation is complete) 

 
f. Annotations tab: 

i. In the Annotation Language area, use the 
list to select the language to be used if 
enabling ViewletBuilder8 Enterprise to 
automatically create annotations (balloons) 
during the capture session. 
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ii. In the “default values” area, you can modify 
the default values for each of the 
annotations.  
 
For example, the Name column contains 
the “title of the action to occur” in order for 
the “data” in the Value column to be 
inserted in an annotation (balloon) during 
the capture session. 
 
To change the “data” (text) that will be 
inserted in a specific annotation: 

1. Click the desired field in the Value 
column. 

2. Type in the edits. 

3. Press the Enter or Tab key to apply 
the edits. 
 

iii. In the Modifiers area, select (as needed): 

• Prefix Click Annotations with 
Modifiers: If selected, this will add 
the text “[Ctrl]” or “[Shift]” (when the 
applicable key is pressed at the 
same time a left mouse click occurs) 
as a “Modifier” to the “Click Here” 
annotation. 

• Separator: Enter the letter to use 
between the “Modifier” and the 
“Annotation” (Click Here) text. 

• Highlight Variables in Bold: If 
selected, this will bold the variable 
text contained in the annotation. 
 

g. Advanced tab: 

i. In the Frame Rate area, enter a number 
(Frames per Second) for the rate at which 
you want to capture screenshots during a 
mouse drag operation. 

ii. In the Screenshot Delay area, enter a 
number (in seconds) for the amount of time 
ViewletBuilder8 Enterprise will delay after a 
mouse click to take a screenshot. 

iii. In the Capture Popups area, select the 
Capture Popups option to enable capture 
of such elements as tooltips, hints and 
popup menus. 
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5. Manual Capture is driven by hotkey presses (or mouse 
clicks, if enabled) and captures one static screenshot per 
capture. When the capture session is ended, each 
screenshot will be converted to a single background frame 
per slide in the project. 

a. General tab: 

i. In the Identification area, enter a: 

1. Name for the profile. This name will 
display in the Capture Profiles list. 

2. Description or a short summary for 
the profile. This will display below 
the profile title in the Capture 
Profiles list. 

ii. In the Timing area: 

1. Select the Maintain Timing Links to 
maintain links between applicable 
objects (message objects, cursors, 
etc.) along the Timeline on each 
slide.  

2. Enter the number (of seconds) for an 
Introductory Delay default before the 
first note or balloon is displayed on a 
slide. 

iii. In the Hotkeys area are several hotkeys 
available. To change a hotkey, click the 
applicable button next to the hotkey’s 
description and press the new hotkey(s) to 
be used for the desired hotkey option. 
 
Capture hotkey options include: 

 Capture Screenshot: Capture a 
screenshot manually... 

 Capture Background Frame: 
Capture an animation frame. 

 Pause Capture: Pause the 
capture session. 

 Stop Capture: End the capture 
session and convert screenshots 
to project slides. 

 Cancel Capture: Cancel capture 
session without saving any 
screenshots. 
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b. Feedback tab: 

i. In the During Capture area, select / deselect 
(as needed): 

• Hide Tray Icon 
• Tray Icon Blinks 

 
ii. In the Play Sound area, select the sounds to 

play during the capture session: 

• On Screen Capture 
• On Background Frame Capture 
• On Key Capture 
• Use Microsoft DirectSound for 

Playback 
 

c. Mouse tab: 

i. In the On Mouse Click – Add to Slide area, 
select: 

• Cursor Simulation: To capture 
cursor animations including the 
curved cursor path. 

• Don’t Add Cursor Simulation to 
disable cursor animation capture. 

ii. In the Mouse Click Capture area, you can 
select additional ways to manually capture 
screenshots, including using regular and 
right click mouse actions. 
 

d. Advanced tab: 

i. In the Capture Popups area, select the 
Capture Popups option to enable capture 
of such elements as tooltips, hints and 
popup menus. 

 
6. Click OK to save the profile, which will be added to the list 

in the Capture Profiles dialog. 
 
 

ii. To MODIFY a Capture Profile: 

1. Select the desired profile in the list. 

2. Click the Modify button. 

3. The Capture Options dialog displays. Make your edits to 
the Capture Mode and in the various available tabs as 
needed. 
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4. Click OK to save the edits and to close the Capture 
Options dialog. 

 
 

iii. To ORGANIZE Capture Profiles in the list: 

1. Select a profile in the list. 

2. Click the Move Up button to move the profile up in the list. 

3. Click the Move Down button to move the profile down in 
the list. 
 

iv. To DELETE a Capture Profile: 

1. Select the desired profile in the list. 

2. Click the Delete button. 

3. Click Yes to confirm the deletion. 
 

4. Select the Options tab to choose a Stylesheet for the project from the list. 
 

Starting / Running the Capture Session 
For the most part, each screen capture session starts the same way. After selecting a 
Capture Profile to use for the capture session, you click OK to start the actual recording 
session. But, what happens AFTER you click OK is determined by two factors: 
 
 The Capture Area selection made  
 The Capture Mode selected 

 
This section focuses on what to expect and instructions for what you will need to do 
“right before” you actually start capturing screenshots (if applicable). 
 

Capture Area – How it Affects the Capture Session 
The following is some helpful information to let you know what to expect at the start of 
your capture session as determined by your Capture Area selection. 
 
 Custom – Specify a custom height and width. 

Before beginning the capture session, a “bounding box” (dotted rectangle) will 
display on your screen in the size you specified when selecting a width and 
height for your project. This box denotes the capture area. Everything inside this 
box will be included in the screenshot. 

o To move the capture area, point your cursor over the bounding box. 
When the cursor changes to a “hand shape”, hold down the left mouse 
button and drag to move the capture area to the desired location on your 
screen. 

o To resize the capture area (if needed), point your cursor over one of the 
gnodes (grab handles) along the edge of the bounding box. Hold down 
your left mouse button and drag to resize.  
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o To “set” the capture area, mouse your cursor inside the capture area and 
double click to set its size and position. (You are now ready to take 
screenshots.) 
 

 Standards – Select a standard window size. 
Before beginning the capture session, a “bounding box” (dotted rectangle) will 
display on your screen in the size you specified when selecting a width and 
height for your project. This box denotes the capture area. Everything inside this 
box will be included in the screenshot. 

o To move the capture area, point your cursor over the bounding box. 
When the cursor changes to a “hand shape”, hold down the left mouse 
button and drag to move the capture area to the desired location on your 
screen. 

o To resize the capture area (if needed), point your cursor over one of the 
gnodes (grab handles) along the edge of the bounding box. Hold down 
your left mouse button and drag to resize. 

o To “set” the capture area, mouse your cursor inside the capture area and 
double click to set its size and position. (You are now ready to take 
screenshots.) 
 

 Application – Capture a running application window. 
The selected program or operating system window will launch on top of all other 
open windows on your computer’s screen and the screen capture session 
begins. This “active” window, surrounded by a “bounding box” (dotted rectangle), 
indicates the capture area. Everything in the capture area (in this example, the 
“active” window) will be included in the screenshot. 

 
 Area – Capture an area of the screen. 

Before the capture session, the cursor changes to a “cross hair” shape. This 
means before the capture session can start, you must define the capture area.  

 
o Point the “cross hair” cursor to the point on the screen where you want to 

start drawing your capture area. 

o Hold down the left mouse button and drag to draw the capture area. As 
you drag the cursor, a “bounding box” (dotted rectangle) will start to form. 
This is the capture area. Everything inside the capture area will be 
included in the screenshot. 

o Let go of the left mouse button to “set” the capture area’s size and 
position. (You are now ready to take screenshots.) 
 

o Dialog – Select a window to capture. 
This option allows you to select an entire window or a portion of an open 
window. The trick here is that you MUST have the window open (not 
minimized) BEFORE you click OK to set up the screen capture session. 
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 Make sure the window you want to capture is open on your 
computer screen (underneath the ViewletBuilder8 Enterprise 
program) and all other program and operating system windows 
are closed or minimized. 
 

 Click OK to start the capture session. 
 

 A “red box” will display over the dialog that is displayed on your 
computer screen. Move the cursor around the window until the 
“red box” outlines the entire window or a portion of the window. 
 

 To “set” the capture area, double click inside the “red box”. The 
“red box” will change to a “Bounding Box” indicating that the 
capture area is set. (You are now ready to take screenshots.) 
 

 Full Screen – Capture the entire screen. 
When using the “Full Screen” slide size option, if you select a “screen resolution” 
different then what your monitor is set to when starting the screen capture 
session, after you click OK to start the capture session, ViewletBuilder8 
Enterprise will automatically adjust your monitor’s resolution to what you selected 
for the slide size and, the screenshot capture session begins. 
 
Everything visible on your screen will be included in the screenshots. Once the 
capture session is ended, the monitor’s resolution will return back to its settings 
prior to taking screenshots. 

 

Capture Mode – How it Affects the Capture Session 
How the capture session begins (whether it immediately goes live or requires you to 
press a hotkey or start button to start the actual recording) depends on the Capture 
Mode.  
 
Smart Capture vs. Manual Capture 
Smart Capture mode is driven by mouse clicks and key presses. Once the capture 
session starts, ViewletBuilder8 Enterprise will automatically start taking screenshots 
(based on the selections made in the Capture Profile you are using). Each time a 
screenshot is taken, you will hear a camera shutter sound (if the On Screen Capture 
option in the Feedback tab is selected).  
 
Note: Smart Capture records a minimum of three screenshots for each capture and will embed 
them as background frames on a single slide. 
 

Manual Capture mode is driven by hotkey clicks (and mouse clicks, if this option is 
enabled). Once the capture session is starts, use the Capture Screenshot hotkey (and 
mouse clicks, if applicable) to capture individual screenshots manually. 
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To capture an “extra” animation during a Smart Capture session: 

 While a Smart Capture session is running, click the Capture Background 
Frame hotkey to manually capture any “extra” animation that displays on your 
screen that you think Smart Capture might not capture. 
 

To pause and resume a capture session, if the capture mode you are using is: 
 
 Smart Capture: Click the Pause hotkey to temporarily pause the Smart Capture 

session without ending it. The Capture Status dialog will display (over the system 
tray). To resume the Smart Capture session, click the Continue button. 

 Manual Capture: Click the Pause hotkey to temporarily pause the Manual 
Capture session without ending it. The Capture Status dialog will display (over 
the system tray). To resume the Manual Capture session, click the Continue 
button. 
 

To switch between Smart Capture and Manual Capture modes during a capture session: 

1. Click the Pause hotkey to temporarily pause the capture session. 

2. The Capture Status dialog displays. Click the More button to expand the options 
available in the Capture Status dialog. 

3. Select the desired Capture Mode from the list (at the top of the Capture Status 
dialog). 

4. Click Continue to resume the capture session, using the newly selected capture 
mode. 

 
To modify capture options during a capture session: 

1. Click the Pause hotkey to temporarily pause the capture session. 

2. The Capture Status dialog displays. Click the More button to expand the dialog. 

3. Select the desired Capture Mode from the list. 

4. Select the applicable tab(s) and modify selections as needed. 

5. Click the Less button to collapse the Capture Status dialog. 

6. Click the Continue button to resume the capture session using the modified 
capture settings. 

 

Ending the Capture Session 
Ending the screen capture session converts the captured screenshots to project slides.  

1. To END the capture session, you can either: 

a. Use the Stop Capture hotkey you defined in your Capture Profile, or 

b. Click on the ViewletBuilder icon in the system tray and click Stop. 

2. A progress bar may display briefly as your captures are converted. Once 
conversion is complete, you capture session is over and your project is ready to 
be saved and edited inside your authoring application. 
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Canceling a Capture Session 
You can “back out” of any “live” capture session by using the Cancel Capture hotkey. 
Or, click the Cancel button in the Capture Status dialog. When you cancel, this will end 
the active capture session without saving any screenshots. You will be returned to 
ViewletBuilder8 Enterprise’s “Start View” to start anew. 

1. To CANCEL the capture session, you can either: 

a. Use the Cancel Capture hotkey you defined in your Capture Profile, or 

b. Click on the ViewletBuilder icon in the system tray and click Cancel. 
2. When prompted, confirm the cancel operation. 

 

Modifying Options During a Capture Session 
You can modify any option in your Capture Profile during a capture session. Be careful 
when doing this because any changes made at this time will also be updated in your 
Capture Profile. 

1. Move your mouse over the system tray. 

2. Click the ViewletBuilder icon. 

3. The Capture Status dialog displays. Click the More button. 

4. The Capture Status dialog expands, allowing you access to the capture modes 
and related capture mode tabs. Make your changes as desired. 

5. Click the Less button once all of your changes are made to hide the Capture 
Status dialog. 

6. Click Continue, Stop or Cancel as needed. 
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VIDEO CAPTURE PROJECT 
The Video Capture Project option allows you to record onscreen actions and audio in 
real time to produce video demos, simulations and assessments. 
 

 
 

Capture Options Setup 
This section provides information on setting up options that will be used for the capture 
session. 

1. Open the Create New Project dialog. There are several ways to do this: 

a. Select File > New from the Menu bar, or 

b. Click the New Project link (Start View page > Actions area), or 

c. Click the New button from the Main toolbar. 

2. The Create New Project dialog displays a list of new project types. Select Video 
Capture Project then click the Create button to continue to the next screen. 

3. Select the Capture tab to choose options for: 

d. Capture Area: Here you will find options to choose for setting the capture 
area during the capture session. The dimensions chosen here will also be 
the same as your slide size (width and height) when the screenshots are 
converted to project slides.  
 
Capture Area Methods and Instructions 

i. Custom: Set a custom width and height. 

1. Enter a number in the Width field. 

2. Enter a number in the Height field. 
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ii. Standards: Select from a list of standard resolutions, or create a 
new standard to add to the list.  

1. To CREATE a new Standard Resolution: 

a. Select the Standards – Select a standard 
window size option from the list. 

b. Click the Add Standard button. The Standard 
Resolution dialog displays. 

c. Enter a Name for the new standard. 

d. Enter a number for both the Width and the Height. 

e. Click OK. 
 

2. To MODIFY an existing Standard Resolution: 

a. Select Standards – Select a standard window 
size option from the list. 

b. Click the Modify Standard button. The Standard 
Resolutions dialog displays. 

c. Edit your options as needed. 

d. Click OK to save the changes. 
 

3. To DELETE an existing Standard Resolution: 

a. Select Standards – Select a standard window 
size option from the list. 

b. Select the standard you want to remove. 

c. Click the Delete button. 

d. Click Yes to confirm the deletion. 
 

iii. Application: Capture an open application and use its window size 
(width and height) as your new project’s slide size. 

1. Select an active program or operating system window from 
the list. If you don’t see your target window listed, open it 
and then click the Refresh Applications button to refresh 
the list. 

2. To resize the target window: 

a. Select the Resize Application to: option. 

b. Click the button next to the Resize Application to: 
option. The Application Size dialog displays. 

i. Select Custom or Standards from the list. 
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ii. Select a Standard Resolution from the list, 
or (following the instructions from the 
previous section) create a custom Standard 
Resolution. 

iii. Click OK. 
 

iv. Area: Capture an area of the screen predefined by you prior to the 
capture session. To use this option: 

1. Select Area – Capture an area of the screen from the list. 

2. Make sure you have set all additional capture session 
options in the Capture and Options tabs. 

3. Click OK to start the capture recording session. 

4. Before the recording session begins, you will be prompted 
to define the capture area: 

a. Hold down your left mouse button and drag to 
define the capture area. 

b. Let go of the mouse button to set the area indicated 
by a rectangle with dotted lines. Everything INSIDE 
this rectangle will be included in the screenshot. 
 

v. Window: Select an open window prior to your capture session 
and its size will determine the resulting slide size for your project. 
To use this option: 

1. Select Window – Select a window to capture from the 
list. 

2. Make sure you have set all additional capture session 
options in the Capture and Options tabs. 

3. Click OK to start the capture recording session. 

4. Before the recording session begins, you will be prompted 
to choose a window (or portion of a window): 

a. A red border outlines the window (or portion of the 
window) that can be used for the recording area. 
Roll you mouse over the window and click to set 
the area. 

b. Once the area is set, it will be surrounded by a 
rectangle with dotted lines. Everything INSIDE this 
rectangle will be included in the screenshot. 

vi. Full Screen: Capture everything visible on your computer’s 
screen. If you: 

1. Use the Current screen resolution from the list, no 
resolution changes will occur when you go into your 
capture session. 
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2. Use another screen resolution (different from your current 
resolution) from the list, your monitor’s resolution will 
automatically change to the selected resolution going into 
the capture session. It will change back to its prior setting 
once you’ve successfully ended your screen capture 
session. 
 

e. Capture Profile: This is where you select a Capture Profile to use during 
the recording session. 
 
Capture Profiles – Quick FAQs 
 
What is a Capture Profile? 
It is a way to organize all the “capture options” chosen for your recording 
session into one place or “profile”. 
 
Does the Capture Profile “title” signify anything? 
Yes and no. The “title” of the Capture Profile is like the title of a 
document. It just gives you an idea of what the profile would be used for. 
You can change the title of the profile at any time. 
 
Can Capture Profiles be created, modified and/or deleted? 
Yes, when creating a new Video Capture Project, you will see one profile 
initially installed. You can, however, create new profiles from scratch, or 
modify any from the list. And, if your list of profiles becomes too long, you 
can also delete any profiles you no longer need. 
 
Working with Capture Profiles 
Use the following steps when creating a new Video Capture Project or 
when inserting new video slides. 

i. To CREATE a Capture Profile: 

1. Open the Capture Profile dialog. 

2. Click the Add button. The Capture Options dialog displays 
with Video Capture mode selected. 

3. Go through the tabs and make selections for your 
recording session to be saved in this profile: 

a. General tab: 

i. In the Identification area, enter a: 

1. Name for the profile. This name will 
display in the Capture Profiles list. 

2. Description or a short summary for 
the profile. This will display below 
the profile title in the Capture 
Profiles list. 
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ii. In the Hotkeys area are several hotkeys 
available. To change a hotkey, click the 
applicable button next to the hotkey’s 
description and press the new hotkey(s) to 
be used for the desired hotkey option. 
 
Capture hotkey options include: 

 Pause/Resume Capture: Pause 
and resume the video capture 
session. 

 Stop Capture: Stop the capture 
session. 

 Mute Sound: Mute audio 
recording during the capture 
session. 

iii. In the Sound Recording area: 

 Select the Record Sound 
During Capture option to enable 
sound capture during the 
recording session. 

 Click the Recording Options 
button to open the Recording 
Options dialog: 

 In the Input Device area, select a 
sound recording device from the 
list. 

 In the Quality area, choose your 
Sample Rate and Sample Size. 
You can also enable/disable 
Stereo. 

 In the Format area, select WAV 
or MP3. 

 In the Microphone Latency area, 
set a microphone delay (if 
needed). 

b. Feedback tab: 

i. In the During Capture area, select / deselect 
(as needed): 

• Hide Tray Icon 
• Tray Icon Blinks 
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c. Mouse tab: 

i. In the On Mouse Click – Add to Slide area, 
select: 

• Cursor Simulation: To capture 
cursor animations and cursor click 
sounds. 

• Don’t Add Cursor Simulation or 
Click Zone to disable cursor 
animations and click sounds 
capture. 
 

d. Advanced tab: 

i. In the Frame Rate area, enter a number 
(Frames per Second) to capture during the 
recording session. 

ii. In the Capture Popups area, select the 
Capture Popups option to enable capture 
of such elements as tooltips, hints and 
popup menus. 

iii. In the Split Video Internal area, you can opt 
to split the video during the live recording in 
a few different ways: 

 Minutes: The video will be split 
according to the value set (in 
minutes). So, if you set this value to 
2 minutes and the entire recording 
session lasts 10 minutes, when it 
converts the capture it will generate 
5 video slides (one for each two 
minutes). 

 Split Video on Pause: This option 
will split the video automatically into 
separate video slides (on 
conversion) based on each time you 
‘pause’ during the recording session. 

 
4. Click OK to save the profile, which will be added to the list 

in the Capture Profiles dialog. 
 
 

ii. To MODIFY a Capture Profile: 

1. Select the desired profile in the list. 

2. Click the Modify button. 
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3. The Capture Options dialog displays. Make your edits to 
the Capture Mode and in the various available tabs as 
needed. 

4. Click OK to save the edits and to close the Capture 
Options dialog. 

 
 

iii. To ORGANIZE Capture Profiles in the list: 

1. Select a profile in the list. 

2. Click the Move Up button to move the profile up in the list. 

3. Click the Move Down button to move the profile down in 
the list. 
 

iv. To DELETE a Capture Profile: 

1. Select the desired profile in the list. 

2. Click the Delete button. 

3. Click Yes to confirm the deletion. 
 

4. Select the Options tab to choose a Stylesheet for the project from the list. 
 

Starting / Running the Capture Session 
After selecting a Capture Profile to use for the capture session, you click OK to start the 
actual recording session. But, what happens AFTER you click OK is determined not only 
by your Video Capture mode selection, but also the Capture Area selected you made. 
 
The following sections provide more information on what to expect at the beginning of 
your Video Capture recording session based on your Capture Area selection as well as 
instructions for additional capture session operations. 

Capture Area – How it Affects the Capture Session 
The following is some helpful information to let you know what to expect at the start of 
your capture session as determined by your Capture Area selection. 
 
 Custom – Specify a custom height and width. 

Before beginning the capture session, a “bounding box” (dotted rectangle) will 
display on your screen in the size you specified when selecting a width and 
height for your project. This box denotes the capture area. Everything inside this 
box will be included in the screenshot. 

o To move the capture area, point your cursor over the bounding box. 
When the cursor changes to a “hand shape”, hold down the left mouse 
button and drag to move the capture area to the desired location on your 
screen. 
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o To resize the capture area (if needed), point your cursor over one of the 
gnodes (grab handles) along the edge of the bounding box. Hold down 
your left mouse button and drag to resize.  

o To “set” the capture area, mouse your cursor inside the capture area and 
double click to set its size and position. (You are now ready to take 
screenshots.) 
 

 Standards – Select a standard window size. 
Before beginning the capture session, a “bounding box” (dotted rectangle) will 
display on your screen in the size you specified when selecting a width and 
height for your project. This box denotes the capture area. Everything inside this 
box will be included in the screenshot. 

o To move the capture area, point your cursor over the bounding box. 
When the cursor changes to a “hand shape”, hold down the left mouse 
button and drag to move the capture area to the desired location on your 
screen. 

o To resize the capture area (if needed), point your cursor over one of the 
gnodes (grab handles) along the edge of the bounding box. Hold down 
your left mouse button and drag to resize. 

o To “set” the capture area, mouse your cursor inside the capture area and 
double click to set its size and position. (You are now ready to take 
screenshots.) 
 

 Application – Capture a running application window. 
The selected program or operating system window will launch on top of all other 
open windows on your computer’s screen and the screen capture session 
begins. This “active” window, surrounded by a “bounding box” (dotted rectangle), 
indicates the capture area. Everything in the capture area (in this example, the 
“active” window) will be included in the screenshot. 

 
 Area – Capture an area of the screen. 

Before the capture session, the cursor changes to a “cross hair” shape. This 
means before the capture session can start, you must define the capture area.  

 
o Point the “cross hair” cursor to the point on the screen where you want to 

start drawing your capture area. 

o Hold down the left mouse button and drag to draw the capture area. As 
you drag the cursor, a “bounding box” (dotted rectangle) will start to form. 
This is the capture area. Everything inside the capture area will be 
included in the screenshot. 

o Let go of the left mouse button to “set” the capture area’s size and 
position. (You are now ready to take screenshots.) 
 

o Dialog – Select a window to capture. 
This option allows you to select an entire window or a portion of an open 
window. The trick here is that you MUST have the window open (not 
minimized) BEFORE you click OK to set up the screen capture session. 
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 Make sure the window you want to capture is open on your 
computer screen (underneath the ViewletBuilder8 Enterprise 
program) and all other program and operating system windows 
are closed or minimized. 
 

 Click OK to start the capture session. 
 

 A “red box” will display over the dialog that is displayed on your 
computer screen. Move the cursor around the window until the 
“red box” outlines the entire window or a portion of the window. 
 

 To “set” the capture area, double click inside the “red box”. The 
“red box” will change to a “Bounding Box” indicating that the 
capture area is set. (You are now ready to take screenshots.) 
 

 Full Screen – Capture the entire screen. 
When using the “Full Screen” slide size option, if you select a “screen resolution” 
different then what your monitor is set to when starting the screen capture 
session, after you click OK to start the capture session, ViewletBuilder8 
Enterprise will automatically adjust your monitor’s resolution to what you selected 
for the slide size and, the screenshot capture session begins. 
 
Everything visible on your screen will be included in the screenshots. Once the 
capture session is ended, the monitor’s resolution will return back to its settings 
prior to taking screenshots. 

 

The Video Capture Session 
Once you’ve made all the selections in the Capture and Options tabs, you are ready to 
begin the Video Capture session. 

1. Click the Finish button to start the live recording session. 

2. A Video Capture Tips window displays. Read the information carefully and then 
click the “X” to close this window and to continue to the video capture session. 
Select the check box next to “Don’t show this message again” at the bottom of 
this window if you don’t want this window to display at the start of each new video 
capture session. 
 

3. The Video Capture Mode toolbar displays options for the capture session: 
 

 
 

a. Start: Use this button to begin the recording session. 
b. Stop: Use this button to finish the recording session. 
c. Microphone: Use this button to enable/disable audio during the recording 

session. 
 

4. You will be prompted by a Start button to begin. Click it to begin the recording 
session. 
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5. Record your onscreen actions (and audio, if enabled) as desired. Click Stop to 
end the capture. 

6. A Stop Capture screen displays (if screenshots were captured) with the 
following options: 
 

a. Stop and Import the Capture Session is used to end the current 
recording session and convert the capture to video for editing. 
 

b. Resume the Capture Session is used to continue a paused session. 
 

c. Cancel and Restart the Capture Session is used to cancel the active 
session, returning you to the “start” position for beginning the session. 
 

d. Cancel the Capture Session is used to discard all captures and returns 
you directly to ViewletBuilder7 Enterprise. 
 

7. Click the Stop and Import the Capture Session button. Everything captures 
during the recording session will be converted to project slides ready for editing. 
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IMAGE PROJECT 
The Image Project lets you create a slideshow from images on your system. Images are 
converted to background frames (one image per slide). 
 

 
 

1. Open the Create New Project dialog. There are several ways to do this: 

f. Select File > New from the Menu bar, or 

g. Click the New Project link (Start View page > Actions area), or 

h. Click the New button from the Main toolbar. 

2. The Create New Project dialog displays a list of new project types. Select Image 
Project then click the Create button to continue to the next screen. 

3. Several tabs display. Go through each to make your selections: 

a. Images tab: You will select images to use in your project. Supported 
formats include GIF, JPG, JPEG, PNG, BMP, TIF and TIFF. 

i. Click the Add button to search for and select image files. 

ii. Click Open to load the images. 

iii. Select an image to preview it (in the preview area). 

iv. To rotate one or more images, make your selections and then 
click the Rotate Left or Rotate Right button. 

v. To organize the list of images, select an image and click the Move 
Up or Move Down button. 
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vi. To determine how you want an image aligned on the project slide, 
select the image, click the Alignment button and make your 
selection. 

vii. To remove an image from the list, select it and click the Delete 
button. 

b. Slides tab: Select the options for the project slide sizes for the image files. 

i. Custom: Set a custom width and height. 

1. Enter a number in the Width field. 

2. Enter a number in the Height field. 
 

ii. Standards: Select from a list of standard resolutions, or create a 
new standard to add to the list.  

1. To CREATE a new Standard Resolution: 

a. Select the Standards – Select a standard 
window size option from the list. 

b. Click the Add Standard button. The Standard 
Resolution dialog displays. 

c. Enter a Name for the new standard. 

d. Enter a number for both the Width and the Height. 

e. Click OK. 
 

2. To MODIFY an existing Standard Resolution: 

a. Select Standards – Select a standard window 
size option from the list. 

b. Click the Modify Standard button. The Standard 
Resolutions dialog displays. 

c. Edit your options as needed. 

d. Click OK to save the changes. 
 

3. To DELETE an existing Standard Resolution: 

a. Select Standards – Select a standard window 
size option from the list. 

b. Select the standard you want to remove. 

c. Click the Delete button. 

d. Click Yes to confirm the deletion. 
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iii. Navigation tab: Set navigational elements for project slides. 

1. In the Slide duration area, enter a number for the default 
amount of time each slide will display (in seconds). 

2. In the General Options area, select/deselect the option to 
add a pause zone to each project slide. 

iv. Options tab: Choose a stylesheet and slide transitions for the 
project. 

4. Click OK to convert the images to project slides (as background frames) ready 
for editing. 
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POWERPOINT PROJECT 
The PowerPoint Project let you create a project by importing slides from a PowerPoint 
project. 
 

 
 

1. Open the Create New Project dialog. There are several ways to do this: 

i. Select File > New from the Menu bar, or 

j. Click the New Project link (Start View page > Actions area), or 

k. Click the New button from the Main toolbar. 

2. The Create New Project dialog displays a list of new project types. Select 
PowerPoint Project then click the Create button to continue to the next screen. 

3. Several tabs display. Go through each to make your selections: 

a. Project tab:  

i. Click the Browse button to search for and select your PowerPoint 
presentation file. 

ii. Click Open to load the file. 

iii. Select a file (from the list) to preview. 
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iv. To organize the list, select a slide and click the Move Up or Move 
Down button. 

v. Select Stretch to fill the slide to stretch the slide’s image to fill 
the entire dimensions (width and height) of your project slide. 

vi. To remove an slide from the list, select it and click the Delete 
button. 

b. Slides tab: Select the options for the project slide sizes. 

i. Custom: Set a custom width and height. 

1. Enter a number in the Width field. 

2. Enter a number in the Height field. 
 

ii. Standards: Select from a list of standard resolutions, or create a 
new standard to add to the list.  

1. To CREATE a new Standard Resolution: 

a. Select the Standards – Select a standard 
window size option from the list. 

b. Click the Add Standard button. The Standard 
Resolution dialog displays. 

c. Enter a Name for the new standard. 

d. Enter a number for both the Width and the Height. 

e. Click OK. 
 

2. To MODIFY an existing Standard Resolution: 

a. Select Standards – Select a standard window 
size option from the list. 

b. Click the Modify Standard button. The Standard 
Resolutions dialog displays. 

c. Edit your options as needed. 

d. Click OK to save the changes. 
 

3. To DELETE an existing Standard Resolution: 

a. Select Standards – Select a standard window 
size option from the list. 

b. Select the standard you want to remove. 

c. Click the Delete button. 

d. Click Yes to confirm the deletion. 
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iii. Navigation tab: Set navigational elements for project slides. 

1. In the Slide duration area, enter a number for the default 
amount of time each slide will display (in seconds). 

2. In the General Options area, select/deselect the option to 
add a pause zone to each project slide. 
 

iv. Options tab: Choose a stylesheet and slide transitions for the 
project. 
 

4. Click OK to convert the PowerPoint slides to project slides (as background 
frames) ready for editing. 
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QUESTION PROJECT 
The Question Project type allows you to integrate scored slides and simple survey 
question slides into a single Viewlet project. Or, if you prefer, use the Question Project to 
create an entire quiz project (for testing purposes) or an entire survey project (for 
gathering information from a user base). 
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Question Types 
There are several different question types available and can be used for quizzes 
(scored) or surveys (not scored) depending on the selected Scoring Mode. Let take a 
look at the different question types available. 

Short Answer – Fill in the Blank 
This question type requires the user to fill in the blank with a single answer. 
 

 
 

Short Answer – Selection from List 
This question type requires the user to select a single answer from a list. 
 

 
 

Short Answer – Rating 
This question type requires the user to select a single rating from a given scale. 
 

 
 

Short Answer – Essay 
This question type allows the user to type in one or more words, sentences or 
paragraphs (essay style) to respond. 
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Multiple Choice – Single Answer 
This question type requires the user to select a single answer from a list with two or 
more choices. 
 

 
 

Multiple Choice – Multiple Answers 
This question type requires the user to select a single or multiple answers from a list with 
two or more choices. 
 

 
 

Multiple Choice – Fill in the Blanks 
This question type requires the user to type in a response in one or more “fill in the 
blank” entry fields. 
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Multiple Choice – Selection from Lists 
This question type requires the user to select an answer from one or more lists. 
 

 
 

Multiple Choice – Rating 
This question type requires the user to select one or more ratings from a single or 
multiple rating scales. 
 

 
 

Multiple Choice – True/False 
This question type requires the user to select an answer from one of only two possible 
choices. 
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Likert Scale 
This question type requires the user to select an answer based on their specific level of 
agreement to a specific statement. 
 

 
 

Drag and Drop 
This question type requires the user to match up items by dragging their response(s) 
across columns. 
 

 
 
 
Click Map 
This question type requires the user to click on one or more areas of the screen in order 
to respond. 
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Random Question 
This question type is used to randomly pull a question from a specified Question Bank 
each time the published file is viewed. 
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Question Banks 
Question Banks provide a way to have your project randomly display different quiz and 
survey questions each time your Viewlet is played. Working in conjunction with the 
Random Question type, you can create one or more Question Banks for quiz or survey 
questions. 
 

 
 

1. To CREATE a Question Bank: 

a. Click the Add a Question Bank button. 

b. In the Add Question Bank dialog that displays, there are two tabs: 

i. General tab:  

1. Enter a title for the Question Bank in the Name field. 

2. In the Scoring Mode area, select whether questions in this 
bank will all be treated as Quiz (scored) or Survey (not 
scored). 

ii. Scoring tab: The selections available in this tab are determined by 
the Scoring Mode selection made in the General tab. 
 
      Quiz (Scoring Mode) 

1. Select Override Settings in Project Properties to use the 
settings you configure in this dialog. 

2. In the Points area, enter a number for the total points to be 
used for each quiz question in the bank. 

3. In the Attempts area, enter a number for the total number 
of allowed attempts for each quiz question in the bank. 
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4. In the Reanswer area, select/deselect the Question can 
be reanswered on backwards navigation option. 

5. In the Time area, to enable a time limit for each quiz 
question, select the Enable a time limit for the question 
and then enter a number for Hours, Minutes and 
Seconds. 
 

         Survey (Scoring Mode) 

1. Select Override Settings in Project Properties to use the 
settings you configure in this dialog. 

2. In the Reanswer area, select/deselect the Question can 
be reanswered on backwards navigation option. 

3. In the Time area, to enable a time limit for each survey 
question, select the Enable a time limit for the question 
and then enter a number for Hours, Minutes and 
Seconds. 

c. Click OK to create the Question Bank. 
 

2. To MODIFY a Question Bank: 

a. Select the Question Bank. 

b. Click the Modify button. 

c. Make your edits as needed in the General and Scoring tabs. 

d. Click OK to apply the changes. 
 

3. To DELETE a Question Bank: 

a. Select the Question Bank. 

b. Click the Delete button. 

c. Click Yes to confirm the deletion. 

 

Creating a New Question Project 
If you haven’t done so already, review the previous two sections on ‘Question Types’ 
and ‘Question Banks’. Once you have done this, you are ready to create a new Question 
Project. 

1. Open the Create New Project dialog. There are several ways to do this: 

a. Select File > New from the Menu bar, or 

b. Click the New Project link (Start View page > Actions area), or 

c. Click the New button from the Main toolbar. 

2. The Create New Project dialog displays a list of new project types. Select 
Question Project then click the Create button to continue to the next screen. 

ViewletBuilder8 Enterprise User Guide Page 72  © 2014 rev. 0626 



 
 
 

3. Several tabs display with options for your new project. These include: 

a. Questions tab: Questions may be added to the Main Timeline or a 
Question Bank. You can create new Question Banks at this point. 

i. Add a question to the Main Timeline: You must add at least one 
question to the Main Timeline in order to create a new project. To 
do this: 

1. Select Main Timeline from the list. 

2. Click the Add Question button. The Question dialog 
displays. 
 
Following are steps for selecting options for the ‘non-
Random Question types’ and for ‘Random Question’ types. 

a. Regular (non-Random) Questions: 

i. Select a Question Type from the list. 

ii. Enter a question or statement in the 
Question field. This will be used as the 
question text. 

iii. Select a Scoring Mode (quiz-scored; 
survey-not scored). 

iv. Select a Style to apply to the question slide. 
 
OR 

b. Random Question: 

i. Select Random Question from the 
Question Type list. 

ii. If no Question Banks are available: 

1. Click the Add a Question Bank 
button. 

2. In the Add Question Bank dialog, 
complete the options for creating a 
new Question Bank in the General 
and Scoring tabs (as outlined in the 
previous section). 

3. Click OK to close this dialog and 
continue on to next step. 

iii. Select a Question Bank from the list. 

iv. Select a value for the Number of 
questions to pull from this bank. 
 

3. Click OK to save selections and to close the Question 
dialog. The question is added to the Main Timeline in the 
list. 
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4. Repeat these steps for every question you want to add to 
the Main Timeline. 
 

ii. Add a question to a Question Bank:  

1. Create one or more Question Banks (as described 
previously) to add to the list. 

2. Select the desired Question Bank from the list. 

3. Click the Add Question button. The Question dialog 
displays. 

4. Select a Question Type from the list (the Random Question 
type is not available at this step). 

5. Enter a question or statement in the Question field. This 
will be used as the question text. 

6. The Scoring Mode is determined by the Question Bank, so 
options here are grayed out. 

7. Select a Style to apply to the question slide. 

8. Click OK to save selections and to close the Question 
dialog. The question is added to the selected Question 
Bank. 

9. Repeat these steps for every question you want to add to a 
Question Bank. 
 

iii. Modify a Question or Question Bank: 

1. Select the Question or Question Bank from the list. 

2. Click the Modify button. The Question dialog displays. 

3. Edit options as needed. 

4. Click OK to save edits and to close the dialog. 
 

iv. To organize items in the list: 

1. Select the desired Question or Question Bank. 

2. Click the Move Up / Move Down button to move the 
selection up / down in the list. 
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v. To remove items from the list: 

1. Select the desired Question or Question Bank. 

2. Click the Delete button. 

3. A Warning dialog may display. Read the information and: 

a. (If applicable) Click OK to close it, resolve the issue 
and start back at step 1 to remove the item from the 
list, or 

b. (if applicable) Click Yes to confirm the deletion and 
remove the selection from the list. 

vi. Preview Options: 

1. Click the right arrow / left arrow to display / hide the 
preview area. 

2. To preview an item in the list: 

a. Select the desired item in the list. 

b. Click the right arrow to display the preview pane (if 
needed) to preview the selection (not all items will 
have a preview available). 
 

c. Slides tab: Select the options for the project slide sizes. 

i. Custom: Set a custom width and height. 

1. Enter a number in the Width field. 

2. Enter a number in the Height field. 
 

ii. Standards: Select from a list of standard resolutions, or create a 
new standard to add to the list.  

1. To CREATE a new Standard Resolution: 

a. Select the Standards – Select a standard 
window size option from the list. 

b. Click the Add Standard button. The Standard 
Resolution dialog displays. 

c. Enter a Name for the new standard. 

d. Enter a number for both the Width and the Height. 

e. Click OK. 
 

2. To MODIFY an existing Standard Resolution: 

a. Select Standards – Select a standard window 
size option from the list. 

b. Click the Modify Standard button. The Standard 
Resolutions dialog displays. 
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c. Edit your options as needed. 

d. Click OK to save the changes. 
 

3. To DELETE an existing Standard Resolution: 

a. Select Standards – Select a standard window 
size option from the list. 

b. Select the standard you want to remove. 

c. Click the Delete button. 

d. Click Yes to confirm the deletion. 
 

d. Options tab: Choose a stylesheet for the project. 
 

5. Click OK to convert the selections to project question slides ready for editing. 

 

Question Randomization & Choice Shuffling 
ViewletBuilder8 Enterprise features tools that allow you to randomize question type 
slides and the order of answers each time the viewer plays back the Viewlet. This 
ensures that the assessment content is fresh each time it is viewed. This section 
provides some information on how these tools work. 
 

Question Randomization 
Following are the steps for designing questions that, on Viewlet playback, will be 
randomly displayed to the viewer. For the most part, you can build these steps in any 
order, but the recommended flow is: 

1. Create one or more question banks. The question bank will determine the 
scoring mode (scored, not scored) of the question slides contained within it. You 
can create question banks when creating a new Question Project type or while 
editing your project. Please refer to the various sections within this guide for 
more information on creating question banks. 

2. Populate the question banks with question slides. At this step, you create all 
of the question type slides you need for each bank. This can be done when 
creating a new Question Project type or while editing your project. Please refer to 
the various sections within this guide for more information on question slides in 
question banks. 

3. Add Random Question slides on the Main Timeline. This is the ‘key’ to the 
whole randomization process. You must insert ONE Random Question type slide 
for EACH question you want randomly generated. Each of these slide types can 
pull one question randomly from a selected question banks. Please refer to the 
various sections within this guide for more information on the Random Question 
slide type. 
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Choice Shuffling 
This feature allows you to design your question slides so that each time the Viewlet is 
played back, the order of the answers (choices) are shuffled randomly. Not all question 
types can use this feature, but when available, it’s easy to set up. 

1. Insert a question slide on the Main Timeline or within a question bank. 

2. Select the slide thumbnail so that it displays in the Slide Editing area. 

3. Click the Shuffle Choices During Viewlet Playback (dice) button on the 
question slide’s Context Sensitive toolbar, if available. 
 

 
  

4. Repeat these steps, as needed, to shuffle choices (when available) for each 
additional question slide. 

5. Preview the results in a browser: 

a. Select Project > Preview in a Browser. 
b. As the question slides play through, note the order the answers (choices) 

are displayed. 

c. When the Viewlet is finished, refresh the browser (F5) and go back 
through the Viewlet to verify the applicable question slides are shuffling 
the answers (choices) on this round of playback. 
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BLANK PROJECT 
The Blank Project type lets you start from scratch by creating a project with one or more 
blank slides. 
 

 
 

1. Open the Create New Project dialog. There are several ways to do this: 

l. Select File > New from the Menu bar, or 

m. Click the New Project link (Start View page > Actions area), or 

n. Click the New button from the Main toolbar. 

2. The Create New Project dialog displays a list of new project types. Select Blank 
Project then click the Create button to continue to the next screen. 

3. Different tabs display with additional options: 

a. Slides tab: Select the options for the project slide sizes. 

i. In the Size area: 

1. Custom: Set a custom width and height. 

a. Enter a number in the Width field. 

b. Enter a number in the Height field. 
 

2. Standards: Select from a list of standard resolutions, or 
create a new standard to add to the list.  

a. To CREATE a new Standard Resolution: 
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i. Select the Standards – Select a standard 
window size option from the list. 

ii. Click the Add Standard button. The 
Standard Resolution dialog displays. 

iii. Enter a Name for the new standard. 

iv. Enter a number for both the Width and the 
Height. 

v. Click OK. 
 

b. To MODIFY an existing Standard Resolution: 

i. Select Standards – Select a standard 
window size option from the list. 

ii. Click the Modify Standard button. The 
Standard Resolutions dialog displays. 

iii. Edit your options as needed. 

iv. Click OK to save the changes. 
 

c. To DELETE an existing Standard Resolution: 

i. Select Standards – Select a standard 
window size option from the list. 

ii. Select the standard you want to remove. 

iii. Click the Delete button. 

iv. Click Yes to confirm the deletion. 
 

d. In the Count area, set the number of blank slides to 
Create for the initial project. 
 

3. Options tab: Choose a stylesheet for the project. 
 

4. Click OK to convert the selections to blank project slides ready for editing. 
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Saving a Project 
ViewletBuilder8 Enterprise offers new options when saving your source files. The new 
features allow for faster performance when opening, saving, publishing and closing your 
project. 
 

 
 

SAVE A PROJECT 
After you create your new project, you should save it. To do this: 

1. Select File > Save from the menu bar. 

2. The Save Project As dialog displays with options for you to select to save your 
source project: 

3. Project Name: Enter a name for your file. 

4. Format: Select a file format to save your project. The default project format for 
ViewletBuilder8 projects is QVPX. 

5. Project Folder: Click the Browse button to locate and select the folder where 
you want to save your project files. 

6. Once all your selections are made in the Save Project As dialog, click OK to save 
the project. 
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THE ANATOMY OF A PROJECT FILE 
By default, your projects will be saved to a ViewletBuilder8\Projects folder located on 
your local computer; however, you can choose to save your projects where ever you 
want. Inside a project folder you will find: 
 
 The source file ending in either QVPX or VIEX 

 
 A “Resources” folder containing all the project’s resources such as sound files, 

background frames, screenshots, thumbnails, cursors, etc. 
 

 An “Output” folder containing all the project’s published output such as the 
Viewlet files, videos and/or Documents, etc. (this folder is not created until 
AFTER you publish your project) 

 
Due to the open nature of the project file (Resources folder), you can directly access the 
project’s resources outside of the program. And, since files are written directly to the 
local drive, this allows quicker performance time when capturing, saving, opening, 
previewing and closing your project than ever before. 
 

FILE ARCHIVE 
You need to create a project file archive (a compressed file containing your project’s files 
and folders) to share your project or to move it for editing / publishing on a different 
computer. To create a project file archive: 
 

 
1. Save your project. 

2. Select File > Create Archive from the Menu bar. 

3. In the Save File As dialog: 
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a. Select a folder for the save location. 

b. Enter a name for the archive file. 

c. Click Save. 

4. Remember where your archived file is stored. When you open this in the 
authoring application, it will be uncompressed automatically and you will be 
prompted to save it to the open project folder format for editing. 

ViewletBuilder8 Enterprise User Guide Page 82  © 2014 rev. 0626 



 
 
 

Tab Views 
The workspace area includes Tab views, each with features to optimize your project 
workflow. As discussed earlier in this guide, Tab views include: 

 Slides 
 Stylesheets 
 Browser 
 Timeline 
 Slide Notes 
 Masters 
 Question Banks 
 Output 
 Problems 

 
Let’s take a look at each of these in more depth. 
 

SLIDES TAB 
The Slides tab provides thumbnails of all the slides located on the project’s Main 
Timeline. These thumbnails (of Main Timeline slides) allow you to: 

 
 Preview slide thumbnails 
 Navigate between slides 
 Zoom in and out on thumbnails 
 Refresh thumbnails 
 Reorder slides 
 Select an active slide for editing purposes 
 Cut, copy, delete, duplicate and paste entire slides or slide elements 
 Insert new on the Main Timeline 
 View slide thumbnails in a storyboard fashion 

 
 
  

ViewletBuilder8 Enterprise User Guide Page 83  © 2014 rev. 0626 



 
 
 
To PREVIEW slide thumbnails: 

1. Select View > Tabs > Slides from the View menu. 

2. Thumbnails of slides on the Main Timeline display in the Slides tab view 
 
 
To NAVIGATE between slides: 

1. Click on a slide thumbnail to make it the active slide in the Slide Editing pane. 

2. To switch to another slide, click its thumbnail in the list. 

3. To progress through slides one by one, use the up / down / right / left arrow keys 
on your keyboard. 

 
To ZOOM in and out on thumbnails: 

1. Click the Zoom In button to zoom in on the thumbnails. Using this feature, all 
thumbnails in the list will get bigger each time you click the button. 

2. Click the Zoom Out button to zoom out on the thumbnails. Using this feature, all 
thumbnails in the list will get smaller each time you click the button. 

 
 
To REFRESH a specific thumbnail: 

1. Select the desired thumbnail to make it the active slide. 

2. Click the Refresh Thumbnail button to refresh the selected thumbnail. 
 
 
To REFRESH all thumbnails: 

1. Click the Refresh All Thumbnails button. This action will refresh all the 
thumbnails. 

 
 
To REORDER slides: 

1. Select one or more thumbnails. 

2. Hold down the left mouse button and drag the slides to the desired location in the 
list. 

3. Let go of the left mouse button to drop into place. 

 
 
To CUT / COPY and PASTE entire slides or slide elements: 

1. Select the desired slide thumbnails or slide elements. 

2. Click the applicable Cut / Copy button. 

3. Click the Paste button to paste the cut / copied selections. 
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To DUPLICATE a thumbnail: 

1. Select the desired slide thumbnail. 

2. Select Edit > Duplicate Slide from the Menu bar. A duplicate of the selected 
slide will be inserted directly after its original. 

 

To DELETE a slide or slide element: 

1. Select the desired slide thumbnail or slide element. 

2. Click the DELETE button. 

3. When prompted, click Yes to confirm the deletion. 
 
 
To INSERT new slides on the Main Timeline: 

1. Select a thumbnail. All new slides will be inserted AFTER the selected thumbnail. 

2. Select Insert > Slides from the Menu bar. 

3. Select one of the options from the expanded menu (Blank Slides, Screenshot, 
Video, Image Slides, PowerPoint Slides, Question Slides, Question Bank). 

a. If inserting a Blank Slide, it will automatically be inserted. 

b. If inserting one of the other slide options: 

i. Follow the instructions in the resulting dialogs. 

ii. Click OK to save the selections and to insert the slide. 
 
 
To VIEW slide thumbnails in a storyboard fashion: 

1. Click the Maximize button. This will expand the Slides tab view. 

2. All of the thumbnails will display in an expanded tab, allowing you to work with 
the thumbnails in a storyboard fashion. 

  

ViewletBuilder8 Enterprise User Guide Page 85  © 2014 rev. 0626 



 
 
 

STYLESHEETS TAB 
The Stylesheets tab provides a way to standardize question slide layouts and attributes 
applied to slides and slide elements. This feature is flexible as the customizable styles 
with cascading attributes are easily superseded at element style levels or while directly 
editing a slide or slide elements. 
 

 
 
Several different stylesheets are pre-installed with your authoring application, so you can 
start with any of them or create a new one. Stylesheets are applied to new projects, but 
also allow you to update existing projects quickly either globally or element by element. 
 

 
Understanding Styles & Attributes 
A stylesheet is a template consisting of predefined styles. In this case, a stylesheet is 
used to standardize the default elements of your Viewlet project. Each style rules how a 
project element is styled (configured) with global styles set at the ‘slide’ level. Each style 
may contain various attributes for such things as slide background color, fonts, etc.   
These attributes cascade down from the slide style level, but may be superseded by a 
‘child’ (slide object) style. 
 

Global (Slide) Styles 
There are two main slide level styles that can be used to create style rules for your 
project at the highest level. Any attributes applied at the slide level will be inherited 
throughout the project unless its cascading effect is superseded by a style at a lower 
(child) level set for other slide objects. 
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Global styles include: 

 Slide: Used to set style rules at the highest level. 

 Question Slide: Used to set style rules at the highest level for questions. 

 
Standard Styles 
In addition to the highest level ‘slide’ styles, you can also add standard or custom styles 
to any stylesheet. Additional standard styles include: 

 Balloon 
 Note 
 Text Box 
 Color Highlight 
 Popout Highlight 
 Line 
 Arrow 
 Matte 
 Button 
 Correct Message 
 Incomplete Message 
 Incorrect Message 
 Click Area 
 Question Text 
 Question Choice Text 
 Question Row Text 
 Question Column Text 
 Question Component Text 
 Question Component Style 
 Drag and Drop Choice Text 
 Drop Area 
 Closed Caption 
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Attributes 
Each style consists of one or more attributes. Attributes associated with styles set at the 
highest (slide) level will be used globally and cascade down to other child styles unless 
superseded at a lower level within another style. A list of attributes that can be used with 
your styles includes: 

 Area Properties 
 Arrow Style 
 Background Color 
 Background Image 
 Border Color 
 Border Width 
 Button Style 
 Check Box Style 
 ComboBox Style 
 Fade Animation 
 Line Style 
 Line Width 
 Message Type 
 Opacity 
 Popout Amount 
 Question Layout 
 Radio Button Style 
 Rating Style 
 Shadow Properties 
 Slide Background Color 
 Text Field Style 
 Text Properties 

 

New Stylesheets 
This section provides information for accessing the Stylesheets tab and instructions for 
creating, modifying and deleting entire stylesheets. 
 
To ACCESS stylesheets: 

1. Select View > Tabs > Stylesheets from the Menu bar. 

2. The Stylesheets tab displays. Click on it to access it and its features. 

 

To CREATE a new stylesheet: 

1. In the Stylesheets tab, click the New Stylesheet button. 

2. In the Stylesheet dialog: 

a. Enter a Name. 

b. Select to Password Protect if desired and enter a password. 

c. Click OK to create the new stylesheet. 
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To MODIFY a stylesheet’s name and password protection: 

1. In the Stylesheets tab, select the desired stylesheet from the list. 

2. Click the Modify Stylesheet button. 

3. Make your edits in the Stylesheet dialog. 

4. Click OK to apply changes. 

 

To DELETE a stylesheet: 

1. In the Stylesheets tab, select the desired stylesheet from the list. 

2. Click the Delete Stylesheet button. 

3. When prompted, click Yes to confirm the deletion. 

 
Note: You cannot delete the Default Stylesheet from the list. 
 

Stylesheet Styles 
This section covers how to work with stylesheet styles. 
 
To ADD a style: 

1. In the Stylesheets tab, select a stylesheet. 

2. Click the Add Style button. 

3. Select an option from the list: 

a. Add Standard Style: Select a standard style from the list and it will be 
added to the existing stylesheet (at the bottom of all the existing styles). 
Once it’s added, you can then modify it as needed. 
 

b. Add Custom Style: Select this option to add a custom style to the 
stylesheet. 
 

i. In the Add Custom Style dialog that displays, add as many 
attributes as desired for the new custom style. 

ii. Once all the attributes are added in the Add Custom Style dialog, 
click OK to create the new style. It will be added at the bottom of 
the Stylesheet. 

To MODIFY a style: 

1. In the Stylesheets tab, select a stylesheet. 

2. Select a style. 

3. Click the Modify Style button. 

4. In the Modify Style dialog that displays, edit the attributes as needed. 

5. Click OK to save the changes. 
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To MOVE a style up / down in the stylesheet list: 

1. In the Stylesheets tab, select a stylesheet. 

2. Select a style. 

3. Hold down the left and drag the style to its new location. 

4. Let go of the left mouse button to drop it into place. 

 

To DELETE a Style: 

1. In the Stylesheets tab, select a stylesheet. 

2. Select a style. 

3. Click the Delete Style button. 

4. When prompted click Yes to confirm the deletion. 

 
Style Attributes 
This section provides instructions for working with style attributes: 
 
To ADD an attribute to a style: 

1. In the Stylesheet tab, select a stylesheet. 

2. Double click on a style.  

3. In the Modify Style dialog, you will see a list of Attributes already applied. To add 
an attribute, click the Add button 

4. In the Add Attributes dialog that displays, select the desired attribute. 

5. Click OK to add it to the list. 

6. Repeat steps 3-5 to add as many attributes as desired. 

7. Once done, in the Modify Style dialog, click OK to apply the new attribute. 

8. Repeat the steps above to add additional attributes to any Stylesheet style as 
needed. 

 

To MODIFY an attribute: 

1. In the Stylesheets tab, select a stylesheet. 

2. Double click on a style. 

3. In the Modify Style dialog, select an attribute. 

4. Click the Modify button. 

5. In the dialog that displays, make edits as needed. 

6. Click OK to save changes. 

7. Click OK to close the Modify Style dialog. 
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To MOVE an attribute up / down the stylesheet list: 

1. In the Stylesheets tab, select a stylesheet. 

2. Double click on a style. 

3. In the Modify Style dialog, select an attribute. 

4. Click the Up / Down arrow to move the selected attribute Up / Down in the list. 

5. Click OK to close the Modify Style dialog. 

 

To DELETE an attribute: 

1. In the Stylesheets tab, select a stylesheet. 

2. Double click on a style. 

3. In the Modify Style dialog, select an attribute. 

4. Click the Delete button. 

5. Click OK to close the Modify Style dialog. 

 

Applying Styles to the Project 
Stylesheets are applied to new projects, but may also be applied (in whole or in part) to 
an open project. This section provides information on the various ways to do this. 
 

New Projects 
To APPLY a stylesheet to a new project: 

1. In the Create New Project dialog, select a new project type. 

2. Click the Create button. 

3. In the next screen, select the Options tab. 

4. Select a Stylesheet from the list. 

5. Make the remaining selections for the new project and when created, the 
selected stylesheet will be applied. 

 

Existing (Open) Projects 
To APPLY A STYLESHEET to a PROJECT: 

1. In the Stylesheets tab, select the stylesheet. 

2. Click the Apply Stylesheet to Project button. 

3. When prompted, click OK to confirm. 

 

 

 

ViewletBuilder8 Enterprise User Guide Page 91  © 2014 rev. 0626 



 
 
 
To APPLY SELECTED STYLES to a project: 

1. In the Stylesheets tab, select the stylesheet. 

2. Select one or more styles from the stylesheet. Use the SHIFT or CTRL key to 
select adjacent or non-adjacent styles when clicking on them. 

3. Click the Apply Select Styles to Project button. 

4. When prompted, click OK to confirm. 

 

To APPLY STYLESHEET to a SELECTION: 

1. In the Stylesheets tab, select the stylesheet. 

2. Select the slide element. 

3. Click the Apply Stylesheet to Selection button. 

4. When prompted, click Yes to confirm. 

 

To UPDATE A STYLESHEET from a SELECTION: 

5. In the Stylesheets tab, select the stylesheet. 

6. Select the slide element. 

7. Click the Update Stylesheet from Section button. 
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Question Layout Feature 
The Question Layout dialog provides three standard styles to apply to question slides: 
 
 Question Slide: Fill Slide 
 Question Slide: Fit Question 
 Question Slide: Align Choices only 
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If one of these questions slide styles are NOT already listed on the stylesheet: 

1. With the stylesheet selected, click the Add Style button. 

2. Select Add Standard Style and then the desired question slide style from the 
menu. 

3. This will add the question slide style to the bottom of the stylesheet. You can 
select it and drag it to (or near) the top of the list of styles if desired. 

4. Double click the question slide style to open the Question Layout dialog. 

 

Question Stylesheet Commands 
You can access question stylesheet commands from the applicable Context Sensitive 
Toolbar, or right click and select Styles from the shortcut menu. 
 

 
 
Question stylesheet commands include: 

 Apply Stylesheet [name of stylesheet] to this Slide 

 Update Style [name of question slide style] from this Slide 

 Create a new Style for this Slide 

 Select a Different Style for this Slide 

 Remove styling from this Slide 

 

In addition, the question slide styles can be customized to fit your needs. Let’s take a 
look at each. 
 

Question Slide: Fill Slide 
This style lays out the question to fill the entire slide. For this style, the Question 
Container layout sets both the width and the height to ‘Fill Slide’. 
 
To ACCESS the Question Layout dialog: 

1. In the Stylesheets tab, select a stylesheet. 

2. Click the arrow next to the Question Slide: Fill Slide question slide style so that 
it points down to display its associated attributes.  

3. Double click  Question Layout... attribute. The Question Layout: Question Slide: 
Fill Slide dialog displays. 

4. In the Question Container tab: 

a. Select the Enable option to set the layout options for the entire question. 
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b. In the Layout area, make your selections for Alignment, Width and 
Height. 

c. In the Padding area, enter a number for the SIZE for all padding or set 
individual padding by Top, Bottom, Left, and/or Right margins. 

5. In the Question Text tab:  

a. Select the Enable option to set the layout options for the main text of the 
question. 

b. In the Layout area, choose an Alignment option. 

c. In the Wrapping Behavior area, text wrapping options for the main text. 

d. In the Padding area, enter a number for the SIZE for all padding or set 
individual padding by Top, Bottom, Left, and/or Right margins. 

6. In the Choices tab: 

a. Select the Enable option to set the layout options for the question choices 
(radio buttons, check boxes, etc.). 

b. In the Layout area, choose alignment, row indent/spacing, order, and 
column indent/spacing options. 

c. In the Wrapping Behavior for Labels area, select wrapping options for text 
labels. 

d. In the Text Field / ComboBox Width area, select width options for the text 
field / combobox. 

e. In the Padding area, enter a number for the SIZE for all padding or set 
individual padding by Top, Bottom, Left, and/or Right margins. 

7. In the Responses tab: 

a. Select the Enable option to set the layout options for the Correct, 
Incomplete and Incorrect response messages (for scored questions). 

b. In the Layout area, set the alignment and arrangement; enter a number 
for the space between feedback responses. 

c. In the Wrapping Behavior area, text wrapping options. 

d. In the Padding area, enter a number for the SIZE for all padding or set 
individual padding by Top, Bottom, Left, and/or Right margins. 

8. In the Buttons tab: 

a. Select the Enable option to set the layout options for the submit button for 
the question. 

b. In the Layout area, choose the alignment and enter a number for button 
spacing. 

c. In the Padding area, enter a number for the SIZE for all padding or set 
individual padding by Top, Bottom, Left, and/or Right margins. 
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9. At the bottom of the Question Layout: Question Slide: Fill Slide dialog: 

a. Optional: Use the navigation buttons to navigate to a specific slide to 
apply the question slide style to. 

b. Choose where to apply the style: Stylesheet Only, Current Slide, or All 
slides with this style. 

10. Click OK to save/apply. 

 

Question Slide: Fit Question 
This style lays out the question compactly in the center of the slide. For this style, the 
Question Container layout sets the alignment to ‘Center’ and both the width and the 
height are set to ‘Fit Question’. 
 
To ACCESS the Question Layout dialog: 

1. In the Stylesheets tab, select a stylesheet. 

2. Click the arrow next to the Question Slide: Fit Question question slide style so 
that it points down to display its associated attributes.  

3. Double click  Question Layout... attribute. The Question Layout: Question Slide: 
Fit Question dialog displays. 

4. In the Question Container tab: 

a. Select the Enable option to set the layout options for the entire question. 

b. In the Layout area, make your selections for Alignment, Width and 
Height. 

c. In the Padding area, enter a number for the SIZE for all padding or set 
individual padding by Top, Bottom, Left, and/or Right margins. 

5. In the Question Text tab:  

a. Select the Enable option to set the layout options for the main text of the 
question. 

b. In the Layout area, choose an Alignment option. 

c. In the Wrapping Behavior area, text wrapping options for the main text. 

d. In the Padding area, enter a number for the SIZE for all padding or set 
individual padding by Top, Bottom, Left, and/or Right margins. 

6. In the Choices tab: 

a. Select the Enable option to set the layout options for the question choices 
(radio buttons, check boxes, etc.). 

b. In the Layout area, choose alignment, row indent/spacing, order, and 
column indent/spacing options. 

c. In the Wrapping Behavior for Labels area, select wrapping options for text 
labels. 
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d. In the Text Field / ComboBox Width area, select width options for the text 
field / combobox. 

e. In the Padding area, enter a number for the SIZE for all padding or set 
individual padding by Top, Bottom, Left, and/or Right margins. 

7. In the Responses tab: 

a. Select the Enable option to set the layout options for the Correct, 
Incomplete and Incorrect response messages (for scored questions). 

b. In the Layout area, set the alignment and arrangement; enter a number 
for the space between feedback responses. 

c. In the Wrapping Behavior area, text wrapping options. 

d. In the Padding area, enter a number for the SIZE for all padding or set 
individual padding by Top, Bottom, Left, and/or Right margins. 

8. In the Buttons tab: 

a. Select the Enable option to set the layout options for the submit button for 
the question. 

b. In the Layout area, choose the alignment and enter a number for button 
spacing. 

c. In the Padding area, enter a number for the SIZE for all padding or set 
individual padding by Top, Bottom, Left, and/or Right margins. 

9. At the bottom of the Question Layout: Question Slide: Fit Question dialog: 

d. Optional: Use the navigation buttons to navigate to a specific slide to 
apply the question slide style to. 

e. Choose where to apply the style: Stylesheet Only, Current Slide, or All 
slides with this style. 

10. Click OK to save/apply. 

 

Question Slide: Align Choices Only 
This layout aligns question choices only. Only the Choices tab is enabled. 
 
To ACCESS the Question Layout dialog: 

1. In the Stylesheets tab, select a stylesheet. 

2. Click the arrow next to the Question Slide: Align Choices Only question slide 
style so that it points down to display its associated attributes.  

3. Double click  Question Layout... attribute. The Question Layout: Question Slide: 
Align Choices Only dialog displays. 

a. In the Question Container tab, deselect the Enable option to disable the 
Layout and Padding options for the entire question. 

b. In the Question Text tab, deselect the Enable option to disable Layout, 
Wrapping Behavior and Padding options for the main text of the question. 
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c. In the Choices tab: 

i. Select the Enable option to set the layout options for the question 
choices (radio buttons, check boxes, etc.). 

ii. In the Layout area, choose alignment, row indent/spacing, order, 
and column indent/spacing options. 

iii. In the Wrapping Behavior for Labels area, select wrapping options 
for text labels. 

iv. In the Text Field / ComboBox Width area, select width options for 
the text field / combobox. 

v. In the Padding area, enter a number for the SIZE for all padding or 
set individual padding by Top, Bottom, Left, and/or Right 
margins. 

b. In the Responses tab, deselect the Enable option to disable the layout 
options for the Correct, Incomplete and Incorrect response messages (for 
scored questions). 

c. In the Buttons tab, deselect the Enable option to disable the layout 
options for the submit button for the question. 

4. At the bottom of the Question Layout: Question Slide: Align Choices Only dialog: 

a. Optional: Use the navigation buttons to navigate to a specific slide to 
apply the question slide style to. 

b. Choose where to apply the style: Stylesheet Only, Current Slide, or All 
slides with this style. 

5. Click OK to save/apply. 

 
Note: All attributes of a style are applied simultaneously so if you wish to affect only the Question 
layout and not the background, you should first either delete the background attribute from the 
style or make it match your desired background. 
 
Note: All three of the options (Stylesheet Only, Current Slide, or All slides with this style) update 
the stylesheet. Current slide and All Slides also applies the settings to slides in the project. 
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BROWSER TAB 
The Browser tab lets you organize, access and manage the resources available to on 
your system while you author your Viewlets. You can open projects, drag and drop 
images and movies, add publishing locations, delete files or folders, and view statistics 
of your Viewlets published on ViewletCentral. This section provides instructions for 
working with the Browser tab. 
 

 
 
To ACCESS the Browser tab: 

1. Select View > Tabs > Browser from the Menu bar. 

2. The Browser tab displays. Click on it to access its features. 

 

To DRAG an image directly on to a slide: 

1. In the Browser tab, select an image file from the list. 

2. Hold down the left mouse button and drag it over the slide. 

3. Let go of the left mouse button to drop it on to the slide. 
 
 
To ADD a publishing target: 

1. In the Browser tab, click the Add button. 

2. Select a publishing location from the list that displays. 

3. Follow the instructions in the dialogs that display (based on your choice). You 
can refer to the chapter on Publishing a Viewlet for more information on 
publishing locations. 
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To REMOVE files or folders from the list: 

1. In the Browser tab, select the desired file or folder. 

2. Click the Delete button. 

3. When prompted, click Yes to confirm the deletion. 
 
 
To NAVIGATE through files and folders in the list: 

1. In the Browser tab, select the desired file or folder to highlight it. 

2. Click the Up One Level button to move up to the next level in the list. 

3. If a folder is selected and it contains a plus  symbol to the left of it, click this 
plus symbol to expand the list of files and additional folders contained in the 
folder. 

4. If a folder contains a minus  symbol to the left of it, click this minus symbol to 
collapse the files and folders contained in the folder. 

5. Click on a desired file or folder at any time to quickly navigate through the list. 
 
 
To REFRESH a selected folder in list: 

1. In the Browser tab, select the desired folder in the list. 

2. Click the Refresh the current folder button to refresh the list of files and folder 
contained in the selected folder. 

 
 
To select a LIST VIEW: 

1. In the Browser tab, click the Views button. 

2. The available view selections display. Select the: 

a. Icon View: Displays an icon next to the file and folder (in the lower pane 
of the Browser tab). 

b. Details View: Displays the file or folder name, type, number of slides, last 
modification date and file size. 
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TIMELINE TAB 
The Timeline tab is where you manage the start and duration times of all elements on 
each slide in your project. In addition to working with objects directly on a slide, the 
timeline provides more enhancement options for your project as you hide, view, modify, 
group, sort and lock / unlock layers in the Timeline. But, that’s not all.  Using the 
timeline’s playhead tool you can scrub the timeline to view your project’s animations. 
You can also preview your project as it plays back, noting where actions occur along the 
timeline, allowing you to “tweak” any part of the project exactly where it needs it. 
 

  
 
To ACCESS the Timeline tab: 

1. Select View > Tabs > Timeline from the Menu bar. 

2. Click on the Timeline tab to access its features. 

 

Time Select Mode 
Use the ‘Time Select Mode’ to add/edit slide elements at any frame or time interval along 
the timeline. Then, while in Time Select Mode, scrub the timeline by dragging the 
playhead to preview animation results. 
 
To switch to Time Select Mode: 

2. Click on the desired time interval (frame) along the timeline to display the 
playhead. 

3. Once the playhead displays, you can: 

a. See exactly what is occurring at that specific interval on the slide. 

b. Move the playhead to any desired frame to insert a slide element. 

c. Drag the playhead to preview your project while you ‘scrub the timeline’. 

 

Layers 
The left side of the timeline displays all the objects on the slide. Each object exists in a 
layer. These layers are “stacked” with “higher object layers” overlapping objects in lower 
layers. You can hide / unhide layers without deleting them from the project. You can lock 
layers to prevent them from being editing. You can also change the starting / ending 
points of objects as they display along the timeline as well as their entire duration. You 
can work on single or multiple layers and group layers into one as needed. 
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To EXPAND / COLLAPSE layers: 

1. In the Timeline tab, click the right arrow next to the slide title. 

2. The arrow now points down, indicating expanded layers. 

3. To collapse the layers, click the down arrow again so it points right. 
 

 
To SELECT a SINGLE layer: 

1. In the Timeline tab, expand the layers if needed. 

2. Click on the desired layer to select it. 
 
 
To SELECT MULTIPLE layers: 

1. In the Timeline tab, for: 

a. Adjacent layers: 

i. Click on the first layer to highlight it.  

ii. Hold down the Shift key. 

iii. Click on the last layer in the series of adjacent layers. This will 
select the first and last layers as well as all the layers in between 
them. 

b. For non-adjacent layers: 

i. Click on a layer to highlight it. 

ii. Hold down the Ctrl key while clicking on other layers to select 
them. 
 

Note: You can select multiple layers to temporarily group them together to ‘batch process’ tasks 
that can applied to all the selected layers simultaneously. 
 
 
To REARRANGE a SINGLE layer: 

1. In the Timeline tab, select a layer. 

2. Hold down the left mouse button and drag it up or down the stack of layers. 

3. Let go of the left mouse button to drop it into place. 
 
 
To REARRANGE MULTIPLE layers: 

1. In the Timeline tab, select the desired layers using the Shift or Ctrl keys. 

2. Hold down the left mouse button and drag the layers up or down the stack of 
layers. 

3. Let go of the left mouse button to drop them into place. 
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To HIDE / UNHIDE a layer: 

1. In the Timeline tab to: 

a. Hide a layer, click the Visible button to change the open ‘eye’ icon to a 
closed ‘eye’. 

b. Unhide a layer, click the Visible button to change the closed ‘eye’ icon to 
an open ‘eye’. 

 
 
To LOCK / UNLOCK a layer: 

1. In the Timeline tab to: 

a. Lock a layer, click the Unlocked button to change the icon to a ‘closed 
padlock’. 

b. Unlock a layer, click the Locked button to change the icon to an ‘open 
padlock’. 

 
To MOVE an OBJECT to a new frame: 

1. In the Timeline tab, point your cursor over the object’s rectangle (which indicates 
its position and duration along the frame in the timeline). 

2. Hold down your left mouse button to select the object’s rectangle and drag. 

3. Let go of the left mouse button to drop the object into its new location in the 
timeline. 
 

 
To INCREASE / DECREASE an OBECT’S DURATION: 

1. In the Timeline tab, point your cursor over the left or right edge of the object’s 
rectangle. 

2. When the cursor changes to a double arrow, hold down the left mouse button 
and drag to change the size (duration) of the rectangle. 

3. Once the rectangle indicates the desired duration (by its new size) on the 
timeline, let go of the left mouse button. 

4. If a Timing Rule dialog displays, read the information and click OK to complete 
the operation. 
 

To DELETE a layer: 

1. In the Timeline tab, select a layer. 

2. Press the Delete key on your keyboard. 

 
Note: If you accidentally delete a later, press the ‘Undo’ button (or Ctrl+Z) to undo the action if it 
was your last action to restore the layer. 
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Splitting Slides 
There may be times when you have a slide that you need to break a part into two slides. 
This is easily done with the “Split Slide” feature. Most commonly used to split video 
slides, this feature is also available for non-video slides too.  
 
Here’s some information to get you started using this feature: 
 

1. Select the slide you want to split. 

2. In the Timeline tab, click on an interval (tick mark) along the timeline (for that 
slide) where you want to “split” the slide. 

3. If prompted, click “Yes” to complete the split operation. 

4. Repeat the steps above as needed for each split. 

 

Merging Slides 
You can merge one or more sequential slides in just a few clicks. Here’s how:  
 

1. Select the first slide by selecting its thumbnail. 

2. Hold down the Shift key and select the last slide in the sequence of slides you 
want to merge. (You can merge one, two or more slides as long as they are in 
sequential order.) 

3. Click the Merge Slides button. 
Note: You will be warned if you try to merge incompatible slides.  

4. If prompted, click “Yes” to complete the merge operation. 

5. Repeat the steps above as needed for each merge. 

 

Timing Links 
Timing Links are links that connect two or more objects in the timeline. The benefit of 
this feature is that as you edit an object’s timing in the timeline, linked objects update. 
 

 
 
To UPDATE timing links: 

1. Open a project. 

2. Select Project > Project Properties from the Menu bar. 

3. The Project Properties dialog displays. Select Timing from the list. 

4. In the Maintain Slide Timing area, select the Enable option. 
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To ADD a timing links: 

1. In the Timeline tab, select the first object. 

2. Hold down the Ctrl key and click to select the second object in the timeline. The 
order in which the objects are selected is the order in which the timing links will 
be applied. 

3. Click the Add Timing Links button on the timeline’s toolbar. 

4. The Timing Links dialog displays. Select a Link Type from the list: 

a. End to Start: Links end of first object to front of second object. 

b. Start to End: Links front of first object to end of second object. 

c. Start to Start: Links front of first object to front of second object. 

d. End to End: Links end of first object to end of second object. 
 
 
To REMOVE a timing link: 

1. In the Timeline tab, select an object. 

2. Hold down the Ctrl key and select the second ‘linked’ object.  

3. Click the Remove Timing Links button. 
 
 
To REMOVE ALL timing links: 

1. In the Timeline tab, select all the objects on the slide. 

2. Click the Remove Timing Links button. 

 
 

Frames 
The Timeline tab contains a “guide bar” known as a Frames Reference Guide. Along 
this guide bar, there are small “sections” known as frames. Each frame is divided by 
tickmarks into 1/10 of second intervals. The main sections of the Timeline are divided 
into 1 second intervals.  Use this guide bar to position objects in the Timeline to 
determine when each will display and for how long when the project is played back. 
 
On non-Video slides, the Background Layer contains special “key frames” where a 
background frame is “painted” over the entire slide. This, in combination with the 
Background Layer’s “non-key frames” (which paint over a smaller, specific area on top of 
the key frame), can produce some dynamic and “attention-getting” effects. 
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To SELECT a frame: 

1. In the Timeline tab, select the desired frame so that a playhead appears. 

2. All objects that exist at that interval display on the slide. 

3. Manually drag the playhead along the timeline (across frames) to ‘scrub the 
timeline’ previewing the project frame-by-frame. 

 
Timeline Features and Tools 
The Timeline tab contains some status information and tools right above the frames 
area, which are useful when working in the Timeline. These include: 
 

 
 

 Slide Numbers: Indicates current slide and number of slides in the project. 

 Clock: Indicates the duration of current slide in relation to overall project 
duration. 

 Slide Duration of Current Slide: Indicates the full playtime for the current slide 
displayed in the Timeline, which can be increased / decreased by clicking the 
up / down arrows. 

 Zoom: Signifies the current zoom of the Timeline. Use the up / down arrows to 
increase / decrease the zoom level of the Timeline. 

 Views: There are two different views that can be used while working in the 
Timeline: All Slides or Current Slide. When the All Slides button displays, the 
Timeline view is “current slide”. When the Current Slide button displays, the 
view is “all slides”. Click this button to toggle between these views. 

 Split Slide: Used to split a slide at the point where the playhead resides. 

 Maintain Slide Timing: When ‘enabled’ adds timing links automatically to slide 
objects; when disabled it will not automatically add timing links to slide objects. 

 Add Timing Links: Adds timing links between two selected slide objects. 

 Remove Timing Links: Removes timing links between two selected slide 
objects. 

 Player Buttons: The “VCR style” buttons are used to navigate to the first slide, 
previous slide, next slide and last slide of the project.  

 Preview Menu: Use this list to select from one of four project preview options. 

 Slide Titles: Along the top of the Frames Reference Guide are boxes containing 
the titles for each of the slides in the project. By default, the titles are the slide 
number. By dragging the edge of the “title box” you can increase / decrease the 
duration of the slide in the Timeline. 
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Timing Commands & Rules 
Understanding how ViewletBuilder8 Enterprise handles the “timing aspects” of objects is 
essential to being able to effectively work in the timeline or while setting the timing of 
objects through the use of dialog dialogs. Two important timing topics each author 
should review are ‘Timing Commands’ and ‘Timing Rules’. These are covered in the 
following sections. 

Timing Commands 
Timing commands can be applied to a single or multiple objects on a slide. An object’s 
timing will determine when it will display on a slide (or on the timeline), how long it will 
remain displayed on a slide (or on the Timeline) and, if multiple objects display on the 
same slide, what timing command elements they may have in common. 
 
For the most part, an object’s timing can be adjusted in two places, in its Properties 
dialog and while working directly in the timeline. 
 
To ADJUST a message object’s TIMING in the TIMELINE: 

1. In the Timeline tab, point your cursor over the left or right edge of the object’s 
rectangle in the timeline. 

2. When the cursor changes to a double arrow  hold down the left mouse button 
and drag to change the size (duration) of the rectangle. 

3. Once the rectangle indicates the desired duration (by its new size) on the 
timeline, let go of the left mouse button. 

4. If a Timing Rule dialog displays, read the information and click OK to complete 
the operation. 
 

To ADJUST an object’s TIMING in the PROPERTIES dialog: 

1. Click the desired object (from either the slide or in the timeline) to select it. 

2. Click the object’s Properties button from the Context Sensitive Toolbar. 

3. The object’s Properties dialog displays. In the Timing area, there are options for 
setting the object’s timing (there’s an additional selection for message objects). 
These include: 

a. Reading Speed: Used (by default) for notes, balloons, and text boxes to 
display the message object from its set Start Time until the automatically 
calculated reading speed is reached. 

b. Manual Timing:  Used to manually set the Start Time and Duration (in 
seconds) for the object.  

c. Until End of Slide: Used to display the object from its set Start Time (in 
seconds) until the end of the slide’s “play” time. 

4. Select a Timing option for the object from the list. 

5. Enter a number for the Start Time (in seconds). This will be the amount of time 
the object will be delayed before displaying on the slide. 
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6. For Manual Timing, enter a number for the Duration. This is the amount of time 
the object will display. 

7. Click OK to apply the timing settings and to close the object’s Properties dialog. 
 
 
To SYNCHRONIZE timing for multiple objects: 

1. Select the objects you want to synchronize the time of by clicking on each one 
while simultaneously holding down the Ctrl key. The first object selected will be 
the ‘key object’ from which all times are calculated. 

2. The Synchronization Context Sensitive Toolbar displays. Click one of the buttons 
to synchronize the selected objects timing: 
 

 
 

a. Same Start Time: Set the same start time for selected objects. 

b. Same End Time: Sets the same end time for selected objects. 

c. Same Start and End Time: Sets the same start and end time for all 
objects based on the key object. 

d. Display Until Last End Time: Sets the end time for all objects to object’s 
whose end time is the last on the slide (of those selected). 

e. Sequence Times: Sets the objects to display sequentially based on the 
selection order. 

 
 
To ADJUST timing for a DISPLAY OBJECT action: 

1. Select the desired object (note, balloon, text box, shape, image, etc.). 

2. Click the Events button on the Context Sensitive Toolbar. 

3. The object’s Events widow displays. Select one of the three tabs: 

a. On Click: Set actions to occur when user clicks the object. 

b. On Rollover: Set actions to occur when user rolls mouse over object. 

c. On Rollout: Set actions to occur when user rolls mouse off object. 

4. Click the Add button. 

5. The Action dialog displays. Select Display Object from the Action Type list. 

6. Select an object from the Select an object on the slide to display list. 

7. In the Duration area, select a timing command. 

8. Click OK to close the Action dialog. 

9. Click OK to close the object’s Events dialog. 
 
 

ViewletBuilder8 Enterprise User Guide Page 108  © 2014 rev. 0626 



 
 
 
Timing Rules 
Each object has a Timing Rule associated with it. Timing Rules automatically control 
how the timing for that object associated with it is calculated. Timing Rules differ from 
“timing synchronization commands” in that synchronization commands make a one-time 
adjustment whereas Timing Rules are applied globally. 
To understand Timing Rules better, let’s take a look at an example. A simple timing rule 
is “Reading Speed”, which insures that the duration of a message object is calculated 
from the number of words or characters in a message object and the reading speed set 
in the Project Properties dialog (Project > Project Properties > Timing) . This rule is 
automatically and globally applied to all message objects, so that each note, balloon and 
text box displays only as long as calculated reading speed allows.  
 
To help standardize object timing, there are several Timing Rules available (each 
described in the previous “Timing Commands” section of this chapter): 
 
 Manual: An object’s timing is calculated manually, meaning the user has full 

control over the start time and duration. 
 

 Reading Speed: Applies to message objects (notes, balloons, text boxes), the 
duration is calculated based on the reading speed set in the Project Properties 
dialog and the number of words or characters in the message object. The start 
time for the message object is adjustable without affecting this rule. 
 

 Until End of Slide: An object displays from a user-defined start time until the 
end of the slide. The start time is adjustable without affecting this rule. 
 

 Display Object Action: Used for objects displayed due to an event which 
triggers the “Display Object” action. You can use any “available” Timing Rule for 
the object that is to be displayed. 

 
Each time you attempt to change an object’s timing, a Timing Rule Change dialog will 
display if you are breaking the rules for the Timing Rule currently associated with the 
object. If this happens, read the information in the dialog carefully before proceeding. 

 
Video Layer Editing 
When you create a new Video Capture Project or insert new Video slides, your captures 
will be converted to slides containing video layers on the timeline. When the video slide 
thumbnail is selected, it displays in the Slide Editing area. Like other slides, you can add 
slide elements the video such as balloons, notes, highlights, etc. directly while working 
on the slide. And, like other slides, you determine where the slide objects will display 
(and for how long) by working with the timeline. 
 
So, for the most part, editing a video slide is the same as any other slide. However, there 
are some exceptions to the rule while working with the timeline. Let’s take a look at 
these. 
 
When a new video capture slide is created, it is made up of layers, which might include 
(at a minimum): 
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 Cursor Path 
 Video 
 Sound Layer 

 

Cursor Path Layer (Video Slide) 
Along the timeline, the Cursor Path is synched with the video layer. For this reason, you 
will NOT be able to edit all of the elements that make up the cursor animation. You can, 
however: 
 
 Change the cursor’s style 
 Add a Shadow to cursors 
 Change the cursor path from straight to curved and visa versa 
 Lock points along the cursor layer 
 Move the position of the cursors on the slide at any interval (selected frame) 

along the timeline 
 Drag the position of any transitional cursor (indicated by blue circle) along the 

cursor path 
 Remove the cursor path entirely 
 Hide / display the layer 
 Lock the layer to prevent it from being edited 

 
You will not be able to: 
 Add new cursors 
 Move the position of the cursors along the timeline 
 Change the duration of the cursors along the timeline 
 Add more points along the cursor path 
 Edit (add/remove) cursor click sounds 

 

Video Layer (Video Slide) 
Along the timeline, the video layer is synched with the Cursor Path layer, if cursor 
animation was captured during the recording session. Therefore, you will not be able to 
edit the “background frames” (images) that occur along the timeline on the video layer. 
Nor will you be able to “move” the position of frames along the video layer. You can, 
however, add various slide elements (such as notes, balloons, etc.) at various frames 
along the timeline on this slide and hide and lock the layer as needed. You can also split 
video slides using the applicable buttons on the timeline. 
 

Sound Layer (Video Slide) 
A Sound Layer is created if sound was enabled during capture and added to the 
project’s video slide. Initially, this layer is in synch with the video layer, but the sound 
layer can be edited. For example, you can change where the sound will start playing 
along the timeline by moving it. You can also insert recorded or imported sound clips as 
additional layers. If you have multiple Sound layers, any sections that overlap (with the 
various Sound layers) will result in multiple sounds playing back (at the overlapping 
frames) at the same time. And, of course, the Sound layer may also be hidden or locked 
as needed. 
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SLIDE NOTES TAB 
The Slide Notes tab displays, by default, below the Slide Editing area. In this tab, you 
can add presenter notes, which can be printed out for you and your audience. The Slide 
Notes tab can also be used as a collaboration tool by adding editing notes (not part of 
the actual slide) when working with a team of authors on the same project. These notes 
can be displayed or hidden inside ViewletBuilder8 Enterprise (and printed) as needed.  
 

 
 
To DISPLAY the Slide Notes tab: 

1. Select View > Tabs > Slide Notes from the Menu bar. 

2. Click the Slide Notes tab to access its features. 
 

 
To ADD TEXT: 

1. Select a slide and then click on the Slide Notes tab. 

2. Click inside the text field to add slide notes text. 

 

To Print slide notes: 

1. Select File > Page Layout from the Menu bar. 

2. The Page Layout dialog displays. In Slide View Layout in the Options area, select 
the Slide Notes option. 

3. Click OK to save this option. Each time you print slides using the Slide View 
Layout, the slide notes will be printed below the image of each slide. 

 
Note: Use these same steps if modifying the Page Layout > Slide View Layout options when 
printing directly from the Publishing dialog. 
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MASTERS TAB 
In the Masters tab, you can create Master Slide templates that can be applied to one or 
more slides within your project. Updates made to master slides will automatically be 
updated to all slides to which the associated master slides are applied. 
 

 
 
 
To ACCESS the Masters tab: 

1. Select View > Tabs > Masters from the Menu bar. 

2. Click the Master tab to access its features. 

 
 
To CREATE a master slide: 

1. In the Masters tab, click the Insert Master Slide button to create a new master 
slide. 

2. Click the thumbnail representing the master slide to load it into the Slide Editing 
area.  

3. Edit the master slide as desired. 

4. Repeat these steps for each new master slide. 
 
Note: The background color on the master slide will NOT be applied when the master slide is 
applied to question slides or slides on the Main Timeline. 
 
 
To MODIFY a master slide: 

1. In the Masters tab, select the desired master slide thumbnail. 

2. Edit the master slide as needed. 
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To ZOOM IN / ZOOM OUT on master slide thumbnails: 

1. In the Masters tab: 

a. Click the Zoom In button to zoom in on the masters’ thumbnails. 

b. Click the Zoom Out button to zoom out on the masters’ thumbnails. 

 

To REFRESH a single master slide thumbnail or all thumbnails: 

1. In the Masters tab: 

a. To refresh the view of a specific thumbnail:  

i. Select the desired thumbnail. 

ii. Click the Refresh Thumbnail button. 

b. To refresh the view of all master slide thumbnails: 

i. Click the Refresh All Thumbnails button. 
 
 
To NAVIGATE between master slides: 

1. In the Masters tab, click on a master slide thumbnail to make it the active slide in 
the Slide Editing pane. 

2. To switch to another master slide, click its thumbnail in the list. 

3. To progress through master slides one by one, use the up / down / right / left 
arrow keys on your keyboard. 

 
 
To REORDER master slide thumbnails: 

1. In the Masters tab, select one or more master slide thumbnails. 

2. Hold down the left mouse button and drag the slides to the desired location in the 
list. 

3. Let go of the left mouse button to drop into place. 

 
 
To CUT / COPY and PASTE entire master slides or master slide elements: 

1. Select the desired master slide thumbnails or slide elements. 

2. Click the applicable Cut / Copy button. 

3. Click the Paste button to paste the cut / copied selections. 

 

To DUPLICATE a master slide: 

1. In the Masters tab, select the desired master slide thumbnail. 

2. Select Edit > Duplicate Slide from the Menu bar. A duplicate of the selected 
master slide will be inserted directly after its original in the thumbnails list. 
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To DELETE a master slide or slide element: 

1. Select the desired master slide thumbnail or slide element. 

2. Click the DELETE button. 

3. When prompted, click Yes to confirm the deletion. 
 
 
To APPLY a master slide: 

1. In the Masters tab, create your master slide. 

2. Select one or more slides from the Main Timeline or from within a Question Bank. 

3. Click the Assign Master Slide button from the Context Sensitive Toolbar. 

4. Select the master slide option you want to apply to the slide or slides. 

 

To CHANGE the master slide APPLIED: 

1. Select the desired slides from the Main Timeline or from within a Question Bank. 

2. Click the Assign Master Slide button from the Context Sensitive Toolbar. 

3. Select the new master slide option you want to apply to the slide or slides. 

 

 

QUESTION BANKS TAB 
In the Question Banks tab, you can create different banks to hold either quiz (scored) or 
survey (not scored) question slides. Used in conjunction with Random Question type 
slides residing on the Main Timeline, these question banks are used to RANDOMLY pull 
a specified number of question slides from a specific bank as determined by the options 
set on the associated Random Question slide. 
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To ACCESS the Question Banks tab: 

1. Select View > Tabs > Question Banks from the Menu bar. 

2. Click the Question Banks tab to access its features. 

 

Creating, Modifying, Deleting Question Banks 
To CREATE a question bank: 

1. In the Question Banks tab, click Add Question Bank button. 

2. In the Add Question Bank dialog that displays, there are two tabs: 

a. General tab:  

i. Enter a title for the Question Bank in the Name field. 

ii. In the Scoring Mode area, select whether questions in this bank 
will all be treated as Quiz (scored) or Survey (not scored). 

d. Scoring tab: The selections available in this tab are determined by the 
Scoring Mode selection made in the General tab. 
 
      Quiz (Scoring Mode) 

i. Select Override Settings in Project Properties to use the 
settings you configure in this dialog. 

ii. In the Points area, enter a number for the total points to be used 
for each quiz question in the bank. 

iii. In the Attempts area, enter a number for the total number of 
allowed attempts for each quiz question in the bank. 

iv. In the Reanswer area, select/deselect the Question can be 
reanswered on backwards navigation option. 

v. In the Time area, to enable a time limit for each quiz question, 
select the Enable a time limit for the question and then enter a 
number for Hours, Minutes and Seconds. 

Survey (Scoring Mode) 

i. Select Override Settings in Project Properties to use the 
settings you configure in this dialog. 

ii. In the Reanswer area, select/deselect the Question can be 
reanswered on backwards navigation option. 

iii. In the Time area, to enable a time limit for each survey question, 
select the Enable a time limit for the question and then enter a 
number for Hours, Minutes and Seconds. 

4. Click OK to create the question bank. 

5. Repeat these steps as needed for each new question bank. As question banks 
are created they are added to the Question Banks list. 
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To MODIFY a question bank: 

1. In the Question Banks tab, select a Question Bank from the list. 

2. Click the Modify Question Bank button. 

3. In the dialog that displays, make your edits as needed in the General and 
Scoring tabs. 

4. Click OK to apply the changes. 

 

To DELETE a question bank: 

1. In the Question Banks tab, select a Question Bank from the list. 

2. Click the Delete button. 

3. Click Yes to confirm the deletion. 

 
Note: If you have any Random Question slide associated with the Question Bank, you will not be 
allowed to delete the bank. 
 

Adding Questions to Banks 
Once you’ve created one or more question banks, you can start inserting new question 
slides (with the exception of a Random Question slide type) into selected banks. 
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To ADD a new question to a bank: 

1. In the Question Banks tab, select the desired question bank. If there are no 
question banks available, you must create at least one bank using the 
instructions outlined in the previous section. 

2. Select the desired Question Bank from the list. 

3. Click the Add Question button. The Insert Questions dialog displays with two 
tabs: 

a. Questions tab: 

i. Click the Add Question button.  

ii. In the Question dialog that displays: 

1. Select a Question Type from the list. As noted previously, 
you can NOT add a Random Question type in a bank. 

2. Enter a question or statement in the Question field. This 
will be used as the question text. 

3. The Scoring Mode is determined by the question bank, so 
options here are grayed out. 

4. Select a Style to apply to the question slide. 

5. Click OK to save selections and return to the previous 
dialog. 

6. Repeat these steps for additional questions. 

b. Options tab: 

i. Select a Stylesheet from the list to apply to the question slides. 

ii. Optional: Click the right arrow to expand the dialog to preview the 
stylesheet or click the left arrow to collapse the preview area. 

4. Click OK to close the dialog. All new question slides will be inserted into the 
selected question bank ready for further editing. 

 

To MOVE or COPY a question slide to a bank (from the Main Timeline or other banks): 

1. To DRAG / DROP a question slide from the Main Timeline into a bank: 

a. Select the desired question bank. 

b. Select the desired slide thumbnails from the Slides tab. 

c. Hold down the left mouse button and drag them over the Question Banks 
tab. 

d. Let go of the left mouse button to drop the selections into the selected 
question bank. 
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2. To MOVE a slide from one question bank to another bank: 

a. Select the initial question bank. 

b. Select one or more question bank slides. 

c. Press Ctrl+X (to cut) the question slides from the bank. 

d. Select the destination question bank. 

e. Press Ctrl+V (to paste) the question slides into the selected bank. 

3. To COPY a slide from the Main Timeline or another question bank: 

a. Main Timeline: 

i. Select one or more slide thumbnails from the Main Timeline. 

ii. Press Ctrl+C (to copy) the question slides. 

iii. Select the destination question bank. 

iv. Press Ctrl+V (to paste) the copied slides into the bank. 

b. Bank to Bank: 

i. Select the initial question bank. 

ii. Select one or more question slide thumbnails. 

iii. Press Ctrl+C (to copy) the question slides. 

iv. Select the destination question bank. 

v. Press Ctrl+V (to paste) the copied slides into the bank. 

 

Modifying Question Slides in Question Banks 
There are several ways in which you can modify question slides within a bank. This 
section highlights some of these scenarios. 

When Adding New Questions to a Bank 
1. In the Question Banks tab, select a question bank. 

2. Click the Add New Question button. The Add Questions dialog displays. 

3. In the Questions tab: 

a. Click the Add Question button to add new questions as described in the 
previous section then click OK to return to the previous dialog. 

b. To MODIFY a question: 

i. Select a question from the list. 

ii. Click the Modify button. 

iii. In the Question dialog, make your edits as needed. 

iv. Click OK to save changes and return to the previous dialog. 
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c. To MOVE a question up / down in the list: 

i. Select a question from the list. 

ii. Click the Up / Down arrow to move it Up / Down in the list. 

d. To DELETE a question: 

i. Select a question from the list. 

ii. Click the Delete button. 

4. Once all your edits are made, click OK to close the dialog. 

 

Questions Within a Bank 
You can easily edit question bank slides similar to how you would when working on 
project slides along the Main Timeline or master slides.  
 
To MODIFY question slides within a bank: 

1. In the Question Banks tab, select the question slide thumbnail to load it in the 
Slide Editing area. 

2. Make your edits as needed directly to the slide in the Slide Editing area. 

3. Select File > Save from the Menu bar to save your changes. 

 

Question Slide Thumbnails Within a Bank 
This section covers some additional information when working with question slide 
thumbnails in the Question Banks tab. 
 
To SELECT a question bank: 

1. In the Question Banks tab, click the down arrow to display the selections in the 
Question Banks list. 

2. Select a question bank from this list. 

 
To ZOOM IN / ZOOM OUT on question slide thumbnails: 

1. In the Question Banks tab: 

a. Click the Zoom In button to zoom in on the thumbnails. 

b. Click the Zoom Out button to zoom out on the thumbnails. 
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To REFRESH a single question slide thumbnail or all thumbnails: 

1. In the Question Banks tab: 

a. To refresh the view of a specific thumbnail:  

ii. Select the desired thumbnail. 

iii. Click the Refresh Thumbnail button. 

b. To refresh the view of all thumbnails: 

iv. Click the Refresh All Thumbnails button. 
 
 
To NAVIGATE between question slides: 

1. In the Question Banks tab, click on a thumbnail to make it the active slide in the 
Slide Editing pane. 

2. To switch to another question slide, click its thumbnail in the list. 

3. To progress through question slides one by one, use the up / down / right / left 
arrow keys on your keyboard. 

 
 
To REORDER question slide thumbnails: 

1. In the Question Banks tab, select one or more question slide thumbnails. 

2. Hold down the left mouse button and drag the slides to the desired location in the 
list. 

3. Let go of the left mouse button to drop into place. 

 

To DELETE a question slide: 

1. Select the desired question slide thumbnail. 

2. Click the DELETE button. 

3. When prompted, click Yes to confirm the deletion. 
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OUTPUT TAB 
The Output tab contains a record of information that can help Qarbon find and correct 
ViewletBuilder8 Enterprise programming errors. The information that is recorded in this 
tab is determined by preferences set up for ViewletBuilder8 Enterprise. 
 

 
 
 
To ACCESS the Output tab: 

1. Select View > Tabs > Output from the Menu bar. 

2. Click the Output tab to access its features. 
 
 
To LOCATE THE LOG FILE containing the information also displayed in the Output tab: 

1. Select Edit > Preferences from the Menu bar. 

2. In the Preferences dialog, select the Logging tab. 

3. In the Log File area, the path to where the log file is saved displays in the File 
field. If you can’t see the entire path to the file, click the Browse button next to 
the File field. 
 

 
To CLEAR the Output tab: 

1. Select Edit > Preferences from the Menu bar. 

2. In the Preferences dialog, select the Logging tab. 

3. In the Output area, click the Clear Output Window button. 
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PROBLEMS TAB 
The Problems tab allows you to validate your project for potential issues. The Qarbon 
Dev Team created a “Top 25” list of things that could possibly go wrong with a project—
those that have generated a lot of support tickets in the past. Armed with this 
information, a new project validation tool was created to check for these potential issues.  
 

 
 
Let’s see how this might work. For example, on a quiz slide, you might forget to mark the 
correct response for the question. Believe it or not, this is a common mistake. And, 
because of this, you wonder why your Viewlet is not scoring results correctly. Using this 
validation feature, you can find the issue and provide the solution a lot quicker than in 
previous versions. 
 
To run PROJECT VALIDATION from the Problems tab: 

1. Select View > Tabs > Problems from the Menu bar. 

2. In the Problems tab that displays, click the Click here link to run project 
validation. 

3. The validation results are listed. 

4. Read through the list of issues and correct them as needed. 

5. Click the Validate Project button (right side of tab) to rerun project validation. 

a. Resolved issues are removed from the list. 

b. If all issues are resolved, a No Problem Found message displays at the 
top of the tab. 
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Color Dialog 
A background color is the color used to “fill” a project element such as a shape, 
message object, slide, etc. A border color is the color used as the “line” color around a 
slide object such as a shape, image, etc. When working with background and/or border 
color options, you have various choices to make. This chapter provides general 
instructions when working with background color and border color while editing your 
Viewlet project. 
 

 
 

BACKGROUND COLOR 
A Background Color can be applied to various elements within your project including 
slides, balloons, notes, highlights, lines, arrows, etc. When available, the Background 
Color is the color used to “fill” the selected element. 
 
To set a Background Color: 

1. Click the Background Color button. 

2. In the Background Color screen that displays, select one of the tabs (Swatches, 
Rainbow). 

a. Swatches (tab) 

 Use the swatches area to click on a color of choice. 

 Or, type in an R-G-B or Hexadecimal number for the desired color. 

 Or, move the “eye dropper” over the desired color and click to select it 
as the color of choice. 

 To add a color to the Custom choices, select the desired color then 
click the green “plus” icon. 
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 To remove a color from the Custom list, select the color and click the 
“red X” (under the green “plus” icon). 

 

b. Rainbow (tab) 

 Use the rainbow palette area to click on a color of choice. 

 Or, type in an R-G-B or Hexadecimal number for the desired color. 

 Or, move the “eye dropper” over the desired color and click to select it 
as the color of choice. 

 To add a color to the Custom choices, select the desired color then 
click the green “plus” icon. 

 To remove a color from the Custom list, select the color and click the 
“red X” (under the green “plus” icon). 

 
 

3. Once the color is selected, click OK to close the dialog and apply it. 
 
 

BORDER COLOR 
A Border Color can be applied to the lines that “border” various slide elements such as 
images, shapes, etc. 
 
To set a Border Color: 

1. Click the Border Color button. The Border Color screen displays. 

2. Follow the same instructions found in steps 2 and 3 as previously outlined for 
“Background Color” to select a Border Color (substituting the Border Color 
screen for the Background Color screen). 

 

GRADIENT COLORS 
In the Color dialog, there is a Gradient tab where you can create, edit and apply custom 
gradients to slide background colors. 
 
There are several gradients pre-installed and are available from the drop-down list: 

You can select a pre-installed gradient from the list, rename a gradient, create/save new 
gradients or delete gradients that you no longer need. This section highlights the basics 
of working with gradient colors. 

Select a Gradient for the Slide Background Color 
1. Select the slide you want to use for the gradient. 

2. Click the Background Color button. 

3. Select the Gradient tab. 

4. Select a gradient from the drop-down list. 

5. Click OK to apply it to the slide. 
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Create a New Gradient 

1. In the Gradient tab (Background Color dialog), select Unnamed Gradient from 
the drop-down list. 

2. Select a Start Color by clicking the Start Color button. In the dialog that 
displays, select a color and click OK to save the selection and to close the dialog. 

3. Select an End Color by clicking the End Color button and, using the same steps 
you did when choosing a Start Color, select an End Color in the dialog that 
displays, clicking OK to save the selection and to close the dialog. 

4. When both colors are selected, make sure to take a look at the Preview area, 
which displays the current gradient effect for the selected colors. 

5. Use the up/down arrows to change the Direction of the gradient. Watch the 
Preview area as you change the “degrees”. 

6. Once you are satisfied with your selections, click the Save  button. The Save 
“Unnamed” Gradient dialog displays. 

7. Enter a name for the gradient and click OK to save it. The new gradient is saved 
to the list for future use. 

 

Rename a Gradient  
1. In the Gradient tab (Background Color dialog), select a gradient from the drop-

down list. 

2. Click the Rename Gradient button. 

3. In the Rename Gradient dialog that displays, modify the name as needed. 

4. Click OK to save the changes and to close this dialog. 

 

Remove a Gradient  
1. In the Gradient tab (Background Color dialog), select a gradient from the drop-

down list. 

2. Click the Remove Gradient button. Be careful when removing a gradient 
because once you click the removal button, the gradient is permanently 
removed/deleted from the drop-down list. 
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Cursor Management 
Cursor animation is a fundamental component of most Viewlet projects. Understanding 
the basics of how cursor movement is captured, the different parts that make up the 
actual slide-to-slide cursor animation and how to edit cursor movement is an important 
Viewlet authoring skill, which is essential for creating attention getting, dynamic Viewlets. 
 
On a Video slide, the cursor layer works very much the same as it does on other project 
slides (non-Video slides). However, since the Cursor Path on a Video slide is intended to 
be “in sync” with the Video layer, certain elements on it cannot be edited.  
 

THE MOUSE TAB 
The Mouse tab in the Capture Options dialog is available for Viewlet authors when 
setting up or modifying Capture Profile options for new screen or video capture projects 
or when inserting new screenshots or video captures into existing projects. In the Mouse 
tab, you have options for capturing cursor movement during a screenshot session and 
also the option to capture screenshots on mouse click action. 
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Screen Capture Projects 

Accessing the Mouse Tab 
1. Select File > New from the menu bar. 

2. The Create New Project dialog displays. Select Screen Capture Project from 
the new project type list. 

3. Select a profile from the list of Capture Profiles to use for the screenshot 
session. 

4. Click the Modify button. 

5. The Capture Options dialog displays. Select the Mouse tab. 
 
Note: You can access the “Mouse” tab to set up cursor options prior to creating a new Screen 
Capture Project or right before inserting new screenshots into an existing project by adding a new 
“Capture Profile” or by selecting an existing “Capture Profile” and clicking “Modify” to display the 
“Capture Options” dialog where the “Mouse” tab is located. 
 

Capturing Cursor Movement During Capture Session 
1. In the Capture Options dialog (accessed when adding or modifying Capture 

Profiles), select the Mouse tab. 

2. In the On Screen Capture – Add to Slide area: 

a. Select the Cursor Simulation option. 

b. If you want to allow the cursor to follow a curved path (for added visual 
interest during playback), select the Curved Cursor Path option. 

3. Click OK to close the Capture Options dialog. 
 
 

Disabling Cursor Animation Capture During Capture Session 
1. In the Capture Options dialog (accessed when adding or modifying Capture 

Profiles), select the Mouse tab. 

2. In the On Screen Capture – Add to Slide area, select the Don’t Add Cursor 
Simulation option. 

3. Click OK to close the Capture Options dialog. 
 

 
Enabling Mouse Click Capture During Manual Capture Session 

1. In the Capture Options dialog (accessed when adding or modifying Capture 
Profiles), select the Mouse tab. 

2. In the Mouse Click Capture area to: 

a. Enable mouse click capture of screenshots during a capture session, 
select the Mouse Clicks Capture Screenshots. 
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b. Select the Include Right Mouse Button to enable additional right click 
mouse click of screenshots capability during the recording session. 

3. Click OK to close the Capture Options dialog. 
 

Cursor Indicators (Red, Green, Blue) 
When you look at a slide that contains cursor movement, you will see cursors indicated 
by (at a minimum) a “green” circle and a “red” circle. These two cursor circle indicators 
are connected by a “dotted” line. And, there may be times when you see a “blue” circle 
along the dotted line connected the green and red circles. Let’s take a look at what these 
all mean: 

 
Green Circle: A green circle around a cursor signifies the starting position 
of the cursor on a cursor path. 

 
Red Circle: A red circle signifies the ending position of a cursor on a cursor 
path. 

 
Blue Circle: A blue circle signifies the point on the cursor path will the 
cursor will change shape before it reaches its destination. 

 
Cursor Path 
The “dotted line” between the green circle and the red circle is known as the “cursor 
path”. This is the path the cursor travels during its animation (while moving from one 
slide to the next slide). A basic path starts at the green circle and ends at the red circle. 
A more complicated path includes points along the cursor path where the cursor may 
change direction or cursor style. Elements of the cursor path may be edited. 
 
In some cases, there may be “points” along the cursor path. These points may be a 
“blue circle” cursor indicator where the cursor changes shape before it reaches the end 
of the cursor path. Or, the cursor path may contain “red points” that indicate a change in 
direction along the cursor path. You can edit these points by dragging them along the 
cursor path. Or, to change the direction the path takes, simply “pull” the point to change 
the cursor path’s direction. 
 

 
 
 
To move a green circle (starting cursor position) on the cursor path: 

1. Click on the green circle. 

2. While holding down your left mouse button, drag the green circle to where you 
want it to reside on the slide. 

3. Let go of the left mouse button to drop it into place. 
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To move a red circle (ending cursor position) on the cursor path: 

1. Click on the red circle. 

2. While holding down the left mouse button, drag the red circle to where you want 
it to reside on the slide. 

3. Let go of the left mouse button to drop it into place. 
 
To move a blue circle (where cursor changes shape on cursor path) on the cursor path: 

1. Click on the blue circle. 

2. While holding down the left mouse button, drag the blue circle to where you want 
the cursor to change its shape on the cursor path. 

3. Let go of the left mouse button to drop it into place. 
 
To add a “red point” to the cursor path: 

1. Click the green circle to select it. 

2. Click the Add Point to Cursor Path button on the Context Sensitive Toolbar. A 
“red point” will display on the cursor path, ready for editing. 

 
To move a “red point” along the cursor path: 

1. Click on the red point. 

2. Hold down the left mouse button and drag it along the cursor path. 

3. Let go of the left mouse button to drop it into place. 
 
 
To change a single cursor path from straight to curved or curved to straight: 

1. Click the green circle to select it. 

2. To change the cursor path to straight, click the Move the cursor in a straight 
path button on the Context Sensitive Toolbar. 

3. To change the cursor path to curved, click the Move the cursor in a curved 
path button on the Context Sensitive Toolbar. 

 
 
To globally change all cursor paths within the project to straight or curved: 

1. Click the green circle to select it. 

2. To change all cursor paths in the project to straight, click the Straight Path – All 
Slides button on the Context Sensitive Toolbar. 

3. To change all cursor paths in the project to curved, click the Curved Path – All 
Slides button on the Context Sensitive Toolbar. 

 
To remove a “red point” or “blue circle” from the cursor path: 

1. Click on the “red point” or the “blue circle” to select it. 

2. Press the Delete key on the keyboard to delete it. Or, right click and select 
Delete from the shortcut menu. 
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To remove all cursor paths: 

1. Select one of the cursors to activate the Cursor Context Sensitive Toolbar. 

2. Select the Remove All Cursor Path button along the toolbar. 

3. When prompted “Are you sure you want to remove all cursor paths?” click Yes. 
 

Cursor Style 
ViewletBuilder8 Enterprise comes with a library of the most common cursor styles used 
in Viewlet projects. Cursor styles captured during screenshot sessions are added to the 
cursor style library. Once captured, cursors can be changed in a project as desired by 
selecting a different style from the cursor style library. 
 
To ADD cursors to a slide that does not contain a cursor: 
 

1. Click the Insert Cursor button from the Object Toolbar. Or, from the Insert Menu 
or right click shortcut menu, select Cursor. A cursor will display on the slide, 
ready for editing. 

 
 
To CHANGE the cursor style: 

1. Click on the cursor to select it. 

2. Click the Cursor Style button from the Context Sensitive Toolbar. 

3. The Cursor Style dialog displays. Click on a style to select it. 

4. Click OK to apply the new cursor style. 
 
 
 
To DELETE a cursor from a slide: 

1. Click the green circle to select the cursor. 

2. Press the Delete key from the keyboard and the cursor, along with the cursor 
path, will be removed from the slide. 

 
Note: The “Insert Cursor” button on the Object Toolbar acts like a “toggle switch”. If a cursor is 
displayed on the slide, click the “Insert Cursor” button to remove it. Click the button again to insert 
a cursor back on the slide. 
 
 

Cursor Path Layer 
If a slide contains cursor animation, then along the Timeline you will see a Cursor Path 
layer. This layer will always be the uppermost layer in the stack of layers and cannot be 
moved down in the stack. You can edit the green circle and any red points along the 
cursor path by selecting the appropriate section on this layer. And, you can use this layer 
to “tweak” the duration of the cursor animation as it plays to the next slide.  
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Notes, Balloons, Text Boxes 
ViewletBuilder8 Enterprise allows you to add impact to your Viewlet projects with notes, 
balloons and text boxes. These slide elements are also referred to as messages. Here 
are some ‘best practices’ for these elements: 
 

Note: A note is used to “introduce” a topic or action that is 
about to occur. It is also used in situations when you want 
to make sure the viewer takes notice of some important 
content such as special information, a tip or trick, or even 
a “warning” of some type. 
 
Balloon: A balloon is used to “point out” an area of the 
screen or an action. For example, a balloon may contain 
text that discusses different areas of the screen while using 
its “pointer” to point at the area being discussed. Or, more 
commonly, a balloon may point at a button or text entry 
field with instructions for the viewer to “interact” with the 
Viewlet. 
 
Text Boxes: A text box is used to “seamlessly blend” text 
into its background, whether it be the slide itself, a shape 
or an image or even other text. Text boxes are also used 
as the “question” box for quiz and survey question types. 
 

AUTHORING PREFERENCES 
As described earlier in this guide, you can set the default ‘text editing’ preference when 
setting up preferences for your authoring application. This will determine the default 
method your application will initially use when you work with notes, balloons, and text 
boxes, however, you can switch between text editing methods while working on your 
project. 
 
Edit in Place  
This is the “classic” message editing method used in previous versions. This method 
allows you to edit text directly in the note, balloon, or text box (without opening a dialog). 
It also allows you to change the Message objects attributes using various buttons on the 
object’s Context Sensitive Toolbar (when the object is selected and not in text editing 
mode). 
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The Text Editor 
The Text Editor offers an alternative way to editing message objects in ViewletBuilder8 
Enterprise all within the same dialog.  
 

 
 
When the “Text Editor” option is used, an editor dialog displays when you are in text edit 
mode. Inside the Text Editor dialog, you can use the: 
 
 Message Type button to change the object’s style and type. 

 
 Background Color button to change the object’s fill color. 

 
 Font list and Font Size list to change the text font type and size. 

 
 Italic, Underline, or Bold button to change text attributes. 

 
 Text Color button to change selected text color. 

 
 Alignment buttons to Left Align, Center Align, Right Align, Top Align, Middle 

Align or Bottom Align selected text. 
 

 Hyperlink button to turn selected text into a clickable hyperlink. 
 

 Text edit field to select text to edit or to select text to apply any of the available 
text attributes (font, font size, italic, bold, underline, color, alignment, hyperlink). 
 

 OK button to save edits in the dialog. 
 

 Cancel button to exit the dialog without saving any changes. 
 

 Apply button to apply changes without exiting the dialog. 
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To open the “Text Editor” from the Context Sensitive Toolbar or “right click” menu: 

1. Select the Message object you want to edit by single clicking it to select it. 

2. Click the Text Editor button on the Context Sensitive Toolbar, 
 
OR 
 

3. Right click on the Message object and select Open in Text Editor from the 
shortcut menu. 

4. The Text Editor dialog displays. Make edits as needed and click OK to save 
changes and to close the dialog. 
 

 
While working with Message objects, you will find the process and options used during 
the “editing” operation will be basically the same for each object whether it is a note, 
balloon or text box. 
 
To insert a Message object on a slide: 
 

Note: 
1. Click the Insert Note button on the Object Toolbar. 

2. If you selected for “message editing”: 

a. Edit in Place: A note object will display on the slide with a “blinking cursor” 
inside it. This indicates the note is ready for you to start typing in it. 

b. Text Editor: The Text Editor dialog displays. Make your selections for the 
text using the available buttons (font, font size, etc.) and type your text in 
the “text edit” field. Click OK to save the information and the note will be 
inserted on the slide. 
 

Balloon: 
3. Click the Insert Balloon  button on the Object Toolbar. 

4. If you selected for “message editing”: 

a. Edit in Place: A balloon object will display on the slide with a “blinking 
cursor” inside it. This indicates the balloon is ready for you to start typing 
in it. 

b. Text Editor: The Text Editor dialog displays. Make your selections for the 
text using the available buttons (font, font size, etc.) and type your text in 
the “text edit” field. Click OK to save the information and the balloon will 
be inserted on the slide. 
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Text Box: 
5. Click the Insert Text Box button on the Object Toolbar. 

6. The cursor changes to a cross-hair shape. Move the cursor over the slide and 
click where you want to “anchor” one corner of the text box. Hold down the left 
mouse button and draw the text box on the slide. 

7. If you selected for “message editing”: 

a. Edit in Place: A text box object (surrounding by a “bounding box” that 
looks like a “dotted rectangle” with gnodes (grab handles) for resizing the 
box) will display on the slide with a “blinking cursor” inside it. This 
indicates the text box is ready for you to start typing in it. 
 

b. Text Editor: The Text Editor dialog displays. Make your selections for the 
text using the available buttons (font, font size, etc.) and type your text in 
the “text edit” field. Click OK to save the information and the text box will 
be inserted on the slide. 

 
 

MESSAGE OBJECTS 
Styles and Type 
Once you insert a Message object on a slide, you can change its “style” and its “type” at 
any time without recreating it from scratch. The process for doing this is the same for all 
Message objects. 
 

 
 
To change object’s style and / or type: 
 

Using “Edit in Place” message editing: 
 
 Single click the message object to select it. 

 
 Click the Message Type button on the Context Sensitive Toolbar. 
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 The Message Type dialog displays. Select: 
 

o A “message style” from the first list. 
 

o A “message type” from the second list. 
 

 Click OK to save and apply the selections. 
 
 

Using “Text Editor” message editing: 
 
 Double click the Message object. 

 
 The Text Editor dialog displays. Click the Message Type button. 

 
 The Message Type dialog displays. Select: 

 
o A “message style” from the first list. 

 
o A “message type” from the second list. 

 
 Click OK to save selections and to close the Message Type dialog. 

 
 Click OK to close the Text Editor dialog and to apply changes. 
 
 

Background Color 
You can change the background color of a note or balloon while the Message object is 
selected (using the “Edit in Place” message editing method) or from inside the Text 
Editor dialog. 
 
Edit in Place 
To CHANGE the background color of a note or balloon: 

1. Single click the note or balloon to select it. 

2. Click the Background Color  button on the Context Sensitive Toolbar. 

3. The Background Color dialog displays. Make your color selections in either the 
Swatches or Rainbow tab. 

4. Click OK to apply the selected color to the Message object. 
 
 
Text Editor 
To CHANGE the background color of a note or balloon: 

1. Double click the note or balloon to open the Text Editor. 

2. In the Text Editor dialog, click the Background Color button. 

3. The Background Color dialog displays. Make your color selection in either the 
Swatches or Rainbow tab. 
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4. Click OK to save the selection and to close the Background Color dialog. 

5. Click OK to close the Text Editor dialog and to apply the selected color. 
 

Alignment Tools 
When the Message object is selected (not in text edit mode), three object “alignment” 
buttons display on the Context Sensitive Toolbar. These buttons can be used to align a 
selected Message object on the slide. 
 
To ALIGN a Message object on a slide: 

1. Single click on the desired Message object. 

2. Click the:  

a. Center Horizontally button to horizontally center the selected object on 
the slide. 

b. Center Vertically button to vertically center the selected object on the 
slide. 

c. Center button to center (both horizontally and vertically) the selected 
object on the slide. 

 
 
Text Options 
While working with Message objects (notes, balloons, text boxes), you will want to 
customize the various attributes that can be applied to the textual content. Text options 
include: font, font size, attributes (italic, bold, underline), text color, text alignment within 
the Message object and hyperlink capability.  Each of these options is available while 
editing text using: 
 
 Edit in Place: Double click the Message object so that a “blinking cursor” 

displays inside it. This indicates you are in “text edit” mode and a Context 
Sensitive Toolbar is available with various buttons for text editing options.  
 

 Text Editor: Double click the Message object to open the Text Editor dialog. The 
text option tools are available within this dialog (as shown in the image below). 
 

To EDIT text in a Message object: 

1. Double click on the Message object. Depending on the “message editing” 
method used, either a Context Sensitive Toolbar (for “Edit in Place” message 
editing) or a Text Editor dialog (for “Text Editor” message editing) displays. 

2. Highlight the text you want to edit (either in the Message object itself or within the 
text edit field in the Text Editor dialog). 

3. Click the applicable option to make the desired text edit: 

a. Font: Select a new font from the Font list. 

b. Font Size: Select a new text size from the Font Size list. 

c. Italic: Click the Italic button to set the selected text in italics. 

ViewletBuilder8 Enterprise User Guide Page 136  © 2014 rev. 0626 



 
 
 

d. Underline: Click the Underline button to underline the selected text. 

e. Bold: Click the Bold button to bold the selected text. 

f. Text Color: Click the Text Color button. In the Text Color dialog, select a 
color from either the Swatches or Rainbow tab then click OK. 

g. Left Align: Click the Left Align button to left align the text in the 
Message object. 

h. Center Align: Click the Center Align button to center the text in the 
Message object. 

i. Right Align: Click the Right Align button to right align the text in the 
Message object. 

j. Top Align: Click the Top Align button to align the text at the top of the 
Message object. 

k. Middle Align: Click the Middle Align button to align the text in the middle 
of the Message object. 

l. Bottom Align: Click the Bottom Align button to align the text at the 
bottom of the Message object. 

m. Hyperlink: Click the Hyperlink button. In the Hyperlink dialog that 
displays, make your selections as required and click OK to close the 
dialog. 

4. To exit text edit mode while using the message editing option: 

a. Edit in Place: Click off the Message object to deselect it. 

b. Text Editor: Click OK to save the changes and to close the Text Editor 
dialog. 

 
 

Resizing 
ViewletBuilder8 Enterprise offers an option on the message object’s Context Sensitive 
Toolbar that allows you to automatically resize the message object as text is edited. This 
feature can be enabled / disabled at will. 
 
To ENABLE “automatic” resizing of a Message object as you edit text: 

1. Click on the Message object to load its Context Sensitive Toolbar. 

2. Click the Automatically size message to fit when editing button. 

3. Double click to Message object to enter “text edit” mode. 

4. If you selected for “Text Editing”: 

a. Edit in Place: As you edit text, the object automatically resizes as you 
type directly in the Message object. 

b. Text Editor: The Text Editor displays. Once you click Apply or OK to save 
the text edits, the Message object will be automatically resized. 
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To MANUALLY resize a Message object: 

1. Single click on the Message object to select the object itself (not in text edit 
mode). A “bounding box” (dotted rectangle) will display around it. 

2. Move your cursor over one of the gnodes (grab handles). When the cursor 
changes to a “double arrow” shape, hold down the left mouse button and drag to 
resize the Message object. 

3. Let go of the left mouse button to complete the resizing action. 
 
 

Miscellaneous Features 
To MOVE a Message object on a slide: 

1. Click the object to select it so that a “bounding box” (dotted rectangle) displays 
around it. 

2. Point your cursor over the selected Message object. When the cursor changes to 
a “hand” shape, hold down your left mouse button and drag the object to its new 
location on the slide. 

3. Let go of the left mouse button to drop the object into place. 
 
 
To ATTACH AUDIO to a Message object: 

1. Click the object to select it so that a “bounding box” (dotted rectangle) displays 
around it. 

2. Click the applicable Attach Sound button on the Context Sensitive Toolbar. 

3. In the Sound dialog that displays, insert or record a sound file. 

4. Click OK to save the sound file and attach it to the Message object. 
 
 
To ADD A SHADOW to a message object: 

1. Select the message object (note, balloon or text box) so the object itself is 
selected (and you are NOT in text edit mode). 

2. Click the Shadow Properties button. 

3. Make your selections in the Shadow Properties dialog and click OK to apply. 

 
To REMOVE a Message object from a slide: 

1. Click on the Message object to select it. 

2. Click the Delete button on the Context Sensitive Toolbar. The selected object will 
be deleted. 
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Format Painter 
The Format Painter may be used to quickly change text properties in notes, balloons and 
text boxes. It can also be used to change properties of a shape object’s border (color, 
width) and fill color based on another shape.  
 

 
 
To use the Format Painter to apply text attributes from one message object to another: 

1. Make your changes to text in your message object. 

2. Click on the text (or click anywhere inside the text) that will be copied from. 

3. Click the Format Painter button. 

4. Click on subsequent text objects to apply this formatting from the first selection. 

5. Continue clicking on text on the current or any other slide to apply the formatting. 

6. When you are finished, click the Format Painter button to deselect it. 
 
 
To use the Format Painter to copy a shape’s attributes and apply them to other shapes: 

1. Make your changes to the shape as desired and then make sure it is selected. 

2. Click the Format Painter button. 

3. Click on subsequent shapes to apply the formatting. 

4. When you are finished, click the Format Painter button to deselect it. 
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Dictionary, Spell Check, Search and Replace 
ViewletBuilder8 Enterprise offers various tools to help you make sure that your content is 
accurate, typos are caught and corrected, and grammar rules are followed. These 
features include: 
 
 Dictionary: Set your dictionary to one of several languages. The dictionary helps 

you catch unwanted typos and allows you to build it for more complex content by 
adding custom words. 
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 Spell Check: Enable the “Spelling Mistakes” option from the View menu to 

automatically check text in message objects against the selected dictionary. 
Incorrectly spelled words, or words not recognized by the dictionary, will be 
quickly identified by a red, squiggly underline. 
 

 
 

 Search and Replace: Use this tool to quickly search for and replace a specific 
word (or even a phrase) on a message by message basis or throughout the 
entire project. 
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To SET your dictionary and spell check preferences: 

1. Select Edit > Preferences from the menu bar. 

2. Select the Spelling tab. 

3. Select a language to use for the spell check dictionary from the list. 

4. Select additional options for the spell check as needed. 
 
 
To ENABLE / DISABLE the Spell Check tool: 

1. To enable the Spell Check tool, select View > Spelling Mistakes from the menu 
bar. 

2. When a word is incorrectly spelled or is not recognized by the selected 
dictionary, it will be designated with a “red squiggly underline”.  

3. To disable the spell check tool, select View from the menu bar. 

4. If the Spelling Mistakes option has a checkmark next to it, click it to remove the 
checkmark to deselect the tool. 

 
 
To CORRECT A TYPO using the right click menu: 

1. Click anywhere in the text where the typo appears (as indicated by the red 
squiggly underline). 

2. Right click to display the shortcut menu. 

3. At the bottom of the shortcut menu, select the appropriate option: 

a. Replace: Select this option to display a list of suggested words to use to 
replace the “selected” incorrect text. 

b. Replace All: Select this option to display a listed of suggested words to 
use to replace all instances of the “selected” incorrect text throughout the 
entire project. 

c. Ignore All: Select this option to ignore all instances of the “selected” 
incorrect text throughout the project. 

d. Learn: Select this option to add the “selected” incorrect text to the 
dictionary. 

 
 
To Search and Replace: 

1. Click the Search and Replace button on the Main Toolbar. 

2. The Search and Replace dialog displays. Two tabs are available: Search and 
Replace.  

3. To search for a specific word or phrase: 

a. Select the Search tab if it is not already selected by default. 

b. In the Text field, type in the word or phrase you want to search for. 

c. Select the Case Sensitive option to narrow results. 
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d. In the Direction area, select Forwards to search from this point in the 
project forwards, or select Backwards to search from this point in the 
object backwards. 

e. In the Slides area, select: 

i. Current to search the current slide. 

ii. From and enter a number in each of the fields provided to search 
from a specific slide to a specific slide based. 

iii. All to search all slides within the project. 

f. Click the Find Next  button to start the search operation. 
 

4. To replace a specific word or phrase: 

a. Select the Replace tab. 

b. In the Text field, type in the word or phrase you want to search for. 

c. In the Replace With field, type in the word or phrase you want to use as 
the replacement text. 

d. Select the Case Sensitive option to narrow results. 

e. In the Direction area, select Forwards to search from this point in the 
project forwards, or select Backwards to search from this point in the 
object backwards.  

f. In the Slides area, select: 

i. Current to search the current slide. 

ii. From and enter a number in each of the fields provided to search 
from a specific slide to a specific slide based. 

iii. All to search all slides within the project. 

g. Once all the information is entered / selected in the Replace tab, click the: 

i. Replace All to search for and replace all instances of the text with 
the text provided. 

ii. Replace to replace the currently “selected” text found after 
clicking the Find Next button. 

iii. Find Next button to find the next instance of the desired word or 
phrase entered in the Text field. 

5. Once you are finished using the Search and Replace tool, click the red “X” to 
close the dialog. Or, click Cancel to end the search and replace operation. 

 
 
 
 

ViewletBuilder8 Enterprise User Guide Page 143  © 2014 rev. 0626 



 
 
 

Working With Slides 
There are several types of slides that you may insert into existing projects: 
 
 Blank Slides 
 Screenshots 
 Video 
 Image slides 
 PowerPoint Slides 
 Question Slides 
 Question Bank 

 
Each of these (in the list above) have been covered previously in this guide. This section 
provides general information for working with slides in your Viewlet project. 
 

INSERTING SLIDES & QUESTION BANKS 
 

 
 

To insert a BLANK SLIDE: 

1. In the Slides tab, select a thumbnail. The inserted slide will be inserted right after 
this thumbnail. 

2. Select Insert > Slides > Blank Slide from the Menu bar. Repeat these steps to 
insert additional blank slides. 

 
 
To insert SCREENSHOTS: 

1. In the Slides tab, select a thumbnail. The new screenshot(s) will be inserted right 
after this slide. 

2. Select Insert > Slides > Screenshots from the menu bar. 

3. The Insert Screenshots dialog displays. Make your selections as needed and in 
the dialogs that display, follow the prompts to select options for screenshots. 

4. Take your screenshots during the recording session. 
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5. End your screenshot session and new screenshots will be converted to slides 
and inserted into your existing project. 

 
 
To insert VIDEO slides: 

1. In the Slides tab, select a thumbnail. The new video slide will be inserted right 
after this slide. 

2. Select Insert > Slides > Video from the menu bar. 

3. The Insert Video dialog displays. Make your selections as needed and in the 
dialogs that display, follow the prompts to select options for the capture session. 

4. Take your video capture. 

5. End your capture session as you would when creating a new Video Project. It will 
be inserted into your existing project as a new Video slide. 

6. Repeat these steps as needed. 
 
 
 
To insert IMAGE SLIDES: 

1. In the Slides tab, select a thumbnail. The new image(s) will be embedded onto 
slides right after this slide. 

2. Select Insert > Slides > Image Slides from the menu bar. 

3. Follow the instructions in the Select Images to Import dialog. 

4. Click OK to insert the new image slides into your existing project. 
 
 
To insert POWERPOINT SLIDES: 

1. In the Slides tab, select a thumbnail. The new PowerPoint slides will be inserted 
right after this slide. 

2. Select Insert > Slides > PowerPoint Slides from the menu bar. 

3. Follow the instructions in the Select PPT file to Import dialog.. 

4. Click OK to insert the PowerPoint slides as background frames into your existing 
project. 

 
 
To insert QUESTION SLIDES: 

1. In the Slides tab, select a thumbnail. The Question slides will be inserted right 
after this slide. 

2. Select Insert > Slides > Question Slides from the menu bar. 

3. In the Add Questions dialog, make your question selections as you would when 
creating a new Question project. 

4. Click OK to insert the new question slides into your project. 
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To insert a QUESTION BANK: 
Note: Question Banks are NOT slides themselves, they are bank locations that hold question 
slides (scored-quiz; not scored-survey) for use with Random Question type slides. So, when 
inserting a new Question Bank from the Insert menu, it will be added to the list of Question Banks 
in the Question Banks tab. 

1. Select Insert > Slides > Question Bank from the menu bar. 

2. In the Add Question Bank that displays, follow the instructions for creating a new 
bank. 

3. Click OK to close the dialog. The new Question Bank will be added to the list in 
the Question Banks tab. 

4. Repeat these steps as needed for each new Question Bank. 
 

PROPERTIES 
The Slide Properties dialog contains options for: 

 Main Timeline slides and Question Bank slides 
 Master slides 

 

Main Timeline Slides & Question Bank Slides 
To ACCESS slide properties: 

Main Timeline: 

1. In the Slides tab, select a project slide thumbnail. 

2. Click the Slide Properties button on the Context Sensitive Toolbar. 

3. In the Slide Properties dialog, enter a: 

a. Name for the slide title. 

b. Duration number for the display time in seconds.  

4. Click OK to save changes and close the dialog. 

 
Question Bank: 

1. In the Question Banks tab, select a bank from the Question Banks list. 

2. Select a question slide thumbnail. 

3. Click the Slide Properties button on the Context Sensitive Toolbar. 

4. In the Slide Properties dialog, enter a: 

a. Name for the slide title. 

b. Duration number for the display time in seconds. 

5. Click OK to save changes and close the dialog. 
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Master Slides 
To ACCESS slide properties: 

1. In the Masters tab, select a master slide thumbnail. 

2. Click the Slide Properties button. 

3. In the Slide Properties dialog, enter a Name for the slide title. 

4. Click OK to apply and to close the dialog. 

 

BACKGROUND COLOR & BACKGROUND FRAME 
Background Color 
Background color can be applied to project slides on the Main Timeline, master slides 
and question bank slides.  
 

 
 
The Background Color dialog, when used to set options for a slide’s background color, 
contains three tab options: 

 Swatches 
 Rainbow 
 Gradient 

 
The Background Color dialog is covered earlier in this guide. This section focuses on 
working with background color for slides. 
 
To CHANGE slide background color: 

1. Select the slide or slides you want to work with. 

2. Click the Background Color button from the Context Sensitive Toolbar. 

3. In the Background Color dialog, select one of the (Swatches, Rainbow, Gradient) 
tabs. 

4. Choose your color with the options available in your selected tab. 

5. Click OK to apply the color and to close the dialog. 
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Background Frame 
Background frames are images that are embedded as part of the slide’s background. 
Unlike slide background color, background frames may only be applied to project slides 
on the Main Timeline and question bank slides. Background frames CANNOT be applied 
to master slides. 
 

 
 
 
To ADD a background frame: 

1. Select the slide or slides you want to work with. 

2. Click the Background Frames button from the Context Sensitive Toolbar. 

3. In the Background Frames dialog, click Add Image  button. 

4. In the Background Frame dialog: 

a. Click the Browse button to locate and select an image file. 

b. Select the Key Frame option if this image is the main background image. 

c. Set options for its location and duration along the timeline. 

5. Click OK to close the Background Frame dialog. 

6. Click OK to close the Background Frames dialog and apply the new background 
frame image. 
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To DELETE a background frame: 

1. Select the slide you want to work with. 

2. Click the Background Frames button from the Context Sensitive Toolbar. 

3. In the Background Frames dialog, click the Remove Background button. 

4. Click OK to save changes and to close the dialog. 

 
 

MOVING SLIDES 
There are various ways to move slides with in a project. The easiest way to do it is while 
working with slide thumbnails. 
 
To MOVE slides using DRAG and DROP: 

1. Optional: Expand the tab containing the slides you are going to move. 

2. Select the thumbnail of the slide you want to move. If you want to move multiple 
slides, you can hold down the Shift (adjacent slides) or Ctrl (non-adjacent slides) 
keys when clicking on slides to select them. 

3. Hold down the left mouse button and drag to the new location. 

4. Let go of the left mouse button to drop into place. 
 
 
To MOVE slides using CUT and PASTE: 

1. Optional: Expand the tab containing the slides you are going to move. 

2. Select the thumbnail of the slide you want to move. If you want to move multiple 
slides, you can hold down the Shift (adjacent slides) or Ctrl (non-adjacent slides) 
keys when clicking on slides to select them. 

3. Click the Cut button on the toolbar. 

4. Click on the thumbnail where you want to insert the “cut” selection after. 

5. Click the Paste button on the toolbar. 
 

 

DELETING SLIDES 
Project slides (on the Main Timeline), master slides and question bank slides can easily 
be deleted one-by-one or several at a time. 
 
To DELETE one or more slides: 

1. Select the applicable tab (Slides, Masters, or Question Banks). 

2. Select the thumbnail of the slide you want to delete. If you want to delete multiple 
slides, you can hold down the Shift (adjacent slides) or Ctrl (non-adjacent slides) 
keys when clicking on slides to select them. 

3. Click the Delete button on the toolbar. 
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4. A Delete warning dialog displays. Read the information in it and click the  
Yes button to confirm the deletion. 

 

THE HIDDEN SLIDE 
Available only with project slides on the Main Timeline, you have the option of hiding a 
slide instead of deleting it. This feature is handy because instead of deleting the slide, it 
will hide it so that it will not display while previewing or publishing the project, but can 
later be unhidden when needed. 
 

 
 
Hidden slide benefits include: 

 The thumbnail for a hidden slide has an X in the lower left corner. 
 If you select a hidden slide in thumbnails, it will display in slide edit view at 50% 

opacity. 
 If you use slide navigation arrows to go from slide to slide, hidden slides are 

skipped. 
 The duration of hidden slides is ignored in total project time playback. 

 
 
To HIDE or UNHIDE a slide: 

1. In the Slides tab, select the thumbnail of the project slide you want to hide (on the 
Main Timeline). If selecting multiple thumbnails, use the Shift (adjacent slides) or 
Ctrl (non-adjacent) key when clicking to select slides. 

2. To hide a slide, click the Hide Slide button on the Context Sensitive Toolbar. 
Hidden slides will not display (or be heard) when previewing a project; however, 
they will remain in the slide count. 

3. To display a slide, click the Show Slide button on the Context Sensitive Toolbar. 
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FLOATING GUIDES 
Floating guides display when you select a slide object. As you drag the object across the 
slide (in the Slide Editing pane), you can use these guides to align the selection with 
other slide objects. 
 

 
 
To DISPLAY floating guides: 

1. Select View > Floating Guides from the Menu bar. 

2. Select a slide object and the floating guides display. 

 

To DISABLE floating guides: 

1. Select View from the Menu bar. 

2. Deselect Floating Guides to remove the checkmark next to it and to disable this 
feature when selecting and moving slide objects. 

 

SLIDE TRANSITIONS 
Slide Transitions are applied between slides located on the project’s Main Timeline. 
These are not visible when editing the project between slide thumbnails. If a slide has a 
transition applied to it, you will see a “transition” icon applied to its thumbnail as well as 
the actual transition applied along the Context Sensitive Toolbar. 
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There are several transitions available: 

 No Transition: Select this option if you do NOT want any transition to occur 
between slides. 

 Fade Transition: Select this option to fade the slide out before playing to the 
next slide. 

 Push Transition: Select this option to have the next slide push the current slide 
out of view as it plays to the next slide. 

 Wipe Transition: Select this option to have the current slide wipe off the screen 
to reveal the next slide as it plays to the next slide. 

 

To APPLY a transition to one or multiple project slides: 

1. In the Slide tab, select one or more slide thumbnails. 

2. Click the Transition button from the Context Sensitive Toolbar. 

3. In the Slide Transition dialog that displays, select the desired transition. 

4. Select any additional options that may display for the transition. These will vary. 

5. Click OK to apply. 
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Side Bars (Table of Contents) 
ViewletBuidler8 Enterprise provides features for you to automatically generate a Table of 
Contents, which displays in a ViewletSkin’s Side Bar. This chapter provides some 
general information for setting up a Table of Contents for your Viewlet.  
 

SLIDE SETUP 
The first thing you need to do is determine which slides in your project (on the Main 
Timeline) will be included in the Table of Contents and at what level. 
 

 
 

1. In the Slides tab, select the one or more slide thumbnails. 

2. Click the Table of Contents button on the Context Sensitive Toolbar. 

3. Select an option from the drop-down list: 

a. Add to Table of Contents – Level 1 

b. Add to Table of Contents – Level 2 

c. Add to Table of Contents – Level 3 

d. Remove from the Table of Contents 

4. Once you are finished setting the Table of Contents option for each of your 
project slides on the Main Timeline, the next step is to configure your ViewletSkin 
Side Bar options. Click the Save button to save these changes. 

 

VIEWLETSKIN SETUP 
Once you’ve determined the slides to include in the Table of Contents and at what level, 
you need to configure some Side Bar options for your selected ViewletSkin. 

1. Select Project > Project Properties from the Menu bar. 

2. In the Project Properties dialog that displays, select ViewletSkin. 

3. Select a ViewletSkin from the drop-down list. 

4. Select the Side Bar tab (this is where the option to display a Table of Contents 
with your skin is found). 

a. All ViewletSkins EXCEPT the Qomplex ViewletSkin: 
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i. Select the Display the Table of Contents option. 

ii. Select additional options as needed: 

1. Points Column 

2. Maintain Selection 
 

b. Qomplex ViewletSkin options: 
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i. Select the Display the Side Bar option. 

ii. In the Tabs area: 

1. Select the Outline Tab (Table of Contents) option. 

2. Selection additional options as needed: 

a. Points Column 

b. Maintain Selection 
 

5. Click OK to save the settings and to close the Project Properties dialog. 

 

PREVIEW PLAYBACK 
The last step you should take is to preview your results in a browser prior to publishing. 
To do this select Project > Preview in a Browser. Your Viewlet will launch in your 
default browser.  
 

 
 
Here are some items to review when previewing the Table of Contents part of the skin: 

 Make sure the actual Table of Contents displays. Depending on the ViewletSkin 
chosen, it may be already displayed or hidden. If you don’t see it, look along the 
player bar for an option to display it.  

 Review all of the slides in the Table of Contents to ensure: 

o Each are at the correct level (Level 1, Level 2, Level 3) 

o Only the slides you want are showing 

 If you chose additional options, make sure they are displaying or working as 
expected. 
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Zoom Zone 
The Zoom Zone feature allows you to zoom in and out on a slide on the Main Timeline. 

 
 

To ADD a Zoom Zone: 

1. In the Slides tab, select a slide. 

2. In the Timeline tab, click a frame to display the playhead to switch to Time Select 
Mode. This will be where the zone will be inserted. 

3. Select Insert > Effects > Zoom Zone from the Menu bar. 

4. The Zoom Zone area displays. Everything inside the rectangle with dotted lines 
will be included in this zoom area, whereas everything outside (as indicated by 
shading) will not be include. You can: 

a. Move the zoom area by holding down your left mouse button over it and 
dragging it. 
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b. Resize the zoom area by dragging one or more of the grab handles at its 
corners. 

c. Change the duration of the zoom zone along the timeline by: 

i. Point your cursor over the right edge of the zoom zone indicator 
(box) located on the Zoom Zone layer on the timeline: 

ii. When the cursor changes to a double arrow shape, hold down the 
left mouse button and drag. 

iii. Let go to change the duration time. 

d. Click the Zoom Zone Properties button. In the Zoom Zone Properties 
dialog: 

i. Enter numbers for the zone areas location and size. 

ii. Enter number (in seconds) for the zone’s start and end times. 

iii. Click OK to save the settings and to close the dialog. 

5. Click off the slide, either elsewhere along the timeline or on the title area of the 
timeline.  

6. A Zoom Zone Added dialog displays: 

a. Carefully review the information. 

b. Select the Don’t show me this message again. option if you don’t want 
to see this dialog each time you add a Zoom Zone. 

c. Click Close. 
Note: You can add multiple Zoom Zones to the same slide. 

 

To add a FULL SIZE zoom: 

1. In the Slides tab, select a slide thumbnail. 

2. In the Timeline tab, click a frame along the timeline to display the playhead and 
switch to Time Select Mode. This is where the Zoom Zone will be inserted. 

3. Click the Full Size button on the Context Sensitive Toolbar. The zoom area 
resizes to fit the full width and height of the slide. 

4. Click off the slide. If prompted, read the information in any dialog that displays 
and click Close to complete the operation. 

 
Note: It’s a good idea to add a Full Size zoom zone after any other zoom zone to return the 
audience’s full to the entire slide. 
 
To MOVE a Zoom Zone: 

1. Select the Zoom Zone along the timeline. 

2. Using the: 

a. Drag and Drop method: 

i. Hold down the left mouse button and drag it left or right. 
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ii. Let go of the left mouse button to drop it into its new position. 
 

b. Properties dialog: 

i. Click the Zoom Zone Properties button. 

ii. In the dialog that displays, enter a number (in seconds) for a new 
start time. 

iii. Click OK to apply and to close the dialog. 

 

To REMOVE a Zoom Zone: 

1. Select the Zoom Zone along the timeline. 

2. Click the Delete button on the Context Sensitive Toolbar. 

ViewletBuilder8 Enterprise User Guide Page 158  © 2014 rev. 0626 



 
 
 

Highlight Tools 
The highlight tools give you the opportunity to create design elements that add extra 
dimension to your project and focus your viewer’s attention right where you want it to be. 
 
There are three available: 

 Popout Highlight 
 Matte 
 Color Highlight 

 
Access to these tools is available via the Insert or a right click shortcut menu or by 
clicking the appropriate button on the Object Toolbar. This section highlights each of 
these tools 

 

POPOUT HIGHLIGHT 
The Popout Highlight lets you specify an area on the slide you want to ‘pop out’ as the 
Viewlet plays back. For added dimension, multiple and overlapping popouts may be 
added to the same slide. 
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To INSERT a Popout Highlight: 

1. Select the thumbnail of the slide you want to work on. 

2. In the Timeline tab, click a frame to display the playhead (switching to Time 
Select Mode). This will be where the Popout Highlight will be inserted. 

3. Select Insert > Effects > Popout Highlight from the Menu bar. 

4. A shaded bounding box displays on the slide. Move and resize the box as 
needed, placing it over the area of the slide you want to have pop out. 

5. Click off the element to apply. 

6. Repeat these steps to insert each additional Popout Highlight. 

7. Preview results by: 

a. Dragging the playhead to scrub the timeline. 

b. Playing back the results in the browser or within the authoring application.  
 

 
To access the Properties dialog: 

1. In the Timeline tab, select the Popout Highlight. 

2. Click the Highlight Properties button on the Context Sensitive Toolbar. 

3. In the Highlight Properties make your edits as needed for the name, location, 
size, timing and fade animation 

4. Click OK to apply and close the dialog. 

 
 
To modify EFFECT properties: 

1. In the Timeline tab, select the Popout Highlight. 

2. Click the Effect Properties button on the Context Sensitive Toolbar. 

3. In the Effect Properties dialog that displays: 

a. Select the Duration you want the Popout Effect to display. The longer the 
duration, the longer the transition from pop out to “pop back in” will be. 

b. Select the Amount (percentage) for the size of the pop out area. The 
higher the percentage, the bigger the pop out image on playback. 

4. Click OK. 

 
Note: You can also add a shadow effect or create/apply a standard/custom style to the 
stylesheet. Please refer to these specific topics covered elsewhere in this guide. 

 

To DELETE a Popout Highlight: 

1. In the Timeline tab, select the Popout Highlight. 

2. Click the Delete button. 
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MATTE 
The Matte highlighter lets you  provide focus on an area of the slide while blocking out 
the rest of it. This section covers information for working with this feature. 
 

 
 
To INSERT a Matte: 

1. Select the thumbnail of the slide you want to work on. 

2. In the Timeline tab, click a frame to display the playhead (switching to Time 
Select Mode). This will be where the Matte will be inserted. 

3. Select Insert > Elements > Matte from the Menu bar. 

4. The cursor changes to a cross-hair shape as you move it over the slide. Hold 
down the left mouse button as you draw the Matte area. Let go to set it 

5. Move and resize the Matte area as needed, placing it over the area of the slide 
you want to focus on. 

6. Click off the element to set it. 

7. Repeat these steps to insert each additional Mattes along the timeline. 
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8. Preview results by: 

a. Dragging the playhead to scrub the timeline. 

b. Playing back the results in the browser or within the authoring application.  
 

 
To access the Properties dialog: 

1. In the Timeline tab, select the Matte. 

2. Click the Highlight Properties button on the Context Sensitive Toolbar. 

3. In the Highlight Properties make your edits as needed for the name, location, 
size, timing and fade animation 

4. Click OK to apply and close the dialog. 

 
To modify SHADED AREA fill color and opacity level: 

1. In the Timeline tab, select the Matte. 

2. To change the background color: 

a. Click the Background Color button on the Context Sensitive Toolbar. 

b. In the Background Color dialog, make your selections. 

c. Click OK to save settings and to close the dialog. 

d. Enter a number for the Opacity (%) level.  

3. To change the border color: 

a. Click the Border Color button on the Context Sensitive Toolbar. 

b. In the Border Color dialog, make your selections. 

c. Click OK to save settings and to close the dialog. 

d. Enter a number for the Border Width. 
 
Note: You can also apply a fade animation or create/apply a standard/custom style to the 
stylesheet. Please refer to these specific topics covered elsewhere in this guide.  

 

To DELETE a Matte: 

1. In the Timeline tab, select the Matte. 

2. Click the Delete button. 
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COLOR HIGHLIGHT 
Use the Color Highlight to focus on one or more areas of a slide by using a color 
highlight set at a specific opacity level.  
 

 
 
To INSERT a Color Highlight: 

1. Select the thumbnail of the slide you want to work on. 

2. In the Timeline tab, click a frame to display the playhead (switching to Time 
Select Mode). This will be where the Color Highlight will be inserted. 

3. Select Insert > Elements > Color Highlight from the Menu bar. 

4. The cursor changes to a cross-hair shape as you move it over the slide. Hold 
down the left mouse button as you draw the highlight area. Let go to set it. 

5. Move and resize the highlight area as needed, placing it over the area of the 
slide you want to focus on. 

6. Click off the element to set it. 

7. Repeat these steps to insert each additional Color Highlights along the timeline. 

8. Preview results by: 
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a. Dragging the playhead to scrub the timeline. 

b. Playing back the results in the browser or within the authoring application.  
 

 
To access the Properties dialog: 

1. In the Timeline tab, select the Color Highlight. 

2. Click the Highlight Properties button on the Context Sensitive Toolbar. 

3. In the Highlight Properties dialog make your edits as needed for the name, 
location, size, timing and fade animation 

4. Click OK to apply and close the dialog. 

 
 
To modify the Color Highlight’s COLOR and OPACITY: 

1. In the Timeline tab, select the Color Highlight. 

2. To change the background color: 

a. Click the Highlight Color button on the Context Sensitive Toolbar. 

b. In the dialog that displays, make your selections. 

c. Click OK to save settings and to close the dialog. 

d. Enter a number for the Opacity (%) level. 

 
Note: You can also add a Fade Animation or create/apply a standard/custom style to the 
stylesheet. Please refer to these specific topics covered elsewhere in this guide.  

 

To DELETE a Color Highlight: 

1. In the Timeline tab, select the Color Highlight. 

2. Click the Delete button. 
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Sound 
ViewletBuilder8 Enterprise offers several different options for enhancing your Viewlets 
with sound. Let take a look at the features available. 
 
Note: Sound can be added to directly to Main Timeline or Question Bank slides and to slide 
elements on those slides. Sound CANNOT be added to master slides. 
 

SOUND RECORDING DURING VIDEO CAPTURE 
You can set sound recording options when creating new Video Capture projects or 
Video slides. 
 

 
1. At the point where you select the actual Capture Profile used for your new video 

capture session the Capture Options dialog displays. In that dialog, select the 
General tab. 

2. In the Sound Recording area, select the Record Sound During Capture button. 

3. Click the Recording Options button. The Recording Options dialog displays. 

4. In the dialog, make your selections in the following areas: Input Device, Quality, 
Format and Microphone Latency. 

5. Click OK to save these recording settings. 
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6. Click OK to close the Capture Options dialog. 

7. Click OK to close the Capture Profiles dialog. 

8. Click OK to start the video capture session with sound recording enabled. 
 

SUPPORTED SOUND FORMATS 
ViewletBuilder8 Enterprise supports the following imported sound file formats: 

 MP3 
 WAV 
 RAW 
 AIF 
 AU 

 
The size of the sound file will have an impact on the project size both in the authoring 
application as well as in the published file. You will have options for compressing sound 
for the published files(Project > Project Properties > Sound Quality). 
 

RECORDING AUDIO... 
Sound can be recorded during a video capture session (covered earlier) and while 
editing the project. This section provides instructions for recording sound within 
ViewletBuilder8 Enterprise. 
 

Directly on Slides 
Sounds may be added directly to slides that reside on the Main Timeline or within 
Question Banks. Each time a sound is added, a new Sound layer is created, therefore, 
multiple sound files may be added directly to the same slide. 
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Main Timeline Slides 
To RECORD sound applied directly to a slide on the Main Timeline: 

 
 

1. In the Slides tab, select the slide thumbnail. 

2. In the Timeline tab, click on a frame so the playhead displays. This is where the 
Sound layer will be inserted. 

3. Click the Insert Sound button on the Object Toolbar. 

4. In the Insert Sound dialog that displays: 

a. Click the Recording Options button. 

i. In the Recording Options dialog, select options in the following 
areas: 

1. Input Device: Choose the device to use for recording the 
sound. 

2. Quality: Select a sample rate, sample size and stereo 
setting. 

3. Format: Select a recording format (WAV or MP3). 

4. Countdown Timer: Enter a number for the amount of time 
(in seconds) for a countdown animation to display. 

5. Microphone Latency: Enter a number for an added 
microphone delay (in milliseconds). 

6. Click OK to save options and to close the Recording 
Options dialog. 
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b. Optional: Select the Preview Viewlet While Recording option if desired. 

c. Click the Record button. The countdown animation will count down the 
delay prior to recording. Once it disappears, start the sound recording. 

d. Click the Stop button end the sound recording. 

e. Click the Play button to review the sound recording. 

f. Optional: Use the Previous Slide or Next Slide  button to go back / 
advance one slide for additional sound recordings without closing the 
dialog. 

g. Optional: Click the Closed Captions button to add a Closed Caption 
element. 

h. Click OK to save the recording and create the new Sound layer. 

i. Repeat these steps for each additional sound layer. 

 
Note: ViewletBulder8 Enterprise uses the MP3 format for sound recorded directly inside the 
authoring application to keep down the project’s source file size. 
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Question Bank Slides 
To RECORD sound applied directly to Question Bank slides: 

 
 

1. In the Question Banks tab, select the question bank. 

2. Select the question slide thumbnail. 

3. Click the Insert Sound button on the Object Toolbar. 

4. In the Insert Sound dialog that displays: 

a. Click the Recording Options button. 

i. In the Recording Options dialog, select options in the following 
areas: 

1. Input Device: Choose the device to use for recording the 
sound. 

2. Quality: Select a sample rate, sample size and stereo 
setting. 

3. Format: Select a recording format (WAV or MP3). 

4. Countdown Timer: Enter a number for the amount of time 
(in seconds) for a countdown animation to display. 
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5. Microphone Latency: Enter a number for an added 
microphone delay (in milliseconds). 

6. Click OK to save options and to close the Recording 
Options dialog. 

b. Click the Stop button end the sound recording. 

c. Click the Play button to review the sound recording. 

d. Optional: Use the Previous Slide or Next Slide  button to go back / 
advance one slide for additional sound recordings without closing the 
dialog. 

e. Optional: Click the Closed Captions button to add a Closed Caption 
element. 

f. Click OK. 

g. Repeat these steps as needed. 

 
Note: ViewletBulder8 Enterprise uses the MP3 format for sound recorded directly inside the 
authoring application to keep down the project’s source file size. 

 

On Slide Elements 
Whenever a speaker icon is visible along a selection’s Context Sensitive Toolbar, this 
indicates that sound can be added. 
 

 
 
To RECORD sound for a slide element:  

1. Select the slide element. 

2. Click the Attach Sound to... button along the selection’s Context Sensitive 
Toolbar.  

3. In the Insert Sound dialog that displays: 

a. Click the Recording Options button. 

ViewletBuilder8 Enterprise User Guide Page 170  © 2014 rev. 0626 



 
 
 

i. In the Recording Options dialog, select options in the following 
areas: 

1. Input Device: Choose the device to use for recording the 
sound. 

2. Quality: Select a sample rate, sample size and stereo 
setting. 

3. Format: Select a recording format (WAV or MP3). 

4. Countdown Timer: Enter a number for the amount of time 
(in seconds) for a countdown animation to display. 

5. Microphone Latency: Enter a number for an added 
microphone delay (in milliseconds). 

6. Click OK to save options and to close the Recording 
Options dialog. 

b. Click the Stop button end the sound recording. 

c. Click the Play button to review the sound recording. 

d. Optional: Click the Closed Captions button to add a Closed Caption 
element. 

e. Click OK. 

4. Repeat these steps as needed. 
 

IMPORTING SOUND... 
In addition to recoding sound, you can also import sound files and attach them to slides 
and slide elements. Several different sound file formats are supported (as discussed 
earlier in this guide). 
 

 
 

ViewletBuilder8 Enterprise User Guide Page 171  © 2014 rev. 0626 



 
 
 
Directly on Slides 
To IMPORT sound directly on a slide: 

1. On the Main Timeline: 

a. In the Slides tab, select a slide thumbnail. 

b. In the Timeline tab, select a frame so the playhead displays. This is 
where the Sound layer will be inserted. 

2. Within a Question Bank: 

a. In the Question Banks tab, select a question bank. 

b. Select a question slide thumbnail. 

3. Click the Insert Sound button on the Object Toolbar. The Insert Sound dialog 
displays. 

a. In the Insert Sound dialog, click the Load Sound button. 

b. In the Load Sound dialog, locate and select your sound file and click 
Open.  

c. Click the Play button to review the sound recording. 

d. Optional: Use the Previous Slide or Next Slide button to go back / 
advance one slide for additional sound recordings without closing the 
dialog. 

e. Optional: Click the Closed Captions button to add a Closed Caption 
element. 

4. Click OK. A Sound layer is added to the slide for the imported sound file. 

5. Repeat these steps as needed. 

 

On a Slide Element 
To IMPORT sound for a slide element: 

1. Select the slide element. 

2. Click the Attach Sound to... button on the selection’s applicable Context 
Sensitive Toolbar. 

3. In the Sound dialog, click the Load Sound button. 

4. In the Load Sound dialog, locate and select your sound file and click Open. 

5. Click the Play button to review the sound recording. 

6. Optional: Click the Closed Captions button to add a Closed Caption element. 

7. Click OK. A speaker icon will display next to the selection indicating a sound file 
is attached. 

 

ViewletBuilder8 Enterprise User Guide Page 172  © 2014 rev. 0626 



 
 
 
DELETING SOUND 
This section covers the steps for removing sound layers from slides and sound from 
selected slide elements. 

 
  

To DELETE a sound layer: 
1. In the Slides tab, select the slide. 

2. In the Timeline tab, select the Sound layer. 

3. Click the Delete button on the Main Toolbar. 

 

To DELETE sound attached to a slide element: 
1. Select the slide element that contains the sound you want to remove. 

2. Click the Attach Sound button along the selection’s Context Sensitive Toolbar. 

3. In the Sound dialog, click the Delete Sound button. 

4. Click OK to exit the Sound dialog. 
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EXPORTING SOUND 
If your Viewlet project contains sound, you can export it out as individual sound files. 
 

 
 
To EXPORT sound from the project: 

1. Optional: Create a file outside of ViewletBuilder8 Enterprise. You will save your 
exported sound file in this folder. 

2. Select File > Export > Sounds from the Menu bar. 

3. In the Export Sounds dialog, select the slides to export: 

a. Current Slide: Only the sound attached to the current slide and any 
attached to slide objects will be exported. 

b. From: Enter a starting slide number in the first field and an ending slide 
number in the second field. Sound attached to the slides (and objects on 
the slides) in this sequence will be exported. 

c. All: All sound attached to slides and slide objects will be exported. 

4. In the Save File In dialog, select a folder to save the exported audio files in. 

5. Click the Save button. 
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EVENT – ACTION ‘PLAY SOUND’ FEATURE 
There is a Play Sound action that you can add to an event. This section provides 
instructions for working with this feature. 
 

 
1. Click the Events icon for adding a desired event. 

2. In the Events dialog, select the desired event tab (if applicable). 

3. Click the Add button. The Action dialog displays. 

4. In the Action dialog, select Play Sound from the list of actions. The dialog 
expands with additional options for working with the Play Sound action. 

5. You have two options for the sound. To: 

a. Import a sound file: 

i. Click the Browse icon to locate, select and Open the sound file to 
load it in the Action dialog. 

b. Record a sound file: 
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i. Click the Recording Options button. 

ii. Make your selections in the Recording Options dialog for input 
device, quality, format , countdown timer and microphone latency. 

iii. Click OK to close the Recording Options dialog.  

6. In the Synchronicity area, select the Wait for the sound to complete before 
advancing to the next action or slide if desired. 

7. In the Concurrency area, select either: 

a. Concurrent Playback – Play concurrently with other sounds. 
b. Privileged Playback – Stop all other even sounds. 
c. Exclusive Playback – Stop all other sounds. 

8. Click OK to save options and to close the Action dialog. 

9. In the Events dialog, the Play Sound action is added to the list. Repeat these 
steps as needed. 

10. Click OK to close the Events dialog. 

 

MUTE – UNMUTE SOUND ACTIONS 
There are two ‘action’ options available to mute and unmute sound automatically when 
the Viewlet is played. 
 

  
These are available in the Action dialog list as: 
 
 Mute Audio: Mute all audio playing in the Viewlet. 
 Unmute Audio: Unmute audio previously muted with the Mute Audio Action. 

 
These work in tandem with the speaker icons on the Viewlet’s player bar, indicating 
when the sound is muted or unmuted. 
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CLOSED CAPTIONS 
If your audience is hearing impaired and your Viewlet contains sound, you can add a text 
version of the sound known as Closed Captions. This feature is available for both 
recorded and imported sound as well as for sound attached directly to a slide or slide 
elements. 
 
Closed Captions are accomplished in two parts: 
 

Sound Dialog Setup 
You enter text for the Closed Caption in the Sound dialog associated with the sound file 
that is attached to the slide or slide element. After that, you will need to also insert a 
Closed Caption text box on to the slide for the Closed Caption to display on playback. 
 

 
 

1. In the Sound dialog, record or import a sound. You must do this first to enable 
the Closed Captions feature. 

2. Click the Closed Captions button. The dialog expands providing access to the 
Closed Captions options. 

3. Click the Add button. 

4. In the Caption dialog: 

a. Enter a number for the Start Time. 
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b. Enter a number for the End Time. 

c. Enter text to be used for the closed captions. 

d. Click OK to close the Caption dialog. 

5. Click OK to save the Closed Caption text and to exit the Sound dialog. 

6. Proceed to the next section, which covers working with the Closed Caption text 
box on the slide. 

 

Closed Caption Text Box 
One you enter text for the Closed Caption in the Sound dialog associated with the sound 
file that is attached to the slide or slide element, the next step is to insert a Closed 
Caption text box on to the slide for the Closed Caption to display on playback. 
 

 
 

1. Select the slide where you want to insert the Closed Caption text box. 

2. Click the Insert Closed Caption button on the Object Toolbar. A Closed 
Caption layer and text box are added to the slide. This text box displays the text 
set up for Closed Captions previously in the Sound dialog. 

3. Optional: By default, the Closed Caption element is locked to prevent it from 
being edited. Click the Locked padlock icon to unlock the layer. 
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4. You can resize and move the text box on the slide. Also, use the Closed 
Captions Context Sensitive Toolbar to edit the text box as needed. Unlike a 
regular slide text box, you CANNOT edit the text itself directly in the text box on 
the slide. You need to go back into the Sound dialog to do this. 

5. Optional: Click the Unlocked padlock icon to lock the layer again to prevent it 
from being edited. 

 

Modify & Delete 
There are two places where you can modify the Closed Caption element: Sound dialog 
and directly on the slide using the Context Sensitive Toolbar. 
 
To MODIFY the Closed Caption text: 

1. Select the slide that has the Closed Caption element. 

2. Select the slide itself or the slide element (if applicable). 

3. Click Sound icon on the Object Toolbar or the applicable Context Sensitive 
Toolbar. 

4. In the Sound dialog, select the Closed Caption text (in the bottom section of the 
Sound dialog in the Caption column). 

5. Click the Modify button. 

6. In the Caption dialog, make your edits as needed. 

7. Click OK to save the changes and to close the dialog. 

8. Click OK to close the Sound dialog. 

 

To MODIFY the Closed Caption text box: 

1. Select the slide that has the Closed Caption layer. 

2. If the layer is locked, click the Locked padlock icon to unlock it for editing. 

3. Make your edits as needed. 

4. Click the Unlocked padlock icon to lock the layer again to prevent further editing. 

 

To DELETE the Closed Caption text: 
1. Select the slide that has the Closed Caption element. 

2. Select the slide itself or the slide element (if applicable). 

3. Click Sound icon on the Object Toolbar or the applicable Context Sensitive 
Toolbar. 

4. In the Sound dialog, select the Closed Caption text (in the bottom section of the 
Sound dialog in the Caption column). 

5. Click the Delete button. 

6. Click OK to close the Sound dialog. 
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To DELETE the Closed Caption text box: 

1. Select the slide that has the Closed Caption layer. 

2. If the layer is locked, click the Locked padlock icon to unlock it for editing. 

3. Select the Closed Caption layer. 

4. Click the Delete button on the Main Toolbar. 

 

BACKGROUND SOUNDTRACK 
You can add a background soundtrack to the project. This option is available in the 
Project Properties dialog. Instructions for adding a background sound track are covered 
later in this guide. 
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Images 
Images may be used in projects in a few different ways. One option is to create an entire 
project made up of image files. When creating image projects or when inserting image 
slides, images are embedded as slide background frames.  When used in this way, 
images cannot be moved around the slide. 
 
Note: Multiple images may be used as part of a slide’s background frames. See the chapter on 
“Background Frames” for more information. 
 
You may also insert images onto slides as slide objects. When inserted on the slide, 
images may be resized, moved on the slide, converted to a hyperlink object, become a 
rollover event, have its transparency level modified and more. And, multiple images may 
be inserted on the same slide. 
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Supported image file formats include: 

 JPEG 
 GIF 
 TIFF 
 PNG 
 BMP 

 
Let’s look at some ways to work with images and slides. 
 
To INSERT an image on to a slide: 

1. Select the slide you want to insert the image on. 

2. Click the Insert Image button on the Object Toolbar. 

3. In the Insert an Image dialog, browse to locate the image file. 

4. Select the image file and click Open. The image is inserted on the slide, ready 
for editing. 

 
To MOVE an image: 

1. Select the image by clicking on it. 

2. Move your cursor over the image and when the cursor changes to a hand shape, 
hold down the left mouse button. 

3. Drag the image (while holding down the left mouse button) to its new location on 
the slide. 

 
To RESIZE an image: 

1. Select an image by clicking on it. 

2. Point your cursor over one of the grab handles. 

3. When the cursor changes to an arrow, hold down your left mouse button. 

4. Drag the grab handle (while holding down the left mouse button) to resize the 
image. 

 

To change an image’s OPACITY level: 

1. Select an image by clicking on it. 

2. Enter a number for the Opacity (%) on the Context Sensitive Toolbar. 

3. Press Enter to apply. 

 
To ARRANGE images (and other objects) in a stack: 

1. Right click on the image. 

2. Select Arrange from the shortcut menu. 

3. Select an arrangement option. 
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To ROTATE an image: 

Please refer to the Rotate Tool chapter for more information. 

 
To ACCESS image properties: 

1. Click on the image to select it. 

2. Click the Image Properties button on the Context Sensitive Toolbar. 

3. In the Image Properties dialog, view and edit the selections as needed. 

4. Click OK to close the Image Properties dialog. 
 
 
To create an IMAGE EVENT: 

1. Click on the image to select it. 

2. Click the Events button on the Context Sensitive Toolbar. 

3. In the Image Events dialog, select an events tab and choose the desired action. 

4. Click OK to apply. 
 
 
To DELETE an image: 

1. Select the image. 

2. Click the Delete button on the Context Sensitive Toolbar.  
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Background Frames 
Project slides may contain embedded images known as Background Frames. This 
chapter discusses how to work with single and multiple slide background frames, an 
important component of many Viewlet projects. 

 

BACKGROUND FRAMES – SINGLE FRAME 
You can have one or more background frames on a slide. When you have just a single 
background frame, the slide’s background area is static during that slide’s playback. This 
section discusses working with a single background frame. 
 

 
 

To ACCESS the Background Frames dialog: 

1. Select the slide. 

2. Right click and select Background Frames. The Background Frames dialog 
displays. (You can also double click on the frame along the Timeline to display 
the Background Frames dialog.) 

 

To ADD / EDIT a background frame to a slide: 

1. Select the slide. 

2. Right click and select Background Frames. The Background Frames dialog 
displays. 

3. In the Background Frames dialog: 

a. To add a frame: 

i. Click the Add Frame button. 

ii. In the dialog that opens: 
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1. Click Browse to locate, select and Open an image to use 
as the background frame. 

2. In the Options area, select Key Frame, if applicable. 

3. Select options for the frame’s Location & Duration. 

4. Click OK to close this dialog. 

iii. To select another frame: 

1. Click the Load Image button. 

2. In the dialog that displays, locate, select and Open an 
image to use as the background frame. 

3. Click OK to close this dialog. 

b. Select an Alignment option from the list. 

c. To preview an frame image, click the Show Preview button. Use the 
zoom buttons on the preview pane to zoom the preview area. 

d. To hide the preview pane, click the Hide Preview button. 

e. Click OK to save options and to exit the Background Frames dialog. 

 

To DELETE a background frame: 

1. Select the slide. 

2. To remove the background frame from the slide: 

a. From the Timeline tab: 

i. Select the Background Frame layer. 

ii. Click the Delete button. 

b. From the Background Frames dialog: 

i. Right click on the slide and select Background Frames from the 
shortcut menu. 

ii. In the dialog that displays, click the Remove Background button. 

iii. Click OK to exit the Background Frames dialog. 
 
 

BACKGROUND FRAMES – MULTIPLE FRAMES 
Slides may be comprised of multiple background frames. This most commonly happens 
when creating projects using Smart Capture. Slides containing multiple background 
frames are animated during playback on the slide itself (similar to an animated GIF file). 
To edit a slide with multiple background frames, you will use the same steps as you 
would with the steps outlined for modifying a slide with a single background frame. There 
are, of course, a few additional options since you are working with multiple frames. 
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Key Frame 
Frames added after the first frame may or may not be key frames. If marked as a key 
frame, the key frame will completely replace the previous image in the sequence. If a 
frame is not marked as a key frame, the frame is just “painted” on top of the previous key 
frame, like an additional image layered on top of it. 
 
After creating a Screen Capture Project or adding new screenshots using Smart 
Capture, if you look at a slide that has multiple background frames on it, you will see that 
all but the first frame are NOT key frames. 
 
To ENABLE / DISABLE a Key Frame: 

1. In the Background Frames dialog, double click a frame. 

2. In the Background Frame dialog, select / deselect the Key Frame option. 

3. Click OK. 
 
 
To MOVE a frame up/down in the list: 

1. In the Background Frames dialog, select the frame in the list. 

2. Click the Move Up button to move the frame up in the list. 

3. Click the Move Down button to move the frame down in the list. 
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Shadow Effect 
Enhance slide objects with the addition of a shadow. The Shadow tool allows you to add 
a shadow effect to most slide objects such as cursors, images, shapes, message 
objects, etc. And, it’s very easy to do! 
 

 
 
To ADD a Shadow to a slide object: 

1. Select the slide object (such as an image, for example) to load its Context 
Sensitive Toolbar. 

2. Select the Shadow Properties  button (if available) from the Context Sensitive 
Toolbar.  

3. In the Shadow Properties dialog that displays: 

a. Deselect the check box next to the No Shadow option. 

b. In the Properties area, make selections for Left Offset, Top Offset, Blur 
Radius, Opacity and Color. 

c. Click Apply to see the results BEFORE closing the Shadow Properties 
dialog and make adjustments as needed with your selections. 

d. When satisfied, click OK to save your shadow selections. 
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To REMOVE a shadow effect: 

1. Select the slide object (such as an image, for example) to load its Context 
Sensitive Toolbar. 

2. Select the Shadow Properties button from the toolbar.  

3. In the Shadow Properties dialog that displays, select the check box next to the 
No Shadow option. 

4. Click OK to apply. 
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Shapes (Rectangle, Ellipse, Lasso, Poly Lasso) 
Using the various Shape tools, you can create different shapes. These tools include: 

 Rectangle: Creates rectangles and squares. 

 Ellipse: Creates circles and ovals. 

 Lasso: Creates free-form shapes. 

 Poly Lasso: Creates polygonal shapes. 
 
Note: Lines and arrows are also available, but specific instructions for creating these are covered 
later in this guide. 
 

CREATING SHAPES   
This section provides instructions for creating a shape using one of the four shape tools 
(rectangle, ellipse, lasso, poly lass) available on the Shape Context Sensitive Toolbar. 
 
To CREATE a rectangle: 
 

 
 

1. Click the Insert Shape button on the Object Toolbar. 

2. Click the Rectangle Tool button on the Context Sensitive Toolbar. 

3. Move the cursor over the slide until the cursor changes to a cross-hair shape. 

4. Click on the slide and hold down the left mouse button. 

5. Continue to hold down the left mouse button and drag to draw the rectangular 
shape. 

6. Let go of the left mouse button to complete the shape. 
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To CREATE an ellipse: 
 

 
 

1. Click the Insert Shape button on the Object Toolbar. 

2. Click the Ellipse Tool button on the Context Sensitive Toolbar. 

3. Move the cursor over the slide until the cursor until the cursor changes to a 
cross-hair shape. 

4. Click on the slide and hold down the left mouse button. 

5. Continue to hold down the left mouse button and drag to draw the elliptical 
shape. 

6. Let go of the left mouse button to complete the shape. 

 
 
To CREATE a free-form shape using the Lasso tool: 
 

 
 

1. Click the Insert Shape button on the Object Toolbar. 

2. Click the Lasso Tool button on the Context Sensitive Toolbar. 
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3. Move the cursor over the slide until the cursor changes to a lasso shape. 

4. Hold down the left mouse button and draw your shape. 

5. Let go of the left mouse button when the free-form shape is complete. 
 
 
To CREATE a polygonal shape using the Poly Lasso: 
 

 
 

1. Click the Insert Shape button on the Object Toolbar. 

2. Click the Poly Lasso Tool button on the Context Sensitive Toolbar. 

3. Move the cursor over the slide until the cursor changes to a poly lasso shape. 

4. Click on the slide to insert the first “anchor” point. 

5. Drag the cursor to form the first leg of the polygon. 

6. Click again to insert the next anchor point. 

7. Drag the cursor again to form the next leg of the polygon. 

8. Continue repeating these steps until the polygon shape is formed. 

 
 

MODIFYING SHAPES 
Once you create your rectangle, ellipse, free-form or polygonal shape, you can then 
move, resize, recolor, and arrange them for create custom effects. 
 
To MOVE a shape: 

1. Click the shape to select it. 

2. Move your cursor over the shape until the cursor becomes a grab hand shape. 

3. Hold down the left mouse button and drag the shape to move it. 
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To RESIZE a shape: 

1. Click the shape to select it. 

2. Move your cursor over one of the grab handles until the cursor changes to an 
arrow shape. 

3. Hold down the left mouse button and drag to resize the shape. 
 
 
To ARRANGE the shape in a stack: 

1. Click the shape to select it. 

2. Right click and select Arrange from the shortcut menu. 

3. Select one of the arrange options to move the shape to that position in the stack. 

 

To ROTATE a shape: 

1. Click the shape to select it. 

2. Move your cursor over the extended “circular” gnode until the cursor changes to 
a circular arrow. 

3. Hold down the left mouse button and drag to rotate the image. 

 
To DELETE a shape: 

1. Click the shape to select it. 

2. Click the Delete button on the Main Toolbar. 
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Lines & Arrows 
Use the Line & Arrow tool to create different line and arrows shapes. This sections 
provides information for working with this tool. 
 

LINES 
 

 
 

To CREATE a line: 

1. Select the Line or Arrow Tool button from the Objects Toolbar. 

2. Click the Line Tool button from the Context Sensitive Toolbar. 

3. The cursor changes to a cross-hair shape. Drag the cursor on the slide to draw 
the line shape. 

4. Let go of the left mouse button to complete the line shape. 

5. Edit the line attributes using any of the buttons along the Context Sensitive 
Toolbar. 

6. Click off of the line when finished. 

 

To RESIZE a line: 

1. Select the line. 

2. Point your cursor over one of the ends of the line until the cursor changes to a 
four-headed arrow. 

3. Hold down the left mouse button and drag to resize. 

4. Let go of the left mouse button when done. 

 

To change the line’s color: 
1. Select the line object. 

2. Click the Line Color button from the Context Sensitive Toolbar. 

3. In the dialog that displays, select a color from the Swatches or Rainbow tab. 

4. Click OK to save the change. 
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To change the line’s opacity: 

1. Select the line object. 

2. Set a number for the Opacity (%) percentage. 

3. Press Tab or Enter or click out of the number field to apply 

 

To change the line’s width: 

1. Select the line object. 

2. Set a number for the Line Width. 

3. Press Tab or Enter or click out of the number field to apply. 

 

To change the line’s style: 

1. Select the line object. 

2. Select a new style from the Line Style list. 

 

To MOVE a line: 

1. Select the line. 

2. Point your cursor over the line until the cursor changes to a hand shape. 

3. Hold down the left mouse button and drag the line. 

4. Let go of the left mouse button to drop it into place. 

 

To ROTATE a line: 

1. Select the line. 

2. Point your cursor over one of the ends until the cursor changes to a four-headed 
arrow shape. 

3. Hold down the left mouse button and drag to rotate the line along its opposite 
end. 

4. Let go of the left mouse button to complete the rotation. 

 

To ARRANGE a line: 

1. Select the line. 

2. Right click and select Arrange from the shortcut menu. 

3. Select an arrangement option to use for the line in the stack. 
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To DELETE a line: 

1. Select the line. 

2. Click the Delete button on the Main Toolbar. 
 

Note: You can also add a Shadow, Events/Actions, Rollovers and Sounds to any line. Please see 
the applicable chapters for more information on these features. 
 
 

ARROWS 
 

 
 

To CREATE an arrow: 

1. Select the Line or Arrow Tool button from the Objects Toolbar. 

2. Click the Arrow Tool button from the Context Sensitive Toolbar. 

3. The cursor changes to a cross-hair shape. Drag the cursor on the slide to draw 
the arrow shape. 

4. Let go of the left mouse button to complete the arrow shape. 

5. Edit the arrow attributes using any of the buttons along the Context Sensitive 
Toolbar. 

6. Click off of the arrow when finished. 
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To RESIZE a line: 

1. Select the arrow 

2. Point your cursor over one of the ends of the arrow until the cursor changes to a 
four-headed arrow. 

3. Hold down the left mouse button and drag to resize. 

4. Let go of the left mouse button when done. 

 

To change the arrow’s background (fill) color: 
1. Select the arrow object. 

2. Click the Background Color button from the Context Sensitive Toolbar. 

3. In the dialog that displays, select a color from the Swatches or Rainbow tab. 

4. Click OK to save the change. 

 

To change the arrow’s opacity: 

1. Select the arrow object. 

2. Set a number for the Opacity (%) percentage. 

3. Press Tab or Enter or click out of the number field to apply 

 

To change the arrow’s border color: 
1. Select the arrow object. 

2. Click the Border Color button from the Context Sensitive Toolbar. 

3. In the dialog that displays, select a color from the Swatches or Rainbow tab. 

4. Click OK to save the change. 

 

To change the arrow’s border width: 

1. Select the arrow object. 

2. Set a number for the Border Width. 

3. Press Tab or Enter or click out of the number field to apply. 

 

To change an arrow’s Start Cap: 

1. Select the arrow object. 

2. Enter a number in the Start Cap Scale Factor number field. 

3. Select an Arrow Start Cap Style from the list. 
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To change an arrow’s End Cap: 

1. Select an arrow object. 

2. Enter a number in the End Cap Scale Factor number field. 

3. Select an Arrow End Cap Style from the list. 

 

To ROTATE an arrow: 

1. Select the arrow. 

2. Point your cursor over one of the ends until the cursor changes to a four-headed 
arrow shape. 

3. Hold down the left mouse button and drag to rotate the arrow along its opposite 
end. 

4. Let go of the left mouse button to complete the rotation. 

 

To ARRANGE an arrow: 

1. Select the arrow. 

2. Right click and select Arrange from the shortcut menu. 

3. Select an arrangement option to use for the arrow in the stack. 

 

To DELETE an arrow: 

1. Select the arrow. 

2. Click the Delete button on the Main Toolbar. 

 
Note: You can also add a Shadow, Events/Actions, Rollovers and Sounds to any arrow. Please 
see the applicable chapters for more information on these features. 
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Rotate Tool 
The Rotate tool allows you to rotate an individually selected slide object such as an 
inserted image or shape up to 360 degrees clockwise or counter clockwise. 
 
To rotate a selected image or shape (created with rectangle, ellipse, lasso or poly lasso 
shape tools): 
 

 
 

1. Select the desired inserted image or shape. 

2. Point your cursor over the extended circle gnode (usually at the top center) until 
the cursor changes to a circular arrow shape. 

3. Hold down your left mouse button and drag left or right to rotate. 

4. Let go of the left mouse button when satisfied to complete the rotate operation. 

 

To rotate a selected shape created using the line or arrow tool: 

     
1. Select the desired inserted line or arrow. 

2. Point your cursor over one of its edge gnodes until the cursor changes to a four-
headed arrow shape. 

3. Hold down your left mouse button and drag left or right to rotate. 

4. Let go of the left mouse button when satisfied to complete the rotate operation. 
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Fade Animation 
Add visual dimension to slide objects as they play back on your slides using Fade 
Animation. This feature allows you to apply fading effects to slide objects along the 
timeline or while working in the slide objects Properties dialog. 
 

PROPERTIES DIALOG 
This section provides instructions for working with the Fade Animation (when available) 
in a selection’s Properties dialog. 
 

 
 
To ENABLE a fade animation: 

1. Select the slide object you want to add a fade animation to. 

2. Click the Properties button along the selection’s Context Sensitive Toolbar. 

3. In the Properties dialog that displays, select the Enable Fade Animation option. 

4. In the Fade Animation Options area: 

a. Duration In: Enter a number (in seconds) for the amount of time the fade 
animation will take as the slide object displays on the timeline. 

b. Duration Out: Enter a number (in seconds) for the amount of time the 
fade animation will take as the slide object reaches its ending time on the 
timeline. 

5. Click OK to apply. 

 

To DISABLE a fade animation: 

1. Select the slide object containing the fade animation. 

2. Click the Properties button along the selection’s Context Sensitive Toolbar. 

3. In the Properties dialog that displays, deselect the Enable Fade Animation 
button. This disables the fade animation options. 

4. Click OK to apply. 

 
  

ViewletBuilder8 Enterprise User Guide Page 199  © 2014 rev. 0626 



 
 
 
TIMELINE EDITING 
This section provides instructions for working with the Fade Animation (when available) 
while working with slide objects on the timeline. 
 

 
 
To ADD a fade animation: 

1. In the Timeline tab, select a slide element. 

2. Click the Fade Animation button on the selection’s Context Sensitive Toolbar. 
The selection’s indicator box along the timeline is divided into two additional 
sections, showing a fade animation applied to the start and end times. 

 

To REMOVE a fade animation: 

1. In the Timeline tab, select a slide element containing a fade animation. 

2. Click the Fade Animation button on the selection’s Context Sensitive Toolbar to 
deselect (remove) the fade animation form the selected object. 

 

To INCREASE / DECREASE a fade animation’s duration in / duration out times: 

1. In the Timeline tab, select the slide object’s layer. 

2. To change the fade animation’s: 

a. Duration In time: 
 

 
 

i. Point your cursor over the inner edge of the slide object’s indicator 
(second vertical line) until it changes to an arrow shape. 

ViewletBuilder8 Enterprise User Guide Page 200  © 2014 rev. 0626 



 
 
 

ii. Hold down the left mouse button and drag left to decrease  the 
time or drag right to increase the time for the fade animation to 
fade in. 

iii. Let go of the left mouse button to set. 

b. Duration Out time: 
 

 
 

i. Point your cursor over the inner edge of the slide object’s indicator 
(third vertical line) until it changes to an arrow shape. 

ii. Hold down the left mouse button and drag left to increase the time 
or drag right to decrease the time for the fade animation to fade 
out. 

iii. Let go of the left mouse button to set. 
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Grouped Objects (Alignment, Distribution, Sizing, Time) 
ViewletBuilder8 Enterprise offers various alignment, distribution and sizing tools when 
working with multiple objects. This chapter provides an overview of working with these 
options. 
 

ALIGNMENT TOOLS 

 
 
Alignment tools are available for selected objects. The alignment tools are divided into 
two sections: 

1. Aligning selected objects within the group’s “bounding” box (as indicated by the 
dotted rectangle surrounding the selected objects). 

2. Aligning selected objects on the slide. 
 

 
To align two or more selected objects within the group’s “bounding” box: 

1. Click on the first object to select it. 

2. Hold down the Ctrl key while clicking to select additional objects. A “bounding 
box” surrounds the selected objects. It will be inside this bounding box area that 
the alignment will occur. 

3. Click the applicable “group alignment” button for the selected objects. 
 

 
To align a single or multiple objects on a slide: 

1. Select the object to select it. 

2. If selecting multiple objects, hold down the Ctrl key while clicking on additional 
objects to select them. 

3. Click the applicable “slide alignment” button for the selected object(s). 
 

 

DISTRIBUTION TOOLS 

 
 
Distribution tools are available for selected objects. In order to use the distribution tools, 
three or more objects must be selected. A “bounding box” (dotted rectangle) displays 
around the selected objects and it is inside the perimeter of this bounding box the 
distribution will be applied. 
 
Note: Three or more objects must be selected in order to access the distribution tools. 
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To use the distribution tools: 

1. Click on the first object to select it. 

2. Hold down the Ctrl key when clicking to select the additional objects. 

3. A “bounding” box displays around the selected objects. Click the applicable 
“distribution” button on the Context Sensitive Toolbar to apply it to the object 
group. 
 

 

SIZE TOOLS 

 
 
Size tools are available for two or more selected objects. Use this tool if you want to 
quickly set all objects within a selected group to the same size. 
 
Note: The order that you select your objects is IMPORTANT. The objects will be “resized” based 
on the first object selected in the group. 
 
To resize two or more selected objects: 

1. Click on the first object to select it. 

2. Hold down the Ctrl key when clicking to select the additional objects. 

3. A “bounding” box displays around the selected objects. Click the applicable “size” 
button on the Context Sensitive Toolbar to apply it to the object group. 

 

TIME TOOLS 

 
 
Time tools are available for two or more selected objects. Use this tool if you want to 
quickly set all objects within a selected group to the same start time, end time, or both 
the same start AND end times. There is also a sequencing time tool available for the 
selected object group. 
 
Note: The order that you select your objects is IMPORTANT. The ‘time’ will be applied using the 
first object selected in the group. 
 
To set the time of how two or more selected objects appear and/or remain displayed on 
the timeline: 

1. Click on the first object to select it. 

2. Hold down the Ctrl key when clicking to select the additional objects. 

3. A “bounding” box displays around the selected objects. Click the applicable 
“time” button on the Context Sensitive Toolbar to apply it to the object group. 
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Events and Actions Overview 
ViewletBuilder8 Enterprise offers a robust set of events and actions that may be 
associated with slides and slide objects such as shapes and images to produce greater 
dynamics and a higher user interactive experience than ever before. This chapter 
provides an overview of events and actions features. 
 

 
 

EVENTS 
Events may be defined as what happens when a certain scenario occurs. For example, 
a slide event may be the “On Load” event. This means that when the slide “loads” or as 
it “loads” this “loading” is an event.  
 
Note: All slides and various slide objects may have Events/Actions associated with them, but not 
all are listed in this chapter. If you see a lightning bolt along the selections Context Sensitive 
Toolbar, this means Events/Actions are available. 
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To CREATE a slide event: 
 

 
 

1. Right click on a slide directly and select Events from the shortcut menu. 

2. In the Slide Events dialog, select a tab: 

a. On Load: This is when a slide is loaded. 

b. On Unload: This is when you leave the slide. 

c. On Key Pressed: This is when a key is press while on a slide. 

3. Select an action as desired. 

4. Make additional selections for the ‘selected’ action (these will vary depending on 
the action selected). 

5. Click OK. 

 
To CREATE a shape event: 
 

 
 

1. Right click on a shape. 

2. Select Events from the shortcut menu. 

3. In the Shape Events dialog, select a tab: 

a. On Click: This is when the user clicks on the shape. 

b. On Rollover: This is when the user moves the mouse over the shape. 

c. On Rollout: This is when the user has moved the mouse off the shape. 

4. Select an action as desired. 

5. Make additional selections for the ‘selected’ action (these will vary depending on 
the action selected). 

6. Click OK. 
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To CREATE an image event:  
 

 
1. Right click on an image. 

2. Select Events from the shortcut menu. 

3. In the Image Events dialog, select an events tab. 

a. On Click: This is when the user clicks on the image. 

b. On Rollover: This is when the user moves the mouse over the image. 

c. On Rollout: This is when the user has moved the mouse off the image. 

4. Select an action as desired. 

5. Make additional selections for the ‘selected’ action (these will vary depending on 
the action selected). 

6. Click OK. 
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ACTIONS 
Actions are associated with Events and are “what will take place” once a particular event 
occurs. For example, an “On Click” event may have a “Goto Slide” action attached to it. 
So, when a user clicks a shape, for example, the project will “go to” a predefined slide. 
 

 
 
To ATTACH an action to an event: 

1. Select a slide, shape, image or other object (that supports events). 

2. Right click and select Events from the shortcut menu. 

3. In the Events dialog, select an events tab. 

4. In the tab, click the Add button. 

5. In the Action dialog, select an action from the list. If applicable, make additional 
selections for the selected action as needed. 

6. Click OK to close the Action dialog to return to the Events dialog. 

7. Click OK to close the Events dialog. 
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To ARRANGE multiple actions for a given event: 

1. In the Events dialog, select an events tab. 

2. If multiple actions are listed in that tab, click an action to highlight it. 

3. Click the Move Up button to move the selected action up in the list. 

4. Click the Move Down button to move the selected action down in the list. 

5. Click OK. 
 
 
To EDIT an action: 

1. In the Events dialog, select an events tab. 

2. Select the action to edit. 

3. Click the Modify button. 

4. In the Action dialog, modify the action as needed. 

5. Click OK to close the Action dialog. 

6. Click OK to close the Events dialog. 
 
 
To DELETE an action: 

1. In the Events dialog, select an events tab. 

2. Select the action to delete. 

3. Click the Delete button. 

4. Click OK to close the Events dialog. 
 
 
Note: If an event has multiple actions associated with it, the actions will be performed in the order 
in which they are listed in the “Action” dialog (from top to bottom). 
 
 
 

ViewletBuilder8 Enterprise User Guide Page 208  © 2014 rev. 0626 



 
 
 

Macros 
ViewletBuilder8 Enterprise has built-in macros that allow you to do some common global 
edits in just a few clicks. These macros are created using GROOVY scripting. 
 

 
 
To LOAD a Macro: 

1. If applicable, select the appropriate object (not required for all macros). 

2. Select Edit > Load Macro from the menu bar. 

3. In the Load Macro dialog, select a Macro. Macros are located in the Macros 
folder. 

4. Click the Open button. 

5. When prompted, “Would you like to run this macro now?” click Yes. 
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Buttons 
Buttons may be used to increase user interactivity within your Viewlet project. For 
example, if you want to give your viewer the control to advance through your Viewlet at 
their own pace, you can create your own series of customized buttons for them to do 
this. Or, you might provide buttons that, when clicked, will allow the viewer to skips 
ahead or to different parts of your project instead of just progressing through it in a linear 
fashion. 
 
When you are editing your button element, double clicking on it will put you into text edit 
mode. You will see a flashing cursor inside the button image indicating it’s ready for text 
input/editing, providing you access to the text edit Context Sensitive toolbar. 
 
You can also single click on the button element to access the button’s Context Sensitive 
toolbar to change the element’s properties and style; open the Text Editor dialog (without 
being in text edit mode); add button events/actions; access simple alignment options and 
additional button style commands.  
 

  
 
To INSERT a button: 

1. Select the slide on which you want to add a button. 

2. Click the Insert Button icon on the Object Toolbar. A button is inserted on the 
slide ready for editing. 

 
Note: Don’t forget to add a “Pause Zone” to a slide that contains a button. This will give the 
viewer a chance to click the button for further navigation in the Viewlet. 

 
To ACCESS button properties: 

1. Select a button. 

2. Click the Button Properties button on the Context Sensitive Toolbar. 

3. In the Button Properties dialog in the: 

a. Name area: Enter a name for the button in the field provided. Enter the 
Text to be displayed on the button in the field provided. 

b. Location & Size area: Enter values for its Left and Top margin. Enter 
values for the Width and Height of the button. 

ViewletBuilder8 Enterprise User Guide Page 210  © 2014 rev. 0626 



 
 
 

c. Timing area: Select a timing option for the button to display on the slide 
from the drop down list. Enter values for any Start/Duration times as 
applicable. 

4. Click OK. 
 
 
To MOVE a button on a slide: 

1. Select a button. 

2. Point your cursor over the button until the cursor changes to a hand shape. 

3. Hold down the left mouse button and drag. 

4. Let go of the left mouse button to drop it into its new location. 

 
 
To select a button style: 

1. Select a button 

2. Click the Button Style button on the Context Sensitive Toolbar. 

3. In the Button Style dialog, select a style from the list. 

4. Click OK. 
 

To MODIFY text in a button: 

1. Select a button. 

2. To edit text: 

a. Using the Text Editor: 

i. Click the Open in Text Editor button on the Context Sensitive 
Toolbar. 

ii. In the Text Editor dialog, make your selections for font type, font 
size, attributes, color and alignment. 

iii. Type your text in the field provided. 

iv. Click OK to apply and exit the Text Editor dialog. 

b. Inline with the button object: 

i. Double click on the button. A flashing cursor inside the button 
object indicates you are in text edit mode. 

ii. Use the active Context Sensitive Toolbar to change font attributes, 
type, color, style and alignment. 

iii. Type your text directly in the balloon object. 

iv. Click off of the balloon to exit text edit mode. 
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To add an event and action(s) to the button: 

1. Select a button 

2. Click the Events button on the Context Sensitive Toolbar. 

3. In the Button Events dialog, in the On Click tab, click the Add icon. 

4. In the Action dialog, select an action from the list. Make additional selections as 
needed. 

5. Click OK to close the Action dialog. 

6. Click OK to close the Button Events dialog. 
 
 
To DELETE a button: 

1. Select a button. 

2. Click the Delete button on the Main Toolbar. 
 
Note: Use multiple buttons on a slide for non-linear navigation within the Viewlet. 
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Hyperlinks & Hotspots 
A well-designed Hyperlink or Hotspot allows a user, with a single click, to perform an 
action such as jump to another section of the project, open an email, go to a web page 
and more. In ViewletBuilder8 Enterprise, hyperlink functionality includes text links and 
the ability to make other objects work as “clickable” links. This chapter covers the basics 
steps for creating hyperlinks in your Viewlet projects. 
 

TEXT LINKS (NOTES, BALLOONS, SLIDE TEXT) 

 
 
While message objects (notes, balloons and slide text) themselves cannot be set up as 
a hyperlink, a portion or all of the text inside can. These types of hyperlinks are known 
as text links. 
 
To CREATE a text link: 

1. Highlight the text you want to use for the link. 

2. Click the Hyperlink button on the Context Sensitive Toolbar. 

3. In the Hyperlink dialog, select the On Click tab. 

4. Click the Add button. 

5. In the Action dialog that displays, select an action from the list. Make additional 
selections as needed. 

6. Click OK to close the Action dialog. 

7. Click OK to close the Hyperlink dialog. 
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Note: If additional event tabs are available when creating hyperlinks, you can use the same steps 
above for additional options when the viewer interacts with the link. 
 
Note: By default, a text hyperlink will be blue underlined text. Once a hyperlink is created, you can 
change the link’s text attributes as needed. 
 
 
To MODIFY a text link: 

1. Highlight the text you want to use for the link. 

2. Click the Hyperlink button on the Context Sensitive Toolbar. 

3. In the Hyperlink dialog, select the On Click tab. 

4. Select the applicable action from the list. 

5. Click the Modify button. 

6. In the dialog that displays, make edits as needed. 

7. Click OK to close the Action dialog. 

8. Click OK to close the Hyperlink dialog. 
 
 
To DELETE a text link: 

1. Highlight the text you want to remove the hyperlink from. 

2. Click the Hyperlink button on the Context Sensitive Toolbar. 

3. In the Hyperlink dialog, select the appropriate tab. 

4. Select the applicable action from the list. 

5. Click the Delete button. 

6. Click OK to exit the Hyperlink dialog.  
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OBJECT HYPERLINKS (CLICKSPOTS, HOTSPOTS) 
An object that requires a viewer to click it in order for an action to occur (like loading a 
web page, etc.) is more commonly referred to as a clickspot or a hotspot. 
 

 
 
 To CREATE a hotspot: 

1. Select the slide object you want to use for the hotspot. 

2. Click the Events button on the Context Sensitive Toolbar. 

3. In the Events dialog, select an event tab, for example, select the On Click tab. 

4. Click the Add button. 

5. In the Action dialog that displays, select an action from the list. Make additional 
selections as needed. 

6. Click OK to close the Action dialog. 

7. Click OK close the Events dialog. 
 
 
To MODIFY a hotspot: 

1. Select the slide object used for the hotspot. 

2. Click the Events button on the Context Sensitive Toolbar. 

3. In the Events dialog, select the applicable tab. 

4. Select the applicable action from the list. 

5. Click the Modify button. 
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6. In the dialog that displays, make edits as needed. 

7. Click OK to close the Action dialog. 

8. Click OK to close the Events dialog. 
 
 
To DELETE a hotspot: 

1. Select the slide object used for the hotspot. 

2. Click the Events button on the Context Sensitive Toolbar. 

3. In the Events dialog, select the applicable tab. 

4. Select the applicable action from the list. 

5. Click the Delete button. 

6. Click OK to exit the Events dialog. 

 
 Note: To create a transparent (invisible) hotspot, use a shape object, set its opacity level to zero 
percent (0%) and add the applicable events/actions to make it a clickable object as previously 
described. 
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Interactive Zones – Common Features 
Interactivity is key to acquiring and maintaining your viewer’s interest. And, with the use 
of interactive zones within your Viewlet, you can gain valuable input from your viewers 
for training, marketing and even product development purposes. The Interactive Zones 
are a staple of ViewletBuilder8 Enterprise and have been in almost all of the previous 
versions. They provide dynamic results like Events and Actions, but focus on specific 
purposes. 
 
ViewletBuilder8 Enterprise offers five Interactive Zones: 
 
 Click Zone 
 Text Zone 
 Keystroke Zone 
 Pause Zone 
 Questions 

 
Note: For purposes of this chapter, we are not including Hyperlinks or Events/Actions since they 
have already been covered in the previous chapters. 
 
The Interactive Zones (with the exception of the Pause Zone) have many elements in 
common. These include: 
 
 Only one zone per slide. 
 An input field OR a clickable area or button. 
 Audio option. 
 Response to user input in the form of a message or some other object for when 

the user answers correctly or incorrectly or doesn’t complete a response. 
 Scoring with points, attempts and time for answering. 

 
Let’s review each of these elements separately. 
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THE ONE ZONE PER SLIDE RULE 
Unlike other dynamic elements, Interactive Zones serve a specific purpose and 
therefore, only one zone may be on the slide at a time (except for the Pause Zone).  If 
you try to insert multiple zones, you will see a Warning dialog the will inform you what 
type of zone the slide already contains. It will offer you the following Options: 
 

 
 
 Remove it. 
 Replace it with a [selected zone/question]. 
 Add the [selected zone/question] to a new empty slide. 
 Add the [selected zone/question] to a copy of this slide. 

 
Select one of these options and click OK. 
 

ZONE INTERACTIVE AREA 
Each of the zones contain some type of “input area” or “zone” that the user will interact 
with and these will vary, depending upon the zone: 
 
 Click Zone: Contains a click area that covers a portion of the slide. This area 

(transparent in the published project) is where the user must click to correctly 
respond. 
 

 Text Zone: Contains a text input field. The user must input the answer correctly 
into this field. 
 

 Keystroke Zone: Contains a zone that shows the Viewlet author (not the viewer) 
the keys that the viewer must press in the published file to answer correctly. This 
“zone” will not display in the published file. 
 

 Pause Zone: Though not technically a zone, when this zone is inserted on a 
slide, it will insert a red triangle (not viewable in the published file) in the bottom 
right corner of the slide and the slide will pause at the point along the Timeline 
where it was inserted (multiple Pause Zones may be added to a slide). 
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 Question: These slides will vary in look, but they will contain some type of input 

button, field or “object” to select, input or drag for the answer. These slides may 
also contain a button to “Submit” the input. 

 
Note: You can attach audio to different parts of a zone. To see what parts support audio, click the 
object and look at the Context Sensitive Toolbar. If a “sound” button displays for the selection, 
then you can attach audio to it. 
 

FEEDBACK MESSAGES 
When creating an Interactive Zone, you should offer some type of response to the user 
after they’ve completed their input. In its simplest form, this response may simply be a 
message object that informs the user they’ve answered correctly. Or, it may be as 
elaborate as a combination of a message that, when the user answers incorrectly, a 
message appears telling them this and directing them to click a link to launch a quick 
training movie before continuing or to just continue without this option, etc. The choice 
as to how simple or complex the response will be is up to you. You even have the option 
to remove all responses to user input as well, if you desire. 
 

  
 
Note: Feedback messages will only display when the user submits a response or the zone has 
“timed out”. 
 
 
To CREATE a feedback message using the default (installed) options: 

1. Insert an Interactive zone and, if applicable, three default response text 
messages will display: 

a. Green message object: This will display if the user answers correctly. 

b. Yellow message object: This will display if the user did not complete the 
message. 

c. Red message object: This will display if the user answers incorrectly. 

2. Select a message object and edit as you would any other message object with 
regards to text and message type/style itself. 

3. Move and stack the messages as desired on the slide. 
 
 
To MODIFY a feedback message: 
You may change a response object from a message to an image or shape or none at all. 
In addition, you may change how this response object responds in reaction to a certain 
user action and the duration a response displays on a slide. These features are part of 
ViewletBuilder8 Enterprise’s events/actions tools. 

1. Click on the “zone” area for the Interactive Zone. 

2. Click the Events button on the Context Sensitive Toolbar. 
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3. In the Slide Events dialog, click the appropriate tab. For example, to change the 
response that will display when the user answers correctly, select the On Correct 
tab. 

4. Select the action to modify and click the Modify button. 

5. In the Action dialog, edit as desired and click OK. 

6. In the Slide Events dialog, select another tab and repeat this process as desired 
for each of the response objects. 

7. When complete, click OK to close the Slide Events dialog. 
 
 
To DELETE a feedback message: 

1. Select the feedback object. 

2. Click the Delete button on the Main Toolbar. 
 

SCORING OPTIONS 
You determine whether or not an Interactive Zone is scored or not based on its Scoring 
Mode. If it is used as a quiz (scored) element, you can set its additional scoring options. 
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To CONFIGURE scoring options for an Interactive Zone: 

1. Select the Interactive Zone. 

2. Click the Scoring button on the Context Sensitive Toolbar. 

3. In the Score dialog: 

a. Select the Override Settings in Project Properties to enable options in 
this dialog. 

b. Points:  Enter a number that will be used for the point value if the user 
answers the question correctly. 

c. Attempts: Enter a number of times the user has to answer the question 
correctly. After this number is reached and if the question is not answered 
correctly, it will be marked as incorrect and the Viewlet will continue. 
Select the option to allow the question to be reanswered if the user 
navigates backwards in the project, if desired.  

d. Time: To limit the amount of time a user has to answer a question, select 
the Enable a time limit for the question check box. Then, enter the 
Hours/Minutes/Seconds as desired. 

e. Click OK to apply the scoring options and to close the Score dialog. 
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Click Zone 
The Click Zone is one of the most popular interactive zones used in ViewletBuilder8 
Enterprise. A Click Zone may be used to increase the effectiveness of your Viewlet, 
forcing the user to interact with it by clicking on a portion of the slide in order to continue. 
 

 
 
This chapter highlights the Click Zone, providing information on this zone not already 
covered in a previous chapter, Interactive Zones – Common Features. 
 
To CREATE a Click Zone: 

1. Click the Insert ClickZone button on the Object Toolbar. 

2. By default, a click zone area and three response message objects will be 
inserted on the slide. 

 
 
To edit the click area properties: 

1. Double click on the click area. The Area Properties dialog displays. 

2. In the Area Properties dialog, you have three “states” to set up for the fill (bucket) 
color and for the border (pencil) color: 

a. Normal: Enter a value for the fill and for the border when the mouse is 
NOT over the click area in the Viewlet. 

b. Rollover: Enter a value for the fill and border when the cursor moves on 
to the click area in the Viewlet. 
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c. Selected: Enter a value for the fill and border when the click area is 
“clicked”. 

 
Note: When the number is zero for any of the values, the fill/border color will be 
transparent. 
 

3. Select the Double Click to Select option if you want the user to double click 
(instead of the default single click) to respond correctly. 

4. Click OK. 
 
 
To MOVE a click area on a slide: 

1. Select the click area. 

2. Move your cursor over the click area until the cursor changes to a hand shape. 

3. Hold down your left mouse button and drag the area to its new location. 
 
 
To RESIZE a click area: 

1. Select the click area. 

2. Move your cursor over one of the grab handles until the cursor changes to a 
double arrow. 

3. Hold down your left mouse button and resize the area as desired. 
 
 
To DELETE a Click Zone: 

1. Select the click area. 

2. Press Delete on your keyboard. 
 
 
 

ViewletBuilder8 Enterprise User Guide Page 223  © 2014 rev. 0626 



 
 
 

Text Zone 
The Text Zones are another popular interactive features used in Viewlets by Viewlet 
authors. These zones may be added to slides when you require the user to answer 
questions by inputting text responses into a field. 
 

 
 
This chapter highlights the Text Zone, providing information on this zone not already 
covered in a previous chapter, Interactive Zones – Common Features. 
 
To CREATE a Text Zone: 

1. Click the Insert TextZone button on the Object Toolbar. 

2. By default, a text input field and three response message objects are inserted on 
the slide. 

 
 
To MODIFY the text zone input field: 

1. Double click the text field or right click it and select Modify Text Field from the 
shortcut menu. 

2. In the Modify Text Field dialog: 

a. Select a Response Type from the list (Textual or Numeric). 

b. For Correct Answers – One Per Line: Input the correct answers in the 
field provided. This is what the user will need to type in the field in order 
to answer correctly. For multiple answers, press the Enter key between 
each correct entry. 
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c. In the Options area, make selections as needed: 

i. Wrap Text: Allows text to wrap inside the text field. 

ii. Password Field: Encrypts the text. 

iii. Case Sensitive: Forces the answer to be exact, including caps. 

iv. Ignore Whitespace: Ignore any ‘spaces’ in answers. 

d. Select a Submit Key option from the list. 
 
Note: After inputting text, the user clicks the Submit Key to submit the answer. If 
you do NOT want to require the user to click this button, use the Auto option. 
When selected, the user types in a response and, after three seconds, the 
Viewlet will automatically submit the input and respond accordingly. 

 

3. Click OK. 

 
To MOVE the text field: 

1. Select the text field. 

2. Mouse your cursor over the text field until the cursor changes to a hand shape. 

3. Hold down the left mouse button and move the text field to its new location. 
 
To RESIZE the text field: 

1. Select the text field. 

2. Mouse your cursor over one of the grab handles until the cursor changes to a 
double arrow shape. 

3. Hold down your left mouse button and drag the grab handle to resize the text 
field. 

 
 
To DELETE a Text Zone: 

1. Select the text field. 

2. Press the Delete key on your keyboard. 
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Keystroke Zone 
A Keystroke Zone may be inserted on a slide to force the user to press an individual or 
combination of keys in order to continue with the Viewlet. This chapter highlights the 
Keystroke Zone features not already covered in a previous chapter Interactive Zones – 
Common Features. 
 

 
 
To CREATE a Keystroke Zone: 

1. Select Insert KeystrokeZone button on the Object Toolbar. 

2. By default, a keystroke “object” that indicates the current key the user needs to 
press in order to answer correct will display along with response messages. 
 

 
To DEFINE the keystroke: 

1. Double click on the keystroke object. The Define Keystroke dialog displays.  

2. In the Define Keystroke dialog, follow the instructions for defining a new 
keystroke or keystroke combination. 

3. Click OK to apply. 
 
Note: If you define a keystroke combination that is not compatible with Flash, an error will display, 
warning you of the issue. 
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KEYSTROKE ZONES & INTERNATIONAL USERS 
If you expect your Viewlet will be viewed by an audience whose native language differs 
from what you’ve used in your Viewlet, when defining Keystroke Zones, a Warning 
dialog will display when a keystroke combination possibly represents a different key 
combination on international keyboards. Along with this warning, you will be presented 
with a Safe Key List to help you select a safer and more appropriate keystroke 
combination for “all” your global users. 
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Pause Zone 
The Pause Zone is used to pause the Viewlet on a particular slide or at a particular 
interval on a slide. These zones are easy to use on slide and are most commonly used 
on slides that contain hyperlinks or buttons that allow the user to click when they decide 
to continue to play the Viewlet. 
 

 
 
To INSERT a Pause Zone on a slide: 

1. Click the interval along the Timeline where you want to insert a Pause Zone. 

2. Click the Insert PauseZone button on the Objects Toolbar. 

3. A Pause Zone indicator will be added to the Timeline where the Pause Zone was 
added and a red triangle will be inserted in the bottom right corner of the slide (in 
Slide Select mode). This triangle indicates the slide will pause, but this triangle 
will not display in the Viewlet. 

 
To insert multiple Pause Zones on a slide: 

1. Select the frame on the Timeline where you want to insert the Pause Zone. 

2. Click the Insert PauseZone button on the Objects Toolbar. 

ViewletBuilder8 Enterprise User Guide Page 228  © 2014 rev. 0626 



 
 
 

3. A new Pause Zone is added and, if there is more than one on the slide, the 
layer’s name is changed to Pause Zones. 

4. Click the Insert PauseZone button for each additional Pause Zone needed on 
the slide. 

5. Drag the Pause Zone indicator along the timeline as needed. 
 

 
To MOVE a Pause Zone: 

1. Click the Pause Zone layer to select it. 

2. Select the object’s indicator in the Timeline by clicking on it. 

3. Hold down your left mouse button and drag the zone. 

4. Let go of the left mouse button to drop it into place. 

5. A Timing Rule Change dialog displays. Read the information and click OK to 
change the timing rule to manual timing. 
 
 

To REMOVE a Pause Zone: 

1. Select the Pause Zone indicator along the Timeline. 
2. Press the Delete key on your keyboard. 

 
 

ViewletBuilder8 Enterprise User Guide Page 229  © 2014 rev. 0626 



 
 
 

Question 
Turn your Viewlet into a testing or survey tool by using Question slides. This chapter 
highlights Question slides, providing information on this feature not already covered in a 
previous chapter, Interactive Zones – Common Features. 
 

 
 
Note: There is one main difference between a quiz and a survey slide. A quiz question normally 
requires the user to provide a correct response and is usually scored. A survey question does not 
normally require a correct response and is therefore usually not scored. 
 
To CREATE a Question slide: 

1. Click the Insert Question button on the Object Toolbar. 

2. In the Question dialog that displays: 

a. Select a Question Type: 

i. Non-Random question types: 

1. Select a question. 

2. Enter text in the Question field. 

3. In the Scoring Mode area, set it to Quiz (for scored 
questions) or Survey (for not scored questions). 

4. In the Style area, select the style to apply to the question 
slide. 

5. Click OK to close the Question dialog and create the new 
question slide. 

ii. Random Question: 
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1. Select Random Question. 

2. If you have to create a question bank: 

a. Click the Add a Question Bank button. The Add 
Question Bank dialog displays. 

b. Make your selections in the General and Scoring 
tabs. 

c. Click OK to close the Add Question Bank dialog. 
The Random Question slide is added to the Main 
Timeline. 

 

QUESTION ELEMENTS 
The question type determines the baseline elements of the Question slide. These 
elements normally include choice text, a selectable response or input field for answers, a 
submit button to submit the response and feedback message objects. Please refer to 
each of these topics as outlined elsewhere in this guide for more information. 
 

CHOICE LISTS 
This question type requires users to select answers from a list of choice by selecting a 
radio button or check box next to each text option. The user then clicks a Submit button. 
If the question is a quiz, it will be scored. If the question is a survey, it will not be scored. 
So, this question type’s elements (by default) may include: 
 

 
 
 Text box for the question 
 Radio buttons (or check boxes) for users to select an answer 
 Text boxes containing possible answers 
 Submit button the user clicks to submit the response 
 Feedback message objects 
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General Editing 
To MODIFY the choice text: 

1. Double click choice text box to enter text edit mode. 

2. Edit the text as you would in any other message object. 
 
 
To ADD additional choices: 

1. Click the Add Choice button on the Context Sensitive Toolbar. 

2. Repeat the step above for to add each new choice. 
 
 
To DELETE a choice option: 

1. Select the radio button / check box or the text box of the choice you want to 
delete. 

2. Press the Delete key on your keyboard. 
 
 
To SET UP the correct responses: 

1. Select the radio button / check box next to the choice you want to set as the 
correct response. 

2. Click the Modify Choice button on the Context Sensitive Toolbar. 

3. Repeat these steps for each choice you want to set as the correct response. 

4. If a choice is set as the correct response, click the Modify Choice button again 
to deselect it as the correct response. 

 
 
To CHANGE the radio button style: 

1. Click on any of the radio buttons to select one. 

2. Click the Choice Type button on the Context Sensitive Toolbar to display a 
menu of options. 

3. Select Radio Button option from the list. 

4. The Radio Button Style dialog displays. Select a style for the radio button from 
the list. 

5. Click OK to apply the new style. 
 
 
To MODIFY a choice text box: 

1. Double click the choice text box. 
2. Edit the text as you would in any other message object. 
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To MODIFY the Submit button properties: 

1. Select the Submit button. 

2. Click the Button Properties button on the Context Sensitive Toolbar. 

3. In the Button Properties dialog, edit the information as required. 

4. Click OK. 
 
 
To DELETE a Question from the slide: 

1. Click the Insert Question button on the Object Toolbar. 

2. In the Warning dialog, select the Remove It option. 

3. Click OK 
 
 

TEXT INPUT FIELDS 
This question type requires the user to respond to a question by typing a response into a 
text input field. The response is then submitted either automatically or by the user 
clicking the Submit button. This question may (quiz) or may not (survey) be scored.  
 

 
 
This question’s default elements may include: 
 
 Text box for the question 
 Text input field for users type their responses in 
 Submit button the user clicks to submit the response 
 Response message objects 

 
 
To MODIFY the text box containing the Question zone’s question: 

1. Double click the text box. 

2. Edit the text as you would in any other message object. 
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To MODIFY the text input field: 

1. Double click the text input field. 

2. In the Modify Text Field dialog: 

a. Select a Response Type from the list (Textual or Numeric). 

b. For Correct Answers – One Per Line: Input the correct answers in the 
field provided. This is what the user will need to type in the field in order 
to answer correctly. For multiple answers, press the Enter key between 
each correct entry. 

c. In the Options area, make selections as needed: 

i. Wrap Text: Allows text to wrap inside the text field. 

ii. Password Field: Encrypts the text. 

iii. Case Sensitive: Forces the answer to be exact, including caps. 

iv. Ignore Whitespace: Ignore any ‘spaces’ in answers. 

d. Select a Submit Key option from the list. 
 
Note: After inputting text, the user clicks the Submit Key to submit the answer. If 
you do NOT want to require the user to click this button, use the Auto option. 
When selected, the user types in a response and, after three seconds, the 
Viewlet will automatically submit the input and respond accordingly. 

 

3. Click OK. 
 

 
To MOVE the text field: 

1. Select the text field. 

2. Mouse your cursor over the text field until the cursor changes to a hand shape. 

3. Hold down the left mouse button and move the text field to its new location. 
 
 
To RESIZE the text field: 

1. Select the text field. 

2. Mouse your cursor over one of the grab handles until the cursor changes to a 
double arrow shape. 

3. Hold down your left mouse button and drag the grab handle to resize the text 
field. 

 
 
 
 
To DELETE a Text Zone: 

1. Select the text field. 

2. Press the Delete key on your keyboard. 
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COMBOBOXES 
This question type requires users to answer a question by selecting a single answer 
from a list of answers contained within a drop-down list. Then the user clicks the Submit 
button to submit the response. So, this question type’s elements (by default) may 
include: 
 

 
 
 Text box for the question 
 ComboBox for users to select an answer from a drop-down list 
 Submit button the user clicks to submit the response 
 Response message objects 

 
 
To MODIFY the text box containing the Question zone’s question: 

1. Double click the question text box. 

2. Edit the text as you would in any other message object. 
 
 
To MODIFY a ComboBox style: 

1. Click the Choice Type button on the Context Sensitive Toolbar. 

2. Select ComboBox from the list that displays. 

3. In the ComboBox Style dialog, select a style from the list. 

4. Click OK. 
 
To CONFIGURE the ComboBox’s options list: 

1. Double click on the ComboBox. 

2. The Modify ComboBox dialog displays. In this dialog:  

a. To insert an answer: 
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i. Click the Add button. 

ii. Type a value in the list area. 
 

b. To modify an answer: 

i. Select a value in the list. 

ii. Click the Modify button. 

iii. Edit the highlighted value. 
 

c. To set an answer as “correct”: 

i. Click on the check box next to the desired value. 

ii. Deselect the checkbox to remove the checkmark. 
 

d. To move an answer up or down in the list: 

i. Select the desired value. 

ii. Click the Move Up button to move it up in the list. 

iii. Click the Move Down button to move it down in the list. 
 

e. To remove an answer from the list. 

i. Select a value in the list. 

ii. Click the Delete button. 

3. Click OK to save the list and to close the dialog. 
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RATINGS 
This question type gathers information from a user by posing a question such as “What 
is your overall level of satisfaction?” In response, the user is required to click along a 
“rating” scale and then click a Submit button to submit the response. This type of 
question is for surveys only and not scored. 
 

  
 
The (default) elements for this question type may include: 
 
 Text box for the question 
 Rating scale the user clicks on in response to the question 
 Submit button the user clicks to submit the response 

 
 
To MODIFY the text box containing the Question zone’s question: 

1. Double click the question text box. 

2. Edit the text as you would in any other message object. 
 
 
To CHANGE a Rating scale’s style: 

1. Select the Rating object to select it. 

2. Click the Modify Choice button on the Context Sensitive Toolbar. 

3. Select Rating from the list. 

4. The Rating Style dialog displays. Select a new style from the list. 

5. Click OK to apply it. 
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To INCREASE / DECREASE the rating scale: 

1. Double click on the Rating object. 

2. The Modify Rating dialog displays. Enter a number in the field provided for the 
Maximum Rating desired. 

3. Click OK. 
 
To REMOVE a Rating from a slide: 

1. Click the Insert Question button on the Object Toolbar. 

2. When the Warning screen displays, select Remove It. 
3. Click OK to remove the Question from the slide. 
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Drag and Drop & Click Map Question Types 
DRAG AND DROP QUESTION TYPE 
The Drag and Drop question type requires the viewer to match up items by dragging 
responses across columns. This question type can be used as a quiz (scored) question 
or as a survey (non-scored) question. 
 

  
 
As with any feature in ViewletBuilder8 Enterprise, there are several ways to achieve the 
same results.  Remember, access to different features when working with the Drag and 
Drop and the Click Map question types are also available via Context Sensitive toolbars 
and via right click shortcut menus. 
 
 
To CREATE a Drag and Drop question: 

1. Click the Insert Question button on the Object Toolbar. 

2. A Question dialog displays. Scroll down the list of Question Types and select 
Drag and Drop from the list. 

3. Type your Question or instructions for the question in the field provided. 

4. In the Scoring Mode area, select Quiz if the question will be scored, or select 
Survey if the question will not be scored. 

5. Click OK and a slide with the new Drag and Drop question type will be created. 
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Properties 
By default, the Drag and Drop question contains various elements (all of which are 
editable) when first created including: 
 Question Text: A text box displays at the top of the question elements with text 

entered in the Question field in the Question dialog when selecting the question 
type. If no text is entered into the field prior to creating the question, the default 
text will be Enter Question Here. Edit the text as needed. 

 Drag Choices: The first column contains three text boxes, which are the 
responses that the viewer is instructed to “drag and drop” on the Drop Areas in 
the second column in order to answer the question correctly. The Drag Choices 
are simply message objects, so its style, type and text can be modified just like 
any other note, balloon or slide text (message) object. 

 Drop Areas: The second column contains three Drop Areas that, by default, are 
linked to their respective Drag Choice. This is the area on the slide where the 
viewer drops the Drag Choice on in order to respond. You can modify the opacity 
level, name, etc. of this area. 

 Links: A dotted line displays between each Drag Choice and its associated Drop 
Area, signifying they are “linked” together. Links can be removed and added 
between new “pairs” of Drag Choices and Drop Areas as desired. 

 Submit Button: Once all of the appropriate responses are “dragged and 
dropped”, the viewer clicks this button to submit the answers. The button’s look, 
text and “on click” action may be modified. 

 Feedback Messages: If using feedback, whether it is the default message 
objects or a custom configuration, the viewer will see (hear) the appropriate 
feedback based on how they respond. Responses can be customized for correct, 
incorrect and incomplete responses.  

 

Working with Drag & Drop Questions 
To EDIT the question text box: 

1. Double click on the text box to enter text edit mode. 

2. Edit your text and its attributes as desired. 

3. Deselect the text box and then single click it to select the object itself. 

4. Resize and move the text box as needed. 
 
Note: Since “Drag Choices” are essentially the same as a message object, you can quickly edit it 
as you would any other message object with regards to changing its style, text content and text 
attributes using the buttons along the context sensitive toolbar, if desired. 
 
To work with Drag Choices using the Drag and Drop dialog: 

1. Click on a Drag Choice to select it. 

2. Click on the Modify Question button. 

3. The Drag and Drop dialog displays. Select the Questions tab. 

4. In the Questions tab: 
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a. To add a new Drag Choice + Drop Area pair: 

i. Click the Add button.  

ii. Select Add Drag Drop Pair from the shortcut menu that displays. 

iii. A Drag and Drop Pair dialog displays. 

1. Select a message Type from the list. 

2. Type the Text for the Drag Choice in the field provided. 

3. Accept the title for the Drop Area Name or type a new one 
in the field provided. 
 
The text used in the “Name” field will display over the Drop 
Area. You will see this “text label” on the Drop Area while 
editing your source file INSIDE ViewletBuilder8 Enterprise 
(it is used to identify its respective Drop Area). However, 
after you publish the file, this text will NOT be visible to the 
viewer in the SWF file. If you want to have the Drop Area 
“labeled” with text that will be visible to the viewer, you 
must add a message object (such as slide text) on or near 
the Drop Area. 

4. Click OK to create the new pair and add it to the list. 
 

b. To modify an existing Drag Choice: 

i. Select a “choice” from the Drag Choices list. 

ii. Click the Modify button. 

iii. In the dialog that displays, make your desired edits. 

iv. Click OK to apply the changes and to return to the previous 
dialog. 
 

c. To link / unlink Drag and Drop Pairs: 

i. To remove an existing link: 

1. Select either item from one of the lists. 

2. Click the Link button. This will remove the link between the 
selected pair. 
 

d. To link an unlinked Drag Choice and Drop Area: 

i. Start by clicking on the desired Drag Choice. 

ii. Then, click on the desired Drop Area that you want to link to the 
Drag Choice. 

iii. Click the Link button. A link will display between the selections. 
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e. To move an item up or down within one of the lists: 

i. Select a Drag Choice or a Drop Area. 

ii. Click the Move Up button to move the selection up in the list. 

iii. Click the Move Down button to move the selection down in the 
list. 
 

f. To delete an item in one of the lists: 

i. Select a Drag Choice or a Drop Area. 

ii. Click the Delete button. The selection is removed from the list. 
 

Note: Be careful when deleting a Drag Choice or Drop Area. If the selection is part of a “Drag and 
Drop Pair” (meaning it is linked), both the Drag Choice and its associated (linked) Drop Area (and 
visa versa) will be deleted. 
 

5. Click OK to save changes and to exit the Drag and Drop dialog. 
 

 
To MODIFY a Drag Choice (while editing directly on the slide): 

1. To change the style, type or fill color of the Drag Choice, single click on it to 
select it. 

2. When the context sensitive toolbar loads, use its buttons to modify the Drag 
Choice object just as you would any other message (note, balloon, slide text) 
object. 

3. To edit the text within the Drag Choice, double click it to enter text edit mode. 
Edit the text as you would any other message object. 
 
 

To RANDOMIZE (mix up) Drag Choices automatically: 

1. Create and modify the Drag and Drop question on the slide as desired. 

2. To mix up the Drag Choices (without affecting the position of their associated 
Drop Areas and slide text, if applicable), click on the slide itself to make sure the 
slide is selected. 

3. Click the Randomize Drag Choices button on the context sensitive toolbar. This 
will mix up the Drag Choices. 

 
Note: When you use the “Randomize Drag Choices” button (feature) this will NOT randomize the 
Drag Choices in the published SWF file (this feature is planned for a future release). It will only 
“mix up” or randomize the Drag Choices each time you click the randomize button while editing 
the project in the source file. 
 
 
To MODIFY with Drop Areas (using the Drag and Drop dialog): 

1. Double click on a Drop Area. 

2. The Drag and Drop dialog displays. The Questions tab displays by default. 
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3. In the Questions tab, make selections / modifications as desired. 

4. To change the attributes of the Drop Areas, select the Style tab. 

5. You have three “states” to set up for the fill (bucket) color and for the border 
(pencil) color: 

a. Normal: The look of the area when the mouse is not over or clicked on it. 

b. Rollover: The look of the area when the mouse is “over” but not clicked 
on it. 

c. Selected: The look of the area when the mouse is clicked on it. 

d. To change the fill color for the area for any of these “states” click on the 
Background Color button. In the dialog that displays, select a color and 
click OK to return to the previous dialog. 

6. To change the area’s border color for any of these “states” click on the Border 
Color button. In the dialog that displays, select a color and click OK. 

7. Click OK to apply / save the selections. 
 
Note: The text that you see on the Drop Area while working in your source file within 
ViewletBuilder8 Enterprise is used to identify its respective Drop Area. This text is only visible 
within ViewletBuilder8 Enterprise and will NOT be visible to the viewer in the published SWF file. 
If you want to use text to identify each Drop Area and have this text visible to the viewer in the 
published SWF file, you must add a message object (such as slide text) on or near each of the 
Drop Areas. 
 
 
To add slide text next Drop Areas that will be visible to the viewer in the published SWF 
file: 

1. Create and modify the Drag and Drop question as needed on the slide, including 
randomizing Drag Choices and Drop Areas as desired. 

2. Click the Insert Text Box button on the Objects Toolbar. 

3. Draw the text box for the slide text on the slide where desired. 

4. Input the slide text and modify its attributes as needed.  

5. Repeat these steps as needed for each slide text box you need to create for 
each Drop Area. 

 
 
To RESIZE / MOVE a Drop Area: 

1. Click on the Drop Area to select it. A “bounding box” displays around it. 

2. Use the “grab handles” to drag and resize the Drop Area as desired. 

3. To move the Drop Area, point your cursor over the object and hold down the left 
mouse button and drag it to a new location on the slide as desired. 
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To REMOVE a Drag and Drop question from the slide: 

1. Click on the Insert Question button on the Objects Toolbar. 

2. A Warning dialog displays. Select the Remove It option. 

3. Click OK to complete the deletion. 
 
 

CLICK MAP QUESTION TYPE 
The Click Map question type requires the viewers to click on one or more areas of the 
screen in order to respond. This question type can be used as a quiz (scored) question 
or as a survey (non-scored) question. 
 

  
 
To CREATE a Click Map question: 

1. Click the Insert Question button on the Object Toolbar. 

2. A Question dialog displays. Scroll down the list of Question Types and select 
Click Map from the list. 

3. Type your Question or instructions for the question in the field provided. 

4. In the Scoring Mode area, select Quiz if the question will be scored, or select 
Survey if the question will not be scored. 

5. Click OK and a slide with the new Click Map question type will be created. 
 
 

Properties 
By default, the Click Map question contains various elements (all of which are editable) 
when first created including: 
 Question Text: A text box displays at the top of the question elements with text 

entered in the Question field in the Question dialog when selecting the question 
type. If no text is entered into the field prior to creating the question, the default 
text will be Enter Question Here. Edit this text as needed. 
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 Click Areas: Similar to the classic “Click Zone”, the Click Map displays three 

“click areas” on the creation of a new question. You can delete or add click 
areas, redraw their shapes using any of the drawing tools, resize them and 
reposition them on the slide. You can also designate one or more “areas” as 
what the viewer needs to click on in order to respond correctly. 

 Submit Button: Once the appropriate selections are “clicked on”, the viewer (by 
default) clicks this button to submit the response. The button’s look, text and “on 
click” action may be modified.  
 
Note: If the viewer is only required to click on ONE click area, you can have the answer 
automatically submitted without use of the Submit button. To set this up, double click on a 
click area to open the “Click Map” dialog. Under “Options” select the “Submit on Click” 
option. This will automatically remove the “Submit” button from the slide. Keep in mind, 
this option will not be available if multiple click areas are designated as the correct 
response. 
 

 Response Messages: If using feedback, whether it is the default message 
objects or a custom configuration, the viewer will see (hear) the appropriate 
feedback based on how they respond. Responses can be customized for correct, 
incorrect and incomplete responses. 

 
 

Working with Click Map Questions 
To MODIFY the question text box: 

1. Double click on the text box to enter text edit mode. 

2. Edit your text and its attributes as desired. 

3. Deselect the text box and then single click it to select the object itself. 

4. Resize and move the text box as needed. 
 
 
To work with Click Areas: 

1. Double click on any of the click areas. 

2. The Click Map dialog displays. Two tabs are available: 

a. In the Questions tab. 

i. In the Click Map Zones area, click on an area in the list to work 
with it. 

ii. Click the Add button to add a new area to the list. After it displays 
in the list, edit its text as needed. 

iii. Click the Modify button to edit the text of a selected area. 

iv. To move an item up or down in the list, click the Move Up  button 
to move the item up in the list. Click the Move Down button to 
move the item down in the list. 

v. Click the Delete button to remove a selected area from the list. 
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vi. In the Click Map Zones area, to set one or more areas as the 
correct response: 

1. In the Correct column, click the check box next to the area 
you want designated as the correct “click area”. 

2. Repeat the step above for each additional “correct” click 
area the viewer must click on in order to respond correctly. 

3. To deselect a correct response, click on the check box 
containing the checkmark to remove (deselect) it as the 
correct response. 

vii. In the Options area, to specify “how the user needs to click” in 
order to respond correctly when clicking on selections: 

1. Select the Multi Select option if multiple click areas are 
designated as correct responses, meaning the viewer must 
click multiple click areas in order to respond correctly. 

2. Select the Submit on Click option when only one click 
area is designated as the correct response. This will 
remove the Submit button from the slide and once the 
viewer clicks on any of the available click areas, the 
response will automatically be submitted right after 
clicking. 

3. Select the Double Click to Select option if you want the 
viewer to double click on one or more click areas in order 
to select and respond correctly. 
 

b. In the Style tab, you have three “states” to set up for the fill (bucket) color 
and for the border (pencil) color: 

i. Normal: The look of the area when the mouse is not over or 
clicked on it. 

ii. Rollover: The look of the area when the mouse is “over” but not 
clicked on it. 

iii. Selected: The look of the area when the mouse is clicked on it. 

c. For any of these “states” click on the Background Color button. In the 
dialog that displays, select a color and click OK to return to the previous 
dialog. 

d. For any of these “states” click on the Border Color button. In the dialog 
that displays, select a color and click OK. 

3. Click OK to save options and exit the Click Map dialog. 
 
 
To CREATE a new Click Area: 

1. Click the Create Area … button on the Context Sensitive toolbar. 

2. Select one of the menu options to draw (create) the Drop Area: 
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a. Create Area with Rectangle Tool: Use this option to create a 
rectangular shaped Drop Area on the slide. 

b. Create Area with Ellipse Tool: Use this option to create an elliptical 
(circle or oval) shaped Drop Area on the slide. 

c. Create Area with Lasso Tool: Use this option to create a free-form 
shaped Drop Area on the slide. 

d. Create Area with Poly Lasso Tool: Use this option to create a polygon 
shaped Drop Area on the slide. 

3. When the cursor changes to a cross-hair, hold down the left mouse button on the 
area of the slide where you want to draw the Drop Area. Drag to draw the area. 

4. Let go of the left mouse button to complete the Drop Area. 
 
 
To REDRAW a Drop Area: 

1. Click on the Drop Area you want to redraw to select it. 

2. Click the Redraw Area button on the Context Sensitive toolbar. 

3. Select one of the menu options to redraw the Drop Area: 

a. Create Area with Rectangle Tool: Use this option to redraw a 
rectangular shaped Drop Area on the slide. 

b. Create Area with Ellipse Tool: Use this option to redraw an elliptical 
(circle or oval) shaped Drop Area on the slide. 

c. Create Area with Lasso Tool: Use this option to redraw a free-form 
shaped Drop Area on the slide. 

d. Create Area with Poly Lasso Tool: Use this option to redraw a polygon 
shaped Drop Area on the slide. 

 
 
To RESIZE / MOVE a Drop Area: 

1. Click on the Drop Area to select it. A “bounding box” displays around it. 

2. Use the “grab handles” to drag and resize the Drop Area as desired. 

3. To move the Drop Area, point your cursor over the object and hold down the left 
mouse button and drag it to a new location on the slide as desired. 

 
 
To REMOVE a Drag and Drop question from the slide: 

1. Click on the Insert Question button on the Objects Toolbar. 

2. A Warning dialog displays. Select the Remove It option. 

3. Click OK to complete the deletion. 
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Resize Project  
The Resize Project feature lets you resize your current project directly within the project, 
while inserting new screenshots, or even while importing slides from a project (whether 
or not the slides are the same size as the current project). Let’s take a look at how this 
works. 
 

 
 

1. Select Project > Resize Project from the Menu. 

2. The Project Resize dialog displays: 

a. In the Current Project Size area, the project’s original size displays. 
Review this information. 

b. In the New Project Size area: 

i. Enter a number for the new Width and Height in the fields 
provided. 

ii. To maintain the correct ratio between the new width and height, 
select the Maintain Aspect Ratio option BEFORE entering a 
number in either the Width or the Height field.  
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c. In the Scaling area, select one of the scaling options: 

i. Scale to Fit: Scales the slide background image to “best fit” the 
new slide dimensions.  
 
Additionally, to Scale a slide object, select the check box next to: 
 

• Shapes 
• Click Areas 
• Images 
• Movies 

 
Each of the selected slide objects will be scaled to fit in proportion 
to the new slide size. 
 

ii. Align Slide: Maintains the current size of the slide’s background 
image and aligns it on the new slide based on the alignment 
selection. Normally used when the new project (slide) size is 
larger than the original project dimensions. After selecting this 
option, select an alignment option from the alignment menu. 
 

3. Click OK to resize the project. 
 
Note: If a “Warning” dialog displays after clicking “OK”, read the information in it and click “OK” to 
close the dialog. Then, back in the “Resize Project” dialog, edit the selections as instructed by the 
warning and click “OK” to resize the project. 
 
 
 

ViewletBuilder8 Enterprise User Guide Page 249  © 2014 rev. 0626 



 
 
 

Crop Project 
ViewletBuilder8 Enterprise offers you the ability to crop the dimensions of your project’s 
slide size. An alternative to the “Resize Project” feature, the “Crop Project” feature will 
crop the project’s slide without the need for scaling the background image. Let take a 
look at how this works. 
 

 
 

CROPPING THE SLIDE 
Note: The “Crop Project” operation cannot be undone, so make sure you create a backup copy of 
your project BEFORE you crop the original project’s slide size. 
 

1. Select Project > Crop Project from the menu bar. 

2. A Crop Project warning dialog displays. Read the information in the dialog and 
click Yes to continue with the cropping task. 

3. In the “Slide Edit” area, four “shaded” sections surround the current slide. The 
area in the shaded portions of the slide will be “cropped” out and the areas of the 
slide that are NOT shaded will not be cropped. 

4. To resize the “crop area”, point your cursor on one of the lines separating the 
shaded area and the unshaded slide area.  
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5. When your cursor changes to a “double arrow” shape, hold down the left mouse 
button and drag to resize the crop area. 

6. Let go of the left mouse button when you are finished resizing one of the edges 
of the crop area. 

7. To view the current dimensions of the new slide size as you resize the crop area, 
look at the top of the slide area where the “Width” and the “Height” are displayed. 

8. Once you’ve resized the crop area, click the Accept Crop button. Depending on 
the size of the project, you may see a progress bar display the status of the 
cropping operation. 
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Insert Movie 
You can insert (embed) Flash files directly to slides within your project. 
 

 
1. Select the slide on which you want to embed the movie file. 

2. Click the Insert Movie button from the Objects Toolbar. 

3. In the Insert Movie dialog: 

a. Embed Movie File:  

i. Click the Load a Movie (folder) button to locate and select a 
movie file (SWF or FLV). 

ii. Click Open to load the file into the Insert Movie dialog. 
 

b. Load from URL: 

i. Click the Load a Movie (globe) button. 

ii. The URL dialog displays. Type the URL to the movie file in the 
field provided  

iii. Click OK. 

c. Back in the Insert Movie dialog, review the information. 
 

4. Click OK to embed the movie on the slide. 
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PROPERTIES 
Once the movie file (SWF or FLV) is inserted on the slide, you can then review its 
properties and edit them as needed. 
 

 
1. Double click the inserted movie thumbnail located on the slide. 

2. The Movie Properties dialog displays with several tabs options. 

a. General Tab 
Review/edit the options in the Name and Location & Size areas. You can 
also review the information in the Frame Rate and Duration area for this 
movie. 

b. Source Tab 
Review information for the inserted movie file and edit as needed right 
from this tab. 

c. Options Tab 
In the Options tab you can opt to display a: 

i. Preloader: as a waiting animation while to movie is being loaded 

ii. Control Bar: for the inserted movie in supported SWF files with 
their own embedded FLV movies 

d. Timing Tab 
Review the information provided. Then, based on the suggestions and 
your needs, select a timing option from the list, which includes: 

i. Manual Timing: Set the Start Time and Duration manually. 
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ii. Fixed Duration: Use the inserted movie’s own length of time for 
the duration. 

iii. Until End of Slide: Set the Start Time for the movie to play, using 
the movie original time for its playback length. 

iv. Pause Viewlet While Playing: (Recommended for most inserted 
movies) Set the Start Time for the movie to play, meanwhile, the 
Viewlet will be paused. 

v. Pause Viewlet While Playing – Resume When Complete: Set 
the Start Time for the movie to play. Like the “Pause Viewlet While 
Playing” the Viewlet will be paused while the movie is playing, 
when complete the Viewlet will resume. 
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Page Layout 
An often overlooked feature is Page Layout. This tool makes it easy for you to determine 
what your electronic and hardcopy (printed) materials will look like. And, it makes it an 
ideal tool for creating handouts, assessment, tests and more!). 
 
Note: Several publishing targets allow you access to page layout options directly from the 
Publishing dialog. 
 

1. Select File > Page Layout from the menu bar. 

2. The Page Layout dialog displays. In the Layout Type area, select a layout type 
from the list: 
 
Slide Layout 
This layout is used for setting options when printing slides as shown in the Slide 
Edit area while editing your project. 
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a. In the Header area, make selections for the Title, Display date and time, 

and Display slide border options. 

b. In the Layout area, select an orientation (Landscape or Portrait) and the 
number of rows/columns needed. 

c. In the Options area, select the elements you want to include on the 
printed slides. 

d. In the Footer area, if you want page numbers for each printed page, 
select the check box next to Page Numbers. 

e. After you make your selections in the Slide Layout dialog, you can 
preview results using the “VCR style” buttons (First, Back, Next, Last) to 
navigate through the slides in the preview area. 

f. In the Slides area, select which slides to print. 
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i. Current Slide: Select this option to print the slide selected prior to 
opening the Page Layout dialog. 

ii. From: Select this option and enter the number of the first slide to 
the last slide (in the fields provided) for the “series” of slide you 
want to print. 

iii. All Slides: Select this option to print all the slides in the project. 

 
Question Summary Layout 
This layout is used to create hard copy printouts such as handouts and also self-
assessments, tests and answer keys for projects containing question elements. 
 

 
a. In the Header area, make selections for the Title and Display date and 

time. 
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b. In the Layout area, select either Landscape or Portrait for the orientation. 

c. In the Options area, select the elements you want to include on the 
printed slides. 

d. In the Footer area, if you want page numbers on the printouts, select the 
check box next to the Page Numbers option. 

e. After you make your selections in the Question Summary Layout dialog, 
you can preview results using the “VCR style” buttons (First, Back, Next, 
Last) to navigate through the slides in the preview area. 

f. In the Questions area, select which slides to print. 

i. Current Question: Select this option to print the current question 
slide selected prior to opening the Page Layout dialog. 

ii. From: Select this option and enter the number of the first question 
slide to the last question slide (in the fields provided) for the 
“series” of question slides you want to print. 

iii. All Questions: Select this option to print all the question slides in 
the project. 

 
3. Once all the selections are made in the Page Layout dialog, select: 

a. Print: to open your system’s Print dialog to continue with the print 
operation. 

b. OK: to save the selections you’ve made as the default page layout 
options for the project. 

c. Cancel: to close the Page Layout dialog without saving any changes. 
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Printing 
There may be times you want to print your slides for users to view or as reference 
materials. When applicable, you will be able to customize Page Layout options for 
specific publishing targets. 
 

 
 
To PRINT a hardcopy of your slides: 

1. Select File > Print from the menu bar. 

2. The Print dialog displays. Select the options in this dialog for your print job as 
desired. (The options available in the Print dialog will vary.) 

3. Click the Print button to print the selected slides. 
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Export and Import Options 
ViewletBuilder8 Enterprise offers various export and import options. 
 

EXPORT OPTIONS 

 
 

Text for Translation 
To export the project’s text for translation or other copywriting purposes: 

1. Select File > Export > Text for Translation from the Menu bar. 

2. In the Export Text dialog, select a location to save the file, which will be saved in 
“XML” format. 

3. Enter a name for the file and click Save. 

4. If an Information dialog displays, click OK. 
 

Sound 
To export sounds from your project: 

1. Optional: Create a folder outside of ViewletBuilder8 Enterprise to save the 
exported sound file in. 

2. Select File > Export > Sounds from the menu bar. 

3. In the Export Sounds dialog, select what slides you want to export audio from. 

4. Click Export. The sound files will be saved in the designated folder with the 
same file names and as the same files types as they exist in your project. 
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Publishing Locations 
In order to resolve possible conflicts that might occur when publishing the same project 
from different computers, ViewletBuilder8 Enterprise offers the ability to create a file 
(publish.dat) to list the publishing locations available for the project. This file can be 
“transported” with the source file when publishing from different computers. 
 
To create a publishing locations data file: 

1. Select File > Export > Publishing Locations from the menu bar. 

2. In the Save File In dialog, select a folder to save the “publish.dat” file in. 

3. Click Save. 

4. An Information dialog displays. Read the information in it and click OK. 
 

 

IMPORT OPTIONS 
 

 
 

Slides 
To import slides from another project: 

1. Select a thumbnail as an insertion point for imported slides. Imported slides will 
be inserted after the selected slide. 

2. Select File > Import > Import Slides from the menu bar. 
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3. In the Import Slides dialog, click Browse. Locate and select a QVP file to load 
into the preview dialog. 

4. Select the slide or slides to import. 

5. If the slides you select to import are a different size, the Slide Alignment dialog 
displays requiring you to make some additional selections: 

a. In the New Size area, select: 

i. Project Size: This option will resize the imported slides to match 
the size of the current project. 

ii. Imported Slide Size: This option will resize the current project to 
match the size of the imported slides. 
 

b. In the Imported Slides Alignment area, if you selected the Imported Slide 
Size option in the New Size area, select an alignment option for the 
imported slides: 

c. Scale to Fit: This option will scale the imported slides to “best fit” the 
current project’s slide size and center the image on the slides. 
 
Additionally, to Scale a slide object, select the check box next to: 
 
 Shapes 
 Click Areas 
 Images 
 Movies 

 
Each of the selected slide objects will be scaled to fit in proportion to the 
new slide size. 
 

d. Align Slide: This option will retain the original size of the imported slides, 
but will align the image on the slide based on your alignment selection.  

6. Click OK and the slides will be imported into the current project. 

 

Question Bank 
To import a Question Bank: 

1. Select File > Import > Import Question Bank from the menu bar. 

2. In the Import Question Bank dialog: 

a. Browse to select the desired project to open it in the dialog. 

b. Select the desired Question Bank from the list. 

c. Select the slides you want to import. 

d. In the Import To area, select where to import the slides: 

i. Main Timeline: Selected slides will be inserted on the project’s 
Main Timeline. 
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ii. Existing Question Bank: Selected slides will be inserted into a 
selected (existing) Question Bank within the project. 

iii. New Question Bank: A new Question Bank with selected slides 
will be inserted into the existing project. 

e. Click OK. 
 

Text for Translation 
To import text for translation: 

3. Select File > Import > Text for Translation from the menu bar. 

4. The Import Text dialog displays. Locate the text translation XML file. This is the 
file previously created from this Viewlet when using the “Export > Text for 
Translation” option. 

5. Click Open. 

6. If an Information dialog displays, click OK. 
 
 
 

Publishing Locations 
In order to resolve possible conflicts that might occur when publishing the same project 
from different computers, ViewletBuilder8 Enterprise offers the ability to create a file 
(publish.dat) to list the publishing locations available for the project. This file can be 
“transported” with the source file when publishing from different computers. 
 
To publish a project from a different computer using the publish.dat file: 

1. Select File > Import > Publishing Locations from the menu bar. 

2. The Import Publishing Locations dialog displays. Click the Browse button. 

3. Locate the publish.dat file previously created when working on your project on 
the original computer used to publish it. 

4. Click Open. 

5. Back in the Import Publishing Locations dialog, a list of available publishing 
locations display. Select the publishing location to use to publish the project by 
clicking the check box next to the desired location. 

6. Click OK to import the selected publishing locations in ViewletBuilder8 Enterprise 
to use for the current project. 
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Project Properties 
The Project Properties dialog is where you configure all the options that will be used for 
your published Viewlet. These selections may be modified on a project-by-project basis. 
The Project Properties dialog contains the following sections: 

 Viewlet Profile 
 Image Quality 
 Sound Quality 
 Viewlet Sounds 
 Timing 
 Viewlet Options 
 Question Options 
 Language 
 ViewletSkin 
 HTML Frame 
 Javascript 

 
 
To ACCESS the Project Properties dialog: 

1. Select Project > Project Properties from the Menu bar. 

2. The Project Properties dialog displays. Configure pre-publishing options in each 
section as needed. 

 
 
To set DEFAULT PROPERTIES for your project: 

1. Select Project > Project Properties from the Menu bar. 

2. In the Project Properties dialog, make your pre-publishing selections in each 
section as needed. 

3. Click the Save As Default Properties button to save these settings as the 
default options for this and new projects. 

 
To set SAVE options selected in Project Properties: 

1. Select Project > Project Properties from the Menu bar. 

2. In the Project Properties dialog, make your pre-publishing selections in each 
section as needed. 

3. Click OK to save the selections and exit the dialog. 

 

VIEWLET PROFILE 
Information entered in this section of the Project Properties dialog is embedded into the 
Viewlet. 
 

1. In the Project Properties dialog, select Viewlet Profile.  
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2. The profile section is organized into three tabs: Viewlet, Author and Company. 
Select a tab and complete the information in each: 

a. Viewlet tab: 
 

 
 

i. Title: Enter a title for the demo to display in the browser’s title bar 
area. 

ii. Description: Enter a description of the demo to display in the 
information window. 

iii. Keywords: Enter keywords or phrases (separated by commas) 
that can be used for searches. 
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b. Author tab: 
 

 
i. Name: Enter in the author’s name. 

ii. Email: Enter in the author’s email address. 

iii. Comments: Enter in any additional author comments for the 
project.  

iv. Photo: Load a picture of the author (128 x 128): 

1. Click the Load Author Photo button. 

2. Locate, select and Open the image to load it in the preview 
area. 

3. To delete / remove the author’s photo, click the Remove 
Author Photo button. 
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c. Company tab: 
 

 
i. Company: Enter the company name. 

ii. Department: Enter the department name. 

iii. Small Logo: Load a small logo image (24 x 24). (This replaces the 
Qarbon logo on the ViewletSkin). 

1. Click the Load Small Logo button. 

2. Locate, select and Open the image to load it in the preview 
area. 

3. To delete / remove the small logo image, click the Remove 
Small Logo button. 

iv. Large Logo: Load a large logo image (64 x 64). This replaces the 
Qarbon logo in the Information window.  

1. Click the Load Large Logo button. 

2. Locate, select and Open the image to load it in the preview 
area. 

3. To delete / remove the small logo image, click the Remove 
Large Logo button. 
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IMAGE QUALITY 
This section of the Project Properties dialog determines the image compression quality 
used for the published project. 
 

 
1. In the Project Properties dialog, select Image Quality. 

2. In the Image Quality area, select a compression level: 

a. Highest quality (lowest compression) 

b. High quality (medium compression) 

c. Medium quality (high compression) 

d. Low quality (highest compression) 
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e. Custom quality:  
 

 
i. Click the Configure button. The Custom Image Quality dialog 

displays. 

ii. In the Custom Image Quality dialog, select options in the following 
areas: 

1. Slide elements: Select the compression option to use for 
slide elements from the list. 

2.  Images: Select compression options for inserted images 
(not background frames). 

3. Background Frames: Select compression options for the 
slides background frames. 
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4. Video Frames: Select the compression option for Video 
Capture slides. 

5. Click OK to save custom settings and to exit the Custom 
Image Quality dialog. 

 

SOUND QUALITY 
The Sound Quality section of the Project Properties dialog offers sound quality options 
for the published Viewlet. Any selections made in this section will NOT impact the source 
project file ONLY the published file. 
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1. In the Project Properties dialog, select Sound Quality. 

2. In the Sound Quality area, choose the sound quality to apply to the published 
Viewlet: 

a. CD quality (44,100 hz – 16 bit) 

b. High quality (22,050 hz – 16 bit) 

c. Standard quality (11,025 hz – 16 bit) 

d. Strip all sounds 

3. If you do NOT strip all sounds, you can select the Use stereo sound (default) 
option for the published sound. 

 

VIEWLET SOUNDS 
Additional sound elements made be selected for your file in the Viewlet Sounds section 
of the Project Properties dialog. 
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1. In the Project Properties dialog, select Viewlet Sounds. 

2. In the Cursor Click Sound area: 

a. Select the sound to be played for cursor clicks from the list.  

b. Click the Play button to preview the sound. 

3. In the Keyboard Typing Sound area: 

a. Select the sound to be played for keyboard typing simulation from the 
list. 

b. Click the Play button to preview the sound. 

4. In the Soundtrack area: 

a. Click the Load Sound button to locate, select and Open a sound file to 
use for the background soundtrack. (You can remove a soundtrack by 
clicking the Delete Sound button. 

b. Select the Loop at End option to loop the soundtrack file. 

c. Select the Pause During Zones and Questions to pause the 
soundtrack playback during interactive zones and question slides. 

i. Select the Don’t pause on Pause Zones for slides containing 
just interactive pause zones so the soundtrack continues on 
these slides. 

d. Enter a number for the playback Volume percentage level. 
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TIMING 
The Timing section of Project Properties offers selections for minimum message 
duration, reading /cursor speed and slide timing. 
 

 
 

1. In the Project Properties dialog, select Timing. 

2. In the Minimum Message Duration area, set a number (in seconds) for the 
minimum time a balloon or note will display. 

3. In the Reading Speed area, enter a number for words per minute or characters 
per minute (select one of these options form the list) for calculating the reading 
speed. 

4. In the Cursor Speed, select an option from the list for the cursor animation 
speed. 

5. In the Maintain Slide Timing area: 

a. Select the Enable option to enable slide timing elements. 

b. If enabled, enter a number (in seconds) for the initial note’s or balloon’s 
introductory delay. 
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VIEWLET OPTIONS 
This section of Project Properties lets you configure settings for how the Viewlet will 
initially display on playback, cursor shapes for different events, start button, preloader, 
animated extras, and various advanced options. 
 

1. In the Project Properties dialog, select Viewlet Options. 

2. Select one of the various tabs available for configuring additional options for the 
published Viewlet: 

a. General tab: 
 

 
i. In the Display Size area, set the initial display size for the Viewlet. 

ii. In the Other Options area, select additional options as needed: 

1. Use hand for cursor for OnClick events 

2. Use hand cursor for ClickZones 

3. Play Mouse Click Animation 

4. Enable Keyboard Navigation 

5. Display Closed Captions 
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b. Start Button tab: 
 

 
i. Select the Display a Start Button over the top of the Viewlet 

option (if desired). If this option is not selected, you will not have 
access to any other options in this tab. 

ii. Preview area: As you make changes in this tab, a preview area 
shows what the button will look like in the published file. 

iii. In the Style area, select either Arrow or Circled Arrow for the 
button style. 

iv. In the Scale area, enter a number (percentage of slide) to scale 
the button. 

v. In the Color area, select a color and enter a number for the 
opacity level each button’s state (Normal, Down, Over, 
Background). 
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vi. In the Drop Shadow area: 

1. Select the Display option (if you want to apply a shadow 
effect to the button). 

2. Enter numbers for the shadow’s offsets, blur radius and 
opacity. 

3. Click the Shadow Color button to choose a color for the 
shadow effect. 
 

c. Extras tab: 
 

 
i. In the Preloader area: 

1. Select the Display a waiting animation while the Viewlet 
is being loaded option to use the preloader feature for the 
published file. 

2. Select an option for the preloader to ‘wait’ while the Viewlet 
is streaming. 
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ii. In the Animated Extras area: 

1. Beginning: Click the folder icon to search for and locate a 
SWF file to load at the front end of the Viewlet. 

2. Ending: Click the folder icon to search for and locate a 
SWF file to load at the back end of the Viewlet. 
 

d. Advanced tab: 
 

 
i. In the Frame Rate area, enter the number of frames per second to 

use for the published Viewlet. 

ii. In the Options area select additional choices for the published file: 

1. Compress Movie 

2. Loop Mode 

3. Local Access Mode 

4. Reduce Flash Context menus 

5. Disable JavaScript to Flash Interface 

iii. In the External SWF Files area, select the Enable External SWF 
Files to improve playback performance. 
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QUESTION OPTIONS 
The Question Options section of Project Properties let you set up options for login, 
scoring, feedback, time limits and various advanced settings for the published Viewlet. 

1. In the Project Properties dialog, select Question Options. 

2. Select each of the various tabs for setting question slide options: 

a. General tab: 
 

 
i. In the Login Options, select options for forcing viewers to login 

and/or to enter a password before playing the Viewlet. 

ii. In the Scoring Options, set additional scoring options for: 

1. Pass / Fail % 

2. Allow Repeat 

3. Clear Answer on Retry 

4. Display Score Panel on Last Slide of Viewlet 
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b. Scoring tab: 
 

 
i. In the Points area, enter a number for the question’s total point 

value. 

ii. In the Attempts area, enter a number for the total number of times 
the viewer can attempt to answer correctly. 

iii. In the Reanswer area, select / deselect the Question can be 
reanswered on backwards navigation option. 

iv. In the Time area: 

1. Select the Enable a time limit for the question to set a 
time limit for question slides. 

2. If enabled, enter a number for hours, minutes and seconds 
for the time limit. 
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c. Responses tab: 
 

 
i. In the Correct Message area, enter the default text to be used in 

the feedback message when the viewer answers correctly. 

ii. In the Incomplete Message area, enter the default text to be used 
in the feedback message when the viewer tries to submit when no 
answer is selected. 

iii. In the Incorrect Message area, enter the default text to be used in 
the feedback message when the viewer answers incorrectly. 
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d. Time Limit tab: 
 

 
i. Select the Time Limit option to enable time limit for the entire 

project. 

ii. If enabled, enter a number for hours, minutes, seconds. 

iii. Add additional actions to perform when the Viewlet’s time limit is 
reached (see the Events and Actions chapter for more information 
on working with actions). 
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e. Advanced tab: 
 

 
i. In the Submit Score Warnings area: 

1. Select the Display Submit Score Warnings option to 
enable this feature. 

2. If enabled, select an option for when the user will be 
prompted. 

ii. In the SCORM Options area, select / deselect the Use Choice 
Indexes for SCORM Reporting option. 

iii. In the Options area, select the Disable navigation during 
Questions and Interactive Zones option to disable the player bar 
during playback on these slide types. 
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LANGUAGE 
Viewlet localizes demo elements using the default language set in the Preference dialog. 
In the Language section of Project Properties lets you override these defaults by 
customizing language options for the login panel, side bar, status area, results panel, 
resume panel and submit score warnings. 
 

1. In the Project Properties dialog, select Language. 

2. Select each of the various tabs for setting language options: 

a. Login Panel tab: Enter label titles for the login panel’s fields (Login, 
Username, Password, OK, Incorrect Password). 
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b. Side Bar tab: Enter label titles for the side bar’s areas (Outline Tab, Slide 
Tab, Notes Tab, Table of Contents, Points Column). 
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c. Status Area tab: Enter labels and variables (when applicable) for the 
status bar (Current Time, Paused Status, Slide Progress, Quiz Progress, 
Quiz Score, Time Remaining). 
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d. Results Panel tab: Enter label titles for the results panel fields (Results, 
Correct, Incorrect, Attempts, Passing Score, Your Score, Passed, Failed, 
Close, Repeat). 
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e. Resume Panel tab: Enter text for the title and message to display for the 
results panel. 
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f. Submit Score Warning tab: Enter labels for titles and text for additional 
information (where applicable) for the warning dialog (Retry Submit, 
Dismiss Warning, Cancel Submit, Unable to Submit, Final Scores 
Already Submitted). 
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VIEWLETSKIN 
The ViewletSkin section of Project Properties let you personalize settings for the look 
and feel on your published Viewlet. 

1. In Project Properties select ViewletSkin. 

2. Select a ViewletSkin from the drop-down list. The selected skin will determine 
the additional options available in each of the tabs. 

3. Select each of the various tabs for setting ViewletSkin options: 

a. Preview tab: 

i. Preview the skin in the preview area. 

ii. Several skins have additional configuration options: 

1. Qarbon ViewletSkin: Customize options for: 
 

 
a. Bars / Panels background color and opacity. 

b. Buttons (Normal and Over states) color and 
opacity. 

c. Click the Reset to Default button to reset these 
options back to installed settings. 
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2. Qista ViewletSkin: Customize options for: 
 

 
a. Bars / Panels background color and opacity. 

b. Click the Reset to Default button to reset these 
options back to installed settings. 
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3. Qomplex ViewletSkin: 
 

 
a.  Bars / Panels background color and opacity. 

b. Buttons (Normal and Over states) color and 
opacity. 

c. Click the Reset to Default button to reset these 
options back to installed settings. 
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b. General tab: 

i. All ViewletSkins EXCEPT the Qomplex ViewletSkin: 
 

 
1. Select options for accessibility and whether or not to use 

embedded fonts. 
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ii. Qomplex ViewletSkin options: 
 

 
1. In the Starting Display Mode area, select an initial display 

mode option for playback: 

a. Full Mode: Shows table of contents and player 
bars. 

b. Player Mode: Shows everything except the table of 
contents. 

c. Movie Mode: Shows the Viewlet only. 
 

2. In the Accessibility area, select / deselect: 

a. Screen Reader Support 

b. Tab Enabled Navigation 
 

3. In the Alignment area, select either Left to Right or Right to 
Left alignment. 
 

4. In the Fonts area, to ensure the Viewlet looks the same 
across all platforms, select the Use Embedded Fonts 
option. 
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c. Title bar: (Qomplex ViewletSkin only) 
 

 
i. Select the Display the Title Bar option if you want to display the 

title bar in the browser. 

ii. If enabled, additional options, in the Buttons area, include: 

1. About Button: Select this option to allow the viewer to 
click an icon for more information about the Viewlet. 

2. Use Company Logo: Replaces the Qarbon logos with 
your company logos (if loaded in the Viewlet Profile 
section). 

3. Close Viewlet Button: Adds an ‘X’ button to the skin. 
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d. Side Bar tab: 

i. ALL ViewletSkins EXCEPT the Qomplex ViewletSkin: 
 

 
1. Select the Display the Table of Contents option to 

display a Table of Contents in the skin. 

2. If enabled, additional options include: 

a. Point Column 

b. Maintain Selection 
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ii. Qomplex ViewletSkin options: 
 

 
1. Select the Display the Side Bar option to display 

additional areas to include authoring information and 
photo, Table of Contents, slide thumbnails and slide notes. 

2. If enabled, additional options include: 

a. In the Author area: 

i. Select the Display option to include any (or 
all) of the following author items: 

1. Photo 

2. Name 

3. Company 

4. Department 

5. Email 
 

ii. In the Tabs area: 

1. Outline Tab: Select this option to 
display a Table of Contents, 
including: 
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a. Points Column 

b. Maintain Selection 

2. Slides Tab: Select this option to 
display slide thumbnails. 

3. Notes Tab: Select this option to 
display slide notes. 
 

e.  Player Bar tab: 

i. ALL ViewletSkins EXCEPT the Qomplex ViewletSkin: 
 

 
1. Select the Display the Player Bar option to display a 

player bar in the skin. 

2. If enabled, additional options include: 

a. In the Status area: 

i. Select the Display option to enable 
additional options for the player bar for 
question or interactive zone slides: 

1. Quiz Progress 

2. Quiz Score 

3. Time Remaining 
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b. In the Options area, select the Display the Slide 
Number via Shift Key to let the viewer press the 
Shift key on the keyboard to view slide numbers. 
 

ii. Qomplex ViewletSkin options: 
 

 
1. Select the Display the Player Bar option to display the 

player bar with the skin. 

2. If enabled, additional options include: 

a. In the Buttons area: Select buttons to display on the 
player bar that the viewer can use for navigation, 
viewing size, audio options and closed captions: 

i. Repeat 

ii. Play / Pause 

iii. Next 

iv. Preview 

v. Mute / Volume 

vi. Scale Viewlet 
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vii. Display Mode 

viii. Full Screen 

ix. Closed Captions 
 

b. In the Status Area: 

i. Select the Display option to display 
additional status information on the player 
bar, including: 

1. Current Time 

2. Slide Progress 

3. Quiz Progress 

4. Quiz Score 

5. Time Remaining 
 

ii. In the Options area, select / deselect 
options to: 

1. Auto Hide the Player Bar 

2. Display Slide Number via Shift Key 
 

c. In the Progress Bar area: 

i. Select the Display option to show the 
progress bar on the player bar. 

ii. Select the Play Head Enabled to display 
the play head on the player bar. 
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HTML FRAME 
The HTML Frame section of Project Properties provides you with several different HTML 
frames that you can use to ‘wrap around’ your Viewlet on playback. 
 

 
 
The frames include: 

 AccessibleFrame.qframe:  

 AccesibleSimpleFrame.qframe:  

 AiccFrame.qframe: Used for AICC reporting. 

 AiccPopupFrame.qframe: Used to launch Viewlet in a popup window for AICC 
reporting. 

 DebugFrame.qframe: Works the same as the Standard.qframe, but contains a 
debug window for Flash logging. 

 FullScreen.qframe: Opens Viewlet in a full screen window.  

 HTML5VideoFrame.qframe: Used with non-interactive video output formats 
(MP4, FLV). 
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 IE7AndAbove.qframe: Used with Internet Explorer 7 (and later version) 

browsers to work without a FlashTag (which blocked the Flash object until it was 
clicked in earlier IE6 and prior versions). 

 PopupFrame.qframe: Displays a link to open the Viewlet in a new window. 

 ShareThis.qframe: Used to share the Viewlet on Facebook, Twitter, Stumble IT 
and email. 

 Standard.qframe: This is the default frame used with most (regular) Viewlets. 

 XHTML.qframe  Similar to the Standard.qframe, just XHtml valid. 

 

If you are comfortable working directly in HTML code, then this features gives you the 
opportunity to tweak the code of any of the frames as needed. If, however, you are not 
versed in HTML, that’s not a problem. Just use the Standard.qframe. In fact, since this 
frame is selected by default, you don’t even have to make any changes in the HTML 
Frame section since the Standard.qframe works just fine with most Viewlets. 

  
To ACCESS HTML Frame options: 

1. Select Project > Project Properties from the Menu bar. 

2. In the Project Properties dialog that displays, select HTML Frame. 
 

 
To SELECT an HTML Frame: 

1. In the Project Properties dialog, select HTML Frame. 

2. Select an HTML Frame from the drop-down list (right side of dialog). In the Files 
area, additional files displays that will be used with the published files. In most 
cases, you do not need to go any further than selecting the HTML Frame you 
want to use with your published Viewlet. 

 

To MODIFY HTML Frame options: 

1. In the HTML Frame section of the Project Properties dialog, select an HTML 
Frame from the list. 

3. In the Files area, additional files (that work with the selection frame) display. You 
can add more files or modify any in the list.  

a. Add: Select this button to: 

i. Add new HTML file 

ii. Add file from your system 

b. Modify: Select this button to modify the selected file. 

c. Delete: Select this button to delete the selected file. 

d. Move Up / Move Down: Select these buttons to move a selected file up / 
down in the list. 
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To ADD a custom HTML Frame: 

1. In the HTML Frame of the Project Properties dialog, click the Add HTML Frame 
button. 

2. In the HTML Frame Properties dialog that displays, enter a Name for the custom 
frame. The extension: .qframe will automatically be added to the end of the file 
name, so you do NOT need to include it. 

3. In the Files area you will see additional files that work with the frame displayed. 
You can add new files, modify existing files or delete files from this list as 
needed. 

 
To DELETE an HTML frame: 

1. In the HTML Frame of the Project Properties dialog, select an HTML Frame from 
the list. 

2. Click the Delete HTML Frame button. 

3. When prompted, click Yes to confirm the deletion. 
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JAVASCRIPT 
In the Javascript section of the Project Properties dialog, you can add Javascript that 
gets included in your HTML pages. This section is for those comfortable working with 
Javascript and can be useful for creating global variables or custom functions. 
 

 
 
 
To ACCESS the Javascript feature: 

1. Select Project > Project Properties from the Menu bar. 

2. In the Project Properties dialog that displays, select Javascript. 
3. Read the instructions on the right side of the dialog for working with the 

Javascript feature. 

4. Enter your code in the field provided. 

 

There are some advanced features available in the Project Properties dialog not fully 
covered in this guide. If you require any more information on any of these pre-publishing 
options, please visit the Online Learning Center or contact us at support@qarbon.com. 
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Previewing a Viewlet 
You will see various VCR-styled buttons you can use to navigate through your project 
slides by going to the first slide, previous slide, next slide and/or last slide. 
 
Note: You can preview the slide background soundtrack, audio attached to objects, cursor click 
sounds and key click background frame sounds within ViewletBuilder8 Enterprise without 
publishing the project. 
 
Additionally, you may access preview options: 
 

 
 
From the Timeline: 
 
 Click the Preview button at the top right of the Timeline to preview the project, or 

 
 Click the down arrow and select a preview option from the menu list. 

 
From the menu bar: 
 
 Select Project from the menu bar. 

 
 Select a preview option: 

 
o Preview Current Slide: Plays the current slide inside ViewletBuilder8 

Enterprise. 
 

o Preview From Current Slide: Plays the project inside ViewletBuilder8 
Enterprise from the selected slide to the end of the project. 
 

o Preview All Slides: Plays the entire project while inside ViewletBuilder8 
Enterprise. 
 

o Preview in Browser: Quickly compiles (publishes) the file to SWF 
(Flash) format and launches it (from a temp folder) in a browser. 

 
Note Displaying the informational “About” dialog during Viewlet playback pauses the Viewlet. 
Closing the dialog returns the Viewlet to play mode. 
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After publishing a project: 
 
 Select Project > Publish Viewlet from the menu bar. 

 
 Complete the information in the dialogs that display to publish your project. 

 
 In the last Publish Viewlet dialog, click the View button to preview the published 

Viewlet. 
 
Note: You can also preview a published Viewlet Flash file by locating the _viewlet_swf.html file 
associated with the project. Double click this file to launch the Viewlet in the browser. 
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Publishing 
The Publish Viewlet dialog offers various options for publishing your Viewlet project. This 
chapter provides an overview of publishing options. 
 

THE PUBLISH VIEWLET DIALOG 
The Publish Viewlet dialog provides a ‘one-stop-shop’ location for all of your Viewlet 
project publishing needs. What this means is that all of your publishing options are found 
in one central location, making it easier than ever to get the job done. 
 

 
 
To ACCESS the Publish Viewlet dialog: 

1. Make sure that you have selected all the options you want to use when 
publishing your project in the Project Properties dialog. 

2. Save your project. 

3. Select Project > Publish Viewlet from the Menu bar. The Publish Viewlet dialog 
displays. 

 

Add / Modify / Remove Publishing Targets 
This section provides some general information for adding new publishing targets and 
modifying information for publishing targets (in general) already in the active list. 
 
To ADD a new publishing target: 

1. In the Publish Viewlet dialog, click the Add button. 

2. Select a publishing target from the list. 
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3. If a dialog displays after choosing a target, fill in the requested information and 
click OK to exit the dialog. 

4. The publishing target is added to the active list. 

 
To MODIFY a publishing target in the active list: 

1. In the Publish Viewlet dialog, select a publishing target from the active list. 

2. Modify the options on the right side of the dialog as needed. 

 

To REMOVE a publishing target from the active list: 

1. In the Publish Viewlet dialog, select a publishing target from the active list. 

2. Click the Delete button. This removes the selected publishing target from your 
active list only. You can add it back at any time. 

 

Publishing Targets 
ViewletBuidler8 Enterprise provides numerous options for publishing known as 
publishing targets. This section provides more information and instructions for working 
with each. 
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Current Project 
This option publishes files in the same location as your current project. You can publish 
your Viewlet project as a SWF, FLV or MP4 video. 
 

 
 

1. Select Current Project as your publishing target. 

2. Configure the following options: 

a. Output Format: Select an output format (SWF, FLV or MP4). 

b. If publishing a SWF file with quiz or survey slides: 

i. Click Edit (pencil icon) next to the Send Results To: field. In the 
dialog that displays, select an option from the list: 

1. Results Not Sent: No results will be emailed. 

2. Qarbon Email Reporting Service: 

a. Email Address: Enter one or more emails that you 
want results sent to. 

b. Report Format: Select plain text or HTML for the 
email results format. 

3. Custom Reporting Server: Enter a URL where you want 
reporting results to be sent. If needed, click the 
‘Redirecting Viewlets Stats to your own Server’ link for 
more information. 

4.  Click OK to exit the Send Result To dialog. 
  

ViewletBuilder8 Enterprise User Guide Page 308  © 2014 rev. 0626 



 
 
 

ii. Optional: Select additional options as needed: 

1. Create Subfolder. 

2. Write Output to a ZIP file. 

3. Enable Resume. 

3. Click Publish to publish your Viewlet project. 

 

Local or Network Folder 
This option publishes files to a selected local or network folder. You can add as many 
local or network publishing locations as desired.  
 

1. Select Local or Network Folder as your publishing target. 

4. Configure the following options: 

a. Output Format: Select an output format (SWF, FLV or MP4). 

b. If publishing a SWF file with quiz or survey slides: 

i. Click Edit (pencil icon) next to the Send Results To: field. In the 
dialog that displays, select an option from the list: 

1. Results Not Sent: No results will be emailed. 

2. Qarbon Email Reporting Service: 

a. Email Address: Enter one or more emails that you 
want results sent to. 

b. Report Format: Select plain text or HTML for the 
email results format. 

3. Custom Reporting Server: Enter a URL where you want 
reporting results to be sent. If needed, click the 
‘Redirecting Viewlets Stats to your own Server’ link for 
more information. 

4.  Click OK to exit the Send Result To dialog. 

ii. Optional: Select additional options as needed: 

1. Create Subfolder. 

2. Write Output to a ZIP file. 

3. Enable Resume. 

2. Click Publish to publish your Viewlet project. 
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FTP Server 
This option allows you to set up an FTP server location as a publishing target. 
 

 
 

1. Select FTP Server as your publishing target. 

2. In the FTP Server dialog, enter information for the following: 

a. Name 

b. Server 

c. Directory 

d. Login 

e. Password 

f. Port 

g. Passive 

3. Click the Test Connection to validate the information is correct and a connection 
can be established. 

4. Click OK to close the FTP Server dialog. 

5. On the right side of the Publish Viewlet dialog: 

a. Output Format: Select an output format (SWF, FLV or MP4). 

b. If publishing a SWF file with quiz or survey slides: 

i. Click Edit (pencil icon) next to the Send Results To: field. In the 
dialog that displays, select an option from the list: 
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1. Results Not Sent: No results will be emailed. 

2. Qarbon Email Reporting Service: 

a. Email Address: Enter one or more emails that you 
want results sent to. 

b. Report Format: Select plain text or HTML for the 
email results format. 

3. Custom Reporting Server: Enter a URL where you want 
reporting results to be sent. If needed, click the 
‘Redirecting Viewlets Stats to your own Server’ link for 
more information. 

4.  Click OK to exit the Send Result To dialog. 

ii. Optional: Select additional options as needed: 

1. Create Subfolder. 

2. Write Output to a ZIP file. 

3. Enable Resume. 

6. Click Publish to publish your Viewlet project. 

 

Qarbon ViewletCentral 
This option publishes your project directly to Qarbon ViewletCentral and requires either a 
FREE or paid subscription to Qarbon ViewletCentral. In the Qarbon ViewletCentral 
dialog (accessed when selecting this publishing target for the first time or when clicking 
the Modify Account button), enter/edit your Qarbon ViewletCentral account information. 
Please refer to the Qarbon ViewletCentral User Guide for more information on publishing 
options. 
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ViewletCentral Self Hosted 
The publishing target lets you publish your projects directly to your organization’s 
ViewletCentral Self Hosted account. This requires the purchase of a ViewletCentral 
Enterprise account. In the ViewletCentral Self Hosted dialog (accessed when selecting 
this publishing target for the first time or when clicking the Modify Account button), 
enter/edit your ViewletCentral Self Hosted account information (provided to you by your 
system administrator). Please refer to the ViewletCentral Self Hosted User Guide for 
more information on publishing options. 

 

YouTube 
Use this option to publish your Viewlet directly to your YouTube account. 
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1. Select YouTube as your publishing target. 

2. Optional: Click the Edit button to edit your YouTube account information. Edit the 
information in the YouTube dialog and click OK to exit this dialog. 

3. Enter a Title. 

4. Enter a Description. 

5. Select a Category from the list. 

6. Select a Privacy setting from the list. 

7. Click Publish to publish your project to YouTube. 
 
Note: Each time you make changes to your Viewlet, you will need to publish it again as a new file 
to your YouTube account when using this publishing target. 

Facebook 
This option allows you to publish to Facebook. 
 

 
 

1. Select Facebook as your publishing target. 

2. Click the Please authenticate your Face account button. A new browser 
window displays to perform the authentication and approve permissions. 

3. Back in ViewletBuilder8 Enterprise, the button changes to Please complete 
your Facebook authentication. 

4. Enter a Title. 

5. Enter a Description. 

6. Click Publish. 
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CD / DVD / Executable 
This publishing target let you publish your Viewlets out as executable files for Windows, 
Linux and Mac operating systems. 
 

 
 

1. Select CD / DVD / Executable as your publishing target. 

2. Select an option as your published files format. 

3. Optional: Select Play executable file fullscreen if you want the video to open in 
fullscreen mode. 

4. Select the Destination folder for your published files. 

5. Click Publish. 

 

AICC 
This publishing target publishes your project to meet AICC compliancy for your Learning 
Management System. 
 

 
 

1. Select AICC as your publishing target. 

2. Select the Destination folder for your published files. 

3. Click Publish. 
 
 

SCORM 
This publishing target meets the compliancy standards for either SCORM 2004 or 
SCORM 1.2. 
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1. Select SCORM as your publishing target. 

2. Click the Advanced button. The SCORM Advanced Options dialog displays. 

3. Select one of the tabs to make additional selections based on the SCORM option 
chosen: 

a. SCORM 1.2 tab: 

i. In the Send Score to LMS as area: 

1. Choose either Score or Percent. 
2. Select the Do not sent score... option (if applicable). 

ii.  In the Lesson Status area, select: 

1. Always use Complete/Incomplete if there are no scored 
slides in the file. 

2. Report Pass/Fail if applicable to the report data if there 
are scored elements in the file. 

iii. Select Include passing score in the manifest. 
 

b. In the SCORM 2004 tab: 

i. Select one or both of the following options: 

1. Include passing score in the manifest 

2. Allow pass before completion 

ii. In the XML Escaping area, select the Enable XML escaping of 
quotes if your LMS doesn’t handle quotes properly. 

iii. In the Multi Answer Delimiter, select a character to use as the 
Delimiter (separator) of possible answers in reporting. 
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4. Click OK to close the SCORM Advanced Options dialog. 

5. Select the Create a zip file option to create a ZIP deployment package during 
the publishing process. 

6. Select the Enable Resume option. 

7. Select a Destination folder for your published files. 

8. Click Publish. 

 

PDF Document 
This publishing target publishes your file directly to PDF format. 
 

 
 

1. Select PDF Document as your publishing target. 

2. Select a Destination folder for the published file. 

3. Click the Page Layout button. In the dialog that displays, select options for the 
layout of the PDF page elements as needed, and click OK to close that dialog. 

4. Click Publish. 

 

Word / RTF Document 
This publishing target publishes your Viewlet to Word or RTF format. 
 

 
 

1. Select Word / RTF Document as your publishing target. 

2. Select a Destination folder for the published file. 

3. Click the Page Layout button. In the dialog that displays, select options for the 
layout of the page elements as needed, and click OK to close that dialog. 

4. Click Publish. 

ViewletBuilder8 Enterprise User Guide Page 316  © 2014 rev. 0626 



 
 
 
HTML Document 
This publishing target creates a basic HTML page with images of your project slides. 
 

 
 

1. Select HTML Document as your publishing target. 

2. Select a Destination folder for the published file. 

3. Select an Image Type (and Quality if selecting a JPG file) from the list. 

4. Click the Page Layout button. In the dialog that displays, select options for the 
layout of the page elements as needed, and click OK to close that dialog. 

5. Click Publish. 

 

Image Set 
This publishing target publishes the slides of your project as individual image files in a 
format chosen by you. 
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1. Select Image Set as your publishing target. 

2. Select a Destination folder for your published files. 

3. Select an Image Type (and Quality if selecting a JPG file) from the list. 

4. Enter a File Prefix to use as the prefix in each image’s file name. 

6. Click the Page Layout button. In the dialog that displays, select options for the 
layout of the page elements as needed, and click OK to close that dialog. 

5. Click Publish. 
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Qarbon User Forum 
Want to share ideas on Viewlet Authoring? Are you hunting for a specific authoring trick 
to take your Viewlets to the next level? Qarbon offers a Viewlet user forum just for you. 
It’s free to join and free to use. It’s a great place to meet other Viewlet enthusiasts from 
across the globe and spotlight your own great Viewlet ideas too! 
 

  
 
Go to: http://forum.qarbon.com/ 
 
Sign up and join in the fun! 
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Self-Help Resources 
In addition to this user guide, additional self-help resources are available online. Just 
click the Help link in the navigation menu. One of the many options available is the 
Qarbon Learning Center, which will launch your browser providing you access to our 
online user guides, FAQs, Viewlet tutorials and the Qarbon User Forum. 
 

 
 
You can also access the online Learning Center by visiting our site at: 
 
http://www.qarbon.com/help/ 
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Training 
Qarbon offers several different types of training opportunities to its clients, depending on 
your needs. Start with a FREE webinar for an overview on the product of your choice. If 
this isn’t enough, sign up for one of several product-specific workshops. Workshops are 
offered as two 90-minute sessions and are limited to 10 students each. This is a great 
way to brush up on the basics and even learn a new trick or two. Qarbon also offers 
private coaching tailored to meet your needs. Offered on an hourly basis, meet with us 
for a free consultation and we’ll design a training session just for you! 
 

 
 
For current training opportunities, email us or visit our site: http://www.qarbon.com. 
And, click the ‘Services’ link in the navigation menu and choose a current training 
opportunity from the available list. 
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Sales 
If you have any questions on Qarbon ViewletCentral (or other Qarbon products and 
services), please feel free to contact our Sales, Customer Service or Support staff at any 
time.  
 

 
 
For current contact information, visit our site at:  
 
http://www.qarbon.com/about_us/contact_us/ 
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