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Welcome to ViewletBuilder6.1 Enterprise

Qarbon welcomes you to the exciting world of Viewlet technology.

People are natural visual learners, so a quick animated Viewlet gets the point across
much more effectively than words on a page. And, with millions of presentations
launched every month, Viewlets are one of the most popular ways of sharing
information, providing support, presenting products and training staff.

ViewletBuilder6.1 Enterprise, the authoring tool used to create Viewlets, allows anyone,
regardless of technical or creative ability, to make compelling, animated online
presentations with ease. Due to its versatility, intuitive interface and incredibly quick
creation time, ViewletBuilder6.1 Enterprise is a standard content creation tool in
corporations, governmental institutions and academic organizations throughout the
world.

ViewletBuilder6.1 Enterprise combines the power of ViewletBuilder6.1 Professional with
the highly dynamic and interactive features found in ViewletQuiz3.1. This user manual is
designed to introduce you to the world of Viewlet authoring and provide you with an
overview of the most important ViewletBuilder6.1 Enterprise features you will need to
know to create your own Viewlets.

Let's get started.

VB6.1 Enterprise User Manual Page 1 March 2009
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New and Enhanced Features

ViewletBuilder6.1 Enterprise introduces some new features and many enhancements,
making the program even more versatile, the creation process smoother and published
content more compelling. Some of the new and enhanced features include:

Message Editing Preferences (Edit in Place; Message Editor)

Capture Profiles (Screenshot Projects; Screenshot Slides)

Capture Options (New and Reorganized Option Tabs)

Alternate Fonts (PowerPoint Projects; PowerPoint Slides)

Quiz Project (New Project Type Combining Quiz and Survey Project Types)
Arrange Layers via Drag and Drop Actions

Cursor Capture and Click Capture Management Options (The Mouse Tab)
Message Editor Dialog Window

Automatic Resize of Message Objects Feature

RAW Audio File Format Support

Play Sound Action Options (Synchronicity and Concurrency)

Auto Submit Key Option (Text Zones; Text Input Fields)

Keystroke Zone Tips for International Users

Resize Project

Crop Project

Page Layout Options — Balloons and Notes

Publishing Locations

Importing Slides with Different Sizes (Slide Alignment Window Options)
Additional Status Bar Selections

Disable JavaScript to Flash Interface Option

ViewletSkin Embedded Fonts

Zip File Options for SCORM 2004 and SCORM 1.2 LMS Publishing

In this user manual it's even easier to spot new and enhanced features and important
Viewlet authoring tips within the manual. Just “skim” down the left margin and be on the
lookout for one of these icons:

e [Femire

Read up for more information on a feature that is “new” or
“enhanced” in ViewletBuilder6.1 Enterprise.

e
Don't let this “tip” pass you by. Find out how to improve your Viewlet
authoring skills with suggestions from the experts.

If you have any questions, please contact us. Or, visit our web site (www.garbon.com)
for more information on all of Qarbon’s products.

VB6.1 Enterprise User Manual Page 2 March 2009
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Tech Specs

The technical specifications, including minimum system requirements, for the effective
use of ViewletBuilder6.1 Enterprise will depend on various factors, including your
operating system. Go to the ViewletBuilder6.1 Enterprise product page (the link can be
found on the Qarbon’s web site home page at www.garbon.com). On the product page
select the “Technical Specs” (or related) link for more information.

If you have any questions after reviewing the technical specifications for

ViewletBuilder6.1 Enterprise, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.

VB6.1 Enterprise User Manual Page 3 March 2009
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Download and Installation

To download ViewletBuilder6.1 Enterprise, go to the Qarbon home page
(www.garbon.com). Click the “Downloads” link. On the “downloads” page, select
ViewletBuilder6.1 Enterprise as the product you want to download. Follow the
instructions on the rest of the web pages that display to download the installation file.

Remember the file name and folder location of the installation file so you can find it when
you are ready to install ViewletBuilder6.1 Enterprise.

After downloading the installation file, close the browser window. Then, locate and
double click the installation file to launch the installation wizard. Follow the prompts in
the installation wizard’'s windows to install ViewletBuilder6.1 Enterprise.

I Setup - ViewletBuilder6 Enterprise 6.1 g@
Welcome to the ViewletBuilderé Enterprise
Setup Wizard

This will install WiewletBuilders Enterprise on wour compuker,

It is recommended thak wou close all okher applications before
conkinuing.

Click Mext to continue, or Cancel ko exit Setup.

€17

]I'.

© Next > [ Cancel

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.

VB6.1 Enterprise User Manual Page 4 March 2009
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License Activation and Deactivation

You must purchase a license to activate ViewletBuilder6.1 Enterprise. To purchase a
license online, go to the Qarbon web site (www.garbon.com) and click the “Store” link
and select a pricing option. Or, you can contact the Qarbon Sales Team
(sales@qarbon.com) for current pricing and related purchasing information.

Once you purchase a license, you will receive a confirmation email with your license and
purchase information. Keep this email for your records.

License Activation

To activate ViewletBuilder6.1 Enterprise:
= Make sure your computer is connected to the Internet.
= Open the ViewletBuilder6.1 Enterprise program.
= Select Help > License Activation from the Menu bar.

Help
YiewletBuilders Help...  F1
User Guide. ..

ViewletCentral, ..

Training...
ViewletCreation, ..

YWiewletBranding. ..

License activakion. ..

Check for Updates. ..
About YiewletBuilders,

= Follow the instructions in the windows that display to complete the registration
process.

f’ For best results, copy the license number directly from your email and paste it in the
TR required field when registering ViewletBuilder6.1 Enterprise.

To check license information:
= Make sure your computer is connected to the Internet.
= Open the ViewletBuilder6.1 Enterprise program.
= Select Help > About ViewletBuilder6.1... from the Menu bar.
= Review the information in the About ViewletBuilder6.1 Enterprise window that
displays.
= Click Close to exit the window.

VB6.1 Enterprise User Manual Page 5 March 2009
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License Deactivation

There may be times when you will need to use your license on a different computer. To
avoid any license abuse issues (such as registering a single use license on more than
one machine at the same time, possibly resulting in your license being suspended), you
can deactivate your license. The process is simple.

To deactivate your ViewletBuilder6.1 Enterprise license:

= Make sure your computer is connected to the Internet.
Open the ViewletBuilder6.1 Enterprise program.
Select Help > License Deactivation from the Menu bar.

Help
YiewletBuilders Help...  F1
User Guide. ..

YiewletCentral,
Training...
YiewletCreation...
ievletBranding. ..

L=

icense Deactivation...
—1

Check For Updates. ..
Abouk YiewletBuilders,

= Follow the instructions in the windows that display to complete the deactivation

process.
» |nstall ViewletBuilder6.1 Enterprise the other computer.
* Follow the “license activation” steps to activate the license on the other

computer.

If you do not have Internet access or encounter firewall issues, go through the
activation/deactivation wizard as usual. On the last screen, you will find troubleshooting
instructions to resolve/complete the activation/deactivation process.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.qgarbon.com). Or, if you prefer, email support@qgarbon.com.

VB6.1 Enterprise User Manual Page 6 March 2009
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Interface Overview

It's important to be comfortable when working in ViewletBuilder6.1 Enterprise. This
chapter provides some quick snapshots of what the ViewletBuilder6.1 Enterprise
program GUI (Graphical User Interface) “looks like” before you open a project and when
a project is first opened. It also contains a brief description of the most common features
and tools displayed in each scenario to give you a good “jump start” into using
ViewletBuilder6.1 Enterprise.

Example of ViewletBuilder6.1 Enterprise Interface — No Project Open

',,'_'1 ViewletBuilder6 Enterprise g@
File Edit  Wiew b Project  Help ﬁ Menu Toolbar
. N = . . . . : : »
LB & <UD EY R |2 Alg e G @y b &0 L
Title Bar &%
Actions Main Toolbar [19I1S . ¥
|_; New Project ite a Yiewlat Object Toolbar r] =
||_7 Open Projeck @ Create a Yiewlet using Smart Capture -
E_ Check for Updates @ Publishing your ¥iewlet
@ Sharing ¥iewlets | | Gl
Recent Files %l o
|t deleteme0l.qvp Ne =
. —— [
Help uffline _ -
_ ) Start View Panels £
(2 Viewletbuildert Help ViewletBuild i oth Pro & “H
<l User Guide Enterprise versions! ‘ @
(2 Webinars httpcitweaner. garbon.comipresentation- 5 oftwarediewl eth i der
/~ License Deactivation... Ifyou purchased VBS hetw oryoUkare a current o
" Licensed Flatinurm Member, yau can ra Status Toolbar helo M IE
(5 Builderé @ ViewletCentral =
Mermory: 6% | Zoorn: 100 % |
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Example of ViewletBuilder6.1 Interface — Project Open

! ViewletBuilder6 Enterprise - Untitled * =Jo/E&d
File Edit Wwiew Insert Project  Help
= (] ( 2 — 1 H y = = b3
LEHBXDD R E ddEbiglEyJ B e gL
B EBlE= |E_] ! | 4 < Context Sensitive Toolbar
Thumbnail =8 L/
% 2|9 ]
= T
kg
- X o
Slide Edit Area IEI
Tab Views ' LJ_“T‘
Timeline =0 \_)J
00:00.0 to 00:01.0 of 00:04.0 00:01.0 w 100% = = 3 m
Slide 1 [l
poslider 1= Z2s s
£ | 3| i
Slide 1 of 4 640 3 480 Mermary: 3% Zoom: Fit Slide

Interface Features and Tools
The ViewletBuilder6.1 Enterprise GUI includes:

= Start View Panels: When ViewletBuilder6.1 Enterprise is launched the opening
window displays a “Start View”, which is divided into individual “Panels”:

o Start View — Actions Panel: Displays “action” links for New Project, Open
Project and Check for Updates.

o Start View — Recent Files Panel: Displays links for quick access to the
most recent projects previously opened in ViewletBuilder6.1 Enterprise.

o Start View — Help Panel: Displays links to help and training resources
such as ViewletBuilder6.1 Help, User Guide and Webinars. A License
Activation or License Deactivation “quick access link” is also available.

o Start View — Publishing History Panel: Displays a list of Viewlets
published to ViewletCentral.

o0 Start View — Tutorials Panel: Displays links to various self-help Viewlet
authoring tutorials.

VB6.1 Enterprise User Manual Page 8 March 2009
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o0 Start View — Start Panel: Dynamic (and fully customizable) page served
from the Qarbon (or your company’s) server with important information
regarding product updates (or information relevant to your company, if
applicable). For a customized version of this page, contact
sales@qarbon.com for more information.

o Start View — Web Page Buttons Panel: Displays three buttons (left to
right) to launch the Qarbon home page, the ViewletBuilder6.1 products
page and/or the ViewletCentral home page.

= Title Bar: This is the “bar” displayed at the top of the program window.
Depending on whether the project is open or closed, it contains the program title,
followed by the file name. It also includes three buttons to Minimize, Restore
Down/Maximize and/or Close the program window.

* Menu Toolbar: This toolbar “sits” below the Title Bar and contains menu titles
that reveal additional drop-down menu options. The Menu bar offers access to:
File, Edit, View, Insert, Project and Help operations.

= Main Toolbar: This toolbar is below the Menu bar and displays a series of
standard command buttons that offer quick “one-click” access to many tools in
ViewletBuilder6.1 Enterprise. Many of these buttons on the Main Toolbar provide
easier access to many options also available on the Menu bar.

= Context Sensitive Toolbar: This toolbar displays when a project is open and is
located below the Main Toolbar. The buttons displayed on this toolbar vary,
depending on the current selection. This toolbar’s buttons change dynamically as
you work within the project.

= Tab Views: By default, different tabs for selected “views” (from the View menu)
display to the left of or below the slide editing pane. Tab View selections include:
Browser, Thumbnails, Stylesheets, Output, Timeline and Slide Notes.

= Object Toolbar: Previously known as the “Tools Palette”, this toolbar displays to
the right program window. It contains buttons for working with various objects
such as: Balloons, Notes, Text Boxes, Cursors, Shapes, Images, Buttons,
Movies, Pause Zones, Click Zones, Text Zones, Keystroke Zones and Questions
while editing a project.

= Slide Edit Area: This is the default panel view when a project is open. It displays

the current slide for editing / viewing operations. The Slide Edit Area is hidden
when any Tab View is maximized.

VB6.1 Enterprise User Manual Page 9 March 2009
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= Status Bar: Located at the bottom of the program window, this “bar” displays
helpful information such as the number of the currently selected slide, the
number of total slides in the project, the dimensions of the project, the “x” and “y”
coordinates of your cursor as you work in the program window, the amount of
system memory in use, and the zoom level currently selected.

Each of these features and tools are discussed throughout this user manual. If you have

any questions, contact us using the “Contact Us” or “Support” links on the home page
(www.qgarbon.com). Or, if you prefer, email support@garbon.com.

VB6.1 Enterprise User Manual Page 10 March 2009
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Program Preferences

In ViewletBuilder6.1 Enterprise, you can set up program preferences for features such
as language, spelling, proxy server, log files for error reporting, backup files and more.
This chapter explains how to set up each of these global preferences for your Viewlet
projects.

You do not need to have a project open to set up program preferences.

To access the program Preferences window:
= Select Edit > Preferences from the Menu bar.

Edit
Undo
5| Redo
ey Zuk
| Copy
Paste

. Delete

| Duplicate Slide

[r Seleck All

Clear Selection

) Search and Replace. ..

Arrange
Align
Distribute

Size

- v v v v

Tirning

Preferences. ..

= The Preferences window displays. Select the desired tab by clicking on it.

VB6.1 Enterprise User Manual Page 11 March 2009
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The General Tab

o~

Preferences

ISEI'IEI’EI||S|:ualli|'u;,| Prowy | Logging | Backup | Advanced

Language
ne The language in which the ViewletBuilders user interface is
displayed.
Language: Endlish
Change Language. ..
Recording

52 countdown timer can be displaved during sound recording to help
@ wou skart on cue,

Display Countdown Timer

Zounkdown Durakion 3{:} Seconds

Message Ediking

(%) Edit in Place

() Use Message Editor

[ Reset Preferences to Defaulk, ., ]

[ oK | [ Cancel

]

Language

The General tab allows you to specify the language that is used in the interface. By
default, ViewletBuilder6.1 Enterprise will use your operating system’s default language
preference, but you may switch to a different language for use in this program only.

VB6.1 Enterprise User Manual Page 12
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To select the default language to use in the ViewletBuilder6.1 Enterprise interface:
* |n the Preferences window, select the General tab.
» |nthe Language area, click the Change Language button.
= Select a language from the available list.

meneral | Speliing | Prosy | Logging | Backup | Adwanced

Language
The language in which the YiewletBuilderd user interface is
displayed.
Language: English
Change Langquage. .. I
L -1
reco| Language Preferences

T I
@ Select the display language For YiewletBuilders, =

Enalish
English s
French

|_{zerman ||
Hebrew

 [Italian

Japanese

= Karean

Marwegian W

Messa04

[ Reset Preferences to Default, ., ]

[ (0] 4 H Cancel ]

= Click OK.

Recording

You can select a countdown timer to display before each recording session when adding

audio to slides, shapes, images or message objects.

To set recording preferences:
* In the Preferences window, select the General tab.
* |nthe Recording area, select the Display Countdown Timer option.

= Type the number of seconds for the countdown to display in the Countdown

Duration field, or use the up/down areas to set this value.

VB6.1 Enterprise User Manual Page 13 March 2009
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Med Fespe | Message Editing Area (New in ViewletBuilder6.1 Enterprise)

In the Preferences window in the General tab, there is a new area called Message
Editing. In this area, there are two options for editing message objects. Select one of
these options to set as the default preference to use while working with notes, balloons
and text boxes.

To set a default message editing preference:
= In the Preferences window, select the General tab.
» |n the Message Editing area, select either:

o Editin Place: When editing a message object, this selection allows you
to edit text directly in the balloon, note or text box. And, you can use the
message object’s Context Sensitive Toolbar to edit other message object
properties.

or

0 Use Message Editor: When editing a message object’s text, this
selection opens the Message Editor window when double clicking a
balloon, note or text box. This selection also allows you to edit other
message object properties directly in the Message Editor window.

It's easy to switch between “message editing” options while working with message
W . . . . .
% objects. Simply right click on the message object and, from the shortcut menu, select
= either “Open in Message Editor” to work in the “Message Editor” window, or select “Edit
Message” to edit text directly in the message object.

VB6.1 Enterprise User Manual Page 14 March 2009
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The Spelling Tab

P -1

Preferences

ceneral | Speling | proxy | Logging | Backup | Adwanced

Spell Checker
ﬁ Select a dickionary For the spell checker.
L__‘ Endglish (United States) v
[ ] Ignore words in UPPER.CASE

[ ]Ignore words with numbers

Ignore domain names

[ (04 H Cancel ]

In ViewletBuilder6.1 Enterprise, you can set preferences for the spell checker tool, which
will automatically proof text in all of the message objects throughout your project.

To select a default dictionary language to use in ViewletBuilder6.1 Enterprise:
= In the Preferences window, select the Spelling tab.
» |n the Spell Checker area, select a language from the list to use as the default for
the program’s spell checker tool.

To select additional options for the spell checker:
» |n the Preferences window, select the Spelling tab.
= Under the language list, select any additional options to use with the spell
checker including:
o0 Ignore words in UPPERCASE
o0 Ignore words with numbers
o Ignore domain names

-3 To enable/disable the spell checker tool, select “View” from the Menu bar. Then
T | select/deselect the “Spelling Mistakes” option.

VB6.1 Enterprise User Manual Page 15 March 2009
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The Proxy Tab

P =1

Preferences

izeneral | Speling | Proxy | Logging | Backup | &dvanced

Preferences

Enter your proxy characteristics to access our servers and activate
= of walr icense ar receive updates, IF yau have any questions, please
contact Qarbon kechnical support,

Address

Part

|:| =& prowey authentication
Lagin

Password

[ (0] 4 l [ Cancel

There may be times when you encounter firewall issues while working with
ViewletBuilder6.1 Enterprise. This may occur when activating your license or when
updating the program. This is when a proxy server comes in handy, if your company has
one available. The Proxy tab is where you can set up default proxy server information for
the program to automatically use when encountering firewall issues. If, however, you do
not know what a proxy server is, chances are you don’t need to worry about it. Some
companies, however, actually require that software programs that access the Internet
log on through a proxy server. In this case, your network administrator should have the
information you will need to fill out this preference screen.

VB6.1 Enterprise User Manual Page 16 March 2009
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To set proxy server default information:
» |n the Preferences window, select the Proxy tab.
* In the Preferences area:
0 Select the Use a proxy server.
» Enter the proxy Address in the field provided.
= Enter the proxy Port in the field provided.
0 Select the Use proxy authentication (if this is required by your server).

= Enter the proxy Login in the field provided.
» Enter the proxy Password in the field provided.

The Logging Tab

Preferences

izeneral | Speling | Proxy | L0Q3ing | Backup | Advanced

Outpuk

r | Logging creates a record of information that can help Qarbon Find
%/ and correct programming errors, Set the options For logging ko the
aukput kab windaw,

Report: |Display All Messages w

[ Clear Dubput Window

Loq File
g et the options For outputting log records ko a file,
|
&, Enabled
Size Limit: 100 /% KE Clear Log File
File: ‘bont YiewletBuilders Enterprise) iswletBuilders, lag ‘_‘
(04 ] [ Cancel
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While ViewletBuilder6.1 Enterprise is running, it writes a log that describes in detail what
is going on in the background. This is indispensable for tracking down software issues
and making ViewletBuilder6.1 Enterprise as bug-free as possible. In the Logging tab,
you can set program defaults for how ViewletBuilder6.1 handles logging reports and
files.

Output

In the Output area of the Logging tab (Preferences window), you can set default options
for the reporting of information in the Output tab, which can be viewed by selecting View
> Qutput from the Menu bar.

To select Output report options:
» In the Preferences window, select the Logging tab.
In the Output area, select an option from the Report list. These include:
o Display Errors Only
o Display Errors and Information
o Display All Messages

ik pik

Logging creates a record of information that can help Qarbon Find
%{ and correct programming errors, Set the options For logging ko the
output tab window,

Repaort: |Display All Messages
Display E ol

@ !spay rrors Only .
Display Errors and Information

Dizplay All Messages

To clear the information in the Output tab:
» |n the Preferences window, select the Logging tab.
* In the Output area, click the Clear Output Window button.

Log File
In the Log File area of the Logging tab (Preferences window), you can set default

options for the size of the logging file and the location where ViewletBuilder6.1
Enterprise will save the file.

To enable the Logging feature for ViewletBuilder6.1 Enterprise:
» |n the Preferences window, select the Logging tab.
* Inthe Log File area, select the Enabled option. This will allow ViewletBuilder6.1
Enterprise to create a record of information to help Qarbon find and correct
program errors.

To set the log report’'s maximum file size:
= Inthe Preferences window, select the Logging tab.
» |nthe Log File area, type a humber in the Size Limit field. This will be the
maximum size (in KB) allowable for the log file.

VB6.1 Enterprise User Manual Page 18 March 2009
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To clear the log file:
* |n the Preferences window, select the Logging tab.
» Inthe Log File area, click the Clear Log File button.

To set the default location where the log file will be saved:
* |n the Preferences window, select the Logging tab.
»= Inthe Log File area, type the path to where you want log files to be saved. Or,
click the “yellow folder” next to the File field.
» A Select Log File window displays. Browse to locate and select a new save
location for the log file.
= Click Open to apply and to return to the Preferences window.

The Backup Tab

F = =1

Preferences

General | Spelling | Proxy | Logging | Backup | Advanced

Backup Files on Save

[ ] Enable - .BAK appended to extension
™

[ ] Backup Files on Automatic Save

(%) Stare backups in local folder
() Stare backups in comman folder

Autornatic Save

i Enable Autamatic Save

Every 5 & Minutes

[ Ok, ][ Cancel ]

The Backup tab allows you to set program preferences for creating backup files while
working on your Viewlet project.

Backup Files on Save
When saving your project, ViewletBuilder6.1 Enterprise can create and update a backup
file. This file can be used to restore a corrupted project from the last “known” good save.
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To enable ViewletBuilder6.1 Enterprise to create a backup project file:
» |n the Preferences window, select the Backup tab.
= |n the Backup Files on Save area, select the Enable - .BAK appended
extension option.

ViewletBuilder6.1 Enterprise creates backup files that end in “.qvp.BAK”. To restore a

<ip project from a backup file, first rename the original project file’s extension to something

- like “.qvpOLD”. Then, simply remove the “.BAK” extension from the backup file so that the
file ends in “.qvp”. It will become the new project file, which can be opened in
ViewletBuilder6.1 Enterprise.

To create backup files automatically as you work on the project:
» |n the Preferences window, select the Backup tab.
= In the Backup Files on Save area, select the Backup Files on Automatic Save
option.

To save the backup files in the same folder where the original project file is saved:
» In the Preferences window, select the Backup tab.
»= Inthe Backup Files on Save area, select the Store backups in local folder
option.

To select a location to save the backup file in (other than in the same folder as the
original project file):
» |n the Preferences window, select the Backup tab.
= Select the Store backups in common folder option.
= Type the path where you want the backup file saved, or click the “yellow folder”
button. In the Select Folder window, select a folder and click Open to save the
new backup file location.

Automatic Save
ViewletBuilder6.1 Enterprise can create automatic backup files while you are working on
your project.

To enable ViewletBuilder6.1 Enterprise to create automatic backup files and to set the
automatic save intervals while working on your project:
= Inthe Preferences window, select the Backup tab.
» |n the Automatic Save area, select the Enable Automatic Save option.
o Enter a number in the field provided for when the project is automatically
saved.
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The Advanced Tab

P -1

Preferences

General | Spelling | Proxy | Logging | Backup | Adwvanced

Java

(( Current Java virkual machine settings.

—

= Initial Memary: 32 MB
Mazirmurm Memory:  S08 ME

£ Change Java Settings...

(0] 4 ] [ Cancel

The Advanced tab displays the current virtual memory usage settings allowable when
ViewletBuilder6.1 Enterprise is in use.

To view the current Java settings for ViewletBuilder6.1 Enterprise:
= In the Preferences window, select the Advanced tab.
* Inthe Java area, review the settings for initial and maximum memory allocations.

To change the memory settings allowable for ViewletBuilder6.1 Enterprise:
» |n the Preferences window, select the Advanced tab.
= Inthe Java area, click the Change Java Settings button. A Java Preferences
window displays.
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Genec_al Spelling | Proxy | Logging | Backup | Advanced

1 Java Preferences

Mennory:

Specify the initial and maximum size of the memary poal
available ko Java in Megabytes,

Initial 32 % MB ]
Maximum | 508 %) MB

WM OpLions

Specify amy additional ¥M opkions,

E oK |[ Carnicel ]

[ Ok, ][ Cancel ]

* |nthe Memory area (Java Preferences window):
o Enter a number for the Initial memory to be used by ViewletBuilder6.1
Enterprise in the field provided.
o0 Enter a number for Maximum memory allowable in the field provided.

= Inthe VM Options area (Java Preferences window), enter additional Virtual
Memory options as needed.

= Click OK to save the information and to close the Java Preferences window.

Once you've set all your program preferences, click OK to save the settings and to close
the Preferences window.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.

VB6.1 Enterprise User Manual Page 22 March 2009



Liser Manual

Creating a New Project Basics

ViewletBuilder6.1 Enterprise, which combines ViewletBuilder6.1 Professional and
ViewletQuiz3.1 into a single, all-encompassing Viewlet Authoring suite, offers five
distinct options for creating new Viewlet projects. The new project types include:

e

k]
|

Screen Capture Project: Capture an application as it runs on your computer to

create a demonstration, simulation or a user training assessment.

Image Project: Create a presentation using one or more images (supported
images: jpg, bmp, png, gif and tif).

PowerPoint Project: Import slides directly from a Microsoft PowerPoint project.

Quiz Project: Use this new project type to create a project of scored slides to
test user, or create survey questions to gather information from your user base.

Blank Project: Start from scratch by creating a project containing one or more

blank slides.

' Create Mew Project

New Project

Create & new YiewletBulders Projeck

LS

o
-
1

Screen Capture Project
Capture a running application
ko create a produck
demaonstration, simulation ar a
user training assessment,

Image Project

Create a slideshow From
images an your syskem,
Supparts jpg, bmp, png, gif
and tif images.,

, PowerPoint Projeck

| Create a project by importing

one of more slides From a
Microsaft PowerPoint project
on your syskem,

Quiz Project
Create a project of scored ar

) survey questions ko kest and

gakther infarmation from your
user base,

Blank Project
Create a project containing
one of more blank slides.
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Each of the five new project types is covered in detail later in this user manual.

New Project First Steps

When creating your new project, the first few steps are common to all new projects. This
chapter focuses on the “first steps” all authors will need to take when creating new
projects.

Step 1: Select a New Project Type:

The first step when creating any new project is to decide what type of project you will be
creating. As mentioned earlier in this chapter, there are five different new project types to
choose from in ViewletBuilder6.1 Enterprise.

= Select File > New from the Menu bar. Or, click the New Project link (from the
Start View), or click the New button from the Main Toolbar.

» The Create New Project window displays. Select a new project type from the list
on the left side of the window by clicking it to highlight it.

Step 2: Select the New Project’s Slide Size:

Once you've select a new project type, the second step is to determine the size (width
and height) for all the slides in your project. There are at least two slide size options
available for all new project types:

= Custom: Set a custom width and height.
= Standards: Select from a list of standard resolutions, or create a new “standard”
to add to the available list.

If you select Screen Capture Project as your new project type, there are several more
slide size options to choose from (in addition to the two listed above):

= Application: Capture an open application and use its window size (width and
height) as your new project’s slide size.

= Area: Capture an area of the screen and use this area’s size (as determined by
you prior to capturing screenshots) as your new project’s slide size.

= Window: Select either an open application’s window or an open operating
system window and use the selected window’s size as your new project’s slide
size.

= Full Screen: Capture everything visible on your computer’s screen and use the
monitor’s resolution (that is used during the capture session) as the width and
height for your new project’s slide size.

‘.’ When selecting a slide size for your project, remember, this is also going to be the size
ET® | that the Viewlet will be played back at when your audience views it. So, if a viewer has to
scroll to view parts of the Viewlet that are “off-screen” then you may need to use a smaller
size for your Viewlet.
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To select a slide size for your new project:

e

k]
sern vianual [

* In the Create New Project window, make sure you've selected the desired New

Project Type.

= Inthe Slide Size area, select an option from the list of available slide sizes.

Working with the Various Slide Size Options

Each of the various slide size options have some additional selections, depending on
which side size you choose. Following are instructions for working with each of the

available slide size options.

= Custom: Select this option to create a custom project size.

5lide Size

@ Specify the slide size vou would like to create or capture.

Custom - Specify a custom width and height. w
width: 800 % Height: 600 2
o Enter a number in the Width field.
0 Enter a number in the Height field.
= Standards: Select this option to:
Slide 5ize
Specify the slide size wou would like to create or capture.
5 = o
(L, Standards - Select a standard window size, w
SYGA (Recommended): 500 x £00 = / >4

WGa: 640 x 480
SWah (Recommended): S00 x 600
aa: 1024 x 765

Capturd...—-. 1280« 1024

||E|h UxGaA: 1600 x 1200

7 T Che Bena eormabthima ic dnna

o0 Create a project size based on a “standard” (monitor) resolution:
= Select a preset standard resolution for your project size from the

available list.

o0 Create a “new” Standard:
= Select a preset Standard from the list.

= Click the Add Standard I{I'j button. The Standard Resolution

window displays.
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= Enter a name for the new Standard in the field provided.

*» Enter a Width in the field provided.

= Enter a Height in the field provided.

= Click OK to save the settings and to close the Standard
Resolution window.

f = =1

Standard Resolution

Marne |Zuskom Size &

width 500 /2 Height 500 :::

w

[ (0] 4 ] [ Zancel

o0 Modify an existing Standard:
= Select a Standard from the list.

= Click the Modify Standard 'f button. The Standard Resolution
window displays.

= Make your edits as needed and click OK to save the settings and
to close the window.

0 Delete an existing Standard:
= Select the Standard you want to remove from the list.

= Click the Delete Standard X button. A Delete Standard warning
window displays.

-,

Delete Standard

\__?().‘ Are you sure vou want to delete this standard resolution?

Eotes [ Mo ]

= Click Yes to confirm the deletion. Click No to cancel the deletion.

= Application: Select this option to use an “active” program or operating system
window as the baseline for your project size.
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Slide Size

\_l Specify the slide size you would like ko create or capture,
application - Capture a running application window, .v.
IEB whi, 1ent_userguideR 00, doc - Microsaft Word 1288 x 803 v =3
Resize &pplication to;

0 Select an “active” program or operating system window from the list.

o If the window you need is not in the list, launch the program or open the
desired operating system window in the appropriate size. Then, click the

Refresh Applications ' button to refresh the list and make your
selection from the list.

o0 To resize the selected “active” window to a specific size for the capture
session:

= Select the Resize Application to: option.

= Click the button next to the Resize Application to: option. The
Application Size window displays:
-Select Custom or Standards from the slide size list.
-Complete the steps for the selected slide size (covered previously
in this chapter) as needed.
-Click OK to save the settings and to close the Application Size

window.
P T
Application Size
Specify the slide size vou would like ko create ar capture.
Cuskom - Specify a cuskom width and beight, w
width: 300 %] Height: 600 %]
ok [ Cancel

# | If you select “Application” (an active program or open operating system window) as your
2 T® | project’s slide size option, ViewletBuilder6.1 Enterprise will move this “window” to the top
of all open windows when you initiate your capture session.

= Area: Select this option to set a custom project size by drawing the specified
screenshot area prior to the capture session.
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Slide Size

@I Specify the slide size wou would like to create or capture.

g Brea - Capture an area of the screen,

e

User Manuall

»  Window: Select this option to choose a program or operating system window

prior to starting the capture session as the baseline for your project size.

Slide Size

@‘ Specify the slide size you would like to create or capture.,

E eindow - Select a windaw Eo capkure,

If you select “Window” as the slide size option for your project, you can also use this
option to select a specific “portion” of awindow (not just the entire window) prior to

starting your capture session.

» Full Screen: Select this option to capture everything visible on your computer’s

screen during the screenshot session.

Slide Size

@ Specify the slide size you would like to create or capture,

# .
**| Full Screen - Capture the entire screen.

Screen Resolukion: | 1280 x 800 - Current

1280 x 800 - Current

1024 x 768

1024 = 600
Capture Profiles 200 x 600
&40 = 480
IE” | Demonskrdc40 x 400
(= | Shaw how s 517 x 354
| Training Sil.t80 % 360

V% Trckrict houw b de comathinn

0 Select a Screen Resolution from the list. If the selection is different from
your monitor’s current resolution, ViewletBuilder6.1 Enterprise will
automatically change your monitor’s resolution to your selected resolution
when you start your screenshot session. When you end your screenshot
session, ViewletBuilder6.1 Enterprise will return your monitor’s resolution

back to the setting it was prior to the capture session.
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Step 3: Make the rest of your selections in the Create New Project window:

After you complete the first two steps for creating a new project, the rest of the steps will
differ depending on what you selected for your new project type. Please refer to the
specific chapter for more information on creating a new project based on the type of new
project you are creating.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.

VB6.1 Enterprise User Manual Page 29 March 2009



Vi1 éﬁw“'._@u BTG eRoT N Eviiey Drries 7 m ; i.lﬂj: m['.éj"llfill [

Screenshot Project

ViewletBuilder6.1 Enterprise allows you to create a new project from a series of
screenshots of an application running on your computer (or from various open operating
system windows). Screenshot projects can be captured using various “slide size” options
based on custom sizes, active program / operating system windows, or screen
resolutions. Each step of the process for creating a new Screenshot Project follows.

1. Select the Project Type and Slide Size

= Select File > New from the menu option. Or, in Start View, click the New Project
link, or click the New button from the Main Toolbar.

= The Create New Project window displays. Select Screenshot Project from the
New Project list. Additional options for creating a new screenshot project will
display in this window.

! Create New Project
New Project \
Creabe a rew YiewletBuilders Project i
Slide Size
| Screen Capture Pro
m,mm’m E Specify the shde size you would ke to creste or capture,
to creste a product | = .
SRR ESE [ custom - Specy a custom width and height. ﬂ
User raining assesament, :
_ . width: 80012 Height: | 600/
— Image Project
I-qﬂ Creste o shdashow from
nages on your systenm,
Supports ipg, bmp, pog, of
and tf inages. Capture Profiles
. PowerPoint Project iz E . Demonstration
I!_-‘E. Create a projact by enporting L_| 5 | Show how something is done.
one or more shdes from 2 | Training Simulation
Microsolt P’t::m project % Instruct how to do something.
on $ 1
yorEE . Assessment E:}I
Dy Quiz Project L% Evaluate training effectiveness. .
[—-J ? e a w;ﬁ:sfomﬁ Manual Capture
ather mm from your &' | Capture screenshots manually with cursors, /
user base, Simple .
) Blank Project & | Capture screenshots manually without cursors. sg
L] creste s project containing
o o eord blank shdes.
v
ok || cancel |
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» |n the Slide Size area of the Create New Project window, select a width and
height for your Viewlet project.

t’ For more information on selecting a New Project Type or selecting a Slide Size for your
> T® | new Viewlet project, please refer to the Creating a New Project Basics chapter.

e Fesire | 2. Capture Profiles (New in ViewletBuilder6.1 Enterprise)

Capture Profiles is a new feature in ViewletBuilder6.1 Enterprise for Screenshot Projects
(or screenshot slides). Start by selecting an existing profile or by creating a new one.

This new feature may seem a little daunting, so here’s some quick “QA’s” to get started:

What is a Capture Profile?
It is a new way to organize all the “capture options” chosen for either a “Smart Capture”
or a “Manual Capture” screenshot recording session into one place or “profile”.

Does the Capture Profile “title” signify anything?

Yes and no. The “title” of the Capture Profile is like the title of a document. It just gives
you an idea of what the profile would be used for. You can change the title of the profile
at any time.

Are Capture Profiles used for all new project types? If not, why not?

No, Capture Profiles are only used when creating new Screenshot Projects or when
inserting new screenshots into existing projects. The reason for this is because a
Capture Profile is simply a “collection” of capture options (stored in one profile) used
during either a Smart Capture mode or Manual Capture mode screenshot recording
session.

What is the “basic” process for creating a “new” Capture Profile.

1. Inthe “New Project” window, with the “Screenshot Project” type selected, click
the “Add” button to open the “Capture Options” dialog window. It will be in this
window where you will select options for your screenshot recording session. And,
these selections will be saved in your new Capture Profile.

2. The next step is to decide what “capture mode” you want to use with this profile.
The choice is either “Smart Capture” (which automatically captures screenshots)
or “Manual Capture” (which forces you to manually capture screenshots using a
hotkey and or mouse click actions). The capture mode you select at this point
determines what additional “tab options” display for additional selections for your
Capture Profile.

3. Make your selections in the tabs that display below your selected “capture

mode”. These are the “additional” capture options that will be saved in your
profile and used when taking screenshots using this Capture Profile.
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a. If you selected “Smart Capture” mode, seven tabs will display (General,
Feedback, Mouse, Wheel, Keyboard, Annotations, Advanced).

b. If you selected “Manual Capture” mode, four tabs will display (General,
Feedback, Mouse, Advanced).

4. Once you've read through and completed all the information in the Capture
Options window (in all the tabs), click OK to create the new profile.

5. Use this profile each time you want to create a new screenshot project or insert
new screenshots using the selected capture mode (Smart Capture or Manual
Capture) and additional capture options in this Capture Profile.

Can Capture Profiles Be Modified?

Yes, when you install ViewletBuilder6.1 Enterprise, you will see a short list of Capture
Profiles already installed. The title of each profile suggests the “type” of project the
Capture Profile might be good for and is further explained in the profile’s description.
But, you can modify any of these profiles instead of creating a new one.

When creating a new Screenshot Project, ViewletBuilder6.1 Enterprise offers you five
“prebuilt” capture profiles to help you easily create specific Viewlet projects, including:

= Demonstration: Show how something is done.

» Training Simulation: Train users how to do something.

= Assessment: Evaluate training effectiveness.

= Manual Capture: Capture screenshots and cursor animation manually.
» Simple: Capture screenshots (without cursor animation) manually.

Capture Profiles

Iﬁ | Demonstration
I_.!..

| Showe hows something is done.

| Training Simulation
% Instruct how to do something.

1| Assessment
4%, Ewaluate training effectivensss,

| Manual Capture
[5' 7| Capture screenshots manually with cursars,
I Simple
|5 7| Capture screenshaots manually without cursars,

4|8 [N

Each capture profile (added during the program installation) contains pre-selected
“capture options” based on the specific profile. You can use the defaults for the selected
profile, modify the selections in the profile, or create a new capture profile from scratch.
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Select a “Capture Profile” from the list. Then, click the “Modify” ‘_| button to open the
“Capture Options” window where you can review and modify options as desired.

To create a new Capture Profile:

* In the Capture Profiles area, click the Add ‘ i | button.

» The Capture Options window displays. In the Capture Mode area, select a mode
to use for the capture session:

0 Smart Capture: This mode automatically captures all changes that occur
on your computer’s screen during the screenshot session.

or

o Manual Capture: This mode allows you to use a hotkey to manually
capture each screenshot during the capture session.

The “Capture Mode” you select determines what tabs will display in the “Capture Options”
window where you will make additional selections for your capture session. And, some of
the options may vary in each of the tabs depending on your selected capture mode.

Smart Capture Mode tabs:
General, Feedback, Mouse, Wheel, Keyboard, Annotations, Advanced

Capture Options

Capture Mode:

f’ii-' Smart Capture - Aukomatically capture all changes, w

GEI'IEF~3||Feedhan:k Mouse | Wheel | Kevboard | Annotations | Advanced

Manual Capture Mode tabs:
General, Feedback, Mouse, Advanced

Capture Options ﬁ

Zapture Mode:

EJ --J| Manual Capkure - Use a hokkey ko capture a screenshot, W

General |Feedl:ua|:k Mouse | Adwvanced
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» |n the General tab (available for Smart Capture and Manual Capture):
o Inthe Identification area, enter a:
= Name for the profile. This name will display in the Captu
Profiles list.

S

WECAYELIEL |

re

= Description or a short summary for the profile. This will display

below the profile title in the Capture Profiles list.

Identification

MName:

Descripkion:

0 Inthe Timing area:

= Select the Maintain Timing Links to maintain links between
applicable objects (message objects, cursors, etc.) along the

Timeline on each slide. For more information on “Timing
please review the Timeline Tab chapter.

Links”,

Tiring
Maintain Timing Links:

Introduckory Delay: 1.00 ::: seconds

For more information on “Timing Links”, please review the “Timeline Tab” chapter.

» Enter the number (of seconds) for an Introductory Delay
before the first note or balloon is displayed on a slide.

default

You can change the “Introductory Delay” for your project at any time by selecting
“Project” then “Project Properties” from the Menu bar. In the “Project Properties” window,

select “Timing” from the list and change the number in the “Introductory Delay”
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o0 Inthe Hotkeys area, depending on the capture mode (Smart Capture or
Manual Capture) selected, several hotkeys are available. To change a
hotkey, click the applicable button next to the hotkey’s description and
press the new hotkey(s) to be used for the desired hotkey option.

Smart Capture Hotkeys:

Hotkeys

Capkure Screenshak: [ oy ]
Capture Background Frame: [ F1z ]
Pause Capture: [ F11 ]
Skop Capture: [ F10 ]
Cancel Capture: [ Fa ]

-Capture Screenshot: Used to capture a screenshot manually.
-Capture Background Frame: Used to capture an animation frame.
-Pause Capture: Used to pause the capture session.

-Stop Capture: Used to finish the capture session and convert
screenshots to slides.

-Cancel Capture: Used to cancel a capture session without converting
screenshots to slides.

Capture Status
J If you click the “Pause” hotkey during a Smart Capture Slides: 1
=& | screenshot session, to resume the session, simply '#,j :
a1 . . ’ . ! \ Size! L BOE bt
> % click the “Continue” button in the “Capture Status” 5 vies
window that displays over the system tray. )
BT e ¥ W
Conkinue Skop Cancel Maote
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Manual Capture Hotkeys:

Hatkeys

Capture Scresnshot: [ Chrl ]
Pause Capture: [ Fi1 ]
Stop Capture: [ Fi0 ]
Cancel Caphure: [ Fa ]

-Capture Screenshot: Used to capture a screenshot manually.
-Pause Capture: Used to pause the capture session.

-Stop Capture: Used to finish the capture session and convert
screenshots to slides.

-Cancel Capture: Used to cancel a capture session without converting
screenshots to slides.

Q 7 | Use the “Pause” hotkey to display the " Capture Status” window to change various capture
2, T options on-the-fly during an active capture session.

= Inthe Feedback tab (available for Smart Capture and Manual Capture):

o Inthe During Capture area, select / deselect (as needed):
= Hide Tray Icon
= Tray Icon Blinks

During Capture

[ ] Hide Tray Icon
[ ] Tray Icon Blinks
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o Inthe Play Sound area, select what sounds to play during the capture
session, including:
= On Screen Capture
= On Background Frame Capture
= On Key Capture

And, for best “sound alert” performance during your capture session,
select:

= Use Microsoft DirectSound for Playback

Play Sound
On Screen Capkure
[ ]©n Backgraund Frame Capture
on Key Capture
se Microsoft DirectSound For Playback

* |In the Mouse tab (available for Smart Capture and Manual Capture):

Smart Capture — Mouse Tab Options:

o0 In the On Mouse Click — Add to Slide area, select:

= Click Here Annotations: To enable ViewletBuilder6.1 Enterprise
to automatically insert balloons for click instructions during the
capture session.

=  Cursor Simulation: To add various cursor animation effects to
your project, which might include:

Mouse Click Sound

Drag to Here Annotations
Mouse Drag Animation
Curved Cursor Path
Transition Cursors

= Click Zone Assessment: To automatically insert “Click Zones” to
the project during the capture session.

= Don’t Add Cursor Simulation or Click Zone: To disable all

cursor simulation or Click Zone additions when clicking your
mouse during the capture session.
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2 Mouse Click - Add ko Slide

Click Here Annotations

(%) Cursor Simulation
Mouse Click Sound
Drag ko Here Annokations
Mouse Drag Animation
Curved Cursor Path
Transition Cursors

() Click Zone Assessment

() Don't Add Cursar Simulation ar Click Zane

0 Inthe Mouse Timing area, input the number (in seconds) for how long
you want to “delay” for mouse click captures, to set the double click speed

and to set the “delay” for drag captures. Options include:

= Delay Before Click
= Delay After Click

= Double Click Speed
= Delay After Drag

Mouse Timing

Delay Before Click: 0.50 % seconds
Delay After Click: 0.50 % seconds
Double Click Speed: 0,102 seconds
Delay after Drag: 1.00 5| seconds

VB6.1 Enterprise User Manual Page 38

March 2009



LAV O LY U= RN C R (0 Lok |r sern vianual

Manual Capture — Mouse Tab Options:

0 Inthe On Screen Capture — Add to Slide area:

-Select the Cursor Simulation option to capture cursor movement during
the recording session. And, to achieve more realistic cursor animation,
select the Curved Cursor Path option.

-Select the Don’t Add Cursor Simulation option if you do NOT want to
capture cursor movement during the recording session.

2n Screen Caphure - Add ko Slide

() Cursor Simulakion

(" Don't Add Cursor Simulation

0 In the Mouse Click Capture area:

-Select the Mouse Clicks Capture Screenshots option if you want to a
screenshot capture each time you click you mouse during a recording
session.

-Select the Include Right Mouse Button option to capture a screenshot
each time you right click during a recording session.

Mouse Click Capture

This feature allows you ko use the mouse ko capkure screenshoks,
Everykime the mouse is clicked, a screenshot is taken, You can also
continue to use the hotkey as usual,

Maouse Clicks Capkure Screenshots

Inchude Right Mouse Button
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» |n the Wheel tab (available for Smart Capture only):

o In the On Mouse Wheel — Add to Slide area, select / deselect mouse
wheel options for the capture session, including:

= Scroll Wheel Up / Down Annotations
= Mouse Wheel Simulation
= Don’'t Add Mouse Wheel Simulation

on Mouse Wheel - Add to Slide
Scroll Wheel Up [ Down Annokations
(%) Mouse ‘Wheel Simulation
(3 Don't Add Mouse Wheel Simulation

0 Inthe Wheel Timing area, enter a number for the:

= Wheel Speed (for click per seconds)
= Delay After Wheel (for capture delay in seconds)

Whieel Timing
Wheel Speed: 10 5 clicks per second
Delay After Wheel: 1.00 % | secands

» |n the Keyboard tab (available for Smart Capture only):
o Inthe On Text Entered — Add to Slide area, select:
= Type Text Here Annotations: To enable ViewletBuilder6.1
Enterprise to automatically add balloon instructions during text
input in the capture session.

= Typing Simulation: To add typing animation to your project.

e Key Click Sound: To include sound effects with the typing
animation.

= Text Zone Assessment: To automatically add Text Zones to the
project during the capture session (where applicable).

= Don’t Add Typing Simulation or Text Zone: To disable all typing

simulation or Text Zone additions to the project when typing
during the capture session.
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On Texk Enkered - Add to Slide
Twpe Text Here Annotations
(%) Twping Simulation

Key Click Sound
() Text Zone Assessment

(") Don't Add Typing Simulation or Text Zane

Completion Keys: Enter,Tab,Escape /

0 Inthe On Text Entered — Add to Slide area, click the Modify f button
next to the Completion Keys field:

= The Completion Keys window displays. The Key list displays the
keyboard keys that ViewletBuilder6.1 Enterprise will recognize as
a “completion key” hotkey when text simulation is captured.
Basically, after typing text, when one of these hotkeys is pressed,
a new screenshot will be captured.

e Click the Add w button to add a new Completion Key

to the list.

o Select a key and click the Delete button to remove it
from the list.

e Select a key and click the Move Up button to move
it up in the list.

. AV
e Select a key and click the Move Down button to
move it down in the list.
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Completion Keys
key
Enter )
Tab —
Escape |::]:|
&
N\
[ ok [ Cancel ]

= Click OK to close the Completion Keys window.
o Inthe Keyboard Timing area, enter a number for the:

» Typing Speed (rate of capture in words per minute)

» Typing Variability (percentage to be used to vary the typing
effects during playback for the most realistic simulation)

= Delay After Typing (number of seconds of delay after typing
simulation is complete)

Kevboard Timing

Typing Speed: 150 {:} wards per minuke
Typing Yariability: 502 %

Delay After Typing: 0.50 {:} seconds

Set the “Typing Variability” at or close to “0” for a more “robotic” typing simulation effect.
Set the percentage closer at or close to “100” for a more “natural” and varied typing
simulation effect.

= In the Annotations tab (available for Smart Capture only):

o Inthe Annotation Language area, use the list to select the language to be
used if enabling ViewletBuilder6.1 Enterprise to automatically create
annotations (balloons) during the capture session.
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Annokation Language

Select the language ko be used to generate the annotations,

Endglish
English s
Oy French s
Zermnan
MHebrew
':_ Italian
Ridjapanese
L% orean

L arwegian w

Tune TowTF Haoreg e TIET T Harvg

re

0 Inthe “default values” area, you can modify the default values for each of
the annotations.

For example, the Name column contains the “title of the action to occur”
in order for the “data” in the Value column to be inserted in an annotation
(balloon) during the capture session.

To change the “data” (text) that will be inserted in a specific annotation:
-Click the desired field in the Value column.

-Type in the edits.
-Press the Enter or Tab key to apply the edits.

Owverride the defaulk values for the annotations,
Marmne Yalue
lick. Here Click Here ~
Right Click Here Righk Click Here
Diouble Click Here Diouble Click Here
Drag To Here Drag To Here
Type Text Here Tvpe "$TEXT$" Here
Scroll Wheel Up Scroll Wheel Up
Scroll Wheel Down Scroll Wheel Down
lick. Butkon Click Butkon
Click. Mamed Button Click "$MAME$" Button
Click, Fadio Button Click, Fadio Button
Click. Wamed Radio Button Click "$MAMES" Radio Bukkon -~

‘.’" Use the “Annotations” list to customize automatic annotations for use during your Smart
2, TR Capture session for all of your Viewlet projects.
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o Inthe Modifiers area, select (as needed):

=  Prefix Click Annotations with Modifiers: If selected, this will add
the text “[Ctrl]” or “[Shift]” (when the applicable key is pressed at
the same time a left mouse click occurs) as a “Modifier” to the
“Click Here” annotation.

e Separator: Enter the letter to use between the “Modifier”
and the “Annotation” (Click Here) text.

= Highlight Variables in Bold: If selected, this will bold the variable
text contained in the annotation.

Maodifiers

Prefix Click Annatations with Modifiers

Separatar | +

Highlight Yariables in Bald

+# | Customizing “Annotations” is pretty straight-forward once you get comfortable working
T | with them. So, if you have any questions with this feature, contact training@qgarbon.com
for help on honing your annotation-authoring skills.

*= In the Advanced tab (all options available for Smart Capture; certain options
available for Manual Capture where noted):

o0 Inthe Frame Rate area (available for Smart Capture only), enter a
number (Frames per Second) for the rate at which you want to capture
screenshots during a mouse drag operation.

Frame Rate
Rate to capture frames during mouse drag operations,

215 Frames per Second

Q ¥ | The higher the number for mouse drag operations, the smoother the resulting animation.
2, T® | You can set a frame rate between 1 to 10 frames per second.

o Inthe Screenshot Delay area (available for Smart Capture only), enter a

number (in seconds) for the amount of time ViewletBuilder6.1 Enterprise
will delay after a mouse click to take a screenshot.
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acreenshot Delay

The amount of ktime after a mouse click to wait before taking a
screenshok, Use longetr delaws Far applications that bake kime to react,
such as browsers,

1.0 Seconds

0 Inthe Capture Popups area (available for Smart Capture and Manual
Capture), select the Capture Popups option to enable capture of such
elements as tooltips, hints and popup menus.

Zapture Popups

Some screen elements such as tooltips and popup menus are displaved in
a separate screen buffer, IF this option is selecked, it will attempt to
capkure them,

[] capture Popups

0 Inthe Compress During Capture area (available for Smart Capture and
Manual Capture), select the Compress During Capture option to
compress captured images during the capture session. This option is
useful for larger projects, but will reduce the number of frames that can be
captured per second during the capture session.

Compress During Capkure

Zaptured images can be compressed during the capture process. This
will keep the size of the capture file small, but will reduce the number of
frames that can be captured per second.

|:| Campress During Capkure

= Once all of the options are selected / edited in the Capture Options window, click
OK to save the information and to close the window. You will be returned to the

Create New Project window where you will see the new Capture Profile added to
the list.

To modify an existing Capture Profile:

= Select the desired profile in the list.
= Click the Modify ”// button.

= The Capture Options window displays. Make your edits to the Capture Mode and
in the various available tabs as needed.
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» Click OK to save the edits and to close the Capture Options window.

To organize the Capture Profiles in the list:

= Select a profile in the list.
= Click the Move Up button to move the profile up in the list.

. 4 . : .
»= Click the Move Down button to move the profile down in the list.

To remove a Capture Profile from the list:

= Select the desired profile in the list.

=  Click the Delete % button.

= A Warning window will display. Click Yes to confirm the deletion, or click No to
cancel the deletion.

e o

Warning
9P

"“"‘4/ Are you sure you wank o delete this Capture Prafile?

Eoves [ Mo

To select a Capture Profile to use for the screen capture session:

= Click on a profile to highlight it to select it. This will be the profile that will be used
during your capture session.

3. Setting up the Screenshot Capture Session

For the most part, each screenshot session starts the same way. After selecting a
Capture Profile to use for the capture session, you click OK to start the actual recording
session. But, did you know that after you click OK, what happens next depends on the
selection made for the project’s slide size?

This section focuses on what to expect and instructions for what you will need to do
“right before” you actually start capturing screenshots (if applicable).

Q — Before “setting” the capture area, you can “back out” by pressing the Esc key.

" ]
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To set up your capture session:

After selecting the Capture Profile to use for your capture session, click OK. The

ViewletBuilder6.1 Enterprise GUI will hide in the background until the end of the
capture session.

= If you selected (for the project’s “Slide Size”):

0 Custom — Specify a custom height and width.

Slide size

@I Specify the slide size wou would like to create or capture,

Custom - Specify a custom width and height.

Before beginning the capture session, a “bounding box” (dotted rectangle)
will display on your screen in the size you specified when selecting a
width and height for your project. This box denotes the capture area.
Everything inside this box will be included in the screenshot.

= To move the capture area, point your cursor over the bounding

box. When the cursor changes to a “hand shape” o , hold
down the left mouse button and drag to move the capture area to

the desired location on your screen.

Sokect th & ed you wat 1O Capbure
Db ik b S22 s Capiburs process
Tocanosl, right oick or press 5

Tips for setting up
the capture area.

&
: Treermet
: Evplorer

Reflects current cize

of capture area (used

for project slide size). Bounding Box (dotted rectangle)
. denotes capture area.

Gnodes {grab handles) can he
usedto resize capture area.
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» To resize the capture area (if needed), point your cursor over one
of the gnodes (grab handles) along the edge of the bounding box.
Hold down your left mouse button and drag to resize.

unless absolutely necessary since the capture area dimensions (width and height) will

; = | Ifyou areusing a“Custom” slide size for your project, do not resize the capture area
,ﬁ&# tely n _
- become the slide size of your project.

= To “set” the capture area, mouse your cursor inside the capture
area and double click to set its size and position. (You are now
ready to take screenshots.)

o0 Standards — Select a standard window size.

slide Size
ﬂ Specify the slide size you would like to create or capture,

l : : )
| Standards - Select a standard window size.

Before beginning the capture session, a “bounding box” (dotted rectangle)
will display on your screen in the size you specified when selecting a
width and height for your project. This box denotes the capture area.
Everything inside this box will be included in the screenshot.

= To move the capture area, point your cursor over the bounding
box. When the cursor changes to a “hand shape” o , hold
down the left mouse button and drag to move the capture area to
the desired location on your screen.

= To resize the capture area (if needed), point your cursor over one
of the gnodes (grab handles) along the edge of the bounding box.
Hold down your left mouse button and drag to resize.

= To “set” the capture area, mouse your cursor inside the capture
area and double click to set its size and position. (You are now
ready to take screenshots.)

0 Application — Capture a running application window.

Slide size

Specify the slide size wou would like to create or capture,

Application - Capture a running application window,

The selected program or operating system window will launch on top of
all other open windows on your computer’s screen and the screen
capture session begins.
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This “active” window, surrounded by a “bounding box” (dotted rectangle),
indicates the capture area. Everything in the capture area (in this
example, the “active” window) will be included in the screenshot.

= | Ifyou select “Application” for the slide size AND are using “Smart Capture” mode, right
< | after you click “OK”, the selected program or operating system window will display on top
- of all other items on your screen and the automatic screen capture session will
IMMEDIATELY begin.

0 Area-— Capture an area of the screen.

Slide Size
. Speclﬁ.-' the slide size wou would like ko create or capture,

- Area - Capture an area aof the screen,

Before the capture session, the cursor changes to a “cross hair” +
shape. This means before the capture session can start, you must define
the capture area. To do this:

= Point the “cross hair” cursor to the point on the screen where you
want to start drawing your capture area.

= Hold down the left mouse button and drag to draw the capture
area. As you drag the cursor, a “bounding box” (dotted rectangle)
will start to form. This is the capture area. Everything inside the
capture area will be included in the screenshot.

T T Bounding Box (dotted rectanole)
e signifies the capture area.
Lok oo of tha moams btion o sttt B
lrentuled deide.

= R I R '
cycle Bin ¢ e

==+ Tips for creating the

Hold down the let mouse button
and drag the "cross hair' cursor
to draw the capture area.

capture area.

IL‘{ 43 5 ]L%

Reflects the current size fwidth
and height) of the capture area.

= Let go of the left mouse button to “set” the capture area’s size and
position. (You are now ready to take screenshots.)
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0 Window — Select a window to capture.

Slide Size
Specify the slide size wou would like to create or capture,

Window - Select a window bo capture,

el

S

WECAYELIEL |

This option allows you to select an entire window (just like the “Active”
slide size option) or a portion of an open window. The trick here is that
you MUST have the window open (not minimized) BEFORE you click OK
to set up the screen capture session. To do this:

VB6.1 Enterprise User Manual

Make sure the window you want to capture is open on your
computer screen (underneath the ViewletBuilder6.1 Enterprise
program) and all other program and operating system windows

are closed or minimized.

Click OK to start the capture session.

A “red box” will display over the window that is displayed on your
computer screen. Move the cursor around the window until the
“red box” outlines the entire window (to capture the entire window)
or a portion of the window (to capture a sub-section of the

window).

L

Mirve the mouse ower the window you
want bo capture

Chck the mouse bo caphure the wandow

Tips for selecting the
capture area.

current size af
the capture area.

Tor earuced, right chek or press ESC, Hator n.:.:l
b Help
[Size: 260 % 260
I_ [Rarl
Reflects the

A'red box" will initially
autline the "patential”
capture area ofthe
celected window.

]M.[W] + ” .
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» To “set” the capture area, double click inside the “red box”. The
“red box” will change to a “Bounding Box” indicating that the
capture area is set. (You are now ready to take screenshots.)

rf{-‘f Calculator E] |

Edit View Help

A"Bounding Box' (dotted
rectangle) surounds the

— "window" capture area. F—

0 Full Screen — Capture the entire screen.

Slide Size

Specify the slide size vou would like to create or capture,

“+*| Full Screen - Capture the entire screen.

When using the “Full Screen” slide size option, if you select a “screen
resolution” different then what your monitor is set to when starting the
screen capture session, after you click OK to start the capture session,
ViewletBuilder6.1 Enterprise will automatically adjust your monitor’s
resolution to what you selected for the slide size and, the screenshot
capture session begins.

If you select “Full Screen” for the project’s slide size AND are using “Smart Capture”
mode, ViewletBuilder6.1 Enterprise will automatically adjust your monitor’s resolution
(based on your selection) and IMMEDIATELY start the automatic capture session. If the
selected “screen resolution” for the slide size is the same as your monitor’s resolution, no
adjustments will be made and the automatic capture session will begin IMMEDIATELY
after you click “OK” to begin the screenshot session.

Everything visible on your screen will be included in the screenshots.
Once the capture session is ended, the monitor’s resolution will return
back to its settings prior to taking screenshots.
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4. Capturing Screenshots (Smart Capture vs. Manual Capture)

Once you've determined the slide size for your screenshot project, have selected a
Capture Profile to use during the capture session, clicked OK to begin the capture
session, and (if applicable) “set up” the capture area—the screenshot capture session is
“live”. At this point, depending on the capture mode you are using (Smart Capture or
Manual Capture), you can start taking screenshots.

To begin the capture session, if the capture mode you are using is:

= Smart Capture: Once the capture session is “live”, ViewletBuilder6.1 Enterprise
will automatically start taking screenshots (based on the selections made in the
Capture Profile you are using). Each time a screenshot is taken, you will hear a
camera shutter sound (if the On Screen Capture option in the Feedback tab is
selected).

= Manual Capture: Once the capture session is “live”, use the Capture
Screenshot hotkey to capture screenshots manually.

To capture an “extra” animation during a Smart Capture session:

»  While a Smart Capture session is running, click the Capture Background
Frame hotkey to manually capture any “extra” animation that displays on your
screen that you think Smart Capture might not capture.

To pause and resume a capture session, if the capture mode you are using is:

= Smart Capture: Click the Pause hotkey to temporarily pause the Smart Capture
session without ending it. The Capture Status window will display (over the
system tray). To resume the Smart Capture session, click the Continue button.

= Manual Capture: Click the Pause hotkey to temporarily pause the Manual
Capture session without ending it. The Capture Status window will display (over
the system tray). To resume the Manual Capture session, click the Continue
button.

Capture Status

Slides: 1
e Size 696 bytes
EPTE & ¥
Caonkinue Skap Cancel More
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Another way to temporarily “pause” a capture session is by pointing your mouse over the
system tray and clicking on the ViewletBuilder6.1 Enterprise icon to display the “Capture
Status” window.

To switch between Smart Capture and Manual Capture modes during a capture session:
» Click the Pause hotkey to temporarily pause the capture session.

» The Capture Status window displays. Click the More button to expand the
options available in the Capture Status window.

e o

Capture Status \

f Slides: 7
| \
" Size: 21,508,096

B B ¥ | ¥

Conkinue Shkop Cancel

= Select the desired Capture Mode from the list (at the top of the Capture Status

window).

o =]
Capture Status
Capture Mode:

| f‘f Smart Capture - Automatically capture all changes. W
| |

("‘-t*' Smart Capture - Automatically capture all changes,

t_. = || Manual Capture - Use a hatkey to capture a screenshot,

e Slides: 7
| A
" Size: 21,5009 bytes

Bound
w0 ] ] ]
v g | To switch hetween capture modes during a live
capture session, simply select the desired

capture maode from the listthen click Continue
Tire to resume the capture session.

Capky
Elapsed: 00:Z1.1

B | & X A

Continue Skop Cancel Less
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= Click Continue to resume the capture session, using the newly selected capture
mode.

To modify capture options during a “live” capture session:
= Click the Pause hotkey to temporarily pause the capture session.

» The Capture Status window displays. Click the More button to expand the
window.

= Select the desired Capture Mode from the list.

= Select the applicable tab(s) and modify selections as needed.

AN

» Clickthe Less =~ "5 | putton to collapse the Capture Status window.

»= Click the Continue button to resume the capture session using the modified
capture settings.

&y Be careful when modifying capture options “on-the-fly” during a live capture session. Any
1-:;u,-;i changes made in the “Capture Status” window will be updated in the selected “Capture
- Profile” being used for that capture session.

5. Ending or Canceling the Screen Capture Session

The last step to create a new Screenshot Project is converting the screenshots taken
during the capture session to the slides that will make up your new Viewlet project. To
do this you must use the Stop Capture hotkey, or click the Stop button in the Capture
Status window to properly end the “live” capture session.

Ending a Capture Session
To end a capture session using the Stop Capture hotkey:
= Once all of your screenshots are captured, press the Stop Capture hotkey. This
will end your capture session.

= Depending on the number of screenshots captured, a progress bar may display
briefly as the screenshots are converted to slides. Once complete, the new
Screenshot Project is displayed in ViewletBuilder6.1 Enterprise, ready for editing.

-

Loading Capture Session

Please Wait ...

L1} 1

14% Complete
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If using Smart Capture for your screen capture session, use the “Stop Capture” hotkey to
end the “live” capture session (instead of clicking the “Cancel” button) to avoid unwanted
screen captures or cursor animations being added at the end of the project.

To end a capture session from the Capture Status window:
»= Once all of your screenshots are captured, move your mouse over the system

tray where you will see a ViewletBuilder6.1 Enterprise icon displayed.
= Click the ViewletBuilder6.1 Enterprise icon.

= The Capture Status window displays. Click the Stop button.

Ca pturE‘Stat us

.

K W

Cancel Maore

= Depending on the number of screenshots captured, a progress bar may display
briefly as the screenshots are converted to slides. Once complete, the new
Screenshot Project is displayed in ViewletBuilder6.1 Enterprise, ready for editing.

Canceling a Capture Session

You can “back out” of any “live” capture session by using the Cancel Capture hotkey.
Or, click the Cancel button in the Capture Status window. When you cancel, this will end
the active capture session without saving any screenshots. You will be returned to
ViewletBuilder6.1 Enterprise’s “Start View” to start anew.

To back out of a capture session using the Cancel Capture hotkey:
= Click the Cancel Capture hotkey. This will end the active capture session.

» No screenshots will be saved and you will be returned to the “Start View” of
ViewletBuilder6.1 Enterprise.
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To back out of a capture session from the Capture Status window:

= Move your mouse over the system tray.

» Click the ViewletBuilder6.1 Enterprise icon that displays.

= The Capture Status window displays. Click the Cancel button.

-,

Capture Status
e Slidesy
| \
'\..--"'E' Size:
B> 7
Conkinue Skop Mare

= This will end the capture session and no screenshots will be saved. You will be
returned to the “Start View” of ViewletBuilder6.1 Enterprise where you can start

again.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@qarbon.com.
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Image Project

ViewletBuilder6.1 Enterprise allows you to create a new project from one or more
images on your system or from an available storage device. You can use images of
different file formats and of varying sizes, combining them all into a single, standard size
Viewlet project.

Imported images are embedded on slides (one image per slide) as background frames.
This chapter highlights the steps for creating a new Image Project.

1. Select the Project Type and Slide Size

= Select File > New from the menu option. Or, in Start View, click the New Project
link, or click the New button from the Main Toolbar.

» The Create New Project window displays. Select Image Project from the New
Project list. Additional options for creating a new image project will display in this
window.

' Create Mew Project

New Project
Create a new YiewlstBuilders Project | e

‘@ Screen Capture Project Slide Size

Capture a running application Specify the slide size vou would like to create or capture,

to create a product JI — ) ) ;

demonstration, simulation or 3 Custom - Specify a custom width and height. w
user training assessment, T

; Width: 002 Height: G002
- Image Project — —
|q;] Create a slideshow From
images on your system. Select Images
gﬁsaﬁr::rsn;gi’:mpj prg, o rol &dd images to the project,
I—Iu Filename Strekch

, PowerPoint Project

| Create a project by importing
one or more slides from a
Microsaft PowerPoint project
an your system,

Quiz Project I:II:I':I

| 83%| Create a project of scored ar
] survey questions ko kest and
gather information From your
user base,
| Blank Project
L] Create a project containing
one or more blank slides. Size:
Dimensions:
CE ] [ Cancel
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» |n the Slide Size area of the Create New Project window, select a width and
height for your Viewlet project.

For more information on selecting a New Project Type or selecting a Slide Size for your
new Viewlet project, please refer to the Creating a New Project Basics chapter.

2. Select Images

Once the project type and slide size are selected for your new project, the next step is to
select the image or images that will make up your new Image Project. Here’s a list of the
various formats supported by ViewletBuilder6.1 Enterprise:

= GIF: Graphics Interchange Format

» JPG, JPEG: Joint Photographic Experts Group
= PNG: Portable Network Graphics

= BMP: Bitmap

= TIF, TIFF: Tagged Image File Format

Animated GIF images are not supported in ViewletBuilder6.1 Enterprise. If you import an
animated GIF image into a project, it will display as a “static” image, showing the image’s
first frame only.

To select images for your new project:

» |nthe Select Images area, click the Add button to search for image files.

Select Images

—1 Addimages ta the project,
LN

Filenanme Skretch

Click the Add buttonto search for and
selectimages for vour new project. l{',:l ‘

» |nthe Select Images File window that displays, select the files you want to
import.
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@_@ To select multiple image files, hold down the “Shift” key and click on the first and last file
2 T® | in asequence to select all the files in the sequence, or hold down the “Ctrl” as you click to
select multiple, non-adjacent files

= After selecting the image files, click Open. Depending on the number and size of
the image files selected, you may see a progress bar display on the screen

indicating the status of the image files being imported into the Create New
Project window.

Loading Images

suntise_01.gif

33% Complete

Cancel

3. Preview and Select “Pre-Import” Image Options

In the Select Images area (Create New Project window), the newly selected images
display in a list. Before importing these images into a new project, you can preview each

image, select its scaling option for the slide, change its position on the list and more.
Let's take a look at each of these options.

To preview an image in the preview panel:
= Click on the image in the list that you want to preview.

» The selected image displays in the preview panel to the “right” of the list. While
the image is displayed in the preview panel:

Select Images

1 Addimages to the project,
[N

Filename Stretch
suntisedl. prig ]
sunrise_01 .hmp\ ]
s —
=| Selected image displays
o inthe Preview Pangl.

s

sunrise_0Z.jpg Ll

Use these buttons to
"rotate” the selected image.

Wiew the file size and dimensions
of the selected imange.

Size: 1 Me
imensions: 1024 x 763
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o Click the Rotate Left |~ | button to rotate the image to the left.

0 Click the Rotate Right |£| button to rotate the image to the right.

If you rotate the image prior to importing it into a new project, this is the “orientation” that
will be used when it is embedded as a background frame on its applicable slide.

0 Below the “rotate buttons” view the selected image’s file Size and
Dimensions.

To add a new image to the list:

=  Click the Add d']j button.

* |n the Select Image Files window that displays, browse for and select the image
files you want to import.

= Click Open. The newly selected images will be added at the bottom of the list.

To move an image up or down in the list:

= Select the desired image.

VAN
= Click the Move Up button. Each time you click this button, it will move the
selected image one position “up” in the list.

= Click the Move Down ‘ button. Each time you click this button, it will move
the selected image one position “down” in the list.

The position of the images in the list determines their “slide” position in the project. The
image at the “top” of the list will be converted to “slide 17, the second from the top will
become “slide 2” and so on down the list.
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To remove an image from the list:

= Select the desired image.

= Click the Delete button. This will remove the image from the list only. It will
NOT delete the original image file.
To modify the “size” of the image prior to importing it into a project:
= Select the desired image from the list.

= Preview the Dimensions of the image below the “rotation buttons”. If the image
width and height is:

o Larger than the project’s slide size, you don’'t need to do anything. The
image will fill the entire background frame of the slide.

o0 Smaller than the project’s slide size:

Filenarne Stretch
sunrisell.png
sunrise_01.bmp
sunrise_01.qif
sunrise_01.jpg
sunrise_01.kif
sunrise_02.jpg

OOOEIOO

-Click the check box in the Stretch column next to the desired image. This
will scale (stretch) the image to fill the slide proportionally. What this
means is that it will scale it to “best fit” the slide, so the image may not fill
the entire slide.

-Deselect the check box in the Stretch column next to the desired image.

The image will remain its original size and be embedded as the
background frame in the middle of the slide.
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4. Convert Images Files to Slides
Here are the last steps to perform in order to create your new Image Project:

= Inthe Slide Size area, make sure the slide size you selected for your new project
is the one you actually want to use. Though the slide size can be change after
creating the project, it's easier to select the proper size right at the beginning.

* |nthe Select Images area:

0 Review the images list and make sure you have all the images you want
listed.

0 Make sure the images are listed in the order you want the slides to be
created. Though you can rearrange slides once the project is created, it
will save you a lot of work to list them in desired order right at the start.

0 Rotate any images as needed.

0 Select the check box in the Stretch column next to any images you want
to “stretch” to fit the slide (only applicable to images smaller then the
project’s slide size).

0 Delete any images you do NOT want to include in your new project.

= Once all your selections are complete, click OK to convert the images to slide
background frames in your new Image Project.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.
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PowerPoint Project

ViewletBuilder6.1 Enterprise allows you to create a new project by directly importing
slides from a Microsoft PowerPoint (.ppt) file while in the Create New Project window.
This chapter walks through the steps for creating a new PowerPoint Project.

1. Select the Project Type and Slide Size

= Select File > New from the menu option. Or, in Start View, click the New Project
link, or click the New button from the Main Toolbar.

» The Create New Project window displays. Select PowerPoint Project from the

New Project list. Additional options for creating a new PowerPoint project will
display in this window.

! Create Mew Project

New Projeck
Create a new YiewletBuilders Project

~ = Screen Capture Project
@ Zapture a running application
to create a product
demonstration, simulation or a
user training assessment,

L, Image Project

0| Create a slideshow From
imnages on your system,
Supports jpg, brap, pnag, gif
and tif images.

a, PowerPoint Project

|L___ || Create a project by importing
one of mare slides from a
Microsoft PowerPoint project
on your systern,

Quiz Project

Create a project of scored or
suryey questions ko test and
gather information From your
user base,

|. g7

l|:|. Blank Project
Create a project conkaining
one or more blank slides,

Slide Size
Specify the slide size you would like to create or capture.
Custor - Specify a custom width and height, w
Width; 540 2| Height: 430
Presenktation
> Select the PPT presentation file to load:
= —

Slides

Select the slides to load into the project.

Slide Impork

][ Cancel ]

[ ok

= Inthe Slide Size area of the Create New Project window, select a width and
height for your Viewlet project.

(oY

T

For more information on selecting a New Project Type or selecting a Slide Size for your

= new Viewlet project, please refer to the Creating a New Project Basics chapter.
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2. Select the PowerPoint (.ppt) File
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Once you've selected the slide size for your new project, it's time to browse for and
select the PowerPoint presentation you want to covert to a Viewlet project. To do this:

» |n the Presentation area (Create New Project) window, click the Load PPT file

button.

Presentation

= Select the PPT presentation File ta load: w

= Inthe Open PowerPoint Presentation window, browse for and select the

presentation file.

= Click Open. You will be returned to the Create New Project window where you

will see the presentation file listed in the Presentation area field.

Presentation
Select the PPT presentation File ko load:

=| wondersdl,pptk

3. Preview and Select “Pre-Import” PowerPoint Slides Options

In the Slides area (Create New Project area), the selected PowerPoint presentation
slides display in a list. At this point, you can preview the slides one at a time, make final
determinations which slides to import into your project, and select additional importing

options. Let’s take a look at each.

Slides
Select the slides to load into the project.

Slide Impart

Slide 1 om

Slide 2 '

Slide 3 i)
Slide 4 %%l?g%
Slide 5 >
Slide &

Slide 7

Slide &
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To select / deselect the PowerPoint slides to import into your new Viewlet project:

= Select the check box (to place a checkmark) next to each of the slides you want
to include in your new project.

» Deselect the check box (to remove the checkmark) next to each of the slides you
do NOT want to include in your new project.
To preview a slide prior to importing it into your new project:
= Select the desired slide from the list.
= In the Preview Pane (to the right of the list), preview the selected slide.

» Follow these steps to preview each of the slides in the list.

To select additional “pre-import” options for your PowerPoint slides:

= Click the Options button.

= The PowerPoint Options window displays. There are two tabs available: General
and Fonts. Select the desired tab for additional options.

PowerPoint Options

General | Fonks

General Tab
= Select the General tab. The General tab contains options for setting slide

durations for your new project and a Pause Zone to each slide.

0 Inthe Slide Duration area (General tab), enter a number in the field
provided for the amount of time to display the slide in your new project.
This will be the “baseline” slide duration for each of the slides in your
Viewlet project.

Slide duration

Cisplay Far 0.0 2 seconds

0 Inthe Options area (General tab):

= Select the Add pause to the slides to add a Pause Zone to each
of the slides in your new project.
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» Deselect the Add pause to the slides if you do NOT want a
Pause Zone added to each of the slides in your new project.

NewiEeattpe Fonts Tab (New in ViewletBuilder6.1 Enterprise)
= Select the Fonts tab.

The Fonts tab is a new feature in ViewletBuilder6.1 Enterprise. It allows you to
select additional fonts for ViewletBuilder6.1 Enterprise to use if the font used in
the imported PowerPoint Presentation is not available for use on your system (or
from within ViewletBuilder6.1 Enterprise).

Select the alternate fonts to use,

Available Fonts Alternate fonks
Ageney FB - zeorgia
LLEERTAN Arial

Arial Comic Sanz WS
Arial Black Dialog

Anal Marrow

Anal Rounded MT EBold

Arial Unicode kS
Baskermlle Cild Face

RBavhauw 93
BellMT
Bedin 5ans FB

q |8 ||+ P

To select an alternate font from the list of available fonts:

0 Select the desired font from the Available Fonts list (on the left side of the
Fonts tab).

o Click the Add i button to add the selected font from the Available
fonts to the list of Alternate fonts (on the right side of the Fonts tab).

0 Repeat the previous steps for each available font you want to add to the
Alternate fonts list.

To move a font up or down in the Alternate fonts list:

0 Select the desired font you want to move in the Alternate fonts list.

0 Click the Move Up button to move the font up in the list. Repeat as
needed to continue moving the font up in the list.
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o Click the Move Down button to move the font down in the list.
Repeat as needed to continue moving the font down in the list.

¥ | The order (top to bottom) of fonts in the Alternate fonts list is important. If
2 T® | ViewletBuilder6.1 Enterprise needs to use an alternate font for your project, it will start
with the first one (top) in the list.

To remove a font from the Alternate fonts list:

0 Select the desired font you want to remove from the Alternate fonts list.

o Click the Delete button. This action will remove the selected font
from the Alternates fonts list only.

= Once all options are selected in the PowerPoint Options window, click OK to
save the information and to return to the previous window.

4. Convert the PowerPoint Presentation to Viewlet Project Slides
Here are the last steps to perform in order to create your new PowerPoint Project:
» |nthe Slide Size area, make sure the slide size you selected for your new project
is the one you actually want to use. Though the slide size can be change after
creating the project, it's easier to select the proper size right at the beginning.

= |n the Presentation area, review the PowerPoint file name to make sure it is the
one you want to convert.

= |n the Slides area:

0 Review the list of PowerPoint slides and select each of the slides you
want to preview in the Preview Pane.

0 Select/ deselect the check box next to each of the slides you want to
include / not include in your new PowerPoint Project.

0 Click the Options button and review / modify choices in the PowerPoint
Options window in both the General and Fonts tabs.
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= Once all your selections are complete, click OK to convert the selected
PowerPoint slides to slide background frames in your new PowerPoint Project.

=  While the PowerPoint slides are being converted, you may see a Loading
PowerPoint File window display as the new project slides are loading. Once the
conversion is complete, your new PowerPoint Project displays and is ready for
editing.

Loading Powerpoint File

Loading Slide 1 of &

LI 1

12% Complete

Cancel

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.
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Quiz Project
(New in ViewletBuilder6.1 Enterprise)

New in ViewletBuilder6.1 Enterprise, the Quiz Project now combines all of the powerful
features of the old Quiz Projects and Survey Projects (in previous versions) into one new
enhanced and redesigned Quiz Project type. The new Quiz Project type allows you to
integrate scored slides and simple survey question slides into a single Viewlet project.
Or, if you prefer, use the new Quiz Project to create an entire quiz project (for testing
purposes) or an entire survey project (for gathering information from a user base).

This chapter explains the steps for creating a new Quiz Project (with scored and/or non-
scored question types). It also provides an overview of the various question types
available for your new Quiz Project.

= =y

! Create Mew Project

New Project
Create a new YiewletBuilders Project N

clide Size
Specify the slide size vou would like to create or capture,

Screen Capture Project

Capture a running application
to create a product ]
demonstration, simulation or 3 Custom - Specify a custom width and height. w

user training assessment,

)

) Width: 8002 Height: 600 2
L Image Project — —
\Qu Create a slideshow From
images on your system. Questions
gﬁsaﬁr::rsn;gijs!mpj pna, gif Create scored or survey queskions for the project.
Question Type

, PowerPoint Project
L—a: Zreate a project by importing
one or more slides from a
Microsaft PowerPoint project

On your syskem, I:::l':I

Quiz Projeck

Create a project of scored or

survey questions ko kest and &
gather information From your

user base,

Og-
g
u

Blank Project
Create a project containing
one or more blank slides.

[0

CE l [ Cancel
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1. Select the Project Type and Slide Size

= Select File > New from the menu option. Or, in Start View, click the New Project
link, or click the New button from the Main Toolbar.

» The Create New Project window displays. Select Quiz Project from the New
Project list. Additional options for creating a new Quiz Project will display in this
window.

» |nthe Slide Size area of the Create New Project window, select a width and
height for your Viewlet project.

Q 7 | For more information on selecting a New Project Type or selecting a Slide Size for your
TR | new Viewlet project, please refer to the Creating a New Project Basics chapter.

2. Review Question Types

There are 11 common question types available for your Quiz Project. These question
types can be scored or not, depending upon how you want to use them. The option to
set a question type as a “quiz question” (scored) or a “survey question” (not scored) is
covered later in this chapter. For now, let's take a look at each of these question types.

Short Answer — Fill in the Blank
This question type requires the user to fill in the blank with a single answer.

The square root of 81 is

[ ]

Short Answer — Selection from List
This question type requires the user to select a single answer from a list.

Who was the first President of the United States?

George Washington L
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Short Answer — Rating
This question type requires the user to select a single rating from a given scale.

Rate Qarbon's customer service.
ST 37 BT

Short Answer — Essay

This question type allows the user to type in one or more words, sentences or
paragraphs (essay style) to respond.

Describe how you use Viewlets.

Multiple Choice — Single Answer

This question type requires the user to select a single answer from a list with two or
more choices.

What is 2 + 27

Multiple Choice — Multiple Answers

This question type requires the user to select a single or multiple answers from a list with
two or more choices.

Which of these numbers are Prime?
2207
3492
4409
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Multiple Choice — Fill in the Blanks

e

k]
|

This question type requires the user to type in a response in one or more “fill in the
blank” entry fields.

| am ____ feet tall and weigh pounds.

Height: [ |

weight:[ |

Multiple Choice — Selection from Lists
This question type requires the user to select an answer from one or more lists.

e

Match the logo to the Qarbon product from each list.

ViewletBuilder Enterprise

ViewletBuilder Professional

ViewletQuiz

ViewletCam

ViewletCentral

Multiple Choice — Rating

This question type requires the user to select one or more ratings from a single or
multiple rating scales.

Rate these Viewlet authoring products.

ViewletBuilders 57 5.7 77
ViewletQuiz3 57 57 77

ViewletCam2 57 57 57
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Multiple Choice — True/False

This question type requires the user to select an answer from one of only two possible
choices.

Qarbon's "HQ" is in San Jose, CA.
) True 1 False

Likert Scale
This question type requires the user to select an answer based on their specific level of
agreement to a specific statement.

Viewlets are cutting-edge when it comes to E-Learning.

Strongly Strongly
Disagree Disagree Undecided Agree Agree

i P Pl P Pl

L

Many of these 11 question types can be used in quizzes or in surveys; the choice is up
to you.

¥ | A quizrequires a correct response (and is typically scored), whereas a survey does not
TR | require a correct response (and is not scored).
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3. Select Quiz Questions

Make sure before you begin adding questions for your Quiz Project that you review the
previous section so that you understand the different question types available for your
project. This will help you determine what questions will work best for you. Once you feel
comfortable with the various question types, you are ready to start building a list of
questions for your project.

To create a new question for your project:

oe

» |n the Quiz Questions area (Create New Project window), click the Add
button.

» The Question window displays. Click on a question in the Question Type list to

select it.
Question Type:
”

e — Short Answer - Fill in the Blank

] & 'Fill in the Blank! question that has a single answer,
Example: The square rook of 81 is .
Short Answer - Selection From List

R & guestion with a single answer, selectable from a given list.

[EZzzE| Example: Which of these planets is the largest?
Pluta, Jupiter, Mars
Short Answer - Rating

S & queskion that allows the user ko choose a single answer on a given scale,
Example: Rate your dining experience in Mew York Ciky,
1 star, & stars, 3 stars, 4 stars, 5 stars -

= Type a question in the field provided.

Question:

wehat is the name of Qarbon's mascok?
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» |n the Scoring Mode area, select either Quiz or Survey.

Scoring Mode:

(@ Quiz: Scored - Requires the user to provide a correct answer.

(71 Survey: Not scored - Does not require a correct answer,

= | Ifyou want to quiz auser, but do NOT want to score the questions, select “Quiz: Scored —
< | Requires the user to provide a correct answer” for the “Scoring Mode”. Then, when you
- edit your project, in the “Score” window, set the “Points” value to “zero”. This way, the
user will be required to answer correctly, but no score will be applied.

= Click OK to apply and to close the Question window. The new question will
display in the Quiz Questions list.

» Repeat these steps for each additional question you want to create for your
project.

Questions
Create scored or survey questions for the project,
T

Question Type

wehat is the square roak of,.. Shaork Answer - Fill in the Blank - Quiz
Whio was the First Preside...  Short Answer - Selection From Lisk - ...
Rate Qarbon's customer 5., Shork Answer - Rating - Survesy
Describe how you use Wie,.,  Short Answer - Essay - Survey

BN P

To edit a question in the list:

= Select the desired question in the list.

= Click the Modify / button.

= Make your edits in the Question window that displays.
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» Click OK to apply the changes and to close the Question window.

To move a question up or down in the list:

= Select the desired question in the list.

= Click the Move Up ‘ ‘ button to move the question up in the list. Repeat this
step to continue moving the selected question up in the list.

»= Click the Move Down ‘ button to move the question down in the list. Repeat
this step to continue moving the selected question down in the list.

The position of questions in the list determines the order in which they will appear in the
project. For example, the question at the top of the list will become slide 1 in the project,
the second from the top will become slide 2 and so on. You can reorganize your slides
once your project is created, but to save time, organize the list of questions as needed
BEFORE creating your new Quiz Project.

To remove a question from the list:

= Select the desired question in the list.

= Click the Delete ‘ ‘ button. This will remove the selected question from the
list.

Be careful when deleting questions from the list. Once you delete them, you cannot
“Undo” the deletion. Once deleted, the question must be recreated if you need to add it
back to the list.

4. Convert Questions to Slides
Here are the last steps to perform to create your new Quiz Project:

» |nthe Slide Size area, make sure the slide size you selected for your new project
is the one you actually want to use. Though the slide size can be change after
creating the project, it's easier to select the proper size right at the beginning.

= In the Quiz Questions area:

0 Review the list of questions and make sure they are in the order you want
them to be when your new project is created.

VB6.1 Enterprise User Manual Page 76 March 2009



TEVVILE FERIUTTHLE] & RO S E KLLEA T L e (\( User Maouall

0 Modify any of the questions as needed.

0 Delete any extra questions from the list so that unnecessary slides are
not created.

= Once all of your selections are made and questions created, click OK. This will
converts the questions in the list to slides. Once this operation is complete, your
project will display, ready for editing.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.qgarbon.com). Or, if you prefer, email support@qgarbon.com.
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Blank Project

ViewletBuilder6.1 offers you the option of creating a new Blank Project containing one or
more blank slides. This new project type is perfect for those not sure of what new project
type to use or for those wanting to create a new project from scratch using a blank
template.

1. Select the Project Type and Slide Size

= Select File > New from the menu option. Or, in Start View, click the New Project
link, or click the New button from the Main Toolbar.

» The Create New Project window displays. Select Blank Project from the New
Project list. Additional options for creating a new Blank project will display in this
window.

. Create Mew Project

New Project
Create a new YiewletBuilders Project W

Slide Size

Screen Capture Project
Specify the slide size you would like to create or capture.

Zapture a running application
to create a product ]
demonstration, simulation or 3 Custor - Specify a custom width and height, w

user training assessment,

)

_ width: | B40[%) Height: | 480[%)
L Image Project o o
ﬁgl Create a slideshow From
irmnages on your system, Slide Count
gﬁsﬁritrsn.;ggejsfjmpj png, oif Entet the number of slides you would like ko create.
13

L

, PowerPoint Project
L'a.' Create a project by importing
one of more slides from a
Microsaft PowerPoint project
an your system,

Quiz Project

Create a project of scored or
survey questions ko kest and
gather information from your
user base,

| | Blank Project
L] Create a project containing

one or more blank slides.

[ Ok, H Cancel ]

» |nthe Slide Size area of the Create New Project window, select a width and
height for your Viewlet project.
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For more information on selecting a New Project Type or selecting a Slide Size for your
new Viewlet project, please refer to the Creating a New Project Basics chapter.

2. Select the Number of Slides

Once you have set the options for the size of the slides for your new Blank Project, the
next step is to decide the number of slides you would like to create for your new project.

= Inthe Slide Count area, enter the number of slides you want to create for your
new project in the field provided.

0 Click the Up Arrow [=] button to increase the number of slides.
o Click the Down Arrow > button to decrease the number of slides.

You may select from 1 to 999 slides for your new Blank Project.

3. Create Blank Slides
Here are the last steps to perform to create your new Blank Project:

» |nthe Slide Size area, make sure the slide size you selected for your new project
is the one you actually want to use. Though the slide size can be change after
creating the project, it's easier to select the proper size right at the beginning.

» |nthe Slide Count area, make sure that the number you entered is the actual
number of slides you want to initially use for the number of slides in your new
Blank Project.

= Click OK. The slides for your new project will display in ViewletBuilder6.1, ready
for editing.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@qgarbon.com.
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Workspace Features and Tab Views

While working on a project in ViewletBuilder6.1 Enterprise, there are various
“workspace” features and views available to help you optimize your Viewlet authoring
tasks. This chapter provides a look at:

= The View Menu — At a Glance
= Organizing Tab Views and Workspace Areas

The View Menu — At a Glance

Wi
Slide Zoom [
ToolTips
Cursor Path
Speling Mistakes
Event Icans
Attached Sound Icons
PauseZone Icons
Tirnirng Links
Status Bar
Browser
Thumbnails
Styleshests
Cuakpuk
Tirneline
Slide Motes

The View menu is divided into three main sections, with selections for use while working
in your project. These include:

= Slide Zoom: This section contains various slide zoom options to use while

working on your project, including Zoom In, Zoom Out, Fit to Slide and various
percentage zooms.
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= Miscellaneous Tools: This section contains selections to enable / disable tools
such as:

o0 ToolTips: Displays a “hint” near the button the cursor hovers over.

BN

Toaltip displays when cursar
howvers over "LUndo” button.

0 Cursor Path: Displays a “dotted” line between cursors, indicating the path
the cursor will travel from the current slide to the next slide.

Point A
CurzorPath
¥ -_‘g;int B
. _}:_,...,_:

o Spelling Mistakes: Displays a “red underline” under words that are not
recognized by the dictionary.

This is a demonstashun.

o0 Event Icons: Displays a “lightning bolt” over objects that have an “event”
attached to them.

The "event icon" denotes
the shape has an "event'
attachedto it
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Attached Sound Icons: Displays a “speaker” near objects that have a
sound file attached.

0 PauseZone Icons: Displays a “red icon” in the bottom right of a slide that
contains a Pause Zone. This “red icon” will not display in the published
Viewlet.

Displayed in
hottarm right
carnerofa
slide with a
FPause fone.

0 Timing Links: Displays a link connecting two or more objects along the

Timeline.
slide 1
| Timing
L Link i
o |
| Y

o0 Status Bar: Displays at the bottom of the program window and displays
various information about the project.

T
Slide 1 of 2 | 640x480 | x48vi240 | Memory:4% | Zoom: 75 % |
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» Tab Views: This section contains options called “Tab Views". Each view can be
displayed or hidden as desired and are used for specific operations. The list of
Tab Views include:

Browser
Thumbnails
Stylesheets
Output
Timeline
Slide Notes

OO0OO0OO0OO0Oo

Each of these Tab Views are discussed later in this manual, each in their own
respective chapter.

Organizing Tab Views and Workspace Areas

The project workspace area, by default, displays selected Tab Views to the left and
below the slide edit area. The workspace can be reorganized as desired based on your
authoring needs.

To display / hide a Tab View from the View Menu:
= Select View from the Menu bar.
» Todisplay a Tab View, select it from the list. When selected, a checkmark will
display next to it.
= To hide a Tab View, deselect it from the list to remove the checkmark next to it.

(oY By default, when first selected, the “Browser”, “Thumbnails” and “ Stylesheets” Tab Views
e | display to the left of the slide edit area. The “Output”, “Timeline” and “Slide Notes” Tab
- Views display below the slide edit area.

Each Tab View contains buttons to expand or minimize / maximize the tab(s):

= Select the Expand & button to expand the tab to full view.
= Select the Minimize = button to minimize all active tabs.
» Select the Maximize = button to restore all active tabs to their previous sizes.

EEE = 82 [Jd & = v
/5
= (d
= F
B
£ |
Z |
=
_ <
2
s e
[==]
[
Wiew of a project with «
. "Minimized Tab Wiews".
&= 2]
a
T
T i
\%/
@neline Dutpukt | Slide Motes @lr
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To move between active Tab Views:
= If multiple tabs are displayed, only one tab can be in view at a given time. Click
on the tab you want to work on to bring it to the front of the active tabs.
= Repeat this action to move between tabs.

To close (hide) an active Tab View:
» Select the desired tab to bring it to the front of the tabs.
= Click the “X” located at the right edge of the selected tab. This will close
(hide) the Tab View, which must be reselected from the View menu to be
displayed again.

-3 Instead of closing (hiding) a Tab View, click the “Minimize” button to neatly collapse it to
2 T® | the side (or bottom) of the workspace area. This way, it is out of the way, but can be easily
accessed again when needed while working on the project.

To move a Tab View from its default position:
= Point your left mouse button over the desired Tab View.
= Hold down your left mouse button and drag the Tab to the bottom or “opposite
side” of the project workspace area.
= When the area to where you are dragging the Tab View is surrounded by a
“dotted rectangle”, let go of the left mouse button to drop it into place.

-f' If you move a Tab View to a new location on the screen, if you then close and reopen it,
2 T® | the Tab View will display in its last “remembered” location on the screen.

To resize the “window area” of a Tab View:
= Point your cursor over the right / left / top edge (whichever is applicable) until the

cursor shape changes to a double arrow shape.

= Hold down the left mouse button and drag the edge of the Tab View window to
resize it.

= Let go of the left mouse button when done.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.

VB6.1 Enterprise User Manual Page 84 March 2009



' K
(2 3BT O I EiLey Dy iAe R e !
LEVVILE NN L] S TREYTR ] B FLLEA L, ‘ (\; User Manual

Slide Edit Area and Zoom Tools

In ViewletBuilder6.1 Enterprise, when a project is open, the workspace area consists of
various toolbars, Tab Views and the traditional “Slide Edit” area. The Slide Edit area is
where you directly add objects to a slide and edit them. This is also the areas where you
will spend a majority of your time while working on your Viewlet project.

As discussed in the previous chapter, when selected, Tab Views display (by default) to
the left and below the Slide Edit area. These tabs can be minimized, repositioned or
closed to allow more “working real estate” on the slide. When a Tab View is “maximized”
the Slide Edit area is hidden from view until the active tab is resized, minimized or
maximized.

Zoom Tools

While working on a slide, there may be times you want to zoom in or out on the slide.
This can be done using the options from the View Menu or by clicking any of three
“zoom” buttons along the Main Toolbar.

To change the slide zoom level from the View Menu:
= Select the desired slide.
= Select View > Slide Zoom from the Menu bar.
= Select the desired slide zoom from the available options.

Wi
Slide Zoom b (]
Sl Zoom In

(i

' Zoomn Sk

o g

=
@), Fit slide

L

200 %
175 %%
150 %
125 %
100 %
W 75 %
50 %
25 %
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To change the slide zoom using the zoom button on the Main Toolbar:

= Select the desired slide.

= Click the Zoom In gl button to zoom in on a slide.

o

= Click the Zoom Out = button to zoom out on a slide.

F=H

» Click the Fit Slide # 4 button to zoom the slide to fit to the size of the current
Slide Edit area.

-3 Keep clicking the Zoom In or the Zoom Out button to continue zooming in or zooming out
2 T® | as desired on the selected slide.

Other tasks, such as adding message objects, images, shapes, tweaking cursor
animation, etc. will vary depending on the content of each project. These additional tasks
performed in the Slide Edit area are covered in further detail throughout this user
manual.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.
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Browser Tab

The Browser Tab allows you to easily organize access and manage the resources that
are available to you while you author your Viewlets. You can open projects, drag and
drop images and movies, add publishing targets, delete files or folders, and view
statistics of your Viewlets published on ViewletCentral. This chapter highlights some of
the features of the Browser Tab.

To display the Browser Tab:
= Select View from the Menu batr.
= Select Browser.

Browser =8
R 9 (-
—-#=% Qarbon

+|E|_-' My Wiswlets

+|E|_f Library
+- [ Carbon YiewletCentral

Mame Description
e/ My Wienwlets Folder
tJ Library Folder

% Carbon WiewletCentral — WiewletCentral

The Browser Tab contains a “tab” at the top of its window area with the title of “Browser
indicating what tab it is. A toolbar displays below the tab’s title with buttons applicable to
tools available in this tab.

To add a new “publishing target” from the Browser Tab:

= Select the Browser Tab to make it the active tab.

=  Click the Add & button.

= The publishing target options display. Select one from the list:

|77 Add Local or Metwork Falder..,
ﬁ Add FTP Server...
% Add Qarbon ViewletCentral. ..

% Add Corporate ViewlekCentral. ..
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» |n the additional windows that display, follow the instructions for creating the new
publishing target. Please see the chapter on Publishing a Viewlet for more
information on adding new and working with publishing targets.

@.ﬁ’ Publishing targets can also be added during the publishing process.
.‘:
-

To remove files or folders from the Browser Tab’s list:

=  Select the desired file or folder from the Browser Tab’s list.

= Click the Delete 5 button.

= A Delete window will display. Click Yes to confirm the deletion. Click No to
cancel the deletion.

= | Pay careful attention to the information in the “Delete” window that displays after you click
% the “Delete” button. In some cases, the deletion will NOT delete the actual file or folder (if
it is a shortcut). In other cases, the deletion WILL delete the actual file or folder from not
only the “Browser Tab” but also from your system.

To navigate through files and folders in the Browser Tab’s list:

= Select the desired file or folder to highlight it.

= Click the Up One Level ' button to move up to the next level in the list.

» |f a folder is selected and it contains a plus # symbol to the left of it, click this
plus symbol to expand the list of files and additional folders contained in the
folder.

» If a folder contains a minus = symbol to the left of it, click this minus symbol to
collapse the files and folders contained in the folder.

» Click on a desired file or folder at any time to quickly navigate through the list.

To refresh a selected folder in the Browser Tab:

=  Select the desired folder in the Browser Tab list.

= Click the Refresh the current folder = button to refresh the list of files and
folder contained in the selected folder.
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The document “check in / out” and “undo document check out” buttons on
the Browser Tab’s button toolbar are only available when working with the “Self Hosted”
version of ViewletCentral. Contact sales@garbon.com for more information.

To change how files and folders are displayed in the Browser Tab:

= Select the Browser Tab to make it the active tab.

= Click the Views " button on the toolbar.
» The available view selections display. Select the:

Icon View
& Dekails Yiew

Thumbnail Vi

o Icon View: Displays an icon next to the file and folder in the lower portion
of the Browser Tab.

o Details View: Displays the file or folder name, type, number of slides, last
modification date and file size.

To sort files and folders displayed in the Browser Tab using the “Details View”, simply
click the applicable column header.

w Mame Description

Available sorts include “Name” or “Description” columns.

o Thumbnail View: Displays the file as a thumbnail.

For more information on working with other Tab View options (such as expanding,
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on
Workspace Features and Tab Views.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@qarbon.com.
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Thumbnails Tab

The Thumbnails Tab, when selected, displays (by default) to the left side of the Slide
Edit area. This tab allows you to view all the slides in the entire project. Various tasks
can be performed while viewing thumbnails including: navigating through the slides in
the project, moving the order of slides, adding features to one or more slides at the same
time, copying and / or deleting slides, zooming in and out on thumbnails and more. This
chapter highlights the main features available while working in the Thumbnails Tab.

Thumbnails =5

o & 99

To display the Thumbnail Tab:
= Select View from the Menu bar.
= Select Thumbnails from the list.

The Thumbnails Tab contains a “tab” at the top of its window area with the title of
“Thumbnails” indicating what tab it is. A toolbar displays below the tab’s title with buttons
for additional features while working with thumbnails.

To increase or decrease the zoom level of the thumbnails in the Thumbnail Tab:
=  To increase the size of the thumbnails, click the Zoom In 5% button.

= To decrease the size of the thumbnails, click the Zoom Out e button.

To update the thumbnail of a recently edited slide:

» Select the desired thumbnail(s) from the list.

= Click the Refresh Thumbnail < button to refresh the selected thumbnail.

VB6.1 Enterprise User Manual Page 90 March 2009



L WALELVVILE FRUNTIUE] CROSEIRC FLLEX DL _ (\( serManualy

To updated all of the thumbnails in the project:

= Select the Thumbnails Tab to make it the active tab.

= Click the Refresh All Thumbnails ™ button to refresh all thumbnails in the
project.
To move one or more slides within the project:
= Select the Thumbnails Tab to make it the active tab.
= Select one or more slide thumbnails by clicking on them to select them.

= Hold down your left mouse button and drag the selected thumbnail(s) to the
desired location.

= Let go of the left mouse button to drop the selected thumbnail(s) into place.

¥ | If you have to move slides within your project, click the “Expand” button in the
M T® | Thumbnails Tab. This will expand the number of thumbnails viewable in your project and
make moving slides (thumbnails) a lot easier.

To copy one or more slides in the Thumbnails Tab:
= Select the desired thumbnail(s) from the list of thumbnails.
= Press Ctrl + C to copy the thumbnail(s). You can also select Edit > Copy from
the Menu bar. Or, select the thumbnail(s) and right click then select Copy from

the shortcut menu.

= Select the thumbnail you want to use as the insertion point. Pasted thumbnails
will be inserted “after” the selected thumbnail.

= Press Ctrl +V to paste the copied thumbnail(s). You can also select Edit >

Paste from the Menu bar, or right click on the “insertion point” thumbnail then
select Paste from the shortcut menu.
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To delete one or more slides from the Thumbnails Tab:
= Select the desired thumbnail(s) from the list.
= Press the Delete key from the keyboard. Or, select Edit > Delete from the Menu
bar. Or, right click on the selected thumbnail(s) and select Delete from the
shortcut menu.
For more information on working with other Tab View options (such as expanding,
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on
Workspace Features and Tab Views.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.qgarbon.com). Or, if you prefer, email support@qgarbon.com.
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Stylesheets Tab

The Stylesheets Tab allows you to set properties of multiple objects using a template
called a “stylesheet”. A stylesheet can be used for new and existing projects and
updated as needed. You can set up one or more stylesheets and then choose to apply
to the entire project or just to a current selection. Here’s an alphabetical list of the
“properties” that can be set up in stylesheets:

= Background Color: Set the background color of a slide or message object.

L o
Background Color...
R 2553
G 2553
B 2553
#FFFFFF
Custorn [T TTTTTTT ]+ %
Recent (I T [T T [T T
[ oK |[ Cancel H Apply

= Button Style: Standardize the “look” of clickable buttons used in a project from
a library of button images.

o 1
. Button Style
Select a style For the Button:
”

Classic Button Skyle Abc
Bumper Button Skyle Abc |
Carnival Button Style m
Galass Bukkon Style E
Impack Butkan Skyle | Abc
Mac Butkon Style  Abc )

— v

K ] [ Cancel ] [ apply ]
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= Check Box Style: Set the “look” of check box selection fields used in question

slides from a library of check box images.

(o T = |

Select a style For the Check Box;

Bumper Check Box Style

Carnival Check Box Skyle
Check Mark Check Box Skyle
aray Mac Check Box Style

Impact Check Box Skyle

B® a0
O e o

“_
o
-
hagg 22
—_—
[l
1}
=]
I}
o
L
—_—
iz
=]
=3
=
L

= ComboBox Style: Set the “look” used for combobox lists used in question

slides from a library of combobox images.

Tomanse

Select a style For the ComboBo:

Mac ComboBox Skyle

Mac ComboBox Skyle 2 II d

Windows 2000 ComboBox Skyle I j

Windows %P ComboBox Style |

E I i[ Cancel J[ Apply J

VB6.1 Enterprise User Manual Page 94

March 2009



d n_']] ,-::..,.F-iyew c_ssﬁ .

= Message Style: Set the style used for message objects from a list of available
“pre-defined” styles.

1 |

m

Select the Message Style:
_ v

i (4 ][ Cancel ]

= Message Type: Standardize the style and type of message objects such as
notes, balloons and text boxes.

i W1

Message Type 3

Select the message skyle:
|Classic Message Style

Select the message bype:

HAU0O000
0O0CC O

E (] 4 i[ Zancel ][ apply ]
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= Modify Click Area: Set the attributes of what happens when a user interacts
with a Click Zone.

= =1

Click Area

Marrmal: the look of the area under normal circurnstances
1 A s
> I o) Z | %
Rollover: the look of the area when the mouse is over it
1 Y Fs
< Il ofs] | == | o
Selected: the loak of the area when the user clicks an it

< o) | 7= | of

[ ] Double Click ta Select

| K |[ Cancel H apply ]

= Radio Button Style: Set the “look” of radio buttons used with question slides
from a library of radio button images.

! Radio Button Style

Select a skyle For the Radio Button:

Classic Radio Button Skyle

Burnper Radio Butkon Skyle

arnival Fadio Butkon Style

aray Mac Radio Button Style

Impact Radio Button Style

Gme® 0 0 ©
OInoN X 1

Jewel Radio Bukton Skyle

Ok |[ Cancel ][ Apply ]
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= Rating Style: Standardize the “look” of survey question rating objects used on
question slides from a library of rating style images.

m

Select a skyle For the Rating:

Acid Rating Style D D
flien Rating Style ®DO® -

Ball Rating Style . . . e »

Elue Maon Rating Style J J J ..

Blue Star Rating Style ﬁ {-\f i}' . .

< 1 |

k (] 4 i[ Cancel ][ Apply ]

= Text Field Style: Set the “look” for text input fields on question slides from a
library of text field images.

Select a style For the Text Field:

Borderless Text Field Skyle i i

Transparent Text Figld Style

wWindows 2000 Text Field Style |

Windows %P Text Field Style |

oK i[ Cancel ][ Apply
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Text Properties: Set text attributes, including: font, size, style, alignment and

color for message objects.

-

Text Properties

Fonk: | Dialog M
Size: | 16 kl

Skyle: I u B

dignment | = = =

Colar:

[ Cancel

|

[

Apply

To display the Stylesheets Tab:

Stylesheets | =8

Ca & G| " =3 9

Skylesheet: | defaulk [il

[ Slide

[ Balloon

[ Mote

[ Text Box

[ Button

[ Correct Message

[ Incomplete Message
[ Incorrect Message

[ Click Area

[ Question Text

[ Question Choice Text
[ Question Row Text
[ Question Colurnn Text

[ Question Component Style

Select View from the Menu bar.
Select Stylesheets from the list.
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ViewletBuilder6.1 Enterprise starts you off with a “default” stylesheet, which can be
modified based on your needs. Each stylesheet contains 14 objects whose properties
can be standardized for use in your current or new projects. These 14 stylesheet

elements include:

= Slide

Background Calor, ..
#FFFFFF

Slide: Used to set slide background color.

= Balloon: Used to set balloon message style, background color and text

properties.

= Balloon

Message Style
ClassicMessageStyle. qums
Background Calor, ..
#FFFFCC

Texk Properties, ..

Cialog 12pt

= Note: Used to set note message style, background color and text properties.

- Mote

L

[Fe)

Message Style
ClassicMessagestyle, gvms
Background Color, .,
#FFFFCC

Texk Properties. ..

Dialog 12pk

= Text Box: Used to set text properties (font, size, style, alignment, color) for text

box.

= Text Box

[Fe)

Text Properties...
Dialog 16pk

= Button: Used to set button style from a library of button images.

= Button

oE

el

Butkon Skyle
Classic Button Style
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= Correct Message: Used to set correct message type, background color and text
properties (font, size, style, alignment, color).

oy

=
[

- Correct Message

Message Type...

Rectangle with Square Corners - ClassicMessagestyle, gvms
Background Colar, ..

H*1eEA4E

Text Properties,..

Dialog 12pk

= Incomplete Message: Used to set incomplete message type, background color
and text properties (font, size, style, alignment, color).

o

[

- Incomplete Message

Message Type...

Rectangle with Square Corners - ClassicMessagestyle, gvms
Background Calar...

#D9EALG

Text Properties...

Dialog 12pk

» |ncorrect Message: Used to set incorrect message type, background color and
text properties (font, size, style, alignment, color).

[

 Incorrect Message

Message Tvpe...

Rectangle with Sguare Corners - ClassicMessagestyle. gwms
Background Calor, ..

#EA1GSC

Texk Properties, ..

Cialog 12pt

= Click Area:
action.

Used to set Click Zone attributes, including enabling double click

s Click &rea

Modify Click Area...
Mormal: #000000 0% border #000000 Op:x

Follover: #000000 0%: border #000000 Op:
Selected: #000000 0% border #000000 Opx
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= Question Text: Used to set question text message type, background color and
text properties (font, size, style, alignment, color).

- Question Text

Message Type...
Y= Text Box - ClassicMessagestyle.qvms

Background Color, .,
#FFFFFF

Texk Properties...
@I Dialog 24pk bold

= Question Choice Text: Used to set question choice text message type,
background color and text properties (font, size, style, alignment, color).

= Question Choice Text

Message Type...
¥ Text Box - ClassicMessagestyle, gvms

Background Color, ..
#FFFFFF
Text Properties, ..
I&I Dialog 16pk

» Question Row Text: Used to set question row text message type, background
color and text properties (font, size, style, alignment, color).

“w Question Row Text

Message Type...
¥ Text Box - ClassicMessagestyle, gvms

Background Color, ..
#FFFFFF

Text Properties. ..
IFE| Diniog 160t

= Question Column Text: Used to set question column text message type,
background color and text properties (font, size, style, alignment, color).

w Question Column Text
Message Type...

Y= Text Box - ClassicMessagestyle. qvms
Background Color, ..

#FFFFFF

Texk Properties. ..
Iﬁl Dialog 16pk
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= Question Component Style: Used to set question slide “input” component
styles for text fields, radio buttons, check boxes, comboboxes, and ratings from a
library of component images.

= Question Component Style
Text Field Style
Classic Text Field Skyle

Radio Butkon Skyle
Classic Fadio Butkan Style

~ Check Box Style
—  Classic Check Box Skyle
ComboBox Skyle
Tel7]
=l Classic ComboBox Skyle
irir  Rating Skyle
Wi Classic Rating Style

teHt

£
(@)
-

The Stylesheets Tab contains a “tab” at the top of its window area with the title of
“Stylesheets” indicating what tab it is. A toolbar displays below the tab’s title with buttons
applicable to tools available in this tab.

Create your own custom stylesheets to standardize up to 14 different objects within new
and existing Viewlet projects.

To create a new stylesheet:

= Select the Stylesheets Tab to make it the active tab.

= Click the New Stylesheet L& button on the tab’s toolbar.

» The Stylesheet window displays.

=,

Stylesheet

Mame: | Support Tukorials

[ ] Password Protect

[ Ok l [ Cancel

o Enter a title for the new stylesheet in the Name field.

0 Select the Password Protect option and enter a password in the field
provided.

» Click OK. The new stylesheet is added to the list of stylesheets.
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To select a stylesheet from the list:

Select the Stylesheet Tab to make it the active tab.

Make a selection from the Stylesheet drop-down list.

Skylesheet: | Support Tutorials
default
Support Tukarials

To modify a stylesheet’s properties:

Select the Stylesheet Tab to make it the active tab.

Make a selection from the Stylesheet list.

Click the Modify Stylesheet L button on the tab’s toolbar.

The Stylesheet window displays. Make edits as needed and click OK to save the
changes to the stylesheet’s properties.

To modify any of the 14 elements (objects) in a stylesheet:

Select the Stylesheet Tab to make it the active tab.

Select the desired stylesheet from the list.

Click the arrow b button to the left of the object you want to modify.

The arrow changes position and points down “¥ to reveal the object’s
“properties’ that area available for editing.

Click on the icon next to each of the “properties” listed below the selected
stylesheet’s object and follow the instructions in the window(s) that display to edit
and save the changes.
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To apply a stylesheet to the entire project:

= Select the desired stylesheet in the Stylesheet Tab.

= Click the Apply Stylesheet to Project ® button on the tab’s toolbar.

= The Apply Stylesheet to Project window displays. Read the information and click
Yes to apply the stylesheet to the project.

P o

Apply Stylesheet to Project

| Are you sure you wank to apply this stylesheet to your projects
‘“‘-‘.'r', The Formatting in all slides will be updated.

Eoook { [ Cancel

To apply a stylesheet’s element to an object:
= Select the desired stylesheet in the Stylesheet Tab.
= Select the object to which you want to apply a stylesheet element.

= Select the stylesheet object you want to use to apply to a selected slide object by
clicking the icon to the left of the element on the stylesheet.

&
= Click the Apply Stylesheet to Selection * button. The selected object will
immediately be updated, based on the stylesheet’s settings.
To update a stylesheet’s element based on a selection:
= Select the desired stylesheet in the Stylesheet Tab.
= Select the desired object you want to use when updating the stylesheet element.

» The applicable object on the stylesheet is automatically selected. Click the

. . - .
Update Stylesheet with Selection = * button and the stylesheet is
automatically updated.
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To remove a stylesheet from the list:

= Select the desired stylesheet in the Stylesheet Tab.

= Click the Delete Stylesheet “* button from the tab’s toolbar.

= A Delete Stylesheet window displays. Read the information in the window and
click Yes to confirm the deletion.

Delete Stylesheet
\:%{/I Are you sure you wank bo delete this skylesheet?
o fes [ Mo ]

For more information on working with other Tab View options (such as expanding,
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on
Workspace Features and Tab Views.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.
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Output Tab

The Output Tab displays, by default, below the Slide Edit area at the bottom of the
program window. This tab contains a record of information that can help Qarbon find and
correct ViewletBuilder6.1 Enterprise programming errors. The information that is
recorded in the Output Tab is determined by preferences set up for ViewletBuilder6.1

Enterprise.

Oubpuk

.| Logging creates a record of information that can help Qarbon find
%4 and correct programming errors, Sek the options for logging ko the
output tab window,

Repark: | Display &l Messages w

[ Clear Output Window ]

To set preferences for the report information recorded in the Output Tab:
= Select Edit > Preferences from the Menu bar.
» The Preferences window displays. Select the Logging tab.

= |n the Output area, from the Reports list, select:

Report: |Display &l Messages
Display E ol

@ !spa'f rrars Cnly .
Display Erraors and Infarmakion

Display &ll Messages

o Display Errors Only
o Display Errors and Information
o Display All Messages

-r‘ ViewletBuilder6.1 Enterprise creates an external log file with the information in the Output
2 T® | Tab that can be sent to Qarbon when program issues arise.
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To display the Output Tab:
= Select View from the Menu bar.

= Select Output from the list.

Output =8

DEBUG | AWT-EventQueue-0 - Q3electionManager {16 Feb 2009 05:40:33,062) | Selected: button: 11 |»
DEBUIG | AWT-EventQueue-0 - QSelectionManager {16 Feb 2009 05:40:35,796) | Selected: slide: 9
DEBLUG | AWT-EventQueue-0 - QSelectionManager (16 Feb 2009 03:40:44,312) | Selected: slide: O
DEBUG | AWT-EventQueue-0 - Q3electionManager (16 Feb 2009 03:40:46,000) | Selected: slide: 5
DEBUG | AWT-EventQueuse-0 - Q3electionManager (16 Feb 2009 03:42:32,046) | Selecked: button; 12 W

To locate the log file containing the information also displayed in the Output Tab:
= Select Edit > Preferences from the Menu bar.
= The Preferences window displays. Select the Logging tab.

» |nthe Log File area, the path to where the log file is saved displays in the File

field. If you can’t see the entire path to the file, click the Browse “' button next
to the File field.

Log File

Set the options For outputting log records to a file.

Enabled

Size Limik: 100 /2 KB Clear Log File

File: -bon YiewletBuilderd EnterpriseYiewletBuilders, log
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» The Select Log File window displays, showing the log file, which end with the
extension .log. To view the full path to where the file is located, click the down
arrow next to the Look In list to see the entire path to the folder containing this
log file.

' Select Log File

Lookin: |5 ViewletBuilders Enterprise T
age Local Disk (C:) Rad
‘A:!ﬁ | Documents and Sekkings
My Recert () Al Users
Diocumienks I Application Data
[ Qarbon
@ |} MiewletBuilders Enkerprise
|5) Shared Documnents
Desktop u'_J My Documents ™

¥ | The location of the log file containing the report information also displayed in the Output
B T® | Tab is determined when setting up ViewletBuilder6.1 Enterprise program preferences.

To clear the report information displayed in the Output Tab:
= Select Edit > Preferences from the Menu bar.

= The Preferences window displays. Select the Logging tab.

[ Clear Oubput Windaw button.

» |n the Output area, click the Clear Output Window

For more information on working with other Tab View options (such as expanding,
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on
Workspace Features and Tab Views.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.
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The Timeline Tab displays, by default, below the Slide Edit area at the bottom of the

program window. The Timeline allows you to manage the start and duration times of all
elements on each slide in your project. In addition to working with objects directly on a
slide, the Timeline provides more enhancement options for your project as you hide,
view, modify, group, sort and lock / unlock layers in the Timeline. But, that's not all.
Using the Timeline’s playhead tool you can scrub the Timeline to view your project’s
animations. You can also preview your project as it plays back, noting where actions
occur along the Timeline, allowing you to “tweak” any part of the project exactly where it
needs it.

This chapter highlights the main features while working in the Timeline Tab. For more
information on how ViewletBuilder6.1 Enterprise handles other timing aspects of a

project’s elements, please see the Object Timing chapter.

To display the Timeline Tab:
=  Select View from the Menu bar.
= Select Timeline from the list.

| Thumbnails E ||3_'||]]|

RS

o 'u'|~r

S
| |6 ]| &7 &7 ©

of

©
These are the huilding
hlacks far success...

Timeline Tak

[v

Timeline

=8

1of6 00:00,0 ko 00:06,2 of 00:11.2

0006.2 » O 100% =

Al Slides

(T ]

K <> B |-

Slide 1

5 Slide 1

3s

I+ Cursar Path

&l

. Balloon: Click a block t...

T}

[ #| Mate: These are the b...

&

)| @ @ &)

‘a Image: success, gif

&l
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The Timeline Tab contains the following elements:

Layers

The left side of the Timeline displays all the objects on the slide. Each object exists in a
layer. These layers are “stacked” with “higher object layers” overlapping objects in lower
layers. You can hide / unhide layers without deleting them from the project. You can lock
layers to prevent them from being editing. You can also change the starting / ending
points of objects as they display along the Timeline as well as their entire duration. You
can work on single or multiple layers and group layers into one as needed.

To expand / collapse layers:
= Select the Timeline Tab.

= On the left side of the Timeline, click the right arrow P next to the slide title.

* The arrow now points down “¥ indicating the layers are now expanded.
= To collapse the layers, click the down arrow again.

To select a single layer:
= Select the Timeline Tab.
= Expand the list of layers, if needed.
= Click on the desired layer to select it.

To select multiple layers:
= For adjacent layers:
0 Click on the first layer to highlight it.
0 Hold down the Shift key.
o0 Click on the last layer in the series of adjacent layers. This will select the
first and last layers as well as all the layers in between them.

5 Slide 1
Cursar Path Huld down the Shift key to
- Rectangle select adjacent lavers. I
.| Rectangle |
| Rectangle oF ' |
Balloon: Click a block to learn mare. & |
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*» For non-adjacent layers:
o Click on a layer to highlight it.
o Hold down the Ctrl key while clicking on other layers to select them.

7 Slide 1

Cursor Path

_ Rectangle Hold q::wn the Ct_rl key to select

@ Rectangle multiple non-adjacent layers. -:

. Rectangle A |
Balloon: Click a bloc arn more o L

| # Maoke: These are the Building blocks For suc. & |

e Image: success,gif oF | ]

# | Select multiple layers to temporarily group them to speed up various authoring tasks that
T® | can be applied to all of the selected layers at the same time.

i |

ek [Femtiure Arrange Layers via Drag and Drop Action (New in ViewletBuilder6.1 Enterprise)
The ability to arrange layers by dragging them up or down in the stack is a new feature
in ViewletBuilder6.1 Enterprise. In the previous versions, the only way to rearrange
layers while working directly in the Timeline was via a right click action.
To drag (rearrange) a single layer up or down the stack in the Timeline:

= Single click on the layer to select it.

= Once the layer is highlighted, single click it again and hold down the left mouse
button.

= While holding down the left mouse button, drag the layer up or down in the stack.
While dragging the layer, its icon will display.

= Let go of the left mouse button to drop it into its new location in the stack.
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Q n While dragging a single layer, its icon is displayed until you drop the layer into its new
2T | |ocation in the stack.

To drag (rearrange) multiple layers up or down the stack in the Timeline:

= Click on the desired layers while using the Shift or the Ctrl key to select multiple
adjacent or nonadjacent layers to highlight them.

»= Once the layers are highlighted, single click on them again and hold down the left
mouse button.

= While holding down the left mouse button, drag the multiple layers up or down in
the stack. While dragging the layers, their icons will display.

= Let go of the left mouse button to drop the multiple layers into their new location
in the stack.

w7 Slide 1
Cursor Path
|# Moke: These are the building blocks For suc...
=/ Rectangle
.| Rectangle &)
=/ Rectangle =
Balloon: Click a block to learn mare.

Ll

Ll

T T T T
5

nj

v Image; success,gif

& While dragging multiple layers, their icons will displayed “stacked” until you drop the
TR layers into their new location in the stack.

To hide / unhide a layer:

* To hide a layer, click the Visible ® | putton to hide the layer. This changes the
“open eye” to a “closed eye” indicating the layer is hidden.

= To unhide a layer, click the Hidden | = | button to display the layer. This changes
the “closed eye” to an “open eye” indicating the layer is visible.
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To lock / unlock a layer:

To lock a layer, click the Unlocked

inj

button to lock the layer. This changes the

“open padlock” to a “closed padlock” indicating the layer is locked.

To unlock a layer, click the Locked

Il

button to unlock the layer. This changes

the “closed padlock” to an “open padlock” indicating the layer is unlocked.

(=Y
TR

o

To prevent a layer from being edited, click the open padlock to close it to lock the layer.

To move an object to a new frame in the Timeline while working in its layer:

Point your cursor over the object’s rectangle (which indicates its position and

duration along the frame in the Timeline).

Timeline.

Hold down your left mouse button to select the object’s rectangle and drag.

Let go of the left mouse button to drop the object into its new location in the

Slide 1

To increase or decrease an object’s duration in the Timeline while working in its layer:

When the cursor changes to a double arrow

Point your cursor over the left or right edge of the object’s rectangle.

+—r

hold down the left mouse

button and drag to change the size (duration) of the rectangle.

Slide 1

Once the rectangle indicates the desired duration (by its new size) on the

Timeline, let go of the left mouse button.
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» |f a Timing Rule window displays, read the information and click OK to complete
the operation.

s 1

Timing Rule Change

This element has the "Manual Timing" timing rule in place.
Whould you like to change it ko manual timing?

[ ] Dan't shawe me this message again.

EoooK | [ Cancel

To delete a layer:
= Click on the layer to select it.
= Press the Delete key on the keyboard, or right click and select Delete from the
shortcut menu.

f' If you accidentally delete a layer, try pressing “Ctrl + Z” to undo the action (if it was your
2 T® | |ast action) to restore the layer.

Timing Links

Timing Links are links that connect two or more objects in the Timeline. The benefit of
this feature is that as you edit an object’s timing in the Timeline, the linked objects
update accordingly.

Timing Links are automatically added to notes, balloons and cursors as they are inserted
in the Timeline if the Maintain Timing Links option is selected (Project Properties
window > Timing section).

@ i ' S
Mote #1 < Balloon #1 3\
‘ Balloon #2 r

Timeline

206 00:06.5 ko 00: 10,0 of 00:14.0 ooy Timing Links are automatically connected to K < e H I‘t
message objects as they are added to the slide. |

7 Slide 2
. Balloon: Balloon #2
. Balloon: Balloon #1
%] Note: Moke #1

& @ | &
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For best practice purposes, by default, when notes are added to a slide, they display first
in the Timeline. When balloons are added to a slide, they display after all of the notes.
Cursors display after balloons. The reason for this is because it is assumed that a note
introduces an action, a balloon points out the action, while cursor animation is an action.
Of course, the position of any object can be change in the Timeline at any time.

To automatically update Timing Links:
= Open a Viewlet project.
= Select Project > Project Properties from the Menu bar.
= The Project Properties window displays. Select Timing from the list (on the left
side of the window).
» |nthe Timing Links area, select the Maintain Timing Links option.

Timing Links
Ensure timing links are added between elements as they are added to the slide. This will
mainkain proper timing on the slide as it is edited.

Maintain Timing Links

The default order that message objects are displayed in the Timeline are “Notes” first
(Note #1, Note #2, etc.) followed by “Balloons” second (Balloon #1, Balloon #2) no matter
when the new balloon or note is inserted o a slide.

To add a Timing Link to two objects in the Timeline:
= Select the first object in the Timeline.
*= Hold down the Ctrl key and click to select the second object in the Timeline.

The order in which the objects are selected is the order in which the Timing Links will be
added to the objects.

g8
= Click the Add Timing Links ‘== button on the Timeline’s toolbar.

= The Timing Links window displays. Select a Link Type from the list:

Timing Links
Link Type:
| I = L | S
L’_lJ_l |_|_+I I'h_l |_|4'I

End ko Startk | Start ko End Skark to Stark End to End

o CK |[ Cancel H Apply

o0 End to Start: Links end of first object to front of second object.
o Start to End: Links front of first object to end of second object.
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0 Start to Start: Links front of first object to front of second object.
o End to End: Links end of first object to end of second object.

To remove a Timing Link:
= Select an object on the Timeline.

= Hold down the Ctrl key to when clicking to select the second object that shares a
Timing Link with the first selected object.

&
= Click the Remove Timing Links == button.

To remove all Timing Links on a slide at the same time:
= Select all of the objects on the slide.

8
= Click the Remove Timing Links == button.

There may be times when you will be prompted to change an object to “Manual Timing” to
allow a Timing Link to be added. And, there are some objects, such as an object on the
main Timeline and an object inside a Question Slide or Interactive Zone, which cannot be
connected by Timing Links.

Frames

The Timeline Tab contains a “guide bar” known as a Frames Reference Guide. Along
this guide bar, there are small “sections” known as frames Each frame is divided by
tickmarks into 1/10 of second intervals. The main sections of the Timeline are divided
into 1 second intervals. Use this guide bar to position objects in the Timeline to
determine when each will display and for how long when the project is played back.

T :;d;

Single Frame Tickmark
Frames > g Ef e 5E M Dviding
& | | Reference 21 Frames [
Guide | | h |

=TT ; I T 1

&0

The Background Layer contains special “key frames” where a background frame is
“painted” over the entire slide. This, in combination with the Background Layer’s “non-key
frames” (which paint over a smaller, specific area on top of the key frame), can produce
some dynamic and “attention-getting” effects. If you are interested in learning more about
this topic, “key frames” are covered in more detail in the “Background Frames” chapter.
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To select a frame on the Timeline:
= Click on the desired frame to select it. All objects that display in that frame in the
Timeline will display on the slide.

There is a phrase called “scrubbing the Timeline” that translates to dragging the
playhead along the frames in the Timeline to preview actions that occur in the project.
This is a useful “trick” to know if you want to manually preview specific sections of the
project in the Timeline for intricate “tweaking”.

To “scrub the Timeline” along specific frames within a single slide:

= Ifthe Current Slide Current Siee | pytton is displayed on the Timeline Tab's

all slides

toolbar, click it so that it changes to All Slides . This will change the

Timeline view from “All Slides” to “Current Slide”.
= Click on the frame where you want to begin.

= A playhead displays on the selected frame with a line that intersects the
Timeline below the playhead. Hold down your left mouse button and drag the
playhead along the frames and watch the actions as you move it along the
Timeline.

= Once you reach the end of the frames contained for the current slide, you will no
longer be able to move the playhead. If you want to “jump” to the next slide, click
on a frame in the next slide to display the playhead and repeat these steps to
scrub the Timeline again.
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To “scrub the Timeline” along specific frames across multiple frames:

If the All Slides = #5955 hutton is displayed on the Timeline Tab’s toolbar,

Current Slide

click it so that it changes to Current Slide . This will change the

Timeline view from “Current Slide” to “All Slides”.
Click on the frame where you want to begin.

A playhead displays on the selected frame with a line that intersects the
Timeline below the playhead. Hold down your left mouse button and drag the
playhead along the frames and watch the actions as you move it along the
Timeline.

Miscellaneous Timeline Features and Tools

The Timeline Tab contains some status information and tools right above the Frames
Reference Guide, which are useful when working in the Timeline. These include:

Slide Numbers: Indicates current slide and number of slides in the project.

1af &

Clock Feature: Indicates the duration of current slide in relation to overall project
duration.

00:00,0 ko 00:06,5 of 00:14,0

Slide Duration of Current Slide: Indicates the full playtime for the current slide
displayed in the Timeline, which can be increased / decreased by clicking the
up / down arrows.

00:06.5 =

Zoom: Signifies the current zoom of the Timeline. Use the up / down arrows to
increase / decrease the zoom level of the Timeline.

100%: =

Views: There are two different views that can be used while working in the
Timeline: All Slides or Current Slide. When the All Slides button displays, the
Timeline view is “current slide”. When the Current Slide button displays, the
view is “all slides”. Click this button to toggle between these views.

all slides Current Slide
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= Player Buttons: The “VCR style” buttons are used to navigate to the first slide,
previous slide, next slide and last slide of the project.

K <d B> B

= Preview Menu: Use this list to select from one of four project preview options.

=) -

[é] Preview Current Slide

LE‘=$]T Presigw From Current Slide  Crrl+-Space

I@] Presiew all Slides

N . .
L'?I:I | Preview in Brawser
ey

= Slide Titles: Along the top of the Frames Reference Guide are boxes containin
the titles for each of the slides in the project. By default, the titles are the slide
number. By dragging the edge of the “title box” you can increase / decrease the
duration of the slide in the Timeline.

(BLe = |

g

Slide 1 Slide 2 Slide 3

Slide 4

For more information on working with other Tab View options (such as expanding,
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on
Workspace Features and Tab Views.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@qgarbon.com.
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Object Timing

Understanding how ViewletBuilder6.1 Enterprise handles the “timing aspects” of objects
is essential to being able to effectively work in the Timeline or while setting the timing of
objects through the use of dialog windows. There are two important “timing topics” that
each Viewlet Author should review before creating any project: Timing Commands and
Timing Rules.

Timing Commands

Timing commands can be applied to a single or multiple objects on a slide. An object’s
timing will determine when it will display on a slide (or on the Timeline), how long it will
remain displayed on a slide (or on the Timeline) and, if multiple objects display on the
same slide, what timing command elements they may have in common.

An object’s timing can be adjusted in two places, in its Properties window and while
working directly in the Timeline.

To adjust a message object’s timing in the Timeline:

= Point your cursor over the left or right edge of the object’s rectangle in the

Timeline.
= When the cursor changes to a double arrow “ | hold down the left mouse
button and drag to change the size (duration) of the rectangle.
Slide 1
1= 23 ER 45
T T T T T T ' | T T T T T T T T T S T T T T ' |
(= ;
|

= Once the rectangle indicates the desired duration (by its new size) on the
Timeline, let go of the left mouse button.

= |If a Timing Rule window displays, read the information and click OK to complete
the operation.

=,

Timing Rule Change

This element has the "Manual Timing" timing rule in place.
Would you like to change it ko manual timing?

[ ] Dan't show me this message again,

Eoook | [ Cancel
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To change an object’s timing using the object’s Properties window:

= Click the desired object (from either the slide or in the Timeline) to select it.

= Click the object’s Properties |D___| button from the Context Sensitive Toolbar.

The object’s Properties window displays. In the Timing area, there are options for

setting the object’s timing (there’s an additional selection for message objects).
These include:

0 Reading Speed: Used (by default) for notes, balloons, and text boxes to
display the message object from its set Start Time until the automatically
calculated reading speed is reached.

Tirning

|Reading Speed [V]

Skart: Tirme 0.5 {:} seconds

To set the default “Reading Speed” for ViewletBuilder6.1 Enterprise, select “Project >
Project Properties” from the Menu bar. In the “Project Properties” window that displays,
select “Timing” from the list (left side of window). In the “Reading Speed” area, enter a
number for the “words per minute” reading speed. This value will be used when the

program automatically calculates a message object’s reading speed based on the amount
of text it contains.

0 Manual Timing: Used to manually set the Start Time and Duration (in
seconds) for the object.

Tirning
|Manual Tirning [V]
Start Time D.D{ﬂ seconds
Dur ation 2.2{:} seconds
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0 Until End of Slide: Used to display the object from its set Start Time (in
seconds) until the end of the slide’s “play” time.

Tirnirg
Until End of Slide v
Start Time 0.51% seconds

= Select a Timing option for the object from the list.

= Enter a number for the Start Time (in seconds). This will be the amount of time
the object will be delayed before displaying on the slide.

= For Manual Timing, enter a number for the Duration. This is the amount of time
the object will display.

= Click OK to apply the timing settings and to close the object’s Properties window.

To synchronize timing for multiple objects on a slide:

= Select the objects you want to synchronize the time of by clicking on each one
while simultaneously holding down the Ctrl key.

&3’ | Be careful when selecting multiple objects for timing synchronization. The first object
2 T® | selected will be used as the “key object” from which the other times are calculated.

» The Synchronization Context Sensitive Toolbar displays. Click one of the buttons
to synchronize the selected objects timing:

’—: Same Start Time: Set the same start time for selected objects.
’:— Same End Time: Sets the same end time for selected objects.

E Same Start and End Time: Sets the same start and end time for all
objects based on the key object.

C—+
’; Display Until Last End Time: Sets the end time for all objects to object’s
whose end time is the last on the slide (of those selected).

’__: Sequence Times: Sets the objects to display sequentially based on the
selection order.
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To adjust timing for a “Display Object” action:

= Select the desired object (note, balloon, text box, shape, image, etc.).

L=y

= Click the Events “  button on the Context Sensitive Toolbar.

= The object’s Events widow displays. Select one of the three tabs:

on Click. | on Rollover | On Rollout

0 On Click: Set actions to occur when user clicks the object.
0 On Rollover: Set actions to occur when user rolls mouse over object.
0 On Rollout: Set actions to occur when user rolls mouse off object.

Click the Add d']j button.

» The Action window displays. Select Display Object from the Action Type list.
= Select an object from the Select an object on the slide to display list.

* |n the Duration area, select a timing command.

Click OK to close the Action window.

Click OK to close the object’'s Events window.

Timing Rules

Each object has a Timing Rule associated with it. Timing Rules automatically control
how the timing for that object associated with it is calculated. Timing Rules differ from
“timing synchronization commands” in that synchronization commands make a one-time
adjustment where as Timing Rules are applied globally.

To understand Timing Rules better, let's take a look at an example. A simple timing rule
is “Reading Speed”, which insures that the duration of a message object is calculated
from the number of words in a message object and the reading speed set in the Project
Properties window. This rule is automatically and globally applied to all message objects,
so that each note, balloon and text box displays only as long as calculated reading
speed allows.

To help standardize object timing, there are several Timing Rules available (each
described in the previous “Timing Commands” section of this chapter):
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= Manual: An object’s timing is calculated manually, meaning the user has full
control over the start time and duration.

= Reading Speed: Applies to message objects (notes, balloons, text boxes), the
duration is calculated based on the reading speed set in the Project Properties
window and the number of words in the message object. The start time for the
message object is adjustable without affecting this rule.

= Until End of Slide: An object displays from a user-defined start time until the
end of the slide. The start time is adjustable without affecting this rule.

= Display Object Action: Used for objects displayed due to an event which
triggers the “Display Object” action. You can use any “available” Timing Rule for
the object that is to be displayed.

Each time you attempt to change an object’s timing, a “Timing Rule Change” window will

display if you are “breaking the rules” for the Timing Rule currently associated with the
object. Read the information in the window carefully before proceeding.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.
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Slide Notes Tab

The Slide Notes tab displays, by default, below the Slide Edit area. In this tab, you can
add presenter notes, which can be printed out for you and your audience. The Slide
Notes tab can also be used as a collaboration tool by adding editing notes (not part of
the actual slide) when working with a team of authors on the same project. These notes
can be displayed or hidden inside ViewletBuilder6.1 Enterprise (and printed) as needed.

S & 7

e
[I] i1

=

TITar
—

o [

g -

i

g

Slide Notes =8|~

—Find a quote from a successful entrepreneur Eﬂ E
—idd company logo to bottom right of slide

—Change =slide background color [update in stylesheet)] to match company branding [Z

£

[

Did you know that you can use Slide Notes in combination with ViewletBuilder6.1
Enterprise’s JavaScript function to add a computer simulated voice-over to your project
on a slide-per-slide basis? For more information, contact support@garbon.com for more
information on this advanced Viewlet authoring trick.

To display the Slide Notes Tab:
= Select View from the Menu bar.
= Select Slide Notes from the list.

To add text in the Slide Notes Tab:
= Select the desired slide so that it displays in the Slide Edit area.
= Select the Slide Notes Tab to make it the active tab.
» Click inside the Slide Notes field and type text as needed.
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To print Slide Notes with your slides:
= Select File > Page Layout from the Menu bar.

» The Page Layout window displays. In the Options area, select the Slide Notes
option.

Options

[] Slide Title [] Cursor Path
[ ] Balloons [ ] Mokes
glide Mates

= Click OK to save this option. Each time you print slides, the Slide Notes will be
added below the image of each slide.

For more information on working with other Tab View options (such as expanding,
minimizing, maximizing, moving, and closing the tab, etc.), see the chapter on
Workspace Features and Tab Views.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@qgarbon.com.
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Cursor Management

Cursor animation is a fundamental component of most Viewlet projects. Understanding
the basics of how cursor movement is captured, the different parts that make up the
actual slide-to-slide cursor animation and how to edit cursor movement is an important
Viewlet authoring skill, which is essential for creating attention getting, dynamic Viewlets.

MNedfi Ffesie | The Mouse Tab (New in ViewletBuilder6.1 Enterprise)

There is a new Mouse tab in the Capture Options window available for Viewlet authors
when setting up or modifying Capture Profile options for new screenshot projects or
when inserting new screenshots into existing projects. In the Mouse tab, you have
options for capturing cursor movement during a screenshot session and also the option
to capture screenshots on mouse click action.

The "Mouse" tab is a new feature in

On Screen Capture - Add to Slide | 1o = a0t Owtions window, which
allowes yvou to set cursar simulation
and mouse clicks capture options
[#] Curved Cursor Path befare a screenshot session.

(%) Cursor Simulation

() Don't Add Cursor Simulation

Mouse Click Capture

This Feature allows you to use the mouse to capture screenshots,
Everykime the mouse is clicked, a screenshat is taken, You can also
continue to use the hotkey as usual,

[] Mause Clicks Capture Screenshots

To access the Mouse tab for new screenshot projects:
» Select File > New from the Menu bar.
= The Create New Project window displays. Select Screenshot Project from the
new project type list.
= Select a profile from the list of Capture Profiles to use for the screenshot
session.

= Click the Modify / button.
= The Capture Options window displays. Select the Mouse tab.

; = | You can access the “Mouse” tab to set up cursor options prior to creating a new
screenshot project or right before inserting new screenshots into an existing project by
! adding a new “Capture Profile” or by selecting an existing “Capture Profile” and clicking
“Modify” to display the “Capture Options” window where the “Mouse” tab is located.
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To capture cursor movement during a screenshot recording session:

= |n the Capture Options window (accessed when adding or modifying Capture
Profiles), select the Mouse tab.

= Inthe On Screen Capture — Add to Slide area:

0 Select the Cursor Simulation option.

0n Screen Capture - Add ko Slide

Cursor Simulation
®
Curved Cursar Path

() Don't Add Cursor Simulation

o If you want to allow the cursor to follow a curved path (for added visual
interest during playback), select the Curved Cursor Path option.

= Click OK to close the Capture Options window.

To remove cursor movement during a screenshot session:

= |n the Capture Options window (accessed when adding or modifying Capture
Profiles), select the Mouse tab.

* |nthe On Screen Capture — Add to Slide area, select the Don’t Add Cursor
Simulation option.

on Screen Capture - Add ko Slide

() Cursor Simulation

(%) Don't Add Cursor Simulation

= Click OK to close the Capture Options window.

=3’ | If you are using the “Manual Capture” mode for your screenshot session and do NOT want
2, T® | toinclude cursors, select the default “Simple” Capture Profile for your recording session.
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To enable “mouse click” capture during a screenshot session:

= |n the Capture Options window (accessed when adding or modifying Capture
Profiles), select the Mouse tab.

»= |n the Mouse Click Capture area to:

o0 Enable mouse click capture of screenshots during a capture session,
select the Mouse Clicks Capture Screenshots.

Maouse Click Capture

This Feature allows you to use the mouse to capture screenshoks,
Everytime the mouse is clicked, a screenshat is taken, You can also
continue to use the hotkey as usual,

Mouse Clicks Capbure Screenshots

Include Right Mouse Buttan

0 Select the Include Right Mouse Button to enable additional right click
mouse click of screenshots capability during the recording session.

= Click OK to close the Capture Options window.

Cursor Indicators (Red, Green, Blue)

When you look at a slide that contains cursor movement, you will see cursors indicated
by (at a minimum) a “green” circle and a “red” circle. These two cursor circle indicators
are connected by a “dotted” line. And, there may be times when you see a “blue” circle
along the dotted line connected the green and red circles. Let's take a look at what these
all mean:

[% Green Circle: A green circle around a cursor signifies the starting
position of the cursor on a cursor path.

Dg Red Circle: A red circle signifies the ending position of a cursor on a
cursor path.

% Blue Circle: A blue circle signifies the point on the cursor path will the
cursor will change shape before it reaches its destination.
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Cursor Path

The “dotted line” between the green circle and the red circle is known as the “cursor
path”. This is the path the cursor travels during its animation (while moving from one
slide to the next slide). A basic path starts at the green circle and ends at the red circle.
A more complicated path includes points along the cursor path where the cursor may
change direction or cursor style. Elements of the cursor path may be edited.

Cured Path - All Slides

Straight Path - All Slides Add Paoint to
3 Cursor Fath

Cursor Context Sensitive Toolbar
@ 2B -i op | @

‘9 i@ t% oy b S° 47| O IS

Cursor Style Shap to Curved Add Click to
Mext Path Cursor Path
=hap to
Previous Straight Lock Paint on
Path Cursor Path

In some cases, there may be “points” along the cursor path. These points may be a
“blue circle” cursor indicator where the cursor changes shape before it reaches the end
of the cursor path. Or, the cursor path may contain “red points” that indicate a change in
direction along the cursor path. You can edit these points by dragging them along the
cursor path. Or, to change the direction the path takes, simply “pull” the point to change
the cursor path’s direction.

To move a green circle (starting cursor position) on the cursor path:
= Click on the green circle.
= While holding down your left mouse button, drag the green circle to where you
want it to reside on the slide.
= Let go of the left mouse button to drop it into place.

To move a red circle (ending cursor position) on the cursor path:
= Click on the red circle.
= While holding down the left mouse button, drag the red circle to where you want
it to reside on the slide.
= Let go of the left mouse button to drop it into place.
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To move a blue circle (where cursor changes shape on cursor path) on the cursor path:

= Click on the blue circle.

= While holding down the left mouse button, drag the blue circle to where you want

the cursor to change its shape on the cursor path.
= Let go of the left mouse button to drop it into place.

To add a “red point” to the cursor path:

= Click the green circle to select it.
op
@
= Click the Add Point to Cursor Path button on the Context Sensitive
Toolbar. A “red point” will display on the cursor path, ready for editing.

To move a “red point” along the cursor path:
= Click on the red point.
= Hold down the left mouse button and drag it along the cursor path.
= Let go of the left mouse button to drop it into place.

To change a single cursor path from straight to curved or curved to straight:

= Click the green circle to select it.

» To change the cursor path to straight, click the Move the cursor in a straight

B
path o button on the Context Sensitive Toolbar.

= To change the cursor path to curved, click the Move the cursor in a curved

48
path ©  putton on the Context Sensitive Toolbar.

To globally change all cursor paths within the project to straight or curved:

= Click the green circle to select it.

= To change all cursor paths in the project to straight, click the Straight Path — All

)
Slides button on the Context Sensitive Toolbar.

= To change all cursor paths in the project to curved, click the Curved Path — All

48
Slides © button on the Context Sensitive Toolbar.

VB6.1 Enterprise User Manual Page 132 March 2009



TEVVILE FERIUTTHLE] & RO S E KLLEA T L e (\( User Maouall

To remove a “red point” or “blue circle” from the cursor path:
= Click on the “red point” or the “blue circle” to select it.
» Press the Delete key on the keyboard to delete it. Or, right click and select
Delete from the shortcut menu.

Cursor Style

ViewletBuilder6.1 Enterprise comes with a library of the most common cursor styles
used in Viewlet projects. Cursor styles captured during screenshot sessions are added
to the cursor style library. Once captured, cursors can be changed in a project as
desired by selecting a different style from the cursor style library.

[ 1
Cursor Style
Select a skyle for the Cursor:
[ -+ = =
L 2
Select.lcr Bound. lcr Busy. lcr
Captured, lcr Captured_2.lcr Captured_3.cr
Captured_4.lcr CrossHair . lcr CrossHair2. lor ™
| (04 | [ Cancel ] [ apply

To add cursors to a slide that does not contain a cursor:

= Click the Insert Cursor W button from the Object Toolbar. Or, from the Insert
Menu or right click shortcut menu, select Cursor. A cursor will display on the
slide, ready for editing.

To change the cursor style:

= Click on the cursor to select it.

e
= Click the Cursor Style o button from the Context Sensitive Toolbar.

» The Cursor Style window displays. Click on a style to select it.

= Click OK to apply the new cursor style.
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To add a new cursor to the cursor library, select the cursor. Then, open the “Cursor Style”
window and the selected cursor will be added to the library for future use.

To a cursor from a slide:
= Click the green circle to select the cursor.

» Press the Delete key from the keyboard and the cursor, along with the cursor
path, will be removed from the slide.

The “Insert Cursor” button on the Object Toolbar acts like a “toggle switch”. If a cursor is
displayed on the slide, click the “Insert Cursor” button to remove it. Click the button again
to insert a cursor back on the slide.

Cursor Path Layer

If a slide contains cursor animation, then along the Timeline you will see a Cursor Path
layer. This layer will always be the uppermost layer in the stack of layers and cannot be
moved down in the stack. You can edit the green circle and any red points along the
cursor path by selecting the appropriate section on this layer. And, you can use this layer
to “tweak” the duration of the cursor animation as it plays to the next slide.

Slide 1
wSdes 1,5 ,,,,,,,,, 2|s. =
I+ Cursor Path & | L /I | —
= Mite: [ | Fr
\s Background: 1 of 1 o&F |

You can move the cursor animation to any point within the slide’s Timeline; however, it is
recommended for most projects that cursor animation occur at the end of the slide.
Additionally, only ONE “Cursor Path” layer can be included on a slide at the any time.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.
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Messages

ViewletBuilder6.1 Enterprise allows you to add impact to your Viewlet projects with
Messages. These Messages come in the form of notes, balloons and text boxes. The
purpose of each Message object is ultimately determined by you, the Viewlet author, but
here some ideas for ways they are commonly used in a Viewlet:

* Note: A note is used to “introduce” a topic or action that is about to occur. It is
also used in situations when you want to make sure the viewer takes notice of
some important content such as special information, a tip or trick, or even a
“warning” of some type.

= Balloon: A balloon is used to “point out” an area of the screen or an action. For
example, a balloon may contain text that discusses different areas of the screen
while using its “pointer” to point at the area being discussed. Or, more commonly,
a balloon may point at a button or text entry field with instructions for the viewer
to “interact” with the Viewlet.

= Text Boxes: A text box is used to “seamlessly blend” text into its background,
whether it be the slide itself, a shape or an image or even other text. Text boxes
are also used as the “question” box for quiz and survey question types.

T T
L This 15 & text box. 1
O O i

Multiple Message objects may be added to the same slide. By default, however, no matter
what order you insert them on a slide, the notes are added first along the Timeline
followed by balloons.

Now that you know the three different Message types available in ViewletBuilder6.1
Enterprise, the next thing you should decide is the method you want to use when editing
the text inside your Message object.

To set the default message editing preference for ViewletBuilder6.1 Enterprise:

= Select Edit > Preferences from the Menu bar.
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The Preferences window displays. Select the General tab.

* In the Message Editing area, select an editing preference.

Click OK to close the Preferences window.

Message Editing Methods

There are two “message editing” methods available in ViewletBuilder6.1 Enterprise. You
can decide the default method to use by selecting it when setting up program
preferences.

L4
(i
(i
Il

I u B | Dialog W

LIE
|‘\ Edit text directly in the message
. object while using the Context

Sensitive Toolbar.

I'want to use the klassic Edit in Place
"message editing" method for texdt.

Message Editing

() Edit in Place

T =& Message Edibar
Lse M Edik

_ Message Editor
 E— B 7
) |Dialu:ug [VI » i & i
L] i lwantto use the NEW :
Llrl Message Editor L
= = = » I "message editing” [
1 I—J B IEI — = — i methaod for text. l
I'want to use the NEW Message Editor i_lr----f---u ------------ 1
"message editing" method for text.
‘\qh‘ Edit messane ohject text
using the Mesage Editor,
Ok, |[ Cancel H apply ]
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Edit in Place

This is the “classic” message editing method used in previous versions of
ViewletBuilder6.1 Enterprise. This method allows you to edit text directly in the note,
balloon, or text box (without opening a dialog window). It also allows you to change the
Message objects attributes using various buttons on the object’'s Context Sensitive
Toolbar (when the object is selected and not in text editing mode).

Message Editor (New in ViewletBuilder6.1 Enterprise)

A new message editing method available in ViewletBuilder6.1 Enterprise is the Message
Editor. This editor window displays when you are in text edit mode. Inside the Message
Editor window, you can use the:

fw_:' Message Editor w
= Arial V 12 V
I UBER==-=

I'want to use the NEW Message Editor "message editing”
method for text.

Ok |[ Cancel ][ Apply

* Message Type 7 button to change the object’s style and type.

= Background Color button to change the object’s fill color.

= Font list and Font Size list to change the text font type and size.

B

» Jtalic 1 , Underline u , or Bold button to change text attributes.

= Text Color IEI button to change selected text color.

= One of the alignment buttons to Left Align , Center Align , or Right

Align selected text.
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=

| Nam’|
= Hyperlink == button to turn selected text into a clickable hyperlink.

= Text edit field to select text to edit or to select text to apply any of the available
text attributes (font, font size, italic, bold, underline, color, alignment, hyperlink).

*= OK button to save edits in the dialog window.
= Cancel button to exit the dialog window without saving any changes.

= Apply button to apply changes without exiting the dialog window.

To open the “Message Editor” from the Context Sensitive Toolbar or “right click” menu:
= Select the Message object you want to edit by single clicking it to select it.

= Click the Message Editor button on the Context Sensitive Toolbar,

e | T G [pAe o3

[open in Message Editor. .. |

OR

» Right click on the Message object and select Open in Message Editor from the
shortcut menu.

[F7| Open in Message Editor...

Edit Message

» The Message Editor window displays. Make edits as needed and click OK to
save changes and to close the window.
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While working with Message objects, you will find the process and options used during
the “editing” operation will be basically the same for each object whether it is a note,
balloon or text box.

To insert a Message object on a slide:

Note:
= Click the Insert Note E button on the Object Toolbar.
» |f you selected for “message editing”:

o Editin Place: A note object will display on the slide with a “blinking cursor”
in side it. This indicates the note is ready for you to start typing in it.

0 Message Editor: The Message Editor window displays. Make your
selections for the text using the available buttons (font, font size, etc.) and
type your text in the “text edit” field. Click OK to save the information and
the note will be inserted on the slide.

Balloon:
= Click the Insert Balloon ¥ button on the Object Toolbar.
» |f you selected for “message editing:

o Editin Place: A balloon object will display on the slide with a “blinking
cursor” in side it. This indicates the balloon is ready for you to start typing
in it.

0 Message Editor: The Message Editor window displays. Make your
selections for the text using the available buttons (font, font size, etc.) and
type your text in the “text edit” field. Click OK to save the information and
the balloon will be inserted on the slide.

Text Box:

AN
» Click the Insert Text Box ]—L button on the Object Toolbar.

= The cursor changes to a cross-hair + shape. Move the cursor over the slide
and click where you want to “anchor” one corner of the text box. Hold down the
left mouse button and draw the text box on the slide.

= [If you selected for “message editing”:

o Editin Place: A text box object (surrounding by a “bounding box” that
looks like a “dotted rectangle” with gnodes (grab handles) for resizing the
box) will display on the slide with a “blinking cursor” in side it. This
indicates the text box is ready for you to start typing in it.
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0 Message Editor: The Message Editor window displays. Make your
selections for the text using the available buttons (font, font size, etc.) and
type your text in the “text edit” field. Click OK to save the information and
the text box will be inserted on the slide.

To exit “text edit mode” while using the “Edit in Place” method, simply click off the note,
balloon or text box to deselect it.

Message Styles and Type
Once you insert a Message object on a slide, you can change its “style” and its “type” at
any time without recreating it from scratch. The process for doing this is the same for all
Message objects.
To change a Message object’s style and / or type:

Using “Edit in Place” message editing:

= Single click the message object to select it.

= Click the Message Type ¥ button on the Context Sensitive Toolbar.
= The Message Type window displays. Select:

0 A “message style” from the first list.

Select the message skyle:

Classic Message Style

Classic Message Style
Bubbles Message Style
Curyy Message Style
Simple Message Style

Standard Message Style
< 1 J 17 S 7 W N W A0

0 A *“message type” from the second list.

Select the message type:

HUO0O00
QoCcoldT

= Click OK to save and apply the selections.
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Using “Message Editor” message editing:

= Double click the Message object.

» The Message Editor window displays. Click the Message Type = button.
» The Message Type window displays. Select:

0 A “message style” from the first list.

0 A “message type” from the second list.
= Click OK to save selections and to close the Message Type window.

» Click OK to close the Message Editor window and to apply changes.

# | Select anew message type in the Message Type window to change a Message object from
T | anoteto aballoon to atext box and so on as needed without recreating the Message
object from scratch.

Message Object’s Background Color

You can change the background color of a note or balloon while the Message object is
selected (using the “Edit in Place” message editing method) or from inside the Message
Editor window.

To edit a note or balloon object’s background color while using “Edit in Place”:

= Single click the note or balloon to select it.

= Click the Background Color button on the Context Sensitive Toolbar.

» The Background Color window displays. Move your cursor over the palette and

when the cursor changes to a “pointing hand” {b shape, click to select a color.
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[ ]

Background Color...

5113

153 2

255 2

#339FF

Custom [T 1]
Recent BT 1

» Click OK to apply the selected color to the Message object.

To edit a note or balloon object’s background color while using “Message Editor”:

= Double click the note or balloon to open the Message Editor.

* In the Message Editor window, click the Background Color button.

*» The Background Color window displays. Move your cursor over the palette and

when the cursor changes to a “pointing hand” l{b shape, click to select a color.

= Click OK to save the selection and to close the Background Color window.

= Click OK to close the Message Editor window and to apply the selected color.
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Message Object Alignment Tools

When the Message object is selected (not in text edit mode), three object “alignment”
buttons display on the Context Sensitive Toolbar. These buttons can be used to align a
selected Message object on the slide.

To align a Message object on a slide:
= Single click on the desired Message object.
= Click the:

_ +E+ _
o Center Horizontally button to horizontally center the selected
object on the slide.

+*

: =] . :
o Center Vertically * ' button to vertically center the selected object on
the slide.

+E+ _ _
o Center * button to center (both horizontally and vertically) the
selected object on the slide.
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Message Text Options

While working with Message objects (notes, balloons, text boxes), you will want to
customize the various attributes that can be applied to the textual content. Text options
include: font, font size, attributes (italic, bold, underline), text color, text alignment within
the Message object and hyperlink capability. Each of these options is available while
editing using:

= Editin Place: Double click the Message object so that a “blinking cursor”
displays inside it. This indicates you are in “text edit” mode and a Context
Sensitive Toolbar is available with various buttons for text editing options.

I u B | Tshoma v 14 v

» Message Editor: Double click the Message object to open the Message Editor
window. The text option tools are available within this window (as shown in the
image below).

P S

. Message Editor

= Tahoma > 14 >
/I U B H=

Enter the Message object's text here |

[ (0] 4 H Cancel H Apply

To edit text in a Message object:

= Double click on the Message object. Depending on the “message editing”
method used, either a Context Sensitive Toolbar (for “Edit in Place” message
editing) or a Message Editor window (for “Message Editor” message editing)
displays.

= Highlight the text you want to edit (either in the Message object itself or within the
text edit field in the Message Editor window).
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You MUST highlight the text you want to edit BEFORE applying any changes.
= Click the applicable option to make the desired text edit:

o Font: Select a new font from the Font list.

Tahoma w

MS Reference Specialty [4
SansSerif

Senf

Tahoma

Tires Mew Boman

Trebuchet fits

Yerdana
Show All Fonts...

£

If the desired font does not display in the “Font” list, but it is a font available on your
computer, scroll down to the bottom of the list and select the “Show All Fonts” option.

o Font Size: Select a new text size from the Font Size list.

12 L

5
g
10
11
12
14
16
18 v

?

o lItalic: Click the Italic 1 button to set the selected text in italics.

o Underline: Click the Underline u button to underline the selected
text.

o Bold: Click the Bold B button to bold the selected text.

o Text Color: Click the Text Color D button. In the Text Color window,
select a color by clicking on it and then click OK to close the window.
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o0 Left Align: Click the Left Align button to left align the text in the
Message object.

0 Center Align: Click the Center Align button to center the text in the
Message object.

0 Right Align: Click the Right Align button to right align the text in
the Message obiject.

@_g You do NOT have to highlight text in order to apply an alignment option. However, you
> Y% | must apply an alignment option to each section of text separated by a “carriage return”
(each time you hit the “Enter” key to start a new paragraph or line of text).

N
(%2
o Hyperlink: Click the Hyperlink = button. In the Hyperlink window that

displays, make your selections as required and click OK to close the
window.

@—«‘-’ See the chapter on “Hyperlinks” for more information on creating clickable text links.
.-_.__l_,-E
» To exit text edit mode while using the message editing option:
o Edit in Place: Click off the Message object to deselect it.

0 Message Editor: Click OK to save the changes and to close the
Message Editor window.

e Fespre | Automatic Resize of Message Objects (New in ViewletBuilder6.1 Enterprise)
Now you no longer have to worry about “manually” resizing your Message object after
you edit text, let ViewletBuilder6.1 Enterprise do it for you! There is now a new “auto
resize” feature when enabled on the Message object’s Context Sensitive Toolbar will
automatically resize a Message object as you edit the text within it. This feature can be
turned on and off as needed.
To enable “automatic” resizing of a Message object as you edit text:

= Click on the Message object to load its Context Sensitive Toolbar.

+A+
= Click the Automatically size message to fit when editing " * ' button.

= Double click to Message object to enter “text edit” mode.
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» |f you selected for “message editing”:

o Editin Place: As you edit text, the object automatically resize as you type
directly in the Message object.

0 Message Editor: The Message Editor displays. Once you click Apply or
OK to save the text edits, the Message object will be automatically
resized.

If enabled, you can quickly “turn off” the auto-resize Message object feature by clicking it
to deselect it on the Context Sensitive Toolbar at any time while editing a Message object.
To manually resize a Message object:

= Single click on the Message object to select the object itself (not in text edit
mode). A “bounding box” (dotted rectangle) will display around it.

= Move your cursor over one of the gnodes (grab handles). When the cursor
changes to a “double arrow” shape, hold down the left mouse button and drag to
resize the Message obiject.

s
~.I am surrounded bya |
bounding box.

If you manually resize a Message object, if enabled, the “auto-resize” Message object
feature will be disabled for that Message object only until it is again selected.

» Let go of the left mouse button to complete the resizing action.
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To move a Message object on a slide:

= Click the object to select it so that a “bounding box” (dotted rectangle) displays
around it.

= Point your cursor over the selected Message object. When the cursor changes to

a “hand” & shape, hold down your left mouse button and drag the object to its
new location on the slide.

W i

= Let go of the left mouse button to drop the object into place.

To attach audio to a Message object:

= Click the object to select it so that a “bounding box” (dotted rectangle) displays
around it.

= Click the applicable Attach Sound button on the Context Sensitive Toolbar.

“U " Attach Sound to Note

&0 Attach Sound to Balloon

“U Attach Sound to Text Box
»= Inthe Sound window that displays, insert or record a sound file.

» Click OK to save the sound file and attach it to the Message object.
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To remove a Message object from a slide:

= Click on the Message object to select it.

= Click the Delete % button on the Context Sensitive Toolbar. The selected
object will be deleted.

If you accidentally delete a Message object and this was the last action you performed,
click the “Undo” button or press “Ctrl + Z” to undo the deletion.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@qgarbon.com.
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Format Painter

The Format Painter may be used to quickly change text properties in notes, balloons and
text boxes. It can also be used to change properties of a shape object’s border (color,
width) and fill color based on another shape.

Faormat Painker |

To use the Format Painter to apply text attributes from one message object to another:
= Make your changes to text in your message object.
= Click on the text (or click anywhere inside the text) that will be copied from.
= Click the Format Painter.
= Click on subsequent text objects to apply this formatting from the first selection.
= Continue clicking on text on the current or any other slide to apply the formatting.
= When you are finished, click the Format Painter to deselect it.

To use the Format Painter to copy a shape’s attributes and apply them to other shapes:
» Make your changes to the shape as desired and then make sure it is selected.
= Click the Format Painter.
= Click on subsequent shapes to apply the formatting.
= When you are finished, click the Format Painter to deselect it.

=3’ | Use the Format Painter to quickly match the format of a selected object or shape across
X T® | multiple slides.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.qgarbon.com). Or, if you prefer, email support@garbon.com.
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Dictionary, Spell Check, Search and Replace

ViewletBuilder6.1 Enterprise offers various tools to help you make sure that your content
is accurate, typos are caught and corrected, and grammar rules are followed. These
features include:

= Dictionary: Set your dictionary to one of several languages. The dictionary
helps you catch unwanted typos and allows you to build it for more complex
content by adding custom words.

= Spell Check: Enable the “Spelling Mistakes” option from the View menu to
automatically check text in message objects against the selected dictionary.
Incorrectly spelled words, or words not recognized by the dictionary, will be
quickly identified by a red, squiggly underline.

= Search and Replace: Use this tool to quickly search for and replace a specific
word (or even a phrase) on a message by message basis or throughout the
entire project.

To set your dictionary and spell check preferences:
= Select Edit > Preferences from the Menu bar.
= Select the Spelling tab.
» Select a language to use for the spell check dictionary from the list.
» Select additional options for the spell check as needed.

To enable or disable the Spell Check tool:

= To enable the Spell Check tool, select View > Spelling Mistakes from the Menu
bar.

View  Insert Project  He

Sige Zoom ]
ToNips
Zul Path

v Speling Mistakes

Ewvent Icons
Attached Sound Icons

=  When a word is incorrectly spelled or is not recognized by the selected
dictionary, it will be designated with a “red squiggly underline”.

It's time to see what words might e missspelled i
this particular texed box object.
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» To disable the spell check tool, select View from the Menu bar.
= |f the Spelling Mistakes option has a checkmark next to it, click it to remove the
checkmark to deselect the tool.
To correct a typo using the right click menu:

= Click anywhere in the text where the typo appears (as indicated by the red
squiggly underline).

= Right click to display the shortcut menu.

= At the bottom of the shortcut menu, select the appropriate option:

Replace "texxt" with ]
Replace &l "t with ]

Ignore All "tesoxt"

Learn "tesxt"”

0 Replace: Select this option to display a list of suggested words to use to
replace the “selected” incorrect text.

0 Replace All: Select this option to display a listed of suggested words to
use to replace all instances of the “selected” incorrect text throughout the
entire project.

o Ignore All: Select this option to ignore all instances of the “selected”
incorrect text throughout the project.

0 Learn: Select this option to add the “selected” incorrect text to the
dictionary.

£ To add custom words not recognized by the Spell Check tool to the dictionary, select the
2, T® | | earn” option from the shortcut menu.
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To use the Search and Replace tool:

= Click the Search and Replace = button on the Main Toolbar.

» The Search and Replace window displays. Two tabs are available: Search and
Replace.

Search and Replace

Search Replace

»= To search for a specific word or phrase:
0 Select the Search tab if it is not already selected by default.
0 Inthe Text field, type in the word or phrase you want to search for.

0 Select the Case Sensitive option to narrow results.

Texk
YiewletBuilders. 0

Case Sensitive

o0 Inthe Direction area, select Forwards to search from this point in the
project forwards, or select Backwards to search from this point in the
object backwards.

Direction
(*) Farwards
() Backwards

o Inthe Slides area, select:

-Current to search the current slide.

-From and enter a number in each of the fields provided to search from a
specific slide to a specific slide based.

-All to search all slides within the project.
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0 Click the Find Next button to start the search operation.

= To replace a specific word or phrase:
0 Select the Replace tab.
0 Inthe Text field, type in the word or phrase you want to search for.

o0 Inthe Replace With field, type in the word or phrase you want to use as
the replacement text.

0 Select the Case Sensitive option to narrow results.

Texk
WigwletBuildera. 0

Replace With
WiewletBuilders, 1

Case Sensitive

o Inthe Direction area, select Forwards to search from this point in the
project forwards, or select Backwards to search from this point in the
object backwards.

Direction
(*) Farwards
() Backwards

o Inthe Slides area, select:

-Current to search the current slide.

-From and enter a number in each of the fields provided to search from a
specific slide to a specific slide based.

-All to search all slides within the project.

Slides
() Current

From 1
O
@ Al

To 7

4
4
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0 Once all the information is entered / selected in the Replace tab, click the:

Feplace all .
-Replace All to search for and replace all instances of the

text with the text provided.

-Replace to replace the currently “selected” text found after

clicking the Find Next button.

-Find Next button to find the next instance of the desired
word or phrase entered in the Text field.

= Once you are finished using the Search and Replace tool, click the red “x” to
close the window. Or, click Cancel to end the search and replace operation.

While performing a Search and Replace operation, use the “Replace All” button to quickly
replace a single word or phrase throughout the entire project with a single click action.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.
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Working with Slides

ViewletBuilder6.1 Enterprise projects are made up of slides, so it's important to
understand how to work with the most common slide features while building your project.
This chapter introduces some of the most common features available while working with
slides within your Viewlet project.

Slide Types
There are essentially five types of slides that you may insert into existing projects:

= Blank slides

= Screenshot slides
= Image slides

= PowerPoint Slides
= Question Slides

Imsert

|2, ek siide
l-_'%i Screenshots., .
hﬂ Image Slides. ..

.u_% PoverPaint Slides. .

UE Question Slides. ..

o) You can insert new slides into existing projects by selecting “Insert” from the Menu bar.
Or, right click on a slide and select “Insert” from the shortcut menu. Either way, once you
select “Insert” you will see a list of available new slide options for your project.

These slide types may seem familiar. This is because these slide types are also the
same options that are available when creating new projects.

To insert blank slides:
= Select a thumbnail. The inserted slide will be inserted right after this slide.

= Select Insert > Blank Slide from the Menu bar. Repeat these steps to insert
additional blank slides.
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To insert screenshot slides:
= Select a thumbnail. The new screenshot(s) will be inserted right after this slide.
=  Select Insert > Screenshots from the Menu bar.

= The Insert Screenshots window displays. Make your selections as needed and In
the windows that display, follow the prompts to select options for screenshots.

P o

Insert Screenshots
Insert Screenshots
Your current project is size 640 x 480 'L,,,FJ
slide size

. Specify the slide size you would like to create or capture.
Cuskam - Specify a cuskam width and height, w

width: 6403 Height: 450 =

il .v.

Capture Profiles

=l Demonstration
% Show how something is done.

| Training Simulation
% Instruct how ko do something.

=] Assessment
L%, Evaluate training effectivensass,

| Manual Capture
gt | Capture screenshots manually with cursors,
| Simple
t;." | Capture screenshots manually without cursors,

4 R[IN]

[ Ok { [ Cancel

= Take your screenshots during the recording session.

= End your screenshot session and new screenshots will be converted to slides
and inserted into your existing project.
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To insert image slides:

= Select a thumbnail. The new image(s) will be embedded onto slides right after
this slide.

= Select Insert > Image Slides from the Menu bar.

» Follow the instructions in the Select Images to Import window that displays for
locating and selecting your image files.

[ = 1
T
Select Images to Import
Current project size: 640 # 480 pixels.
Filename Stretch
LY
,E:g
D 9] e
Size:
Dimensians:
| (874 g [ Cancel

= Once your images are selected, click OK to insert the new image slides into your
existing project.
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To insert PowerPoint slides:

= Select a thumbnail. The new PowerPoint slides will be inserted right after this
slide.

= Select Insert > PowerPoint Slides from the Menu bar.

» Follow the instructions in the Select PPT file to Import window and those that
follow to locate and select your PowerPoint slides.

[ 1
Select PPT file to Import
Presentation
rj' Select the PPT presentation File ko load:
= Es
Slides
Select the slides tao load into the project.
| Bz
Slide Impark

oK |[ Cancel ]

= Once your presentation slides are selected, click the Options button.

» |n the Options window, review your selections as needed in the General and the
Fonts tab. Then, click OK to return to the Select PPT file to Import window.

» Click OK to insert the PowerPoint slides into your existing project.
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To insert question slides:
= Select a thumbnail. The Question slides will be inserted right after this slide.
= Select Insert > Question Slides from the Menu bar.

» |n the Add Questions window, make your question selections as you would when
creating a new quiz project.

!

rIl_,':'! Add Questions ﬁ

Create scored or survey questions for the project,

Queskion Type

EHEIN 3]

[ oK 4 [ Cancel

|_|

= Click OK to insert the new question slides into your project.
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To insert duplicate slides quickly:
= Click on a slide so that it displays in slide edit view.

= Press Ctrl + D on your keyboard, or select Edit > Duplicate Slide from the Menu
bar.

Edit

S Chrb+x

|_|h_“| Copy ChrliC

% Delete Delete

1= ouplcate Side Ctrl+D

=1k
H, i

Slide Properties

Slide properties can be set for each slide. These properties include the slide name,
duration and whether to include the slide in the table of contents (for viewing purposes).

f =1

Slide Properties

Marne

Slide 1

Duration

Display For 1.0 {:} seconds

Options

[ ]Included in Table of Contents

| QK |[ Cancel H apply

VB6.1 Enterprise User Manual Page 162 March 2009



vil eWleEREINEE O

T YLLES D LAE:

To access slide properties:

= Right click on a slide.

el

S

i
User Manualy

= Select Slide Properties from the shortcut menu. Or, double click directly on the
slide to open the Slide Properties widow.

To edit slide properties:

= Select a slide by clicking on it.

B=
= Click the Slide Properties I—I button on the Context Sensitive Toolbar.

» |n the Slide Properties window, edit the:

-~

Slide Properties

=,

Marne

Slide 1

Duration

LCisplary Far 1.0 E‘:

v-.

Opkions

seconds

[ ]Included in Table of Contents

[ Ok |[ Cancel H Apply

o0 Name: This is the title of the slide displayed at the top of the slide while in

Thumbnail View and along the timeline.

o0 Duration: The amount of time the slide displays.

0 Options: Select this option if you want it included in the Table of Contents
when viewed as a Flash file.
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Slide Color

Slide color is applied directly to the slide and can be changed on one or multiple slides.
The slide color appears behind slide objects and embedded images. The color chooser
remembers recent and custom color selections and has buttons for adding and deleting
custom colors to make that functionality easier to use.

i '\
Background Color...
255 2
255 (%)
255 (%)
#FFFFFF
Custorn [T T T T T T T T 1T ] =
Recent (T TP TT T[]
| [ |[ Cancel H apply

To change slide color:

= Select the slide or slides you want to work with.

= Click the Background Color button from the toolbar.
= In the Background Color window, select a color.

= Click OK to apply it to the selected slide or slides.

VB6.1 Enterprise User Manual Page 164 March 2009



viewletB UG eRONINErierpriie

7 n @g%jﬂlfﬂl

Slide Background Frame

You can embed an image directly to a slide background. In fact, you can do this to one
or multiple slides using the same image. In addition, images can be aligned in various
ways on the slide or stretched as needed.

Slide 1 Slide 2

Slide 3 Slide 4

-

Background Frames

-,

Frame:

Slide 5

=

T =

Slide 8

[ Shiow Prewview l|

(o4 |l Cancel ]

To add a background image to a slide or slides:

= Select the slide or slides you want to work with.

= Right click and select Background Frames.

= In the Background Frames window, click Load Image “~ button.

= Locate an image file, select it and click Open.

= Select a Layout option.

= Click OK.

In the “Background Frames” window, click “Show Preview” to view a preview of the

selected background frame image.
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To delete a background frame:

= Right click a slide and select Background Frames.

» |n the Background Frames window, click the Remove Background & button.

= Click OK.

Moving Slides

There are various ways to move slides with in a project. The easiest way to do it is while
working with thumbnails.

To move slides using drop and drag:

= Make sure the Thumbnails tab is displayed. You can work in this view or while it
is expanded in full view so that only thumbnails are displayed.

» Select the slide (or slides) you want to move by clicking on them.
= Hold down the left mouse button and drag the slide(s) to the new location and
drop into place.
To move slides using cut and paste:
= Make sure the Thumbnails tab is displayed.

= Select the slide you want to move.

»  Click the Cut @ * button on the toolbar.

= Click on the slide where you want to insert the “cut” slide next to.

= Click the Paste H’—-I button on the toolbar.

[#%—7 Click the “Undo” " button to immediately undo cut and paste operations.
Tip

o
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Deleting Slides

You can remove slides from a project while in Slide Edit view or while working with
thumbnails. The choice is up to you. However, if you are deleting multiple slides at the
same time, you will need to do this while working with in the Thumbnail tab.

To delete a single slide:
= Select the thumbnail or click on it while in slide edit view (so that it is the current
slide).

= Click the Delete % button on the toolbar.

= A Delete warning window displays. Read the information in it and click the

Yes button to confirm and complete the deletion.

To delete multiple slides:

= Select the slides you want to delete while viewing thumbnails.

= Click the Delete % button on the toolbar.

» A Delete warning window displays. Read the information in it and click the

Yes button to confirm and complete the deletion.

The Hidden Slide

ViewletBuilder6.1 Enterprise offers you the option of hiding a slide instead of deleting it.
This feature is handy because instead of deleting the slide, it will hide it so that it will not
display while previewing or publishing the project, but can later be unhidden when
needed.
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The main features of working with hidden slides include:

=  The thumbnail for a hidden slide has an X in the lower left corner.

Slide 1

= If you select a hidden slide in thumbnails, it will display in slide edit view at 50%
opacity.

= If you use slide navigation arrows to go from slide to slide, hidden slides are
skipped.

» The duration of hidden slides is ignored in the times in the Timeline.

To hide or unhide a slide:

= Click on the slide (while in slide edit view) or slides in thumbnail view.

= To hide a slide, click the Hide Slide EJ button on the Context Sensitive
Toolbar to hide the slide.

Q T | Hidden slides will not display (or be heard) when previewing a project; however, they will
2™ | remain in the slide count.

» To display a slide, click the Show Slide @J button on the Context Sensitive
Toolbar to display the slide.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.
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Audio

ViewletBuilder6.1 Enterprise allows you to add sound to your project. You can import
sound files or record them directly while working in ViewletBuilder6.1 Enterprise. Audio
files may be attached directly to a slide or various slide objects such as balloons, notes,
text boxes and shapes. You may also export sound from projects. And, there is a feature
that allows you to add a background sound track (independent of sound attached to
slides or slide objects) to your project.

= o

Sound

Select or record & sound:

ol || | @ || BP
0 KB - 00:00.0 f 00:00.0

Y,

£ ok, |[ Cancel ][ apply

To attach an external audio file to a slide or a slide object:

= Click on the slide or slide object to select it.

=  Click the Attach Sound rﬂl button on the Context Sensitive Toolbar.

]

= |n the Sound window, click the Load Sound “ button.

= Select a sound file and click Open to return to the Sound window.
=710 Supported sound file formats include MP3, RAW, AlF, WAV and AU.

MWed Fesmpe | The RAW Audio File Format (New in ViewletBuilder6.1 Enterprise)
ViewletBuilder6.1 Enterprise now supports the RAW audio format. A “raw” sound file can
contain audio in any codec, but is usually used with PCM audio data. So, if you have
“raw” audio files, you can now import them into your Viewlet projects.

» Click Open to return to the Sound window.

= |n the Sound window, click OK.
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To record sound inside ViewletBuilder6.1 Enterprise:

= Click on the slide or slide object to select it.

=  Click the Attach Sound rq!]” button on the Context Sensitive Toolbar.

= The Sound window displays. Click the Record | ® | button.

In order to record audio, your computer must have a sound card. ViewletBuilder6.1
Enterprise records audio using the MP3 format. This reduces file sizes in projects
containing audio.

» Speak into your system’s microphone to record.
A “Countdown Timer” will display prior to recording audio if you selected the “Display

Countdown Timer” option when setting up program preferences (Edit > Preferences >
General tab). Start speaking after the timer countdown is complete.

ecord a sound:

CEEY:

0.0

3

b 1 | | &

* Press the Stop |£| button to end the recording.

= Click OK to attach the recording to the slide or slide object.

To preview a sound file in the Sound window:

* |n the Sound window, press the Play | > | button to listen to the sound file
attached to the slide or slide object.

= Click OK to close the Sound window.
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You can listen to sound files attached directly to slides by clicking on a slide. Then, click
the “Attach Sound to Slide” button. In the “Sound” window that displays, click the

“Previous Sound” |ﬂ| button or the “Next Sound” |ﬁ| button. This will move you
automatically to the applicable slide and the sound attached to it in the “Sound” window.
Click “Play” to preview the sound. Repeat these steps while in the “Sound” window to
listen to slide sounds throughout the project without closing the “Sound” window.

To remove sound attached to a slide or slide object:
= Click on the slide or slide object to select it.

= Click the Attach Sound button on the Context Sensitive Toolbar.

= |n the Sound window, click the Delete Sound % button.

= Click OK to close the Sound window.

To export sounds from your project:
= Before exporting any sound files from your project, create a folder outside of
ViewletBuilder6.1 Enterprise to save your exported sound files in
(recommended).

= Select File > Export from the Menu bar.

= Select Sounds.
= In the Export Sounds window, select the slides to export:

f = =1

Export Sounds

Slides

() From ko
= all
[ Excport ] [ Zancel
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0 Current Slide: Only the sound attached to the current slide and any
attached to slide objects will be exported.

o0 From: Enter a starting slide number in the first field and an ending slide
number in the second field. Sound attached to the slides (and objects on
the slides) in this sequence will be exported.

o All: All sound attached to slides and slide objects will be exported.
»= |nthe Save File In window, select a folder to save the exported audio files in.

= Click Save.

'r‘ Exported sound files are saved in the same format (and with the same file name) as they
2 T® | have in the project prior to being exported.

Play Sound Action Options

When working with Events and Actions, you can add a “Play Sound” action to many
different Events such as when a slide loads or unloads, when a mouse rolls over an
object or area of the slide, when the user clicks and more. The “Player Sound” action
has some synchronicity and concurrency features for ultimate sound control during
Viewlet playback.

Synchronicity (Play Sound Action)
In the Action window, when the Action Type of Play Sound is selected you have the
ability to determine when your sound file will end.

! Action

Action Type: Seleck the action bype From the list,

E;I Play Sound W

In the Synchronicity area, select the Wait for the sound to complete before
advancing to the next action or slide if desired.

Synchronicity

‘Wit for the sound bo complete before adwancing
ko the next action or slide.
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Med Fespe | CoOncurrency (Play Sound Action) (New in ViewletBuilder6.1 Enterprise)
A new “Play Sound” action option includes selections for further controlling when the
sound files plays along with other sounds on the slide. In the Concurrency area, select
the desired option:

= Concurrent Playback — Play concurrently with other sounds.
= Privileged Playback — Stop all other event sounds.
» Exclusive Playback — Stop all other sounds.

COMCLFFEncy
{#) Concurrent Playback - Play concurrently with other sounds,
() Privileged Playback - Stop all other event sounds,
() Exclusive Playback - Stop all other sounds,

Sound Quality for Published Project

Please refer to the Project Properties chapter for information regarding how to set up
sound quality options for your published project.

Background Soundtrack

As discussed previously in this chapter, audio may be attached directly to a slide as well
as to other slide objects. You may also attach a background sound track to your
published project. This sound track is independent of sound attached to slides and slide
objects and plays in the background when the Viewlet is played. Please refer to the
Project Properties chapter for more information on adding a background soundtrack to
your Viewlet.

# | A background sound track will loop and continue to play even when the Viewlet pauses on
2T | slides with interactive zones. However, if the viewer uses the player bar or clicks an object
with a pause even, the sound track will stop until the Viewlet is back in “play” mode.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@qgarbon.com.
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Images

Images may be used in projects in a few different ways. One option is to create an entire
project made up of image files. When creating image projects or when inserting image
slides, images are embedded as slide background frames. When used in this way,
images cannot be moved around the slide.

Q y¥ | Multiple images may be used as part of a slide’s background frames. See the chapter on
2, T® | “Background Frames” for more information.

You may also insert images onto slides as slide objects. When inserted on the slide,
images may be resized, moved on the slide, converted to a hyperlink object, become a
rollover event, have its transparency level modified and more. And, multiple images may
be inserted on the same slide.

Let’s look at some ways to work with images and slides.

To insert an image on to a slide:

= Select the slide you want to insert the image on.

=

= Click the Insert Image button on the Object Toolbar.

» Inthe Insert an Image window, browse to locate the image file.

&y Supported image file formats include JPEG, GIF, TIFF, JPG, TIF, PNG and BMP.
Tip

-]

= Select the image file and click Open. The image is inserted on the slide, ready
for editing.
To move an image on a slide:
= Select the image by clicking on it.

= Move your cursor over the image and when the cursor changes to a hand shape,
hold down the left mouse button.

Drag the image (while holding down the left mouse button) to its new location on
the slide.
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To resize an image on a slide:
= Select an image by clicking on it.
= Point your cursor over one of the grab handles.

= When the cursor changes to an arrow, hold down your left mouse button.

= Drag the grab handle (while holding down the left mouse button) to resize the
image.

To change an image’s opacity level:
= Select an image by clicking on it.

= Enter a value in the Opacity field on the Context Sensitive Toolbar.

W = I o e

~ L2 l__| +
SDEI 4 +[E+ IE

R S

= Press enter to apply the new opacity level.
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To layer images (and other objects):

* Right click on the image.

= Select Arrange from the shortcut menu.

= Select an arrangement option from the fly-out menu.

ef Manual

H--ih=—t

L=

2= | Image Properties...

I:}-(}

[

Events...

5‘1’% Cuk Chrl+¥

|:|3 Copy Chel4+C
Paste Chrly

% Delete Delete
Arrange ]
Align F
Skyleshest r
Opacity (%) »
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To view and/or modify image properties:

= Click on the image to select it.

B=
» Click the Image Properties I—I button on the Context Sensitive Toolbar.

= Inthe Image Properties window, view/edit the Name, Location & Size and Timing

as desired.
s '\
Image Properties
Marne
Image
Location & Size
Left 2643 Top 160 (%]
Width 6112 Height 455
Tirning
Until End of Slide v
Start Time D.D{:} seconds
| (04 { [ Cancel ] [ apply

»= Click OK to close the Image Properties window.

To create an image event:

= Click on the image to select it.

= Click the Events L4 button on the Context Sensitive Toolbar.
* Inthe Image Events window, select an events tab and choose the desired action.

» Click OK to apply.
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To delete an image:

= Select the image.

= Click the Delete ‘ ‘ button on the Context Sensitive Toolbar.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.qgarbon.com). Or, if you prefer, email support@garbon.com.
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Background Frames

The most popular Viewlet projects have slides that contain embedded images as part of
the background. These background images are known as Background Frames. This
chapter discusses how to work with single and multiple slide background frames, an
important component of many Viewlet projects.

Background Frames — Single Frame

T v— = = ) v

¥ <

Background Frames .ﬁ
o Qaskon | Presentation Soltwane
@- = il i e aparhon o Frame:
Fis Ecé Vew Feoidss Todh H q} '._1 %
wf & @@ Jwban | Pramrlaon St
Layauk
Qlarbon |
Seligiore. | Products Ser E| Top Left - 4
[ Shiw Preview ] [ ok g [ Cancel
# Budget Friendly
df
athorin Wel Baved Content Cresticn KHanagement .
In:::Is 2 ':I:h-l:::- - 5-:“"-'-:;5 : Sy leTs I
Dieskiop Based ‘Wl Based
€7 : .
1 : \J,
Bt oan o fr_..d_ari. i Vs ._'.- ﬂlnlemei”.- o “:u:m

To access the Background Frames window:

e Select the desired slide in slide or thumbnail view.

e Right click and select Background Frames. The Background Frames window
displays.

e You can also double click on the frame along the Timeline to display the
Background Frames window.
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To add a background frame to a slide with detailed settings:

e In the Background Frames window, click the Add Frame button.

2le X

o The Background Frame window displays. Click the folder button to search for
and select an image for the frame.

-~

Background Frame

Frame Image

Opkions
Key Frame

[ Play Keyboard Click

Locakion & Curakion
Left: of]

Tap: III{:}

Duration: 0.0 {:} seconds

[ oK |[ Cancel ]

e Set Options, Location & Duration settings as desired.

e Click OK.

e Click OK in the Background Frames window to load the selected frame.
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To directly load a frame from the Background Frames window:

¢ In the Background Frames window, select the Load Image button.

HE R

Load Image

e Browse for and select an image.
o Click Open.

e Click OK.

To delete a background frame:

¢ In the Background Frames window, click the Remove Background button.

ustomers  Dowr

[Remove Background |

e Click OK to remove the background frame.

If you accidentally delete a background frame from a slide (and this was your last action),
simply press “Ctrl + Z" to undo this last action.

To expand/collapse the Background Frames window:

¢ In the Background Frames window, click Show Preview [ A ] button
to expand the window.

To collapse the window, click the Hide Preview button.
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To choose the layout for the frame:

¢ In the Background Frames window, select an orientation for the image from the
Layout list.

I L

Top Left Top Top Right:
Left Cenker Right

el laf [d

Bottom Left Baokkam Boktam Right

e Click OK to close the Background Frames window.

To change zoom selection of frame Preview:

e To zoom in, click the Zoom In button.

Presviem
Linited States
Services | Demos | Customers Downloads Store | Cen
T — r—n
o
L3 [ ] O
iewletBuilder zeondo]
F=N
é{?\'iu
|
what this means lor your company. .. T0%
= Increased Productivity: Create high-impact online prese
with minimeal sffort,
= Optimized Business Plamning: Caplurs valuable stabsuc
R = | I | Pt tl 1 [ Pl | 1
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e To zoom out, click the Zoom Out button.

Presiew:

| fard | I ]

e To fit the image in the Preview panel, click the Scale to Fit button.

Prewview:
P P Am Frede v e
[ EUIRES RN B - R T TR SR A i h N 1
it | g sy o mitor = e dmeas B o
o
@
—=
S i
39 -
Sicale ko Fit
Il:rr. 'I-J.l n-cm:t:r;u B ETA DA T L T W R T
. |uﬂ\.l‘ruru_rr l_lu!lr:'rul'wlml.k.uﬁ o <t ket @
Al D
S I | Pt | I 1
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Background Frames — Multiple Frames

Slides may be comprised of multiple background frames. This most commonly happens
when creating projects using Smart Capture. Slides containing multiple background
frames are animated during playback on the slide itself (similar to an animated GIF file).
To edit a slide with multiple background frames, you will use the same steps as you
would with the steps outlined for modifying a slide with a single background frame. There
are, of course, a few additional options since you are working with multiple frames.

For instance, following is an example of what a typical Background Frames window
looks like when working with a slide containing multiple background frames.

F = =1

Background Frames
Frames:
Frame: Duration Key
Frarne 2 seconds True N
Frame 0.1 seconds False —
Frame 0.5 seconds False _
A4
Layauk:
EI Top Left w
£ Show Preview | [ Ok, ] [ Cancel ]

Background Frames Window with Preview Hidden
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Background Frames x
Frames: Preview:
Franme: Duration Key # uren | Frensalatn Seters. Soiman Caglan e Kacaidr. £nnnan (e - Wi inlanmd teal.. - D (5]
f} __ v [ s e e ¥
Frame Z seconds True | S ‘ R T P
Frame: 0.1 seconds False — F ]
% 5
Frame 0.5 seconds False F
0 Why Choose Qarbon?
= Easy To Use Toals =
/ = Dedicated Suppart Team éf')
& High Quakity Output =
- * Budgel Friendly
| % ‘ T | i gl 74
—_— Dcibins Bused s Buseel 40%
k4 ¢ 8 &
i AT Em
Layouk: c s
K <« B B Bl
Top Left w
EI op e Frame 1 of 3
[ Highlight Selected Frame
[ Hide Preview [ Ok l [ Cancel

Background Frames window with Preview Displayed

Key Frame

Frames added after the first frame may or may not be key frames. If marked as a key
frame, the key frame will completely replace the previous image in the sequence. If a
frame is not marked as a key frame, the frame is just “painted” on top of the previous key
frame, like an additional image layered on top of it.

After creating a screenshot project or adding new screenshots using Smart Capture, if
you look at a slide that has multiple animation frames on it, you will see that all but the
first frame are NOT key frames.
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To enable/disable a Key Frame:
e In the Background Frames window, double click a frame.

¢ In the Background Frame window, select the Key Frame option.

Opkions

Key Frame

[] Play kKeybaard Click

e Click OK.

To move a frame up/down within the list:

e Select the frame in the list.
e Click the Move Up button to move the frame up in the list.

e Click the Move Down button to move the frame down in the list.

To add a frame to the list of frames:

e Click the Add d'}l button.

¢ In the Background Frame window, click Browse.

Frame Image

Mintinne

o The Select Frame Image window displays. Select and image file and click Open.

¢ In the Background Frame window, make other selections as needed and click
OK.
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To edit a background frame:

e Select a frame in the list.

/|

e In the Background Frame window, make selections as desired.

e Click the Modify button.

e Click OK.

To delete a frame:

e Select a frame in the list.

p—

e Click the Delete‘ % ‘button.

If you accidentally delete a background frame from a slide (and this was your last action),
simply press “Ctrl + Z" to undo this last action.
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Previewing Multiple Background Frames

When working with multiple background frames there are a few different features for
navigating the Preview in addition to the zoom features previously covered. Use the
following tools to quickly navigate through background frames.

To navigate through multiple background frames:

¢ Inthe Background Frames window, select a frame in the list.

o Click the Show Preview I Show Preview l button, if applicable.

e Click the appropriate button (below the preview pane):

Preview:

1 Cersen | Freanlilen Soteea, Sinnn Caglam e Facarder. Anmarard S - Worrdosa Inlamed Exal.. ZEE

[ ﬂ B T e —— [# =l &=
a4 1H e byvdw la e
L_. G gkl | el s L i BB &tk
N awhdiwy Frw ot R Ihwwy Tirder ot ERT) Cirgpan g J:i‘q
o
— Why Choose Qarbon?
| A FocuTnllcg e ﬁ
4 Frewview 4’%‘
- Background
g p— p—— Frames — . 4
Trads Lrrens) [rstome ltan -
I Dethtizs B 4%
] Previous It
7_ €| Frame | Frame D
= T e e -
First p—
Fiasta rb K < B B B ﬁ Frarme
W
] Frame Z of 3
o First Frame
o0 Previous Frame
0 Preview Background Frames
0 Next Frame
o0 Last Frame
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To highlight a selected frame:
¢ Inthe Background Frames window, select a frame in the list.

e Under the preview pane, select the Highlight Selected Frame option.

Presyiew:

[ T T —
o bR e byvdw lae bl

o |-m|qwmﬂmmu.. —

F=H

0%

B> b D

Frame z of 3

Highlight Selected Frame

If the selected background frame is a “Key Frame” the entire image will be highlighted. If it
is not a Key Frame, only the image that “sits on top of the Key Frame” will be highlighted.
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Using the Timeline to Access Background Frames

If you prefer to edit your project using the Timeline, you can also easily access the
Background Frames window to modify your background frames.

Here’s an example of what a slide containing multiple background frames looks like
along the Timeline:

3 Do | Presentation Soltesn: . Sccen Capiese. Screen Recordes, Aastssment Teok - Micresolt Inernes Expleser r-_|ﬁml
2
L

Fle Edt Vew Fovoites Tods Hep
Qo O A @G Do drroms @25 E-LJ0 B
] hat fiwsmons, ceatin, coned v e S B o

T T

F Lol seComn - Produns Senioes Deeimin AT S gt bt Srare (\‘p"w ) St
ek Ha
Selected % " ]

"Key"” Frame |=.

has become even better and easier.

Caabon Solutins: Sen what this means for your comgany

= Inceessed Productivitys Cresbs high-imosot anline presentations guiokfy
with minimal effart
= Dptimized Bmsiness Planning: Capturs vakishls rtsbirticn that halp reveal

cuskarmar prafsrences ard target market.
= Wise Use of ¥aluable Manpomer and Ressweces Ui feedhack sod

SCOFQ SLATNES 10 M EAEUre T SMTeOtivaness of pour GORbE I Ard Takir yiur

focun to arly whara & in rasded,
& Flenibilitys Maoke the micst out of Gamon's m Ut pefam s and desgn

N0 SASHA I Ar DN MRt as vou ke
= Hegher Beturn on Investment (E01): Tabs sdvantaps of Qarbar’s &

B Iriurat

Timeline

27 of 34 01:39.0 ta 01:42.6 of 0Z:04.5 Om03.6 » L 100% = all Slides C

H Side Frame 2

7 Slide 27 Frame 1 e
+ Cursar Path & | L
Balloon: Click Here &F | L \
i Background: 1 af 3 &F | L

In the illustration above, Slide 27 contains multiple animation background frames. In fact,
it contains three frames (as designated in the layer called “Background: 1 of 3). Frame 1
is the selected frame and, in this example, is a Key Frame. Frame 2 and Frame 3 are
part of the background frames, but will not display until selected along the Timeline. In
this example, they are not selected.

If you click on a specific background frame in the Timeline, it will display it in the Slide
Edit area.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.
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Shapes

You may insert one or more shapes onto slides. This chapter provides an overview of
the four basic tools for creating shapes and how to edit them.

The Rectangle Tool
The rectangle tool allows you to draw rectangles and squares on a slide.

= Tl TP o e T o W —

] - 100 = |!.| 12 ¥ l'_l'l_ "'ﬂu
D Rectangle Tool

Thinshnads =

[L%-': =0

Insert
Shape Tool

E 0 G

To insert a rectangle:

S

»= Click the Insert Shape button on the Object Toolbar.

= Click the Rectangle Tool I:I button on the Context Sensitive Toolbar.

= Move the cursor over the slide until the cursor changes to a cross-hair +
shape.

= Click on the slide and hold down the left mouse button.

= Continue to hold down the left mouse button and drag to draw the rectangular
shape.

= Let go of the left mouse button to complete the shape.
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The Ellipse Tool
The ellipse tool allows you to draw circles or ovals on a slide.

m = = 7 & M

.Q @ Ellipse Tool wolsl o W= 8 Y TR N
i =
| =
E 'r]l'i
§
@
=
Insert Shape |
Tool o
&
(5=11

To insert an ellipse:

S

= Click the Ellipse Tool O button on the Context Sensitive Toolbar.

= Click the Insert Shape on the Object Toolbar.

= Move the cursor over the slide until the cursor until the cursor changes to a

_|_

cross-hair shape.

= Click on the slide and hold down the left mouse button.

= Continue to hold down the left mouse button and drag to draw the elliptical
shape.

= Let go of the left mouse button to complete the shape.
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The Lasso Tool
The lasso tool allows you to create free-form shapes.

A - = & B g

Insert Shape

Tool |~y ~
rx"'

W {:}j
£ > =
To create a free-form shape:
= Click the Insert Shape O on the Object Toolbar.
= Click the Lasso Tool O button on the Context Sensitive Toolbar.
. . v
= Move the cursor over the slide until the cursor changes to a lasso shape.

= Hold down the left mouse button and draw your shape.

= Let go of the left mouse button when the free-form shape is complete.
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The Poly Lasso Tool
The poly lasso tool allows you to create polygonal shapes.

= & (_J Poly Lasso Tool 'A 3] ¥ Bl o

Tool

Insert Shape <
:ll'.-‘

To create a polygonal shape:

S

= Click the Insert Shape button on the Object Toolbar.

= Click the Poly Lasso Tool @ button on the Context Sensitive Toolbar.

= Move the cursor over the slide until the cursor changes to a poly lasso %:j
shape.

= Click on the slide to insert the first “anchor” point.

= Drag the cursor to form the first leg of the polygon.

= Click again to insert the next anchor point.

= Drag the cursor again to form the next leg of the polygon.

= Continue repeating these steps until the polygon shape is formed.

To close one of the lasso shapes, make sure to click back on the starting point. Or, double
click when you are ready to close the shape.
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Miscellaneous Shape Tool Features

Once shapes are created, you may move, resize, recolor, and arrange them to create
custom effects.

To move a shape on a slide:

= Click the shape to select it.

= Move your cursor over the shape until the cursor becomes a grab hand
shape.

*= Hold down the left mouse button and drag the shape to move it.
To resize a shape:
= Click the shape to select it.

= Move your cursor over one of the grab handles until the cursor changes to an
arrow shape.

* Hold down the left mouse button and drag to resize the shape.

To arrange the shape in a stack:

5= | Image Properties...

A Cut Chrl+x
|_|_—| Copy Chrl+iC
EH " Paste Chel+

% Delete Delete

Arrange Foreground

Align Forward

Backwward
Backaround

Styleshest

Opacity {%%)
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= Click the shape to select it.
= Right click and select Arrange from the shortcut menu.

= Select one of the arrange options to move the shape to that position in the stack.

To delete a shape from the slide:

» Click the shape to select it.

= Click the Delete % button on the toolbar.

Use the shape tools in ViewletBuilder6.1 Enterprise to create custom slide effects for your
Viewlet project.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@qgarbon.com.
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Grouped Objects Alignment, Distribution and Sizing
ViewletBuilder6.1 Enterprise offers various alignment, distribution and sizing tools when
working with multiple objects. This chapter provides an overview of working with these
options.

Alignment Tools

Alignment tools are available for selected objects. The alignment tools are divided into
two sections:

1. Aligning selected objects within the group’s “bounding” box (as indicated by the
dotted rectangle surrounding the selected objects).

2. Aligning selected objects on the slide.

To align two or more selected objects within the group’s “bounding” box:
= Click on the first object to select it.
= Hold down the Ctrl key while clicking to select additional objects. A “bounding
box” surrounds the selected objects. It will be inside this bounding box area that

the alignment will occur.

= Click the applicable “group alignment” button for the selected objects:

e e

@ :

I am a note,

|
|':' Align Left Edges

|:|u

Align Top Edges
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':'| Align Right Edges

In

Align Bottom Edges

EL&' Align Horizontal Center

fio

Align Vertical Center

To align a single or multiple objects on a slide:
= Select the object to select it.

= |If selecting multiple objects, hold down the Ctrl key while clicking on additional
objects to select them.

= Click the applicable “slide alignment” button for the selected object(s).

@

I am a note,

+[E+ . .
Center Horizontally (on slide)

+[E+

Center Vertically (on slide)

+  Center (horizontally and vertically on slide)
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Distribution Tools

Distribution tools are available for selected objects. In order to use the distribution tools,
three or more objects must be selected. A “bounding box” (dotted rectangle) displays
around the selected objects and it is inside the perimeter of this bounding box the

distribution will be applied.
To use the distribution tools:
= Click on the first object to select it.

= Hold down the Ctrl key when clicking to select the additional objects.

Three or more objects must be selected in order to access the distribution tools.

= A *“bounding” box displays around the selected objects. Click the applicable
“distribution” button on the Context Sensitive Toolbar to apply it to the object

group.

I am a note,

I'] Distribute Left Edges

=
== Distribute Top Edges

IE‘ Distribute Right Edges
=
I—1

Distribute Bottom Edges

.¢| Distribute Horizontal Center
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1=
= Distribute Vertical Center

Sizing Tools

Sizing tools are available for two or more selected objects. Use this tool if you want to

quickly set all objects within a selected group to the same size.

To resize two or more selected objects:

= Click on the first object to select it.

The order that you select your objects is IMPORTANT. The objects will be “resized” based

on the first object selected in the group.

= Hold down the Ctrl key when clicking to select the additional objects.

= A *“bounding” box displays around the selected objects. Click the applicable
“sizing” button on the Context Sensitive Toolbar to apply it to the object group.

= IS =

!

=
=1 Make Same Width

EIDI Make Same Height

[0y

I Make Same Size
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Events and Actions — An Introduction

ViewletBuilder6.1 Enterprise offers a robust set of events and actions that may be
associated with slides and slide objects such as shapes and images to produce greater
dynamics and a higher user interactive experience than ever before. This chapter
provides an introduction into ViewletBuilder6.1 Enterprise’s events and actions features.

Events

Events may be defined as what happens when a certain scenario occurs. For example,
a slide event may be the “On Load” event. This means that when the slide “loads” or as
it “loads” this “loading” is an event.

To create a slide event:

! Slide Events

On Load | On Unload | On Key Pressed

@rfnrmed when the slide@
Auction \

(#)0]

Click Add to add an
action to this event tab.

R

V
b 4

|

oK |[ Cancel ][ Apply ]

» Right click on a slide directly and select Events from the shortcut menu.
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= |n the Slide Events window, select a tab:

on Load | on Unload | On Key Pressed

0 On Load: This is when a slide is loaded.
0 On Unload: This is when you leave the slide.
0 On Key Pressed: This is when a key is press while on a slide.

= Select an action as desired.

The selections you make for the selected “action” will depend upon the action you select.
-,T

= Click OK.

To create a shape event:
= Right click on a shape.
=  Select Events from the shortcut menu.

= Inthe Shape Events window, select a tab:

on Click | on Rollover | On Rollout

0 On Click: This is when the user clicks on the shape.

o On Rollover: This is when the user moves the mouse over the shape.

0 On Rollout: This is when the user has moved the mouse off the shape.
= Select an action as desired.

»= Click OK.

Don’t forget, you can add multiple actions to an events tab!
P i
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To create image event:
= Right click on an image.
= Select Events from the shortcut menu.

= Inthe Image Events window, select an events tab.

On Click. | on Rollover | ©n Rollout

0 On Click: This is when the user clicks on the image.
0 On Rollover: This is when the user moves the mouse over the image.
0 On Rollout: This is when the user has moved the mouse off the image.

=  Select an action as desired.

= Click OK.

Actions

Actions are associated with Events and are “what will take place” once a particular event
occurs. For example, an “On Click” event may have a “Goto Slide” action attached to it.
So, when a user clicks a shape, for example, the project will “go to” a predefined slide.

=

On Load | On Unload | On Key Pressed

Actions petformed when the slide is lnaded,

Action

I:;J Play Sound: recorded_3.mp3

GctinD

———

Action Type: Select the action bype From the lisk,
‘[E,] Goko Slide v

Slide:

EJ Slide 3 w

[ K ][ Cancel ]

IF, [ <aner [ #pey |
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To attach an action to an event:

= Select a slide, shape, image or other object (that supports events).

Right click and select Events from the shortcut menu.

= |n the Events window, select an events tab.

= |n the tab, click the Add d']j button.

= |n the Action window, select an action from the list. If applicable, make additional
selections for the selected action as needed.

= Click OK to close the Action window to return to the Events window.

= (Click OK to close the Events window.

To arrange multiple actions for a given event:
* In the Events window, select an events tab.

= If multiple actions are listed in that tab, click an action to highlight it.
= Click the Move Up button to move the selected action up in the list.

= (Click the Move Down button to move the selected action down in the list.

= Click OK.

To edit an action:
= |n the Events window, select an events tab.

= Select the action to edit.

4

= Click the Modify button.
= |n the Action window, modify the action as needed.
= Click OK to close the Action window.

= Click OK to close the Events window.
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To delete an action:

= |n the Events window, select an events tab.

= Select the action to delete.

= Click the Delete‘ % ‘button.

= Click OK to close the Events window.

If an event has multiple actions associated with it, the actions will be performed in the
order in which they are listed in the “Action” window (from top to bottom).

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@qgarbon.com.
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Buttons

Buttons may be used to increase user interactivity within your Viewlet project. For
example, if you want to give your viewer the control to advance through your Viewlet at
their own pace, you can create your own series of customized buttons for them to do
this. Or, you might provide buttons that, when clicked, will allow the viewer to skips

ahead or to different parts of your project instead of just progressing through it in a linear
fashion.

e =y
- — T
' Button Style
Select a skyle for the Butkon:
”
Zlassic Bukton Style Abc
Bumnper Bukton Skyle
Zarnival Butkon Style T Insert Button tool
Glass Button Style E
Impact Butkon Skyle Abc
Mac Bukkon Skyle [ Abc ) L==ib==4]
E— v Ll Button LI N
K, g [ Cancel ] [ Apply ] I@
=i

To insert a button on to a slide:

[l
= Select the Insert Button “ | button on the Object Toolbar.

= A button is inserted on the slide ready for editing.

Don’t forget to add a “Pause Zone” to a slide that contains a button. This will give the
viewer a chance to click the button for further navigation in the Viewlet.
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To view/modify button properties:
= Right click a button and select Button Properties from the shortcut menu.
» |n the Button Properties window in the:

o0 Name area: Enter a name for the button in the field provided. Enter the
Text to be displayed on the button in the field provided.

Marme

MName: |Buktton

Text: |Button

0 Location & Size area: Enter values for its Left and Top margin. Enter
values for the Width and Height of the button.

Location & Size

Left 224

4

Top 37

Width g Height 36

4k

o Timing area: Select a timing option for the button to display on the slide
from the drop down list. Enter values for any Start/Duration times as
applicable.

= Click OK.

To move a button on a slide:

= Click a button to select it.

Y

= Point your cursor over the button and when the cursor changes to a hand
shape, hold down your left mouse button.

= Continue to hold down the left mouse button and drag the button to its new
location.
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To select a button style:
* Right click on the button and select Button Style.
» |n the Button Style window, select a style from the list.

= Click OK.

To add an event and action(s) to the button:
*= Right click on the button.

=  Select Events from the shortcut menu.

p—

= |n the Button Events window, in the On Click tab, click the Add ‘i‘ icon.

Button Events
OnCIlck|
Ackions to perfarm when the user clicks on this butkon,
Ackion
s ™,
Goto Slide; Slide 4
o
e
.
[ (] ] [ Cancel ] [ Apply ]

= |n the Action window, select an action from the list. Make additional selections as
needed.

= Click OK to close the Action window.

= Click OK to close the Button Events window.
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To delete a button:

=  Select a button to delete.
. &
= Click the Delete button on the toolbar.

Use multiple buttons on a slide for non-linear navigation within the Viewlet.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.
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Hyperlinks

A hyperlink allows a user, with a single click, to perform an action such as jump to
another section of the project, open an email, go to a web page and more. In
ViewletBuilder6.1 Enterprise, hyperlink functionality includes text links and the ability to
make other objects work as “clickable” links. This chapter covers the basics steps for
creating hyperlinks in your Viewlet projects.

Hyperlink, ..

Message Hyperlinks

While message objects themselves cannot be set up as a hyperlink, a portion or all of
the text inside can. These types of hyperlinks are known as text links.

hlend ideas to the slide

Chrl+C

Chrl+Y

Ttalic Chrl+1
Underline Chrl+0
Bold Cbrl+B
Fant

Text Colar.,.

Font Size

Left align
Center Align
Right Align

P _
I&I Hyperlink...
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To create a text link within a message object:

= Highlight the text you want to use for the link.

» Right click the text and select Hyperlink from the shortcut menu.

= In the Hyperlink window, make sure the On Click tab is selected.

= (Click the Add d']j button.

= |n the Action window, select an action from the list. Make additional selections as

needed.
= Click OK to close the Action window.

= Click OK to close the Hyperlink window.

r-h,'.'k Action

Action Type: Select the action bype From the list,

@ Display URL "

RL

Rikkps e, qarban, cam

Destinakion:

|New Window - Advanced [v]

indow Dimensions

idth 640/2] Height 4302

Window Opkions

[ ]Cisplay Toolbars [ ] Display Scrollbars [ ] Resizable

Please Mote: Using this destination will display a warning message unless the
Yiewlet is run From a trusted Folder or webserver,

(0] 4 l [ Zancel
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By default, a text hyperlink will be blue underlined text. Once a hyperlink is created, you
can change the link’s text attributes as needed.

Miscellaneous Hyperlinks

Any object that requires the user to click may be considered a link of some sort.
Message (text) hyperlinks work the same as when you are creating an Event/Action
setup. Links can also be set up to occur when an image loads, etc. Please refer to the
chapter on Events and Actions Overview.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.
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Interactive Zones — Common Features

Interactivity is key to acquiring and maintaining your viewer’s interest. And, with the use
of interactive zones within your Viewlet, you can gain valuable input from your viewers
for training, marketing and even product development purposes. The Interactive Zones
are a staple of ViewletBuilder6.1 Enterprise and have been in almost all of the previous
versions. They provide dynamic results like Events and Actions, but focus on specific
purposes.

ViewletBuilder6.1 Enterprise offers five Interactive Zones:

= Click Zone

= Text Zone

= Keystroke Zone
= Pause Zone

= Questions

For purposes of this chapter, we are not including Hyperlinks or Events/Actions since
they have already been covered in the previous chapters.

The Interactive Zones (with the exception of the Pause Zone) have many elements in
common. These include:

= Only one zone per slide.

= Aninput field OR a clickable area or button.

= Audio option.

= Response to user input in the form of a message or some other object for when
the user answers correctly or incorrectly or doesn’t complete a response.

= Scoring with points, attempts and time for answering.

Let's review each of these elements separately.
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The One Zone Per Slide Rule

Unlike other dynamic elements, Interactive Zones serve a specific purpose and
therefore, only one zone may be on the slide at a time. If you try to insert multiple slides,
you will see a Warning window the will inform you what type of zone the slide already
contains. It will offer you the following Options:

P o

Warning

This slide already contains a ClickZane,

Options
(%) Replace it with a TextZane.
() Add the TextZone ko a new empty slids.
() Add the TextZone to a copy of this slide,

ok | [ Cancel ]

= Replace it with a [selected zone].
= Add the [selected zone] to a new empty slide.
= Add the [selected zone] to a copy of this slide.

Select one of these options and click OK.

Zone Interactive Area

Each of the zones contain some type of “input area” or “zone” that the user will interact
with and these will vary, depending upon the zone:

= Click Zone: Contains a click area that covers a portion of the slide. This area
(transparent in the published project) is where the user must click to correctly
respond.

= Text Zone: Contains a text input field. The user must input the answer correctly
into this field.

= Keystroke Zone: Contains a zone that shows the Viewlet author (not the viewer)
the keys that the viewer must press in the published file to answer correctly. This
“zone” will not display in the published file.

= Pause Zone: Though not technically a zone, when this zone is inserted on a
slide, it will insert a red triangle (not viewable in the published file) in the bottom
right corner of the slide and the slide will pause.

= Question: These slides will vary in look, but they will contain some type of input

button or field to select or input an answer. These slides also contain a button to
“Submit” the input.
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You can attach audio to different parts of a zone. To see what parts support audio, click
the object and look at the Context Sensitive Toolbar. If a “sound” button displays for the
selection, then you can attach audio to it.

Response to User Input

When creating an Interactive Zone, you should offer some type of response to the user
after they’ve completed their input. In its simplest form, this response may simply be a
message object that informs the user they’'ve answered correctly. Or, it may be as
elaborate as a combination of a message that, when the user answers incorrectly, a
message appears telling them this and directing them to click a link to launch a quick
training movie before continuing or to just continue without this option, etc. The choice
as to how simple or complex the response will be is up to you. You even have the option
to remove all responses to user input as well, if you desire.

Try again, your
answer was
incomplete.

Response objects will only display when the user submits a response or the zone has
“timed out”.

To create a response message object:

= Insert an Interactive zone and, if applicable, three default response text
messages will display.

0 Green message object: This will display if the user answers correctly.

0 Lime message object: This will display if the user did not complete the
message.

0 Red message object: This will display if the user answers incorrectly.

= Select a message object and edit as you would any other message object with
regards to text and message type/style itself.

= Move and stack the messages as desired on the slide.
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To edit a response object:

You may change a response object from a message to an image or shape or none at all.
In addition, you may change how this response object responds in reaction to a certain
user action and the duration a response displays on a slide. These features are part of

ViewletBuilder6.1 Enterprise’s events/actions tools.

= Click on the “zone” area for the Interactive Zone.

= Click the Events *  button on the Context Sensitive Toolbar.

= Inthe Slide Events window, click the appropriate tab. For example, to change the
response that will display when the user answers correctly, select the On Correct

tab.

o Tirneout On Load Cn Unload on Key Pressed
On Correct on Incomplete ion Incarreck

4

= |n the Action window, edit as desired and click OK.

= Select the action to modify and click the Modify button.

» |n the Slide Events window, select another tab and repeat this process as
desired for each of the response objects.

= When complete, click OK to close the Slide Events window.

To delete a response object:
= Click the response obiject.

= Press Delete on your keyboard.

Scoring Options
Several of the Interactive Zones offer you the option of scoring user input. When

available, these scoring options include points, attempts and time to complete an
answer.

L2
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To set up scoring options for an Interactive Zone:

e ™
Score
Painks
H Total points For the question;
Y
1
Atkempks

& 5 Total number of attempts to answer question:
3 Y

.v.

[ ] Guestion can be reanswered on backwards navigation,

Time
1: i [ 1Enable a time limit for the question.
it

Hours Minukes Secands

[ oK { [ Cancel

= Click on the zone’s input or zone field.

= Click the Scoring IHI button on the Context Sensitive Toolbar.
» |n the Score window, three scoring options are available. To set:

o0 Points: Enter a number that will be used for the point value if the user
answers the question correctly.

0 Attempts: Enter a number of times the user has to answer the question
correctly. After this number is reached and if the question is not answered
correctly, it will be marked as incorrect and the Viewlet will continue.
Select the option to allow the question to be reanswered if the user
navigates backwards in the project, if desired.

o Time: To limit the amount of time a user has to answer a question, select
the Enable a time limit for the question check box. Then, enter the
Hours/Minutes/Seconds as desired.

o

= Click OK to apply the scoring options and to close the Score window.
For more information on working with Interactive Zone features covered in this chapter,
please contact support@garbon.com.
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Click Zone

The Click Zone is one of the most popular interactive zones used in ViewletBuilder6.1
Enterprise. A Click Zone may be used to increase the effectiveness of your Viewlet,
forcing the user to interact with it by clicking on a portion of the slide in order to continue.

-

2
= [ |

| Click Area

i

T

5 Mormal: the look of the area under normal droumstances

5 w .

JNSY o ZZ | oS

Rallowver: the look of the area when the mouse is over it

1 | o | Z W o

Ingert Click Zone hutton

2 E @® v = B 1

-
L]

Selected: the look of the area when the user clicks on it

o
L

o) W o

BE

(0] 4 H Cancel H Bpply

G &

This chapter highlights the Click Zone, providing information on this zone not already
covered in a previous chapter, Interactive Zones — Common Features.

To create a Click Zone:

= Click the Insert ClickZone * | button on the Object Toolbar.

» By default, a click zone area and three response message objects will be
inserted on the slide.
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To edit the click area properties:

= Double click on the click area or right click it and select Modify Click Area from
the shortcut menu.

» |n the Click Area window, you have three “states” to set up for the fill (bucket)
color and for the border (pencil) color:

o Normal: Enter a value for the fill and for the border when the mouse is
NOT over the click area in the Viewlet.

o Rollover: Enter a value for the fill and border when the cursor moves on
to the click area in the Viewlet.

o Selected: Enter a value for the fill and border when the click area is
“clicked”.

0 Select the Double Click to Select opton if you want the user to double
click (instead of the default single click) to respond correctly.

When the number is zero for any of the values, the fill/border color will be transparent.

= Click OK.

To move a click area on a slide:

= Select the click area.

= Move your cursor over the click area until the cursor changes to a hand
shape.

= Hold down your left mouse button and drag the area to its new location.

To resize a click area:
= Select the click area.

= Move your cursor over one of the grab handles until the cursor changes to a
double arrow.

= Hold down your left mouse button and resize the area as desired.
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To delete a Click Zone:

= Select the click area of the Click Zone.

» Press Delete on your keyboard.

Click Area “styles” are applied to new Click Zones.

; =
P (7 L—"."E‘.ilsf-{llﬁté]'=l!r;_|’|

Sktyleshest: | default

2

= Slide
IE Background Calar,
#FFFFFF
[ Balloon
[» Mote
[ Text Box
[ Button

[ Carrect Message
[ Incomplete Message

[» Incorrect Message

2

Click Area

wClick Area

Madify Click Area,
Mormal: 000000

......

P Juestion Text
[» Question Choice Text
£ ] i |

Marmal: the look of the area under normal circurmstances
[ ] ofs |z | 5]

Faollover: the look of the area when the mouse is over it
[ ] o) |Z= |

Selected: the look of the area when the user clicks on it

[ ] o) - | of

[ ] Double Click to Select

| OK |[ Cancel H

Apply -

Pl HM | l Lo A Ao

LA Ao = kB ol H |

For additional Click Zone features, please review the Interactive Zones — Common
Features chapter. Or, email support@garbon.com with any questions you may have.
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Text Zone

Text Zones are another popular interactive features used in Viewlets by Viewlet authors.
These zones may be added to slides when you require the user to answer questions by
inputting text responses into a field.

1"
b]
’,

|%ﬂh."- EEGEF

Insert TextZone

=

This chapter highlights the Text Zone, providing information on this zone not already
covered in a previous chapter, Interactive Zones — Common Features.

To create a Text Zone:

[EeT

» By default, a text input field and three response message objects are inserted on
the slide.

» Click the Insert TextZone button on the Object Toolbar.

To modify the text zone input field:

= Double click the text field or right click it and select Modify Text Field from the
shortcut menu.
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NEWiEeatline

e

» |n the Modify Text Field window, enter information as needed:

0 For Correct Answers — One Per Line: Input the correct answers in the
field provided. This is what the user will need to type in the field in order
to answer correctly. For multiple answers, press the Enter key between
each correct entry.

o0 Case Sensitive: By default, user may enter responses using caps or not
and the answers, if input otherwise properly, will be considered to be
correct. To force a user to use capital letters (for proper nouns, etc.),
select the Case Sensitive check box.

0 Wrap Text: Select the Wrap Text option to allow text to wrap inside the
text field.

o Password Field: To encrypt the user input while typing in the text field,
select the Password Field check box.

The Submit Key (New in ViewletBuilder6.1 Enterprise)

There is a new option available for the Submit Key. If you do not want to require the
user to press a button after typing in a response in the text field, use the new Auto
option. When selected, once the user types in a response, after approximately three
seconds, the Viewlet will automatically “submit” the input and respond accordingly.

Submit Key: |Enter

Emter
Tab
[ome

Auko

Zancel J' Il pply

0 Submit Key: Make a selection from the list. This will be what will be used
for the viewer to submit the response.

To force users to click the “Submit” button in order to submit the response, select “None”
from the “Submit Key” list.

To move the text field on the slide:

= Select the text field.

W

Mouse your cursor over the text field until the cursor changes to a hand
shape.

=  Hold down the left mouse button and move the text field to its new location.
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To resize the text field:
= Select the text field.

= Mouse your cursor over one of the grab handles until the cursor changes to a
double arrow shape.

= Hold down your left mouse button and drag the grab handle to resize the text
field.

To delete a Text Zone:
= Select the text field.

» Press the Delete key on your keyboard.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.qgarbon.com). Or, if you prefer, email support@garbon.com.
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Keystroke Zone

A Keystroke Zone may be inserted on a slide to force the user to press an individual or
combination of keys in order to continue with the Viewlet. This chapter highlights the
Keystroke Zone features not already covered in a previous chapter Interactive Zones —
Common Features.

# b

-

BE

JL.

=

H]

Insert kKeystroke Zone hutton

| [2]

I
© @

To insert a Keystroke Zone:
= Select Insert KeystrokeZone button on the Object Toolbar.

» By default, a keystroke “object” that indicates the current key the user needs to
press in order to answer correct will display along with response messages.
Double click the “keyboard key object”.
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To define the keystroke:

Right click on the keystroke object and select Define Keystroke from the

shortcut menu.

In the Define Keystroke window, follow the instructions for defining a new

keystroke or keystroke combination.

Define Keystroke

=

Define the keystroke that must be entered by the user to complete this
KeystrokeZone, It can be a single key aor combination of characters,

Ok | [ Cancel

]

Click OK to apply.

If you define a keystroke combination that is not compatible with Flash, an error will
display, warning you of the issue.

-

Error

-,

A

F10is naot a keystroke that is recognized in Flash,
Please select a different keystroke,
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Med Femre | Keystroke Zones & International Users (New in ViewletBuilder6.1 Enterprise)

New in ViewletBuilder6.1 Enterprise, if you expect your Viewlet will be viewed by an
audience whose native language differs from what you've used in your Viewlet, when
defining Keystroke Zones, a Warning window will display when a keystroke combination
possibly represents a different key combination on international keyboards. Along with
this new warning feature, you will be presented with a Safe Key List to help you select a
safer and more appropriate keystroke combination for “all” your global users.

P 1

Warning

The key stroke "CTRL + ALT + BACK QUOTE" may represent
a different key on international keyboards,

IF you expect your Yiewlet will be viewed by dients whose
native language is different from yours, ywou should stick with
the safe key lisk.

Safe Key Liskt:

Letters: &-2

MumbersL 0-9

Mumber Pad Keys

Function Keys: F1-F12, except the F10

Backspace, Caps Lock, Delete, End, Enter, Escape, Home,
Insert, Mum Lack, Page UpfDawn, Pause/Break, Print
Screen, Scroll Lock, Space Bar, Tab

Arrow keys

Please, read the EAQ For mare information,

[ ] Dan't show me this message again,

For more information on applying other Keystroke Zone features, review the Interactive
Zones — Common Features chapter. Or, email support@garbon.com.
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Pause Zone

The Pause Zone is used to pause the Viewlet on a particular slide. These zones are
easy to use on slide and are most commonly used on slides that contain hyperlinks or
buttons that allow the user to click when they decide to continue to play the Viewlet.

1 -
k - 4 =
E ,:'_ » :L.
¥ \

) — @

Want to change your life? oY

'(_-what Are Your Waiting For? Click Here Now! ) @

Insert 45

PauseZone @l

I

A

To insert a Pause Zone on a slide:
= Click the Insert PauseZone @] on the Object Toolbar.

= Ared triangle will be inserted in the bottom right corner of the slide. This triangle
indicates the slide will pause, but this triangle will not display in the Viewlet.

To move a Pause Zone in the Timeline:
= Click the Pause Zone layer to select it.
= Select the object’s “rectangle” in the Timeline by clicking on it.
= Hold down your left mouse button and drag the zone.
» Let go of the left mouse button to drop it into place.

= A Timing Rule Change window displays. Read the information and click OK to
change the timing rule to manual timing.
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Timing Rule Change

This element has the “One Frame Duration” timing rule in
place, Would you like to change it to manual trming?

[ ] Don't showe me this message again.

Eoook [ Cancel

To remove a Pause Zone from a slide:

W

= In the Warning window, select the Remove It option.

» Click the Insert PauseZone on the Object Toolbar.

f 1

Warning

This slide already contains a PauseZone,

Opkions

{*) Remaove it

() Add the PauseZane ta a new empty slide.
() Add the PauseZane ta a copy of this slide.

E ok { [ Cancel

= Click OK.

You must preview the project in a browser to view the results of the Pause Zone.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.
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Turn your Viewlet into a testing or survey tool by using Question Slides. This chapter
highlights the Question, providing information on this feature not already covered in a
previous chapter, Interactive Zones — Common Features.

What is the difference between a quiz and a survey question? A quiz question normally
requires the user to provide a correct response and is usually scored. A survey question
does not normally require a correct response and is therefore usually not scored.

To insert a Question on an existing slide:

T
= Click the Insert Question button on the Object Toolbar.

oo
(=
T

ke
@

J
-
&)
w
Llés
=
=
[“:“ ] insert Question H' ¥
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» |n the Question window that displays:

Question Type:
A
_— Short Answer - Fill in the Blank
& 'Fill in the Blank' question that has a single answer, -
Example: The square roak of &1 is . 1
Short Answer - Rating
w A question that allows the user to choose a single answer on a given scale,
Example: Rate your dining experience in Mew Yark Ciky,
1 star, 2 stars, 3 stars, 4 stars, S stars
w
Question:
Scaring Made:
(%) Quiz: Scored - Requires the user to provide a correct answer,
0 Surwvey: Mok scored - Does nok require a correct answer,
(0] 4 i [ Cancel J

0 Select a Question Type from the list.
0 Type your Question in the field provided.

o0 Inthe Scoring Mode area, select either Quiz or Survey to use for the
scoring mode for the new question.

» Click OK to insert the question on the slide.
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Question Elements

The “question type” determines the default elements of the Question zone. These
elements normally include a text box for the question, text boxes for answers in a list,
some type of “input” object for the user to click on to respond, submit button to submit
the response and response message (or image) objects.

Use stylesheets to standardize the “elements” that make up each Question zone for your
projects.

Let's take look at the different question types (in general) and their default elements. For
more information on specific question types, please refer to the “Review Question
Types” section of the Quiz Project chapter.

Choice Lists

This question type requires users to select answers from a list of choice by selecting a
radio button or check box next to each text option. The user then clicks a Submit button.
If the question is a quiz, it will be scored. If the question is a survey, it will not be scored.
So, this question type’s elements (by default) include:

Enter Question Here

o Choice 1

 Choice 2

o Choice 3

Submit
Tryagain , wour
answerwas
incomplete.

= Text box for the question

» Radio buttons for users to select an answer

= Text boxes containing possible answers

= Submit button the user clicks to submit the response
= Response message objects

You can customize the default elements of any Question to best fit your project’s needs.
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To modify the text box containing the Question zone’s question:

= Double click the text box.
» Edit the text as you would in any other message obiject.
To add additional choices:
g7

= Click the Add Choice —  button on the Context Sensitive Toolbar.

= Repeat the step above for to add each new choice.

To delete a choice option:

= Select the radio button / check box or the text box of the choice you want to
delete.

» Press the Delete key on your keyboard.

To set the correct responses:
= Select the radio button / check box next to the choice you want to set as the
correct response.
= Click the Modify Choice & button on the Context Sensitive Toolbar.
» Repeat these steps for each choice you want to set as the correct response.

= |f a choice is set as the correct response, click the Modify Choice button again
to deselect it as the correct response.

[y Each Question can contain one or more correct responses. The choice is up to you.
T

o
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To change the radio button style:

= Click on any of the radio buttons to select one.

® - " :
= Click the Choice Type button on the Context Sensitive Toolbar to display
a menu of options.

: (&) Radio Button, .. _ _
= Select Radio Button [~ " " option from the list.

Use the “Check Box” option as an alternative Choice Type for the Radio Button.

» The Radio Button Style window displays. Select a style for the radio button from
the list.

= Click OK to apply the new style.

To modify an answer text box:
= Double click the text box.

= Edit the text as you would in any other message object.

To modify the Submit button properties:

= Select the Submit button.

= Click the Button Properties I—I button on the Context Sensitive Toolbar.
= In the Button Properties window, edit the information as required.
= Click OK.

Refer to the chapter on Buttons for more information on modifying the “Submit” button.
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To delete a Question from the slide:

» Click the Insert Question =  button on the Object Toolbar.

» |n the Warning window, select the Remove It option.

f o

Warning

This slide already contains a Question,

Options

(%) Remave it.

() Add the Cuestion to a new empty slide.
() Add the Cuestion to a copy of this slide,

Eoook [ Cancel

*= Click OK

Text Input Fields

This question type requires the user to respond to a question by typing a response into a
text input field. The response is then submitted either automatically or by the user
clicking the Submit button. This question may (quiz) or may not (survey) be scored.

Enter Question Here

Submit |

Thy again, yaur
answer wWas
incamplete.

VB6.1 Enterprise User Manual Page 234 March 2009



. E
=R Y = ey 1 ¥ By e i T Tl I i".
VIIEWILE ERUITVE EROMNINELES DELiE: . (7 Usef Manualy
- — —

This question’s default elements include:
= Text box for the question
= Text input field for users type their responses in
= Submit button the user clicks to submit the response
= Response message objects
To modify the text box containing the Question zone’s question:

=  Double click the text box.

= Edit the text as you would in any other message object.

To modify the text input field:
= Double click the text input field.

» The Modify Text Field window displays. Enter information or make selections as
follows:

-,

Modify Text Field

Carrect Answers - One Per Line:

[ ]case Sensitive  Submit Key:
Wrap Text
[ ] Password Field

| K |[ Cancel H apply ]

o0 Correct Answers — One Per Line: If this question requires a correct
response, type it in this field. This is what the user will need to type in the
text input field in order to answer correctly. For multiple answers, press
the Enter key between each correct entry.

Leave the “Correct Answers — One Per Line” field blank if the Question is not scored (a
survey question).
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o0 Case Sensitive: By default, user may enter responses using caps or not
and the answers, if input otherwise properly, will be considered to be
correct. To force a user to use capital letters (for proper nouns, etc.),
select the Case Sensitive check box.

0 Wrap Text: Select the Wrap Text option to allow text to wrap inside the
text field.

o Password Field: To encrypt the user input while typing in the text field,
select the Password Field check box.

0 Submit Key: Make a selection from the list. This will be what will be used
for the user to submit the response.

The Submit Key (New in ViewletBuilder6.1 Enterprise)

There is a new option available for the Submit Key. If you do not want to require the
user to press a button after typing in a response in the text field, use the new Auto
option. When selected, once the user types in a response, after approximately three
seconds, the Viewlet will automatically “submit” the input and respond accordingly.

e [Fesire

Submit Key: |Enter

Enker
Tab
[ore

Aubo

[ Zancel Jlll PRl

# | Toforce users to click the “Submit” button in order to submit the response, select “None”
2 1® | from the “Submit Key” list.

To move the text field on the slide:

= Select the text field.

= Mouse your cursor over the text field until the cursor changes to a hand &
shape.

=  Hold down the left mouse button and move the text field to its new location.
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To resize the text field:

= Select the text field.

= Mouse your cursor over one of the grab handles until the cursor changes to a
double arrow shape.

= Hold down your left mouse button and drag the grab handle to resize the text
field.
To delete an input field:
= Select the text field.

» Press the Delete key on your keyboard.

ComboBoxes

This question type requires users to answer a question by selecting a single answer
from a list of answers contained within a drop-down list. Then the user clicks the Submit
button to submit the response. So, this question type’s elements (by default) include:

Enter Question Here
| ]

Try again, your
ANSWEr WaS
incomplete.

= Text box for the question

= ComboBox for users to select an answer from a drop-down list
= Submit button the user clicks to submit the response

= Response message objects
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To modify the text box containing the Question zone’s question:
= Double click the text box.

» Edit the text as you would in any other message obiject.

To modify a ComboBox style:

I/;\I
-
-~

= Click the Choice Type button on the Context Sensitive Toolbar.

Telv]| ComboBox,..

= Select ComboBox from the list that displays.

= Inthe ComboBox Style window, select a style from the list.

Lll ComboBox Style

Select a skyle For the ComboBox:

Classic ComboBox Skyle | - |
Mar ComnbioBox Style ||__|_';‘|]
Mac ComboEo:x Style 2 [ﬁ - ]
Windows 2000 ComboBox Skyle I j
Windows XP ComboBox Style | w |

K, | [ Cancel ] [ Apply

= Click OK.
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To set up and manage the ComboBox’s options list:
= Double click on the Combobox.

» The Modify ComboBox window displays. In this window:

=,

Modify ComboBox

Enter Yalues For the Combo Baox:

Correct | Walue
[] Apples
Pumpkins
[] EaggPlants

REINEE

Ik H Zancel H Apply

o0 Toinsert an answer:

-Click the Add i button.
-Type a value in the list area.

o0 To modify an answer:
-Select a value in the list.

-Click the Modify button.
-Edit the highlighted value.

o To set an answer as “correct”:

-Click on the check box I next to the desired value.
-Deselect the checkbox to remove the checkmark.

0 To move an answer up or down in the list:
-Select the desired value.

-Click the Move Up button to move it up in the list.

R
-Click the Move Down button to move it down in the list.
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o To remove an answer from the list.
-Select a value in the list.

-Click the Delete % button.

= Click OK to save the list and to close the window.

Ratings

e

e

ﬁ! ’
User Manuall

This question type gathers information from a user by posing a question such as “What
is your overall level of satisfaction?” In response, the user is required to click along a
“rating” scale and then click a Submit button to submit the response. This type of

question is for surveys only and not scored.

Enter Question Here

Submit

The (default) elements for this question type include:
= Text box for the question

» Rating scale the user clicks on in response to the question
= Submit button the user clicks to submit the response

To modify the text box containing the Question zone’s question:

=  Double click the text box.

= Edit the text as you would in any other message obiject.
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To change a Rating scale’s style:

= Select the Rating object to select it.

= Click the Modify Choice ﬁ button on the Context Sensitive Toolbar.

. Rating... .
»  Select Rating L= "™ | from the list.

» The Rating Style window displays. Select a new style from the list.

Select a style for the Rating:

Aicid Rating Style D D
Alien R.ating Skyle \G ﬁ \G )

Ball Rating Skyle . . . L ]

Blue Moon Rating Style J J J .

Blue Star Rating Style ﬁ ﬁ ‘f_? I

< i |

k Ik i[ Cancel ][ apply ]

» Click OK to apply it.
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To increase / decrease the rating scale:
= Double click on the Rating object.

» The Modify Rating window displays. Enter a number in the field provided for the
Maximum Rating desired.

(Modify Rating W
Maxinurn Rating: 5 {:}
ok ] [ Cancel ] [ Apply
= Click OK.

To remove a Question from a slide:

—_

* Click the Insert Question =  button on the Object Toolbar.

» When the Warning screen displays, select Remove It.

f o

Warning

This slide already contains a Question,

Options

() Add the Cuestion to a new empy slide.
) Add the Cuestion to a copy of this slide,

EoooK | [ Cancel

= Click OK to remove the Question from the slide.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@qgarbon.com.
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wed Fesie | Resize Project
(New in ViewletBuilder6.1 Enterprise)
Have you ever worked for hours on end perfecting your Viewlet only to realize its
dimensions were either too small or too big for your viewers needs? In previous
versions, when this happened, the only solution was to recreate the project from scratch
starting with the correct slide size. That's now a thing of the past!

ViewletBuilder6.1 Enterprise now offers a “Resize Project” tool that allows you to resize
your current project. You can do this directly within the project, while inserting new
screenshots, or even while importing slides from a project (whether or not the slides are
the same size as the current project). Let's take a look at how this works.

Resizing the Current Project
= Select Project > Resize Project from the Menu.

Praoject

Project Properties, ., Chrl+0

Publish Viewlet, ..

Display Publishing Prafile, .

Presview Current Slide
reviews From Current Slide  Chrl+5pace
review All Slides

review in Browser

|
|

E

E?[}} Mt Slide Ctrl+-Page Covn

Chrl+-End

Resize Project. ..

[ReA
L2 o
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» The Project Resize window displays.

o Inthe Current Project Size area, the project’s original size displays.
Review this information.

Current Project Size
Width: 800 Height: 600

0 Inthe New Project Size area:
-Enter a number for the new Width and Height in the fields provided.

-To maintain the correct ratio between the new width and height, select
the Maintain Aspect Ratio option BEFORE entering a number in either
the Width or the Height field.

Mews Project Size
Width: s00 ::: Height: a7s :::

Maintain Aspect F.atia

+# | If the “Maintain Aspect Ratio” option is selected, just enter a number in either the “Width”
T® | or the “Height” field and press the “Enter” key and number for the “other” value will
automatically be filled in the applicable field.

0 Inthe Scaling area, select one of the scaling options:

-Scale to Fit: Scales the slide background image to “best fit” the new
slide dimensions.

Scaling

(%) Scale ko Fit
() Align Slide

2]

-Align Slide: Maintains the current size of the slide’s background image
and aligns it on the new slide based on the alignment selection. Normally
used when the new project (slide) size is larger then the original project
dimensions. After selecting this option, select an alignment option from
the alignment menu.
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(%) Align Slide

IEI Center W
il I Ll N

Top Left Top Top Right
Left Cenker Right

ol (@ [d

Botkom Left Botkom Botkom Right:

» Click OK to resize the project.

If a “Warning” window displays after clicking “OK”, read the information in it and click
“OK” to close the window. Then, back in the “Resize Project” window, edit the selections
as instructed by the warning and click “OK” to resize the project.

f 1

Warning

' Tao resize your project to a size smaller than the largest background image (800 6007,
. wou must select Scale to Fit,

Did you know the “Project Resize” feature also allows you to import slides from projects

with dimensions “different” from the current, open project? For more information on this

topic, review the “Importing Slides with Different Sizes” section of the “Export and Import
Options” chapter.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@qgarbon.com.
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Medf Fesire | Crop Project

(New in ViewletBuilder6.1 Enterprise)

ViewletBuilder6.1 Enterprise now offers you the ability to crop the dimensions of your
project’s slide size. An alternative to the “Resize Project” feature, the “Crop Project”
feature will crop the project’s slide without the need for scaling the background image.
Let take a look at how this works.

Cropping the project’s slide size
@_Qf' The “Crop Project” operation cannot be undone, so make sure you create a backup copy
5

T® | of your project BEFORE you crop the original project’s slide size.

= Select Project > Crop Project from the Menu bar.

Praoject
i N

Praoject Properties. ., Chrl+0

=¥ publish viewlat. ..

Display Publishing Prafile. ..

Preview Current Slide

reviews From Current Slide  Chrl+-5Space

Ckrl+Home
Chrl+Page Up
Chrl+Page Down

Chrl+-End

= A Crop Project warning window displays. Read the information in the window and
click Yes to continue with the cropping task.
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You should save a backup copy of the project before proceeding.

': Cropping Projeck cannak be undone,

Continue?

Eooves [ Mo ]

* Inthe “Slide Edit” area, four “shaded” sections surround the current slide. The
area in the shaded portions of the slide will be “cropped” out and the areas of the
slide that are NOT shaded will not be cropped.

@ Accepk Crop w Cancel Crop | Width : 548 Height : 391

= Toresize the “crop area”, point your cursor on one of the lines separating the
shaded area and the unshaded slide area.

= When your cursor changes to a “double arrow” shape, hold down the left mouse
button and drag to resize the crop area.

= Let go of the left mouse button when you are finished resizing one of the edges
of the crop area.
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= To view the current dimensions of the new slide size as you resize the crop area,
look at the top of the slide area where the “Width” and the “Height” are displayed.

s R L A A ==

v Accept Crop %‘2 Cancel Crop | Width ; 548  Height ; 391

Displays currentdimensions of
the project slide size.

. . Q,// Accept Crop
= Once you've resized the crop area, click the Accept Crop button.

Depending on the size of the project, you may see a progress bar display the
status of the cropping operation.

5 |

Ernpplng ﬂrn]ec! E

Cropping slide 76 of 150

OO |

51% Complete

Zancel

If you decide you do not want to crop the project while viewing the shaded and unshaded
slide areas, click the “Cancel” button.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.
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The Page Layout feature is an often overlooked option in ViewletBuilder6.1 Enterprise.
The settings in the Page Layout window determine what your hardcopy and electronic
“printed” materials will look like. You can set print (page layout) options for the page
header, the layout of images on each page, what slide elements to include, page

numbers and the slides to print.

o~

Page Layout

-,

Header

Title | My Viewlet
Display date and time
Display slide border

Layout
(#) Landscape  Rows 1{
[A] O Portrait Calumns 1{
Opkions

Hidden Slides [+] Cursor

Slide Title Cursar Path
EBalloons Motes

[ ] 5lide Nates

Fooker

Page Murbers

)
)

K <K B> H
Page 1 of 1
Slides
() Current Slide
" From to
(%) All shides
[ Print ] Eoook [ Cancel

To access Page Layout:

» Select File > Page Layout from the Menu bar.

= The Page Layout window displays.

VB6.1 Enterprise User Manual

Page 249

March 2009



LEVVILE RIS S IREERIE CFLLE D RL AT (7 serMantalyl

To edit options for Page Layout:
= Open the Page Layout window.

» |n the Header area (if desired):

Header
Title |y Viewlet
Cisplay date and kime
Cisplay slide border

0 Select the Title option and type a title in the field.
0 Select the Display date and time option to add a date signature.
0 Select the Display slide border to add a border around each slide.

» Inthe Layout area:

Layouk

(%) Landscape  Rows 1
[A] O Portrait Caolumns | 1

0 Select Landscape orientation and enter a number for the number of rows
(slides) to include per page.

or

0 Select Portrait orientation and enter a number for the number of columns
(slides) to include per page.
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» |n the Options area, select the elements you want to include on the print
materials, including:

Opkions
Hidden Slides Cursor
Slide Title Cursor Path

Balloons Motes

[ ] slide Mates

Hidden slides

Slide Title

Balloons (now available in ViewletBuilder6.1 Enterprise)
Slide Notes

Cursor

Cursor Path

Notes (now available in ViewletBuilder6.1 Enterprise)

OO0OO0OO0OO0OO0O0o

Medfi [fesfivre | Balloons & Notes (New in ViewletBuilder6.1 Enterprise)
ViewletBuilder6.1 Enterprise now offers new options for printing “Balloons” and “Notes”
in the Page Layout window. If selected (Balloons or Notes), these message objects will
now be included on print materials.

* Inthe Footer area, select/deselect if you want Page Numbers to display.

= As you make selections, view the slide Preview area. Use the “VCR style”
buttons (First, Back, Next, Last) to navigate through the slides preview.

......

M ext

Back

Last

First
3 -
& < Bk =]

Page 1 of 1
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» |nthe Slides area, select which slides to print.

Slides
() Current Slide
) From ko
(=) Al Slides

0 Current Slide: Select this option to print the slide selected prior to
opening the Page Layout window.

0 From: Select this option and enter the number of the first slide to the last
slide (in the fields provided) for the “series” of slide you want to print.

o All Slides: Select this option to print all the slides in the project.
= Click OK to save these as the default options for this project. Or, click Print to

open the Print window.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@qgarbon.com.
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Printing

There may be times you want to print your slides for users to view or as reference
materials. Before you print your slides, review the Page Layout chapter for setting up
layout options for printing your slides.

To print a hardcopy of your slides:

= Select File > Print from the Menu bar.

File
ﬁ MEwW, ., Chrl+M
Tl
l_} Qpern... Chr[ 0
Recent Files [
-
l_} Close
Save As... Crrl+Shift+5

Page Layout,,, Ckrl+35hift+F

E.;] PHink. .. Chrl+P

Irnport b
Export ¢
Exit CEF[H0)

= The Print window displays. Select the options in this window for your print job as
desired.

: =
The options available in the “Print” window will vary from computer to computer.
e

= Click the Print button to print the selected slides.
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To print an electronic copy of your slides:

= Select File > Export > PDF from the Menu.

File
Dh Mew... CErlM
g
E Qpen, . k40
Recent Files [
E"‘ Close
Save
Save As... Zkrl+Shift+5
Page Layout,,,  Ckrl+3hift+P
[‘E:] Prirt... Chrl+P
Impart b
Expart b TextFor Translation...
Exit Ctrl+Q Sounds. .
FDF...
Slides to Images...
QuestionMark, .,

Publishing Locations. .

» The Export PDF window displays.

-,

Export PDF

Opkions

Slides

) Current Slide
) Fram ko

@) Al

[ Export H Zancel ]

0 Inthe Options area: Select Slide Title and / or Page Numbers if you
want to include these in the electronic document.
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o0 Inthe Slides area, select what slides to print:

-Current Slide: Select this option to print the slide selected prior to
opening the Page Layout window.

-From: Select this option and enter the number of the first slide to the last
slide (in the fields provided) for the “series” of slide you want to print.

-All Slides: Select this option to print all the slides in the project.

= Click the Export button.

= The Export PDF window displays. Select a folder to save the file in and give the
file a name.

»= Click Save. Depending upon the size of your file, a progress bar may display.
Once complete, you will be returned to your Viewlet project.

¥ | Another way to print an electronic copy of your slides is by selecting a “PDF” printer from
T® | the “Print” window, if one is available on your system.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.
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Export and Import Options

ViewletBuilder6.1 Enterprise offers various export and import options. These include:

Export Options

File
ﬁ Mew. .. Chrl+M
|
L} CIpEn. .. Chrl+0
Recent Files [
-
L} Close
Save As.., Ckrl+5hift+3

Page Layout,,,  Ckrl+3hift+P

E.;] Frint... Chrl+P

Imnpork b
Export p|  TextFor Translation, .,
Exit Chrl+y
PDF...
Slides to Images...
QuestionMark. .,

Publishing Locations. ..

= Text for Translation
= Sounds
= PDF
= Slides to Images
= QuestionMark
* Publishing Locations (New in ViewletBuilder6.1 Enterprise)
To export the project’s text for translation or other copywriting purposes:
= Select File > Export > Text for Translation from the Menu bar.

= In the Export Text window, select a location to save the file, which will be saved
in “XML” format.

Enter a name for the file and click Save.

= [f an Information window displays, click OK.
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To export sounds from your project:

= Create a folder outside of ViewletBuilder6.1 Enterprise to save the exported
sound file in.

» Select File > Export > Sounds from the Menu bar.
» |n the Export Sounds window, select what slides you want to export audio from.

= Click Export. The sound files will be saved in the designated folder with the
same file names and as the same files types as they exist in your project.

¥ | For more information on exporting sound from your project, review the chapter on
TR | “Audio”.

To export slides as a PDF file:
= Select File > Export > PDF from the Menu bar.
= Inthe Export PDF window, make selections for Options and for Slides

= Click Export.
» Inthe second Export PDF window that displays, select a folder to save the file in.

= Enter a name for the file and click Save.
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To export slides as image files:

= Select File > Export > Slides to Images from the Menu bar.

= Select Slides to Images.

* In the Export Slides to Images window in the:

-

Export Slides to Images

-~

File
Prefix Extension CQuality
Expark PG v High

Opkions

Slide Title [ ] within HTML Page

Slides
(") Current Slide
") From ko

@)l

W

[ Expork ][ Zancel

]

el

L.
serManualy

o File area: Enter a Prefix (used for beginning of file names); select an
Extension from the drop down list (this will determine the type of image
file that will be saved when slides are exported); and, if applicable, select

the Quality (for JPG files) from the drop down list.
0 Options area: Select additional options as desired.

0 Slides area: Select which slides to export as images.

-Current to search the current slide.
-From and enter a number in each of the fields provided to search from a
specific slide to a specific slide based.

-All to search all slides within the project.

= Click Export.

» |n the Save File In window, select a folder to save the image files in.

= Click Save.

VB6.1 Enterprise User Manual Page 258

March 2009



ViIEWIEERUTUE E ROMINELES DY LI,

e [Femine

Publishing Locations (New in ViewletBuilder6.1 Enterprise)
In order to resolve possible conflicts that might occur when publishing the same project

el

.

g 179
User Manualy|

from different computers, ViewletBuilder6.1 Enterprise now offers the ability to create a
file (publish.dat) to list the publishing locations available for the project. This file can be
“transported” with the source file when publishing from different computers.

To create a publishing locations data file:

Select File > Export > Publishing Locations from the Menu bar.

In the Save File In window, select a folder to save the “publish.dat” file in.

Click Save.

An Information window displays. Read the information in it and click OK.

‘f' When publishing your project from different computers, import the “publish.dat” file into
TR | ihe project while working the “different” computer.

Import Options

ﬁ Mew. .. Chrl+M

|
L} Qpen... ]

Fecent Files ]

-
l_} Close
[EI] Save Chrl+5

Save As... Zkrl+Shift+3
Page Layout,,, Ckrl+3hift+F

[‘%'] Print. . Chrl+P

Irnporkt b Import Slides...
Expart p|  TextFor Translation...
Exit Ctrl+0 | Publishing Locations. ..
Import Slides

Text for Translation
Publishing Locations (New in ViewletBuilder6.1 Enterprise)

VB6.1 Enterprise User Manual Page 259

March 2009



| VilEWVILE RN (RO SR N EKLLEA D ELE (\( Lser Manual |

To import slides (from another qvp project):

= Select a thumbnail as an insertion point for imported slides. Imported slides will
be inserted after the selected slide.

= Select File > Import > Import Slides from the Menu bar.

* |n the Import Slides window, click Browse. Locate and select a QVP file to load
into the preview window.

= Select the slide or slides to import.

e Femrz | Importing Slides with Different Sizes (New in ViewletBuilder6.1 Enterprise)
ViewletBuilder6.1 Enterprise now allows you to import slides from projects with different
slide sizes. In previous versions, if you wanted to import slides from one project into
another, the slide size had to be the same in both projects. Now, if ViewletBuilder6.1
Enterprise detects a difference in size, a Slide Alignment window displays with options
for “matching up” the slide sizes for consistency when importing slides of a different size
into your current project.

~,

Slide Alignment

The slides you hawe impaorted are a different size than
the current projeck,

Mew Size

{#) Project Size: 500 3 GO0
Resize imparked slides ko match current projeck,

) Imported Slides Size: 640 x 430
Resize current project to match imported slides.

Imported slides Alignmenk

(%) Scale to Fit
i) Align Slide

12

(8]4 { [ Cancel
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» |f the slides you select to import are a different size, the Slide Alignment window
displays requiring you to make some additional selections:

o Inthe New Size area, select:

-Project Size: This option will resize the imported slides to match the size
of the current project.

-Imported Slide Size: This option will resize the current project to match
the size of the imported slides.

o Inthe Imported Slides Alignment area, if you selected the Imported Slide
Size option in the New Size area, select an alignment option for the
imported slides:

-Scale to Fit: This option will scale the imported slides to “best fit” the
current project’s slide size and center the image on the slides.

=3’ | You must use the “Scale to Fit” alignment option if the imported slides are “larger” then
T | the slide size of the current project.

-Align Slide: This option will retain the original size of the imported
slides, but will align the image on the slide based on your alignment
selection.

» Click OK and the slides will be imported into the current project.

To import text for translation:
= Select File > Import > Text for Translation from the Menu bar.
= The Import Text window displays. Locate the text translation XML file. This is the
file previously created from this Viewlet when using the “Export > Text for
Translation” option.
= Click Open.

» |f an Information window displays, click OK.

¥ | In order to use the “Import > Text for Translation” option, you will have to create an XML
2 T® | file for this SAME Viewlet using the “Export > Text for Translation” option.
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Publishing Locations (New in ViewletBuilder6.1 Enterprise)

In order to resolve possible conflicts that might occur when publishing the same project
from different computers, ViewletBuilder6.1 Enterprise now offers the ability to create a
file (publish.dat) to list the publishing locations available for the project. (See the “Export
Options” section of this chapter for information on creating a “publish.dat” file.) This file
can be “transported” with the source file when publishing from different computers.

e [Femiure

To publish a project from a different computer using the publish.dat file:

= Select File > Import > Publishing Locations from the Menu bar.

= The Import Publishing Locations window displays. Click the Browse “~ button.

» Locate the publish.dat file previously created when working on your project on
the original computer used to publish it.

In order to use the “Import > Publishing Locations” option, you must first create a

Q _“; “publish.dat” file on the computer the project was originally published from by using the
=2 “Export > Publishing Locations” option.

= Click Open.

= Back in the Import Publishing Locations window, a list of available publishing
locations display. Select the publishing location to use to publish the project by
clicking the check box next to the desired location.

P S

Import Publishing Locations

Flease select a publishing locations file ko import

C:Qarbontpublish, dak

L{l> Qarbon YiewletCentral

Publish ywour Wiewlet to Qarbon WiewletCentral For Free,

= Desktop
' CH\Docurents and SettingsikathyDeskiop

My ¥Yiewlets
' CH\Docurients and SettingsiKathy\ My Docurmentsi My Viewlets

O
[ = Library

IE_/' CDocuments and Settingsikathyd My Documentsi iy Yiewlet Assets Library
0

il l [ Cancel
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» Click OK to import the selected publishing locations in ViewletBuilder6.1
Enterprise to use for the current project.

Once you’'ve imported the desired publishing locations for your project, click the “Publish
Viewlet” button and the selected publishing locations will be available in the “Location”
list.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@qgarbon.com.
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Project Properties

ViewletBuilder6.1 Enterprise allows you to set up default properties for all of your Viewlet
projects. These project properties may be modified on a project per project basis. The
project properties set up in the Project Properties are used when the project is
published.

Project  Help
] C@ Project Properties, .. Ckrl+r

il

| @'-"' Publish Viewlet, ..

Project properties include:

Viewlet Profile
Sound Quality
Image Quality

= Timing

Viewlet Options
Scoring Options
Packaging
Language
Flash
ViewletSkin
HTML Frame

To set up project properties:
= Select Project > Project Properties from the Menu bar.

» |n the Project Properties window, set up options for your project as needed.

To save project properties as default settings:
= Select Project > Project Properties from the Menu bar.

» |n the Project Properties window, edit the properties as desired.

[ Save fs Defaulk Properties

= Click the Save as Default Properties button.

= Click OK to close the Project Properties window.

Q ¥ | The ”Save As Default Properties” button does NOT save other changes to the project, only
P, T® | edits made in the “Project Properties” window.
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Viewlet Profile — Project Properties
Information entered in the Viewlet Profile section of the Project Properties window will be

embedded into the Viewlet.

&

Project Properties m
: . Please provide the Following information bo be embedded into the Wiewlet,
@ Wiewlet Profile
Wigwlek
E':!] || Sound Quality Title: Qarbon Tour
Image Quality Descriplion: | T2ke & tour of Qarbon's products and
X services.
@ Timing
" Wiewlet Options
Scoring Options
| = | Packaging
d Author
& Language Mame: |
€D Fiash Email |
@ WiewletSkin omments:
@ HTML Frarne
Company
Campanty': |Qar|:u:|n |
Department: |'v'iew|et Creakion Services |
Web Site: |www.qarban.cam| |
[ Save As Default Properties ] [ (0] 4 ] [ Cancel ]
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To set up Viewlet Profile details:
= Select Project > Project Properties from the Menu bar.

= Select Viewlet Profile from the left navigation menu.

In the Viewlet area:

= Enter a Title. This information will display in the browser’s title bar when the
Viewlet is played back and will also be included in the Viewlet's metatag
information.

W (S)r—f=E= 3| 44 | »

» Enter a Description. This information will be included in the Viewlet's metatag
information.

In the Author area:
= Enter an author Name.
=  Enter an Email.

= Enter additional Comments.

Use the “Author” information to promote your Viewlet. The author’s name, email and
comments display Viewlet's information window.
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viewletBuilders Enterprise 6.1.4

Dynamic Viewlets
sales@agarbon.com
Qarbon

Take a tour of Qarbon's products and
Services.

wiewlet is a trademark of Qarbon.com Inc.

| X

In the Company area:
= Enter a Company name.
= Enter a Department.

= Enter a company Web Site.

VB6.1 Enterprise User Manual Page 267

March 2009



WALEVVILE PTG ROEETC KLLEA K Lt _ (\( serManualy

Sound Quality — Project Properties

The sound quality selected in the Sound Quality section of the Project Properties window
will be what is used when the Viewlet is published.

-

Project Properties

-

ljj Wienlet Profile
IZ;I Sound Quality
\EI Image Quality
() Tining

Wiewlet Options
Iﬁ‘ Scoring Options
¥ Packaging
4 Language
@ Flash
|§U WiewletSkin

Ll!é’ HTML Frarne

Choose the sound quality bo apply ko this Wiewlet,

) €0 quality

Enables superior sound quality, Recommended for music and subtler audio effects but
increases the file size considerably, The size of the Yiewlet will increase considerably.

(*) High quality

Enables sound effects and high quality woice-overs, Target audience should have iDSL lines
or access bo a corporate network, Reasonable For iDSL lines or corporate network,

() Standard quality

Recommended For reqular Wiewlet voice-overs, Keeps file size low and is acceptable For most

bandwidth,
3 Strip all sounds

The Viewlet will be exported without sound, The audio files, howeswer, will remain a part of

the project file,

[]use steren sound {default).

Save As Defaulk Properties ][ (0] 4 H Cancel
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To select Sound Quality options:

= Select Project > Project Properties from the Menu bar.
» Select Sound Quality from the left navigation menu.
= Select one of the sound quality options:

0 CD quality: Highest sound quality option, which is recommended for
music and subtle audio effects. Results in biggest file size.

o0 High quality: This is the second best sound quality choice, which is
suitable for good qualify audio effects and high quality voice-overs. Best
choice for viewers using high speed or network connections.

o Standard quality: This is the third best sound quality choice, which is
recommended for average voice narration quality. Results in lowest file
size possible (with projects containing audio) and is suitable for most
bandwidths.

o Strip all sounds: Removes all sound when publishing the project.

0 Use stereo sound (default): Publishes audio using “stereo” quality
sound, if applicable.

¥ | The sound quality selection you make in the “Project Properties” will not affect the sound
2 T® | in the “pre-published” source qvp file.
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Image Quality — Project Properties

The image quality select in the Image Quality section of the Project Properties window
will be the setting used when the Viewlet is published.

i =y

Project Properties

Choose the image quality For the Yiewlet,

lﬁj Wiewlet Profile
() Highest: quality

%I Sound Cuality Ideal For photographic quality.
Most suitable For DSL and broadband and <0 distribution.
e lit:
EI mage Qualiy (%) High quality
:,3:- | Timing Ideal for showing graphic design software and lossless images.
ot Most suitable For DSL and broadband.
Wiewlet Options ) Medium quality
ﬁ Scoring Options This default setting is ideal for all professional training, support and online help content.
) Suitable For all types of connections,
| = | Packaging
= ) Low quality
€ Language Creates smaller file sizes by reducing image quality, May not be suitable For professional
demonstrations.
@ Flash Optirized far dial-up or 1508 access,
||:|_ Wiegwletskin

L@ HTML Frarne

Save As Defaulk Properties ][ (0] 4 ][ Cancel

To select Image Quality options:
= Select Project > Project Properties from the Menu bar.

= Select Image Quality from the left navigation menu.
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» There are several image settings to choose from. Select the radio button next to
the image quality of your choice:

0 Highest Quality: This option is best suited for photographic quality
images, but results in the biggest file size.

o0 High Quality: This selection is recommended for images created in
graphic design software and for lossless images. Results in a file size
best suited for high speed connections.

o Medium Quality: This is the default setting for all professional training
and online help content. Acceptable file size for most connections.

o0 Low Quality: This selection creates the smallest file size by reducing the
image quality as much as possible. Not recommended for professional
demonstrations, but is optimized for dial-up connections.

2 | The selection made for image quality in the “Project Properties” window will not affect the
TW | image quality of the source file.

o

VB6.1 Enterprise User Manual Page 271 March 2009



ILEBEIENITE]E [ROERI B E FLL el b (\( LSEr Wianual |

L

Timing — Project Properties

In the Timing section of the Project Properties window, you can set minimum defaults for
timing features throughout your project. These settings serve as a baseline for your
project and may be modified on a slide-per-slide or object-per-object basis, where
applicable, as needed.

Project Properties

[ﬁj Viewlat Brafile Minirmum Message Duration

Enter the minimurn amount of time a message should be displayed, regardless of its

[;'!I Sound Quality contents, The Minimum Message Duration will only be applied if the message timing rule is
Reading Speed.
~ [ Image CQualic
@] Image Quaity 1005 seconds
{3’1 Tirning

Reading Speed
Wigwlet Options sl Spee

The reading speed adjusts how long balloons and notes are displaved, Average user
ﬁ Scoring Ciptions reading speed is around 200 words per minuke,

200 5| words per minute

¢ Packaging
< Language Cursor Speed
@ Flash Select the speed of the cursor to control the tempo of your Viewlet,
|§U WiewletSkin ey el
LG;E—; Al ST Introductory Delay

add an introductory delay before Balloons and Motes are added ko a slide.

1.0 seconds

b

Timing Links
Ensure timing links are added between elements as they are added to the slide. This will
maintain propet timing on the slide as it is edited.

Mainkain Tirming Links

Save As Defaulk Properties ][ (0]4 ][ Cancel

To set up Timing options:
= Select Project > Project Properties from the Menu bar.

= Select Timing from the left navigation menu.
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In the Minimum Slide Duration area:

= Enter a value for the minimum number of seconds a slide will be displayed.
In the Reading Speed area:

= Enter a default reading speed (words per minute) for your project.

f' Changing the reading speed maintains the timing on slides, including manual gaps added
- 1® | at the end of the slide.

In the Cursor Speed area:
= Select a default cursor speed from the drop down list.
In the Introductory Delay area:
» Enter a default delay (in seconds) before a message object is displayed.
In the Timing Links area:
» Select the Maintain Timing Links check box to automatically add and maintain

timing between elements along the Timeline while editing a project. For more
information on “Timing Links”, see the Timeline Tab chapter.

VB6.1 Enterprise User Manual Page 273 March 2009



ILEBEIENITE]E [ROERI B E FLL el b (\( LSEr Wianual |

L

Viewlet Options — Project Properties

In the Viewlet Options section of the Project Properties window, you may set up
additional miscellaneous features for your published Viewlet.

Project Properties

Login Opkions

ljj Wiewlet Prafile
|:| Require Yiewers to Login
I:;,\I Sound Quality

| Image Quality

:._': 1] Tirming

[] viewlet Password:

Display Cptions
[] bisplay Table of Contents

o Migwlet Options
] ] Mewy Status Bar Options include:
£ 5| Seoring Options [] Display Score Panel an Last Slide of Viewlst | -Display Quiz Pogress
_ ) -Display Quiz Seore
(2 Packaging Display Player Bar -Display Time Remaining
& Language Display Status Bar
@ - Display Quiz Progress - Requires at [east one question slide.
Flas
Faor Example: "Progress 3 of 10"
] | WigwletSkin Display Quiz Score - Reguires at least one scored guestion,
L@ e For Example: "Score 75 of 100"

Display Time R.emaining - Requires Time Limit to be set in Scoring Options,
Faor Example; "Time Remaining 00:32:54"

se hand cursar For OnClick events

[] Use hand cursor For ClickZanes

Soundtrack

Select a sound to play in the background of your Yiewlet,

(i

Save As Defaulk Properties ] [ [u]4 l [ Cancel ]

To set up Viewlet Options:
= Select Project > Project Properties from the Menu bar.

= Select Viewlet Options from the left navigation menu.
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In the Login Options area:
= Select the option to require viewers to login before viewing your Viewlet.

= Select the password option and enter a password (that you will provide to
viewers) in the password field.

In the Display Options area:
= Select the option to display Table of Contents when the Viewlet is viewed.
Status Bar Options (New in ViewletBuilder6.1 Enterprise)

There are now additional options (new in ViewletBuilder6.1 Enterprise) to select if you
select the Display Status Bar option in Project Properties window.

Cisplay Status Bar

Display Progress
Display Score

Display Time Remnaining

= Select a Status Bar to be displayed as the Viewlet is playing. Select additional
options for the status bar as desired:

o0 Display Quiz Progress: Displays progress of the Viewlet as it plays.
Requires at least one question slide.

o Display Quiz Score: Displays the current score. Requires at least one
scored question.

o Display Time Remaining: If the Viewlet is set with a time limit, the
remaining time displays.

= Select the display score option if you want the “final” score displayed at the end
of the Viewlet.

= Select the options for when the hand shape cursor is displayed for OnClick
Events and ClickZones
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In the Soundtrack area:

= Click the Load Soundtrack “— button to locate and select a sound file that will
play in the background when the Viewlet plays.

= Toremove a soundtrack, click the Delete Soundtrack % button.

The Viewlet’'s background soundtrack will continue to play asynchronously even if the
slide contains an interactive zone.
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Scoring Options — Project Properties
The Scoring Options section of the Project Properties window offers scoring selections

for your Viewlet project.

-

Project Properties

-,

8ij Wienlet Profile
E—i] 11 Sound Quality
@I Image Quality
(é. Timing

L Wiewlet Options
Scoring Options
Gz Packaging
4 Language

@ Flash

|| iewletSkin

Scoring Options
[ rass | Fail =:
[] Time Limit:
Allowe Repeat

Actions to perfarm when the Yiewlet time limit is reached.

Ackion

=[P

['fq

>

<]

Save As Defaulk Properties ] [

0K ] [ Cancel

In the Scoring Options area:

» Select a Pass / Fail percentage and its value in the field provided.

= Limit the amount of time the viewer has to answer a question in the fields

provided.

= Select Allow Repeat if you will allow the viewer to play the Viewlet again.

You can set a global “on time out” event by selecting an action to occur in the “Actions to
perform when the Viewlet time limit is reached” area of the Scoring Options section. The
action triggers when the Viewlet’s global time limit is reached.
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Packaging — Project Properties
The Packaging section of the Project Properties window offers additional publishing
selections for your Viewlet project.

Project Properties

Standalone Projeckor

'Ei'j Wigwlet Profile
Standalone Projectors will disable reporting.,
I%] Sound Quality

[] create an executable file Far Windows ( exe)
| Image Quality [] Create an executable file For Linus: el

g Timing [] create an executable file For MacOs | hgs)
=

Sy Wigwlet Options
E Scaring Options Miscellaneous

L2 Packaging [] create a zip file

= Language

@ Flash

D_t WigwletSkin

L@ HTML Frame

[ Save As Defaulk Properties ] [ (04 ] [ Cancel

To select additional Viewlet file Packaging options:
= Select Project > Project Properties from the Menu bar.

» Select Packaging from the left navigation menu.
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In the Standalone Projector area:

= Select options for creating “standalone Viewlets” that play in their own viewer
(according to the operating system selected).

= Select the Play executable file fullscreen if you want the standalone Viewlet to
launch fullscreen (filling the entire viewing area of the user’'s monitor) when
played.

In the Miscellaneous area:

= Select the Create a zip file option to create a copy of the Viewlet files contained
in a zip file.

VB6.1 Enterprise User Manual Page 279 March 2009



vIIEeWIe R UTE E RONINEVILE: D tde: ; (7 Wﬁgr'ﬂ‘.‘ﬂélinralfl

Language — Project Properties

In the Language section of the Project Properties window, you may set default language
preferences for your Viewlet.

-,

Project Properties

Ejj Wiewlet Profile ¥iewlet language

By default, ViewletBuilders localizes the Viewlet elements using the language selected in the
Q] Sound Quality preferences dialog. To change the default compiling language, make another selection from
the drop down menu,

@I Irnage Quality Enilish [V]

[) Timing
h You can override the Following default values For the selected language.

@ Wiewlet Options -
Login Panel

ﬁ Scaring Opkians Login Liogin

Ca9 Packaging Llsername Username
== Language Password Password
84 Ik
@ Flash Incorrect Password Incorreck Password
D_ WiewletSkin Table of Contents Panel =
—1 HTML Frame Table of Contents
Pts
Results Panel
Resulks Results
Carreck Zarrect
Incarreck Incaorreck
Atternpts atkempks
Passing Score Passing Score
Your Scare Your Score [v
Save As Defaulk Properties ] [ (0] 4 ] [ Cancel ]

To set up Language details:
= Select Project > Project Properties from the Menu bar.

= Select Language from the left navigation menu.
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In the Viewlet language area:

= By default, the compiling language used by ViewletBuilder6.1 Enterprise is the
same as your computer’s operating system. To change it, select a new language

from the list.
To change default language or text details for various Viewlet panels:

= Login Panel: If you require viewers to log into the Viewlet, you can change the
text displayed in the login panel in the fields provided.

= Table of Contents Panel: If you choose to display a Table of Contents with the
Viewlet, you may edit this panel’s text in the fields provided.

» Results Panel: If your Viewlet is scored, you may modify the text that displays in
the results panel in the fields provided.
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Flash — Project Properties

In the Flash section of the Project Properties window, you may set up your default Flash
settings for your Viewlet.

-,

Project Properties

— i ' =]
E‘ij Yiewlet Profile Sfee: 100.0%

J, Width  800[%| Height = &00%] [ Scale ToFit Web Page
I'{] Sound Quality

| Image CQuality Cptions
) Timing [] campress Mavie [] Reduce Flash Cantext Menus
=
[] Loop Mode [[] Rapid Fading Effects an Messages

W Wiewlet Options

Iﬁ‘ Scoring Options

[]Local Access Mode [ Disable JavasScript to Flash Interface

| -:p-’l Pack,agmg Preloader

€ |anquage [] bisplay & waiting animation while the Yiewlet is being loaded.
@ Flash

5 Wiegwletskin

Animated Extras
Attach Flash (SWF) movies to the beginning or the end of the Viewlet.

Beaqinning I %

Ending n_1 %

Save As Defaulk Properties ][ (0] 4 H Cancel

To set up Flash defaults:
= Select Project > Project Properties from the Menu bar.

= Select Flash from the left navigation menu.
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In the Size area:

» Enter a value for the final Width and Height of your SWF file, or

» Select the Scale to Fit Web Page option.

In the Options area:

= Select additional options for your Flash file including:

0 Compress Movie: Recommended for smaller file size.

e

ﬁ! ’
User Manuall

0 Loop Mode: Recommended for tradeshow Viewlets to play continuously.

0 Reduce Flash Context Menus: Displays abbreviated right click Flash
shortcut menu options.

0 Rapid Fading Effects on Messages: Fades message objects in / out on

slides.

o Local Access Mode: Allows Viewlet to have access to local files.

Disable JavaScript to Flash Interface (New in ViewletBuilder6.1 Enterprise)

If your Viewlet contains JavaScript function, they may conflict with Flash. Now, in
ViewletBuilder6.1 Enterprise, you now have a feature (found in the Project Properties
window in the “Flash” section) that will allow you to avoid such conflicts by selecting the
Disable JavaScript to Flash Interface option.

Options
[] Compress Movie
[ ] Loop Mode
[ ]Local Access Made

[ ] Reduce Flash Context Menus

[ ] Rapid Fading Effects on Messages

Disable JawaScript ko Flash Interface

o Disable JavaScript to Flash Interface: Select this option if your Viewlet
contains JavaScript functions that might conflict with the Flash interface.
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n the Preloader area:

= Select Display a waiting animation while the Viewlet is being loaded option
is you want a Preloader animation to display while the Viewlet streams in the
background.

= If a Preloader is selected, select how long the Preloader will “wait” by selecting a
radio button next to the desired option.

In the Animated Extras area:

* To display a SWF movie before the Viewlet plays and/or after the Viewlet is

]

played, click the Load Movie ' folder next to the Beginning and/or Ending
field. Locate the SWF movie, select it and click Open.

»= To delete a Beginning and/or Ending SWF movie file, click the Delete Movie &
button next to the Beginning and/or Ending field.

VB6.1 Enterprise User Manual Page 284 March 2009



'h.r

ViewletBundenoNINEnterprise

/ﬂ' fml:]l'llt'll
ViewletSkin — Project Properties

In the ViewletSkin section of the Project Properties window, you may select a wrapper
that will display around your Viewlet.

~.

-
Project Properties E
= ) WiewletSkins allow wou ko personalize your Yiewlets look and Feel
gj Wiewlet Profile
|Blue.qukin M
E—i] 11 Sound Quality
( Preview | & |
Image Quality . ﬁ
ol [
(4) Timing =
4" Wiewlet Options |2
Scoring Options = —_—
" ‘ - ‘ Tlmam&.a.nu.ﬁl - ‘ “ ‘ b
-] Packaging b = =k =
4 Language
Options
@ Flash Use Embedded Fonts
|| MiswletSkin Embedded fants insure that the Yiewlet laoks the same acrass all platforms, however it wil
increase the size of the Yiewlet,
L@ HTML Frarne
Save As Default Properties ] [ (0] 4 ] [ Cancel
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To select a ViewletSkin:
= Select Project > Project Properties from the Menu bar.
= Select ViewletSkin from the left navigation menu.
= Select a ViewletSkin from the list. Once a skin is selected, you may preview it in

the preview area below the list.

e Fesiire | ViewletSkin Embedded Fonts (New in ViewletBuilder6.1 Enterprise)
To insure your Viewlet “looks” the same across multiple platforms, ViewletBuilder6.1
Enterprise has a new feature that allows you to use “embedded fonts” in your
ViewletSkin. This feature will standardize the look of your Viewlet across platforms, but
will also significantly increase the size of your Viewlet file.

To embed fonts in your ViewletSKin:
= Select your ViewletSkin from the available list.

= Inthe Options area, select the Use Embedded Fonts option to embed fonts in
the selected ViewletSkin.

Options
Use Erbedded Fonts

Embedded fonts insure that the Yiewlet looks the same across all platforms, howewer it wil
increase the size of the Wiewlet,
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HTML Frame — Project Properties

In the HTML Frame section of the Project Properties window, you may choose and
modify the HTML Frame that is published with your Viewlet.

-
I
Project Properties
== ) Select the HTML Frame that is published with wour Wiewlet,
tjj Wiewlet Profile
] |Standard.qframe M I:E:I & g\:g
I%I 11 Sound Quality
Files
<= | Image Qualit
98 Qualkey .ﬂ FVIEWLET_MAMES wiewlet _swF. bl
T
(& Timing
4 || FlashTag.js
07 Yiewlet Options
Scoring Options
(zd Packaging 1Y
€ Language <IDOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Trans®) o
$FILE HEADERS
@ Flash - S
<html> —
|:|_ Wiewletskin <head> /
<titler»§VIEWLET TITLE§</titlex | ——
L@HTML Frame <meta name="Keywords" content="§{VIEWLET EEYWCR %
<meta name="Description®” content=" SUIEDILET_DES N
§VIEWLET HEAD TAGH
— |
<3cript language="Javalcript”™ src="FlashTag.]js
</ head:>
<body hgoolor="#ffffff" SVIEIJLET_BODY_ATTRIBUTE i
CCENLEL>
<script language="Javaicripc™>
(]
[P
< | m | [*]
Save As Default Properties ] [ (0] 4 ] [ Cancel ]

To select HTML Frame options:
= Select Project > Project Properties from the Menu bar.

= Select HTML Frame from the left navigation menu.
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To select the frame that is published with your project:

= Inthe HTML Frame section of the Project Properties window, select a default
frame from the list.

=  The frame will be added to the Files field area below the list.

To add a custom frame:

In the HTML Frame section, click the Add I{I'j button.
»= |Inthe HTML Frame Properties window, enter a Name for the new frame.
= Click OK.

= Double click inside the “coding” field area. In the Resource Properties window
that displays, edit as needed.

= Click OK.

To edit or delete an HTML frame:
= Select an HTML Frame from the list.

= To modify an HTML Frame:

0 Click the Modify button.
o0 Inthe HTML Frame Properties window, edit the Name and click OK.
o0 Double click in the “coding” field.

0 Inthe Resource Properties window, edit as needed and click OK.

= To delete an HTML Frame:

o Select a frame from the list.

o Click the Delete % button.
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A warning displays if the HTML Frame entry point is not set correctly.

To Save Project Properties
Once all of the options are set up in the Project Properties window, click OK.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.
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Previewing a Viewlet

There are various ways to preview your Viewlet project. For example, any place you see
these buttons:

K <« B> B

You may use them to navigate through your project while inside ViewletBuilder6.1
Enterprise. These buttons will allow you to go to the:

K

First Slide

«

= Previous Slide

P

Next Slide

B

Last Slide

You can preview the slide background soundtrack, audio attached to objects, cursor click
sounds and key click background frame sounds within ViewletBuilder6.1 Enterprise
without publishing the project.

Additionally, you may access preview options:
From the Timeline:
[@ Preview Current Slide

] @ Presdew From Current Slide  Chrl+-Space

= Click the Preview button at the top right of the Timeline to preview the project, or

= Click the down arrow and select a preview option from the menu list.
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From the Menu bar:

Praoject
E@ Project Properties... ChElHHM

A
D@ﬂ Publish Wiewlet, ..

[é] Preview Current Slide

@ Preview Fram Current Slide  Chrl+Space

[@ Preview All Slides

T q q
Lfn | Preview in Browser
o

il

= Select Project from the Menu bar.
= Select a preview option:

o Preview Current Slide: Plays the current slide inside ViewletBuilder6.1
Enterprise.

o Preview From Current Slide: Plays the project inside ViewletBuilder6.1
Enterprise from the selected slide to the end of the project.

o0 Preview All Slides: Plays the entire project while inside
ViewletBuilder6.1 Enterprise.

o Preview in Browser: Quickly compiles (publishes) the file to SWF
(Flash) format and launches it (from a temp folder) in a browser.

@:‘_‘g Displaying the informational “About” window during Viewlet playback pauses the Viewlet.
£ Closing the window returns the Viewlet to play mode.
After publishing a project:
= Select Project > Publish Viewlet from the Menu bar.
= Complete the information in the windows that display to publish your project.

= In the last Publish Viewlet window, click the View button to preview the published
Viewlet.
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Outside of ViewletBuilder6.1 Enterprise:
Once you've published a Viewlet file, a folder containing the published files is created.

Locate this folder and open it. Double click the HTML or the SWF file to preview the
Viewlet.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.qgarbon.com). Or, if you prefer, email support@garbon.com.
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Publishing a Viewlet

In order to create the final Flash Viewlet your audience will see, you must publish your
Viewlet source (qvp) file. ViewletBuilder6.1 Enterprise allows you to publish your
Viewlets to a several locations, some are preinstalled with the program while others you
can add to the list.

Location Cie
Specify the location to publish your Viewlet,

My Wiewlets A
CADocuments and Settingsikatbyi My Documentsiiy Viewlets
4

< Back |k Mesxt = i[ Cancel J
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To add a publishing location to the list:

= Click the Add iy button.
= Select a location type from the menu list that displays:

|~ Add Local or Mebwork Falder...
[l add FTP Server...

&% add Qarbon YiewletCentral, .
(% Add Corporate WiewletCentral. .

0 Local or Network Folder: This includes your hard drive, a network drive,
or any other external file storage device (such as a floppy disk, CD, jump
drive, etc.).

o FTP Server

o0 Qarbon ViewletCentral

o Corporate ViewletCentral

= If, for the publishing location you select:

0 Add Local or Network Folder: This includes folders on your hard drive,

a network drive or any other external file storage device (floppy disk, CD,

jump drive, etc.).

-In the Select Folder window, locate and select a folder from a local or
network drive.

-Click the Select Folder FIeE AR button. You will be returned to

the Publish Viewlet window and the new local or network folder will be
displayed in the “Location” list.

‘f' When selecting a publish folder, if an “Allow Publishing to Folder” window displays, read
2T | the information and click “Yes” to create the location.

-,

Allow Publishing to Folder

] This Folder does not allowe publishing.
‘““(j Allow viewlets to be published ko this folder?

Eoves [ Mo
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o0 FTP Server: The FTP Server window displays. Make sure the required
fields and selections are complete:

-Name: This is the name that will display in the “Location” list for the FTP
Server.

-Server: This is the path to your FTP Server. (for example:
ftp.garbon.com).

-Directory: This is the folder on the server where you will publish your
files.

-Login: Enter the login information for your server.

-Password: Enter the password required to access your server.

-Port: This is the port used by the server, by default it is “21”.
-Passive: Select the Passive mode is required to get through some

firewalls option is your server is behind a firewall.

When configuring an FTP Server for a publishing location, click the “Text Connection”
== button. An information window will display letting you know if the connection passed.

-

{-FTPl Server

FTP Server
Specify an FTP server to publish viewlets ko,

Marme: Wiewlet Publishing Location
Server: Fep. mywiewlet, com
Directary:

Login: jdoe

Password: esssss
Part: 21

Passive: Passive mode is required to get through some Firewalls,

[ Test Conneckion,..

[ Ok l [ Cancel

-Click OK to save the information. The FTP Server will be added to the
“Location” list in the Publish Viewlet window.
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0 Qarbon ViewletCentral: The Qarbon ViewletCentral window displays.

Fa <

Qarbon ViewletCentral

Qarbon YiewletCentral r?l

Specify wour account information or create a new account,

Congratulations, you have chosen Qarbon YiewletCentral to publish your Viewlets!
YWiewletCentral is the easiest, most rewarding way ko publish, manage, and track
vour Viewlets, Tell Me More, ..

Email &ddress;

Passwiord;

If wou losk your password, go ba the YiewletCentral Login Page and Fill in the losk
password Form,

e Get the power of YiewletCentral.
'ﬂ} Create an account now and start publishing immediately.

[ (84 H Cancel ]

-In the Email Address field, type in the email address used when signing
up for Qarbon ViewletCentral.

-In the Password field, type in the applicable password to sign into
ViewletCentral.

-Click OK to save this information. The Qarbon ViewletCentral publishing
location is added to the list in the Publish Viewlet window.
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o0 Corporate ViewletCentral: The Corporate ViewletCentral window
displays. This option is available to organizations who subscribed for a
Self-Hosted ViewletCentral. Fill in the following fields with information
provided by your ViewletCentral Administrator:

-In the Name field, type in the name of the ViewletCentral account.
-In the Server field, type in the server information.

-In the Login field, type in the login used to access ViewletCentral.

-In Password field, type in the password required to access
ViewletCentral.

-Click OK to save the information. The Corporate ViewletCentral
publishing location is added to the list in the Publish Viewlet window.

[ o

Corporate ViewletCentral
Corporate ViewletCentral firiery
Specify your Corparate YiewletCentral account information, L—)

If wour arganization has subscribed For a Private Self-Hosked YiewletCentral, ywou
may now join ik, You should have received From the ViewletCentral Administrator
the required information, including your login and password,

To start experiencing the power of WiewletZentral, enter this information now,
Marme:
Server:

Login:

Passwiord:

Ok d [ Cancel
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To edit a publishing location:

= Select the desired location from the list.

4

= Make edits in the windows that display as needed.

= Click the Modify button.

= Click OK to save edits and to return to the Publish Viewlet window.

To move a publishing location up or down in the list:

= Select the desired publishing location.
= Click the Move Up button to move the selection up in the list.

= Click the Move Down button to move the selection down in the list.

To remove a publishing location from the list:

= Select the desired publishing location.

= Click the Delete % button.

= A Warning window displays. Read the information and click Yes to confirm the
deletion. The selection is removed from the list.

[ =
Warning
M_?(}. Are you sure you want to delete this publishing location?
Yes [ Ma
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= | If youremove all of your publishing locations, the next time you try to publish your
1-;&-;[ project, you will be prompted to add a new publishing location.

P S

Warning

! E ou musk add and select a publishing location Firsk,

To publish a project to a local or network folder:
= Make sure you've completed all your edits and save your file.
= Select Project > Publish Viewlet from the Menu bar.

= The Publish Viewlet window displays. Select a local or network publishing
location from the “Location” list.

= Click Next.
= Select a “Reporting” or “Learning Management System” from the list:

0 None: Select this option if you do not have any reporting or LMS options.

Select a Reporting or Learning Management System;

ﬁ Mone lv.

0 Qarbon Email Reporting System: Select this option to have an email of
Viewlet results sent to the email or emails specified.

-Enter an email address in the field provided.

-Select HTML Format to send the email results in HTML format.

Select a Reporting or Learning Management Syskenm:
s | Qarbon Email Reparting Systemn

Email address to which resulks are sent:
aname@emailaddy.cu:um;annthername@emailaddyz.u:u:um|

Separate multiple email address with commas.

Herml Forrmat
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When using multiple email addresses, separate each email with a semi-colon.

SCORM 2004 Learning Management System: Select this option to publish files to
meet SCORM 2004 compliancy for your LMS.

Select a Reparting or Learning Management Syskem;

ﬂ SCORM 2004 Learning Management Systen A

Create a zip file Mew "Iip file" option when publizhing to & SCORM 2004 LMS.

Create a ZIP File for SCORM 2004 LMS (New in ViewletBuilder6.1 Enterprise)
When publishing files to a SCORM 2004 compliant LMS, you now have the option to
allow ViewletBuilder6.1 Enterprise automatically create a zip file with all the published
files you will need for the Viewlet to play back on your LMS.

-Select the Create a zip file option to have ViewletBuilder6.1 Enterprise
create a zip file containing copies of all of the published files when using
the SCORM 2004 LMS option.

0 SCORM 1.2 Learning Management System: Select this option to
publish files to meet SCORM 1.2 compliancy for your LMS.

Select a Reporting or Learning Management System:

ﬂ SCORM 1,2 Learning Management System W

Create a zip file *_ Mews "Zip file” option when

[]Include Saba compatibility Features publishing to a SCORM 1.2 LMS.

Create a ZIP File for SCORM 1.2 LMS (New in ViewletBuilder6.1 Enterprise)

When publishing files to a SCORM 1.2 compliant LMS, you now have the option to allow
ViewletBuilder6.1 Enterprise automatically create a zip file with all the published files you
will need for the Viewlet to play back on your LMS.

-Select the Create a zip file option to create a zip file containing copies of
all the published files when using the SCORM 1.2 LMS option.

-Select Include Saba compatibility features if applicable for compliancy
and compatibility requirements for your LMS.
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0 AICC Learning Management System: Select this option to publish files
to meet AICC compliancy requirements for your LMS.

Select a Reporting or Learning Management System:

ﬂ AICC Leatning Managernent Systemm A

= Once you've selected a “Reporting” or “Learning Management System” option
from the list, click Next.

* |n the Publish Viewlet window, a “Folder Publish Complete” information screen
will display once the Viewlet has been successfully published.

Folder Publish Complete
Your Wiewlet has been successfully published to the Folder. L,

Wiewlet LIRL:

and Settings/kathyDeskiop/deletemanzdeletemenz_vigwlet_swf,html [ Wiz ] [ Browse

0 Click the View button to view the Viewlet in your default browser.
o0 Click the Browse button to view the published project files.

= | If your computer displays the “path” to folder when displaying operating system windows,
when you click the “Browse” button, a path to the folder containing the published project
- files displays. Use this information to quickly locate these files when needed.

0 Click Finish to close the Publish Viewlet window once publication is
complete.
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To publish a project to a Qarbon ViewletCentral or Corporate ViewletCentral account:
= Make sure you've completed all the edits to your project and save the file.
= Select Project > Publish Viewlet from the Menu bar.

= The Publish Viewlet window displays. Select a “ViewletCentral” account from the
publishing location list.

= Click Next.

= The “Reporting Options” screen displays. Keep the default selected and click
Next.

» The “ViewletCentral — Space Available” screen displays. Read the information
about the space available in the ViewletCentral account. Then, click Next.

-~

" Publish Viewlet
YiewletCentral - Space Available | \
Your YWiewletCentral account has space available to publish, '-,.«“'A
Account Mame: kathya@garbon, com Wiewlets Used: 31z
Current Plan:  Platinum Yiewlets Remaining: 653

Current Usage

312 Used 638 Remaining

U=age Afker Publishing

313 Used AE7 Remaining

Publishing this Yigwlet will puk you ak 31% of your current plan on iewlekCentral, Yau may wank ta consider
upgrading ko an advanced plan with maore space,

f Get more power out of YiewletCentral.
ﬁ Upgrade now to an extended plan.

Mesxt = ]| Cancel |
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= Once the project a published, a “Publish Complete” screen displays.

Publish Complete
Your Yiewlet has been successfully published to ViewletCentral, |

Yiewlek LURL:
htkp: f e, viewletcentral, comveviewlet 6 76314550 Wi

http: f e, viewaletcentral . comve/content_show, hkml Wigtn

The Viewlet statistics can be viewed at the Following URL:

Far your records, you will also receive an email wikh this information,

o Inthe Viewlet URL area, a path to the Flash file displays. Click the View
button next to this field to launch the Viewlet in your default browser.

0 In The Viewlet statistics can be viewed at the following URL: field, a path
to an information page showing your Viewlet's stats displays. Click the
View button next to this field to go to your Viewlet's stats’ page on
ViewletCentral.

o Click Finish to close the Publish Viewlet window.

‘-:' Each time you publish your project, as long as the file name remains the same, the Viewlet
> R il be updated on ViewletCentral.
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To view publishing information for your Viewlet:

= Select Project > Display Publishing Profile from the Menu bar.

Praoject

Ll_@.';‘. Project Properties. ., Chel+M

sla -
® Publish Vigwlet, ..

Display Publishing Profile. .,

|-.12L.'I Dl sioun = EClid

» |n the Publishing Profile window that displays:

o0 Inthe Location area, select a publishing location from the publishing
history list.

Locakion:

% Qarbon WiewletZentral - kathyg@garbon.com

| Qarbon YiewletCentral - kathyg@garbon,com

l5) Deskkop

0 Inthe General area, review the Viewlet’s publishing information, including
date of publishing, time of publishing and reporting type.

General;
Drake; March 01, 2009 Feporting Type: SCORM 1.2 Learning Management System
Time: 05:18 PM

o Inthe Viewlet URL area:

-Click the View button to launch the Viewlet in the default browser.
-Click the Browse button to open the folder containing the published files.

o Click Close to close the Publishing Profile window.

If you have any questions, contact us using the “Contact Us” or “Support” links on the
home page (www.garbon.com). Or, if you prefer, email support@garbon.com.
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ViewletCentral — General Information

Are you looking for a solution for publishing your Viewlets on the Web? Why not check
out Qarbon’s ViewletCentral. ViewletCentral is a server-based application that provides
centralized reporting, management and deployment of your valuable Viewlets and other
Flash-content files.

e

Solutions | Products | Services | Demos [ Customers | Downloads | Store | Cnmpany [ Su

* Know everything about your Flash-content files *Top 3 Reasons to Buy
- ) 1. Real Time Stats - Know
]ew et en tra everything about your VYiewlets
usage.
[ [ 2. One-click Publishing - Get your
b @@ = Viewlets up and running in a snap.
Q DH 3. Protect and Share - Have one

centralized location for all your

Viewlet content,

Store Manage Collect Report Measure
+Product Info
What is YiewletCentral? Product Page
VewletCentral is a comprehensive server-based system that allows you to store, manage Foul
and deploy vour Viewlets as well as gather important usage statistics, Demo

= Technical Specs
& Create a ViewletCentral Account

i Plans
[ Host Your Own Server
%  Account Login How To

Why use ¥YiewletCentral?

Do you need to see

By using WiewletCentral, you can easily determine the effectiveness of your content and reports on the activity

how viewers respond to therm. YiewletCentral provides easy access to valuable information
such as:

of your Flash content
files?

- The nurmber of viewers far each Viewlet

- Average time spent by viewers on each Viewlet

- Whether a user has completed a Yiewlet

- Scoring on quiz Wiewlets | es, but it's not
— necessary

)
%  Live stats ] | Mo, but it would be

nice to knowe | have

| Ahzohately. | need this
featurel

To discover all the features of ViewletCentral, you can immediately open a Free account,
which will give you ample disk space to store your Viewlets. For more information about
ViewletCentral information, please visit our web site at:

http://lwww.garbon.com/presentation-software/viewletcentral/
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Viewlet Central Self-Hosted Server

When you purchase a Self-Hosted ViewletCentral server license, you not only get all of
the same features that the Qarbon-Hosted version has, but you gain the ability to

perform account and project management activities easily and efficiently from one single
location.

http://lwww.garbon.com/presentation-software/viewletcentral/host_server.php

If you are interested in learning more about Self-Hosted ViewletCentral, please contact
our sales group (sales@garbon.com) or support (support@garbon.com).
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Support and Self-Help Options

Qarbon offers a support plan to fit your needs. Standard Support is offered to all
customers at no charge. You can also purchase Platinum Membership, which is a
software maintenance plan with enhanced support benefits.

For more information on support plans and options available, visit us online at:

http://www.garbon.com/help/support_plans.php

Qarbon also offers users online, self-help resources in the form of Viewlet tutorials, user
manuals and FAQs. For access to these self-help aids, please visit our site at:

http://lwww.garbon.com/help/

You may also contact support@garbon.com with any support questions you may have.
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Webinars and Training Opportunities

Take advantage of all the features in ViewletBuilder6.1 Enterprise by signing up for
Qarbon’s training classes. Learn how to get the most out of your Viewlet authoring tool
to create stunning Flash demonstrations and interactive movies in no time. For
information on how to learn from the Viewlet experts, visit us online at:

https://garbon.on.intercall.com/confmgr/
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Sales and General Customer Service

Customer support is our top priority at Qarbon! Please feel free to contact our Sales or
Support staff at any time if you have ANY ViewletBuilder6.1 Enterprise (or other product
related) questions or concerns or for options to discuss additional training needs.

For current contact information, visit our web site:

http://www.garbon.com/about_us/contact_us/
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Qarbon User Forum

Want to share ideas on Viewlet Authoring? Are you hunting for a specific authoring trick
to take your Viewlets to the next level? Qarbon offers a Viewlet user forum just for you.

It's free to join and free to use. It's a great place to meet other Viewlet enthusiasts from

across the globe and spotlight your own great Viewlet ideas too!

Go to: http://forum.garbon.com/

Sign up and join in the fun!

Qarbon | e Qarbon User Forum

Flash Presentation Software - Screen Capture
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