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Composica is a robust e-Learning authoring system
that brings new meaning to the term team-work.
With its powerful web-based WYSIWYG authoring
environment, no programming is needed to create
amazing interactive e-learning content.

Authors, designers, subject matter experts and
reviewers collaborate using a sophisticated
groupware authoring environment with tasks
management and page-level lock out control,
granting live overview of progress throughout the
development process.

Its combination of reusable learning objects and
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Composica 4.0 is focused on merging its proven state-of-the-art authoring capabilities with social media, to
create true eLearning 2.0 courses.

Composica 4.0 provides authors with the ability to create highly rich, interactive and structured content, but it
also empowers them to take full advantage of social media tools to create a learning community around each
course. Courses then become both formal and social by nature - learners can share knowledge with others, learn
from each other, comment on anything, rate everything and more - all while browsing a course, without ever
leaving the learning environment.

Learn more about some of the new features:

§ Tagging documents
§ Adding mashups
§ Adding narration
§ Adding social media
§ Sequencing and effects
§ Collaborating - Tasks
§ Collaborating - Blogs
§ Collaborating - Chats
§ Collaborating - Dashboards
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This quick-start tutorial illustrates the basic usage of Composica, and should bring you up to speed on its
elementary features. Following through this chapter, you will learn everything you need to know to create a
basic project and publish it.

This tutorial only covers the essentials of each step, to help you quickly grasp the basics of Composica. If you
prefer an in-depth view, see Using Composica.

§ Starting Composica
§ Creating a project
§ Adding chapters and pages
§ Tagging documents
§ Designing a document
§ Editing and formatting text
§ Adding general elements
§ Adding activities
§ Adding media
§ Adding mashups
§ Adding narration
§ Adding social media
§ Sequencing and effects
§ Adding tests and games
§ Collaborating - Tasks
§ Collaborating - Blogs
§ Collaborating - Chats
§ Collaborating - Dashboards
§ Previewing the project
§ Publishing

2.1 Starting Composica

Start Composica by entering its URL in your web browser. If you don't know the URL, ask your system
administrator.

Logging in

To log in, enter your Login and Password at the Login screen, and press the Login button.

The Login screen may be skipped by using the same Login as your Windows account login, and enabling Integrated Windows
authentication on the web server. For more information, contact your system administrator.

Welcome to Composica

Once logged in, you are presented with the Composica Dashboard.  Pressing on the Start Composica button will
open Composica in a new window. Additionally, if you are an administrator, you can open the administration
panel.

If Composica doesn't start, try Troubleshooting.

Main window

The Windows-like user interface of Composica should allow you to quickly become familiar with its basic features.

When opening Composica for the first time, the Select Project dialog opens. This dialog allows you to open a
previous project if one exists, or create a new project. The next time you open Composica, the last project you
worked on will automatically open.
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2.2 Creating a project

Creating your first project will allow you to start working with Composica. For more information about creating a
project, see Creating a project.

Start a new project

Pressing the New Project button in the Select Project dialog opens the project creation wizard. The wizard offers
different options for starting a project.

To quickly start a new project:

1.  Enter the project's title (the description is optional), and press Next.

2.  Choose Styled Project, and press Next.

3.  Choose one of the available styles, and press Next.

4.  Edit the basic project properties (optional), and press Next.

5.  Press Finish to create the new project.

Once the new project has been created, the Project Manager will open. The Project Manager allows you to
configure the project, manage its outline, and set different project or document level settings.

2.3 Adding chapters and pages

Each project consists of different chapters and pages. In the Project Manager you can create and manage the
different chapters and pages of the project.

Adding a chapter

To add the first chapter, either use the Edit > Add Chapter Inside menu item or press the Add Chapter Inside
Selection toolbar button. This will create a new chapter inside the currently selected item, which is the project.
You can now select the chapter and change its title, by altering the Title field.

Adding a page

Adding a page is very similar to adding a chapter. To add a page, simply select the tree item you wish to add
the page in, such as the project or the chapter, and use the Edit > Add Page Inside menu item or press the Add
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Page Inside Selection toolbar button. You can also choose to add a page after the chapter, by selecting the
chapter and using the Edit > Add Page After menu item or the Add Page After Selection toolbar button.

All the options of the Edit menu are also available by right-clicking on a tree item.

The project outline can be easily manipulated by using the Copy/Paste functionality or by simply dragging items
from one location to another.

When you're done manipulating the project outline, save your changes by using the Project > Save Project
menu item, or by pressing the Save Project toolbar button.

2.4 Tagging documents

Tags can be assigned to each document in a project (including the project itself and Resources documents), to
assist in organizing different assets, find them quickly and reuse them.

Tagging a document

1.  Select the document from the Outline tab of the Project Manager.
2.  In the Tags field, add relevant tags, separated by space or comma. Each tag is a single word, so make sure

to use underline or dash to create a tag with multiple words if required.
3.  Click the Tag Color button to color the tags.

Finding tagged projects and documents

· A tag cloud is available in the Composica Dashboard, which displays the most dominant tags across all
projects in the system. Pressing a tag name will filter the projects list according to that tag.

· The project manager provides a Tagged tab, which sorts documents according to their different tags in the
project.

· Find by Tags is available from the Document menu, which can be used to search for tagged documents
across all projects.

· Many dialogs allow you to search for projects and/or documents according to tags, including the Select
Project dialog, and the Import dialog.

2.5 Designing a document

Page designing is at the core of Composica. While designing, you insert and organize the elements and content
that comprise the document.

Elements include basic design elements such as boxes and separators, interactive elements such as multiple
choice questions and hot spots, and navigational elements such as buttons, links, and menus.

Design Document

To start designing a document, choose the document you wish to design in the Project Manager, and use the
Edit > Design Document menu item or press the Design Document toolbar button. You can also simply double-
click the document you wish to edit.

If you close the Project Manager, you'll go back to editing the last document you were editing.

The editing area

The main Composica user interface consists of several toolbars and panels, and the large editing area. The
editing area is a WYSIWYG (what you see is what you get) representation of the document. In this area you
design the document's layout and edit its content.

You can start by Editing and formatting text.

Saving the document

Once you're done editing your document (and every once in a while), it's important to remember to save your
changes. You can do so by using the Document > Save menu item, or by pressing the Save Document toolbar
button.

If you forget to save your document, and perform an operation which requires the document to be closed, Composica will ask
you whether you want to save or discard your changes.
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§ Editing and formatting text
§ Adding general elements
§ Adding activities

2.5.1 Editing and formatting text

Composica provides text editing and formatting capabilities that are similar to ones of common word processors,
along with more advanced methods for power-users.

Editing text

You can enter text into any element in the editing area, including the document itself.

Composica provides you all the common text editing capabilities such as Cut, Copy, Paste, Find and Replace, and
more.

Formatting

Composica provides you with quick formatting attributes through the Format menu, and the Format toolbar. You
can quickly set text attributes such as Bold, Italic, Underline, Fonts, Colors, Alignment, and more.

To set these attributes, select text and choose the attribute to apply on it. Alternatively, you can set attributes
without selecting text to apply them to the entire text block.

Bold, Italic, and Underline behave differently. If you press one of these without any text selected, they become active, and are
applied to any text entered. Pressing them again will deactivate them. This behavior is similar to common word processors.

Composica also features many more formatting properties, available through the Properties pane.

2.5.2 Adding general elements

Elements are the building blocks of documents. Throughout your documents you will use many different
elements for different purposes. Some elements simply serve the design of the document, while others provide
navigation and interaction tools.

Adding boxes

A box is one of the simplest elements available, but also one of the more useful ones. A box is simply a
container, which can contain text and other elements. You can use a box to arrange floating content around the
document, and as a design building block.

You can set different properties for a box such as its background, borders and many more, and you can set
properties for its content, such as color, font and so on.

To add a box, use the Insert > Box menu item or press the Insert Box toolbar button. An empty floating box will
be added to the document. You can now manipulate this box and its content.

Editing an element's content

You can edit the content of most elements, and they can contain rich content. Elements can also contain other
elements, giving you endless possibilities. To edit an element's content, you need to select it, and then click
inside of it. The editing caret will then be inside the element, and you can edit its content.

An empty box Selected box Editing content

Adding links

Links allow you to link to outside URL's from your document. To add a link, use the Insert > Link menu item or
press the Insert Link toolbar button. A new link will be added where the caret is located.

To edit the link's URL:
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1.  Select the link.

2.  Select the Settings tab in the Properties pane.

3.  Select the <URL> property, and click its value to start editing.

4.  Choose whether to link to a local resource (Media Explorer button), whether to link to a new uploaded local
resource (Upload button) or whether to link to an external address (Link button).

To edit the link's text, simply edit its content, as explained above. You can also change the link's color and
formatting as described in Editing and formatting text.

Links automatically open in a new browser window but can also be set to open inside the project, by using a 
Frame element and the <Window Name> property.

2.5.3 Adding activities

Activities are interactive elements, which you can add to your documents to make them interesting and
appealing to viewers. Like all other elements, activities are highly customizable, both visually and functionally.
Activity elements consist of several sub-elements, which you can reorganize, edit, and format.

Multiple choice questions

A multiple choice activity allows you to quiz viewers about a certain topic, and provide instant feedback. To add
a multiple choice activity, use the Insert > Multiple Choice menu item, or press the Insert Multiple Choice toolbar
button. A multiple choice question will be added to your document with its default layout.

A multiple choice question consists of a question, several answers, a check answer button, and feedback. You
can format any of these elements, and change their content. For information on editing their content, see 
Editing an element's content.

There are three simple steps to make the multiple choice question functional:

1.  Change the question's text.

2.  Change each answer's text.

3.  Set the correct answer. This is done by selecting the correct answer, selecting the Settings tab in the 
Properties pane, and switching the value of <Correct> to true.

The multiple choice question is now ready and operable. There are many more options and possibilities available.
For more information, see Activities, Multiple Choice.

The sub-elements which comprise the activity elements are sometimes necessary for the activities to function properly. Avoid
deleting such sub-elements, unless advised to do so.

2.5.4 Adding media

Media elements are often used to enrich documents. Composica features an intuitive media management
system, and allows you to embed all popular media formats in your documents.

Uploading media files

To quickly upload media files, use the Tools > Upload... menu item or press the Upload toolbar button. The
Upload dialog will open, allowing you to select multiple files and upload them to the central media library.
Uploaded media files are contained along with your project, and are available to any developer that has access
to your project.

The files will be uploaded and added to the project's media library. They will then be available via the Media
Explorer and the Media tree.

Embedding media files

You can now insert the uploaded media files to the project. There are several methods of adding media elements
to a document:

1.  Using the Insert menu or the Insert toolbar.

2.  Using the Media Explorer.

3.  Using the Media tree.
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The quickest way to add media files is using the Media tree. To add a media file:

1.  Select the Media tab in the Project pane. Under the Media tab, you'll find the media library tree. The tree is
divided into two main categories: Project, which holds the media files uploaded for the currently open
project; and Public, which holds media files available to all projects.

2.  Open the Project tree. The media files of the project are divided according to their type or format.

3.  Locate the media file you wish to add to the document.

4.  Double-click on the file.

The media element will be added to the document. You can then position and customize the media element.

You can insert media elements inside other elements, by entering the element content edit mode before inserting the media.

2.5.5 Adding mashups

Composica provides a simple and quick integration of mashup elements from popular external services into the
project. The customization of these elements is done from within Composica. 

Mashups are inserted from the Insert > Mashups menu item. 

YouTube Movies

The YouTube Movie element allows you to search and embed streaming movies directly from YouTube into the
project. This can become a good source of existing materials that can be harnessed to create quick and effective
training units.

Editing the <Source> property of the element provides an interface to search, sort, and finally embed YouTube
movies based on their ID or associated keywords.

You can preview the different movies found and press the Select button to embed the movie. Once a movie is
embedded you can control different aspects of the element from the Settings tab.

Universal Search

The Universal Search element allows the learner to perform a search in multiple search engines. This helps the
learner be involved in retrieving the information, while remaining in the environment of the course, which can
improve the quality of learning.

Additional Search Engine elements can be added from the Modify menu according to need. Select each Search
Engine sub-element and use its <Search In> property of the Settings tab to select one of the listed search
engines to use. You can also set the value to Custom and specify a URL for a search engine of your choice.

The search results can be set to be displayed in an external window (default) or inside the page, by changing
the <Show Results In> property under the Settings tab. The searched term can also be pre-populated by simply
typing the term in the Text Field area of the search.

Google Charts

The Google Chart element provides a quick and simple way to enrich the project with charts of several types,
based on data entered directly into the element.

The chart type is set in the <Chart / Type> property under the Settings tab (types include: Line, Columns, Pie,
Venn and more). Each type is accompanied with several attributes such as: Size, Colors, Labels and Legend, to
allow maximum control over its look and feel. Select each Data Point sub-element and from the Settings tab, use
the <Data> property to enter the data, and the <Label> property to add a label to that piece of data. 

Google Map Charts 

The Google Map Chart element is a variation of the Google Chart element. It provides the ability to create
thematic maps of different geographical areas, based on data entered directly into the element. 

The <Geographical Area> property under the Setting tab (available in Advanced view) lists different
geographical areas. When a Data Point is selected, a country code (see links below) can be set in its <Label>
property and this country will be highlighted on the map accordingly.

Supported country codes: http://code.google.com/apis/chart/isocodes.html 
Supported state codes (USA): http://code.google.com/apis/chart/statecodes.html

http://code.google.com/apis/chart/isocodes.html 
http://code.google.com/apis/chart/statecodes.html
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2.5.6 Adding narration

Narration is an important aspect of every project. It adds a new dimension to the content and helps learners
absorb content better.

Narrating an element

1.  Select the element to narrate.
2.  Go to the Settings tab.
3.  Edit the <Narration> property.
4.  Choose whether to use an existing audio file, upload a new audio file, or record the narration now (see

below).

This will add narration to your element, and it will immediately become a participant in the document's
sequence. You may add narration this way to every element on the document that requires narration. Composica
will automatically sequence these elements according to their position and the length of the audio.

Using the audio recorder

1.  Press on the Record button to begin. Once recording, you can press on the Pause button to temporarily stop
the recording and resume it later.

2.  Press on the Stop button once you're done recording.
3.  Press on the Play button to play back your recording, and press on the Record button again if you wish to re-

record.
4.  Once you're happy with the recording, name the audio file and press on the Upload button, which will upload

your recording and assign it to the element.

Java is required in order to record audio.

Disable/enable narration in the course

A Narration On/Off button can be inserted to the project from the Insert > Narration sub-menu. This function is
global to the entire project, so the learner can mute the narration according to preference.

Closed captioning in the course

The project can include a Closed Captioning element that will contain the captions of the narration, to support
accessibility guidelines. The Closed Captioning element is inserted from the Insert > Narration sub-menu. 

Captions are toggled by the Closed Captioning On/Off element, which is also inserted from the Insert > Narration
sub-menu. 

This function is global to the entire project, so the learner can choose to see or hide the captions according to
preference.

2.5.7 Adding social media

Composica provides authors with the ability to create highly rich, interactive and structured content, but it also
empowers them to take full advantage of social media tools to create a learning community around each course.
Courses then become both formal and social by nature - learners can share knowledge with others, learn from
each other, comment on anything, rate everything and more - all while browsing a course, without ever leaving
the learning environment.

Blogs

Blogs provide a very powerful method for learners to share their knowledge and benefit from each other’s
experience. 

A project can include any number of blogs that can be customized and configured. Blogs are inserted from the
Social Media sub-menu of the Insert menu.

The inserted Blog element consists of different widgets and buttons:

· The left area of the blog element includes default blog widgets (Recent Posts and Archive), that contain
placeholders. In the published course these placeholders will provide access to the learner’s blog posts.

· The top-left area of the blog element also includes default blog buttons (Blog Home, Add Post and Edit Post).
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The Settings tab of the Properties grid provides control over the buttons’ functionality, according to the button
selected. For example, when the Add Post button is selected, <Approval Required> and <Login Required> can
be used to set the requirements for adding a post. 

· The right area of the blog element includes place holders for the actual blog posts and comments. After
publishing, these will reflect the thread of posts and comments.

Select any of the blog’s sub-elements to customize their look and feel. Additional blog widgets and buttons can
be added from the Modify menu (enabled when one of the widgets, place holders or buttons is selected). When
one of the sub-elements in the Posts area is selected, a Rating option can be added from the Modify menu.

Each blog can also be accessed and edited independently of the course, and includes RSS feeds for subscription. 

Remote RSS feeds

A blog element can be configured to display the remote RSS/Atom feed of any other blog or other RSS/Atom-
based service, by simply pasting the external RSS address in the <External Feed> property under the Settings
tab (available when the Blog itself is selected). The feed is presented using the Composica blog element, with all
of its features.

Comments

Comments can be combined with any other Composica element, so learners can add their input about a specific
piece of content, the subject matter of the course or the course itself. 

A project can include any number of Comments elements that can be customized and configured. Comments are
inserted from the Social Media sub-menu of the Insert menu.

The inserted Comments element consists of placeholders. In the published course these placeholders will reflect
the thread of learner’s comments. 

Select any of the Comments sub-elements to customize their look and feel.

When the Add Comment sub element is selected, the <Approval Required> and <Login Required> properties
under the Settings tab can be used to set the requirements for adding a comment. Selecting the Add Comment
element also toggles the New Comment form, so it can be customized as well.

Rating

SCORM supported Rating elements can be combined with any other Composica element, so learners are able to
rate the content in the page level or the course level. 

In the published course, the average rating of all previous votes will be displayed in the Rating element. To
change this, select the Rating element and change the value of <Accumulate Votes> in the Settings tab to
"no". 

A document can include any number of Rating elements that can be customized and configured.

The rating range can be set (from 1-3 to 1-10) using the <Star Count> property in the Settings tab. 
Different images can be set for the different modes of the Rating element (rating on, rating off and rating edit).
Select one of the three star types of the element and change its image using the <Source> property in the
Settings tab. Repeat the same for the other two star types. 

Sign in

Different Social Media elements can be set to require learners authentication. The authentication can be set to
use the LMS or Windows authentication. Alternatively, custom authentication can be chosen, and a Sign-in
element can be inserted to the project to force the learner to sign-in.

2.5.8 Sequencing and effects

Sequencing elements can enrich the document and helps learners digest information better as the document
gradually builds. Sequencing can be combined with effects and narration to enhance the overall experience.

Adding a sequence

· Select all the elements that should be sequenced (use Shift+Click for multiple selection) and press on
Sequencing in the Toolbar. This will open the Sequencing dialog and allow you to configure the order, timing,
effects, and much more.

· Alternatively, you can manually assign elements to participate in the sequence by setting their <Sequence
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Active> property to yes, as well as their <Effect Type> property to the desired effect. Both are accessible
from the Style tab.

Precise control over the associated effects, order, timing and many other settings is available in the Sequencing
dialog. It is divided into two tabs; one controls the common settings, while the other can be used to control the
behavior of specific elements.

2.6 Adding tests and games

Tests

Composica has powerful testing and assessment capabilities that can be used for summary tests, self
assessments and certification. Comprehensive performance information is communicated to an LMS through
SCORM. 

Tests are added to the project outline in the Project Manager. As with any outline item, their position in the
outline tree can be freely changed at any time. 

A test must have at least one section, so a default Test Section is included with every new test and additional
sections can be added according to need. Sections contain pages with activities in them. The learner gets scored
based on performance in these activities. 

When a test is selected in the outline tree, different aspects of its functionality can be defined in the Properties
area. For instance:

· The Test Mode property determines if the test will use all available questions, or a set of questions selected at
random out of a question bank.

· The Section Order and Question Order properties are used to set the order in which the questions will be
presented.

· The Score Method property determines if all sections will have an equal score weight, or a custom weight per
section.

In addition, tests can be time limited, their pass score and the number of allowed attempts can be set and much
more. 

Each Test Section has additional properties, which complement the test settings and allow for further flexibility
in the configuration of the test.

Tests are inserted to the outline tree with an associated Test Results page. A Test Feedback element can be
added to this page, to provide learners with a detailed report on their performance in the test. This element can
be configured to show as much or as little information as required.

Games

Games employ powerful motivational elements such as competition, humor and the satisfaction of winning
through applying a skill. 

Composica Mind Games allow authors to utilize these elements and create experiences that learners can enjoy
and from which they gain knowledge. 

Game elements can be added to Test documents and wrap the functionality of the test. Games support all
settings available to tests, and while using them, performance data can be reported to an LMS via SCORM. 

Composica offers a variety of attractive games, each with its unique approach, focus, and level of playability:
Master Plumber, Space Bubbles, High Hops, Rescue Mission, Game Show. 

Games can be added using the Game Picker toolbar button or the Mind Games sub-menu of the Insert menu. 

Like all other elements, games are highly customizable, both visually and functionally. The author can adjust the
difficulty level of the game play as well as the educational difficulty of the questions, and achieve the desired
balance. 

When the game element is selected, the author can use the Setting tab of the Properties grid to set the number
of questions per level, the background setup, the number of allowed attempts and many other parameters.
Some of the properties are common to all games, while others are specific to each game. 
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Each game consists of several layers that are used for visual and functional control. At run-time, the layers will
be shown and hidden at different game states. Selecting the different layers for viewing and editing is done
using the tabs at the top of the game element. 

Question pages in the game are displayed with the game design and background.

2.7 Collaborating

2.7.1 Tasks

Tasks provide a smooth and organized project management methodology. The tasking system of a project is
open to Developers, Contributors and Reviewers with permissions to the project. 

Using Tasks

The Related Tasks dialog shows the current or selected document's related tasks, along with their status,
assignee, priority, tags, comments and system audit trail. 

The Related Tasks dialog is available from the Project Manager by clicking the Manage Tasks option (available
from the Tasks menu or by right-clicking a document in the Outline tab).

In Design Mode it is available by clicking the Tasks option (available from Document menu, the toolbar and by
right-clicking a document in the Outline tab).

To add tasks: 
1.  Open the Related Tasks dialog.
2.  Press the Add toolbar button and write the task description in the Task area.
3.  Use the related fields to assign the task to a team member, set its priority and assign tags to it.
4.  Comments can be added to the task by writing them in the Add Comment area and pressing the Append

button to append them to the Comments area.
5.  Press OK.

The number of open tasks is indicated near the document name in the outline tree. If any of the tasks in the
documents are assigned to you, the number will appear in bold.

All tasks in a project are displayed in the Tasks widget of the Project Dashboard along with their details, where
they can be filtered in various ways. A similar view is available in the Tasks widget of the Composica Dashboard
for tasks from all available projects.

To edit tasks: 
1.  Open the Related Tasks dialog.
2.  Select the task from the tasks list and perform the desired changes.
3.  When the task is completed, change its status by checking the Status checkbox, or by pressing the Mark

Closed toolbar button.
4.  To remove the task, use the Remove toolbar button.
5.  The system keeps an audit trail of any saved modification made to the task. To display this trail, check the

System option under the Comments area.
6.  Press OK.

Task Reports 

Different task reports can be generated for a complete overview of the development process. 

The Task Report dialog is available from the Tasks menu of the Project Manager, the Tasks widget in the
dashboards and from within the Related Tasks dialog. 

Tasks reports can be generated for the scope of the project or for all the available projects. The results can be
displayed and filtered in various ways.

2.7.2 Blogs

Each project in Composica has an integral blog, so developers can freely share information with each other. By
using blogs, development teams can avoid communication bottlenecks and assure that important correspondence
is attached to its related context. 

When the project is created, a Start Project Blog button is displayed in the Recent Blog Posts widget of the
Project Dashboard. Press this button to add the first post of the project’s blog. 
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Posts are added from the Add Post button, which opens an editing dialog with various formatting options. Once
the post is completed, press the Send button to submit it. The post will be displayed in the Recent Blog Posts
widgets of the Project Dashboard and the Composica Dashboard. Other team members can now read the post,
add comments to it and initiate new posts. 

Blog comments are displayed with their related post, as well as in the Recent Blog Comments widgets of the
Project Dashboard and the Composica Dashboard. 

Each post has a Permalink link, so it can be viewed independently of the project. 

RSS subscription to the blog is available from the Blog RSS Feeds widget of the Project Dashboard.

2.7.3 Chats

Team members can efficiently communicate with each other using real-time personal chats or group chats. 

The Chat interface can be accessed from the Chat toolbar button (also available from the Status bar) or the View
> Chat menu item. 

Press on any team member that appears under the Online section to initiate a personal chat. Group chats can be
initiated by using the Start a Group Chat button and then inviting other team members (Developers,
Contributors, Reviewers and Viewers are included). 

Chats remain active even when the Chat dialog is closed and can be resumed at anytime. 

Chats can also be saved and function as "Meeting logs", so the information and discussions about the project
becomes an integrated part of it. Press the Save button of the Chat dialog to title and save the chat. Saved
chats then become available from the Saved Chat widgets of the Composica Dashboard and the Project
Dashboard, where searches can be performed to quickly find the required chat. 

2.7.4 Dashboards

Composica has two types of dashboards:

· The Composica Dashboard, which appears immediately after logging into the application and displays
aggregated information from all projects that are available to the user. 

· The Project Dashboard, which appears when accessing a specific project and displays information that is
directly related to the project. 

The position of widgets in the dashboard can be swapped by simply dragging widgets to the desired location. 

Both dashboards also include configuration buttons:

The View Mode button toggles between a detailed blog view and the normal Dashboard view.

The Dashboard Preferences button provides control over the displayed widgets, the header color of
each widget and the number of displayed entries. Press the Reset button to change back to the
default configuration.

The Refresh button reloads the dashboard so it reflects the most recently updated information.

The Close / Logout button closes the Project Dashboard and logs the user out in the Composica
Dashboard.

The functionality of most of widgets is similar in both dashboards; however, some widgets are available only in
one of the dashboards.

Start Composica

Only available in the Composica Dashboard. Press the Start Composica button to start the application. Users with
admin privileges will also be presented with the Administration button, providing access to the Administration
panel. 

Common Actions

Only available in the Project Dashboard. Provides quick access to common project actions such as preview,
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manage and publish.

News

Provides a place to post global notes and administrative messages. These are displayed to all the users in the
environment and are not attached to any specific project. Administrators can add new posts and edit existing
ones. 

Tasks

Composica provides a comprehensive Tasks Management mechanism including task assignment, task priority,
tags, task comments, task mail notification, audit trails, and more.

From the Tasks widget the user can filter the tasks at hand in various ways, to plan the work efficiently. 

The Project Dashboard displays tasks from the current project and the Composica Dashboard displays tasks from
all the projects that are available to the user.

Press on a task to open the project it's associated with, and the Related Tasks dialog.

Team Members

Users can easily see the current status of each team member (online/offline) as well as the project/document
they are currently editing and immediately access it.

In the Project Dashboard, when a team member is logged in, press on the the user's name to start a Chat dialog
with that user.

Press on the Status Massage icon to update your display message. 

Modified Projects

Only available in the Composica Dashboard. Provides a list of recently modified projects, along with the last
person who edited them and the time in which they were edited. Press on the Project Preview button to preview
the project, or on the project's name to open it. 

The Modified Project widget also includes a Tag Cloud. Press one of the tags to see only modified projects that
have this tag assigned to them.

Modified Documents

Provides a list of recently modified documents, along with the last person who edited them and the time in which
they were edited. Press on the Preview Button to preview the document, or on the document's name to open it. 

The Project Dashboard displays recently modified documents from the current project and the Composica
Dashboard displays recently modified documents from all the projects that are available to the user. 

The Composica Dashboard also includes a Project Preview button for previewing the entire project. 

Recent Blog Posts

Each project in Composica includes a Developers Blog, to help team members freely share information with each
other and discuss development aspects. 

In the Project Dashboard, the Recent Blog Posts widget displays blog posts from the current project. In the
Composica Dashboard it displays blog posts from all the projects that are available to the user. 

Press on the post title to see a detailed view of the post. In the detailed mode, press on the Add Comment
button to comment about the post and on the Permalink button to open the post in an external browser
window. 

Use the Older and Newer buttons to see other single posts, or the Home button to see a list of several posts. 

Press on the View Mode button to go back to the Dashboard view.

Recent Blog Comments

Developers Blog comments are displayed with their related post, as well as in the Recent Blog Comments widget.

Press on the comment title to see a detailed view of the comment, along with its related post. In the detailed
mode, press on the Add Comment button to add another comment to the post, on the Delete button to delete
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the comment and on the Permalink button to open the comment in an external browser window. 

Press on the View Mode button to go back to the Dashboard view.

RSS Feeds

Developers Blogs in Composica also offer RSS Feeds, so developers can receive updates made to the blog with
an RSS reader.

In the Project Dashboard, the Blog RSS Feeds widget displays a link to the RSS feed and the current number of
posts added to the project's blog. In the Composica Dashboard it displays the list of blogs from all the projects
that are available to the author along with the number of posts added to each blog.

Saved Chats

Composica provides real-time Chats between two or more users. These chats can be saved to be later accessed,
previewed or deleted. 

The Project Dashboard displays recently saved chats from the current project and the Composica Dashboard
displays recently saved chats from the all the projects that are available to the user.

The Saved Chats widget also provides a Find functionality to quickly search for a chat based on its content.

Recent Publications

Only available in the Project Dashboard. Recent publications of the project are listed under the Recent
Publications widget and include the publish method, the publish date and the name of the author that published
the project.

Links

Authors can add common links to the work environment. Links can be available to all the projects (Public) or just
for the author who added them (Personal). 

The Project Dashboard also includes an option to add links that will be available to all the developers working on
that project.

Press on the Add Link button to add a new link or the Edit Link button to modify an existing one.

My Notes

Each user has a personal 'To Do' notes widget. This space can be used to type in anything you want to save, and
will remain in the widget until removed.

2.8 Previewing the project

The editing area of Composica provides a WYSIWYG view of the document, which means the way the document
looks while you're editing it, is the way it will appear when published.

However, you may wish to preview the document you're editing, to examine how it interacts with the viewer,
and to view how all the elements integrate in the document.

Previewing the document

You can quickly preview the document you're currently working on, by using the Document > Preview
Document... menu item, or by pressing the Preview Document toolbar button. A new window will open,
previewing how the document will look when published.

Previewing a document requires the latest changes to be saved. If you haven't saved your changes, Composica will ask you if you
wish to save the changes you have made.

Previewing the project

Previewing the document shows you a preview of the current document within the project. To see how project
will be viewed when published, you need to preview the project by using the Project > Preview Project... menu
item.
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2.9 Publishing

Publishing your project is the concluding step of your work with Composica. Once pleased with how the project
looks and functions, you can publish it in various different formats to produce the final course. The published
course runs independently of Composica, and doesn't require any special software installed.

Published courses are separated to two main categories, online and offline. Courses published online will be
automatically placed on the web server, making them available without requiring any download. When
publishing offline, Composica will produce a package of one of several optional formats.

Publish project

To publish your project, use the Project > Publish Project... menu item. The publish project dialog will open,
allowing you to choose from several different publishing options.

Publishing online

To publish your work online, choose the Web Server (SCORM Enabled) option.

Once processing is complete, you will be given the web address of the newly published course. You can follow
the link to view the published course, or use the Copy Address button to copy the URL to your clipboard.

Publishing offline

You can publish offline to several formats, such as an executable application, an installation package, or a zip
file. Choose the desired format, and press OK.

Once the processing is complete, a File Download dialog will open allowing you to save the published course to
your hard drive. You are also presented with a web link to the file, in case downloading fails or you wish to pass
the link to other users.
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This chapter covers the different possibilities of Composica in-depth, including various tips and notes. Wherever
possible, links are provided to the referential section to provide raw details and facts.

§ Creating a project
§ Blank project
§ Styled project
§ Duplicate of an existing project
§ Instructional design based project

§ Managing a project
§ Project properties
§ Run-time properties
§ Project metadata
§ Assigning groups
§ Assigning tags

§ Project outline
§ Adding items
§ Organizing
§ Deleting items
§ Item properties
§ Importing

§ Resources
§ Adding items
§ Deleting items
§ Item properties
§ Importing

§ Importing from PowerPoint
§ Styles
§ Tasks

§ Mind Games
§ Adding games
§ Game layers

§ Publishing
§ Multi-SCO Considerations

3.1 Creating a project

There are two ways to start a new project:

1.  Using the Project > New Project... menu item.

2.  Using the New Project button in the Select Project dialog, available when starting Composica for the first
time, or through the Project > Open Project... menu item.

Start a new project

Both methods will open the Start a New Project dialog, providing a step-by-step wizard to quickly create your
project.

Title your new project

Project Title is the name the project will have, and the way it will be recognized in the future. Make sure to
choose a name you can distinguish from other names.

Description is an optional field, available for personal usage.

The Assign Groups button allows you to assign one or more user groups which can view and edit the project.
The Assign Tags button allows you to assign one or more tags which can help organizing and tracking the
project.

Once titling the new project, press Next to move on to the next step.

Create a new project

The second step of the wizard gives the choice of selecting one of the following options:

§ Blank project
§ Styled project
§ Duplicate of an existing project
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§ Instructional design based project

3.1.1 Blank project

Choosing to create a blank project is the quickest way to create a new project. There are no further steps for
creating the project, besides confirming the selection.

Create the project

Once confirmed, a new project will be created, and the Project Manager will be automatically opened to allow
configuration of the project.

The new project is created with all the default properties and no style settings. To start configuring the project,
see Managing a project.

3.1.2 Styled project

The styled project is the most standard way to create a new project. It allows you to create a project based on
an existing system style, giving your project a basic theme.

Choose a style

A style is the general theme a project has. A style affects the default visual appearance of each document in
your project.

The styles tree consists of several styles, each consisting of several master layers. Selecting one of the master
layers in each style will show a preview of that style.

Even though a style is configured for an entire project, each document in the project can override its style and master layer
settings. See outline item properties and resources item properties.

Create the project

Once confirmed, a new project will be created, and the Project Manager will be automatically opened to allow
configuration of the project. To start configuring the project, see Managing a project.

3.1.3 Duplicate of an existing project

Choosing to create a project as a duplicate of an existing project will list all the projects currently available.
Creating projects from previously made projects can speed the process of creating similar projects.

Choose a project

Given a list of available projects, choose a project to use as a base for the new project.

Choose components to copy

Once choosing a project to duplicate, an option of which components to copy is available. Choose the
components which you want copied over to the new project.

Create the project

Once confirmed, a new project will be created, and the Project Manager will be automatically opened to allow
configuration of the project.

The new project is created as an exact duplicate of the base project, according to the components selected. To
start configuring the project, see Managing a project.

3.1.4 Instructional design based project

Choosing to create a project based on an instructional design template will list all the projects configured as such
templates. Creating projects from previously made templates can speed the process of creating projects.

Template projects are identical to regular projects, except that their Project Type property is set to Instructional Design
Template.

Choose a instructional design template

Given a list of available templates, choose a template to use as a base for the new project.

Choose components to copy
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Once choosing a template to use, an option of which components to copy is available. Choose the components
which you want copied over to the new project.

Create the project

Once confirmed, a new project will be created, and the Project Manager will be automatically opened to allow
configuration of the project.

The new project is created based on the instructional design template, according to the components selected. To
start configuring the project, see Managing a project.

3.2 Managing a project

The Project Manager can be opened from one of the following places:

§ The Project > Manage Project... menu item.

§ The Manage Project toolbar button.

§ Right-clicking on the outline tree in the Project pane, and choosing Manage Project....

Any changes you make in the Project Manager are not saved, until you use the Project > Save Project menu
item or the Save Project toolbar button. Once saved, changes to the Project Manager cannot be undone.

In the Project Manager, you can configure and manage the following:

§ Project properties
§ Project outline
§ Resources
§ Importing from PowerPoint
§ Assigning groups
§ Assigning tags
§ Styles
§ Tasks

3.2.1 Project properties

When the project (root) is selected in the tree of the Project Manager, the project properties can be viewed and
edited in the properties area. Following is a table of each property and its description.

Title The name of the project, how it will be identified throughout Composica
.

Description A description of the project, for personal usage.

Version The version of the project.

Style The style to use as default for the project.

Master Layer The master layer to use as default for the project. Only master layers
relevant to the current style can be selected.

Dynamic Layer The dynamic layer to use as default for the project.

Global Settings

Project Type Project - A regular project resulting in a course.
Instructional Design Template - A template project, used as an
instructional design template.

Writing Direction The default writing direction for the project.

Skip Menu Pages When set to skip, menu pages (chapters, tests and test sections) are
skipped from navigation.

Persist Activities When on, the state of activities is maintained when navigating away
from a page.

Press the Run-time Properties button to open the Run-time Properties dialog.
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Press the Project Metadata button to open the Metadata Editor dialog.

The following properties can be overridden in each document's properties:

§ Style

§ Master Layer

§ Dynamic Layer

§ Persist Activities

§ Skip Menu Pages (named Skip Page, available in relevant pages)

Writing Direction can be overridden in the page level, by changing the document's Layout > Direction property.

§ Run-Time properties
§ Project metadata

3.2.1.1 Run-time properties

The run-time properties dialog exposes different
properties relevant to the run-time of the project.

To edit the project's run-time properties, in the Project Manager, use the Project > Run-time Properties... menu
item, or select the project (root) in the tree and press the Run-time Properties button.

Document size

The size of the document (and not the window it opens in). This dictates the size of the editing area in
Composica.

§ 700 x 530 - Suitable for screen resolution of 800x600.

§ 800 x 600 - Suitable for screen resolution of 1024x768.

§ 900 x 675 - Suitable for screen resolution of 1024x768 and higher.

§ Custom - A custom size specified by width and height selectors.
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Open project in

The window to open the project in.

§ New proportional window - Opens in a new window, proportional to the document size.

§ New maximized / fullscreen window - Opens in a new window, in maximized or full-screen state.

§ Current window - Opens in the current window.

§ Current window and resize to fit (when possible) - Opens in the current window, and attempts to
resize the window to fit the document.

Allow the user to

§ Select text and content - The user can select text and content included in the project. This implies the
user can also copy any such contents.

§ Invoke the context-menu - The user can invoke the browser's context-menu (by right-clicking or any
other method).

§ Resize the window - The window is resizable.

If the window becomes smaller than the document

How to handle the document when the window is too small for it to fit.

§ Scale document down (zoom out) - Scale (resize) the document down so it fits the window.

§ Show scrollbars - Keep the document at its original scale, and allow the user to scroll around the window.

Scaling will likely lead to loss of quality. Documents containing flash, media player or mind games cannot be scaled.

If the window becomes larger than the document

How to handle the document when it's smaller than the window.

§ Scale document up (zoom in) - Scale (resize) the document up so it fits the window.

§ Center document - Keep the document at its original scale, and center it in the window.

Scaling will likely lead to loss of quality. Documents containing flash, media player or mind games cannot be scaled.

Window background color

When the window doesn't fit the document, stripes of the window's background color will show to accommodate
for the space. This setting allows you to match the color of these stripes to your project.

When the project is re-launched

If a project has been launched before, Composica can attempt to restore the run-time state of the project, either
from LMS data, from data stored on the local computer, or from both.
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3.2.1.2 Project metadata

The project's metadata meets the SCORM standard
metadata definition. Even though providing
metadata isn't required by the SCORM standard, it
is generally a good idea to provide such information
if you plan to import the published course to a
SCORM conformant LMS, or include it in a
cataloging system.

To edit the project's metadata, in the Project
Manager, use the Project > Edit Metadata... menu
item, or select the project (root) in the tree and
press the Project Metadata button.

The following metadata can be configured:

General

Language The language of the course.

Catalog The name(s) of one or more catalog systems that contain an entry for
the course.

Catalog Entry The entry of the course in the catalog systems.

Keywords A keyword list that describes the course, used as search terms.

Purpose The purpose of the course.

Cost Indicates whether a fee is charged for using the course.

Copyright Indicates whether the course is copyrighted.

Description The description of the course, will typically be included in catalog listing
and displayed by LMS's.

Educational

Interactivity Type The type of interactivity provided by the course.

Interactivity Level The level of interactivity provided by the course.

Learning Resource Indicates the learning resource type.

Context The educational context of the course.

Semantic Density The level of semantic density of the course.

Intended End User Indicates who the intended viewer is.

Difficulty The difficulty of the course.

Age Range The intended age range appropriate for the course.

Learning Time The average time needed to complete the course.
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Description The description of the educational or pedagogical characteristics of the
course.

3.2.2 Project outline

The outline describes the skeleton of the project. The outline can be modified at any time, documents can be
added, removed and rearranged at will through the Project Manager.

The outline tree describes a hierarchy of documents, each document can be one of the following types: a page,
a chapter, a test, or a test section. Any document type can be designed and can contain any type of content
supported by Composica.

Pages

Pages are the most primitive document types. Pages can't contain other documents under them in the outline
tree. Pages have several configurable properties.

Chapters

Chapters are menu pages, which contain other documents. Chapters can be used to arrange other documents
into blocks, and can be configured to be skipped from the project's navigation in their properties.

Tests

Tests are the outer menu pages holding test sections and pages. A test has many different properties unique to
tests, which allow for tests to have scores and pass status determined.

Test Sections

Tests can be made up of one or more test sections, which are another type of menu pages. Similar to chapters,
sections can be configured to be skipped from the project's navigation in their properties.

§ Adding items
§ Organizing
§ Deleting items
§ Item properties
§ Importing

3.2.2.1 Adding items

Outline items can be added by designing new documents and saving them, but can also be planned and added
up front in the Project Manager, as blank documents which can later be designed.

Following is a list of different outline item types and the ways they can be added to the outline tree.

Pages

Pages can be added directly under the project, inside chapters, and inside test sections.

To add a page inside an outline item, select that item and either:

§ use the Edit > Add Page Inside menu item.

§ press the Add Page Inside Selection toolbar button.

To add a page after an outline item, select that item and either:

§ use the Edit > Add Page After menu item.

§ press the Add Page After Selection toolbar button.

Chapters

Chapters can be added directly under the project, inside other chapters, and inside test sections.

To add a chapter inside an outline item, select that item and either:

§ use the Edit > Add Chapter Inside menu item.

§ press the Add Chapter Inside Selection toolbar button.

To add a chapter after an outline item, select that item and either:
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§ use the Edit > Add Chapter After menu item.

§ press the Add Chapter After Selection toolbar button.

Tests

Tests can be added directly under the project, and inside chapters.

To add a test inside an outline item, select that item and either:

§ use the Edit > Add Test Inside menu item.

§ press the Add Test Inside Selection toolbar button.

To add a test after an outline item, select that item and either:

§ use the Edit > Add Test After menu item.

§ press the Add Test After Selection toolbar button.

Test Sections

Test Sections can only be added directly under a test. Any documents inside a test must reside inside a test
section, and a test must have at least one test section.

To add a test section inside a test, select the test and either:

§ use the Edit > Add Test Section Inside menu item.

§ press the Add Test Section Inside Selection toolbar button.

To add a test section after another test section, select the test section and either:

§ use the Edit > Add Test Section After menu item.

§ press the Add Test Section After Selection toolbar button.

3.2.2.2 Organizing

The organization of items is never final, and can be reordered and reorganized at any time.

When reorganizing, items can be moved either after other items, or into other items.

After other items

To move items after other items, you can either drag an item over another item, or use cut and paste:

§ Cut the item you want to move by either using the Edit > Cut menu item, or pressing the Cut toolbar button.

§ Select the item you want to move it after.

§ Paste by either using the Edit > Paste After menu item, or pressing the Paste After toolbar button.

Into other items

To move items into other items, use cut and paste:

§ Cut the item you want to move by either using the Edit > Cut menu item, or pressing the Cut toolbar button.

§ Select the item you want to move it into.

§ Paste by either using the Edit > Paste Inside menu item, or pressing the Paste Inside toolbar button.

3.2.2.3 Deleting items

Items can be deleted at any time. Deleting an item will remove its document, and cannot be undone.

To delete an item, select it and either:

§ use the Edit > Delete menu item.

§ press the Delete toolbar button.

After confirming the deletion, the document will be deleted from the system, and removed from the tree. Any
deleted content cannot be recovered.
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Deleting an item requires the Project Manager to immediately save any previous changes.

3.2.2.4 Item properties

Each outline item has several properties which can be configured in the properties area of the Project Manager,
when the relevant outline item is selected in the tree.

Following is a table of each outline item type, its properties and their descriptions.

Throughout the properties, a value of [ Inherit ] means the property is inherited from the parent outline item.

Pages

Title Title of the document.

Style The style to use for the document.

Master Layer The master layer to use for the document.

Dynamic Layer The dynamic layer to use for the document.

Skip Page No - The document isn't skipped from navigation, and shown in menus.
Skip - The document is skipped from navigation, but shown in menus.
Skip & Hide - The document is skipped from navigation, and shown in
menus.

Persist Activities When on, the state of activities is maintained when navigating away
from the document.

Chapters

Title Title of the chapter.

Style The style to use for the document.

Master Layer The master layer to use for the document.

Dynamic Layer The dynamic layer to use for the document.

Skip Page No - The document isn't skipped from navigation, and shown in menus.
Skip - The document is skipped from navigation, but shown in menus.
Skip & Hide - The document is skipped from navigation, and shown in
menus.

Persist Activities When on, the state of activities is maintained when navigating away
from the document.

Tests

Title Title of the test.

Style The style to use for the document.

Master Layer The master layer to use for the document.

Dynamic Layer The dynamic layer to use for the document.

Skip Page No - The document isn't skipped from navigation, and shown in menus.
Skip - The document is skipped from navigation, but shown in menus.
Skip & Hide - The document is skipped from navigation, and shown in
menus.

Persist Activities When on, the state of activities is maintained when navigating away
from the document.

Test Settings
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Test Mode Normal - Use all questions from all test sections.
Global Bank - Use a given number of questions from all test sections.
Section Bank - Use a given number of questions from each test
section, specified in each test section's properties.

No. of Questions The number of questions to use when Test Mode is set to Global Bank
.

Sections Order Normal - Uses the order of the test sections in the outline to determine
the order of the sections.
Random - Randomizes the order of the test sections.

Questions Order Normal - Uses the order of the questions in the outline to determine
the order of questions.
Random - Randomizes the order of the questions. Test section pages
are always skipped.
Use Section Settings - Use the setting in each test section's
properties to determine the order of the questions.

Score Method Normal - Each section has the same weight on the score.
Use Section Settings - Use the setting in each test section's
properties to determine the score method.

Time Limit Normal - No time limit will be coerced.
Question Time Limit - Each question will be time limited.
Global Time Limit - The entire test is time limited.

Time The time to limit by, according to Time Limit. Only available when Time
Limit is other than Normal.

Partial Answer Accept - Accept partial answers.
Consider as Full - Accept partial answers, and consider them as full
ones.
Reject - Reject partial answers.

Feedback Mode Delayed Feedback - Feedback is given at the end of the test. Check
buttons are always hidden.
Immediate Feedback - Feedback is given immediately. Check buttons
are available by default.

Pass Score The minimal score required for the test to be considered passed.

Attempts The number of attempts possible for retaking the test.

Allow Review Whether to show the review test link in the test feedback element.

Participate in Global Score Whether the score of the test participates in the global score of the
course.

Test Sections

Title Title of the test section.

Style The style to use for the document.

Master Layer The master layer to use for the document.

Dynamic Layer The dynamic layer to use for the document.

Skip Page No - The document isn't skipped from navigation, and shown in menus.
Skip - The document is skipped from navigation, but shown in menus.
Skip & Hide - The document is skipped from navigation, and shown in
menus.

Persist Activities When on, the state of activities is maintained when navigating away
from the page.

Section Settings
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Questions Order Normal - Uses the order of the questions in the outline to determine
the order of questions.
Random - Randomizes the order of the questions.
Only available when Questions Order in the test settings is set to Use
section settings.

No. of Questions The number of questions to use from the selected test section. Only
available when Test Mode in the test settings is set to Section Bank.

Section Type Question Pages - The pages in the section contain questions, and will
be considered for score.
Information Pages - The pages in the section contain informational
material, and will not be considered for score.

Section Weight The weight, in percents, the score of this test section has on the total
score of the test. To help determine the amount, use the Validate
Sections Score button which shows the weight of each test section and
whether the sum of weights is 100%.
Only available when Score Method in the test settings is set to Use
section settings.

3.2.2.5 Importing

Items can be imported from other projects and templates. Importing items duplicates them into the current
tree, at the position requested.

Items can be either imported:

§ after the selected item, by either using the Edit > Import After... menu item or the Import After Selection
toolbar button.

§ inside the selected item, by either using the Edit > Import Inside... menu item or the Import Inside Selection
toolbar button.

The import dialog shows a tree of projects and templates available on the system. Expanding each of the
projects shows the project's tree, allowing you to select each item you wish to import. When an item is selected,
a preview of that document is shown on the right. To import the selected item, press the Import button.

Once you're done importing, press the Close button to close the import dialog, and return to the Project Manager
.

3.2.3 Resources

The resource repository lists different resources which can be used by the project's documents.

Resources can be one of the following types: master layers, dynamic layers, widgets, and pop-ups. Any resource
type can be designed like any other document, and can contain any type of content supported by Composica.

Master Layers

Each document of the project can have a master layer assigned to it, either directly or inherited from its parent
(see outline item properties). The master layer is shown in the back of the document, and can contain common
project-wide elements, such as background, title, navigational elements and more.

If your project uses one of the system styles, it already has one of that style's master layers. You can add more
master layers from the system styles by using the Project > Add System Style... menu item or Add System Style
toolbar button of the Project Manager.

Dynamic Layers

Additionally to the master layer, each document of the project outline can have a dynamic layer assigned. The
dynamic layer is more powerful, as its special settings provide with many different possibilities.

For example, a dynamic layer can created with a tree menu, set to apply only to menu pages, and assigned to
the entire project. Such a simple setup would quickly add menus to every menu page (chapters and sections) in
the project, managed from a central document.

Widgets

Widget documents give the ability to create pre-made element configurations, which can be quickly applied to
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the current document by using the Tools > Apply Widget... menu item, or by pressing the Apply Widget toolbar
button.

Pop-ups

Pop-up documents are opened in a new pop-up window via the Popup Button.

§ Adding items
§ Deleting items
§ Item properties
§ Importing

3.2.3.1 Adding items

Resource items can be added by designing new documents and saving them, but can also be planned and added
up front in the Project Manager, as blank documents which can later be designed.

Following is a list of different resource item types and the ways they can be added to the resource tree.

Master Layers

To add a master layer, select the Master Layers folder in the tree, and either:

§ use the Edit > Add Page Inside menu item.

§ press the Add Page Inside Selection toolbar button.

To add a master layer after an existing one, select that master layer and either:

§ use the Edit > Add Page After menu item.

§ press the Add Page After Selection toolbar button.

To add a master layer from system styles, either:

§ use the Project > Add System Style... menu item.

§ press the Add System Style toolbar button.

Dynamic Layers

To add a dynamic layer, select the Dynamic Layers folder in the tree, and either:

§ use the Edit > Add Page Inside menu item.

§ press the Add Page Inside Selection toolbar button.

To add a dynamic layer after an existing one, select that dynamic layer and either:

§ use the Edit > Add Page After menu item.

§ press the Add Page After Selection toolbar button.

Widgets

To add a widget, select the Widgets folder in the tree, and either:

§ use the Edit > Add Page Inside menu item.

§ press the Add Page Inside Selection toolbar button.

To add a widget after an existing one, select that widget and either:

§ use the Edit > Add Page After menu item.

§ press the Add Page After Selection toolbar button.

Pop-ups

To add a pop-up, select the Pop-ups folder in the tree, and either:

§ use the Edit > Add Page Inside menu item.

§ press the Add Page Inside Selection toolbar button.

To add a pop-up after an existing one, select that pop-up and either:
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§ use the Edit > Add Page After menu item.

§ press the Add Page After Selection toolbar button.

3.2.3.2 Deleting items

Items can be deleted at any time. Deleting an item will remove its document, and cannot be undone.

To delete an item, select it and either:

§ use the Edit > Delete menu item.

§ press the Delete toolbar button.

After confirming the deletion, the document will be deleted from the system, and removed from the tree. Any
deleted content cannot be recovered.

Deleting an item requires the Project Manager to immediately save any previous changes.

3.2.3.3 Item properties

Each outline item has several properties which can be configured in the properties area of the Project Manager,
when the relevant outline item is selected in the tree.

Following is a table of each outline item type, its properties and their descriptions.

Throughout the properties, a value of [ Inherit ] means the property is inherited from the parent outline item.

Master Layers

Title Title of the document.

Description A description of the document, for personal usage.

Style The style to use for the document.

Dynamic Layers

Title Title of the document.

Description A description of the document, for personal usage.

Style The style to use for the document.

Layer Position How to position the dynamic layer, relative to the document layer (the
actual document). In design-time, the dynamic layer always shows
under the document layer, regardless of this setting.

Apply Layer to Whether to apply the dynamic layer to Menu Pages Only, to Pages
Only, or to All documents.

Widgets

Title Title of the document.

Description A description of the document, for personal usage.

Pop-ups

Title Title of the document.

Description A description of the document, for personal usage.

Style The style to use for the document.
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3.2.3.4 Importing

Items can be imported from other projects and templates. Importing items duplicates them into the current
tree, at the position requested.

Items can be either imported:

§ after the selected item, by either using the Edit > Import After... menu item or the Import After Selection
toolbar button.

§ inside the selected item, by either using the Edit > Import Inside... menu item or the Import Inside Selection
toolbar button.

The import dialog shows a tree of projects and templates available on the system. Expanding each of the
projects shows the project's tree, allowing you to select each item you wish to import. When an item is selected,
a preview of that document is shown on the right. To import the selected item, press the Import button.

Once you're done importing, press the Close button to close the import dialog, and return to the Project Manager
.

3.2.4 Importing from PowerPoint

Composica can import PowerPoint presentations directly into any project. Each slide in the presentation will be
duplicated to a page in the outline, at the position requested. Once imported, the pages (the PowerPoint slides)
are entirely editable and customizable within Composica.

PowerPoint presentations can be either imported:

§ inside the selected item, by either using the Edit > Import PowerPoint Inside... menu item or the Import
PowerPoint Inside... toolbar button.

§ after the selected item, by either using the Edit > Import PowerPoint After... menu item or the Import
PowerPoint After... toolbar button.

Using any of these options, will open the Import PowerPoint Presentation wizard.

Select the source presentation

The first step is selecting the PowerPoint presentation to use as the source for the import. If PowerPoint files are
already in the project's library, they will be shown in the tree, and new ones can be uploaded by pressing the
Upload button. If no PowerPoint files are in the library, Composica will automatically request you to upload one.

Once you've uploaded and selected the PowerPoint presentation, press Next to continue.

Choose import mode

Choose between importing all slides from the presentation, or selected slides.

Select slides to import

If you've chosen to import selected slides, a list of slide thumbnails will now be presented, showing every slide of
the presentation. You can select/deselect any of the slides by pressing them, or using the selection buttons at
the bottom, marking them for import.

Once you've finished selecting which slides to import, press Next to continue.

Choose slide sizing mode

Choose between importing slides at full size, which maximizes the size of the slide to fit the size of the
document while maintaining proportions, or manually customizing the size position and master layer settings for
the slides.

Choose slide size, position, and Master Layer

If you've chosen to customize slide's size, position and master layer, a sample slide will now be presented which
can be scaled and moved around, like regular Composica elements. On the right, you can set the slide's default
master layer (which will show in the preview box, under the slide, once you make a selection), and also center
the slide horizontally and vertically. On the bottom-right corner of the slide is an info box showing the current
size and position of the slide.

Once you've finished customizing the slide's size, position and master layer, press Next to continue.
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Choose the level of image quality

Images in slides can be imported in a variety of quality levels, to best match the target usage in the slide. The
higher the level of quality, the larger the files. If you are not sure, use the default settings, and just re-import if
you are not happy with the quality or file size.

Choose how to handle slide notes and comments

Composica can transform PowerPoint notes and comments into tasks on the relevant pages. Choose whether you
want notes, comments, or both, to be imported as tasks along with the slides. You can also choose to mark the
tasks generated by the import as done.

Once you've made your choices, press Next to continue.

Finalize the import

Finally, confirm your selections by pressing Finish to close the wizard and import the slides.

3.2.5 Assigning groups

Each project can be assigned one or more groups which can view
and edit it. Groups can be used to organize projects between different teams of developers.

To assign groups for the current project:

1.  Open the Groups dialog, by using the Project > Assign Groups menu item in the Project Manager, or by
pressing the Assign Groups button in the Start a New Project wizard.

2.  Check or uncheck the checkbox next to any of the groups, by pressing it. A group which is marked with a
check is a group which can view and edit the project.

3.  Press the OK button to finish.

Groups are maintained by administrators.

3.2.6 Assigning tags

Each project can be assigned one or more tags which can help organizing and tracking different projects. Any
dialog showing a tree of projects in the system (such as the Select Project dialog, the Media Explorer or the
project import dialog) lets you filter projects by tags.

To assign tags for the current project:

1.  Select the root item in the Project Manager and add the desired tags to the Project Tags field, or by add the
tags to the Tags field when first creating a project in the Start a New Project wizard.

2.  Press the colored tag button in order to give specific colors to tags.

3.  Press the OK button to finish.
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3.2.7 Styles

Style is a logic layer determining the look of each element in the project. Composica includes several system
styles that can be used within the project.

All the properties determined by the style can be overridden by a style rule or by changing the properties
directly on the element.

Adding a system style

To add a system style during the creation of a project, choose the styled project option.

To add a system style to an existing project, in the Project Manager, use the Project > Add System Style...
menu item or the Add System Style toolbar button to open the Add System Style dialog, choose a style and
press OK.

Assigning a system style

Each document can have a system style assigned to it, either directly or inherited from its parent. To assign a
style, use the Style setting for any document in the outline or resources tree.

3.2.8 Tasks

Tasks allow for easier management in a collaborative environment, and also for personal tasks management in a
single-developer scenario. Tasks are assigned to developers, and managed per-document in the project, or
globally to the entire project.

Tasks can be maintained in the Project Manager. To view a list of tasks for a specific document, select it from
the tree. To view a list of tasks for the project, select the project (root node) from the tree.

The tasks are listed in the task list, where they can be edited and deleted.

Adding a task

When adding a task, the task's date will be set to the current date, and the task's owner will be set to your user
name.

In the main application

Use the Document > Tasks... menu item or the Tasks toolbar button to open the Tasks dialog. Press the Add
toolbar button, and a task with the title "New Task" will be added to the task list.

In the Project Manager

Select a document, and use the Tasks > Add menu item or the Add Task toolbar button. A task with the title
"New Task" will be added to the task list.

Editing a task

A task has two editable properties, its description and status.

In the main application

Use the Document > Tasks... menu item or the Tasks toolbar button to open the Tasks dialog. Select one of the
tasks from the task list.

To change a task's description, edit the text in the description box at the bottom of the dialog.

To mark a task as done or undone, you can:

§ use the Mark Done or Mark Undone toolbar buttons.

§ press the checkbox in the Done column, to check or uncheck it.

In the Project Manager

Select a document, and select one of the tasks from the task list.

To change a task's description, you can:

§ use the Tasks > Edit Description... menu item. A small dialog opens, allowing you to edit the description.

§ quickly edit the description by clicking on the task's description text. A quick editor opens, allowing you to
edit the first line of the description.
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To mark a task as done or undone, you can:

§ use the Tasks > Mark as Done or Tasks > Mark as Undone menu items.

§ use the Mark Task as Done or Mark Task as Undone toolbar buttons.

§ press the checkbox in the Done column, to check or uncheck it.

Marking a task as done sets the task's closer to your username, and the closed time to the current time.

Removing a task

In the main application

Use the Document > Tasks... menu item or the Tasks toolbar button to open the Tasks dialog. Select one of the
tasks from the task list, and press the Remove toolbar button.

In the Project Manager

Select a document, select one of the tasks from the task list and use the Tasks > Remove menu item, or the
Remove Task toolbar button.

Generating task reports

Task reports contain a list of all tasks, open tasks, and closed tasks, along with a summary of tasks.

To generate task reports for the project, you can:

§ use the Project > Task Reports... menu item.

§ in Project Manager, select any of the documents, and use the Tasks > Task Reports... menu item or the Task
Reports toolbar button.

If the task reports are generated for a specific document (and not the entire project), they will only show tasks
related to that document and its descendants. You can use the Up button to generate the reports of the parent
document.

3.3 Mind Games

Games can enhance the learning process by creating a dynamic and interactive experience for users. Games
employ powerful motivational elements such as competition, humor, and the satisfaction of winning through
applying a skill. Composica Mind Games allow designers to utilize these elements and create experiences that
learners can enjoy and from which they gain knowledge.

Through games, learners acquire different types of knowledge as each game develops different skills. The games
offer different levels of Playability: Games like Master Plumber or Space Bubbles emphasize the game part,
while Rescue Mission or Game Show put more emphasis on the educational part.

On top of that, the designer has full control over the playability and the educational aspects of the game. Like all
other elements, games are highly customizable, both visually and functionally. By adjusting the different
properties, the designer can dictate the difficulty level of the game (regardless of the level of questions) as well
as the educational level of difficulty and so create the desired balance.

This way, the designer can cater for a wide range of students' needs; a student fluent in the subject learned
should play a game where questions can quickly be answered, where the interaction would be more beneficial.
On the other hand, a less knowledgeable student should play a game designed so all questions must be
answered and so, thoroughly and repeatedly learn the subject.

§ Adding games
§ Layers

3.3.1 Adding games

Games can only be added to test documents. Once inserted, they wrap the configuration and functionality of the
test. Test sections and pages should be inserted, configured and designed like any test. Each page in the test is
a question in the game, and can contain any activity or other content. The elements of an activity inserted in a
game will, by default, follow the visual and functional aspects of the specific game.

To add a game to your project:
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1.  Add a test to the outline of the project, to contain the game.

2.  Add test sections and pages to the test, to meet your needs.

3.  Edit the test created in step 1, and open the game picker, using the Insert > Mind Games > Game Picker...
menu item or the Game Picker toolbar button.

4.  Select one of the games in the Game Picker dialog, and press OK to add it to the document.

The game inserted is fully functional, using default values for all its different properties. To edit the different
elements of the game, read about game layers. To further customize the game, see the Mind Games reference.

The game element will maintain its proportions when resized. It is important to assure that the Document Size in the Run Time
Properties is set to follow the same proportions.

3.3.2 Game layers

A game is made up of several layers stacked on top of the game, which are general containers that can contain
any Composica elements. The layers are shown and hidden throughout the game according to their purpose.

Each layer has a corresponding tab, in the switch-bar at the top of the game. The tabs are only shown during
design time, to assist in designing the game. To edit any of the layers, press its tab.

Inserting elements to a layer

Every element in the game can be customized, and additional elements can be added. To add an element to one
of the layers:

1.  Show the layer you wish to edit, by pressing on its tab.

2.  Select the game's element.

3.  Click inside the element, to enter content editing mode. The active layer will now be edited.

4.  Insert any element by using the Insert menu or the Insert toolbar.

Layers

The following layers are available for all games:

Common

Includes elements that are common to all the different states in the game. Should contain elements that should
appear all throughout the game, and usually includes the game's main control buttons like Help, Mute and Start
Game.

Intro

Displayed as the game loads, until the game starts. Usually contains the welcome message and the game's
objectives and notes.

Game

Shown during the playing stage of the game (from the moment it starts to the moment it ends). Contains
elements relevant to the actual gameplay, such as the Game Timer and the Score.

Popup

The popup contains the question, which is shown throughout the game whenever needed. The popup tab
toggles the popup layer on top of the active layer.

Win

Shown when the game ends, if the player has won. Usually contains feedback to the player.

Lose

Shown when the game ends, if the player has lost. Usually contains feedback to the player.

Results

Shown on top of the win/lose layer, containing the test feedback element. Only shown if <Show Results> is true
. The results tab toggles the results layer on top of the active layer.

Help

Shown over other layers, when the user clicks the Help button. Contains a short description of the game, along
with gameplay instructions. The help tab toggles the help layer on top of the active layer.
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3.4 Publishing

Publishing your project is the concluding step of your work with Composica. Once pleased with how the project
looks and functions, you can publish it in various different formats to produce the final course. The published
course runs independently of Composica, and doesn't require any special software installed.

Published courses are separated to two main categories, online and offline. Courses published online will be
automatically placed on the web server, making them available without requiring any download. When
publishing offline, Composica will produce a package of one of several optional formats.

Publish project

To publish your project, use the Project > Publish Project... menu item. The publish project dialog will open,
allowing you to choose from several different publishing options.

Publishing online

To publish your work online, choose the Web Server (SCORM Enabled) option.

Once processing is complete, you will be given the web address of the newly published course. You can follow
the link to view the published course, or use the Copy Address button to copy the URL to your clipboard.

Publishing offline

You can publish offline to several formats, such as an executable application, an installation package, or a zip
file. Choose the desired format, and press OK.

Once the processing is complete, a File Download dialog will open allowing you to save the published course to
your hard drive. You are also presented with a web link to the file, in case downloading fails or you wish to pass
the link to other users.

3.4.1 Multi-SCO Considerations

Why should Multi-SCO be generally avoided?

Using Multi-SCO publish presents the following limitations in the course, because of the very nature of how this
feature works in LMSs:

§ Many navigation elements will not work as expected:

§ Because an SCO cannot directly link to another SCO in SCORM,

§ Navigation buttons to other pages will not be able to function.

§ Menus will not work properly.

§ Branching will not be achievable.

§ Because each document will become a single SCO independent of the others,

§ Breadcrumbs will not show the entire hierarchy.

§ Progress Bar will not work properly.

§ In summary, most of the Insert > Navigation menu will not be of any use.

§ The course "wrapper" will be stripped out, resulting in slower performance:

§ Pre-caching of media before a page is reached will not take place since each SCO is autonomous and has no
knowledge of other SCOs.

§ Master Layers will need to be reloaded from scratch with each navigation (in single SCO mode Master
Layers are not reloaded once they are rendered).

§ Chapter pages will not be displayed (the chapters will be shown in the course structure, but only as
containers of pages, they will not display their own content page).

§ Assessments will need to be placed in their own chapters, which are then transformed into a single SCO. Test
Results pages will not work otherwise.

§ Courses that are designed to operate as Multi-SCO will not be able to run independently (without an LMS).
Multi-SCO courses will typically not have any menus or navigation (since the LMS is responsible for
navigation in Multi-SCO mode), so when attempting to run such courses offline or outside of an LMS the
learner will not have a way to navigate through them.
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When creating Multi-SCO courses, what precautions should be taken?

§ Avoid any of the navigation elements mentioned above.

§ Avoid having content in chapter pages, always set Skip Page in the chapter properties to Skip.

§ Place any assessment and its Test Results page inside their own separate chapter. Note that any chapter that
contains a test will be created as one SCO, so you would probably want to avoid having other pages in this
(sub-)chapter.
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The Composica user interface is divided into six main sections.

§ Menus
§ Toolbars
§ Properties pane
§ Project pane
§ Project Manager
§ Media Explorer
§ Sequence Manager
§ Status bar
§ Keyboard shortcuts

4.1 Menus

The menu is positioned at the top of the user interface. Through the different menus you get access to most of
the possible operations of Composica.

Each page in this chapter denotes a menu. In each page you will find a description of the menu, and a list of all
the menu's items, along with a description of each. If a menu item has an equivalent toolbar button, an icon
next to the item will link to that toolbar's help page.

§ Document
§ Project
§ Edit
§ View
§ Insert
§ Modify
§ Format
§ Layout
§ Tools
§ Help
§ Context menu
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4.1.1 Document

The document menu provides document level operations.

New Creates a new document.

Open... Opens the Select Resource dialog, allowing you to open outline
items, master layers, menus, widgets or pop-ups.

Save Saves the current document, or if it's a new document, opens the
Save As dialog.

Save As... Opens the Select Resource dialog, allowing you to save the current
document as an outline item (page, chapter or test), master layer,
menu, widget or pop-up.

Preview Document... Previews the current document. Even when previewing the current
document, the entire project is available for navigation.

Assign Tags... Opens the Assign Document Tags dialog, allowing you to assign
tags to the current document.

Find By Tags... Opens the Find Documents dialog, allowing you to find documents
by tags in the current and other projects.

Open Next Opens the next item in the outline tree.

Open Previous Opens the previous item in the outline tree.

Tasks... Opens the Related Tasks dialog, allowing you to manage tasks for
the current document.

Recent Documents Opens a list of recently opened documents, available for quick
access.

Close Closes Composica.

4.1.2 Project

The project menu provides project level operations.

Manage Project... Opens the Project Manager, allowing you to manage different
aspects of the project.

Preview Project... Previews the current project, as it will be shown when published.

Open Project... Opens the Select Project dialog, allowing you to open a different
project, or create a new one.

New Project... Opens the Start a New Project dialog, allowing you to create a
new project.

Project Dashboard Shows or hides the Project Dashboard, containing various project
related widgets.

Tasks Report... Opens a task report for the current project, listing all/open/closed
tasks, and a summary of all tasks.

Export / Import... Opens the Export/Import dialog, allowing you to export the
current project into a special Composica recognized file format
"cpa", or import a previously exported project back into Composica
.
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Publish Project... Opens the Publish Project dialog, allowing you to publish the
current project in different formats.

Recent Projects Shows a list of recently opened projects, available for quick
access.

4.1.3 Edit

The edit menu provides different tools for editing the current document.

Undo Reverts the last change to the document.

Redo Restores the last change reverted by undo.

Cut Copies the current selection to the clipboard, and removes it from
the document.

Copy Copies the current selection to the clipboard.

Paste Pastes the contents of the clipboard at the caret's position, as
plain text.

Paste Special Pastes the contents of the clipboard along with formatting and
styles at the caret's position. Allows you to copy content and
elements from other documents or from programs such as
Microsoft Word.

Erase Content Clears the content of the selected element.

Duplicate Duplicates the selected element.

Delete Deletes the selected element or text.

Drag Select Toggles drag select mode, allowing you to drag and select several
elements with a single mouse click.

Select Parent Selects the direct parent of the selected element.

Select Ancestor Shows a list of all ancestors of the selected element, allowing you
to select them.

Select All Selects all the contents of the current document.

Find... Opens the find dialog, allowing you to search for text in the
current document.

Replace... Opens the replace dialog, allowing you to search and replace text
in the current dialog.

Add Design Hint Adds a design hint to the current document, allowing you to
maintain comments which aren't shown when previewing or
publishing the project.

4.1.4 View

The view menu provides options for changing the look and feel of Composica.

Design Mode Switches to design mode, allowing you to edit your document
visually in a WYSIWYG manner.
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HTML Mode Switches to HTML mode, allowing you to directly edit the source
code of the document. This is not recommended for intermediate
developers.

Chat Opens the chat widget, listing all the users in your groups,
showing their online status, and allowing you to chat with one or
more of them.

Editor Background A list of available backgrounds for the editing area.

Toolbars Shows a list of all available toolbars, allowing you to toggle their
visibility. Additionally, allows you to choose between showing no
labels next to icons, showing labels to the right of selected icons,
and showing labels under all icons.

Layers Allows you to show, hide and edit the document's master layer
and dynamic layer.

Show Properties Pane Toggles the visibility of the Properties pane.

Show Project Pane Toggles the visibility of the Project pane.

Show Status Bar Toggles the visibility of the Status bar.

Float Properties Pane Toggles the Properties pane between floating and docked modes.

Float Project Pane Toggles the Project pane between floating and docked modes.

Basic Properties Switches to basic properties mode, showing only the basic and
most common properties in the property grid.

Normal Properties Switches to normal properties mode, showing most of the
properties in the property grid.

Advanced Properties Switches to advanced properties mode, showing all of the
available properties in the property grid.

4.1.5 Insert

The insert menu allows you to insert different elements to the current document. To insert an element, simply
choose it from the menu, and it will be inserted.

The Float Elements option toggles between (when on) inserting elements as floating elements you can freely
position around the document, and (when off) inserting elements at the caret's position as static elements,
which are positioned according to the text and elements around them.

The following elements can be inserted from the insert menu:

Box

Text Elements

Image

Link

List
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Table

Frame

Media Player

Flash Animation

Shape

Narration

Sequence Manager

Variable

Social Media

Mashups

Navigation

Test Feedback

User Identification

Multiple Choice

Point Click

Drag Drop

Fill Blank

Hot Spots

Hot Word

Mind Games

4.1.6 Modify

The modify menu provides different operations you can apply to the selected element. Different options are
available, according to the element which is currently selected.

Link
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Unlink Cancels the link. Available only when a link is selected.

List

Toggle List Cancels the list.

Add List Item Adds a list item below the current one.

Indent List Item Increases indentation of the current list item.

Outdent List Item Decreases indentation of the current list item.

Table

Add Row Adds a row below the current one.

Add Column Adds a column after the current one.

Remove Row Removes the current row.

Remove Column Removes the current column.

Add Topmost Row Adds a row at the top of the table.

Add Leftmost Column Adds a column at the left of the table.

Table Cell

Add Row Below Adds a row below the current cell.

Add Column After Adds a column after the current cell.

Remove Current Row Removes the current row.

Remove Current Column Removes the current column.

Merge Rows Merges the current row with the one below it.

Merge Cells Merges the current cell with the one after it.

Split Row Splits the current cell, horizontally.

Split Cell Splits the current cell, vertically.

Test Feedback
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Test Summary Adds a test summary item, showing information about the entire
test.

Sections Summary Adds a sections summary item, listing information about each
section.

Test Details Adds a results details item, showing the result of each question.

Test Results Adds a test results item, showing the title and final score of the
test.

Test Pass Adds a test pass item, showing the passing score. Only shown
when test is passed.

Test Fails Adds a test fail item, showing the passing score. Only shown when
the test is failed.

Test Review Adds a review test item, allowing the viewer to review the test.

Re-test Adds a re-test item, allowing the viewer to retake the test.

Feedback

Sequence Manager... Opens the sequence manager for the feedback element.

Move Up Moves the selected feedback item up.

Move Down Moves the selected feedback item down.

Add Custom Feedback Adds a custom feedback item, shown when a specified condition is
met.

Add Range Feedback Adds a range feedback item, shown when the number of correct
answers is in a specified range.

Add Right Feedback Adds a right feedback item, shown when the answer is correct.

Add Wrong Feedback Adds a wrong feedback item, shown when the answer is incorrect.

Add Partial Feedback Adds a partial feedback item, shown when the answer is partially
correct.

Add Final Feedback Adds a final feedback item, shown after the last attempt.

Add Close Button Adds a close button, hides the feedback.

Add Try Again Button Adds a try again button.

Add Show Correction Button Adds a show correction button, shown after the last attempt.

Add Check Button Adds a check button, if one doesn't already exist.

Multiple Choice
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Add Answer Adds an additional answer. To remove answers, simply delete
them.

Add Hint Adds a hint element.

Drag Drop

Add Drag Drop Pair Adds an additional drag drop pair of drag item and drop area.

Add Drag Item To Pair Adds a drag item to the group of the selected item.

Add Drop Area To Pair Adds a drop area to the group of the selected item

Add Dummy Drag Item Adds a dummy drag item, which isn't taken into consideration in
the score calculation for the activity.. 

Add Dummy Drop Area Adds a dummy drop area, which isn't taken into consideration in
the score calculation for the activity..

Add Hint Adds a hint element.

Fill Blank

Add Writeable Blank Adds a writable blank which can be filled by the viewer.

Add Selectable Blank Adds a selectable blank with options the viewer can choose from.

Add Option Adds an option to the selected blank.

Add Range Option Adds a range option to the selected blank.

Add Mask Option Adds a mask (wildcard) option to the selected blank.

Add Hint Adds a hint element.

Hot Spots

Design-Time View Sets how hot popups are shown in design-time.
Show Contextual Popups - Only shows hot popups when they
are in context (when their related hot spot is actively selected).
Show All Popups - Shows all hot popups at all times.

Sequence Manager... Opens the sequence manager for the hot spots element.

Add Hot Spot Pair Adds an additional hot spot pair of hot spot and hot popup.

Add Hot Spot To Pair Adds a hot spot to the group of the selected item.

Add Hot Popup To Pair Adds a hot popup to the group of the selected item.
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Hot Word

Sequence Manager... Opens the sequence manager for the hot word element.

Hint

Sequence Manager... Opens the sequence manager for the hint element.

4.1.7 Format

The format menu allows you to control the formatting and style of different elements. Each of the operations are
applied to the selected element, or to selected text in the document.

Lock Group Locks an element so you can no longer edit its content and
children.

Unlock Group Unlocks a previously locked element.

Create Style Rule... Creates a style rule from the style of the selected element, as
either a class or an element style rule.

Flip Horizontally Horizontally flips the selected element and its children. Can also
flip images, if requested.

Bold Toggles the bold status of the selected element/text.

Italic Toggles the italic status of the selected element/text.

Underline Toggles the underline status of the selected element/text.

Border Style Sets the border style of the selected element.

Border Width Sets the border width of the selected element.

Font Family Sets the font family of the selected element/text.

Font Size Sets the font size of the selected element/text.

Text Align Sets the text alignment of the selected element/text.

Writing Direction Sets the writing direction of the selected element.

Order Sets the depths (z-index) of the selected elements.

Center in Parent Centers the selected element, either vertically, horizontally, or
both, within its parent element.

Fit Fits the size and position of the selected element to its parent
element, or of the parent element to the selected element.
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4.1.8 Layout

The layout menu provides several operations for controlling the layout of multiple elements. The menu is only
available when multiple items are selected.

Align Aligns the selected elements according to the actively selected
element, either vertically or horizontally.

Distribute Evenly distributes the selected elements' positions, either
vertically or horizontally, according to the two outmost elements.
Similar to space, but doesn't take the elements sizes into account.

Space Evenly spaces the selected elements, either vertically or
horizontally, according to the two outmost elements. Similar to 
distribute, but takes the elements sizes into account keeping the
spaces between them equal.

Fit Size Fits the size of all elements to the actively selected element.

4.1.9 Tools

The tools menu provides miscellaneous useful tools.

Apply Widget... Opens the Select Resource dialog, allowing you to select a widget
to apply in the current document.

Media Explorer Opens the Media Explorer.

Upload... Opens the multiple file upload dialog, allowing you to upload
resources to your project.

Dings Map... Shows a list of dings in different fonts you can quickly add at the
caret's position.

Sequence Manager... Opens the Sequence Manager. If elements are selected, they are
the elements which will take part in the sequence.

Spell Check... Checks spelling on the entire document. If errors are found, a
dialog with suggestions is shown, allowing you to correct the error.
After finishing, the status bar shows how many errors were found,
and how many words were altered.

Change Password... Opens the change password dialog, allowing you to change your 
Composica password.

4.1.10Help

The help menu provides with helpful and informative options.

Content and Index Opens the Composica help manual.

Getting Started Opens the Composica getting started manual.

Keyboard Map Shows a list of available keyboard shortcuts.

Send Feedback

About Composica Opens the about dialog.
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4.1.11Context menu

The context menu appears when right-clicking on elements or on the document. The context menu allows for
quick access to different options which are also available via the main menu.

Select Parent Selects the direct parent of the selected element. See Edit >
Select Parent.

Select Ancestor Allows you to select one of the selected element's ancestors. See 
Edit > Select Ancestor.

Insert A clone of the Insert menu.

Modify A clone of the Modify menu.

Format A clone of the Format menu.

Layout A clone of the Layout menu.

Cut Copies the current selection to the clipboard, and removes it from
the document.

Copy Copies the current selection to the clipboard.

Paste Pastes the contents of the clipboard at the caret's position, as
plain text.

Paste Special Pastes the contents of the clipboard along with formatting and
styles at the caret's position. Allows you to copy content and
elements from other documents or from programs such as
Microsoft Word.

4.2 Toolbars

The toolbars are positioned at the top of the user interface, below the menu, and allow quick access to the most
useful menu items. You can customize the toolbars appearance and choose which toolbars to display through
the View > Toolbars menu.

Each page in this chapter denotes a toolbar. In each page you will find a screenshot of the toolbar, and a list of
all the toolbar's buttons, along with the icon and a description of each. The icon links each toolbar button to it's
equivalent menu item.

§ Document
§ Edit
§ Group
§ Insert
§ Format
§ Layout
§ Table
§ Tools

4.2.1 Document

New Document Creates a new document.

Open Document Opens the Select Resource dialog, allowing you to open outline
items, master layers, menus, widgets or pop-ups.
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Save Document Saves the current document, or if it's a new document, opens the
Save As dialog.

Preview Document Previews the current document. Even when previewing the current
document, the entire project is available for navigation.

Project Dashboard Shows or hides the Project Dashboard, containing various project
related widgets.

Manage Project Opens the Project Manager, allowing you to manage different
aspects of the project.

Tasks Opens the Related Tasks dialog, allowing you to manage tasks for
the current document.

Tags Opens the Assign Document Tags dialog, allowing you to assign
tags to the current document.

Chat Opens the chat widget, listing all the users in your groups,
showing their online status, and allowing you to chat with one or
more of them.

4.2.2 Edit

Layers Allows you to show, hide and edit the document's master layer
and dynamic layer.

Cut Copies the current selection to the clipboard, and removes it from
the document.

Copy Copies the current selection to the clipboard.

Paste Pastes the contents of the clipboard at the caret's position, as
plain text.

Paste Special Pastes the contents of the clipboard along with formatting and
styles at the caret's position. Allows you to copy content and
elements from other documents or from programs such as
Microsoft Word.

Erase Content Clears the content of the selected element.

Delete Deletes the selected element or text.

Drag Select Toggles drag select mode, allowing you to drag and select several
elements with a single mouse click.

Select Parent Selects the direct parent of the selected element.

Undo Reverts the last change to the document.

Redo Restores the last change reverted by undo.

Find Opens the find dialog, allowing you to search for text in the
current document.

4.2.3 Group

Lock Group Locks an element so you can no longer edit its content and
children.

Unlock Group Unlocks a previously locked element.
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Create Style Rule... Creates a style rule from the style of the selected element, as
either a class or an element style rule.

4.2.4 Insert

Each button of the insert toolbar allows you to insert an element at the caret's position, identically to the Insert
menu.

The following elements can be inserted from the insert toolbar:

Insert Box

Insert Image

Insert Link

Insert List

Insert Table

Insert Multiple Choice

Insert Drag Drop

Insert Fill Blank

Insert Hot Spots

Insert Hot Word

Game Picker

4.2.5 Format

Bold Toggles the bold status of the selected element/text.

Italic Toggles the italic status of the selected element/text.

Underline Toggles the underline status of the selected element/text.

Color Sets the text color of the selected element/text. Remembers the
last used color.

Fill Color Sets the background color of the selected element/text.
Remembers the last used color.

Border Color Sets the border color of the selected element. Remembers the last
used color.

Border Style Sets the border style of the selected element.

Border Width Sets the border width of the selected element.

Font Family Sets the font family of the selected element/text.

Font Size Sets the font size of the selected element/text.

Text Align Sets the text alignment of the selected element/text.

Writing Direction Sets the writing direction of the selected element.
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Order Sets the depths (z-index) of the selected elements.

Center in Parent Centers the selected element, either vertically, horizontally, or
both, within its parent element.

4.2.6 Layout

Align Aligns the selected elements according to the actively selected
element, either vertically or horizontally.

Distribute Evenly distributes the selected elements, either vertically or
horizontally, according to the two outmost elements.

Fit Size Fits the size of all elements to the actively selected element.

The layout toolbar is only active when multiple elements are selected.

4.2.7 Table

Add Row Adds a row below the current one.

Add Column Adds a column after the current one.

Delete Row Removes the current row.

Delete Column Removes the current column.

Merge Rows Merges the current row with the one below it.

Merge Cells Merges the current cell with the one after it.

Split Row Splits the current cell, horizontally.

Split Cell Splits the current cell, vertically.

4.2.8 Tools

Spell Check Checks spelling on the entire document. If errors are found, a
dialog with suggestions is opened, allowing you to correct the
error. After finishing, the status bar shows how many errors were
found, and how many words were altered.

Sequence Manager Opens the Sequence Manager. If elements are selected, they are
the elements which will take part in the sequence.

Upload Multiple Files Opens the multiple file upload dialog, allowing you to upload
resources to your project.

Media Explorer Opens the Media Explorer.

Apply Widgets Opens the Select Resource dialog, allowing you to select a widget
to apply in the current document.
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4.3 Properties pane

The properties pane allows you to modify different properties for
elements in your project. The properties pane updates according to your current selection, and shows the real-
time state of your elements.

The properties pane consists of several tabs, and the properties grid. The tabs separate properties to 4
categories:

§ Text, listing all the properties related to the text of the element and it's presentation.

§ Layout, listing all the properties related to the element's layout and visual appearance.

§ Style, listing all properties related to the styling of the element.

§ Settings, listing miscellaneous element-specific settings.

Properties grid

The properties grid lists all the properties of the selected tab, and their current values, accordingly. The available
properties can change from element to element.

To change a property, select it on the grid, and click its value. Each property type has a different editor, allowing
you to enter or select values which are appropriate for that property.

Changes are displayed in real-time, so you can instantly see their effect.

Filtering properties

All properties available in Composica are separated to 3 levels: basic, normal, and advanced. You can choose to
filter the properties you see to one of the levels, according to your level of expertise and personal preference.

To switch between the different modes, use one of the three menu items: Basic properties, Normal properties,
Advanced properties.

Floating the pane

To float the pane, either choose the View > Float Properties Pane menu item, or drag the pane by its caption
from its position. Once floating, you can drag the pane around and position it as you wish.

To dock the pane, either toggle the View > Float Properties Pane menu item off, or drag the pane back to its
docked position.
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4.4 Project pane

The project pane allows you to overview two aspects of your project:
the project outline, and the media tree.

Project outline

The project outline is identical to the one in the Project Manager. The currently open document is marked in
bold in the list.

To open a document from the tree for editing, either right-click it and choose Open Document, or double-click on
it.

To preview a document, right-click it and choose Preview Document....

Media tree

The media library tree, identical to the one in the Media Explorer, lists all the available media files for the current
project.

The tree is divided into two main categories:

§  Project, which holds the uploaded media files for the currently open project.

§  Public, which is a public media repository available to all projects, divided into different sections.

All the media files are separated according to their types: Images, Animations, Movies, Sounds, and Misc.

To insert a media file, double-click on it, and it will be inserted to the active document.

Floating the pane

To float the pane, either choose the View > Float Project Pane menu item, or drag the pane by its caption from
its position. Once floating, you can drag the pane around and position it as you wish.

To dock the pane, either toggle the View > Float Project Pane menu item off, or drag the pane back to its
docked position.
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4.5 Select Project

The Select Project dialog lets you choose a
project to open, from any project in the system you have access to.

The projects in the tree are divided by the following, for easy access:

§ Recent - Lists the recently accessed projects.

§ Tagged - Lists each tag, and the projects associated with that tag.

§ All - Lists all projects, divided by:

§ Type - Either Projects or Templates.

§ Group - Lists each user group, and the projects associated with that group.

§ Owner - Lists each user, and the projects they own.

Filter by Tags

To further filter projects by a specific set of tags:

1.  Press the Filter by Tags button, to open the Filter Projects by Tags dialog.

2.  Select the tags you wish to filter by. To select multiple tags, hold down the Ctrl key and press each of the
tags you wish to filter by.

3.  Press the Filter button to set the filter.

4.  The tree will now have an additional branch, titled "Results For:" and the list of tags you've selected.
Underneath that branch will be listed all the projects which have all the tags of the filter assigned to them.

To make another search, simply repeat the process.
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4.6 Select Resource

The select resource dialog is used in various situations where a document needs to be selected, such as when
opening or saving a document.

Path

Shows the current path.

List

Shows a list the documents of the currently selected resource category, within the current path. Select a
document by pressing it, and double-click it to see the documents underneath it.

Document

The document area lets you enter the title of the document, and select its type.

Category

Gives a choice of any of the available resource categories:

§ Outline

§ Master Layers

§ Dynamic Layers

§ Widgets

§ Pop-ups

New Chapter

Creates a new chapter at the current path.
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4.7 Project Manager

The Project Manager allows you to manage different aspects of your project including its outline and resources,
its properties, and the tasks for each document. Any changes made in the Project Manager are not effective until
saved.

Menu

The main menu is divided into four menus:

§ Project, listing project-wide options.

§ Edit, listing operations relevant to the tree.

§ Import, listing import related operations.

§ Tasks, listing task related operations.

Toolbar

The toolbar offers quick access to most of the operations available from the main menu.

Tree

The tree allows you to overview two aspects of your project:
§ Outline, listing all the outline items in your project.
§ Resources, listing all the resource documents used in your project.

Properties

The properties section allows you to view and change the properties available for the selected item in the tree.
Each item may have different properties available.
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Tasks

The tasks list shows tasks related to the selected item in the tree, along with their status. Adding, removing and
editing tasks can all be done through the menu and toolbar.

4.7.1 Menu

Project

Run-time Properties... Opens the Run-time Properties dialog, allowing you to customize
the appearance and behavior of the course in run-time.

Add System Style... Opens the Add System Style dialog, allowing you to select one of
the system styles listed, so it will be available to the project and
can be assigned to any of the documents.

Save Project Saves the current state of the project.

Delete Project... Deletes the project from the system. Once the deletion is
confirmed, the project will be removed completely, and cannot be
recovered.

Edit Metadata... Opens the Metadata Editor dialog, allowing you to configure
various project metadata.

Assign Tags... Opens the Tag dialog, allowing you to assign tags to the project so
it can be easily found.

Assign Groups... Opens the Groups dialog, allowing you to assign groups of users
which can view and edit the project.

Outline Report... Generates an outline report, listing the outline tree, starting from
the currently selected document. In the outline report, press the 
Up button to move to the parent node's outline report.

Close Closes the Project Manager.

Edit

Design Document Closes the Project Manager, and opens the selected document for
edit.

Add Page After Adds a page after the selected document.

Add Page Inside Adds a page inside the selected document.

Add Chapter After Adds a chapter after the selected document.

Add Chapter Inside Adds a chapter inside the selected document.

Add Test After Adds a test after the selected document.

Add Test Inside Adds a test inside the selected document.

Add Test Section After Adds a test section after the selected document.

Add Test Section Inside Adds a test section inside the selected document.
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Cut Copies the selected document to the clipboard, and removes it
from the tree.

Copy Copies the selected document to the clipboard.

Paste After Pastes the document from clipboard after the selected document.

Paste Inside Pastes the document from clipboard inside the selected document.

Delete Deletes the selected document.

Import

Import After... Opens the Import dialog, allowing you to import documents from
other projects after the selected document.

Import Inside... Opens the Import dialog, allowing you to import documents from
other projects inside the selected document.

Import PowerPoint After... Opens the Import PowerPoint Presentation dialog, allowing you to
import a PowerPoint presentation after the selected document.

Import PowerPoint Inside... Opens the Import PowerPoint Presentation dialog, allowing you to
import a PowerPoint presentation inside the selected document.

Tasks

Add Adds a new task to the selected document.

Remove Removes the selected task.

Edit Description... Opens a small dialog allowing you to edit (multi-line) the
description of the selected task.

Mark as Done Marks the selected task as done.

Mark as Undone Marks the selected task as undone.

Task Reports... Opens task reports for the selected document (and its
descendants), listing and summarizing the tasks.

4.7.2 Toolbar

Save Project Saves the current state of the project.

Add Page After Adds a page after the selected document.

Add Page Inside Adds a page inside the selected document.

Add Chapter After Adds a chapter after the selected document.

Add Chapter Inside Adds a chapter inside the selected document.

Add Test After Adds a test after the selected document.

Add Test Inside Adds a test inside the selected document.
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Add Test Section After Adds a test section after the selected document.

Add Test Section Inside Adds a test section inside the selected document.

Design Document Closes the Project Manager, and opens the selected document for
edit.

Cut Copies the selected document to the clipboard, and removes it
from the tree.

Copy Copies the selected document to the clipboard.

Paste After Pastes the document from clipboard after the selected document.

Paste Inside Pastes the document from clipboard inside the selected document.

Delete Deletes the selected document.

Import After... Opens the Import dialog, allowing you to import documents from
other projects after the selected document.

Import Inside... Opens the Import dialog, allowing you to import documents from
other projects inside the selected document.

Import PowerPoint After... Opens the Import PowerPoint Presentation dialog, allowing you to
import a PowerPoint presentation after the selected document.

Import PowerPoint Inside... Opens the Import PowerPoint Presentation dialog, allowing you to
import a PowerPoint presentation inside the selected document.

Add System Style... Opens the Add System Style dialog, allowing you to select one of
the system styles listed, so it will be available to the project and
can be assigned to any of the documents.

Assign Tags... Opens the Tag dialog, allowing you to assign tags to the project so
it can be easily found.

Add Adds a new task to the selected document.

Remove Removes the selected task.

Mark as Done Marks the selected task as done.

Mark as Undone Marks the selected task as undone.

Task Reports... Opens task reports for the selected document (and its
descendants), listing and summarizing the tasks.
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4.8 Media Explorer

The media explorer allows you to manage, preview, and select media files from the project library, the public
library, or other projects' media repository.

Toolbar

The toolbar provides options to upload media to your project, refresh the media tree, remove uploaded files,
download files from the library, and toggle the preview and thumbnails view.

Tree

The media library tree lists all the available media for the current project.

The tree is divided into three main categories:

§ Project, which holds the uploaded media files for the currently open project.

§ Public, which is a public media repository available to all projects, divided into different sections.

§ Other Projects, which gives access to the media libraries of any other project the developer has access to.

All the media files are separated according to their types: Images, Animations, Movies, Sounds, and Misc.

Preview

The preview pane shows a preview of the selected media file, along with information about it such as type, size,
and dimensions.

Thumbnails

The thumbnails pane shows a scrollable list of thumbnails, giving a quick view through the media files in the
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current folder.

Tagging

Each media file in the Media Explorer can have one or more tags assigned to it in its Tags field, to assist in
organizing different media files, find them quickly and reuse them when necessary.

4.8.1 Toolbar

Upload Media Files Opens the Upload dialog, allowing you to select multiple files and
upload them to the central media library.

Refresh Media Files Refreshes the selected media folder.

Remove Media Files Removes the selected media item from the Projects folder. After
confirming the removal, the item will be removed from the
system, and cannot be recovered.

Download Media Files Allows downloading media files from the Media Explorer and
storing them locally.

Toggle Preview Pane Toggles the visibility of the preview pane.

Toggle Thumbnails Toggles the visibility of the thumbnails pane.

4.9 Sequence Manager

The sequence manager allows you to manage and configure effects and narration for your documents and
elements. Several features may not be available in all modes. For information about the associated element, see
the Sequence Manager element page.
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Main

In the main tab, you can configure different properties for the sequence manager, control the type, speed,
duration, and other properties of the sequence. Some effect types have additional properties which become
available when selected.

You can preview the current configuration by pressing on the preview area at the bottom.

Elements

When available, the elements tab allows you to specify attributes for each element. When set to inherit, the
elements use the values configured in the main tab. It also enables you to change the order of appearance for
the elements, when setting <Order> to custom.

4.10 Status bar

The status bar shows useful information about the current Composica activity.

Status

Shows the current activity status. Says "Ready" when Composica is ready for user interaction.

Project

Shows the name of the active project.

Document

Shows the name of the active document.

Element

Shows the name of the currently selected element.

Group

Shows a lock icon when the currently selected item is grouped.

Tasks

Shows an icon when the current document has open tasks. See Tasks system.

Mode

Shows the current editing mode (Design or HTML).

4.11 Keyboard shortcuts

Most frequently used operations in Composica have keyboard shortcuts. To see an updated list of shortcuts, use
the Help > Keyboard Map menu item.

Document

New Ctrl+N

Open... Ctrl+O

Save Ctrl+S

Preview Document... F9

Close Alt+X
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Project

Manage Project... F4

Preview Project... F8

Open Project... Ctrl+Alt+O

Edit

Undo Ctrl+Z

Redo Ctrl+Y

Cut Ctrl+X

Copy Ctrl+C

Paste Ctrl+V

Paste Special Ctrl+Alt+V

Erase Content Ctrl+Alt+E

Duplicate Ctrl+D

Delete Del

Drag Select Alt+Drag

Select Parent Ctrl+W

Select All Ctrl+A

Find... Ctrl+F

Replace... Ctrl+H

View

Design Mode Ctrl+E

Show Properties Pane Alt+O

Show Project Pane Alt+R

Insert

Header 1 Ctrl+Alt+H

Image Ctrl+M

Link Ctrl+K

Table Ctrl+T

Hot Word Ctrl+Alt+W

Modify

Toggle List Ctrl+L

Add Row Ctrl+Alt+R

Add Column Ctrl+Alt+C

Format
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Bold Ctrl+B

Italic Ctrl+I

Underline Ctrl+U

Tools

Apply Widget... Alt+W

Media Explorer... F6

Upload... Alt+U

Spell Check... F7

Help

Content and Index F1



Part

V

Elements
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The following element reference lists each element available in Composica, its description, its usage, and its
available properties. If an element consists of other sub-element, those are listed along with their respective
properties.

Each list of properties is divided to sections matching the tabs of the property grid, and the name, type, and
description for each property is listed. Rows marked with a darker background color are advanced properties.

§ Property types

§ Common properties
§ Text
§ Layout
§ Style
§ Settings

§ Basic
§ Box
§ Separator
§ Text Elements
§ Link
§ List
§ Table
§ Frame
§ Marquee

§ Media
§ Image
§ Media Player
§ Flash Animation

§ Shapes
§ Navigation
§ Project Title
§ Document Title
§ Navigation Button
§ Navigation Link
§ Popup Button
§ Breadcrumbs
§ Progress Bar
§ Navigation Locator
§ Timer
§ Tree Menu
§ Compact Tree Menu
§ One-Level Menu

§ Activities
§ Multiple Choice
§ Point Click
§ Drag Drop
§ Hot Spots
§ Fill Blank
§ Hot Word
§ Feedback
§ Hint

§ Other
§ Variable
§ Test Feedback
§ User Identification
§ Sequence Manager

§ Mind Games
§ Master Plumber
§ Space Bubbles
§ High Hops
§ Rescue Mission
§ Game Show
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5.1 Property types

Listed along each property in the element reference is the property's type. Following is a list of the possible
property types and their descriptions:

Number Shows a number spin, allowing you to enter a number.

Unit Shows a number spin, and a unit selection spin.

Point Shows a pair of number spins, allowing you to enter a point on two axes.

Text Shows an input, allowing you to enter text.

Select Shows a list of options, which you can select one from.

Color Shows a color picker, allowing you to select a color, or transparent where applicable.

Media Opens the Media Explorer, allowing you to select a media file.

Style Rule Opens the Style Rules dialog, allowing you to select a style rule.

Resource Opens the Select Resource dialog, allowing you to select a resource.

Condition Opens the Custom Feedback Conditions dialog, allowing to specify a certain answer
combination.

5.2 Common properties

Most of the properties in Composica are common to all elements. These properties are listed in the following
pages, divided according to the tabs of the property grid.

§ Text
§ Layout
§ Style
§ Settings

5.2.1 Text

Basic

Color Color Text color. Can also be set via the Color toolbar
button.

Font Select Text's font name. Can also be set via the Font
Family toolbar button.

Font Size Unit Text's font size. Can also be set via the Font Size
toolbar button.

Font Style Select normal - Normal font style.
italic - Italic font style.
Can also be set via the Italic toolbar button.

Font Weight Select normal - Normal font weight.
bold - Bold font weight.
Can also be set via the Bold toolbar button.

Text Align Select left - Text is aligned to the left.
right - Text is aligned to the right.
center - Text is centered.
justify - Text is justified.
Can also be set via the Text Align toolbar button.

Text Decoration Select none - No text decoration.
underline - Text is underlined. Can also be set
via the Underline toolbar button.
overline - Text has a line over it.
line-through - Text has a line going through it.
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Normal

Font Variant Select normal - Font is normal.
small-caps - Font is in small capital letters.

Letter Spacing Unit Spacing between letters.

Line Height Unit Distance between lines.

Text Autospace Select Autospacing and narrow space width adjustment of
text.
none - No extra space is added.
ideograph-alpha - Extra spacing between runs of
ideographic and non-ideographic text.
ideograph-numeric - Extra spacing between runs
of ideographic text and numeric characters.
ideograph-parenthesis - Extra spacing between
a normal (non-wide) parenthesis and an ideograph.
ideograph-space - Extends the width of the
space character when it is adjacent to ideographs.

Text Indent Unit Indentation of the first line of text.

Text Overflow Select ellipsis - Display ellipsis (...) for overflowing text.
clip - Clip overflowing text.

Text Transform Select none - No text transformation.
capitalize - First letter of each word is capitalized.
uppercase - Text is transformed to uppercase.
lowercase - Text is transformed to lowercase.

Word Wrap Select normal - Content exceeds the boundaries of its
container.
break-word - Content wraps to next line, and a
word-break occurs when necessary.

Advanced

Text Justify Select auto - Automatically determine justification
algorithm.
distribute - Similar to newspaper, optimized for
Asian languages, such as Thai.
distribute-all-lines - Similar to distribute, but
also justifies the last line of the paragraph.
Optimized for ideographic text.
inter-cluster - Justifies lines of text that contain
no inter-word spacing. Optimized for Asian
languages.
inter-ideograph - Justifies lines of ideographic
text, and increases or decreases both inter-
ideograph and inter-word spacing.
inter-word - Aligns text by increasing spacing
between words, in each line but the last.
kashida - Justifies lines of text by elongating
characters at chosen points. Optimized for Arabic
script languages.
newspaper - Increases or decreases the spacing
between letters and between words.

Unicode Bidi Select normal - Element does not open an additional
level of embedding. For inline elements, implicit
reordering works across element boundaries.
embed - Element opens an additional level of
embedding. Reordering is implicit inside the
element.
bidi-override - Same as the embed, but this
value overrides the implicit bidirectional algorithm.
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White Space Select normal - Lines of text break automatically.
Content wraps to the next line if it exceeds the
width of the object.
nowrap - Line breaks are suppressed. Content
does not wrap to the next line.

Word Break Select normal - Allows line breaking within words.
break-all - Behaves the same as normal for Asian
text, yet allows the line to break arbitrarily for non-
Asian text. Optimized for Asian text containing
excerpts of non-Asian text.
keep-all - Behaves the same way as normal for
all non-Asian languages. Optimized for text that
includes small amounts of Chinese, Japanese, or
Korean.

Writing Mode Select lr-tb - Text flows horizontally - from left to right,
top to bottom. Used in Roman-based typography.
tb-rl - Text flows vertically - from top to bottom,
right to left. Non-wide-cell glyphs are rotated
90-degrees clockwise. Used in East Asian
typography.

5.2.2 Layout

Basic

Border Color Color Border color. Can also be set via the Border Color
toolbar button.

Border Style Select none - No border is shown.
dotted - Border is a dotted line.
dashed - Border is a dashed line.
solid - Border is a solid line.
double - Border is a double solid line.
groove - 3d groove, in colors based on <Border
Color>.
ridge - 3d ridge, in colors based on <Border
Color>.
inset - 3d inset, in colors based on <Border
Color>.
outset - 3d outset, in colors based on <Border
Color>.
Can also be set via the Border Style toolbar button.

Border Width Unit Thickness of the border. Only relevant when
<Border Style> is other than none. Can also be
set via the Border Width toolbar button.

Direction Select ltr - Content flows from left to right.
rtl - Content flows from right to left.
Can also be set via the  Writing Direction toolbar
button.

Fill Color Color Color to use as the background of the element. Can
also be set via the Fill Color toolbar button.

Fill Image Media Image to use as the background of the element.

Position Select static - Element has no special position, it follows
the flow of its parent's content.
absolute - Element is positioned relatively to its
parent element.
relative - Element is positioned relatively to its
position in the flow of its parent's content.

Position / Bottom Unit Offset from the bottom, according to <Position>.
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Position / Left Unit Offset from the left, according to <Position>.

Position / Right Unit Offset from the right, according to <Position>.

Position / Top Unit Offset from the top, according to <Position>.

Size / Height Unit Height of the element.

Size / Width Unit Width of the element.

Normal

Fill Image Align X Select left - Align <Fill Image> to the left of the element.
center - Align <Fill Image> to the center of the
element, horizontally.
right - Align <Fill Image> to the right of the
element.

Fill Image Align Y Select top - Align <Fill Image> to the top of the element.
center - Align <Fill Image> to the center of the
element, vertically.
bottom -Align <Fill Image> to the bottom of the
element.

Fill Repeat Select repeat - <Fill Image> is tiled horizontally and
vertically, to fit the element's size.
no-repeat - <Fill Image> is not tiled.
repeat-x - <Fill Image> is tiled horizontally, to fit
the element's width.
repeat-y -<Fill Image> is tiled vertically, to fit the
element's height.

Float Select none - Element is displayed in it's position in its
parent's content flow.
left - Content of the parent element flows to the
left of the element.
right - Content of the parent element flows to the
right of the element.

Margin Unit Margin of the element from the content
surrounding it.
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Mouse Cursor Select all-scroll - Arrows pointing up, down, left, and
right with a dot in the middle, indicating that the
page can be scrolled in any direction.
auto - Automatically determine which cursor to
display based on the current context.
col-resize - Arrows pointing left and right with a
vertical bar separating them, indicating an
item/column can be resized horizontally.
crosshair - A cross-hair.
default - The default system cursor.
hand - Hand with the first finger pointing up,
indicating pressing the element will result in an
action.
help - Arrow with question mark, indicating help is
available.
move - Crossed arrows, indicating the element is
to be moved.
no-drop - Hand with a small circle with a line
through it, indicating that the dragged item cannot
be dropped over the element.
not-allowed - Circle with a line through it,
indicating an action is not allowed.
pointer - Identical to hand.
progress - Arrow with an hourglass next to it,
indicating that a process is running in the
background.
row-resize - Arrows pointing up and down with a
horizontal bar separating them, indicating an
item/row can be resized vertically.
text - A vertical I-bar, indicating the text is
editable.
vertical-text - A horizontal I-bar, indicating the
text is editable.
wait - An hourglass, indicating a process is
currently running.
N-resize - North pointing arrow, indicating an item
can be resized.
NE-resize - North-east pointing arrow, indicating
an item can be resized.
NW-resize - North-west pointing arrow, indicating
an item can be resized.
S-resize - South pointing arrow, indicating an
item can be resized.
SE-resize - South-east pointing arrow, indicating
an item can be resized.
SW-resize - South-west pointing arrow, indicating
an item can be resized.
E-resize - East pointing arrow, indicating an item
can be resized.
W-resize - West pointing arrow, indicating an item
can be resized.

Padding Unit Padding of the element, between its edges and its
contents.

Visibility Select inherit - Element inherits its visibility from it's
parent element.
visible - Element is visible.s
hidden - Element is invisible.

Z Index Number A number indicating the element's position in the
stacking order. An element with a higher number is
displayed above an element with a lower number.

Advanced

Border Bottom Color Color Color of the bottom section of the border.
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Border Bottom Style Select Same as <Border Style>, affecting only the bottom
section of the border.

Border Bottom Width Unit Thickness of the bottom section of the border. Only
relevant when <Border Bottom Style> is other
than none.

Border Left Color Color Color of the left section of the border.

Border Left Style Select Same as <Border Style>, affecting only the left
section of the border.

Border Left Width Unit Thickness of the left section of the border. Only
relevant when <Border Left Style> is other than 
none.

Border Right Color Color Color of the right section of the border.

Border Right Style Select Same as <Border Style>, affecting only the right
section of the border.

Border Right Width Unit Thickness of the right section of the border. Only
relevant when <Border Right Style> is other than 
none.

Border Top Color Color Color of the top section of the border.

Border Top Style Select Same as <Border Style>, affecting only the top
section of the border.

Border Top Width Unit Thickness of the top section of the border. Only
relevant when <Border Top Style> is other than 
none.

Clear Select none - Element can be displayed alongside floating
content.
left - Element is moved below any floating content
on its left.
right - Element is moved below any floating
content on its right.
both - Element is moved below any floating
content.

Display Select block - Element is rendered as a block element.
none - Element is not rendered.
inline - Element is rendered as an inline element.

Fill Image Position X Unit Horizontal position of <Fill Image>, according to
<Fill Image Align X>.

Fill Image Position Y Unit Vertical position of <Fill Image>, according to <Fill
Image Align Y>.

Line Alignment Select top - Vertically aligns text lines to the top.
bottom - Vertically aligns text lines to the bottom.

Margin Bottom Unit Margin of the element from the content to the
bottom of it.

Margin Left Unit Margin of the element from the content to the left
of it.

Margin Right Unit Margin of the element from the content to the right
of it.

Margin Top Unit Margin of the element from the content to the top
of it.
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Overflow-X Select visible - Content exceeding the width of the
element is not clipped, and  a horizontal scroll bar
is not added.
scroll - A horizontal scroll bar is added, and
content exceeding the width of the element is
clipped.
hidden - Content exceeding the width of the
element is clipped, and a horizontal scroll bar is not
added.
auto - Content exceeding the width of the element
is clipped, and a horizontal scroll bar is added when
necessary.

Overflow-Y Select visible - Content exceeding the height of the
element is not clipped, and  a vertical scroll bar is
not added.
scroll - A vertical scroll bar is added, and content
exceeding the height of the element is clipped.
hidden - Content exceeding the height of the
element is clipped, and a  vertical scroll bar is not
added.
auto - Content exceeding the height of the
element is clipped, and a  vertical scroll bar is
added when necessary.

Padding Bottom Unit Padding of the element, between its bottom edge
and its contents.

Padding Left Unit Padding of the element, between its left edge and
its contents.

Padding Right Unit Padding of the element, between its right edge and
its contents.

Padding Top Unit Padding of the element, between its top edge and
its contents.

Page Break After (Print) Select always - In print, always insert a page break after
an element.
auto - In print, automatically determine whether
to insert a page break after an element.

Page Break Before (Print) Select always - In print, always insert a page break
before an element.
auto - In print, automatically determine whether
to insert a page break  before an element.

Scrollbar 3d Light Color Color Color of the top and left edges of the scroll box,
and scroll arrows of the scroll bar.

Scrollbar Arrow Color Color Color of the arrows of the scroll bar.

Scrollbar Base Color Color Base color of the scroll bar.

Scrollbar Dark Shadow Color Color Color of the bottom and right edges of the scroll
box, and scroll arrows of the scroll bar.

Scrollbar Face Color Color Face color of the scroll bar.

Scrollbar Highlight Color Color Highlight color of the scroll bar.

Scrollbar Shadow Color Color Shadow color of the scroll bar.

Zoom Unit Magnification scale of the element and its contents.

5.2.3 Style

Basic
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Style Rule Style Rule Style rule to apply to the element.

Common elements might also have style properties which relate to effects and narration. For more information, see the Sequence
Manager element.

5.2.4 Settings

Basic

Tooltip Text Advisory information to show when the mouse is
over the element.

Advanced

Hide Focus Select 1 - Hides visible indication for focus.
0 - Focus is visibly indicated by a dotted rectangle
around the element.

Tab Index Number Index of the element in the tabbing order. A
negative value omits the element from the tabbing
order.

5.3 Basic

Basic elements are the simplest and most generic elements in Composica, which are likely to be used in any
document. These elements have little to no functionality, and can be fitted to many uses.

§ Box
§ Separator
§ Text Elements
§ Link
§ List
§ Table
§ Frame
§ Marquee

5.3.1 Box

Box elements are generic elements, with no specific purpose. A box can contain any content or elements, and
can be used for laying out text or as a design building block.

It's generally advised to put every section of content in a box, which aids in easily organizing the document and
promotes the modularity of the content.

To insert a box element, use the Insert > Box menu item, or press the Insert Box toolbar button.

Settings

Link To Text A URL to open when pressing the box.

Linked Window Name Text The name of the window to open the <Link To>
URL in. If no window name is given, the URL will be
opened in a new window. Only relevant when a
URL is set.

5.3.2 Separator

A separator element is a special case of a box, and its visual appearance is defined by the document's style.

To insert a horizontal separator element, use the Insert > Text Elements > Horizontal Separator menu item. To
insert a vertical separator element, use the Insert > Text Elements > Vertical Separator menu item.
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5.3.3 Text Elements

Text elements are generic elements, and their visual appearance is defined by the document's style.

Each text element type can be customized by creating a style rule for that element. To learn more, see style
rules.

To insert a text element, use one of the Insert > Text Elements menu items:

§ Header 1 - Large header

§ Header 2 - Medium header

§ Header 3 - Small header

§ Footer 1 - Large footer

§ Footer 2 - Small footer

§ Instructions

§ Comment

§ Quote

Settings

Link To Text A URL to open when pressing the box.

Linked Window Name Text The name of the window to open the <Link To>
URL in. If no window name is given, the URL will be
opened in a new window. Only relevant when a
URL is set.

5.3.4 Link

Links are inline elements which allow linking external URL's to open when the link is pressed. To change an
existing link's text, edit its content.

To insert a link, select a segment of text, and use the Insert > Link menu item, or press the Insert Link toolbar
button. Inserting a link without selecting a segment of text will append a link to the current text.

Settings

URL Text A URL to open when pressing the link.

Window Name Text A target window name to open the link in. If no
name given, the link will open in a new window.

5.3.5 List

Lists display lines of text as list items with a marker next to each.

To convert existing text to a list, select one or more lines of text, and use the Insert > List menu item, or press
the Insert List toolbar button. To add an empty list, use the Insert > List menu item or press the Insert List
toolbar button without any selection.

To convert a list back to lines of test, select it and use the Modify > List > Toggle List menu item. To add a list
item to a list, select it and use the Modify > List > Add List Item menu item.

Style

List Style Image Text



Elements 78

© 2009 Composica Ltd.

List Style Position Select outside - Marker is placed outside the text, and
wrapped text is aligned after the marker.
inside - Marker is placed inside the text, and
wrapped text is aligned under the marker.

List Style Type Select The marker type to appear next to each list item.

List Item

Each list item of the list is a list item element. 

To indent a list item, select it and use the Modify > List > Indent List Item menu item. To outdent a list item,
select it and use the Modify > List > Outdent List Item menu item.

5.3.6 Table

Tables are used to represent tabular data in a document.

To insert a table element, use the Insert > Table menu item, or press the Insert Table toolbar button.

For table manipulation, see the Modify > Table menu items, the Modify > Table Cell menu items, and the Table
toolbar.

Style

Border Collapse Select separate - Adjacent borders are separated.
collapse - Adjacent borders are collapsed to a
single border.

Cell Padding Number Padding, in pixels, to apply to each cell of the
table.

Cell Spacing Number Spacing, in pixels, to apply between each cell of
the table.

Outline Depth Number Thickness of the table's outline, in pixels.

Table Layout Select auto - Column width is automatically determined
by the widest unbreakable content in the column's
cells.
fixed - Column widths are fixed, according to
specifically set widths, or by equally diving the
table width between columns.

Table Cell

Each cell of the table is a table cell element.

Style

Vertical Align Select Vertical alignment of the contents of the table cell.

5.3.7 Frame

Frames are be used for embedding other web pages in a document.

To insert a frame element, use the Insert > Frame menu item.

Style
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Scrolling Select auto - Automatically determine when to show
scrollbars based on the size of the content.
no - Never show scrollbars.
yes - Always show scrollbars.

Settings

Name Text Name of the frame, as can be used in links'
<Window Name> to force links to target the frame.

Source Text The URL of the webpage to show in the frame.

5.3.8 Marquee

Marquees are used to create scrolling text.

To insert a marquee element, use the Insert > Marquee menu item.

Settings

Behavior Select scroll - Text scrolls in from one end and out of the
other.
alternate - Text scrolls from one end to the other,
and reverses when reaching the end.
slide - Text scrolls in from one end and stops when
reaching the other.

Direction Select The direction the text scrolls in.

Loop Select Number of times to repeat the scroll before
stopping. infinitely never stops repeating.

Step Delay Number The delay between each step of the scroll, in
milliseconds.

Step Size Number The size of each step of the scroll, in pixels.

When <Behavior> is slide, setting <Loop> to infinitely will not repeat the scroll, and will only slide the text once into position.

5.4 Media

Media elements are used to enrich documents. All of the available media types are managed through the Media
Explorer, and can all be added and embedded in the document directly from it.

 To learn more about adding media elements, read about adding media.

§ Image
§ Media Player
§ Flash Animation

5.4.1 Image

Image elements are used to embed graphics in a document.

To insert an image element, use the Insert > Image menu item, or press the Insert Image toolbar button. To
learn more about adding images, read about adding media.

Settings
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Dynamic Source Media Video or audio file to use as the source for the
image element.

Link To Text A URL to open when pressing the image element.

Linked Window Name Text The name of the window to open the <Link To>
URL in. If no window name is given, the URL will be
opened in a new window. Only relevant when a
URL is set.

Loop Number Number of times to loop the video or audio file.
Only relevant when a <Dynamic Source> is set.

Source Media Image file to use as the source for the image
element.

Start Select fileopen - Video or audio file is started when it
finishes loading.
mouseover - Video or audio file is started when
the mouse is over the image element.

5.4.2 Media Player

Media player elements are used to embed video or audio clips in a document.

To insert a media player element, use one of the Insert > Media Player menu items to insert a media player
using either the current style, or the default style. To learn more about inserting media elements, read about 
adding media.

Settings

Auto Start Select When on, automatically starts the media when
entering the page.

Context Menu Select When on, right-clicking on the media player shows
the media player context menu.

Mute Select When on, the media player starts as muted.

Source Media Video or audio file to use as the source for the
media element.

Volume Number Determines the volume of the audio/video element,
with 100 being full volume, and 0 being muted.
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5.4.3 Flash Animation

Flash media elements are used to Adobe (Macromedia) Flash animations in a document.

To insert a flash animation element, use the Insert > Flash Animation menu item. To learn more about inserting
media elements, read about adding media.

Settings

Context Menu Select When on, right-clicking on the flash animation
shows an extended flash player context menu.

Loop Select When on, the flash animation loops indefinitely
when reaching its end.

Quality Select The quality of the flash animation. A lower quality
could result in better performance, but also in
degraded visual appearance.

Source Media Flash animation file to use as the source for the
media element.

Transparency Select opaque - Blank sections of the flash animation are
opaque, and content cannot be seen through.
transparent - Blank sections of the flash
animation are transparent, and any content
underneath them is shown through.

5.5 Shapes

Shape elements are used to embed combinations of vector graphics, 3d shapes and text paths in a document.

To insert a shape element, use any shape type from the Insert > Shape menu.

Style

Fill Active Select When on, a fill for the shape is displayed.

Fill Angle Number Angle for a gradient fill, in degrees. Only relevant
when <Fill Type> is gradient or gradientcenter.

Fill Color Color Primary color to use for the fill. Only relevant when
<Fill Type> is other than tile.

Fill Color 2 Color Secondary color to use for the fill. Only relevant
when <Fill type> is gradient, gradientcenter or
pattern.

Fill Image Media Image to use for the fill. Only relevant when <Fill
Type> is tile or pattern.

Fill Method Select Defines the method to use to generate a gradient
fill:
none - No sigma fill.
linear - Linear sigma fill.
sigma - Sigma fill.
any - Any sigma fill.
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Fill Opacity Number Opacity level (0-1) of the fill.

Fill Type Select solid - The fill is a solid color, using <Fill Color>.
gradient - The fill is a linear gradient, fading
between <Fill Color> and <Fill Color 2>.
gradientcenter - The fill is a linear radial, fading
between <Fill Color> and <Fill Color 2>.
tile - <Fill Image> is tiled to fill the shape.
pattern - <Fill Image> is used to create a pattern
using <Fill Color> and <Fill Color 2>.

Flip Select x - Flip the shape along the X-axis.
y - Flip the shape along the Y-axis.
x,y - Flip the shape along both the X-axis and the
Y-axis.
none - Don't flip the shape.

Rotation Number Angle of the shape's rotation, in degrees.

Shadow Active Select When on, a shadow for the shape is displayed.

Shadow Color Color Primary color to use for the shadow.

Shadow Color 2 Color Secondary color to use for the shadow. Only
relevant when <Shadow Type> is double or
emboss.

Shadow Offset Point Primary offset of the shadow.

Shadow Offset 2 Point Secondary offset of the shadow, only relevant
when <Shadow Type> is double or emboss.

Shadow Opacity Number Opacity level (0-1) of the shadow.

Shadow Type Select single - A single shadow is displayed, using <Fill
Color> and <Fill Offset>.
double - Two shadows is displayed, one using <Fill
Color> and <Fill Offset>, and one using <Fill Color
2> and <Fill Offset 2>.
perspective - A perspective shadow.
shapeRelative - A shadow is created relative to
the shape.
emboss - A shadow with an embossed look.

Skew Active Select When on, the shape is skewed according to <Skew
X> and <Skew Y>.

Skew X Point The skew to apply on the X-Axis.

Skew Y Point The skew to apply on the Y-Axis.

Stroke Active Select When on, a stroke is displayed outlining the shape.

Stroke Color Color Color to use for the stroke.

Stroke Opacity Number Opacity level (0-1) of the stroke.

Stroke Style Select The dot and dash style to use for the stroke.

Stroke Weight Number Thickness of the stroke, in pixels.

TextPath Active Select When on, displays text along the path of the
shape.

TextPath Align Select The alignment of the text along the path.

TextPath Equal Height Select When on, all letters are of the same height,
regardless of their case.

TextPath Fit Path Select When on, the text is sized to fit its path.

TextPath Fit Shape Select When on, stretches the text to the edges of the
bounding box of the shape.
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TextPath Rotate Letters Select When on, rotates the letters of the text by 90
degrees.

TextPath Spaces Select tightening - Space is removed between each
letter of the text.
tracking - Space is added between each letter of
the text.

TextPath Spacing Number The amount of spacing between the letters of the
the text.

TextPath String Text The text to display long the path.

TextPath X Scale Select When on, a straight textpath along the lower
boundary of the shape is used.

Three-D Active Select When on, the shape is given a 3d effect.

Three-D Back Depth Number The depth the shape stretches toward the back.

Three-D Brightness Number The over-all brightness (0-1).

Three-D Color Color The color of the extrusion faces.

Three-D Diffusity Number The amount of diffusion of reflected light (0-1).

Three-D Edge Number The size of a simulated bevel edge.

Three-D Fore Depth Number The depth the shape stretches toward the front.

Three-D Light Harsh Select When off, the shadow boundaries are diffused.

Three-D Light Level Number The intensity of the light source.

Three-D Outline Select When on, makes the object appear more metallic.

Three-D Render Select solid - Render the shape as a solid.
wireframe - Display a wireframe of the shape.

Three-D Rotation Angle Point Angles of the shape's rotation on the X-axis and
the Y-axis, in degrees.

Three-D Skew Amount Number The amount of skew to apply to the shape. Only
relevant when <Three-D Type> is parallel.

Three-D Skew Angle Number The angle in degrees of skew to apply to the
shape. Only relevant when <Three-D Type> is 
parallel.

Three-D Specularity Number The ratio (0-1) of incident light to specularly
reflected light

Three-D Type Select parallel - 3d shape is rendered so that the center
of projection is infinitely far away.
perspective - 3d shape is rendered so that the
center of projection is the same as the vanishing
point for non-rotated objects.

Settings

Link To Text A URL to open when pressing the box.

Linked Window Name Text The name of the window to open the <Link To>
URL in. If no window name is given, the URL will be
opened in a new window. Only relevant when a
URL is set.
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5.6 Navigation

Navigation elements are used to provide information about the document in the scope of the entire project, and
to provide navigation from the document to other documents of the project.

§ Project Title
§ Document Title
§ Navigation Button
§ Navigation Link
§ Popup Button
§ Breadcrumbs
§ Progress Bar
§ Navigation Locator
§ Timer
§ Tree Menu
§ Compact Tree Menu
§ One-Level Menu

5.6.1 Project Title

Project title elements are variable elements, with <Value> set to project title.

To insert a project title element, use the Insert > Navigation > Project Title menu item.

5.6.2 Document Title

Document title elements are variable elements, with <Value> set to location title.

To insert a document title element, use the Insert > Navigation > Document Title menu item.

5.6.3 Navigation Button

Navigation buttons allow the viewer to navigate to another document on the project, when <Trigger> is
triggered.

To insert a navigation button, use the Insert > Navigation > Navigation Button menu item.

Style

Disabled Style Style Rule Used when the button is disabled.

Mouse Over Style Style Rule Used when the mouse is over the button.

Settings

Disabled Mode Select disable - Keep the button shown when disabled.
hide - Hide the button when disabled.
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Disabled On Select default - Button is not specifically disabled on
special situations.
first page - Button is disabled on the first page of
the project.
last page - Button is disabled on the last page of
the project.
first chapter page - Button is disabled on the
first page of each chapter.
last chapter page - Button is disabled on the last
page of each chapter.
first test page - Button is disabled on the first
page of each test.
last test page - Button is disabled on the last
page of each test.

Enabled On Select default - Button is not specifically enabled on
special situations.
first page - Button is enabled on the first page of
the project.
last page - Button is enabled on the last page of
the project.
first chapter page - Button is enabled on the first
page of each chapter.
last chapter page - Button is enabled on the last
page of each chapter.
first test page - Button is enabled on the first
page of each test.
last test page - Button is enabled on the last
page of each test.

Navigate To Resource A specific outline document in the project to
navigate to.

Operation Select next - Navigate to the next document in the
outline.
previous - Navigate to the previous document in
the outline.
up - Navigate to the document above the current
one in the outline hierarchy.
custom - Navigate to a custom document,
specified by <Navigate To>.
back - Navigates back in the viewed documents
history.
forward - Navigates forward in the viewed
documents history.
refresh - Refresh the current document.
close window - Close the current window.
finish test - Finish the current test.
print - Print the current document.

Trigger Select click - The navigation is triggered when the button
is pressed.
mouseover - The navigation is triggered when the
mouse is over the button.
timer - The navigation is triggered after an
interval specified by <Trigger Delay>.

Trigger Delay Unit When <Trigger> is timer, the interval to wait
before triggering the navigation.

5.6.4 Navigation Link

Navigation links are inline navigation button elements, with the appearance of a regular link.

To insert an inline navigation link, use the Insert > Navigation > Navigation Link menu item. You can optionally
select text before inserting, which would convert the text segment to a navigation link element.
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5.6.5 Popup Button

Popup buttons open a popup document or a URL in a new popup window, when <Popup Trigger> is triggered.

To insert a popup button, use the Insert > Navigation > Popup Button menu item.

Style

Disabled Style Style Rule Used when the button is disabled.

Match To Content Select When on, matches the popup window dimensions
to the size of its contents.

Mouse Over Style Style Rule Used when the mouse is over the button.

Popup Height Unit The height of the popup window.

Popup Left Unit The offset of the popup window from the left edge
of the screen.

Popup Top Unit The offset of the popup window from the top edge
of the screen.

Popup Width Unit The width of the popup window.

Position Center Select When on, automatically positions the popup
window at the center of the screen.

Resizable Select When on, the popup window can be resized by the
viewer.

Scroll Select When on, scrollbars are available when the
dimensions of the window are smaller than the size
of its content.

Settings

Popup Resource The popup document to open in the popup window.

Popup Delay Unit When <Popup Trigger> is timer, the interval to
wait before triggering the popup.

Popup Mode Select modeless - The viewer can interact with the main
project window while the popup window is open.
modal - The viewer cannot interact with the main
project window while the popup window is open,
until it's closed.

Popup Trigger Select click - The popup is triggered when the button is
pressed.
timer - The popup is triggered after an interval
specified by <Popup Delay>.

URL Text When no <Popup> set, the URL to open in the
popup window.

<Edge> does not affect popups which open a <URL> and have <Popup Mode> set to modeless.

5.6.6 Breadcrumbs

Breadcrumbs show the current location, in relation to the outline hierarchy.

Breadcrumb elements consist of a parent crumb element, a crumb separator element, and a current crumb
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element.

To insert a breadcrumbs element, use the Insert > Navigation > Breadcrumbs menu item.

Settings

Can Navigate Select When on, breadcrumbs can be used to navigate to
any documents they list.

Parent Crumb

The parent crumb element is a generic text element, which can be altered visually to affect the visual
appearance of the breadcrumbs.

Crumb Separator

The crumb separator element is a generic element, which can be altered visually to affect the visual appearance
of the breadcrumbs.

Current Crumb

The current crumb element is a generic text element, which can be altered visually to affect the visual
appearance of the breadcrumbs.

5.6.7 Progress Bar

Progress bars show the progress made on the entire course. 

Progress bar elements consist of percent done elements and percent not done elements.

To insert a progress bar element, use the Insert > Navigation > Progress Bar menu item.

Settings

Show Percentage Select When on, the progress bar shows a numeric
presentation of the done percentage.

Percent Done

The percent done element is the segment of the progress bar showing the relative amount done throughout the
course. The percent done element's contents can not be edited, but it's visual appearance can be customized.

Percent Not Done

The percent not done element is the segment of the progress bar showing the relative amount of the course that
is yet to be done. The percent done element's contents can not be edited, but it's visual appearance can be
customized.

5.6.8 Navigation Locator

Navigation locators show the current page number and the total number of pages.

Navigation locator elements are generic elements, consisting of text and two variable elements:

§ Page No., showing the current page number, is a variable element with <Value> set to page number.

§ Total Pages, showing the total count of pages in the course, is a variable element with <Value> set to total
pages.

The text of the navigation locator can be modified as in any other generic element, and variables can be added
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or removed for customization.

To insert a navigation locator element, use the Insert > Navigation > Navigation Locator menu item.

5.6.9 Timer

Timers allow one of several actions to trigger, after a specific amount of time has passed since the document has
been first viewed.

Timer elements contain a timer message element.

To insert a timer element, use the Insert > Navigation > Timer menu item.

Settings

Mode Select Defines the visual appearance of the timer. Only
relevant when <Visible> is true.
digital - A digital clock.
horizontal - A horizontal bar.
vertical - A vertical bar.
boxed - A growing box.

Navigate To Resource The document to navigate to once the timer has
elapsed. Only relevant when <Timer Action> is 
custom.

Show Message Select When on, shows the timer message element once
the timer has elapsed. Only relevant when
<Visible> is true.

Timer Action Select Defines the action to execute once the timer has
elapsed.
auto - Inherits the test properties, when available.
Otherwise, does nothing.
check question - Check the question in the
document.
next - Navigate to the next document in the
outline.
check and next - Check the question in the
document, and then navigate to the next document
in the outline.
custom - Navigate to the document specified by
<Navigate To>.
none - Take no action.

Timer Period Unit The time from the first viewing of the document,
after which the action specified by <Timer Action>
will be executed. When auto, inherits the test
properties if available.

Update Interval Unit The time between each visual update to the timer.
Only relevant when <Visible> is true.

Visible Select When off, the timer isn't visible on screen, but the
<Timer Action> is still executed after the timer has
elapsed.

Timer Message

The timer message element is a generic element, which is shown when the timer has elapsed. The timer
message is only shown if <Show Message> is true, and <Visible> is true.
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5.6.10Tree Menu

Tree menus show a traversable menu of the project outline in the form of a tree.

Tree menu elements consist of one or more: menu chapter elements, menu page elements, menu container
elements, current marker elements, and done marker elements.

To insert a tree menu element, use the Insert > Navigation > Tree Menu menu item.

Style

Mouse Over Chapter Style Style Rule Used for menu chapter elements when the mouse
is over them.

Mouse Over Page Style Style Rule Used for menu page elements when the mouse is
over them.

Settings

Collapsible Select When on, chapters can be collapsed to hide the
documents underneath them.

Custom Root Resource The document to consider as the root of the menu.
Only relevant when <Menu Root> is custom.

Disable Navigation Select When on, the menu is for display purposes only,
and cannot be used for navigation.

Layout Select vertical tree - The tree is in vertical form.

Levels Select The number of levels to show (threshold) beneath
the root level.
all - Show any number of levels.

Mark / Current Select Defines whether the current marker is shown.

Mark / Done Select Defines whether the done marker is shown.

Mark / Started Select Defines whether the started marker is shown.

Menu Root Select Defines which document will be considered as the
root of the menu. Any documents higher than the
menu root will not be shown as part of the menu.
project - The root of the project.
current location - The current document.
parent location - The parent of the current
document.
mixed - The current document if it's a chapter, or
the parent document otherwise.
custom - A custom document, specified by
<Custom Root>.
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Show Select all - Show any type of documents.
chapters - Show only chapter documents.

Start State Select collapsed - Initiates the tree with all chapters in
collapsed state.
expanded - Initiates the tree with all chapters in
expanded state.
expand one level - Initiates the tree with one
level of chapters in expanded state, and the rest in
collapsed state.
expand two levels - Initiates the tree with two
levels of chapters in expanded state, and the rest
in collapsed state.

Toggle Sibling Select When on, expanding a chapter collapses all its
sibling chapters.

Menu Chapter

Each chapter of the project's outline is represented by a menu chapter element. Customizing the visual
appearance of one menu chapter element will alter the visual appearance of all menu chapter elements
throughout the menu.

When <Collapsible> is true, and the chapter contains other documents, pressing the menu chapter element
collapses or expands (hides or shows, accordingly) the documents underneath the chapter. Otherwise, pressing
the menu chapter element navigates to the chapter.

Menu Page

Each page of the project's outline is represented by a menu page element. Customizing the visual appearance of
one menu page element will alter the visual appearance of all menu page elements throughout the menu.

Pressing a menu page element navigates to the page.

Menu Container

Menu container elements are used for each branch in the menu's hierarchy.

Current Marker

The current marker element is a generic element, which is used to mark the current document in the menu.
Current markers are only shown when <Mark / Current> is true.

Started Marker

The started marker element is a generic element, which is used to mark a chapter which has been started but
not completed. Started markers are only shown when <Mark / Started> is true.

Done Marker

The current marker element is a generic element, which is used to mark which of the documents in the menu are
done. Done markers are only shown when <Mark / Done> is true.

Compact Tree Menu

The compact tree menu is a modified tree menu, which is styled to be simple and compact.

To insert a compact tree menu element, use the Insert > Navigation > Compact Tree Menu menu item.
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5.6.11Compact Tree Menu

Tree menus show a traversable menu of the project outline in the form of a tree.

Tree menu elements consist of one or more: menu chapter elements, menu page elements, menu container
elements, current marker elements, and done marker elements.

To insert a tree menu element, use the Insert > Navigation > Tree Menu menu item.

Style

Mouse Over Chapter Style Style Rule Used for menu chapter elements when the mouse
is over them.

Mouse Over Page Style Style Rule Used for menu page elements when the mouse is
over them.

Settings

Collapsible Select When on, chapters can be collapsed to hide the
documents underneath them.

Custom Root Resource The document to consider as the root of the menu.
Only relevant when <Menu Root> is custom.

Disable Navigation Select When on, the menu is for display purposes only,
and cannot be used for navigation.

Layout Select vertical tree - The tree is in vertical form.

Levels Select The number of levels to show (threshold) beneath
the root level.
all - Show any number of levels.

Mark / Current Select Defines whether the current marker is shown.

Mark / Done Select Defines whether the done marker is shown.

Mark / Started Select Defines whether the started marker is shown.

Menu Root Select Defines which document will be considered as the
root of the menu. Any documents higher than the
menu root will not be shown as part of the menu.
project - The root of the project.
current location - The current document.
parent location - The parent of the current
document.
mixed - The current document if it's a chapter, or
the parent document otherwise.
custom - A custom document, specified by
<Custom Root>.
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Show Select all - Show any type of documents.
chapters - Show only chapter documents.

Start State Select collapsed - Initiates the tree with all chapters in
collapsed state.
expanded - Initiates the tree with all chapters in
expanded state.
expand one level - Initiates the tree with one
level of chapters in expanded state, and the rest in
collapsed state.
expand two levels - Initiates the tree with two
levels of chapters in expanded state, and the rest
in collapsed state.

Toggle Sibling Select When on, expanding a chapter collapses all its
sibling chapters.

Menu Chapter

Each chapter of the project's outline is represented by a menu chapter element. Customizing the visual
appearance of one menu chapter element will alter the visual appearance of all menu chapter elements
throughout the menu.

When <Collapsible> is true, and the chapter contains other documents, pressing the menu chapter element
collapses or expands (hides or shows, accordingly) the documents underneath the chapter. Otherwise, pressing
the menu chapter element navigates to the chapter.

Menu Page

Each page of the project's outline is represented by a menu page element. Customizing the visual appearance of
one menu page element will alter the visual appearance of all menu page elements throughout the menu.

Pressing a menu page element navigates to the page.

Menu Container

Menu container elements are used for each branch in the menu's hierarchy.

Current Marker

The current marker element is a generic element, which is used to mark the current document in the menu.
Current markers are only shown when <Mark / Current> is true.

Started Marker

The started marker element is a generic element, which is used to mark a chapter which has been started but
not completed. Started markers are only shown when <Mark / Started> is true.

Done Marker

The current marker element is a generic element, which is used to mark which of the documents in the menu are
done. Done markers are only shown when <Mark / Done> is true.

Compact Tree Menu

The compact tree menu is a modified tree menu, which is styled to be simple and compact.

To insert a compact tree menu element, use the Insert > Navigation > Compact Tree Menu menu item.
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5.6.12One-Level Menu

One-level menus show a traversable menu of one level of the project's outline.

One-level menu elements consist of one or more: menu chapter elements, menu page elements, derived chapter
elements, derived page elements,  menu blockelements, menu container elements, current marker elements,
and done marker elements.

To insert a one-level menu element, use the Insert > Navigation > One-Level Menu menu item.

Style

Mouse Over Chapter Style Style Rule Used for menu chapter elements when the mouse
is over them.

Mouse Over Page Style Style Rule Used for menu page elements when the mouse is
over them.

Mouse Over Sub-Chapter Style Rule Used for derived chapter elements when the mouse
is over them.

Mouse Over Sub-Page Style Rule Used for derived page elements when the mouse is
over them.

Settings

Collapsible Select When on, chapters can be collapsed to hide the
documents underneath them.

Layout Select columns - Shows a column for each branch in the
root level, with its derived documents underneath
it.
rows - Shows a row for each branch in the root
level, with its derived documents side-by-side.
bars - Shows a list of all the documents.
pop menu - Shows a list of all the documents in
the root level, with each branch opening a list of
derived documents.

Mark / Current Select Defines whether the current marker is shown.

Mark / Done Select Defines whether the done marker is shown.

Mark / Started Select Defines whether the started marker is shown.

Menu Root Select Defines which document will be considered as the
root of the menu. Any documents higher than the
menu root will not be shown as part of the menu.
project - The root of the project.
current location - The current document.
parent location - The parent of the current
document.
mixed - The current document if it's a chapter, or
the parent document otherwise.
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Show Select all - Show any type of documents.
pages - Show only page documents.
chapters - Show only chapter documents.

Start State Select collapsed - Initiates the tree with all chapters in
collapsed state.
expanded - Initiates the tree with all chapters in
expanded state.
expand one level - Initiates the tree with one
level of chapters in expanded state, and the rest in
collapsed state.
expand two levels - Initiates the tree with two
levels of chapters in expanded state, and the rest
in collapsed state.

Toggle Sibling Select When on, expanding a chapter collapses all its
sibling chapters.

Menu Chapter

Each chapter of the root level's outline is represented by a menu chapter element. Customizing the visual
appearance of one menu chapter element will alter the visual appearance of all menu chapter elements
throughout the menu.

When <Collapsible> is true, and the chapter contains other documents, pressing the menu chapter element
collapses or expands (hides or shows, accordingly) the documents underneath the chapter. Otherwise, pressing
the menu chapter element navigates to the chapter.

Menu Page

Each page of the root level's outline is represented by a menu page element. Customizing the visual appearance
of one menu page element will alter the visual appearance of all menu page elements throughout the menu.

Pressing a menu page element navigates to the page.

Derived Chapter

Each chapter underneath the root level is represented by a derived chapter element. Customizing the visual
appearance of one derived chapter element will alter the visual appearance of all derived chapter elements
throughout the menu.

Pressing a derived chapter element navigates to the chapter.

Derived Page

Each page underneath the root level is represented by a derived page element. Customizing the visual
appearance of one derived page element will alter the visual appearance of all derived page elements
throughout the menu.

Pressing a derived page element navigates to the page.

Menu Block

Menu blocks elements are used for each branch underneath the root level.

Menu Container

Menu container elements are used to hold documents underneath each chapter inside each menu block.

Current Marker

The current marker element is a generic element, which is used to mark the current document in the menu.
Current markers are only shown when <Mark / Current> is true.

Started Marker

The started marker element is a generic element, which is used to mark a chapter which has been started but
not completed. Started markers are only shown when <Mark / Started> is true.

Done Marker

The current marker element is a generic element, which is used to mark which of the documents in the menu are
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done. Done markers are only shown when <Mark / Done> is true.

5.7 Activities

Activities are interactive elements, which are used for tests and for creating other interactive experiences for
users. Activities are the most complex of elements, and are usually made of several different types of elements.

Each of the following pages represents an activity, and list each of the sub-elements it consists of, and their
respective properties.

§ Multiple Choice
§ Point Click
§ Drag Drop
§ Hot Spots
§ Fill Blank
§ Hot Word
§ Feedback

5.7.1 Multiple Choice

Multiple choice activities consist of a question element, one or more answer elements, a check answer button,
and a feedback element.

To insert a multiple choice activity, use the Insert > Multiple Choice menu item or the Insert Multiple Choice
toolbar button.

Style

Answer Normal Style Rule Used for an answer in its normal state.

Answer Over Style Rule Used for an answer when the mouse is over it.

Answer Pressed Style Rule Used for an answer when its selected.

Answer Right Style Rule Used for an answer which is marked as correct.

Answer Wrong Style Rule Used for an answer which is marked as wrong.

Bullet Image Media Used for answer bullets in its normal state.

Bullet Pressed Image Media Used for selected answer bullets.

Bullet Right Image Media Used for answer bullets marked as correct.

Bullet Wrong Image Media Used for answer bullets marked as wrong.

Settings
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Immediate Check Select When on, the answer is checked immediately when
an answer is selected, and the check answer button
is hidden.

Limit Answer Count Select When on, limits the amount of possible answers to
the number of correct answers.

Shuffle Answers Select When on, randomizes the order of answers.

Question

A question of the multiple choice activity is a generic element. A multiple choice activity can only have one
question, and it should not be removed. To edit the question, simply edit the question element's content.

Answer

An answer of the multiple choice activity is a generic element. To add additional answers, use the Modify >
Multiple Choice Activity > Add Answer menu item. To remove an answer, simply select and delete it using the
Edit > Delete menu item, or the Delete key.

An answer is considered correct when <Correct> is true, and all answers are incorrect by default. One or more
answers can be set as correct.

Settings

Correct Select Marks the answer as correct or incorrect.

Point Click

Point click activities are modified multiple choice activities, with <Immediate Check> set to true by default.
Point click activities can be used for quickly creating questions where one answer out of several options should
be pressed for a correct answer.

To insert a point click activity, use the Insert > Point Click menu item.
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5.7.2 Point Click

Multiple choice activities consist of a question element, one or more answer elements, a check answer button,
and a feedback element.

To insert a multiple choice activity, use the Insert > Multiple Choice menu item or the Insert Multiple Choice
toolbar button.

Style

Answer Normal Style Rule Used for an answer in its normal state.

Answer Over Style Rule Used for an answer when the mouse is over it.

Answer Pressed Style Rule Used for an answer when its selected.

Answer Right Style Rule Used for an answer which is marked as correct.

Answer Wrong Style Rule Used for an answer which is marked as wrong.

Bullet Image Media Used for answer bullets in its normal state.

Bullet Pressed Image Media Used for selected answer bullets.

Bullet Right Image Media Used for answer bullets marked as correct.

Bullet Wrong Image Media Used for answer bullets marked as wrong.

Settings

Immediate Check Select When on, the answer is checked immediately when
an answer is selected, and the check answer button
is hidden.

Limit Answer Count Select When on, limits the amount of possible answers to
the number of correct answers.

Shuffle Answers Select When on, randomizes the order of answers.

Question

A question of the multiple choice activity is a generic element. A multiple choice activity can only have one
question, and it should not be removed. To edit the question, simply edit the question element's content.

Answer

An answer of the multiple choice activity is a generic element. To add additional answers, use the Modify >
Multiple Choice Activity > Add Answer menu item. To remove an answer, simply select and delete it using the
Edit > Delete menu item, or the Delete key.
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An answer is considered correct when <Correct> is true, and all answers are incorrect by default. One or more
answers can be set as correct.

Settings

Correct Select Marks the answer as correct or incorrect.

Point Click

Point click activities are modified multiple choice activities, with <Immediate Check> set to true by default.
Point click activities can be used for quickly creating questions where one answer out of several options should
be pressed for a correct answer.

To insert a point click activity, use the Insert > Point Click menu item.

5.7.3 Drag Drop

Drag drop activities consist of one or more pairs of drag item elements and drop area elements, a check answer
button and a feedback element. A drag item is considered correct when dropped on a drop area that shares its
index.

To insert a drag drop activity, use the Insert > Drag Drop menu item or the Insert Drag Drop toolbar button.

Usually, drag items and drop areas go in pairs. To add such a pair, use the Modify > Drag Drop Activity > Add
Drag Drop Pair menu item. However, each "pair" can have any number of drag items or drop areas.

To add a drag item to an existing pair, choose an element of the pair and use the Modify > Drag Drop Activity >
Add Drag Item To Pair menu item. To add a drop area to an existing pair, choose an element of the pair and use
the Modify > Drag Drop Activity > Add Drop Area To Pair menu item.
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Dummy drag items and drop areas are ones which have an index of -1. Such dummy items aren't involved in the
score calculation of the activity.

Style

Animate Correction Select When on, animates drag items when showing the
correction.

Correction Animation Duration
(MS)

Number
The time (in milliseconds) for the correction
animation to take. Only relevant when <Animation
Correction> is true.

Drag Opacity Number The opacity level (0-100) of the drag items while
dragging.

Settings

Allow Drop Over Select Allows dragging items over a drop area which
already has an item attached to it.

Force Correction Order Select Enforces the order in which to fix the items when
showing correction, according to their order
property.

On Drop Align To Select center - Dropped items will align to the center of
the drop area.
top-left - Dropped items will align to the top-left
of the drop area.

Reject Mismatched Drops Select When on, items dropped over a mismatched drop
area will be rejected.

Shuffle Drag Items Select When on, randomizes the order of drag items.

Shuffle Drop Areas Select When on, randomizes the order of drop areas.

Drag Item

A drag item is a generic element. To remove a drag item, simply select and delete it using the Edit > Delete
menu item, or the Delete key.

Settings

Drag Item Index Number The index of the drag item, linking it to one or
more corresponding drop areas. A negative value
creates a dummy drag item, which isn't taken into
consideration in the score calculation for the
activity.

Drop Area

A drop area is a generic element. To remove a drop area, simply select and delete it using the Edit > Delete
menu item, or the Delete key.

Style

Opacity Number The opacity level (0-100) of the drop area.

Settings



Elements 100

© 2009 Composica Ltd.

Drop Area Index Number The index of the drop area, linking it to one or
more corresponding drag items. A negative value
creates a dummy drop area, which isn't taken into
consideration in the score calculation for the
activity.

Correction Order Number The order in which to fix the items when showing
correction, when <Force Correction Order> is true.

5.7.4 Fill Blank

Fill blank activities consist of a question element with one or more fill blank item elements, a check answer
button, and a feedback element. Fill blank activities allow  providing one or more writeable or selectable blanks,
which needs to filled correctly to complete the activity.

To insert a fill blank activity, use the Insert > Fill Blank menu item or the Insert Fill Blank toolbar button.

Settings

Shuffle Options Select When on, randomizes the order of the options of
selectable blanks.

Question

The question element of the Fill Blank activity consists of the question along with the blanks of the activity. A fill
blank activity can only contain one question, but a question can contain any number of blanks. 

The question element should generally not be removed. To add the question element in case of a removal, use
the Modify > Fill Blank Activity > Add Question menu item.

Fill Blank Item

Blanks are inline to the question, which means they are embedded along with the text of the question, to easily
maintain the flow of the text. To add an inline blank to the question, you must first enter the question's content
editing mode. To remove a blank, simply select and delete it using the Edit > Delete menu item, or the Delete
key.

A blank can be of two types: a writeable blanks, and a selectable blanks.

Settings

Case Sensitive Select When on, the entered answer must have the exact
same case as the provided options.

Writeable Blank

Writeable blanks are open inputs which can be filled by the viewer. A writeable blank has a list of one or more
options, which are considered as correct values for that blank. To add a writeable blank, when editing the
question's content, at the position you wish to add the blank use the Modify > Fill Blank Activity > Add
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Writeable Blank menu item.

Selectable Blank

Selectable blanks provide the viewer with a list of options to choose from, in which one or more options can be
correct. To add a selectable blank, when editing the question's content, at the position you wish to add the
blank use the Modify > Fill Blank Activity > Add Selectable Blank menu item.

Options

Each blank has an option list, which is visible when selecting the blank. To add an option, you must first select
the blank you wish to add the option to. To remove an option, simply select and delete it using the Edit > Delete
menu item, or the Delete key.

An option can be of the following types: a blank option, a blank range, and a blank mask.

Blank Option

A blank option is a normal option. To edit a blank option's value, edit its text. To add a blank option, use the 
Modify > Fill Blank Activity > Add Option menu item.

Settings

Correct Select Marks the option as a correct or incorrect answer.

Blank Range

A range option allows for a value within a certain range to be considered correct. A range option is only relevant
for writeable blanks. To add a range option, use the Modify > Fill Blank Activity > Add Range Option menu item.

Settings

Higher Bound Number The higher bound of the range to be considered as
a correct value.

Lower Bound Number The lower bound of the range to be considered as a
correct value.

Blank Mask

A range option allows for a value which matches a certain mask to be considered correct. A mask option is only
relevant for writeable blanks. To add a mask option, use the Modify > Fill Blank Activity > Add Mask Option
menu item.

Settings

Mask Text A wildcard mask to be considered as a correct
value. A regular expression can be used, enclosed
in forward slashes.

5.7.5 Hot Spots

Hot spots elements consist of one or more pairs of hot spot elements and hot popup elements. A hot popup is
shown when the hot spot's event is triggered, according to its <Hot Event>.
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To insert a hot spots element, use the Insert > Hot Spots menu item or the Insert Hot Spots toolbar button.

Usually, hot spots and hot popups go in pairs. To add such a pair, use the Modify > Hot Spots > Add Hot Spot
Pair menu item. However, each "pair" can have any number of hot spots or hot popups.

To add a hot spot to an existing pair, choose an element of the pair and use the Modify > Hot Spots > Add Hot
Spot To Pair menu item. To add a hot popup to an existing pair, choose an element of the pair and use the
Modify > Hot Spots > Add Hot Popup To Pair menu item.

Style

Hide Mode Select effect - Use an effect (if defined) when hiding hot
popups.
plain - Hide hot popups without any effects.

Settings

Exclusive Popups Select When on, only one hot popup of this activity can be
active at a time.

Play Mode Select every time - Hot popups are triggered each time
the defined <Hot Event> is triggered.
first time - Hot popups are only triggered the first
time the defined <Hot Event> is triggered.

Hot Spot

A hot spot is a generic element. To remove a hot spot, simply select and delete it using the Edit > Delete menu
item, or the Delete key.

Style

Opacity Number The opacity level (0-100) of the hot spot.

Settings

Hide Hotspot After Event Select When on, hides the hot spot after being triggered
for the first time.

Hot Event Select mouseover - The hot popup is shown when the
mouse is over the hot spot, and hidden when it
leaves.
click - The hot popup is shown/hidden each time
the hot spot is pressed.
timer - The hot popup is shown/hidden on a timer,
according to <Timer Show Interval> and <Timer
Hide Interval>.

Hot Spot Index Number The index of the hot spot, linking it to one or more
corresponding hot popups.

Popup Toggle Select When on, the hot popup is shown/hidden each time
the defined <Hot Event> is triggered. When off,
the hot popup is never hidden.

Timer Hide Interval Unit When <Hot Event> is timer, the interval before
hiding the hot popup, after showing it.

Timer Show Interval Unit When <Hot Event> is timer, the interval before
showing the hot popup.

Hot Popup

A hot popup is a generic element, available for edit when the hot spot associated with it is selected (see also 
Modify > Hot Spots > Design-Time View). To remove a hot popup, simply select and delete it using the Edit >
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Delete menu item, or the Delete key.

Settings

Hot Popup Index Number The index of the hot popup, linking it to one or
more corresponding hot spots.

Hide Popup Event Select The event upon which to hide the hot popup
(additionally to the behavior implied by <Hot
Event>).
none - No hiding.
click - Hide the hot popup when it is clicked.
mouseenter - Hide the hot popup when the
mouse goes over it.
mouseleave - Hide the hot popup when the
mouse goes out of it.

5.7.6 Hot Word

Hot words are inline elements, which allow easily adding interactivity embedded in a text paragraph. Hot words
consist of a hot word element, and a hot word popup element which is shown when the hot word's event is
triggered, according to its <Hot Event>.

Hot words are similar to Hot Spots, but serve a specific purpose of triggering hot word popups on interaction
with a segment of text.

To insert a hot word, select a segment of text, and use the Insert > Hot Word menu item. Inserting a hot word
without selecting a segment of text will append a hot word to the current text.

Style

Hide Mode Select effect - Use an effect (if defined) when hiding hot
word popups.
plain - Hide hot word popups without any effects.

Mouse Over Style Style Rule Used when the mouse is over the hot word.

Settings

Hot Event Select mouseover - The hot word popup is shown/hidden
when the mouse is over/out the hot spot.
click - The hot word popup is shown/hidden when
the hot spot is pressed.

Link To Text A URL to open when pressing the hot word. Setting
a URL voids the normal functionality of the hot
word, and the hot word popup is never shown.

Linked Window Name Text The name of the window to open the <Link To>
URL in. If no window name is given, the URL will be
opened in a new window. Only relevant when a
URL is set.

Hot Word Popup

A hot popup is a generic element, available for edit when the hot word associated with it is selected.
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5.7.7 Feedback

The feedback element is a part of all assessment activities. Upon
checking the answer of an activity, the feedback element provides
the users with immediate feedback on the accuracy of their answer.

Feedback elements consist of one or more feedback items, along
with several optional buttons. The appearance and contents of each
of these can be customized, similarly to other generic elements. The
feedback element features are configured via the properties pane,
and the Modify > Feedback menu.

Settings

Attempts Number The number of incorrect attempts possible for this
activity.

Auto Fix Select When on, automatically corrects the answer after
the last incorrect attempt.

Lock Next Navigation Select When on, prevents from navigating to the next
page before the first attempt.

Match Size Select When on, automatically resizes the feedback
element to match its contents.

Right Feedback

Shown when the answer is correct. To add a right feedback item, use the Modify > Feedback > Add Right
Feedback menu item.

Wrong Feedback

Shown when the answer is incorrect. To add a wrong feedback item, use the Modify > Feedback > Add Wrong
Feedback menu item.

Settings

When Select last attempt - Show the feedback after the last
attempt only.
any attempt - Show the feedback after any
attempt.

Partial Feedback

Shown when the answer is partially correct. To add a partial feedback item, use the Modify > Feedback > Add
Partial Feedback menu item.

Settings

When Select last attempt - Show the feedback after the last
attempt only.
any attempt - Show the feedback after any
attempt.

Final Feedback

Shown after the last attempt. To add a final feedback item, use the Modify > Feedback > Add Final Feedback
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menu item.

Custom Feedback

Shown when a custom condition is met. To add a custom feedback item, use the Modify > Feedback > Add
Custom Feedback menu item.

Settings

Condition Condition A combination of conditions upon which to show
the custom feedback item.

Range Feedback

Shown when the number of correct answers is in the specified range. To add a range feedback item, use the 
Modify > Feedback > Add Range Feedback menu item.

Settings

Higher Bound Number The higher bound of the range of correct answers.

Lower Bound Number The lower bound of the range of correct answers.

Close Button

Shown on every attempt. Hides the feedback element. To add a close button, use the Modify > Feedback > Add
Close Button menu item.

Retry Button

Shown on every incorrect attempt but the last. Hides the feedback element an allows for another attempt. To
add a retry button, use the Modify > Feedback > Add Try Again Button menu item.

Settings

Reset Question Select When on, the question gets reset when the retry
button is pressed.

Fix Button

Shown on the last incorrect attempt. Fixes the activity to show the correct answers. To add a fix button, use the 
Modify > Feedback > Add Show Correction Button menu item.

Check Button

The check button resides outside of the feedback element, but is connected to it. Validates the answers of the
activity, and gives feedback accordingly.

5.7.8 Get a Hint

Hints are helper elements, which are added to existing activities to provide helpful hints to users.

Hint elements contain a hint popup element.

A hint element can be added to the following elements:

§ Multiple choice, by selecting a multiple choice element and using the Modify > Multiple Choice > Add Hint
menu item.

§ Drag drop, by selecting a drag drop element and using the Modify > Drag Drop > Add Hint menu item.

§ Fill blank, by selecting a fill blank element and using the Modify > Fill Blank > Add Hint menu item.

Style
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Hide Mode Select effect - Use an effect (if defined) when hiding the
hint popup.
plain - Hide the hint popup without any effects.

Mouse Over Style Style Rule Used when the mouse is over the hint button.

Settings

Available After Unit The amount of time after which the hint will be
available for viewing.

Hint Event Select mouseover - The hint popup is shown/hidden
when the mouse is over/out the hint.
click - The hint popup is shown/hidden when the
hint is pressed.

Score Decrease Unit The factor (in percents) by which to decrease the
users score, once they view the hint. A value of 0
means the score will not be decreased.

Show Button Select effect - Use an effect (if defined) when showing
the hint button.
plain - Show the hint button without any effects.

Show Once Select When on, the hint will only be shown once.

Hint Popup

A hint popup is a generic element, available for edit when the hint button associated with it is selected. The hint
popup is shown according to the hint <Hint Event>, and should contain any helpful hint to help the player solve
the question at hand.

5.8 Other

The following elements don't fit in any of the other categories.

§ Variable
§ Test Feedback
§ User Identification
§ Sequence Manager

5.8.1 Variable

Variable elements are text elements which show a dynamic value according to <Value>.

To insert a variable element, use the Insert > Variable menu item.

Settings

Value Select See information below for the list of options for
<Value>.

<Value> options

The options available for <Value> may be extended according to the element the variable element is nested in.
Following is a table of each element, and the options it adds.

All Elements

first name Viewer's first name.
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last name Viewer's last name.

middle name Viewer's middle name.

global score Overall score throughout the course.

status Overall status of the course.

total hours Hour part of the total amount of time spent by the viewer on the
course.

total minutes Minute part of the total amount of time spent by the viewer on the
course.

session hours Hour part of the amount of time spent by the viewer on the current
session.

session minutes Minute part of the amount of time spent by the viewer on the current
session.

project title Title of the project, as specified in the project properties.

location title Title of the current document, as specified in the document properties.

page number Number of the current pages out of the total pages in the course.

total pages Total number of pages in the course.

total done Total number of pages done in the course.

identification User identification, as supplied by the User Identification element.

Multiple Choice

correct answers Number of answers answered correctly.

incorrect answers Number of answers answered wrong.

total answers Total number of supplied answers.

attempts left Number of attempts left.

current attempt Number of the current attempt.

total attempts Total number of attempts available.

Drag Drop

correct answers Number of answers answered correctly.

total answers Total number of supplied answers.

attempts left Number of attempts left.

current attempt Number of the current attempt.

total attempts Total number of attempts available.

Fill Blank

correct answers Number of answers answered correctly.

incorrect answers Number of answers answered wrong.

total answers Total number of supplied answers.

attempts left Number of attempts left.

current attempt Number of the current attempt.

total attempts Total number of attempts available.
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Test Feedback

test title Title of the current test, as specified in the document properties.

total questions Total number of questions in the test.

total answers Total number of answers provided in the test.

correct answers Total number of correct answers in the test.

incorrect answers Total number of incorrect answers in the test.

partial answers Total number of partial answers in the test.

total score Total score achieved in the test.

pass score Pass score defined for the test, as specified in the test settings.

Values of first name, last name, middle name, total hours, and total minutes all depend on values
supplied by a SCORM compliant LMS.

5.8.2 Test Feedback

The test feedback element is used to show feedback about a test once it's finished. Test feedback elements
consist of one or more feedback items, along with several optional buttons. The appearance and contents of each
of these can be customized, similarly to other generic elements. The feedback element features are configured
via the properties pane, and the Modify > Test Feedback menu.

To insert a test feedback element, use the Insert > Test Feedback menu item. For a test feedback element to
operate, it must be linked to its relevant test via the <Linked Test> property.

Settings

Linked Test Resource Links the test feedback element to its relevant test.

Test Summary

Lists global statistics for the test.

Sections Summary

Lists each section of the test and its statistics.

Results Details

Lists each question in the test and its score.
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Settings

Show Correct Answers Select When on, lists answers which are marked as
correct.

Show Incorrect Answers Select When on, lists answers which are marked as
incorrect.

Show Partial Answers Select When on, lists answers which are marked as
partial.

Test Results

Shows the final score of the test.

Test Pass

Shows the pass score of the test, only shown if the test is passed.

Test Fail

Shows the pass score of the test, only shown if the test is failed.

Review Test

A button for reviewing the test, only shown when Allow Review in the test properties is on.

Style

Style Rule Over Style Rule Used when the mouse is over the button.

Re-Test

A button for retaking the test.

Settings

Target Resource The document to navigate to when pressing the
button. If none set, defaults to the first page of the
<Linked Test>.

5.8.3 User Identification

User identification is used to identify the user when basic student tracking is used. User identification can be
based on any identifier wanted. A user identification element consists of a label, a text field, and an error
message. To specify which identifier is wanted, change the text of the label.

To insert a user identification element, use the Insert > User Identification menu item.

Settings

Mandatory Select When on, user identification is required to leave
the document it is on.
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User Id Label

A descriptive text of the wanted identifier.

Text Field

An input for the user identification.

User Id Error

An error message shown when <Mandatory> is on, and user identification is not filled.

5.8.4 Sequence Manager

The sequence manager manages the sequential aspects of the document, like effects and narration. The
sequence manager is a virtual element, and is not visible in runtime.

To insert a sequence manager, use the Insert > Sequence Manager menu item. A document can only hold one
sequence manager element.

To configure the global sequence settings, either select the sequence manager element and use the property
grid, or use the Sequence Manager dialog.

A sequence manager element can also be added automatically when applying effects or narration to the
document.

Style

Effect Active Select When on, the effect sequence is enabled.

Effect Delay Unit Delay between each step of the effect sequence.
Only relevant when <Effect Trigger> is timer or
either.

Effect Duration Unit Duration for each step of the effect sequence.

Effect Hide Mode Select Determines how elements are hidden after being
shown by the sequence manager.
none - Elements are not hidden.
effect - Elements are hidden by using the effect.
effect, interlaced - Elements are hidden by using
the effect, while the next element gets shown.
plain - Elements are hidden without an effect.

Effect Loop Select When on, the effect sequence is repeated infinitely.

Effect Order Select The order of steps of the effect sequence. Either
determined by the positions of the elements on
screen, random, or custom which is specified by
their order in the Sequence Manager dialog.

Effect Start After Unit Delay after showing the page before starting the
effect sequence. Only relevant when <Effect
Trigger> is timer or either.

Effect Trigger Select timer - The sequence is advanced by a timer,
controlled by <Effect Start After>, <Effect
Duration> and <Effect Step>.
moue click - The sequence is advanced by mouse
clicks - each step is delayed until the mouse is
pressed.

Effect Type Select Type of effect to play by default.
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Play Mode Select every time - Effect sequence is played every time
the document is viewed.
first time - Effect sequence is only played the first
time the document is viewed.

Elements

Each element which can be part of an effect sequence, is also given the following properties:

Style

Effect Active Select When on, the element participates in the effect
sequence.

Effect Type Select Type of effect for the element.

Settings

Narration Media An audio file containing narration for the element,
to be played along with the effect and be timed
accordingly.

5.9 Mind Games

Game elements are a special type of elements, which have a high degree of flexibility both in their options and
their visual appearance.

Games can be inserted via the game picker, which can be opened using the Insert > Mind Games > Game
Picker... menu item or the Game Picker toolbar button. The game picker also shows a thumbnail of the game,
along with a short description of the game and its key attributes.

The following properties are common to all games:

Settings

Recycle Questions Select When on, questions are recycled once the user
exhausts the question list (and the game isn't
over). When off, the game is ended once the user
exhausts the question list.

Replayable Select When off, the start game button is hidden after the
game is started, and the game cannot be restarted
at any point.

SFX / Background Media Audio file to play as background music throughout
the entire game. The volume for this sound can be
set via <Volume / Background>.

SFX / Correct Media Audio file to play when a question is answered
correctly.

SFX / Incorrect Media Audio file to play when a question is answered
incorrectly.

SFX / Lose Media Audio file to play when the game is lost.

SFX / Question Media Audio file to play when a question is shown.

SFX / Start Media Audio file to play when the game is started.

SFX / Win Media Audio file to play when the game is won.
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Show Continue Select always - Show the Continue button at all times,
allowing the user to proceed before answering the
question.
after answer - Only show the Continue button
after the user has answered the question.
auto continue - Don't show the Continue button,
and automatically continue after the question has
been answered.

Show Results Select When on, the results layer is shown after has
ended.

Show Score Select When on, score is displayed along with the game.

Sound Select Determines the initial state of sounds in the game.
When off, sounds is initially mute.

Volume / Background Number The volume, in percents, for the background music.

Each of the following pages represents a game, and lists the game-specific settings, allowing to further
customize the game to your personal needs.

§ Master Plumber
§ Space Bubbles
§ High Hops
§ Rescue Mission
§ Game Show

5.9.1 Master Plumber

The goal of this game is to align the pipes correctly, so they will carry the fluid from one end to the other and
not spill at any point along the way.

The game starts with the pipes in randomized directions. The player clicks on a pipe in order to rotate it. Some
pipes are broken and marked with a wrench icon. In order to fix a broken pipe and rotate it the player needs to
answer a question correctly. If a pipe has not been fixed, the question will simply transfer to the next level.
Once the player believes the pipes are properly aligned, the valve can be opened by clicking on it, and start the
flow of fluid.

Levels can be loaded from pre-made presets, using <Levels Presets>. Levels can be further customized using
the level editor, which can be opened via <Levels Designer>. In the level editor, levels can either be created
from scratch, or single levels can be imported from the level presets.

Game attributes:

§ Win: The player wins by completing all questions and passing the test, or by completing all levels
(configurable).

§ Lose: The player loses when time runs out, or the test is failed.

§ Playability: Intermediate or advanced strategy/skills required to play the game, depending on levels.

§ Test score: Questions that the player did not reach before the game ended will not be counted as part of
the test.

In the Game layer there is a Solve button, allowing the player to immediately solve the pipe route. This feature is useful if the
designer would like to give the player the option to only answer the questions without solving the puzzle. This element will
appear in run-time, unless it's manually removed.

To insert a muster plumber game, use the Insert > Mind Games > Master Plumber menu item or the Game
Picker > Master Plumber toolbar menu item. Alternatively, you can use the game picker, which can be opened
using the Insert > Mind Games > Game Picker... menu item or the Game Picker toolbar button.

Settings

Color / Fluid Color The color of the fluid running through the pipes.
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Color / Joints Color The color of the joints connecting between the
pipes.

Color / Pipes Color The color of the pipes.

Cycle Levels Select When on, levels are cycled when all levels have
been exhausted and questions still remain. When
off, the game is ended once all levels have been
exhausted.

Level Time (sec) Select The time available for the player to complete each
level. After the time has elapsed, the valve is
automatically opened and the fluid starts flowing.

Levels Designer Special A special property, which opens the level editor
when clicked. The property displays the number of
levels in the active set. Changing the level data via
the editor automatically sets <Levels Preset> to 
user defined.

Levels Preset Select Allows to choose one of the pre-made level sets.
Choosing a presets overwrites any level data in
<Levels Designer>.
user defined - Allows you to design your own set
of levels, via <Levels Designer>.
blank - Resets the level data to a blank set.

Machine Type Select The visual appearance of the machine generating
the fluid. A setting of mixed cycles through the
different machines each level.

Questions per Level Number The number of questions (wrenches) to display in
each level. When set to 0, <Cycle Levels> should
be set to false.

SFX / Failure Media Audio file to play when the level has failed (fluid
has spilled along the way).

SFX / Rotate Media Audio file to play when a pipe is rotated.

SFX / Success Media Audio file to play when the level has been
completed successfully.

SFX / Valve Media Audio file to play when the valve is opened.

Tile Opacity Number The opacity level (0-100) of the tiles.

Tile Type Number The visual appearance of the tiles.

When Spilled Select When failing a level (the fluid was spilled along the
way), the game should:
next level - continue to the next level, regardless.
same level - let the player try the same level
again.

5.9.2 Space Bubbles

This is a traditional 'bubbles' game, the goal is to pop all bubbles (in this case, stars or dices) and/or answer all
questions. The player aims a cannon and fires it by clicking. If the fired item creates a cluster of at least 3 items
of the same type, the cluster explodes. Some stars have questions attached to them. When attempting to
explode a star with a question, the player is prompted with a question. A question star cannot be exploded
unless the question attached to it is answered correctly.

Game attributes:

§ Win: The player wins by exploding all items and/or answering all questions (see <Win Condition>). It's
possible for a player to win the game, but still fail the test.

§ Lose: The player loses when time runs out, questions run out, or the items are stacked too low. It's possible
for a player to lose the game, but still pass the test.

§ Playability: Intermediate strategy/skills required to play the game.
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§ Test score: Questions that the player did not reach before the game ended will not be counted as part of
the test.

To insert a space bubbles game, use the Insert > Mind Games > Game Show menu item or the Game Picker >
Game Show toolbar menu item. Alternatively, you can use the game picker, which can be opened using the
Insert > Mind Games > Game Picker... menu item or the Game Picker toolbar button.

Settings

Galaxy Select The visual appearance of the stars.

Missed Before Penalty Row Number The number of "missed" shots (shots which don't
generate explosions) before a penalty row is
added. A successful hit resets the counter. A value
of 0 disables penalty rows.

Questions Number The number of questions to attach to stars.

Rows Number The number of rows of stars.

SFX / Explode Media Audio file to play when a cluster explodes.

Show Background Select When off, the default background is hidden and the
visual appearance of the game can be customized.

Star Sprites Select The number of different star sprites to use (a lower
number will imply an easier game).

Stars per Row Number The number of stars per each row.

When Wrong Select Upon answering a question incorrectly:
keep cluster - The rest of the cluster doesn't
explode along with the question star.
explode cluster - The rest of the cluster
explodes, leaving only the question star.

Win Condition Select clear all questions - The game is won when all
questions have been cleared.
clear all stars - The game is won when all the
stars have been cleared.

5.9.3 High Hops

The player guides a frog from the left bank of the pond to the right by hopping from one lily pad to the next.
The player clicks on a lily pad to hop to, and needs to answer a question correctly to remain on the chosen lily
pad.

Game attributes:

§ Win: The player wins by reaching the right bank. It's possible for a player to win the game, but still fail the
test.

§ Lose: The player loses when time runs out, questions run out, or lily pads run out. It's possible for a player
to lose the game, but still pass the test.

§ Playability: Basic strategy/skills required to play the game.

§ Test score: Questions that the player did not reach before the game ended will not be counted as part of
the test.

§ Special features: The game can be played by two groups/people playing against each other.

To insert a high hops game, use the Insert > Mind Games > High Hops menu item or the Game Picker > High
Hops toolbar menu item. Alternatively, you can use the game picker, which can be opened using the Insert >
Mind Games > Game Picker... menu item or the Game Picker toolbar button.

Settings
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Attempts Number Set the number of attempts per step (lily pad).

Frog Color Select The player frog color, either red or purple.

Players Select The number of players to play the game, either 
one or two. When set to two, the lily pads on
screen will be numbered to aid collaborative play.

SFX / Hop Media Audio file to play when the frog hops between lily
pads.

Show Pool Select When off, the pool is transparent allowing
customization of the game's appearance.

Show Ripples Select When on, ripples will be shown around the lily pads
the player can jump to on each step.

Steps per Column Number The number of lily pads in a column.

Steps per Row Number The number of lily pads in a row.

5.9.4 Rescue Mission

The goal of this game is to rescue the penguin from the hole in the ice by stacking fish under it. A fish comes to
the penguin's aid when the player answers a question correctly. The top-most fish will vanish when the player
answers a question incorrectly.

Game attributes:

§ Win: The player wins by completing all questions and passing the test.

§ Lose: The player loses when when time runs out, the test is failed, or the penguin isn't rescued (see <Drown
Mode>).

§ Playability: No strategy/skills required to play the game.

§ Test score: Questions that the player did not reach before the game ended will be counted as mistakes in
the test.

To insert a rescue mission game, use the Insert > Mind Games > Rescue Mission menu item or the Game Picker
> Rescue Mission toolbar menu item. Alternatively, you can use the game picker, which can be opened using
the Insert > Mind Games > Game Picker... menu item or the Game Picker toolbar button.

Settings

50:50 Number The number of 50:50 lifelines (reduces the number
of answers by 50%) made available to the player.

Drown Mode Select Determines whether the penguin drowns if the
player fails to answer the question at the bottom of
the sea.

Fish Type Select The visual appearance of the fish stacked under the
penguin. A setting of mixed chooses a different
fish type each round.

Landscape Select The visual appearance of the background. A setting
of mixed cycles through the different landscape
each level.

Sea / Color Color A custom color to use for the sea. Only relevant
when <Sea / Custom> is true.

Sea / Custom Select When on, uses <Sea / Color> to determine the
color of the sea.

SFX / Level Media Audio file to play when the player moves up a
level.

Switch Question Number The number of switch question lifelines made
available to the player.
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5.9.5 Game Show

This is a gameshow-type trivia game, the player simply answers questions in order to get ahead in the game.

Game attributes:

§ Win: The player wins by completing all questions and passing the test.

§ Lose: The player loses when time runs out, or the test is failed.

§ Playability: No strategy/skills required to play the game.

§ Test score: Questions that the player did not reach before the game ended will be counted as mistakes in
the test.

§ Special features: The player may use special lifelines, including "switch the question" and "fifty-fifty".

When you insert an activity to a game show question page, make sure you set the activity size to take only half of the screen (as
the other half is taken by the game's host).

To insert a game show game, use the Insert > Mind Games > Game Show menu item or the Game Picker >
Game Show toolbar menu item. Alternatively, you can use the game picker, which can be opened using the
Insert > Mind Games > Game Picker... menu item or the Game Picker toolbar button.

Settings

50:50 Number The number of 50:50 lifelines (reduces the number
of answers by 50%) made available to the player.

Game Host Select The visual appearance of the game host.

SFX / Continue Media Audio file to play when the player continues to the
next question.

Switch Question Number The number of switch question lifelines made
available to the player.
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6.1 Composica doesn't start

Popup blockers

Popup blockers can prevent Composica from starting properly. If pressing the Start Composica button in the
Welcome screen does not open a new window, make sure any popup blockers you might have are disabled, or
have been set to allow popups. Some common popup blockers are the Windows XP SP2 popup blocker, and
blockers provided by Internet Explorer toolbars.

Anti-Virus applications

Different anti-virus applications might wrongly identify Composica as a security risk, and interfere with its normal
operation. If you're experiencing trouble, try temporarily disabling your anti-virus services, and consult your
system administrator.

Internet Explorer security

Internet Explorer's strict security policy might prevent some features from working properly. You're advised to 
add Composica to Internet Explorer's Trusted sites list.

6.2 Spell checker can't run

The spell checker requires access to certain system components, that might be blocked by Internet Explorer's
default security settings. To grant Composica the required permissions, you might need to add it to Internet
Explorer's Trusted sites list.

Trusted sites

To add Composica to Internet Explorer's Trusted sites list, follow these steps:

1.  Open a new Internet Explorer window.

2.  Choose the Tools > Internet Options... menu item.

3.  Select the Security tab.

4.  Select the Trusted sites icon.

5.  Important: Make sure the Security Level is set to "Low".

6.  Press the Sites... button.

7.  Make sure the "Require server verification (https:) for all sites in this zone" checkbox is not checked.

8.  Enter the URL of Composica in the "Add this Web site to the zone" field.

9.  Press the Add button.

10.  Press the OK button to close the Trusted sites dialog, and click OK again to close the Internet Options
dialog.

You should now see the  Trusted sites icon at the bottom of Internet Explorer when starting Composica.

These steps may differ between different Internet Explorer versions. For more information, refer to the Microsoft Internet Explorer
manual.



Composica119

© 2009 Composica Ltd.

Index
- A -
Add Page After Selection     30

- B -
Box     76

Breadcrumbs     86

Crumb Separator     87

Current Crumb     87

Parent Crumb     87

- C -
Chapters     25

adding     25

properties     27

Common properties     69

Layout     71

Settings     76

Style     75

Text     69

- D -
Document Title     84

Drag Drop     98
Drag Item     99

Drop Area     99

- E -
Effects Manager     63

- F -
Feedback     104

Check Answer     105

Check Button     105

Close Button     105

Custom Feedback     105

Final Feedback     104

Fix Button     105

Partial Feedback     104

Range Feedback     105

Retry Button     105

Right Feedback     104

Show Correction     105

Try Again     105

Wrong Feedback     104

Fill Blank     100

Blank Mask     101

Blank Option     101

Blank Range     101

Fill Blank Item     100

Question     100

Selectable Blank     101

Writeable Blank     100

Flash     81

Frame     78

- G -
Game Show     116

Get a Hint     105

Groups     33

- H -
High Hops     114

Hint    

Hint Popup     106

Horizontal Separator     76

Hot Spots     101

Hot Popup     102

Hot Spot     102

Hot Word     103
Hot Word Popup     103

http://code.google.com/apis/chart/isocodes.h
tml     9

- I -
Image     79

- K -
Keyboard shortcuts     64



Index 120

© 2009 Composica Ltd.

- L -
Link     77

List     77

List Item     78

- M -
Marquee     79

Master Layers     29
adding     30

properties     31

Master Plumber     112

Media Explorer     62

toolbar     63

Media Player     80

Menu Layers     29

adding     30

properties     31

Menus     40

Context menu     50

Document     41

Edit     42

Format     48

Help     49

Insert     43

Layout     49

Modify     44

Project     41

Project Manager     59

Tools     49

View     42

Metadata     24

Mind Games     35, 111
adding     35

layers     36

Multiple Choice     95, 97

Answer     96, 97

Point Click     96, 98

Question     96, 97

Multi-SCO     37

- N -
Navigation Button     84

Navigation Link     85

Navigation Locator     87

- O -
One-Level Menu     93

Current Marker     94

Derived Chapter     94

Dervied Page     94

Done Marker     94

Menu Block     94

Menu Chapter     94

Menu Container     94

Menu Page     94

Started Marker     94

Outline     25

adding items     25

deleting items     26, 31

importing     29, 32

item properties     27

organizing     26

- P -
Pages     25

adding     25

properties     27

Popup Button     86

Pop-ups     30

adding     30

properties     31

PowerPoint    
importing     32

Progress Bar     87
Percent Done     87

Project Manager     58
menu     59

toolbar     60

Project pane     55

Project properties     21
metadata     22

run-time properties     22

Project Title     84

Properties pane     54

Publishing     37



Composica121

© 2009 Composica Ltd.

- R -
Rescue Mission     115

Resources     29

adding items     30

deleting items     31

importing     32

item properties     31

- S -
Select Project     56

Select Resource     57

Separator     76

Shape    

Arc     81

Curve     81

Line     81

Oval     81

Rectangle     81

Round Rectangle     81

Space Bubbles     113

Spell checker troubleshooting     118

Status bar     64

Styles     34

adding     34

assigning     34

- T -
Table     78

Table Cell     78

Tags     33

Tasks     34

adding     34

editing     34

removing     35

reports     35

Test Feedback     108
Results Details     108

Re-Test     109

Review Test     109

Sections Summary     108

Test Details     108

Test Fail     109

Test Pass     109

Test Results     109

Test Summary     108

Test Sections     25

adding     26

properties     28

Tests     25
adding     26

properties     27

Text Elements     77

Comment     77

Footer 1     77

Footer 2     77

Header 1     77

Header 2     77

Header 3     77

Instructions     77

Quote     77

Timer     88
Timer Message     88

Toolbars     50
Document     50

Edit     51

Format     52

Group     51

Insert     52

Layout     53

Media Explorer     63

Project Manager     60

Table     53

Tools     53

Tree Menu     89, 91

Compact Tree Menu     90, 92

Current Marker     90, 92

Done Marker     90, 92

Menu Chapter     90, 92

Menu Container     90, 92

Menu Page     90, 92

Started Marker     90, 92

Troubleshooting     118

Trusted sites     118

- U -
User Identification     109

Text Field     110

User Id Error     110

User Id Label     110



Index 122

© 2009 Composica Ltd.

- V -
Variable     106

Vertical Separator     76

- W -
Widgets     29

adding     30

properties     31


	New in Composica 4.0
	Getting Started
	Starting Composica
	Creating a project
	Adding chapters and pages
	Tagging documents
	Designing a document
	Editing and formatting text
	Adding general elements
	Adding activities
	Adding media
	Adding mashups
	Adding narration
	Adding social media
	Sequencing and effects

	Adding tests and games
	Collaborating
	Tasks
	Blogs
	Chats
	Dashboards

	Previewing the project
	Publishing

	Using Composica
	Creating a project
	Blank project
	Styled project
	Duplicate of an existing project
	Instructional design based project

	Managing a project
	Project properties
	Run-time properties
	Project metadata

	Project outline
	Adding items
	Organizing
	Deleting items
	Item properties
	Importing

	Resources
	Adding items
	Deleting items
	Item properties
	Importing

	Importing from PowerPoint
	Assigning groups
	Assigning tags
	Styles
	Tasks

	Mind Games
	Adding games
	Game layers

	Publishing
	Multi-SCO Considerations


	User Interface
	Menus
	Document
	Project
	Edit
	View
	Insert
	Modify
	Format
	Layout
	Tools
	Help
	Context menu

	Toolbars
	Document
	Edit
	Group
	Insert
	Format
	Layout
	Table
	Tools

	Properties pane
	Project pane
	Select Project
	Select Resource
	Project Manager
	Menu
	Toolbar

	Media Explorer
	Toolbar

	Sequence Manager
	Status bar
	Keyboard shortcuts

	Elements
	Property types
	Common properties
	Text
	Layout
	Style
	Settings

	Basic
	Box
	Separator
	Text Elements
	Link
	List
	Table
	Frame
	Marquee

	Media
	Image
	Media Player
	Flash Animation

	Shapes
	Navigation
	Project Title
	Document Title
	Navigation Button
	Navigation Link
	Popup Button
	Breadcrumbs
	Progress Bar
	Navigation Locator
	Timer
	Tree Menu
	Compact Tree Menu
	One-Level Menu

	Activities
	Multiple Choice
	Point Click
	Drag Drop
	Fill Blank
	Hot Spots
	Hot Word
	Feedback
	Get a Hint

	Other
	Variable
	Test Feedback
	User Identification
	Sequence Manager

	Mind Games
	Master Plumber
	Space Bubbles
	High Hops
	Rescue Mission
	Game Show


	Troubleshooting
	Composica doesn't start
	Spell checker can't run


