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Composica 5.0 is focused on high productivity and makes it incredibly easy to get started with authoring
and reach advanced levels in a very short time.

The new version touches on nearly every aspect of course development, adding new authoring features,
streamlining existing features, and expanding on the variety offered to learners.

Dashboards

Dashboards have been overhauled and include a large, friendly menu, with the most common available
options, a searchable projects tree or an outline tree, depending on context, and a new version of the
dashboard widgets, which can now contain a lot more information in an easier to read format. Tasks can
be accessed via a tab in the dashboard, enabling quick search and report capabilities.

User Interface

Faster application loading, course previewing, and overall better experience. Smoother menus, toolbars,
and a new color scheme. Important elements from the Inse rt menu now also have presence in toolbars,
including Text, Media Player, Shapes and Navigation. Style rules can be assigned and created directly
from the Form at toolbar.

Elements Tree

A collapsible elements tree shows all elements on the document in a hierarchical format, making it a
breeze to find and select elements, as well as temporarily hide elements to make complex pages less
cluttered in design mode. Elements are easy to identify in the tree by their content, source, or the new 
<Name> property.

To read more about what's new in Composica 5.0, see the detailed release notes.

http://www.composica.com/product/release/5.0/
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This quick-start tutorial illustrates the basic usage of Composica, and should bring you up to speed on its
elementary features. Following through this chapter, you will learn everything you need to know to
create a basic project and publish it.

This tutorial only covers the essentials of each step, to help you quickly grasp the basics of Composica.
If you prefer an in-depth view, see Using Composica.

Starting Composica
Creating a project
Adding chapters and pages
Designing a document

Editing and formatting text
Adding general elements
Adding activities
Adding media
Adding mashups
Adding narration
Adding social media
Sequencing and effects
Adding tests and games

Previewing the project
Publishing

2.1 Starting Composica

Start Composica by entering its URL in your web browser. If you don't know the URL, ask your system
administrator.

Preparing for the first login

Popup blockers can prevent Composica from starting properly. In addition, recent changes in Internet
Explorer require that you add the Composica URL to the Trusted Sites zone in order to enable all of its
features.

Prior to your first login, follow the simple instructions provided at the login screen, to disable any popup
blocker and to add Composica to the Trusted Sites Zone.

Note that Composica does not require the installation of any ActiveX objects.

Logging in

To log in, enter your Login and Password at the Login screen, and press the Login button. To avoid
having to log in again from the same computer, check the Remember Me checkbox.

Login may be skipped by us ing the same Login as  your Windows  account username, and enabling Integrated Windows

authentication on the web server. For more information, contac t your sys tem adminis trator.

Welcome to Composica

Once logged in, you are presented with the Composica Dashboard.

The dashboard is a centralized information hub and provides easy access to the projects in the system.
Use the Quick Start panel to open an existing project, start a new project or import an existing one. If
you are an administrator, you can also open the administration panel.

I f C ompos ica doesn't s tart, try T roubleshooting.

2.2 Creating a project

The first step to working with Composica is to create a new project. For more information about creating
a project, see Creating a project.

Start a new project

Pressing the New Project button in the Quick Start panel launches the project creation wizard. The wizard
offers various options, most of which are optional, for starting a new project.
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To quickly start a new project:

1.  Enter the project's title (providing a description and assigning groups and tags is optional), and press
Next.

2.  Choose Styled Project, and press Next.

3.  Choose one of the available styles, and press Next.

4.  Edit the basic project properties (all of which can be left at their default values), and press Next.

5.  Press Finish to create the new project.

Once the new project has been created, the Project Manager will open. The Project Manager allows you
to configure the project, manage its outline, and set different project or document level settings.

2.3 Adding chapters and pages

Each project consists of different chapters and pages. In the Project Manager you can create and
manage the different chapters and pages of the project.

Adding a chapter

To add the first chapter, either use the Edit >  Add Chapte r Ins ide menu item or press the Add Chapte r
Inside  Se lection toolbar button. This will create a new chapter inside the currently selected item, which is
the project. You can now select the chapter and change its title, by altering the Title field.

Adding a page

Adding a page is very similar to adding a chapter. To add a page, simply select the tree item you wish to
add the page in, such as the project or the chapter, and use the Edit >  Add Page  Ins ide menu item or
press the Add Page  Ins ide  Se lection toolbar button. You can also choose to add a page after the chapter,
by selecting the chapter and using the Edit >  Add Page  A fte r menu item or the Add Page  A fte r Se lection
toolbar button.

A ll the options  of the Edit menu are also available by right-c licking on a tree item.

The project outline can be easily manipulated by using the Copy/Paste functionality or by simply
dragging items from one location to another.

When you're done manipulating the project outline, save your changes by using the Pro ject >  Save
Pro ject menu item, or by pressing the Save  P ro ject toolbar button.

2.4 Designing a document

Page designing is at the core of Composica. While designing, you insert and organize the elements and
content that comprise the document.

Elements include basic design elements such as boxes and separators, interactive elements such as
multiple choice questions and hot spots, and navigational elements such as buttons, links, and menus.

Design Document

To start designing a document, choose the document you wish to design in the Project Manager, and use
the Edit >  Design Docum ent menu item or press the Design Docum ent toolbar button. You can also
simply double-click the document you wish to edit.

A document can also be opened from the Project Dashboard, by selecting it in the Select Document
panel, or by clicking on any of the document links in the dashboard widget's. The Open Document or Find
Document buttons in the Quick Start panel provide additional means to opening documents.

The editing area

The familiar user interface of Composica should allow you to quickly become familiar with its basic
features.

The main Composica user interface consists of several toolbars and panels, and the large editing area.
The editing area is a WYSIWYG (what you see is what you get) representation of the document. In this
area you design the document's layout and edit its content.
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You can start by Editing and formatting text.

Saving the document

Once you're done editing your document (and every once in a while), it's important to remember to save
your changes. You can do so by using the Docum ent > Save menu item, or by pressing the Save
Docum ent toolbar button.

I f you forget to save your document, and perform an operation which requires  the document to be c losed, C ompos ica will

ask you whether you want to save or discard your changes .

Editing and formatting text
Adding general elements
Adding activities
Adding media
Adding mashups
Adding narration
Adding social media
Sequencing and effects

2.4.1 Editing and formatting text

Composica provides text editing and formatting capabilities that are similar to ones of common word
processors, along with more advanced methods for power-users.

Editing text

You can enter text into any element in the editing area, including the document itself.
Composica provides you all the common text editing capabilities such as Cut, Copy, Paste, Find and
Replace, and more.

Formatting

Composica provides you with quick formatting attributes through the Form at menu, and the Form at
toolbar. You can quickly set text attributes such as Bold, Italic, Underline, Fonts, Colors, Alignment, and
more.

To set these attributes, select text and choose the attribute to apply on it. Alternatively, you can set
attributes without selecting text to apply them to the entire text block.

Bold, I talic , and Underline behave differently. I f you press  one of these without any text selec ted, they become ac tive,

and are applied to any text entered. P ress ing them again will deac tivate them. This  behavior is  s imilar to common word

processors .

Composica also features many more formatting properties, available through the Properties pane.

2.4.2 Adding general elements

Elements are the building blocks of documents. Throughout your documents you will use many different
elements for different purposes. Some elements simply serve the design of the document, while others
provide navigation and interaction tools.

Adding boxes

A box is one of the simplest elements available, but also one of the more useful ones. A box is simply a
container, which can contain text and other elements. You can use a box to arrange floating content
around the document, and as a design building block.

You can set different properties for a box such as its background, borders and many more, and you can
set properties for its content, such as color, font and so on.

To add a box, use the Inse rt >  Box  menu item or press the Inse rt Box toolbar button. An empty floating
box will be added to the document. You can now manipulate this box and its content.

Editing an element's content
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You can edit the content of most elements, and they can contain rich content. Elements can also contain
other elements, giving you endless possibilities. To edit an element's content, you need to select it, and
then click inside of it. The editing caret will then be inside the element, and you can edit its content.

An empty box Selected box Editing content

Adding links

Links allow you to link to outside URL's from your document. To add a link, use the Inse rt >  Link menu
item or press the Inse rt Link toolbar button. A new link will be added where the caret is located.

To edit the link's URL:

1.  Select the link.

2.  Select the Settings tab in the Properties pane.

3.  Select the <URL> property, and click its value to start editing.

4.  Choose whether to link to a local resource (Media Explorer button), whether to link to a new
uploaded local resource (Upload button) or whether to link to an external address (Link button).

To edit the link's text, simply edit its content, as explained above. You can also change the link's color
and formatting as described in Editing and formatting text.

Links automatically open in a new browser window but can also be set to open inside the project, by
using a Frame element and the <Window Name> property.

2.4.3 Adding activities

Activities are interactive elements, which you can add to your documents to make them interesting and
appealing to viewers. Like all other elements, activities are highly customizable, both visually and
functionally. Activity elements consist of several sub-elements, which you can reorganize, edit, and
format.

Composica offers a variety of activities, which can be inserted from the Inse rt menu or the Inse rt toolbar
. An activity element is added to the document with its default layout and settings, including all of the
sub-elements essential for its functionality.

Some activities are used as questions, and as such their "correct" state can be configured. This is
configured differently for each activity, according to its usage. These activities are: multiple choice, point
click, drag drop and fill blank. These activities also include a feedback element, which provides learners
with feedback based on their selection.

Other activities are simply used to add interaction and richness to the document, without having a
correct or incorrect state. These activities are: hot spots, hot word and survey.

Customizing and combining these activities can result in endless possibilities, allowing you to develop
nearly any wanted scenario without the need for any programming or any advanced knowledge.

Multiple choice questions

A multiple choice activity allows to quiz viewers about a certain topic, and provide them with instant
feedback. To add a multiple choice activity, use the Inse rt >  Multip le  Cho ice menu item, or press the
Inse rt Multip le  Cho ice toolbar button. The multiple choice question will be added to your document with
its default basic layout.

A multiple choice question consists of a question, several answers, a check answer button, and feedback.
You can format any of these elements, and change their content. For information on editing their content,
see Editing an element's content.
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There are three simple steps to make the multiple choice question functional:

1.  Change the question's text.

2.  Change each answer's text.

3.  Set the correct answer. This is done by selecting the correct answer, selecting the Settings tab in
the Properties pane, and setting the value of <Correct> to true.

The multiple choice question is now ready and functional. There are many more options and possibilities
for customizing and personalizing the activity. For more information, see Activities, Multiple Choice.

The sub-elements  which comprise the ac tivity elements  are often necessary for the ac tivities  to func tion properly. A void

removing such sub-elements , unless  advised to do so.

2.4.4 Adding media

Media elements are often used to enrich documents. Composica features an intuitive media management
system, and allows you to embed all popular media formats in your documents.

Uploading media files

To quickly upload media files, use the Too ls > Upload... menu item or press the Upload toolbar button.
The Upload dialog will open, allowing you to select multiple files and upload them to the central media
library. Uploaded media files are contained along with your project, and are available to any developer
that has access to your project.

The files will be uploaded and added to the project's media library. They will then be available via the 
Media Explorer and the Media tree.

Embedding media files

You can now insert the uploaded media files to the project. There are several methods of adding media
elements to a document:

1.  Using the Inse rt menu or the Inse rt toolbar.

2.  Using the Media Explorer.

3.  Using the Media tree.

The quickest way to add media files is using the Media tree. To add a media file:

1.  Select the Media tab in the Project pane. Under the Media tab, you'll find the media library tree. The
tree is divided into two main categories: Pro ject, which holds the media files uploaded for the
currently open project; and Public, which holds media files available to all projects.

2.  Open the Pro ject tree. The media files of the project are divided according to their type or format.

3.  Locate the media file you wish to add to the document.

4.  Double-click on the file.

The media element will be added to the document, at which point it can be positioned, sized, and
customized. Audio and video files of numerous formats are displayed using the highly customizable
universal media player.

You can insert media elements  ins ide other elements , by entering the element content edit mode before inserting the

media.

2.4.5 Adding mashups

Composica provides a simple and quick integration of mashup elements from popular external services
into the project. The customization of these elements is done from within Composica. 

Mashups can be inserted from the Inse rt >  Mashups menu item. 

YouTube Movie

The YouTube Movie element allows you to search and embed streaming movies directly from YouTube
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into the course. This can become a good source of existing material that can be harnessed to create
quick and effective training units.

The <Source> property of the element provides an interface to search, sort, and finally embed YouTube
movies based on their ID or associated keywords.

You can preview the different movies found and press the Se lect button to embed the movie. Once a
movie is embedded you can control different aspects of the element from the Settings tab.

Universal Search

The Universal Search element allows the learner to perform a search in one or more search engines.
This encourages the learner to be involved in retrieving the information, while remaining in the
environment of the course, which can improve the quality of learning.

Additional Search Engine elements can be added using the  Modify  > Add Search Engine menu item
according to need. Select each Search Engine sub-element and use its <Search In> property of the
Settings tab to select one of the listed search engines to use. You can also set the value to custom and
specify a URL for a search engine of your choice.

The search results can be set to be displayed in an external window (default) or inside the page, using
the <Show Results In> property under the Settings tab. The searched term can also be pre-populated by
simply typing the term in the Text Field sub-element of the search.

Twitter Tweets

The Twitter Tweets element displays an updated twitter feed embedded in the document. This can be
used to show updates on a topic, directly within the relevant document.

Using the <Hashtag or Search> property, a query can be set for which tweets should be searched. The
<From Twitterer> and <To Twitterer> properties can be used to look up tweets which are authored by or
directed to a specific twitter user. These can be combined in order to create more specific queries, for
example, searching for tweets containing a specific word coming from a specific user.

Facebook Like Button

The Facebook Like Button element allows learners to express interest in a document, and share it with
their facebook friends, allowing for community interest in the course, and a social learning experience.
The interface contains a button which users can use to "like" the document, and also lists the number
(and possibly faces) of other people who liked this document. The look and feel of the interface can be
customized using several properties.

Google Chart

The Google Chart element provides a quick and simple way to enrich the project with charts of several
types, based on data entered directly into the element.

The chart type is set in the <Chart / Type> property under the Settings tab (types include: line,
columns, pie, venn and more). Each type is accompanied with several attributes such as: Size, Colors,
Labels and Legend, to allow maximum control over its look and feel. Select each Data Point sub-element
and from the Settings tab, use the <Data> property to enter the data and the <Label> property to add a
label to that piece of data. 

Google Map Chart

The Google Map Chart element is a variation of the Google Chart element. It provides the ability to
create thematic maps of different geographical areas, based on data entered directly into the element. 

The <Geographical Area> property under the Setting tab (available in Advanced prope rtie s view) lists
different geographical areas. When a Data Point is selected, a country code (see links below) can be set
in the <Label> property and this country will be highlighted on the map accordingly.

Supported country codes: http://code.google.com/apis/chart/isocodes.html 
Supported state codes (USA): http://code.google.com/apis/chart/statecodes.html

http://code.google.com/apis/chart/isocodes.html
http://code.google.com/apis/chart/statecodes.html
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2.4.6 Adding narration

Narration is an important aspect of every course. It adds a new dimension to the content and helps
learners absorb content better.

Narrating an element

1.  Select the element to narrate.

2.  Go to the Settings tab.

3.  Edit the <Narration> property.

4.  Choose whether to use an existing audio file, upload a new audio file, or record the narration now
(see below).

This will add narration to your element, and it will immediately become a participant in the document's
sequence. You may add narration this way to every element on the document that requires narration.
Composica will automatically sequence these elements according to their position and the length of the
audio.

Using the audio recorder

The audio recorder allows recording audio clips directly inside Composica without having to use any
external applications or tools.

1.  Press on the Record button to begin. Once recording, you can press on the Pause button to
temporarily stop the recording and resume it later.

2.  Press on the Stop button once you're done recording.

3.  Press on the P lay button to play back your recording, and press on the Record button again if you
wish to re-record.

4.  Once you're happy with the recording, name the audio file and press on the Upload button, which will
upload your recording and assign it to the element.

Java is  required in order to record audio.

Disable/enable narration

A Narration On/Off button can be inserted to the document using the Inse rt >  Narra tion > Narra tion On/
O ff menu item. The function of the button is global to the entire course, so the learner can mute or
restore the narration according to personal preference.

Closed captioning

A Closed Captioning element in the document can contain the captioning of the narration, in order to
support accessibility guidelines. It can be inserted from the Inse rt >  Narra tion > C losed Captioning menu
item.

Captions can be toggled on or off using the Closed Captioning On/Off element, available from the Inse rt
> Narra tion > C losed Captioning On/O ff menu item.  The function of this button is global to the entire
course, so the learner can choose to show or hide the captions according to personal preference.

2.4.7 Adding social media

Composica provides authors with the ability to create highly rich, interactive and structured content, but
it also empowers them to take full advantage of social media elements to create a learning community
around each course. Courses then become both formal and social by nature - learners can share
knowledge with others, learn from each other, comment on and rate content, and more - all while
browsing the course, without ever having to leave the learning environment.

Blogs

Blogs provide a very powerful method for learners to share their knowledge and benefit from each
other's experience.

A project can include any number of blogs that can be customized and configured. Blogs are inserted
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from the Inse rt >  Socia l Media menu.

The blog element consists of several widgets and buttons:

The left area of the blog element includes default blog widgets (Recent Posts and Archive), that
contain placeholders. In the published course these placeholders will provide access to the learner's
blog posts.

The top-left area of the blog element also includes default blog buttons (Blog Home, Add Post and Edit
Post). Different properties provides control over the buttons' functionality. For example, the
<Approval Required> and <Login Required> properties of the Add Post button can be used to set the
requirements for adding a post.

The right area of the blog element includes place holders for the actual blog posts and comments.
After publishing, these will reflect the thread of posts and comments.

Select any of the blog's sub-elements to customize their look and feel. Additional blog widgets and
buttons can be added from the Modify menu, enabled when any of the blog elements are selected. When
one of the post placeholders are selected, a rating element can be added from the Modify menu.

Each blog can also be accessed and edited independently of the course, and includes an RSS feed for
subscription.

Remote RSS feeds

A blog element can be configured to display the remote RSS/Atom feed of any other blog or other RSS/
Atom-based service, by simply pasting the external RSS address in the <External Feed> property under
the Settings tab (available when the blog element is selected). The feed is presented using the full set of
features available to regular blog elements.

Comments

Comments can be combined with any other Composica element, so learners can add their input about a
specific piece of content, the subject matter of the course or the course itself. 

A project can include any number of comment elements that can be customized and configured.
Comments are inserted from the Inse rt >  Socia l Media menu.

The Comments element consists of placeholders. In the published course these placeholders will reflect
the thread of learner's comments.  Edit the look and feel of the these sub-elements to customize the
visual aspects of the comments.

The <Approval Required> and <Login Required> properties of the Add Comment sub-element can be
used to set the requirements for posting a new comment. Selecting the Add Comment element toggles
the New Comment form, which can also be customized.

Rating

SCORM supported Rating elements can be combined with any other Composica element, so that learners
are able to rate the content in the document level or the course level.

A document can include any number of rating elements that can be customized and configured. Rating
elements are inserted from the Inse rt >  Socia l Media menu.

In the published course, the average rating of all previous votes will be displayed. To alter this behavior,
use the rating element's <Accumulate Votes> property.

The <Star Count> property controls the rating range of a specific element. Different images can be set
for the different states of the rating sub-elements (on, off and edit). Select any of the three star types
and change its image using the <Source> property.

Learner authentication

Different social media elements can optionally require learners to be authenticated to the system. The
authentication can be set to use LMS or Windows authentication; alternatively, custom authentication can
be chosen. A Sign In element can be inserted to the project from the Inse rt >  Socia l Media menu to
allow the learner to log in using custom authentication.
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2.4.8 Sequencing and effects

Sequencing elements can enrich the document and help learners digest information better as the
document gradually builds. Sequencing can be combined with effects and narration to enhance the
overall experience.

Adding a sequence

Select all the elements that should be sequenced (use Shift+Click for multiple selection) and use the 
Too ls > Sequence  Manager... menu item or press the Sequencing toolbar button. This will open the
Sequence Manager dialog allowing you to configure the order, timing, effects, and more.

Alternatively, you can manually assign elements to participate in the sequence by setting their
<Sequence Active> property to yes, as well as their <Effect Type> property to the desired effect.
Sequencing properties are available from the Style tab.

Precise control over the associated effects, order, timing and many other settings is available in the 
Sequence Manager dialog. It is divided into two tabs; the Main tab controls common settings, while the
Elements tab can be used to control the behavior of specific elements.

2.5 Adding tests and games

Composica has powerful testing and assessment capabilities that can be used for summary tests, self
assessments and certification. Comprehensive performance information is communicated to an LMS
through SCORM.

Tests

Tests are added to the project outline in the Project Manager. As with any outline item, their position in
the outline tree can be freely changed at any time.

A test must have at least one section, so a default Test Section is included with every new test and
additional sections can be added according to need. Sections contain pages with activities in them. The
learner gets scored based on performance in these activities.

When a test is selected in the outline tree, different aspects of its functionality can be set in the
properties area. For instance:

The Test Mode property determines if the test will use all available questions, or a set of questions
selected at random out of a question bank.

The Section Order and Question Order properties are used to set the order in which the questions will
be presented.

The Score Method property determines whether all sections have an equal score weight, or a custom
weight per section.

In addition, tests can be time limited, their pass score and the number of allowed attempts can be set
and much more.

Each Test Section has additional properties, which complement the test settings and allow further
flexibility in the configuration of the test.

Tests are inserted to the outline tree with an associated Test Results page. A Test Feedback element can
be added to this page, to provide learners with a detailed report on their performance in the test. This
element can be configured to show as much or as little information as required.

Games

Games employ powerful motivational elements such as competition, humor and the satisfaction of
winning through applying a skill.

Composica Mind Games allow authors to utilize these elements and create experiences that learners can
enjoy and from which they gain knowledge.

Game elements can be added to test documents and wrap the functionality of the test. Games support
all settings available to tests, and while using them, performance data can be recorded to an LMS via
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SCORM.

Composica offers a variety of attractive games, each with its unique approach, focus, and level of
playability: Master Plumber, Space Bubbles, High Hops, Rescue Mission, Game Show. 

Games can be added using the Inse rt >  Mind G am es menu item or the G am e P icke r toolbar button.

Like all other elements, games are highly customizable, both visually and functionally. The author can
adjust the difficulty level of the gameplay as well as the educational difficulty of the questions, and
achieve the desired balance.

When the game element is selected, the author can use its properties to set the number of questions per
level, the background setup, the number of allowed attempts and many other parameters. Some of the
properties are common to all games, while others are specific to each game. 

Each game consists of several layers that are used for visual and functional control. At run-time, the
layers will be shown and hidden at different game states. Selecting the different layers for viewing and
editing is done using the tabs at the top of the game element. 

Question pages in the game are displayed with the game design and background.

2.6 Previewing the project

The editing area of Composica provides a WYSIWYG view of the document, which means the way the
document looks while you're editing it, is the way it will appear when published.

However, you may wish to preview the document you're editing, to examine how it interacts with the
viewer, and to view how all the elements integrate in the document.

Previewing the document

You can quickly preview the document you're currently working on, by using the Docum ent > Prev iew
Docum ent... menu item, or by pressing the Prev iew Docum ent toolbar button. A new window will open,
previewing how the document will look when published.

P reviewing a document requires  the lates t changes  to be saved. I f you haven't saved your changes , C ompos ica will ask

you if you wish to save the changes  you have made.

Previewing the project

Previewing the document shows you a preview of the current document within the project. To see how
project will be viewed when published, you need to preview the project by using the Pro ject >  P rev iew
Pro ject... menu item.

2.7 Publishing

Publishing your project is the concluding step of your work with Composica. Once pleased with how the
project looks and functions, you can publish it in various different formats to produce the final course.
The published course runs independently of Composica, and doesn't require any special software
installed.

Published courses are separated to two main categories, online and offline. Courses published online will
be automatically placed on the web server, making them available without requiring any download.
When publishing offline, Composica will produce a package of one of several optional formats.

Publish project

To publish your project, use the Pro ject >  Publish P ro ject... menu item. The publish project dialog will
open, allowing you to choose from several different publishing options.

Publishing online

To publish your work online, choose the Web Server option.

Once processing is complete, you will be given the web address of the newly published course. You can
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follow the link to view the published course, or use the Copy Address button to copy the URL to your
clipboard.

The course can also be published as a SCORM 1.2 or SCORM 2004 package. In this format, the system
generates a content package, which is fully compliant with the standard specification and includes
everything needed in order for the course to be immediately integrated with any SCORM supported LMS.

Publishing offline

You can publish offline to several formats, such as an executable application, an installation package, a
zip file, and a PDF document. Choose the desired format, and press OK.

Once the processing is complete, a File Download dialog will open allowing you to save the published
material to your hard drive. You are also presented with a web link to the file, in case downloading fails
or you wish to pass the link to other users.



Part

III

Using Composica



Using Composica 16

©  2010 Com posica  Ltd.

This chapter covers the different possibilities of Composica in-depth, including various tips and notes.
Wherever possible, links are provided to the referential section to provide raw details and facts.

Creating a project
Blank project
Styled project
Duplicate of an existing project
Instructional design based project

Managing a project
Project properties

Run-time properties
Window
Settings
Social Media
SCORM

Project metadata
Project tree

Adding documents
Organizing documents
Removing documents
Document properties
Importing documents

PowerPoint import
Groups
Tags
Styles

Mind Games
Adding games
Game layers

Publishing
Multi-SCO Considerations

Collaborating
Tasks
Blogs
Chats
Dashboards

3.1 Creating a project

There are several ways to start a new project:

1. Using the New Project button in the Quick Start panel of one of the dashboards.

2. Using the Pro ject >  New Pro ject... menu item.

3. Using the New Project button in the Select Project dialog, available from the Pro ject >  Open Pro ject...
menu item.

Start a new project

Both methods will open the Start a New Project dialog, providing a step-by-step wizard to quickly create
your project.

Title your new project

Project Title is the name the project will have, and the way it will be recognized in the future. Make sure
to choose a name you can distinguish from other names.

Description is an optional field, available for personal usage.

The A ssign G roups button allows you to assign one or more user groups which can view and edit the
project.
The Tags input allows you to assign one or more tags which can help organizing and tracking the project.

Once titling the new project, press Next to move on to the next step.
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Create a new project

The second step of the wizard gives the choice of selecting one of the following options:

Blank project
Styled project
Duplicate of an existing project
Instructional design based project

3.1.1 Blank project

Choosing to create a blank project is the quickest way to create a new project. There are no further
steps for creating the project, besides confirming the selection.

Create the project

Once confirmed, a new project will be created, and the Project Manager will be automatically opened to
allow configuration of the project.

The new project is created with all the default properties and no style settings. To start configuring the
project, see Managing a project.

3.1.2 Styled project

The styled project is the most standard way to create a new project. It allows you to create a project
based on an existing system style, giving your project a basic theme.

Choose a style

A style is the general theme a project has. A style affects the default visual appearance of each
document in your project.

The styles tree consists of several styles, each consisting of several master layers. Selecting one of the
master layers in each style will show a preview of that style.

Even though a s tyle is  configured for an entire projec t, each document in the projec t can override its  s tyle and master

layer settings . See document properties .

Personalize the master layer

The theme master layers are fully customizable as any Composica document, once the project has been
created. However, some of the built-in master layers can be quickly customized at the style selection
stage. Styles which support this feature (namely Mix  &  Match, C risp, Oute r Curves and B lox) will show
the customization panel when selected, allowing to change certain aspects such as colors and icons
within the master layer.

Create the project

Once confirmed, a new project will be created, and the Project Manager will be automatically opened to
allow configuration of the project. To start configuring the project, see Managing a project.

3.1.3 Duplicate of an existing project

Choosing to create a project as a duplicate of an existing project will list all the projects currently
available. Creating projects from previously made projects can speed the process of creating similar
projects.

Choose a project

Given a list of available projects, choose a project to use as a base for the new project.

Choose components to copy

Once choosing a project to duplicate, an option of which components to copy is available. Choose the
components which you want copied over to the new project.

Create the project

Once confirmed, a new project will be created, and the Project Manager will be automatically opened to



Using Composica 18

©  2010 Com posica  Ltd.

allow configuration of the project.

The new project is created as an exact duplicate of the base project, according to the components
selected. To start configuring the project, see Managing a project.

3.1.4 Instructional design based project

Choosing to create a project based on an instructional design template will list all the projects configured
as such templates. Creating projects from previously made templates can speed the process of creating
projects.

Template projec ts  are identical to regular projec ts , except that their P rojec t Type property is  set to Instructional Design

Template.

Choose a instructional design template

Given a list of available templates, choose a template to use as a base for the new project.

Choose components to copy

Once choosing a template to use, an option of which components to copy is available. Choose the
components which you want copied over to the new project.

Create the project

Once confirmed, a new project will be created, and the Project Manager will be automatically opened to
allow configuration of the project.

The new project is created based on the instructional design template, according to the components
selected. To start configuring the project, see Managing a project.

3.2 Managing a project

The Project Manager can be opened from one of the following places:

The Manage button in the Quick Start panel of the Project Dashboard.

The Pro ject >  Manage  P ro ject... menu item or the Manage  P ro ject toolbar button.

Right-clicking on the outline tree in the Project pane, and choosing the Manage  P ro ject... option.

Any changes you make in the Project Manager are not saved, until you use the Pro ject >  Save  P ro ject
menu item or the Save  P ro ject toolbar button. Once saved, changes to the Project Manager cannot be
undone.

In the Project Manager, you can configure and manage the following:

Project properties
Project tree
PowerPoint import
Groups
Tags
Styles
Tasks

3.2.1 Project properties

When the project (root) is selected in the tree of the Project Manager, the project properties can be
viewed and edited in the properties area. Following is a table of each property and its description.

Title The name of the project, how it will be identified throughout
Composica.

Description A description of the project, for personal usage.

Version The version of the project.

Style The style to use as default for the project.
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Master Layer The master layer to use as default for the project. Only master
layers relevant to the current style can be selected.

Dynamic Layer The dynamic layer to use as default for the project.

Global Settings

Project Type Project - A regular project resulting in a course.
Instructional Design Template - A template project, used as
an instructional design template.

Writing Direction The default writing direction for the project.

Skip Chapter Pages When set to skip, chapters, tests and test sections are skipped
from navigation.

Persist Activities When on, the state of activities is maintained when navigating
away from a page.

Press the Run-tim e  Prope rtie s button to open the Run-time Properties dialog.
Press the Pro ject Me tadata button to open the Metadata Editor dialog.

Use the Pro ject Tags field to assign tags to the project.

The following properties can be overridden in each document's properties:

Style

Master Layer

Dynamic Layer

Persist Activities

Skip Chapter Pages (named Skip Page)

Writing Direc tion can be overridden in the page level, by changing the document's  Layout > Direc tion property.

Run-Time properties
Project metadata

3.2.1.1 Run-time properties

The run-time properties dialog exposes different properties relevant to the run-time of the project.

To edit the project's run-time properties, in the Project Manager, use the Pro ject >  Run-tim e  Prope rtie s...
menu item or the Run-tim e  Prope rtie s toolbar button, or select the project (root) in the tree and press
the Run-tim e  Prope rtie s button.

Run-time properties are divided into four tabs:

Window - settings related to the window the course launches in, and different behaviors of that
window.

Settings - various settings controlling the looks and the behavior of the published course.

Social Media - settings related to social media elements.

SCORM - settings controlling the behavior of SCORM communications with the LMS.
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3.2.1.1.1  Window

Window tab of the run-time properties dialog contains settings related to the window the course launches
in, and different behaviors of that window.

Document size

Document Size - Size of the document (and not the window it opens in). This dictates the bounds of
the document editing area in the project. Choose one of the available recommended options (each
option also specifies which target resolution it is appropriate for), or choose Custom and specify custom
bounds.

Window launch

Open project in

New proportional window - Opens in a new window, proportional to the document size.

New maximized / fullscreen window - Opens in a new window, in maximized or full-screen state,
as possible.

Current window - Opens in the current window.

Current window and resize to fit - Opens in the current window, and attempts to resize the
window to fit the document.

Window behavior

User must press a button to begin - When unchecked, the course starts automatically when
entering the launch page.

User may resize the window - When checked, the learner can change the size of the course
window.

User may select text and content - When checked, the learner can select text and other contents
in the course using the mouse, and optionally copy the contents.

User may invoke the context-menu - When checked, the learner can use the right mouse button
to open the browser's native context-menu, which gives different options which may have undesirable
results.

Scaling

If the window becomes smaller than the document

Scale document down (zoom out) - Scale (zoom) the document down so it fits the window.
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Show scrollbars - Keep the document at its original scale, and allow the learner to scroll around the
window.

If the window becomes larger than the document

Scale document up (zoom in) - Scale (zoom) the document up so it fits the window.

Center document - Keep the document at its original scale, and center it in the window.

Window background color - When the window doesn't fit the document, stripes of the window's
background color will show to accommodate for the space. This setting allows you to match the color of
these stripes to your project.

Scaling will likely lead to loss  of quality. Documents  containing flash, media player, shapes  or mind games  cannot be

scaled, and will fall back to alternative handling.

3.2.1.1.2  Settings

Settings tab of the run-time properties dialog contains various settings controlling the looks and the
behavior of the published course.

Launch page

Project launch page

Styled - Shows a styled Composica branded launch page.

Styled - Customize - When selected, shows an Upload Im age link, allowing to replace the brand of
the styled launch page. The dimensions of the uploaded image should be 780 x 85 pixels.

Minimal - Shows a minimal launch page with no branding.

Restoration

When the project is re-launched

Restore state using LMS data - Stores the course state to the LMS, and restores it when the same
learner launches the course again. Due to a limitation in SCORM 1.2, this only works when using
SCORM 2004.

Restore state using local computer data - Stores the course state to the local computer, and
restores it when the course is launched again by the same computer user.

Preloading
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Number of documents to preload on launch

Only preload media files of size less than - Threshold for image size, to avoid preloading large
media files (such as videos) which might not be necessary.

Media

Media to include

Detect automatically - Upon publishing, Composica automatically detects which media files are
being used in the project, and only includes these in the published product.

All project media - In some situations, objects embedded in the course (such as Flash animations)
depend on external assets. Because Composica has no way to detect these files are being used in the
project, all media files in the library must be included in the course. When publishing with all media
included, care should be taken to maintain the library as minimal as possible in order to reduce the
size of the published course.

Visuals

Disable ClearType font smoothing in Internet Explorer 7+

Yes, disable ClearType for everything - Disables ClearType entirely for the course, in order to
maintain consistency when effects are used.

No, only disable ClearType on elements that are showing effects - Only disables ClearType
on elements which are using effects (due to an Internet Explorer limitation), while still using it
everywhere else.

3.2.1.1.3  Social Media

Social media tab of the run-time properties dialog contains settings related to social media elements.

Blogs

Show blog index in launch page - Shows an index of blogs which participate in the course in the
launch page, linking to the external version of the blogs, so that learners can have quick and easy
access to the blogs without having to enter the course, and search engines can find and include the
blogs in their search results.

Moderation password - When set, a moderation link is added to the course launch page and, by using
the set password, a moderator can review, edit, and remove any social content of the course.

Authentication
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Authentication is used by the social media engine to recognize learners, and to allow them to add, edit,
and remove content according to the social media element's settings.

Learner Authentication - Method used to authenticate users to the social media engine.

System Default - Uses the authentication method set as default by the system administrator.

LMS - Authenticates the user according to information provided by the LMS.

Windows - Uses Windows built-in authentication.

Custom - Uses custom authentication provided by the social media engine. Any learner can sign up
and log-in using the sign in element, which must be provided when this authentication method is used.

Social Media Engine

The social media engine is the heart of all social interactions, as it stores and maintains all the social
related data of the course. For the social media elements to function properly, the learner must have
access to the social media engine from the location where the course is taken. This means that for a
specific course, it might be required to have a social media engine at a different location.

Engine URL

System Default - Uses the engine URL set as default by the system administrator. This normally
points to the social engine installed with the Composica installation.

Custom - When selected, shows an input allowing to enter a URL 

A  s tand-alone ins tallation of the soc ial media engine is  available, and will be given upon reques t.

3.2.1.1.4  SCORM

SCORM tab of the run-time properties dialog contains settings controlling the behavior of SCORM
communications with the LMS.

SCO Level

Determines the hierarchy level at which documents are packaged into SCOs. A level of zero means the
entire course is packaged as a single SCO, which is the recommended mode of usage.

Setting the level to a non-zero value means that all documents at the specified hierarchy level are
packaged into an SCO, resulting in multiple SCOs for the course. This can significantly impair the normal
functionality of the course, and is strongly discouraged. For more information, read about Multi-SCO
consideration.

SCORM 2004 Behavior

Behavior settings which only apply when SCORM 2004 is used to communicate with the LMS.



Using Composica 24

©  2010 Com posica  Ltd.

Mark course as completed when the user - Defines when the course is considered to be
completed, regardless of success status.

Passes all participating tests and visits all pages

Visits all pages

Passes all participating tests

Visits any page

Mark course as passed when the user - Defines when the course is considered to be passes,
regardless of completion status.

Passes all participating tests

Passes all participating tests and visits all pages

SCORM 1.2 Behavior

Behavior settings which only apply when SCORM 1.2 is used to communicate with the LMS. Unlike
SCORM 2004, SCORM 1.2 refers to the course either according to its completion status, or according to
its success status.

Mark lesson status as - Determines whether the course is referred to according to its completion
status, or according to its success status.

Passed/failed when tests exist, completed/incomplete otherwise

Always completed/incomplete, even when tests exists

Mark course as passed/completed when the user - Determines when the completion or success
status is considered to be true.

Passes all participating tests or, if no tests exist, visits all pages

Passes all participating tests or, if no tests exist, visits any page

Passes all participating tests and visits all pages

Note that when publishing the course in multi-SC O  mode, any of these settings  referring to the course ac tually refers  to

each s ingle SC O .

3.2.1.2 Project metadata

The project's metadata meets the SCORM
standard metadata definition. Even though
providing metadata isn't required by the SCORM
standard, it is generally a good idea to provide
such information if you plan to import the
published course to a SCORM conformant LMS,
or include it in a cataloging system.

To edit the project's metadata, in the Project
Manager, use the Pro ject >  Edit Me tadata ...
menu item, or select the project (root) in the 
tree and press the Pro ject Me tadata button.

The following metadata can be configured:

General
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Language The language of the course.

Catalog The name(s) of one or more catalog systems that contain an entry
for the course.

Catalog Entry The entry of the course in the catalog systems.

Keywords A keyword list that describes the course, used as search terms.

Purpose The purpose of the course.

Cost Indicates whether a fee is charged for using the course.

Copyright Indicates whether the course is copyrighted.

Description The description of the course, will typically be included in catalog
listing and displayed by LMS's.

Educational

Interactivity Type The type of interactivity provided by the course.

Interactivity Level The level of interactivity provided by the course.

Learning Resource Indicates the learning resource type.

Context The educational context of the course.

Semantic Density The level of semantic density of the course.

Intended End User Indicates who the intended viewer is.

Difficulty The difficulty of the course.

Age Range The intended age range appropriate for the course.

Learning Time The average time needed to complete the course.

Description The description of the educational or pedagogical characteristics of
the course.

3.2.2 Project tree

The project tree represents the documents which comprise the project. The tree is separated to Outline
and Resources trees.

Outline

The outline tree describes the skeleton of the project. The outline can be modified at any time,
documents can be added, removed and rearranged at will through the Project Manager. The outline's
tree root is the project node, which contains the project outline and properties which are global to the
project.

The outline tree describes a hierarchy of documents, each document can be one of the following types:
a page, a chapter, a test, or a test section. Any document type can be designed and can contain any
type of content supported by Composica.

Pages

Pages are the most primitive document types. Pages can't contain other documents under them in the
outline tree. Pages have several configurable properties.

Chapters

Chapters are menu pages, which contain other documents. Chapters can be used to arrange other
documents into blocks, and can be configured to be skipped from the project's navigation in their 
properties.

Tests

Tests are the outer menu pages holding test sections and pages. A test has many different properties
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unique to tests, which allow for tests to have scores and pass status determined.

Test Sections

Tests can be made up of one or more test sections, which are another type of menu pages. Similar to
chapters, sections can be configured to be skipped from the project's navigation in their properties.

Resources

The resource tree is a repository of different resources which can be used and reused by the project's
outline documents.

Resources can be one of the following types: master layers, dynamic layers, widgets, and standalones.
Any resource type can be designed like any other document, and can contain any type of content
supported by Composica.

Master Layers

Each document of the project can have a master layer assigned to it, either directly or inherited from its
parent (see document properties). The master layer is shown behind the document, and can contain
common project-wide elements, such as background, title, navigational elements and more.

If your project uses one of the system styles, it already has one of that style's master layers. You can
add more master layers from the system styles by using the Project > Add System Style... menu item
or Add System Style toolbar button of the Project Manager.

As master layers can be reused by multiple documents, they can save precious development time in not
having to make the same changes in multiple places. Any changes made to the master layer are
immediately reflected in any document which uses it.

Dynamic Layers

Additionally to the master layer, each document of the project outline can have a dynamic layer
assigned. A dynamic layer can either be shown behind or in front of the document, and has special 
settings which allowed it to be applied only in specific scenarios, allowing it to be used to complement
the master layer.

For example, a dynamic layer can created with a tree menu, set to apply only to menu pages, and
assigned to the entire project. Such a simple setup would quickly add menus to every menu page (
chapters and sections) in the project, managed from a central document.

As dynamic layers can be reused by multiple documents, they can save precious development time in
not having to make the same changes in multiple places. Any changes made to the dynamic layer are
immediately reflected in any document which uses it.

Widgets

Widget documents give the ability to create template document configurations, and can contain one or
more elements, or an entire document, including all contents, formatting and properties.

Widgets can be quickly applied to the current document by using the Tools > Apply Widget... menu
item, or by pressing the Apply Widget toolbar button. Applying a widget copies it to the current
document, and any changes made to the original widget will not be reflected after the widget has been
applied.

Standalones

Standalone documents are normal documents, but they don't participate in the project's outline tree,
don't appear in navigation, and aren't counted as part of the project's completion objectives. Standalone
documents can only be navigated to directly, using a Navigation Button set to the custom <Operation>,
or opened in a new pop-up window via the Popup Button.

Adding documents
Organizing documents
Removing documents
Document properties
Importing documents
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3.2.2.1 Adding documents

Documents can be added by designing new documents and saving them, but can also be planned and
added up front in the Project Manager, as blank documents which can later be designed.

Following is a list of different document types and the ways they can be added to the project tree.

Pages

Pages can be added directly under the project, inside chapters, and inside test sections.

To add a page inside an outline item, select that item and either:

use the Edit >  Add Page  Ins ide menu item.

press the Add Page  Ins ide  Se lection toolbar button.

To add a page after an outline item, select that item and either:

use the Edit >  Add Page  A fte r menu item.

press the Add Page  A fte r Se lection toolbar button.

Chapters

Chapters can be added directly under the project, inside other chapters, and inside test sections.

To add a chapter inside an outline item, select that item and either:

use the Edit >  Add Chapte r Ins ide menu item.

press the Add Chapte r Ins ide  Se lection toolbar button.

To add a chapter after an outline item, select that item and either:

use the Edit >  Add Chapte r A fte r menu item.

press the Add Chapte r A fte r Se lection toolbar button.

Tests

Tests can be added directly under the project, and inside chapters.

To add a test inside an outline item, select that item and either:

use the Edit >  Add Test Ins ide menu item.

press the Add Test Ins ide  Se lection toolbar button.

To add a test after an outline item, select that item and either:

use the Edit >  Add Test A fte r menu item.

press the Add Test A fte r Se lection toolbar button.

Test Sections

Test Sections can only be added directly under a test. Any documents inside a test must reside inside a
test section, and a test must have at least one test section.

To add a test section inside a test, select the test and either:

use the Edit >  Add Test Section Ins ide menu item.

press the Add Test Section Ins ide  Se lection toolbar button.

To add a test section after another test section, select the test section and either:

use the Edit >  Add Test Section A fte r menu item.

press the Add Test Section A fte r Se lection toolbar button.

Master Layers

To add a master layer, select the Master Layers folder in the tree, and either:
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use the Edit >  Add Page  Ins ide menu item.

press the Add Page  Ins ide  Se lection toolbar button.

To add a master layer after an existing one, select that master layer and either:

use the Edit >  Add Page  A fte r menu item.

press the Add Page  A fte r Se lection toolbar button.

To add a master layer from the built-in system styles, either:

use the Pro ject >  Add System  Sty le ... menu item.

press the Add System  Sty le toolbar button.

Read more about system styles and how they can be added to the project.

Dynamic Layers

To add a dynamic layer, select the Dynamic Layers folder in the tree, and either:

use the Edit >  Add Page  Ins ide menu item.

press the Add Page  Ins ide  Se lection toolbar button.

To add a dynamic layer after an existing one, select that dynamic layer and either:

use the Edit >  Add Page  A fte r menu item.

press the Add Page  A fte r Se lection toolbar button.

Widgets

To add a widget, select the Widgets folder in the tree, and either:

use the Edit >  Add Page  Ins ide menu item.

press the Add Page  Ins ide  Se lection toolbar button.

To add a widget after an existing one, select that widget and either:

use the Edit >  Add Page  A fte r menu item.

press the Add Page  A fte r Se lection toolbar button.

Standalones

To add a standalone, select the Standalones folder in the tree, and either:

use the Edit >  Add Page  Ins ide menu item.

press the Add Page  Ins ide  Se lection toolbar button.

To add a standalone after an existing one, select that standalone and either:

use the Edit >  Add Page  A fte r menu item.

press the Add Page  A fte r Se lection toolbar button.

3.2.2.2 Organizing documents

The order and hierarchy of outline items is never final, and documents can be reordered and
reorganized at any time. Documents in the resources tree cannot be moved, as each document is of a
specific type.

Dragging

Reorganizing can most simply be achieved by dragging documents and dropping them in the desired
location. While dragging, a semi-transparent clone of the  document shows where the dragged item will
be dropped.

Dragging will only allow moving documents to a valid location. For example, only test sections are
allowed to be dragged into a test, and only pages can be dragged into test sections.

To create a copy of the dragged document, rather than move it, hold down the Ctrl-key while dragging.



Composica29

©  2010 Com posica  Ltd.

The mouse cursor will show a plus [+] icon signifying that the document will be copied.

Cut and Paste

As an alternative, documents can be moved into or after other items using the Cut and Paste functions,
which are less mouse-oriented:

Cut the document you want to move by either using the Edit >  Cut menu item, or pressing the Cut
toolbar button. To copy a document without moving the original, use the Edit >  Copy menu item or
the Copy toolbar button.

To move it after another item:

Select the item you want to move it after.

Paste by either using the Edit >  Paste  A fte r menu item, or pressing the Paste  A fte r toolbar button.

To move it into another item:

Select the item you want to move it into.

Paste by either using the Edit >  Paste  Ins ide menu item, or pressing the Paste  Ins ide toolbar button.

3.2.2.3 Removing documents

Documents can be removed at any time. Removing a document will delete its contents and its
properties, and cannot be undone.

To remove a document, select it and either:

use the Edit >  Rem ove menu item.

press the Rem ove toolbar button.

After confirming the removal, the document will be removed from the system, and removed from the
tree. Any removed content cannot be recovered.

Removing an item requires  the P rojec t Manager to immediately save any additional changes  done before the removal.

3.2.2.4 Document properties

Each document has several properties which can be configured in the properties area of the Project
Manager, when the document is selected in the tree.

Following is a table of each document type, its properties and their descriptions.

Throughout all properties , a spec ial value of [ Inherit ] means  the property is  inherited from the parent outline item.

Pages

Title Title of the page.

Style The style to use for the page.

Master Layer The master layer to use for the page.

Dynamic Layer The dynamic layer to use for the page.

Skip Page No - The document isn't skipped from navigation, and shown in
menus.
Skip - The document is skipped from navigation, but shown in
menus.
Skip & Hide - The document is skipped from navigation, and
shown in menus.

Persist Activities When on, the state of activities is maintained when navigating
away from the document.

Page Tags Tags associated with the page.

Chapters
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Title Title of the chapter.

Style The style to use for the chapter.

Master Layer The master layer to use for the chapter.

Dynamic Layer The dynamic layer to use for the chapter.

Skip Page No - The document isn't skipped from navigation, and shown in
menus.
Skip - The document is skipped from navigation, but shown in
menus.
Skip & Hide - The document is skipped from navigation, and
shown in menus.

Persist Activities When on, the state of activities is maintained when navigating
away from the document.

Chapter Tags Tags associated with the chapter.

Tests

Title Title of the test.

Style The style to use for the test.

Master Layer The master layer to use for the test.

Dynamic Layer The dynamic layer to use for the test.

Skip Page No - The document isn't skipped from navigation, and shown in
menus.
Skip - The document is skipped from navigation, but shown in
menus.
Skip & Hide - The document is skipped from navigation, and
shown in menus.

Persist Activities When on, the state of activities is maintained when navigating
away from the document.

Test Settings

Test Mode Normal - Use all questions from all test sections.
Global Bank - Use a given number of questions from all test
sections.
Section Bank - Use a given number of questions from each test
section, specified in each test section's properties.

No. of Questions The number of questions to use when Test Mode is set to Global
Bank.

Sections Order Normal - Uses the order of the test sections in the outline to
determine the order of the sections.
Random - Randomizes the order of the test sections.

Questions Order Normal - Uses the order of the questions in the outline to
determine the order of questions.
Random - Randomizes the order of the questions. Test section
pages are always skipped.
Use Section Settings - Use the setting in each test section's
properties to determine the order of the questions.

Score Method Normal - Each section has the same weight on the score.
Use Section Settings - Use the setting in each test section's
properties to determine the score method.

Time Limit Normal - No time limit will be coerced.
Question Time Limit - Each question will be time limited.
Global Time Limit - The entire test is time limited.
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Time The time to limit by, according to Time Limit.

Only available when Time Limit is other than Normal.

Partial Answer Accept - Accept partial answers.
Consider as Full - Accept partial answers, and consider them as
full ones.
Reject - Reject partial answers.

Feedback Mode Delayed Feedback - Feedback is given at the end of the test.
Check buttons are always hidden.
Immediate Feedback - Feedback is given immediately. Check
buttons are available by default.

Pass Score The minimal score required for the test to be considered passed.

Attempts The number of attempts possible for retaking the test.

Allow Review Whether to show the review test link in the test feedback element.

Participate in Global Score Whether the score of the test participates in the global score of the
course.

Test Tags Tags associated with the test.

Test Sections

Title Title of the test section.

Style The style to use for the test section.

Master Layer The master layer to use for the test section.

Dynamic Layer The dynamic layer to use for the test section.

Skip Page No - The document isn't skipped from navigation, and shown in
menus.
Skip - The document is skipped from navigation, but shown in
menus.
Skip & Hide - The document is skipped from navigation, and
shown in menus.

Persist Activities When on, the state of activities is maintained when navigating
away from the page.

Section Settings

Questions Order Normal - Uses the order of the questions in the outline to
determine the order of questions.
Random - Randomizes the order of the questions.

Only available when Questions Order in the test settings is set to
Use section settings.

No. of Questions The number of questions to use from the selected test section.

Only available when Test Mode in the test settings is set to
Section Bank.

Section Type Question Pages - The pages in the section contain questions,
and will be considered for score.
Information Pages - The pages in the section contain
informational material, and will not be considered for score.

Section Weight The weight, in percents, the score of this test section has on the
total score of the test. To help determine the amount, use the 
Va lida te  Sections Score button which shows the weight of each test
section and whether the sum of weights is 100%.

Only available when Score Method in the test settings is set to Use
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section settings.

Section Tags Tags associated with the test section.

Master Layers

Title Title of the master layer.

Description A description of the master layer, for personal usage.

Style The style to use for the master layer. When a master layer is
assigned to an outline element, its style cannot be changed.

Layer Tags Tags associated with the master layer.

Dynamic Layers

Title Title of the dynamic layer.

Description A description of the dynamic layer, for personal usage.

Style The style to use for the dynamic layer.

Layer Position How to position the dynamic layer, relatively to the document. In
design-time, the dynamic layer always shows under the document
layer, regardless of this setting.

Apply Layer to Whether to apply the dynamic layer to Chapter Pages Only, to
Pages Only, or to All documents.

Layer Tags Tags associated with the dynamic layer.

Widgets

Title Title of the widget.

Description A description of the widget, for personal usage.

Widget Tags Tags associated with the widget.

Standalones

Title Title of the standalone.

Description A description of the standalone, for personal usage.

Style The style to use for the standalone.

Master Layer The master layer to use for the standalone.

Dynamic Layer The dynamic layer to use for the standalone.

Standalone Tags Tags associated with the standalone.

3.2.2.5 Importing documents

Documents can be imported from other projects and templates. Importing items copies them into the
current project's tree, at the requested position.

Documents can be either imported:

after the selected item, by either using the Im port > Im port A fte r... menu item or the Im port A fte r
Se lection toolbar button.

inside the selected item, by either using the Im port > Im port Ins ide ... menu item or the Im port Ins ide
Se lection toolbar button.

The import dialog shows a tree of projects and templates available on the system. The search box at the
bottom of the dialog allows to filter projects or documents by tags or by text.
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Expanding each of the projects shows the project's tree, allowing you to select each item you wish to
import. When an item is selected, a snapshot of that document and a preview option are shown on the
right. To import the selected item, press the Im port button.

Several items can be imported at once. When you're done importing, press the C lose button to close the
import dialog, and return to the Project Manager.

3.2.3 PowerPoint import

Composica can import PowerPoint presentations directly into any project. Each slide in the presentation
will be duplicated to a page in the outline, at the position requested. Once imported, the pages (the
PowerPoint slides) are entirely editable and customizable within Composica.

PowerPoint presentations can be either imported:

inside the selected item, by either using the Im port > Im port PowerPo int Ins ide ... menu item or the
Im port PowerPo int Ins ide ... toolbar button.

after the selected item, by either using the Im port > Im port PowerPo int A fte r... menu item or the
Im port PowerPo int A fte r... toolbar button.

Using any of these options, will open the Import PowerPoint Presentation wizard.

Select the source presentation

The first step is selecting the PowerPoint presentation to use as the source for the import. If PowerPoint
files are already in the project's library, they will be shown in the tree, and new ones can be uploaded by
pressing the Upload button. If no PowerPoint files are in the library, Composica will automatically request
you to upload one.

Once you've uploaded and selected the PowerPoint presentation, press Next to continue.

Choose import mode

Choose between importing all slides from the presentation, or selected slides.

Select slides to import

If you've chosen to import selected slides, a list of slide thumbnails will now be presented, showing every
slide of the presentation. You can select/deselect any of the slides by pressing them, or using the
selection buttons at the bottom, marking them for import.

Once you've finished selecting which slides to import, press Next to continue.

Choose slide sizing mode

Choose between importing slides at full size, which maximizes the size of the slide to fit the size of the
document while maintaining proportions, or manually customizing the size position and master layer
settings for the slides.

Choose slide size, position, and Master Layer

If you've chosen to customize slide's size, position and master layer, a sample slide will now be
presented which can be scaled and moved around, like regular Composica elements. On the right, you
can set the slide's default master layer (which will show in the preview box, under the slide, once you
make a selection), and also center the slide horizontally and vertically. On the bottom-right corner of the
slide is an info box showing the current size and position of the slide.

Once you've finished customizing the slide's size, position and master layer, press Next to continue.

Choose the level of image quality

Images in slides can be imported in a variety of quality levels, to best match the target usage in the
slide. The higher the level of quality, the larger the files. If you are not sure, use the default settings,
and just re-import if you are not happy with the quality or file size.

Choose how to handle slide notes and comments

Composica can transform PowerPoint notes and comments into tasks on the relevant pages. Choose
whether you want notes, comments, or both, to be imported as tasks along with the slides. You can also
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choose to mark the tasks generated by the import as done.

Once you've made your choices, press Next to continue.

Finalize the import

Finally, confirm your selections by pressing Finish to close the wizard and import the slides.

3.2.4 Styles

A style is a logic layer determining the basic look of each element in the project. Composica includes
several system styles that can be used within the project. A single project can contain any number of
styles, and different styles can be applied to some or all of the documents in the project.

All of the properties determined by the style can be overridden by a style rule or by changing properties
directly on the element.

Adding a system style

To choose a system style during the creation of a project, select the styled project option and choose
one of the built-in styles.

To add a system style to an existing project, in the Project Manager, use the Pro ject >  Add System
Sty le ... menu item or the Add System  Sty le toolbar button to open the Add System Style dialog, choose a
style and press OK.

Assigning a system style

Each document can have a system style assigned to it, either directly or inherited from its parent. To
assign a style, use the Style setting for any document in the tree.

3.2.5 Groups

Each project can be assigned one or more groups which can view and edit it. Groups can be used to
organize projects between different teams of developers.

To assign groups for the current project:

1.  Open the Groups dialog, by using the Pro ject >  A ssign G roups menu item in the Project Manager, or
by pressing the A ssign G roups button in the Start a New Project wizard.

2.  Check or uncheck the checkbox next to any of the groups, by pressing it. A group which is marked
with a check is a group which can view and edit the project.

3.  Press the OK button to finish.

Groups are maintained by administrators.

3.2.6 Tags

Tags can be assigned to each document in a project (including the project itself and Resources
documents), to assist in organizing different assets, find them quickly and reuse them.

Tagging a document

Tags can be assigned using the Project Manager:

1.  Open the Project Manager using the Pro ject >  Manage  P ro ject... menu item or the Manage  P ro ject
toolbar button.

2.  Select a document.

3.  In the Tags field, add relevant keywords separated by space or a comma.

4.  Press the Tag Co lor button to change the color of any of the used tags.

Alternatively, tags can be assigned to the current document, by using the Docum ent > A ssign Tags menu
item.

Tags  are delimited by spaces , so to c reate multiple word tags  use an underscore or a dash.



Composica35

©  2010 Com posica  Ltd.

Finding tagged projects and documents

A tagged folder is available in the project and document trees in the dashboards, sorting the projects
and documents by tag names allowing to quickly look up a specific tag.

The Composica Dashboard also provides a quick lookup search box for searching for specific tags (or
text).

The project manager provides a tag pane under the tree, allowing to lookup documents by tags.

Searching for tagged documents across all projects is possible using the Docum ent > Find by  Tags...
menu item, or the Find Document button in the Quick Start panel.

Many dialogs give the option to search for projects and/or documents according to tags, including the
Select Project dialog and the Import dialog.

3.2.7 Views

Views allow creating different published configurations of the project, with varying contents and different
run-time behavior. Each view can define which parts of the outline tree participate in it, and can override
any of the run-time properties, allowing to create different configurations of the same project for
different needs.

Managing views

To open the views manager, in the Project Manager, use the Pro ject >  Manage  V iews... menu item or
the Manage  V iews toolbar button, or select the project (root) in the tree and press the Manage  V iews
button.

In the views manager, views can be added, removed, renamed, their trees can be defined, and their
run-time properties edited.

To add a view, press the Add toolbar button, and set the new view's name. To remove a view, select it
and press the Remove toolbar button, or the Del key. To rename a view, select it and press the Renam e
toolbar button or the F2 key, and set the new name.

To select which documents participate in the view, select the view, and using the project tree on the left
check the documents you want to be part of the published course. Unchecked documents will not appear
in the course, won't be part of the navigation, and won't be counted as part of the course's completion
objectives. A document cannot be included if one of it's parent documents are unchecked.

To customize the view's run-time properties, select the view and press the Run-tim e  Prope rtie s toolbar
button. This opens the Run-time Properties dialog, allowing to override any of the default settings as set
in the project settings. Any property which is overridden can be restored to its default value, by pressing
the back  to  de fault link.

Previewing

To preview a view, select it in the views manager and press the Prev iew toolbar button. A project
preview will be shown, showing only the documents included in the selected view, and using the
customized run-time properties as specified.

Alternatively, a view can be previewed while designing a document, using the Project > Preview
Project... menu item. When views are available, the menu item will show a sub-menu including the
available views, and choosing them will show a preview of the selected view.

Publishing

To publish a project using a specific view, use the View selection in the publish dialog. The publish dialog
also provides access to the view manager, by pressing the Manage  V iews icon next to the view selection.

3.3 Mind Games

Games can enhance the learning process by creating a dynamic and interactive experience for learners.
Games employ powerful motivational elements such as competition, humor, and the satisfaction of
winning through applying a skill. Composica Mind Games allow designers to utilize these elements and
create experiences that learners can enjoy and from which they gain knowledge.
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Through games, learners acquire different types of knowledge as each game develops different skills.
The games offer different levels of Playability: Games like Master Plumber or Space Bubbles emphasize
the game part, while Rescue Mission or Game Show put more emphasis on the educational part.

On top of that, the designer has full control over the playability and the educational aspects of the game.
Like all other elements, games are highly customizable, both visually and functionally. By adjusting the
different properties, the designer can dictate the difficulty level of the game (regardless of the level of
questions) as well as the educational level of difficulty and so create the desired balance.

This way, the designer can cater for a wide range of students' needs; a student fluent in the subject
learned should play a game where questions can quickly be answered, where the interaction would be
more beneficial. On the other hand, a less knowledgeable student should play a game designed so all
questions must be answered and so, thoroughly and repeatedly learn the subject.

Adding games
Layers

3.3.1 Adding games

Games can only be added to test documents. Once inserted, they wrap the configuration and
functionality of the test. Test sections and pages should be inserted, configured and designed like any
test. Each page in the test is a question in the game, and can contain any activity or other content. The
elements of an activity inserted in a game will, by default, follow the visual and functional aspects of the
specific game.

To add a game to your project:

1.  Add a test to the outline of the project, to contain the game.

2.  Add test sections and pages to the test, to meet your needs.

3.  Edit the test created in step 1, and open the game picker, using the Inse rt >  Mind G am es > G am e
P icke r... menu item or the G am e P icke r toolbar button.

4.  Select one of the games in the Game Picker dialog, and press OK to add it to the document.

The game inserted is fully functional, using default values for all its different properties. To edit the
different elements of the game, read about game layers. To further customize the game, see the Mind
Games reference.

The game element will maintain its  proportions  when res ized. I t is  important to assure that the Docum ent Size in the Run

T ime P roperties  is  set to follow the same proportions .

3.3.2 Game layers

A game is made up of several layers stacked on top of the game, which are general containers that can
contain any Composica elements. The layers are shown and hidden throughout the game according to
their purpose.

Each layer has a corresponding tab, in the switch-bar at the top of the game. The tabs are only shown
during design time, to assist in designing the game. To edit any of the layers, press its tab.

Inserting elements to a layer

Every element in the game can be customized, and additional elements can be added. To add an
element to one of the layers:

1.  Show the layer you wish to edit, by pressing on its tab.

2.  Select the game's element.

3.  Click inside the element, to enter content editing mode. The active layer will now be edited.

4.  Insert any element by using the Insert menu or the Insert toolbar.

Layers

The following layers are available for all games:

Common
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Includes elements that are common to all the different states in the game. Should contain elements that
should appear all throughout the game, and usually includes the game's main control buttons like He lp,
Mute and Sta rt G am e.

Intro

Displayed as the game loads, until the game starts. Usually contains the welcome message and the
game's objectives and notes.

Game

Shown during the playing stage of the game (from the moment it starts to the moment it ends). Contains
elements relevant to the actual gameplay, such as the G am e T im er and the Score.

Popup

The popup contains the question, which is shown throughout the game whenever needed. The popup tab
toggles the popup layer on top of the active layer.

Win

Shown when the game ends, if the player has won. Usually contains feedback to the player.

Lose

Shown when the game ends, if the player has lost. Usually contains feedback to the player.

Results

Shown on top of the win/lose layer, containing the test feedback element. Only shown if <Show Results>
is true. The results tab toggles the results layer on top of the active layer.

Help

Shown over other layers, when the learner presses the He lp button. Contains a short description of the
game, along with gameplay instructions. The help tab toggles the help layer on top of the active layer.

3.4 Publishing

Publishing the project is the final step of the development process, taking all the different parts of the
project and making it into a working course ready to be taken by learners.

To publish your project, use the Publish button in the Project Dashboard, or the Pro ject >  Publish
Pro ject... menu item to open the Publish Project dialog.

Publish format

Composica provides several different publishing formats:

Web Server - Publishes the project to the web-server on which Composica is installed, providing
with a link to be used by the learners. This option is only viable if the target audience of the course
has access to the web-server.

SCORM 1.2 Content Package - Generates a content package fully compliant with the SCORM 1.2
specification.

SCORM 2004 Content Package - Generates a content package fully compliant with the SCORM
2004 specification.

PDF Document - Creates a static PDF version of the course, which is ideal for print, and can also be
provided as a portable document format.

Zip File - Generates a compressed zip package which can be saved and later deployed anywhere.

Executable Application - Publishes the course as a standalone executable application which can be
executed on Windows platforms.

Installation Package - Creates an installation package, for installing a standalone version of the
course on the desired Windows platforms.

View

Allows publishing only a limited view of the project, which can include only a part of the project's outline
tree, and can also have customized run-time properties. To publish a specific view, select the view. To
edit a view, or create new views, press the Manage  V iews icon. Read more about views.
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Publish options

The available options in the publish dialog depend on the selected publish format.

Basic Student Tracking

While deploying to a SCORM supporting LMS is the recommended manner to track student's performance
on the course, Composica provides with a very simplistic alternative for non-LMS configurations. When
basic student tracking is activated, a password is set to access the tracking results. In the published
course, a link is available on the introduction page which, after entering the password, leads to a
spreadsheet of the recorded data.

Whenever possible, it's recommended to seek out an LMS alternative to basic student tracking, which
provides much deeper and richer information tracking.

LMS Notification - PENS

When publishing as a SCORM 1.2 or SCORM 2004 content package, the PENS option is available. When
activated, the course is deployed to the LMS using the PENS protocol. For the values to enter in the
address, user and password fields, please refer to the user manual of your LMS product.

Customize URL

When publishing to the web server, a custom URL path can be chosen to which the course will be
published. By default, the path is made up of the project's name, and the selected view (if any).

PDF Document

When publishing to a PDF document, several options are available which control the look of the result
PDF:

Convert to greyscale - When checked, the entire course is stripped of colors, and shown in shades
of grey.

Strip images, media and shapes - When checked, all images, media files, and shapes, are
stripped from the course.

Strip text and border colors - When checked, all text and element borders are stripped of color,
and are shown in black.

Strip fill images and colors - When checked, all fill images and fill colors are stripped, and are
shown as transparent.

Show activities in their correct state - When checked, all interactive activities are shown as if
they were answered correctly, rather than showing in their initial unanswered state.

Master Layer - Allows overriding the master layer for the entire course. When set to [ Inherit ],
the predefined master layer settings are maintained. When set to [ None ], no master layer is
shown.

Dynamic Layer - Allows overriding the dynamic layer for the entire course. When set to [ Inherit ],
the  predefined dynamic layer settings are maintained. When set to [ None ], no dynamic layer is
shown.

Compression

When publishing to an executable application, the compression of the executable can be chosen, which is
a balance between the result file size, and the time it takes to open when executing.

3.4.1 Multi-SCO considerations

In Multi-SCO mode, set in the SCORM run-time properties, each page is packaged into a separate SCO,
as opposed to the whole course being maintained in a single SCO.

Why should Multi-SCO be generally avoided?

Choosing to publish as Multi-SCO presents the following limitations in the course, because of the very
nature of how this feature works in LMSs:

Many navigation elements will not work as expected:

Because an SCO cannot directly link to another SCO in SCORM,

navigation buttons to other pages will not be able to function;
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menus will not work properly; and

branching will not be achievable.

Because each document will become a single SCO independent of the others,

breadcrumbs will not show the entire hierarchy; and

the progress bar element will not work properly.

In summary, most of the Inse rt >  Nav iga tion menu will not be of any use.

The course "wrapper" will be stripped out, resulting in slower performance:

Pre-caching of media before a page is reached will not take place since each SCO is autonomous
and has no knowledge of other SCOs.

Master Layers will need to be reloaded from scratch with each navigation (in single SCO mode
Master Layers are not reloaded once they are rendered).

Chapter pages will not be displayed (the chapters will be shown in the course structure, but only as
containers of pages, they will not display their own content page).

Assessments will need to be placed in their own chapters, which are then transformed into a single
SCO. Test Results pages will not work otherwise.

Courses that are designed to operate as Multi-SCO will not be able to run independently (without an
LMS). Multi-SCO courses will typically not have any menus or navigation (since the LMS is responsible
for navigation in Multi-SCO mode), so when attempting to run such courses offline or outside of an
LMS the learner has no way to progress through them.

When creating Multi-SCO courses, what precautions should be taken?

Avoid any of the navigation elements mentioned above.

Avoid having content in chapter pages, always set Skip Page in the chapter properties to Skip.

Place any assessment and its Test Results page inside their own separate chapter. Note that any
chapter that contains a test will be created as one SCO, so other pages in this (sub-)chapter should
generally be avoided.

3.5 Collaborating

Composica puts a high emphasis on collaboration in development. Projects can be developed by teams
of people simultaneously, each author only locking the specific part of the project they're working on.
The different user roles supported by Composica allow different authors to control various aspects of the
project, and each can contribute their knowledge and skills to the finished product. Groups further
enhance the concept of teams, allowing each group member to only see the projects they're involved in.

Beyond being able to work on the project together, Composica offers several unique features to support
collaboration:

The task system helps authors keep track of the work getting done, and the work yet to be done.
Team members can assign other members on tasks and discuss tasks through comments.

The developer blogs provide a common place to share knowledge, and communicate effectively
regarding the project. Each project in Composica gets its own dedicated blog, where information
relevant to the project can be kept integrated in the project.

The chat system gives team members the ability to converse with each other in real-time, right in the
development environment. Several personal or group chats can be maintained in parallel, and
conversations can be saved as an integral part of the project.

The dashboards are central information centers, centralizing application-wide and project-specific
information in one clean and simple interface.

3.5.1 Tasks

Tasks provide a smooth and organized project management methodology. The tasking system of a
project is open to Developers, Contributors and Reviewers with permissions to the project. 

Using Tasks

The Related Tasks dialog shows a document's related tasks, along with their status, assignee, priority,
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tags, comments and system audit trail. It is available from the Project Manager by using the Tasks >
Manage  Tasks... menu item, the Manage  Tasks toolbar button, or the Manage  Tasks... context menu
option. The dialog can be opened for the active document, using the Docum ent > Tasks... menu item or
the Tasks toolbar button.

The number of open tasks is indicated next to the document name in the outline tree of the project pane.
If any of the tasks are assigned to the active user, the number will appear in bold.

All tasks in a project are displayed in the Tasks widget of the Project Dashboard along with their details,
where they can be filtered in various ways. An aggregation of tasks from all available projects is
available in the Tasks widget of the Composica Dashboard.

Users involved in tasks (the opener and the assignee) also receive e-mail notifications for changes being
done, tasks being completed and comments being added.

Adding Tasks

1.  Open the Related Tasks dialog.

2.  Press the Add toolbar button and enter the task description in the Task area.

3.  Use the related fields to assign the task to a team member, set its priority and assign tags to it.

4.  Comments can be added to the task by writing them in the Add Com m ent area and pressing the
Append button to append them to the Com m ents area.

5.  Press OK to commit your changes.

Editing Tasks

1.  Open the Related Tasks dialog.

2.  Select the task from the tasks list and perform the desired changes.

3.  When the task is complete, change its status by checking the Sta tus checkbox, or by pressing the
Mark  C losed toolbar button.

4.  To remove the task, use the Rem ove toolbar button.

5.  The system keeps an audit trail of any committed changes made to the task. To view this trail, check
the System option under the Com m ents area.

6.  Press OK to commit your changes.

Task Reports

Different task reports can be generated for a complete overview of the development process. 

The Task Report dialog is available from using the Tasks > Tasks Report... menu item in the Project
Manager, the Tasks tab in the dashboards and using the Tasks Report button in the Related Tasks
dialog. 

Task reports can be generated for the scope of the project or for all available projects, and the results
can be displayed and filtered in various ways.

3.5.2 Blogs

Each project in Composica has an integral blog, so that developers can freely share information with
each other. By using blogs, development teams can avoid communication bottlenecks and assure that
important correspondence is attached to its related context. 

Starting a blog

When the project is created, a Sta rt P ro ject B log button is displayed in the Recent Blog Posts widget of
the Project Dashboard. Press this button to add the first post  to the project's blog. 

Adding a post

Posts are added using the Add Post button, which opens an editing form with various formatting options.
Once the post is ready, press the Send button to submit it. The post will be displayed in the Recent Blog
Posts widgets of the Project Dashboard and the Composica Dashboard.
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Other team members can now read the post and comment on it. Blog comments are displayed along
their related post, as well as in the Recent Blog Comments widgets of the Project Dashboard and the
Composica Dashboard. 

External access

Each post has a Pe rm a link link, which can be used to view it independently of the project. Additionally,
an RSS link is available from the Blog RSS Feeds widget of the Project Dashboard, allowing team
members to subscribe and keep track of the blog using their favorite feed reader.

3.5.3 Chats

Team members can efficiently communicate with each other in real-time using personal or group chats.

Starting the chat

The chat interface can be accessed using the V iew > Chat menu item, the Chat toolbar button or the chat
icon in the status bar.

Press on any team member under the Online section to initiate a personal chat. Group chats can be
initiated using the Sta rt a  G roup Chat button and then inviting other team members. Developers,
Contributors, Reviewers and Viewers are all included.

Chats can also be saved and function as a 'meeting log', so the information and discussions about the
project becomes an integrated part of it. Press the Save button to title and save the chat. Saved chats
are available from the Saved Chats widgets of the Composica Dashboard and the Project Dashboard,
where searches can be performed to quickly find the required chat.

C hats  remain ac tive even when the chat dialog is  c losed and can be resumed at anytime.

3.5.4 Dashboards

The dashboards provide a centralized information hub, where concurrent information about Composica
and its projects can be found and managed. Composica consists of two dashboards:

Composica Dashboard, which appears after logging in to the application and displays aggregated
information from all projects available to the user. 

Project Dashboard, which appears when accessing a specific project and displays information that is
directly related to the project. 

Both dashboards provide the following utility buttons:

The Dashboard P re fe rences button provides control over the displayed widgets, the header
color of each widget and the number of displayed entries. Press the Rese t button to change
back to the default configuration.

Under the Tasks tab, the Report Options button shows or hides the task report options panel at
the top of the report.

The Re fresh button reloads the dashboard contents so it reflects the most recently updated
information.

The Print button, only available under the Tasks tab, prints a printer friendly version of the
selected task report.

The Export to  Disk button, only available under the Tasks tab, saves a printer friendly version
of the selected task report to disk, in HTML format.

The Logout button, only available under the Composica Dashboard, signs the user out of the
system.

The information presented in the dashboards is divided into tabs: Dashboard, Tasks, Blog and Projects
(in the Project Dashboard Only):

Under the Dashboard tab, the information is organized into widgets. The functionality of most of
widgets is similar in both dashboards; however, some widgets are only available in one of the



Using Composica 42

©  2010 Com posica  Ltd.

dashboards. The arrangement of widgets in the dashboard can always be swapped by simply
dragging widgets to the desired location.

The Tasks tab provides a task report of the current project, or a summary of all projects in the main
dashboard.

The Blog tab provides each project with a developers blog, to help team members freely share
information with each other and discuss development aspects. Under the main dashboard, the Blog
tab provides a summary of all the available developers blogs.

The Projects tab in the Project Dashboard provides a quick method to find and open a different
project, providing a projects tree, a tagged tree for quick tag look-up, and a search box allowing to
filter projects by tags or by text. A quick snapshot of the selected project is shown to the right, along
with basic information about it.

Quick Start

Each dashboard provides a Quick Start panel, providing quick access buttons to common actions.

The following buttons are available from the Composica Dashboard:

Last Project - Launches Composica and opens the last accessed project. This button is only
available if a project has been previously opened.

New Project - Launches Composica and opens the project creation wizard, allowing to create a new
project.

Open Project - Shows the Select Project dialog, allowing to choose a project to launch.

Import - Launches Composica and opens the Import / Export dialog, allowing to import an existing
project to the system.

Getting Started - Launches the Composica help manual to the Getting Started chapter.

Administration - Shows the administration dialog, giving access to different administrator functions,
such as user management, global settings and activation. This button is only available for users with
administrator privileges.

The following buttons are available from the Project Dashboard:

Last Document - Open the last accessed document in the project. This button is only available if a
document has been previously opened.

New Document - Creates a new document. Shows the Save As dialog, to allow choosing a title,
document type, and tree position for the new document.

Open Document - Opens the Select Document dialog, allowing to choose a document to be opened
for design.

Manage - Opens the Project Manager.

Preview - Shows a quick preview of the entire project.

Publish - Opens the Publish dialog.

Import / Export - Opens the Import / Export dialog, allowing to import an existing project to the
system, or export the current project.

New Project - Opens the project creation wizard, allowing to create a new project.

Find Document - Opens the Find Documents by Tags dialog, allowing to find documents by tags
across all projects in the system.

Widgets

The following widgets are available:

News

Tasks

Team Members

Modified Projects

Modified Documents

Recent Blog Posts
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Recent Blog Comments

RSS Feeds

Saved Chats

Recent Publications

Links

My Notes

News

Provides a place to post global notes and administrative messages. These are displayed to all the users
in the environment and are not attached to any specific project. Administrators can add new posts and
edit existing ones. 

Tasks

Composica provides a comprehensive Tasks Management mechanism including task assignment, task
priority, tags, task comments, task mail notification, audit trails, and more.

The Project Dashboard displays tasks from the current project and the Composica Dashboard displays
tasks from all the projects that are available to the user.

Using the Tasks widget the user can filter the relevant tasks in various ways, to plan the work more
efficiently. Press on a task to open the project it's associated with, and the Related Tasks dialog.

Team Members

Users can easily see the current online status of each team member as well as the project/document
they are currently working on, and have immediate access to it.

In the Project Dashboard, pressing on an online user's name will initiate a chat with them.

To update your own status message, press on the Status Message icon in the widget's header, edit your
status, and press Update. 

Modified Projects

Only available in the Composica Dashboard.

Provides a list of recently modified projects, along with the last person who edited them and the
modification time. The project can either be previewed, or opened by pressing on its name.

The Modified Project widget also includes a Tag Cloud. Press any of the tags to filter the list of modified
projects, only showing projects associated with the selected tag.

Modified Documents

Provides a list of recently modified documents, along with the last person who edited them and the
modification time. The document can either be previewed, or opened by pressing on its name.

The Project Dashboard displays recently modified documents from the current project. The Composica
Dashboard displays recently modified documents from all projects available to the user, along with an
option to preview each relevant project.

Recent Blog Posts

In the Project Dashboard, the Recent Blog Posts widget displays blog posts from the current project. In
the Composica Dashboard it displays blog posts from all projects available to the user. 

Press on a post's title to switch to the Blog tab and see a detailed view of that post. To comment about a
post, press the Add Comment button. The Permalink link can be used to access the post from outside the
dashboard.

To go back to the dashboard view, press the Dashboard tab.

Recent Blog Comments

Provides an aggregated view of comments on blog posts.
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Press on a comment's title to switch to the Blog tab and see a detailed view of that comment, along with
its related post. To add another comment to the post, press the Add Comment button. To remove a
comment, use the Remove button. The Permalink link can be used to access the comment from outside
the dashboard.

To go back to the dashboard view, press the Dashboard tab.

RSS Feeds

Developer blogs also offer RSS/Atom feeds, which developers can subscribe to in order to keep track of
the blogs using their favorite feed reader.

In the Project Dashboard, the Blog RSS Feeds widget displays a link to the feed for the current project's
blog. In the Composica Dashboard, a list of all the feeds available to the user is displayed.

Saved Chats

Composica provides real-time chats between two or more users. These chats can be saved as 'meeting
logs' to be later accessed, previewed or removed.

The Project Dashboard displays recently saved chats from the current project, and the Composica
Dashboard displays recently saved chats from the all projects available to the user.

The Saved Chats widget also provides a search functionality to quickly find a chat based on its content.

Recent Publications

Only available in the Project Dashboard.

Lists recent publications of the project, along with the publish method, the publish date and the name of
the author that initiated the publish.

Links

Authors can add common links to the work environment.

Links can either be Public, or Pe rsona l and available only to the user who added them. In the Project
Dashboard, P ro ject links can also be added, associated them to the current project.

Press on the Add Link button in the widget's header to add a new link or the Edit Link button to modify an
existing one.

My Notes

Each user has a personal 'To Do' notes widget. Any text entered in the widget is personal and can only
be viewed by the user, and will remain there until it's removed.
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The Composica user interface is divided into six main sections.

Menus
Toolbars
Properties pane
Project pane
Project Manager
Media Explorer
Sequence Manager
Status bar
Keyboard shortcuts

4.1 Menus

The menu bar is positioned at the top of the user interface. Through the different menus you get access
to most of the possible operations of Composica.

Each page in this chapter denotes a menu. In each page you will find a description of the menu, and a
list of all the menu's items, along with a description of each. If a menu item has an equivalent toolbar
button, an icon next to the item will link to that toolbar's help page.

Document
Project
Edit
View
Insert
Modify
Format
Layout
Tools
Help
Context menu
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4.1.1 Document

The document menu provides document level operations.

New Creates a new document.

Open... Opens the Select Document dialog, allowing you to open
outline items, master layers, menus, widgets or pop-ups.

Close Closes the current document, and returns to the Project
Dashboard.

Save Saves the current document, or if it's a new document, opens
the Save As dialog.

Save As... Opens the Save As dialog, allowing you to save the current
document as any document type.

Preview Document... Previews the current document. Even when previewing the
current document, the entire project is available for
navigation.

Assign Tags... Opens the Assign Document Tags dialog, allowing you to
assign tags to the current document.

Find By Tags... Opens the Find Documents dialog, allowing you to find
documents by tags in the current and other projects.

Open Next Opens the next item in the outline tree.

Open Previous Opens the previous item in the outline tree.

Tasks... Opens the Related Tasks dialog, allowing you to manage
tasks for the current document.

Recent Documents Opens a list of recently opened documents, available for
quick access.

Exit Closes Composica.

4.1.2 Project

The project menu provides project level operations.

Manage Project... Opens the Project Manager, allowing you to manage different
aspects of the project.

Preview Project... Previews the current project, as it will be shown when
published.

Open Project... Opens the Select Project dialog, allowing you to open a
different project, or create a new one.

New Project... Opens the Start a New Project dialog, allowing you to create
a new project.

Project Dashboard Shows or hides the Project Dashboard, containing various
project related widgets.

Tasks Report... Opens a task report for the current project, listing all/open/
closed tasks, and a summary of all tasks.

Import / Export... Opens the Import / Export dialog, allowing you to export the
current project into a special Composica recognized file
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format "cpa", or import a previously exported project back
into Composica.

Publish Project... Opens the Publish Project dialog, allowing you to publish the
current project in different formats.

Recent Projects Shows a list of recently opened projects, available for quick
access.

4.1.3 Edit

The edit menu provides different tools for editing the current document.

Undo Reverts the last change to the document.

Redo Restores the last change reverted by undo.

Cut Copies the current selection to the clipboard, and removes it
from the document.

Copy Copies the current selection to the clipboard.

Paste Pastes the contents of the clipboard along with formatting and
styles at the caret's position. Allows you to copy content and
elements from other documents or from programs such as
Microsoft Word.

Paste as Text Pastes the contents of the clipboard at the caret's position, as
plain text.

Find... Opens the find dialog, allowing you to search for text in the
current document.

Replace... Opens the replace dialog, allowing you to search and replace
text in the current dialog.

Remove Removes the selected element or text.

Duplicate Duplicates the selected element.

Erase Content Clears the content of the selected element.

Select Gives options to select elements relative to the selected
element, such as the parent, sibling, child and all.

Select Ancestor Shows a list of all ancestors of the selected element, allowing
to select them.

Drag Select Toggles drag select mode, allowing you to drag and select
several elements with a single mouse click.

Lock Group Locks an element so you can no longer edit its content and
children, or locks several elements together in a group.

Unlock Group Unlocks a previously locked element or group.

Add Design Hint Adds a design hint to the current document, allowing you to
maintain comments which aren't shown when previewing or
publishing the project.
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4.1.4 View

The view menu provides options for changing the look and feel of Composica.

Design Mode Switches to design mode, allowing you to edit your document
visually in a WYSIWYG manner.

HTML Mode Switches to HTML mode, allowing you to directly edit the
source code of the document. This is not recom m ended for
intermediate developers.

Chat Opens the chat widget, listing all the users in your groups,
showing their online status, and allowing you to chat with one
or more of them.

Editor Background A list of available backgrounds for the editing area.

Toolbars Shows a list of all available toolbars, allowing you to toggle
their visibility. Additionally, allows you to choose between
showing no labels next to icons, showing labels to the right of
selected icons, and showing labels under all icons.

Layers Allows you to show, hide and edit the document's master
layer and dynamic layer.

Navigator Gives an option to show (a small or large) navigator, which
provides quick navigation to elements relative to the selected
element, such as parent, sibling and child.

Elements Tree Gives options related to the Elements Tree, including the
options to hide/show the selected element, to expand/
collapse the entire tree, and other options.

Helpers Allows toggling several helpers on/off, including the selection
prediction highlighting, the move/resize guidelines, and the
positioning handle.

Show Properties Pane Toggles the visibility of the Properties pane.

Show Project Pane Toggles the visibility of the Project pane.

Show Status Bar Toggles the visibility of the Status bar.

Float Properties Pane Toggles the Properties pane between floating and docked
modes.

Float Project Pane Toggles the Project pane between floating and docked
modes.

Basic Properties Switches to basic properties mode, showing only the basic
and most common properties in the property grid.

Normal Properties Switches to normal properties mode, showing most of the
properties in the property grid.

Advanced Properties Switches to advanced properties mode, showing all of the
available properties in the property grid.

4.1.5 Insert

The insert menu allows you to insert different elements to the current document. To insert an element,
simply choose it from the menu, and it will be inserted.

The following elements can be inserted from the insert menu:
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Box

Text Elements

Image

Link

List

Table

Frame

Media Player

Flash Animation

Shape

Narration

Variable

Social Media

Mashups

Navigation

Test Feedback

User Identification

Multiple Choice

Point Click

Drag Drop

Fill Blank

Hot Spots

Hot Word

Survey
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Mind Games

4.1.6 Modify

The modify menu provides different operations you can apply to the selected element. Different options
are available, according to the element which is currently selected.

Link

Unlink Cancels the link. Available only when a link is selected.

List

Toggle List Cancels the list.

Add List Item Adds a list item below the current one.

Indent List Item Increases indentation of the current list item.

Outdent List Item Decreases indentation of the current list item.

Table

Add Row Adds a row below the current one.

Add Column Adds a column after the current one.

Remove Row Removes the current row.

Remove Column Removes the current column.

Add Topmost Row Adds a row at the top of the table.

Add Leftmost Column Adds a column at the left of the table.

Table Cell

Add Row Below Adds a row below the current cell.

Add Column After Adds a column after the current cell.

Remove Current Row Removes the current row.

Remove Current Column Removes the current column.

Merge Rows Merges the current row with the one below it.
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Merge Cells Merges the current cell with the one after it.

Split Row Splits the current cell, horizontally.

Split Cell Splits the current cell, vertically.

Test Feedback

Add Test Summary Adds a test summary item, showing information about the
entire test.

Add Test Sections Summary Adds a sections summary item, listing information about each
section.

Add Test Details Adds a test details item, showing the result of each question.

Add Custom Feedback Adds a custom test feedback item, showing custom feedback
on a certain pre-set condition.

Add Test Results Adds a test results item, showing the title and final score of
the test.

Add Passed Feedback Adds a test passed item, showing the passing score. Only
shown when test is passed.

Add Failed Feedback Adds a test failed item, showing the passing score. Only
shown when the test is failed.

Add Review Button Adds a review test item, allowing the viewer to review the
test.

Add Retake Button Adds a retake test item, allowing the viewer to retake the
test.

Feedback

Move Up Moves the selected feedback item up.

Move Down Moves the selected feedback item down.

Add Custom Feedback Adds a custom feedback item, shown when a specified
condition is met.

Add Range Feedback Adds a range feedback item, shown when the number of
correct answers is in a specified range.

Add Right Feedback Adds a right feedback item, shown when the answer is
correct.

Add Wrong Feedback Adds a wrong feedback item, shown when the answer is
incorrect.

Add Partial Feedback Adds a partial feedback item, shown when the answer is
partially correct.

Add Final Feedback Adds a final feedback item, shown after the last attempt.

Add Close Button Adds a close button, hides the feedback.

Add Try Again Button Adds a try again button.
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Add Show Correction Button Adds a show correction button, shown after the last attempt.

Add Check Button Adds a check button, if one doesn't already exist.

Multiple Choice

Add Answer Adds an additional answer. To remove answers, simply
remove them.

Add Hint Adds a hint element.

Drag Drop

Add Drag Drop Pair Adds an additional drag drop pair of drag item and drop area.

Add Drag Item To Pair Adds a drag item to the group of the selected item.

Add Drop Area To Pair Adds a drop area to the group of the selected item

Add Dummy Drag Item Adds a dummy drag item, which isn't taken into consideration
in the score calculation for the activity.. 

Add Dummy Drop Area Adds a dummy drop area, which isn't taken into consideration
in the score calculation for the activity..

Add Hint Adds a hint element.

Fill Blank

Add Writeable Blank Adds a writable blank which can be filled by the viewer.

Add Selectable Blank Adds a selectable blank with options the viewer can choose
from.

Add Option Adds an option to the selected blank.

Add Range Option Adds a range option to the selected blank.

Add Mask Option Adds a mask (wildcard) option to the selected blank.

Add Hint Adds a hint element.

Hot Spots

Design-Time View Sets how hot popups are shown in design-time.
Show Contextual Popups - Only shows hot popups when
they are in context (when their related hot spot is actively
selected).
Show All Popups - Shows all hot popups at all times.

Add Hot Spot Pair Adds an additional hot spot pair of hot spot and hot popup.
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Add Hot Spot To Pair Adds a hot spot to the group of the selected item.

Add Hot Popup To Pair Adds a hot popup to the group of the selected item.

Hot Popup

Add Hot Popup Close Button Adds a hot popup close button to the hot popup element.

Survey

Add Rating Item Adds a rating item, allowing takers to rate a question.

Add Open Text Item Adds an open text item, allowing takers to freely write about
a question.

Add Send Button Adds a send button for submitting the survey.

Add Final Message Adds a final message clause to the survey.

Survey Item

Move Item Up Moves a survey item up in the survey element.

Move Item Down Moves a survey item down in the survey element.

Media Player

Add Stage Adds a stage to the player.

Add Controls Adds a control set to the player.

Add Play Button Adds a play button to the player.

Add Progress Slider Adds a progress slider, showing the current playing position,
to the player.

Add Status Adds an information bar to the player.

Add Volume Slider Adds a volume slider to the player.

Add Mute Adds a mute button to the player.

Add Separator Adds a separator to the player.

Blog

Add Blog Home Button Adds a blog home button, for returning to the main blog
screen.
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Add Add Post Button Adds an add post button for adding posts to the blog.

Add Edit Post Button Adds an edit post button for editing posts on the blog.

Add Remove Post Button Adds a remove post button for removing posts from the blog.

Add Subscribe Link Adds an RSS/Atom subscription link to the blog.

Add Recent Posts Widget Adds a recent posts widget, listing all the recent posts.

Add Recent Comments
Widget

Adds a recent comments widget, listing all the recent
comments.

Add Archive Widget Adds an archive widget, listing all the posts on the blog by
their dates.

Add Categories Widget Adds a categories widget, listing all the different tags
associated with posts.

Add Tag Cloud Widget Adds a tag cloud widget, graphically showing tags and their
usage in the blog.

Add Top Rated Widget Adds a top rated widget, listing the highest rated posts.

Blog Post

Add Rating Adds a rating element to the post, enabling to rate each
specific post.

Blog Widgets

Move Widget Up Moves a blog widget up in the widget container.

Move Widget Down Moves a blog widget down in the widget container.

Universal Search

Add Search Engine Adds an additional search engine option the the universal
search element.

Google Chart

Add Dataset Adds a dataset to the Google chart, duplicating the existing
dataset.

Add Default Dataset Adds a default dataset to the Google chart.

Add Data Point Adds a data point to the Google chart.

4.1.7 Format

The format menu allows you to control the formatting and style of different elements. Each of the
operations are applied to the selected element, or to selected text in the document.
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Create Style Rule... Creates a style rule from the style of the selected element,
as either a class or an element style rule.

Style Rule Provides quick access to apply a style rule to the selected
element, as an alternative to the <Style Rule> property.

Flip Horizontally Horizontally flips the selected element and its children. Can
also flip images, if requested.

Bold Toggles the bold status of the selected element/text.

Italic Toggles the italic status of the selected element/text.

Underline Toggles the underline status of the selected element/text.

Border Style Sets the border style of the selected element.

Border Width Sets the border width of the selected element.

Font Family Sets the font family of the selected element/text.

Font Size Sets the font size of the selected element/text.

Text Align Sets the text alignment of the selected element/text.

Writing Direction Sets the writing direction of the selected element.

Order Sets the depths (z-index) of the selected elements.

Center in Parent Centers the selected element, either vertically, horizontally,
or both, within its parent element.

Fit Fits the size and position of the selected element to its parent
element, or of the parent element to the selected element.

4.1.8 Layout

The layout menu provides several operations for controlling the layout of multiple elements. The menu is
only available when multiple items are selected.

Align Aligns the selected elements according to the actively
selected element, either vertically or horizontally.

Distribute Evenly distributes the selected elements' positions, either
vertically or horizontally, according to the two outmost
elements. Similar to space, but doesn't take the elements
sizes into account.

Space Evenly spaces the selected elements, either vertically or
horizontally, according to the two outmost elements. Similar
to distribute, but takes the elements sizes into account
keeping the spaces between them equal.

Fit Size Fits the size of all elements to the actively selected element.
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4.1.9 Tools

The tools menu provides miscellaneous useful tools.

Apply Widget... Opens the Select Document dialog, allowing you to select a
widget to apply in the current document.

Media Explorer Opens the Media Explorer.

Upload... Opens the multiple file upload dialog, allowing you to upload
resources to your project.

Sequence Manager... Opens the Sequence Manager. If elements are selected, they
are the elements which will take part in the sequence.

Spell Check... Checks spelling on the entire document. If errors are found,
a dialog with suggestions is shown, allowing you to correct
the error. After finishing, the status bar shows how many
errors were found, and how many words were altered.

Change Password... Opens the change password dialog, allowing you to change
your Composica password.

4.1.10Help

The help menu provides with helpful and informative options.

Content and Index Opens the Composica help manual.

Getting Started Opens the Composica getting started manual.

Keyboard Map Shows a list of available keyboard shortcuts.

Send Feedback

About Composica Opens the about dialog.

4.1.11Context menu

The context menu appears when right-clicking on elements or on the document. The context menu
allows for quick access to different options which are also available via the main menu. The options in
the context menu are context sensitive, and only the relevant ones show according to the current
selection.

Select Ancestor Shows a list of all ancestors of the selected element, allowing
to select them.

Select Gives options to select elements relative to the selected
element, such as the parent, sibling, child and all. See Edit >
Se lect.

Insert A clone of the Insert menu.

Modify A clone of the Modify menu.

Format A clone of the Format menu.
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Layout A clone of the Layout menu.

Lock Group Locks an element so you can no longer edit its content and
children, or locks several elements together in a group.

Unlock Group Unlocks a previously locked element or group.

Hide Element Temporarily hides an element, for the purpose of designing
only. Hiding doesn't affect the actual document, and is only
effective while editing.

Show Element Shows a previously hidden element.

Cut Copies the current selection to the clipboard, and removes it
from the document.

Copy Copies the current selection to the clipboard.

Paste Pastes the contents of the clipboard along with formatting and
styles at the caret's position. Allows you to copy content and
elements from other documents or from programs such as
Microsoft Word.

Paste as Text Pastes the contents of the clipboard at the caret's position, as
plain text.

Remove Removes the selected element or text.

4.2 Toolbars

The toolbars are positioned at the top of the user interface, below the menu, and allow quick access to
the most useful menu items. You can customize the toolbars appearance and choose which toolbars to
display through the V iew > Too lbars menu.

Each page in this chapter denotes a toolbar. In each page you will find a screenshot of the toolbar, and a
list of all the toolbar's buttons, along with the icon and a description of each. The icon links each toolbar
button to its equivalent menu item.

Document
Edit
Group
Insert
Format
Layout
Table
Tools

4.2.1 Document

New Document Creates a new document.

Open Document Opens the Select Document dialog, allowing you to open
outline items, master layers, menus, widgets or pop-ups.

Save Document Saves the current document, or if it's a new document, opens
the Save As dialog.

Preview Document Previews the current document. Even when previewing the
current document, the entire project is available for
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navigation.

Project Dashboard Shows or hides the Project Dashboard, containing various
project related widgets.

Manage Project Opens the Project Manager, allowing you to manage different
aspects of the project.

Tasks Opens the Related Tasks dialog, allowing you to manage
tasks for the current document.

Tags Opens the Assign Document Tags dialog, allowing you to
assign tags to the current document.

Chat Opens the chat widget, listing all the users in your groups,
showing their online status, and allowing you to chat with one
or more of them.

4.2.2 Edit

Layers Allows you to show, hide and edit the document's master
layer and dynamic layer.

Cut Copies the current selection to the clipboard, and removes it
from the document.

Copy Copies the current selection to the clipboard.

Paste Pastes the contents of the clipboard along with formatting and
styles at the caret's position. Allows you to copy content and
elements from other documents or from programs such as
Microsoft Word.

Paste as Text Pastes the contents of the clipboard at the caret's position, as
plain text.

Erase Content Clears the content of the selected element.

Remove Removes the selected element or text.

Drag Select Toggles drag select mode, allowing you to drag and select
several elements with a single mouse click.

Select Parent Selects the direct parent of the selected element.

Undo Reverts the last change to the document.

Redo Restores the last change reverted by undo.

Find Opens the find dialog, allowing you to search for text in the
current document.

4.2.3 Group

Lock Group Locks an element so you can no longer edit its content and
children.

Unlock Group Unlocks a previously locked element.
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4.2.4 Insert

Each button of the insert toolbar allows you to insert an element at the caret's position, identically to the 
Insert menu.

The following elements can be inserted from the insert toolbar:

Text Elements

Insert Box

Insert Image

Insert Table

Media Player

Shape

Navigation

Insert Multiple Choice

Insert Drag Drop

Insert Fill Blank

Insert Hot Spots

Game Picker

4.2.5 Format

Bold Toggles the bold status of the selected element/text.

Italic Toggles the italic status of the selected element/text.

Underline Toggles the underline status of the selected element/text.

Insert Link Inserts a link element, or converts the selected text to one.

Insert List Inserts a list element, or converts the selected text to one.

Insert Hot Word Inserts a hot word element, or converts the selected text to
one.

Color Sets the text color of the selected element/text. Remembers
the last used color.

Fill Color Sets the background color of the selected element/text.
Remembers the last used color.

Border Color Sets the border color of the selected element. Remembers
the last used color.

Border Style Sets the border style of the selected element.

Border Width Sets the border width of the selected element.

Font Family Sets the font family of the selected element/text.

Font Size Sets the font size of the selected element/text.
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Text Align Sets the text alignment of the selected element/text.

Writing Direction Sets the writing direction of the selected element.

Order Sets the depths (z-index) of the selected elements.

Center in Parent Centers the selected element, either vertically, horizontally,
or both, within its parent element.

Create Style Rule... Creates a style rule from the style of the selected element,
as either a class or an element style rule.

Style Rule Provides quick access to apply a style rule to the selected
element, as an alternative to the <Style Rule> property.

4.2.6 Layout

Align Aligns the selected elements according to the actively
selected element, either vertically or horizontally.

Distribute Evenly distributes the selected elements, either vertically or
horizontally, according to the two outmost elements.

Fit Size Fits the size of all elements to the actively selected element.

The layout toolbar is  only ac tive when multiple elements  are selec ted.

4.2.7 Table

Add Row Adds a row below the current one.

Add Column Adds a column after the current one.

Remove Row Removes the current row.

Remove Column Removes the current column.

Merge Rows Merges the current row with the one below it.

Merge Cells Merges the current cell with the one after it.

Split Row Splits the current cell, horizontally.

Split Cell Splits the current cell, vertically.

4.2.8 Tools

Spell Check Checks spelling on the entire document. If errors are found,
a dialog with suggestions is opened, allowing you to correct
the error. After finishing, the status bar shows how many
errors were found, and how many words were altered.

Sequence Manager Opens the Sequence Manager. If elements are selected, they
are the elements which will take part in the sequence.

Upload Multiple Files Opens the multiple file upload dialog, allowing you to upload
resources to your project.
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Media Explorer Opens the Media Explorer.

Apply Widgets Opens the Select Document dialog, allowing you to select a
widget to apply in the current document.

Help Opens the Composica help manual.

4.3 Properties pane

The properties pane allows you to modify different
properties for elements in your project. The properties pane updates according to your current selection,
and shows the real-time state of your elements.

The properties pane consists of several tabs, and the properties grid. The tabs separate properties to 4
categories:

Text, listing all the properties related to the text of the element and it's presentation.

Layout, listing all the properties related to the element's layout and visual appearance.

Style, listing all properties related to the styling of the element.

Settings, listing miscellaneous element-specific settings.

Properties grid

The properties grid lists all the properties of the selected tab, and their current values, accordingly. The
available properties can change from element to element. The properties list is divided into collapsible
sub-categories.

To change a property, select it on the grid, and click its value. Each property type has a different editor,
allowing you to enter or select values which are appropriate for that property. Changes are displayed in
real-time, so you can instantly see their effect.

In the Text and Layout tabs, an additional column is shown, containing specifity markers. When a
property has a small circle set in the specifity column, it signifies that the property has been explicitly set
on that element. When a property is explicitly set on an element, it overrides any settings inherited from
its parents, the system style or any style rules. Pressing the marker will remove the property from the
element, allowing it to regain its default or inherited value.

When a property is  removed by press ing the marker, it cannot be res tored by press ing it again. To res tore it, you must

manually set it to the des ired value again.
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Filtering properties

All properties available in Composica are divided to 3 levels: basic, normal, and advanced. You can
choose to filter the properties you see to one of the levels, according to your level of expertise and
personal preference.

To switch between the different modes, use one of the three menu items: V iew > Basic P rope rtie s, V iew
> Norm a l P rope rtie s, V iew > Advanced P rope rtie s.

Throughout the elements  reference advanced properties  are marked by a darker background color.

Floating the pane

To float the pane, either use the V iew > Floa t P rope rtie s Pane menu item, or drag the pane by its caption
from its default position. Once floating, you can drag the pane around and position it as you wish.

To dock the pane, either toggle the V iew > Floa t P rope rtie s Pane menu item off, or drag the pane back
to its docked position.

4.4 Project pane

The project pane allows you to overview three aspects of
your project: the project tree, the media tree, and the elements tree

Project tree

The project tree is similar to the one in the Project Manager. The tree includes the entire outline tree, the
resource documents, a recent tree of recently opened documents, and a tagged tree aggregating
documents by their tags for quick lookup.

The currently open document is marked in bold in the list. Next to each document's title, a number
shows the number of currently open tasks on the document. If the number is bold, some of these tasks
are assigned to the active user.

To open a document from the tree for editing, double-click it or right-click it and use the Open Docum ent
menu item. To preview a document, right-click it and use the Prev iew Docum ent... menu item.

Widgets can also be quickly applied from the tree, by right-clicking and using the Apply  W idge t menu
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item.

Media tree

The media library tree, identical to the one in the Media Explorer, lists all the available media files for the
current project.

The tree is divided into two main categories:

 Project, which holds the uploaded media files for the currently open project.

 Public, which is a public media repository available to all projects, divided into different sections.

All the media files are separated according to their types: Im ages, Anim ations, Mov ies, Sounds, and Misc
.

To insert a media file, double-click on it, and it will be inserted to the active document.

Elements tree

The collapsible elements tree shows all the elements in the document, in a hierarchical format, making it
easier to understand the structure of the documents, to find elements in it, and to keep control of the
document.

Elements can be selected by pressing them in the tree, and multiple elements can be selected by holding
down the Shift or Ctrl keys. The show/hide eye icon can be used to temporarily hide elements, to make
complex documents less cluttered and more manageable, without affecting the actual document. The 
context menu can also be used by right-clicking elements in the tree.

Some relatively positioned elements can be rearranged by dragging them around in the tree: feedback
sub-elements, test feedback sub-elements, survey items, and blog widgets.

Additional options related to the elements tree are available from the V iew > Elem ents Tree menu:

The entire tree can be expanded/collapsed using the V iew > Elem ents Tree  > Expand A ll and the
V iew > Elem ents Tree  > Co llapse  A ll menu items.

All elements in the document can be shown/hidden using the V iew > Elem ents Tree  > Show A ll and
the V iew > Elem ents Tree  > Hide  A ll menu items.

When the V iew > Elem ents Tree  > Auto-Co llapse  Tree option is checked, the tree is automatically
collapsed to only show the selected element.

When the V iew > Elem ents Tree  > Sta rt as Co llapsed option is checked, the tree starts off as
collapsed. This option is only available if auto-collapsing is turned off.

Floating the pane

To float the pane, either use the V iew > Floa t P rope rtie s Pane menu item, or drag the pane by its caption
from its default position. Once floating, you can drag the pane around and position it as you wish.

To dock the pane, either toggle the V iew > Floa t P rope rtie s Pane menu item off, or drag the pane back
to its docked position.

4.5 Select Project

The Select Project dialog lets you choose a project to open, from any project in the system you have
access to.

The Select Project dialog can be opened by using the Open Project button in the Quick Start panel of the 
Composica Dashboard, or the Pro ject >  Open Pro ject... menu item. The Select Project functionality is
also available from the Projects tab in the Project Dashboard.

The projects in the tree are divided by the following, for easy access:

Recent - Lists the recently accessed projects.

Tagged - Lists each tag, and the projects associated with that tag.

All - Lists all projects, divided by:

Type - Either Projects or Templates.
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Group - Lists each user group, and the projects associated with that group.

Owner - Lists each user, and the projects they own.

Filter

The Look  fo r input at the bottom of the dialog allows to search for projects by text or tags:

Enter the desired text in the input; or

Enter the desired tags in the input, separated by space or commas; or

Press the the arrow to open the Filter by Tags dialog, where tags can be selected from a list or from a
tag cloud.

Press the Find button to commit the search.

Search results will be shown in the projects tree.

4.6 Select Document

The select document dialog is used in various situations where a document needs to be selected, such as
when opening a document, or by certain properties which point to documents within the course, such as
the Navigation Button <Navigate To> property.

Tree

The tree shows all documents in the project, along with a tagged tree aggregating the available
documents by tags for quick access. In some usage scenarios, only documents of specific types will be
available in the tree, as appropriate.

Preview

On the right-hand side of the dialog, a snapshot preview of the selected document is shown, unless the
Show Snapshot checkbox is unchecked. The Preview link can be used to open a live preview of the
selected document.
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4.7 Project Manager

The Project Manager allows you to manage different aspects of your project including its outline and
resources and its properties. Any changes made in the Project Manager are not effective until saved.

Menu

The main menu is divided into four menus:

Project, listing project-wide options.

Edit, listing operations relevant to the tree.

Import, listing import related operations.

Tasks, listing task related operations.

Toolbar

The toolbar offers quick access to most of the operations available from the main menu.

Tree

The tree allows you to overview two aspects of your project:
Outline, listing all the outline items in your project.
Resources, listing all the resource documents used in your project.

Items in the tree can be easily dragged and dropped in order to be rearranged and reorganized.

Tags

The tags pane gives quick access to documents by their tags. All tags can be browsed through by
pressing the A ll button, and one or more tags can be searched for using the Tags input and pressing the
Find button. Selecting an item in the tagged tree selects the equivalent item in the project tree. The tags
pane can be expanded and collapsed according to need, by resizing it, or collapsed completely using the
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X button on the upper-right corner of the tagged tree.

Properties

The properties section allows you to view and change the properties available for the selected item in the
tree. Each item may have different properties available. Read more about specific project properties and
document properties.

4.7.1 Menu

Project

Run-time Properties... Opens the Run-time Properties dialog, allowing you to
customize the appearance and behavior of the course in run-
time.

Manage Views... Opens the views management dialog, allowing you to create
and manage the project's views.

Edit Metadata... Opens the Metadata Editor dialog, allowing you to configure
various project metadata.

Add System Style... Opens the Add System Style dialog, allowing you to select
one of the system styles listed, so it will be available to the
project and can be assigned to any of the documents.

Save Project Saves the current state of the project.

Assign Groups... Opens the Groups dialog, allowing you to assign groups of
users which can view and edit the project.

Outline Report... Generates an outline report, listing the outline tree, starting
from the currently selected document. In the outline report,
press the Up button to move to the parent node's outline
report.

Remove Project... Removes the project from the system. Once the removal is
confirmed, the project will be removed completely, and
cannot be recovered.

Close Closes the Project Manager.

Edit

Design Document Closes the Project Manager, and opens the selected
document for edit.

Preview Document Previews the selected document.

Add Page After Adds a page after the selected document.

Add Page Inside Adds a page inside the selected document.

Add Chapter After Adds a chapter after the selected document.

Add Chapter Inside Adds a chapter inside the selected document.

Add Test After Adds a test after the selected document.

Add Test Inside Adds a test inside the selected document.
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Add Test Section After Adds a test section after the selected document.

Add Test Section Inside Adds a test section inside the selected document.

Cut Copies the selected document to the clipboard, and removes
it from the tree.

Copy Copies the selected document to the clipboard.

Paste After Pastes the document from clipboard after the selected
document.

Paste Inside Pastes the document from clipboard inside the selected
document.

Remove Removes the selected document.

Import

Import After... Opens the Import dialog, allowing you to import documents
from other projects after the selected document.

Import Inside... Opens the Import dialog, allowing you to import documents
from other projects inside the selected document.

Import PowerPoint After... Opens the Import PowerPoint Presentation dialog, allowing
you to import a PowerPoint presentation after the selected
document.

Import PowerPoint Inside... Opens the Import PowerPoint Presentation dialog, allowing
you to import a PowerPoint presentation inside the selected
document.

Import Style Rules... Opens the Import Style Rules dialog, allowing you to import
class and element-type style rules from a different project.

Tasks

Manage Tasks... Opens the Related Tasks dialog, allowing you add and
manage tasks for the selected document.

Task Reports... Opens task reports for the selected document (and its
descendants), listing and summarizing the tasks.

4.7.2 Toolbar

Save Project Saves the current state of the project.

Design Document Closes the Project Manager, and opens the selected
document for edit.

Preview Document Previews the selected document.

Add Page After Adds a page after the selected document.

Add Page Inside Adds a page inside the selected document.

Add Chapter After Adds a chapter after the selected document.

Add Chapter Inside Adds a chapter inside the selected document.

Add Test After Adds a test after the selected document.
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Add Test Inside Adds a test inside the selected document.

Add Test Section After Adds a test section after the selected document.

Add Test Section Inside Adds a test section inside the selected document.

Design Document Closes the Project Manager, and opens the selected
document for edit.

Cut Copies the selected document to the clipboard, and removes
it from the tree.

Copy Copies the selected document to the clipboard.

Paste After Pastes the document from clipboard after the selected
document.

Paste Inside Pastes the document from clipboard inside the selected
document.

Remove Removes the selected document.

Import After... Opens the Import dialog, allowing you to import documents
from other projects after the selected document.

Import Inside... Opens the Import dialog, allowing you to import documents
from other projects inside the selected document.

Import PowerPoint After... Opens the Import PowerPoint Presentation dialog, allowing
you to import a PowerPoint presentation after the selected
document.

Import PowerPoint Inside... Opens the Import PowerPoint Presentation dialog, allowing
you to import a PowerPoint presentation inside the selected
document.

Add System Style... Opens the Add System Style dialog, allowing you to select
one of the system styles listed, so it will be available to the
project and can be assigned to any of the documents.

Run-time Properties... Opens the Run-time Properties dialog, allowing you to
customize the appearance and behavior of the course in run-
time.

Manage Views... Opens the views management dialog, allowing you to create
and manage the project's views.

Manage Tasks Opens the Related Tasks dialog, allowing you add and
manage tasks for the selected document.

Task Reports... Opens task reports for the selected document (and its
descendants), listing and summarizing the tasks.



User Interface 70

©  2010 Com posica  Ltd.

4.8 Media Explorer

The media explorer allows you to manage, preview, and select media files from the project library, the
public library, or other projects' media repository.

Toolbar

The toolbar provides options to upload media to your project, record audio, refresh the media tree,
remove uploaded files, download files from the library, and toggle the preview, thumbnails and find by
tags view.

Tree

The media library tree lists all the available media for the current project.

The tree is divided into three main categories:

Project, which holds the uploaded media files for the currently open project.

Public, which is a public media repository available to all projects, divided into different sections.

Other Projects, which gives access to the media libraries of any other project the developer has
access to.

All the media files are separated according to their types: Im ages, Anim ations, Mov ies, Sounds, and Misc
.

Tags

Tags can be assigned to media files, in order to assist in organizing the media files and finding them
quickly.

To assign tags to a media file, enter the desired tags, separated by space or comma, in the Tags input in
the preview pane. To set the colors of the assigned tags, press the Tag Co lor button to the side of the
input.
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To search for media files associated with one or more tags:

Enter the desired tags in the Tags input, separated by space or commas; or

Press the the arrow to open the Filter by Tags dialog, where tags can be selected from a list or from a
tag cloud.

Press the Find button to commit the search.

Search results will be shown in the media tree.

Preview

The preview pane shows a preview of the selected media file, along with information about it such as
type, size, and dimensions.

Thumbnails

The thumbnails pane shows a tiled thumbnails layout, giving a quick view through the media files in the
current folder. The zoom in/out buttons can be used to change the zoom level of the thumbnails display.

Tagging

Each media file in the Media Explorer can have one or more tags assigned to it in its Tags field, to assist
in organizing different media files, find them quickly and reuse them when necessary.

4.8.1 Toolbar

Upload Media Files Opens the Upload dialog, allowing you to select multiple files
and upload them to the central media library.

Record Audio Opens the Audio Record dialog, allowing you to record audio
files straight inside Composica.

Refresh Media Files Refreshes the selected media folder.

Remove Media Files Removes the selected media item from the Projects folder.
After confirming the removal, the item will be removed from
the system, and cannot be recovered.

Download Media Files Allows downloading media files from the Media Explorer and
storing them locally.

Toggle Preview Pane Toggles the visibility of the preview pane.

Toggle Thumbnails Toggles the visibility of the thumbnails pane.

Find by Tags Toggles the visibility of the find by tags pane.
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4.9 Sequence Manager

The sequence manager allows you to manage and configure effects and narration for your documents
and elements. Several features may not be available in all modes. For information about the associated
element, see the Sequence Manager element page.

Main

In the main tab, you can configure different properties for the sequence manager, control the type,
speed, duration, and other properties of the sequence. Some effect types have additional properties
which become available when selected.

You can preview the current configuration by pressing on the preview area at the bottom.

Elements

When available, the elements tab allows you to specify attributes for each element. When set to inherit,
the elements use the values configured in the main tab. It also enables you to change the order of
appearance for the elements, when <Order> is custom.

4.10 Status bar

The status bar shows useful information about the current Composica activity.

Status

Shows the current activity status. Says "Ready" when Composica is ready for user interaction.

Project

Shows the name of the active project.
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Document

Shows the name of the active document. The left and right pointing arrows allow moving to the next and
previous documents.

Element

Shows the name of the currently selected element.

Upload

Shows an icon when an upload is in progress, and the upload progress popup has been closed. Press the
icon to show the upload progress popup.

Group Lock

Shows a lock icon when the currently selected item is grouped.

Tags

Shows an icon when the current document has tags associated with it. Put the mouse over the icon to
see the tags, and press it to edit or assign new tags.

Chat

Provides quick access to the chat interface. The icon will flash when there's incoming chat activity. To
open the chat, press on the icon.

Tasks

Shows an icon when the current document has open tasks. Put the mouse over the icon to see task
information, and press it to open the Related Tasks dialog.

Mode

Shows the current editing mode (Design or HTML).

4.11 Keyboard shortcuts

Most frequently used operations in Composica have keyboard shortcuts. To see an updated list of
shortcuts, use the He lp > Keyboard Map menu item.

Document

New Ctrl+N

Open... Ctrl+O

Save Ctrl+S

Preview Document... F9

Close Alt+X

Project

Manage Project... F4

Preview Project... F8

Open Project... Ctrl+Alt+O

Edit

Undo Ctrl+Z

Redo Ctrl+Y

Cut Ctrl+X
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Copy Ctrl+C

Paste Ctrl+V

Paste Special Ctrl+Alt+V

Erase Content Ctrl+E

Duplicate Ctrl+D

Remove Del

Drag Select Alt+Drag

Select Parent Ctrl+W

Select All Ctrl+A

Find... Ctrl+F

Replace... Ctrl+H

View

Design Mode Ctrl+Alt+E

HTML Mode Ctrl+Alt+T

Show Properties Pane Alt+O

Show Project Pane Alt+R

Insert

Header 1 Ctrl+Alt+H

Image Ctrl+M

Link Ctrl+K

Table Ctrl+T

Hot Word Ctrl+Alt+W

Modify

Toggle List Ctrl+L

Add Row Ctrl+Alt+R

Add Column Ctrl+Alt+C

Format

Bold Ctrl+B

Italic Ctrl+I

Underline Ctrl+U

Tools

Apply Widget... Alt+W

Media Explorer... F6

Upload... Ctrl+Alt+U

Spell Check... F7
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Help

Content and Index F1
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The following element reference lists each element available in Composica, its description, its usage, and
its available properties. If an element consists of other sub-element, those are listed along with their
respective properties.

Each list of properties is divided to sections matching the tabs and sub-categories of the property grid,
and the name, type, and description for each property is listed. Rows marked with a darker background
color are advanced properties.

Property types

Common properties
Text
Layout
Style
Settings

Basic
Box
Text Elements
Link
List
Table
Frame

Media
Image
Media Player
Flash Animation

Shape
Social Media

Blog
Widgets

Comments
Rating
Sign In

Mashups
YouTube Movie
Universal Search
Twitter Tweets
Facebook Like Button
Google Chart
Google Map Chart

Navigation
Project Title
Document Title
Navigation Button
Navigation Link
Popup Button
Breadcrumbs
Progress Bar
Navigation Locator
Timer
Tree Menu
Compact Tree Menu
One-Level Menu

Activities
Multiple Choice
Point Click
Drag Drop
Hot Spots
Fill Blank
Hot Word
Survey
Feedback
Hint

Other
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Variable
Test Feedback
User Identification
Narration
Sequence Manager

Mind Games
Master Plumber
Space Bubbles
High Hops
Rescue Mission
Game Show

5.1 Property types

Listed along each property in the element reference is the property's type. Following is a list of the
possible property types and their descriptions:

Number Shows a number spin, allowing you to enter a number.

Unit Shows a number spin, and a unit selection spin.

Point Shows a pair of number spins, allowing you to enter a point on two axes.

Text Shows an input, allowing you to enter text.

Select Shows a list of options, which you can select one from.

Color Shows a color picker, allowing you to select a color, or transparent where
applicable.

Media Opens the Media Explorer, allowing you to select a media file.

Style Rule Opens the style rules dialog, allowing you to select a style rule.

Resource Opens the Select Document dialog, allowing you to select a resource.

Condition Opens the feedback conditions dialog, allowing to design a certain condition
combination.

String List Opens a dialog containing a list of strings, which can be edited and localized.

YouTube Opens the YouTube movie selection dialog, allowing to search for and select a
YouTube movie.

5.2 Common properties

Most of the properties in Composica are common to all elements. These properties are listed in the
following pages, divided according to the tabs of the property grid.

Text
Layout
Style
Settings

5.2.1 Text

Basic

Font

Font Select Text's font name. Can also be set via the Font
Fam ily toolbar button.

Size Unit Text's font size. Can also be set via the Font
Size toolbar button.
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Color Color Text color. Can also be set via the Co lor
toolbar button.

Bold Select When on, shows text in bold. Can also be set
via the Bo ld toolbar button.

Italic Select When on, shows text in ita lics. Can also be set
via the Ita lic toolbar button.

Decoration Select none - No text decoration.
underline - Text is underlined. Can also be set
via the Underline toolbar button.
overline - Text has a line over it.
line-through - Text has a line going through
it.

Spacing and Alignment

Text Align Select left - Text is aligned to the left.
right - Text is aligned to the right.
center - Text is centered.
justify - Text is justified.
Can also be set via the Tex t A lign toolbar
button.

Letter Spacing Unit Spacing between letters.

Normal

Font

Small Caps Select When on, shows text in small capital letters

Transform Select none - No text transformation.
capitalize - First letter of each word is
capitalized.
uppercase - Text is transformed to
uppercase.
lowercase - Text is transformed to lowercase.

Spacing and Alignment

Line Height Unit Distance between lines.

Text Indent Unit Indentation of the first line of text.

Text Autospace Select Autospacing and narrow space width
adjustment of text.
none - No extra space is added.
ideograph-alpha - Extra spacing between
runs of ideographic and non-ideographic text.
ideograph-numeric - Extra spacing between
runs of ideographic text and numeric
characters.
ideograph-parenthesis - Extra spacing
between a normal (non-wide) parenthesis and
an ideograph.
ideograph-space - Extends the width of the
space character when it is adjacent to
ideographs.

Wrapping and Direction

Word Wrap Select normal - Content exceeds the boundaries of
its container.
break-word - Content wraps to next line, and
a word-break occurs when necessary.

Text Overflow Select ellipsis - Display ellipsis (...) for overflowing
text.
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clip - Clip overflowing text.

Advanced

Spacing and Alignment

Text Justify Select auto - Automatically determine justification
algorithm.
distribute - Similar to newspaper, optimized
for Asian languages, such as Thai.
distribute-all-lines - Similar to distribute,
but also justifies the last line of the paragraph.
Optimized for ideographic text.
inter-cluster - Justifies lines of text that
contain no inter-word spacing. Optimized for
Asian languages.
inter-ideograph - Justifies lines of
ideographic text, and increases or decreases
both inter-ideograph and inter-word spacing.
inter-word - Aligns text by increasing spacing
between words, in each line but the last.
kashida - Justifies lines of text by elongating
characters at chosen points. Optimized for
Arabic script languages.
newspaper - Increases or decreases the
spacing between letters and between words.

Wrapping and Direction

Word Break Select normal - Allows line breaking within words.
break-all - Behaves the same as normal for
Asian text, yet allows the line to break
arbitrarily for non-Asian text. Optimized for
Asian text containing excerpts of non-Asian
text.
keep-all - Behaves the same way as normal
for all non-Asian languages. Optimized for text
that includes small amounts of Chinese,
Japanese, or Korean.

White Space Select normal - Lines of text break automatically.
Content wraps to the next line if it exceeds the
width of the object.
nowrap - Line breaks are suppressed. Content
does not wrap to the next line.

Unicode Bidi Select normal - Element does not open an additional
level of embedding. For inline elements, implicit
reordering works across element boundaries.
embed - Element opens an additional level of
embedding. Reordering is implicit inside the
element.
bidi-override - Same as the embed, but this
value overrides the implicit bidirectional
algorithm.

Writing Mode Select lr-tb - Text flows horizontally - from left to
right, top to bottom. Used in Roman-based
typography.
tb-rl - Text flows vertically - from top to
bottom, right to left. Non-wide-cell glyphs are
rotated 90-degrees clockwise. Used in East
Asian typography.
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5.2.2 Layout

Basic

Size and Position

Width Unit Width of the element.

Height Unit Height of the element.

Top Unit Offset from the top, according to <Position>.

Left Unit Offset from the left, according to <Position>.

Bottom Unit Offset from the bottom, according to
<Position>.

Right Unit Offset from the right, according to <Position>.

Position Select static - Element has no special position, it
follows the flow of its parent's content.
absolute - Element is positioned relatively to
its parent element.
relative - Element is positioned relatively to its
position in the flow of its parent's content.

Fill

Color Color Color to use as the background of the
element. Can also be set via the Fill Co lo r
toolbar button.

Image Media Image to use as the background of the
element.

Borders

Style Select none - No border is shown.
dotted - Border is a dotted line.
dashed - Border is a dashed line.
solid - Border is a solid line.
double - Border is a double solid line.
groove - 3d groove, in colors based on
<Border Color>.
ridge - 3d ridge, in colors based on <Border
Color>.
inset - 3d inset, in colors based on <Border
Color>.
outset - 3d outset, in colors based on <Border
Color>.
Can also be set via the Borde r Sty le toolbar
button.

Width Unit Thickness of the border. Only relevant when
<Border Style> is other than none. Can also
be set via the Borde r W idth toolbar button.

Color Color Border color. Can also be set via the Borde r
Co lor toolbar button.

Normal

Fill

Repeat Select repeat - <Fill Image> is tiled horizontally and
vertically, to fit the element's size.
no-repeat - <Fill Image> is not tiled.
repeat-x - <Fill Image> is tiled horizontally, to
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fit the element's width.
repeat-y -<Fill Image> is tiled vertically, to fit
the element's height.

Image Align X Select left - Align <Fill Image> to the left of the
element.
center - Align <Fill Image> to the center of
the element, horizontally.
right - Align <Fill Image> to the right of the
element.

Image Align Y Select top - Align <Fill Image> to the top of the
element.
center - Align <Fill Image> to the center of
the element, vertically.
bottom -Align <Fill Image> to the bottom of
the element.

Padding and Margin

Padding Unit Padding of the element, between its edges and
its contents.

Margin Unit Margin of the element from the content
surrounding it.

Overflow and Scroll

Vertical Overflow Select visible - Content exceeding the height of the
element is not clipped, and  a vertical scroll bar
is not added.
scroll - A vertical scroll bar is added, and
content exceeding the height of the element is
clipped.
hidden - Content exceeding the height of the
element is clipped, and a  vertical scroll bar is
not added.
auto - Content exceeding the height of the
element is clipped, and a  vertical scroll bar is
added when necessary.

Horizontal Overflow Select visible - Content exceeding the width of the
element is not clipped, and  a horizontal scroll
bar is not added.
scroll - A horizontal scroll bar is added, and
content exceeding the width of the element is
clipped.
hidden - Content exceeding the width of the
element is clipped, and a horizontal scroll bar is
not added.
auto - Content exceeding the width of the
element is clipped, and a horizontal scroll bar is
added when necessary.

Visibility and Z-Order

Visibility Select inherit - Element inherits its visibility from it's
parent element.
visible - Element is visible.
hidden - Element is invisible.

Z Index Number A number indicating the element's position in
the stacking order. An element with a higher
number is displayed above an element with a
lower number.

Float

Float Select none - Element is displayed in it's position in
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its parent's content flow.
left - Content of the parent element flows to
the left of the element.
right - Content of the parent element flows to
the right of the element.

Misc

Direction Select ltr - Content flows from left to right.
rtl - Content flows from right to left.
Can also be set via the  W riting Direction
toolbar button.

Mouse Cursor Select all-scroll - Arrows pointing up, down, left, and
right with a dot in the middle, indicating that the
page can be scrolled in any direction.
auto - Automatically determine which cursor to
display based on the current context.
col-resize - Arrows pointing left and right with
a vertical bar separating them, indicating an
item/column can be resized horizontally.
crosshair - A cross-hair.
default - The default system cursor.
hand - Hand with the first finger pointing up,
indicating pressing the element will result in an
action.
help - Arrow with question mark, indicating
help is available.
move - Crossed arrows, indicating the element
is to be moved.
no-drop - Hand with a small circle with a line
through it, indicating that the dragged item
cannot be dropped over the element.
not-allowed - Circle with a line through it,
indicating an action is not allowed.
pointer - Identical to hand.
progress - Arrow with an hourglass next to it,
indicating that a process is running in the
background.
row-resize - Arrows pointing up and down
with a horizontal bar separating them,
indicating an item/row can be resized vertically.
text - A vertical I-bar, indicating the text is
editable.
vertical-text - A horizontal I-bar, indicating
the text is editable.
wait - An hourglass, indicating a process is
currently running.
N-resize - North pointing arrow, indicating an
item can be resized.
NE-resize - North-east pointing arrow,
indicating an item can be resized.
NW-resize - North-west pointing arrow,
indicating an item can be resized.
S-resize - South pointing arrow, indicating an
item can be resized.
SE-resize - South-east pointing arrow,
indicating an item can be resized.
SW-resize - South-west pointing arrow,
indicating an item can be resized.
E-resize - East pointing arrow, indicating an
item can be resized.
W-resize - West pointing arrow, indicating an
item can be resized.
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Advanced

Fill

Image Position X Unit Horizontal position of <Fill / Image>, according
to <Fill / Image Align X>.

Image Position Y Unit Vertical position of <Fill / Image>, according to
<Fill / Image Align Y>.

Borders

Top Style Select Same as <Border Style>, affecting only the top
section of the border.

Top Width Unit Thickness of the top section of the border. Only
relevant when <Border Top Style> is other
than none.

Top Color Color Color of the top section of the border.

Right Style Select Same as <Border Style>, affecting only the
right section of the border.

Right Width Unit Thickness of the right section of the border.
Only relevant when <Border Right Style> is
other than none.

Right Color Color Color of the right section of the border.

Bottom Style Select Same as <Border Style>, affecting only the
bottom section of the border.

Bottom Width Unit Thickness of the bottom section of the border.
Only relevant when <Border Bottom Style> is
other than none.

Bottom Color Color Color of the bottom section of the border.

Left Style Select Same as <Border Style>, affecting only the left
section of the border.

Left Width Unit Thickness of the left section of the border. Only
relevant when <Border Left Style> is other
than none.

Left Color Color Color of the left section of the border.

Padding and Margin

Padding Top Unit Padding of the element, between its top edge
and its contents.

Padding Right Unit Padding of the element, between its right edge
and its contents.

Padding Bottom Unit Padding of the element, between its bottom
edge and its contents.

Padding Left Unit Padding of the element, between its left edge
and its contents.

Margin Top Unit Margin of the element from the content to the
top of it.

Margin Right Unit Margin of the element from the content to the
right of it.

Margin Bottom Unit Margin of the element from the content to the
bottom of it.

Margin Left Unit Margin of the element from the content to the
left of it.
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Overflow and Scroll

Scrollbar 3d Light Color Color Color of the top and left edges of the scroll
box, and scroll arrows of the scroll bar.

Scrollbar Arrow Color Color Color of the arrows of the scroll bar.

Scrollbar Base Color Color Base color of the scroll bar.

Scrollbar Dark Shadow Color Color Color of the bottom and right edges of the
scroll box, and scroll arrows of the scroll bar.

Scrollbar Face Color Color Face color of the scroll bar.

Scrollbar Highlight Color Color Highlight color of the scroll bar.

Scrollbar Shadow Color Color Shadow color of the scroll bar.

Float

Line Alignment Select top - Vertically aligns text lines to the top.
bottom - Vertically aligns text lines to the
bottom.

Clear Select none - Element can be displayed alongside
floating content.
left - Element is moved below any floating
content on its left.
right - Element is moved below any floating
content on its right.
both - Element is moved below any floating
content.

Misc

Page Break After (Print) Select always - In print, always insert a page break
after an element.
auto - In print, automatically determine
whether to insert a page break after an
element.

Page Break Before (Print) Select always - In print, always insert a page break
before an element.
auto - In print, automatically determine
whether to insert a page break  before an
element.

Display Select block - Element is rendered as a block
element.
none - Element is not rendered.
inline - Element is rendered as an inline
element.

5.2.3 Style

Basic

Style Rules

Style Rule Style Rule Style rule to apply to the element.

C ommon elements  might also have s tyle properties  which relate to effec ts  and narration. For more information, see the 

Sequence Manager element.
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5.2.4 Settings

Basic

Misc

Tooltip Text Advisory information to show when the mouse
is over the element.

Normal

Misc

Name Text A name associated with the element, to be
displayed in the elements tree, for easier
recognition. Only meaningful in design time.

Advanced

Misc

Tab Index Number Index of the element in the tabbing order. A
negative value omits the element from the
tabbing order.

Hide Focus Select When off, focus is visibly indicated by a dotted
rectangle around the element. Otherwise focus
is not visibly indicated.

5.3 Basic

Basic elements are the simplest and most generic elements in Composica, which are likely to be used in
any document. These elements have little to no functionality, and can be fitted to many uses.

Box
Text Elements
Link
List
Table
Frame

5.3.1 Box

Box elements are generic elements, with no specific purpose. A box can contain any content or
elements, and can be used for laying out text or as a design building block.

To insert a box element, use the Inse rt >  Box menu item, or press the Inse rt Box toolbar button.

Style

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the button.

Settings

Link

Link To Text A URL to open when pressing the box.

Window Name Text The name of the window to open the <Link To>
URL in. If no window name is given, the URL
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will be opened in a new window. Only relevant
when a URL is set.

5.3.2 Text Elements

Text elements are generic elements, and their visual appearance is defined by the document's style.

Each text element type can be customized by creating a style rule for that element. To learn more, see
style rules.

To insert a text element, use one of the Inse rt >  Tex t Elem ents menu items or the Tex t Elem ents toolbar
button:

Tex t

Header 1 - Large header

Header 2 - Medium header

Header 3 - Small header

Subscript

Superscript

Foote r 1 - Large footer

Foote r 2 - Small footer

Instructions

Com m ent

Quote

Horizonta l Separa tor

Ve rtica l Separa tor

Marquee

Marquee

Marquees are special text elements, used to create scrolling text, and exhibit additional properties.

Settings

Marquee

Behavior Select scroll - Text scrolls in from one end and out of
the other.
alternate - Text scrolls from one end to the
other, and reverses when reaching the end.
slide - Text scrolls in from one end and stops
when reaching the other.

Loop Select Number of times to repeat the scroll before
stopping. infinitely never stops repeating.

Direction Select The direction the text scrolls in.

Step Size Number The size of each step of the scroll, in pixels.

Step Delay Number The delay between each step of the scroll, in
milliseconds.

When <Behavior> is  slide, setting <Loop> to inf initely will not repeat the sc roll, and will only s lide the text once into

pos ition.
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5.3.3 Link

Links are inline elements which allow linking external URL's to open when the link is pressed. To change
an existing link's text, edit its content.

To convert a piece of text to a hyperlink, select a segment of text, and use the Inse rt >  Link menu item,
or press the Inse rt Link toolbar button. Inserting a link without selecting a segment of text will append a
link at the current position.

Settings

Link

URL Text A URL to open when pressing the link.

Window Name Text A target window name to open the link in. If no
name given, the link will open in a new window.

5.3.4 List

Lists display lines of text as list items with a marker next to each.

To convert existing text to a list, select one or more lines of text, and use the Inse rt >  List menu item, or
press the Inse rt List toolbar button. To add an empty list, use the Inse rt >  List menu item or press the
Inse rt List toolbar button without any selection.

To convert a list back to lines of text, select it and use the Modify  > Toggle  List menu item. To add a list
item to a list, select it and use the Modify  > Add List Item menu item.

Style

List

List Style Type Select The marker type to appear next to each list
item.

List Style Image Text

List Style Position Select outside - Marker is placed outside the text,
and wrapped text is aligned after the marker.
inside - Marker is placed inside the text, and
wrapped text is aligned under the marker.

List Item

Each list item of the list is a list item element. 

To indent a list item, select it and use the Modify  > Indent List Item menu item. To outdent a list item,
select it and use the Modify  > Outdent List Item menu item.

5.3.5 Table

Tables are used to represent tabular data in a document.

To insert a table element, use the Inse rt >  Table menu item, or press the Inse rt Table toolbar button.

For table manipulation, see the Modify  > Table menu items, the Modify  > Table  Ce ll menu items, and the
Table toolbar.

Style

Table
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Outline Depth Number Thickness of the table's outline, in pixels.

Cell Spacing Number Spacing, in pixels, to apply between each cell
of the table.

Cell Padding Number Padding, in pixels, to apply to each cell of the
table.

Border Collapse Select separate - Adjacent borders are separated.
collapse - Adjacent borders are collapsed to a
single border.

Table Layout Select auto - Column width is automatically
determined by the widest unbreakable content
in the column's cells.
fixed - Column widths are fixed, according to
specifically set widths, or by equally diving the
table width between columns.

Table Cell

Each cell of the table is a table cell element.

Style

Table Cell

Vertical Align Select Vertical alignment of the contents of the table
cell.

Settings

Accessibility

Scope Select col - Current cell provides header information
for its column.
row - Current cell provides header information
for its row.
colgroup - Header cell provides header
information for its column group.
rowgroup - Header cell provides header
information for its row group.

5.3.6 Frame

Frames are be used for embedding other web pages in a document.

To insert a frame element, use the Inse rt >  Fram e menu item.

Style

Frame

Scrolling Select auto - Automatically determine when to show
scrollbars based on the size of the content.
no - Never show scrollbars.
yes - Always show scrollbars.

Settings

Source
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Source Text The URL of the webpage to show in the frame.

Frame

Window Name Text Name of the frame, as can be used in links
<Window Name> to force links to target the
frame.

5.4 Media

Media elements are used to enrich documents. All of the available media types are managed through
the Media Explorer, and can all be added and embedded in the document directly from it.

 To learn more about adding media elements, read about adding media.

Image
Media Player
Flash Animation

5.4.1 Image

Image elements are used to embed graphics in a document.

To insert an image element, use the Inse rt >  Im age menu item, or press the Inse rt Im age toolbar
button. To learn more about adding images, read about adding media.

Style

Misc

Image Interpolation Select normal - Regular resizing algorithm.
bicubic - Uses high-quality bicubic image
resampling, making images resize much more
smoothly. Only  effects Internet Explorer 7 and
higher.

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the image.

Settings

Source

Source Media Image file to use as the source for the image
element.

Link

Link To Text A URL to open when pressing the image
element.

Window Name Text The name of the window to open the <Link To>
URL in. If no window name is given, the URL
will be opened in a new window. Only relevant
when a URL is set.

Accessibility

Alternate Text Text Alternative text for viewers who cannot view
the image.
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5.4.2 Media Player

Media player elements are used to embed video or audio clips in a document.

To insert a media player element, use one of the Inse rt >  Media  P laye r menu items or the Media  P laye r
toolbar button. A media player can either be inserted using the current style, which generally matches
the color theme of the document's style, or the default style which is more generic and fits most styles.
Like any other element, the media player can be completely customized after its added to the document.
To learn more about inserting media elements, read about adding media.

Style

Player

Controls Select Provides several preset layouts for the player.

Settings

Source

Source Media Video or audio file to use as the source for the
media element.

YouTube YouTube A YouTube movie to display in the standard
media player.

Media

Auto Start Select When on, automatically starts the media when
entering the page.

Volume Number Determines the volume of the audio/video
element, with 100 being full volume, and 0
being muted.

Mute Select When on, the media player starts as muted.

Window Mode Select windowed - Video is opaque overlays all
contents in the document.
opaque - Video is opaque, but can be
overlayed by other elements in the document.
transparent - Video can contain alpha
transparency, and can be overlayed by other
elements in the document. Transparency only
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works with certain video types.

Player

Visibility Select inherit - Media player inherits its visibility from
it's parent element.
visible - Media player is visible.
hidden - Media player is invisible.

Allow Seek Select When off, seeking in the audio/video is not
allowed and the media will be played from start
to finish.

Context Menu Select When on, right-clicking on the media player
shows the media player context menu.

Navigation

Lock Next Navigation Select When on, prevents from navigating to the next
page before the media finished playing.

5.4.3 Flash Animation

Flash media elements are used to Adobe (Macromedia) Flash animations in a document.

To insert a flash animation element, use the Inse rt >  Flash Anim ation menu item. To learn more about
inserting media elements, read about adding media.

Settings

Source

Source Media Flash animation file to use as the source for the
media element.

Flash Animation

Loop Select When on, the flash animation loops indefinitely
when reaching its end.

Context Menu Select When on, right-clicking on the flash animation
shows an extended flash player context menu.

Quality Select The quality of the flash animation. A lower
quality could result in better performance, but
also in degraded visual appearance.

Transparency Select opaque - Blank sections of the flash animation
are opaque, and content cannot be seen
through.
transparent - Blank sections of the flash
animation are transparent, and any content
underneath them is shown through.

5.5 Shape

Shape elements are used to embed vector graphics in a document.

To insert a shape element, use any shape type from the Inse rt >  Shape menu or the Shape toolbar
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button. Shapes can be quickly rotated by pressing and  dragging the rotation handle which appears when
the shape is selected.

Style

Shape and Rotation

Shape Select The type of the shape. One of the following: 
rectangle, oval, polygon, star, rectangle
callout, oval callout, line, arrow, diamond,
trapezoid, parallelogram, cross.

Rotation Number Angle of the shape's rotation, in degrees.
Shapes can also be quickly rotated using the
rotation handle.

Rotation Scaling Select normal - When resizing while rotated, shape
maintains its original aspect ratio.
stretch to fit - When resizing while rotated,
shape is stretched to fit.

Fill

Type Select none - No fill, the shape's background is
transparent.
solid - Solid fill, in a single color determined by
<Fill / Color>.
linear - A linear gradient, between <Fill /
Color> and <Gradient Color>.
radial - A radial gradient, between <Fill /
Color> and <Gradient Color>.

Color Color Primary color to use for the fill.

Opacity Number Opacity level (0-100) of the fill.

Gradient Color Color Secondary color to use in a gradient fill. Only
relevant when <Fill / Type> is linear or radial
.

Gradient Angle Number Angle for a gradient fill, in degrees. Only
relevant when <Fill / Type> is linear.

Gradient Opacity Number Opacity level (0-100) of the gradient fill.

Stroke

Type Select none - No stroke.
solid - A solid stroke outlining the shape.
dashed - A dashed stroke, alternating between
solid and none.

Color Color Color to use for the stroke.

Width Number Thickness of the outline stroke.

Dash Spacing Number The spacing between stroke dashes. Only
relevant when <Stroke / Type> is dashed.

Dash Width Number The width of stroke dashes. Only relevant when
<Stroke / Type> is dashed.

Shadow

Enabled Select When on, shows a drop shadow underneath the
shape.

Color Color Color to use for the drop shadow.

Opacity Number Opacity level (0-100) of the drop shadow.
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Offset X Unit Horizontal displacement of the drop shadow
from the shape.

Offset Y Unit Vertical displacement of the drop shadow from
the shape.

Rectangle

Rectangle shapes have additional properties.

Style

Shape and Rotation

Corner Radius Number The radius to round corners by. 0 means
corners are not rounded.

Polygon

Polygon shapes have additional properties.

Style

Shape and Rotation

Points Number The number of corners in the polygon.
Minimum of 3.

Corner Radius Number The radius to round corners by. 0 means
corners are not rounded.

Star

Star shapes have additional properties.

Style

Shape and Rotation

Inner Radius The radius of the inner points.

Points Number The number of spokes in the star. Minimum of 
2.

Corner Radius Number The radius to round corners by. 0 means
corners are not rounded.

Rectangle Callout

Rectangle callout shapes have additional properties.

Style

Shape and Rotation

Corner Radius Number The radius to round corners by. 0 means
corners are not rounded.

Callout

Orientation Select The direction of the callout tail. Either bottom
left, bottom right, top right, or top left.

Tail Style Number One of several (1-4) types of tails.

Oval Callout

Rectangle callout shapes have additional properties.
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Style

Callout

Orientation Select The direction of the callout tail. Either bottom
left, bottom right, top right, or top left.

Tail Style Number One of several (1-12) types of tails.

Line and Arrow

Line and arrow shapes have additional properties.

Style

Shape and Rotation

Corner Radius Number The radius to round corners by. 0 means
corners are not rounded.

Arrows

Arrow Head Select head - Show an arrow head at one end of the
arrow.
end - Show an arrow head at the other end of
the arrow.
both - Show an arrow head at both ends of the
arrow.
none - Don't show an arrow head.

Head Shape Number The shape of the arrow head (-100 to 100).

Head Size Number The size of the arrow head.

Body Size Number Size of the body of the arrow, as a portion (0-
100) of the available space.

Diamond

Diamond shapes have additional properties.

Style

Shape and Rotation

Corner Radius Number The radius to round corners by. 0 means
corners are not rounded.

Trapezoid

Trapezoid shapes have additional properties.

Style

Shape and Rotation

Corner Radius Number The radius to round corners by. 0 means
corners are not rounded.

Base Size Number The size of the trapezoid base, as a portion (0-
100) of the available space.

Parallelogram

Parallelogram shapes have additional properties.
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Style

Shape and Rotation

Corner Radius Number The radius to round corners by. 0 means
corners are not rounded.

Tilt Number The amount of tilt of the parallelogram's bases,
as a portion (0-100) of the available space.

Cross

Cross shapes have additional properties.

Style

Shape and Rotation

Corner Radius Number The radius to round corners by. 0 means
corners are not rounded.

Body Size Number The size of the cross body, as a portion (0-100
) of the available space.

5.6 Social Media

Social media elements allow the author to develop a community around the course, and make the
learners involved in the contents of the course. To learn more about adding social media to the course,
read about adding social media.

Blog
Comments
Rating
Sign In

5.6.1 Blog

Blogs are flexible platforms which let the learners participate in the content of the course.

Blogs created in Composica are highly configurable and customizable, and can be designed to present
the information in various ways. For of this flexibility, blogs consist of a wide variety of sub-elements,
each being open to reconfiguration and redesign.

Blogs can be divided into two main sections: the widgets area, normally the left column; and the content
area. Blog widgets are covered separately on this page. The main blog consists of a blog navigation
element, post elements, a blog comments element, comment post elements and a comment form
element.

To insert a blog element, use the Inse rt >  Socia l Media  > B log menu item.

Settings

Blog

External Feed Text External RSS/Atom feed to use for the blog's
content, instead of creating an original blog.
When an external feed is provided, the blog
operates in read-only mode, and new posts
cannot be made.

Summary Word Count Number Number of words to show in a post's summary,
or all to show entire posts in the summary.
When posts are trimmed, they are also stripped
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of any formatting, images and embedded
content.

Footer Notice Text A customizable line of text which is shown at
the bottom of the external blog.

Hide from Search Engines Select When on, the blog is hidden from search engine
spiders, and is not indexed.

Misc

Date Format Select Date format to use when showing post dates,
where yyyy signifies year, mm signifies
month, dd signifies day of the month, hh
signifies hours, nn signifies minutes and ss
signifies seconds.

Comments

The comments element is a special case of a blog, slimmed down and simplified, for allowing learners to
quickly add comments on a document. It consists of several post elements and an add post button
element.

To insert a comments element, use the Inse rt >  Socia l Media  > Com m ents menu item.

Blog Navigation

Provides controls for navigation through the blog. Consists of two sub-elements, for moving back and
forward through the posts. When viewing a single post, the labels of these sub-elements will be replaced
with the titles of the next and previous posts.

Settings

Blog

Posts per Page Number Number of posts to show in each page of the
summary, or all to show all posts in one page.

Post

Displays a single blog post. In run-time, the post element is duplicated for each post displayed, and filled
in with information and content from the post. A post consists of several variables for displaying this
information, a post ellipsis element and a permalink.

A rating element can be added to a post, to allow learner's to rate any of the posts, using the Modify >
Add Rating menu item

Post Ellipsis

Used in the post summary, when a post's contents have been trimmed, to signify the post contains more
information. In run-time, pressing the post ellipsis shows the full post.

The post ellipsis element can be edited to contain different text (or any other content), and its looks can
be customized.

Blog Comments

Provides the ability to read and post comments on single posts in the blog. In run-time, comments are
only shown when a single post is viewed, and not when showing the post summary. The comments
element consists of several comment post elements, and a comment form element.

Viewing and posting of comments can be prevented, by simply removing the comments element using
the Edit >  Rem ove menu item or the Delete key.

Comment Post

Displays a single comment post. In run-time, the comment post element is duplicated for each comment
post displayed, and filled in with information and content from the comment. A comment post consists of 
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several variables for displaying this information, and a permlink.

Comment Form

Allows learners to add new comments on a post. The comment form element consists of a notice
element, an author text field, a rich text element for the comment text, and a submit button.

Settings

Blog Requirements

Login Required Select When on, only learners which are authenticated
can post new comments.

Approval Required Select When on, new comments don't show up in the
blog until they are approved by a moderator.

Comment Notice

Providing the learner with notices regarding the comment posting process, the notice is only visible in
run-time when such information is present. The textual content of these notices can be edited and
localized via <Items>.

Settings

Notice

Items String List Notices which can be displayed to the learner
when trying to post a comment.

Permalink

Provides a permanent link to the post or comment in the blog's external version, allowing the learner to
read the post or comment outside of Composica, send the link to other people, bookmark the link and
more.

A lthough the permalink is  a regular link element, it has  spec ial run-time func tionality and its  <URL> and <Window

Name> properties  should be left blank.

5.6.1.1 Widgets

Blog widgets, normally contained in the left column of the main blog element, provide different
functionalities and aggregations of the blog's posts. Widgets can be added, removed, rearranged, and
customized to the author's preference.

To add widgets, use any of the Modify  > B log menu items. To remove a widget, simply remove it by
selecting it and using the Edit > Remove menu item or the Delete key. To reorganize widgets, use the
Modify  > Move  W idge t Up and Modify  > Move  W idge t Down menu items.

The following widgets are available:
Blog Home Button
Add Post Button
Edit Post Button
Remove Post Button
Subscribe Link
Recent Posts
Recent Comments
Archive
Categories
Tag Cloud
Top Rated

Blog Home Button

Returns to the blog start page, containing the post summary. To insert a blog home button, use the 
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Modify  > Add B log Hom e Button menu item.

Style

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the button.

Add Post Button

Adds a new post. To insert an add post button, use the Modify  > Add Add Post Button menu item.

When the add post button is selected, the post form is revealed, allowing to edit and customize it.

Style

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the button.

Settings

Blog Requirements

Login Required Select When on, only learners which are authenticated
can add new posts.

Approval Required Select When on, new posts (or edited posts) don't
show up in the blog until they are approved by
a moderator.

Edit Post Button

Edits the current post. To insert an edit post button, use the Modify  > Add Edit Post Button menu item.

When the edit post button is selected, the post form is revealed, allowing to edit and customize it.

Style

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the button.

Settings

Post Editing

Edit By Select author only - Only the original author of the
post can edit it.
logged in - Any authenticated user can edit
the post.
anyone - Anyone can edit the post.

Remove Post Button

Removes the current post. To insert a remove post button, use the Modify  > Add Rem ove  Post Button
menu item.

Style
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Style Rules

Mouse Over Style Style Rule Used when the mouse is over the button.

Settings

Post Removal

Remove By Select author only - Only the original author of the
post can remove it.
logged in - Any authenticated user can
remove the post.
anyone - Anyone can remove the post.

Post Form
Allows learners to add new posts, and edit existing ones. The post form element consists of a notice
element, several text fields, a rich text element for the post text, and a submit button. None of the fields
are required, and any of them can be removed by selecting them and using the Edit >  Rem ove menu
item or the Delete key.

Post Notice

Providing the learner with notices regarding the posting process, the notice is only visible in run-time
when such information is present. The textual content of these notices can be edited and localized via
<Items>.

Settings

Notice

Items String List Notices which can be displayed to the learner
when trying to add or edit a post.

Subscribe Link

Provides the learners with an RSS/Atom feed link, which allows them to subscribe to the feed with their
preferred feed reader and keep track of the blog from outside of Composica.

A lthough the subsc ription link is  a regular link element, it has  spec ial run-time func tionality and its  <URL> and <Window

Name> properties  should be left blank.

Recent Posts

Displays a summarized list of the recent blog posts. To insert a recent posts widget, use the Modify  >
Add Recent Posts W idge t menu item.

The recent posts widget consists of a widget title element, and several widget post elements. In run-
time, the widget post element is duplicated for each post, and its comprising variables are filled in with
information from the post.

Settings

Recent Posts

Post Count Number Number of recent posts to show, or all to show
all posts.

Recent Comments

Displays a summarized list of the recent comments on blog posts. To insert a recent comments widget,
use the Modify  > Add Recent Com m ents W idge t menu item.

The recent comments widget consists of a widget title element, and several widget post elements. In
run-time, the widget post element is duplicated for each post, and its comprising variables are filled in
with information from the post.
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Settings

Recent Comments

Comment Count Number Number of recent comments to show, or all to
show all posts.

Summary Word Count Number Number of words from the originating blog post
to show, or all to show the entire post text.

Archive

Displays a list of all blog posts, by their dates. To insert an archive widget, use the Modify  > Add A rchive
W idge t menu item.

The archive widget consists of a widget title element, several archive group elements, and several
widget post elements. In run-time, the archive group element is duplicated for each calendar month, and
the widget post element is duplicated for each post with its comprising variables filled in with information
from the post.

Categories

Shows a list of tags associated with posts in the blog, and the number of posts associated with each. To
insert a categories widget, use the Modify  > Add Categorie s W idge t menu item.

The categories widget consists of a widget title element, and several widget post elements. In run-time,
the widget post element is duplicated for each tag, and its comprising variables are filled in with
information associated with the tag.

Settings

Categories

Count Number Number of tags to show, or all to show all
posts.

Tag Cloud

Shows a list of tags associated with posts in the blog, visually indicating which tag is the most associated
with. To insert a tag cloud widget, use the Modify  > Add Tag C loud W idge t menu item.

The tag cloud widget consists of a widget title element, and several widget post elements. In run-time,
the widget post element is duplicated for each tag, and its comprising variables are filled in with
information associated with the tag.

Settings

Tag Cloud

Count Number Number of tags to show, or all to show all
posts.

Top Rated

Displays a summarized list of the highest rated blog posts.  To insert a top rated widget, use the Modify
> Add Top Rated W idge t menu item.

The top rated widget consists of a widget title element, and several widget post elements. In run-time,
the widget post element is duplicated for each post, and its comprising variables are filled in with
information from the post.
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Settings

Top Rated

Post Count Number Number of top rated posts to show, or all to
show all posts.

5.6.2 Comments

Blogs are flexible platforms which let the learners participate in the content of the course.

Blogs created in Composica are highly configurable and customizable, and can be designed to present
the information in various ways. For of this flexibility, blogs consist of a wide variety of sub-elements,
each being open to reconfiguration and redesign.

Blogs can be divided into two main sections: the widgets area, normally the left column; and the content
area. Blog widgets are covered separately on this page. The main blog consists of a blog navigation
element, post elements, a blog comments element, comment post elements and a comment form
element.

To insert a blog element, use the Inse rt >  Socia l Media  > B log menu item.

Settings

Blog

External Feed Text External RSS/Atom feed to use for the blog's
content, instead of creating an original blog.
When an external feed is provided, the blog
operates in read-only mode, and new posts
cannot be made.

Summary Word Count Number Number of words to show in a post's summary,
or all to show entire posts in the summary.
When posts are trimmed, they are also stripped
of any formatting, images and embedded
content.

Footer Notice Text A customizable line of text which is shown at
the bottom of the external blog.

Hide from Search Engines Select When on, the blog is hidden from search engine
spiders, and is not indexed.

Misc

Date Format Select Date format to use when showing post dates,
where yyyy signifies year, mm signifies
month, dd signifies day of the month, hh
signifies hours, nn signifies minutes and ss
signifies seconds.

Comments

The comments element is a special case of a blog, slimmed down and simplified, for allowing learners to
quickly add comments on a document. It consists of several post elements and an add post button
element.

To insert a comments element, use the Inse rt >  Socia l Media  > Com m ents menu item.

Blog Navigation

Provides controls for navigation through the blog. Consists of two sub-elements, for moving back and
forward through the posts. When viewing a single post, the labels of these sub-elements will be replaced
with the titles of the next and previous posts.
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Settings

Blog

Posts per Page Number Number of posts to show in each page of the
summary, or all to show all posts in one page.

Post

Displays a single blog post. In run-time, the post element is duplicated for each post displayed, and filled
in with information and content from the post. A post consists of several variables for displaying this
information, a post ellipsis element and a permalink.

A rating element can be added to a post, to allow learner's to rate any of the posts, using the Modify >
Add Rating menu item

Post Ellipsis

Used in the post summary, when a post's contents have been trimmed, to signify the post contains more
information. In run-time, pressing the post ellipsis shows the full post.

The post ellipsis element can be edited to contain different text (or any other content), and its looks can
be customized.

Blog Comments

Provides the ability to read and post comments on single posts in the blog. In run-time, comments are
only shown when a single post is viewed, and not when showing the post summary. The comments
element consists of several comment post elements, and a comment form element.

Viewing and posting of comments can be prevented, by simply removing the comments element using
the Edit >  Rem ove menu item or the Delete key.

Comment Post

Displays a single comment post. In run-time, the comment post element is duplicated for each comment
post displayed, and filled in with information and content from the comment. A comment post consists of 
several variables for displaying this information, and a permlink.

Comment Form

Allows learners to add new comments on a post. The comment form element consists of a notice
element, an author text field, a rich text element for the comment text, and a submit button.

Settings

Blog Requirements

Login Required Select When on, only learners which are authenticated
can post new comments.

Approval Required Select When on, new comments don't show up in the
blog until they are approved by a moderator.

Comment Notice

Providing the learner with notices regarding the comment posting process, the notice is only visible in
run-time when such information is present. The textual content of these notices can be edited and
localized via <Items>.

Settings

Notice
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Items String List Notices which can be displayed to the learner
when trying to post a comment.

Permalink

Provides a permanent link to the post or comment in the blog's external version, allowing the learner to
read the post or comment outside of Composica, send the link to other people, bookmark the link and
more.

A lthough the permalink is  a regular link element, it has  spec ial run-time func tionality and its  <URL> and <Window

Name> properties  should be left blank.

5.6.3 Rating

Rating elements give the learners the ability to rate content, and express their views on different
subjects.

Rating elements consist of one or more rating on, rating off and rating edit elements, and usually contain
several variables. The star images can be easily replaced, by replacing the images in these sub-
elements.

To insert a rating element, use the Inse rt >  Socia l Media  > Rating menu item.

Settings

Rating

Accumulate Votes Select When on, votes are accumulated, and the
rating shown is the average of all accumulated
votes.

Star Count Number Number of stars (3-10) in the rating element,
or the max rating.

Description Text Description of the rating, to be sent to the LMS
along with the score.

Rating On

Represents an active star in the rating. Usually contains an image, and can be customized to any image
or any other content.

Rating Off

Represents a non-active star in the rating. Usually contains an image, and can be customized to any
image or any other content.

Rating Edit

Represents an edit star in the rating. Usually contains an image, and can be customized to any image or
any other content.

5.6.4 Sign In

Sign in allows for custom authentication for social media. When authentication mode is set to custom,
providing a sign in control is required in order to let learners sign up and log in.

The sign in element is made up of the sign in button, and the login form. In run-time, the sign in button
shows the login form. When the learner is logged in, the sign in button is automatically hidden.

Signing in is global; once a learner has signed in, he remains logged in for the rest of the course. It is
recommended to provide a sign in button in any document that contains social media elements, or
alternatively have on in the master layer.

To insert a sign in element, use the Inse rt >  Socia l Media  > Sign In menu item.
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Login Form

Providing the learners with space to enter their username and password, the login form also functions as
a registration form. In design time, the login form is revealed when the sign in button is selected.

The login form consists of several text fields, a login button, a register button, and a notice. In order to
log in, learners enter their username and password, and press the login button. In order to register,
learners enter their design username and password, repeating the password in the verification field, and
press the register button.

Notice

Providing the learner with pertinent information about the sign in process, such as errors and missing
information, the notice is only visible in run-time when such information is present. The textual content of
these notices can be edited and localized via <Items>.

Settings

Notice

Items String List Notices which can be displayed to the learner
during the login or registration process.

5.7 Mashups

Mashups are special elements, which integrate Web 2.0 services provided by third-party service
providers into Composica, while using Composica native design and elements making them completely
flexible and customizable.  To learn more about adding mashups, read about adding mashups.

YouTube Movie
Universal Search
Twitter Tweets
Facebook Like Button
Google Chart
Google Map Chart

5.7.1 YouTube Movie

YouTube movie elements are used to embed streaming movies and videos from YouTube in the course,
using the native YouTube interface. YouTube movies can also be displayed using the Media Player.

To insert a YouTube movie element, use the Inse rt >  Mashups > YouTube  Mov ie menu item. The
YouTube movie selection dialog will open, providing an interface to find and select a YouTube movie, by
keywords or by its ID. After selected the movie, use the Inse rt option to add the movie using the native
YouTube interface.

Settings

Source

Source YouTube YouTube movie to show in the player. Opens a
special selection dialog, allowing to search for
and select YouTube movies.

Player

Color Color Color to use for the player.

Show Border Select When on, a border is shown.

Border Color Color Color to use for the border. Only relevant when
<Show Border> is yes.

Allow Fullscreen Select When on, the fullscreen button is shown
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allowing to view the movie in fullscreen.

Loop Select When on, the movie loops when it reaches its
end.

Show Related Select When on, related movies are shown when the
movie reaches its end.

5.7.2 Universal Search

Universal search elements allow the learner to search in one or more search engines from within
Composica, without having to leave the learning environment.

Universal search elements can contain one or more search engine elements.

To insert a universal search element, use the Inse rt >  Mashups > Unive rsa l Search menu item.

Settings

Universal Search

Show Results In Select external window - Open a new window with
the search results.
frame - Show search results in a frame, in the
current document.

Read Only Select When on, the search term is predetermined
and cannot be modified.

Search Engine

Each search engine element represents a choice of search engine the learner can use to make the
lookup.

Additional search engines can be added using the Modify  > Add Search Engine menu item.

Settings

Search Engine

Search In Select The search engine to use. Custom will use the
search engine defined in <Custom URL>.

Custom URL Text A custom search engine URL, only relevant
when <Search In> is Custom. The search
query will be appended to the URL, so the URL
should similar to the following format: my.
web.site/search?q=

5.7.3 Twitter Tweets

Twitter tweets element allows to embed a twitter feed in the document, which shows the most recent
twitter updates when viewing the course.

A twitter tweets element is basically an enhanced comments element, and as such it inherits the same
basic properties and behaviors from it. Additionally to these properties, the twitter tweets element
introduces several properties which allow configuring what tweets are displayed.

To insert a twitter tweets element, use the Inse rt >  Mashups > Tw itte r Twee ts menu item.

Settings
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Twitter

Hashtag or Search Text Show tweets containing the specified hashtag
or search query.

From Twitterer Text Show tweets from the specified author.

To Twitterer Text Show tweets in reply to the specified user.

Tweet Type Select Include only the most recent tweets, the most
popular tweets, or a mixed aggregation of
both.

Tweet Count Number Number of tweets to list.

Misc

Date Format Select Date format to use when showing tweet dates,
where yyyy signifies year, mm signifies
month, dd signifies day of the month, hh
signifies hours, nn signifies minutes and ss
signifies seconds.

5.7.4 Facebook Like Button

Facebook like button embeds a standard facebook like interface in the document, allowing learners to
express interest in a specific document, and share it with their facebook peers.

To insert a facebook like button element, use the Inse rt >  Mashups > Facebook  Like  Button menu item.

Settings

Facebook Like Button

Title Select Displays like or recommend as the action
taken.

Layout Select A standard or minimal layout for the
interface.

Color Scheme Select A light or dark color scheme, to better match
the background of the document.

Show Faces Select When on, shows the faces of people who liked
this document.

5.7.5 Google Chart

Google charts allow charting data, which is entered into the element, in one of several ways.

Google chart elements consist of data set elements and data point elements, which describe the data of
the chart. These elements are not visible when the course is published, they are fed into the chart.

To insert a Google chart element, use the Inse rt >  Mashups > G oogle  Chart menu item.

Settings

Chart Appearance

Chart Type Select The type of chart to display, either line,
sparkline, columns, columns stacked, pie,
3d pie, venn, scatter, radar, map or meter
.
For the map chart type, see the Google Map
Chart.
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Width Unit Width of the chart.

Height Unit Height of the chart.

Color Color Color of the chart.

Background Color Color Background color of the chart.

Area Type Select Fill type for the chart area, either solid,
gradient, or stripes.

Area Color 1 Color Primary fill color for the chart area.

Area Color 2 Color Secondary fill color for the chart area, only
relevant when <Chart / Area Type> is 
gradient or stripes.

Gradient Angle Number Angle of the chart area gradient. Only relevant
when <Chart / Area Type> is gradient.

Title

Title Text Title to show in the head of the chart.

Size Unit Font size to use for chart title.

Color Color Font color to use for chart title.

Axes

Axis 1 Font Size Unit Font size for the first axis label.

Axis 1 Font Color Color Font color for the first axis label.

Axis 2 Font Size Unit Font size for the second axis label.

Axis 2 Font Color Color Font color of the second axis label.

Legend

Show Select When on, a legend is shown on the chart.

Position Select Position to show the legend in, either bottom,
top, right or left. Only relevant when
<Legend / Show> is yes.

Grid

Show Select When on, a grid is shown in the back of the
chart.

X Step Number Step between each grid line on the X-axis. Only
relevant when <Grid / Show> is yes.

Y Step Number Step between each grid line on the Y-axis. Only
relevant when <Grid / Show> is yes.

Line Segment Number Length of each line segment in the dashed grid
line.

Blank Segment Number Length of each blank segment in the dashed
grid line, or 0 for a solid grid line.

Bars

Width Number Width of each bar. Only relevant when <Chart /
Type> is columns or stacked columns.

Spacing Number Spacing between bars in each group. Only
relevant when <Chart / Type> is columns or 
stacked columns.

Groups Spacing Number Spacing between each group of bars. Only
relevant when <Chart / Type> is columns or
stacked columns.
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Stripes

Width Number The width of each stripe in the chart area. Only
relevant when <Chart / Area Type> is stripes.

Direction Select The direction of the chart area stripes, either 
vertical or horizontal. Only relevant when
<Chart / Area Type> is stripes.

Scaling

Min Number Minimum point value to scale the chart by. To
reset scaling, set both this and <Scaling / Max>
to 0.

Max Number Maximum point value to scale the chart by. To
reset scaling, set both this and <Scaling / Min>
to 0.

Map

Geographical Area Select Geographical area covered by the map chart.
Only relevant when <Chart / Type> is map.

More information about Google chart options  can be found on Google C hart A P I .

Data Set

Each data set in the chart describes a set of points, or an axis. A data set element consists of any
number of data point elements.

Additional data sets can be added using the Modify  > Add Data  Se t or Modify  > Add De fault Da ta  Se t
menu items.

Settings

Colors

Color Color Color of the dataset. When left undefined,
inherits the color of the chart.

Labels

Show Select When on, labels are shown for each point in the
dataset.

Dataset Label Text Label of the dataset, displayed on the axis.

Line

Width Number Width of the line described by the dataset.

Line Segment Number Length of each line segment in the dashed line.

Blank Segment Number Length of each blank segment in the dashed
line, or 0 for a solid line.

Marker

Show Select When on, markers are shown for each point in
the data set.

Type Select Type of points markers, either arrow, cross,
diamond, circle, square or x. Only relevant
when <Marker / Show> is yes.

Color Color Color of point markers. Only relevant when
<Marker / Show> is yes.

Size Number Size of point markers. Only relevant when

http://code.google.com/apis/chart/
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<Marker / Show> is yes.

Priority Select Priority of point markers, either high, normal,
or low. Only relevant when <Marker / Show>
is yes.

Data Point

Each point in the chart is described using a data point element.

Additional data points can be added using the Modify  > Add Data  Po int menu item.

Settings

Point

Label Text Label of the data point.

Data Number Value of the data point.

Color Color Color of the data point. When left undefined,
inherits the color of the data set.

Google Map Chart

Google map charts are special cases of the Google chart, used to create a map of geographical area.
The geographical area covered by the map is defined by <Geographical Area>. Each data point's
<Label> can be set to a country code or state code to highlight it on the map.

See Google's  lis t of supported country codes , and of supported s tate codes  for the USA .

5.8 Navigation

Navigation elements are used to provide information about the document in the scope of the entire
project, and to provide navigation from the document to other documents of the project.

Project Title
Document Title
Navigation Button
Navigation Link
Popup Button
Breadcrumbs
Progress Bar
Navigation Locator
Timer
Tree Menu
Compact Tree Menu
One-Level Menu

5.8.1 Project Title

Project title elements are variable elements, with <Value> set to project title.

To insert a project title element, use the Inse rt >  Nav iga tion > Pro ject T itle menu item or the Nav iga tion
> Pro ject T itle toolbar button.

http://www.iso.org/iso/english_country_names_and_code_elements
http://code.google.com/apis/chart/docs/gallery/map_charts.html#statecodes
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5.8.2 Document Title

Document title elements are variable elements, with <Value> set to location title.

To insert a document title element, use the Inse rt >  Nav iga tion > Docum ent T itle menu item or the
Nav iga tion > Docum ent T itle toolbar button.

5.8.3 Navigation Button

Navigation buttons allow the viewer to navigate to another document on the project, when <Trigger> is
triggered.

To insert a navigation button, use the Inse rt >  Nav iga tion > Nav iga tion Button menu item or the
Nav iga tion > Nav iga tion Button toolbar button.

Style

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the button.

Pressed Style Style Rule Used while the mouse is pressed over the
button.

Disabled Style Style Rule Used when the button is disabled.

Visited Style Style Rule Used once the button's target has already been
visited.

Settings

Behavior

Trigger Select click - The navigation is triggered when the
button is pressed.
mouseover - The navigation is triggered when
the mouse is over the button.
timer - The navigation is triggered after an
interval specified by <Trigger Delay>.

Operation Select next - Navigate to the next document in the
outline.
previous - Navigate to the previous document
in the outline.
next chapter - Navigate to the next chapter in
the outline.
previous chapter - Navigate to the previous
chapter in the outline.
up - Navigate to the document above the
current one in the outline hierarchy.
custom - Navigate to a custom document,
specified by <Navigate To>.
back - Navigates back in the viewed
documents history.
forward - Navigates forward in the viewed
documents history.
refresh - Refresh the current document.
close window - Close the current window.
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finish test - Finish the current test.
print - Print the current document.

Navigate To Resource A specific outline document in the project to
navigate to.

Trigger Delay Unit When <Trigger> is timer, the interval to wait
before triggering the navigation.

State

Enabled On Select default - Button is not specifically enabled on
special situations.
first page - Button is enabled on the first page
of the project.
last page - Button is enabled on the last page
of the project.
first chapter page - Button is enabled on the
first page of each chapter.
last chapter page - Button is enabled on the
last page of each chapter.
first test page - Button is enabled on the first
page of each test.
last test page - Button is enabled on the last
page of each test.

Disabled On Select default - Button is not specifically disabled on
special situations.
first page - Button is disabled on the first
page of the project.
last page - Button is disabled on the last page
of the project.
first chapter page - Button is disabled on the
first page of each chapter.
last chapter page - Button is disabled on the
last page of each chapter.
first test page - Button is disabled on the first
page of each test.
last test page - Button is disabled on the last
page of each test.

Disabled Mode Select disable - Keep the button shown when
disabled.
hide - Hide the button when disabled.

5.8.4 Navigation Link

Navigation links are inline navigation button elements, with the appearance of a regular link.

To insert an inline navigation link, use the Inse rt >  Nav iga tion > Nav iga tion Link menu item or the
Nav iga tion > Nav iga tion Link toolbar button. You can optionally select text before inserting, which would
convert the text segment to a navigation link element.

5.8.5 Popup Button

Popup buttons open a standalone document or a URL in a new popup window, when <Popup Trigger> is
triggered.

To insert a popup button, use the Inse rt >  Nav iga tion > Popup Button menu item or the Nav iga tion >
Popup Button toolbar button.
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Style

Popup

Popup Top Unit The offset of the popup window from the top
edge of the screen.

Popup Left Unit The offset of the popup window from the left
edge of the screen.

Popup Width Unit The width of the popup window.

Popup Height Unit The height of the popup window.

Position Center Select When on, automatically positions the popup
window at the center of the screen.

Resizable Select When on, the popup window can be resized by
the viewer.

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the button.

Pressed Style Style Rule Used while the mouse is pressed over the
button.

Settings

Source

Source Resource The standalone document to open in the popup
window.

URL Text When no <Popup> set, the URL to open in the
popup window.

Behavior

Popup Trigger Select click - The popup is triggered when the button
is pressed.
timer - The popup is triggered after an interval
specified by <Popup Delay>.

Popup Delay Unit When <Popup Trigger> is timer, the interval to
wait before triggering the popup.

Popup Mode Select modeless - The viewer can interact with the
main project window while the popup window is
open.
modal - The viewer cannot interact with the
main project window while the popup window is
open, until it's closed.

5.8.6 Breadcrumbs

Breadcrumbs show the current location, in relation to the outline hierarchy.

Breadcrumb elements consist of a parent crumb element, a crumb separator element, and a current
crumb element.

To insert a breadcrumbs element, use the Inse rt >  Nav iga tion > B readcrum bs menu item or the
Nav iga tion > B readcrum bs toolbar button.
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Settings

Behavior

Can Navigate Select When on, breadcrumbs can be used to navigate
to any documents they list.

Parent Crumb

The parent crumb element is a generic text element, which can be altered visually to affect the visual
appearance of the breadcrumbs.

Crumb Separator

The crumb separator element is a generic element, which can be altered visually to affect the visual
appearance of the breadcrumbs.

Current Crumb

The current crumb element is a generic text element, which can be altered visually to affect the visual
appearance of the breadcrumbs.

5.8.7 Progress Bar

Progress bars show the progress made on the entire course, indicated by either the completion
percentage of the course, or by the current location in the outline. 

Progress bar elements consist of percent done elements and percent not done elements.

To insert a progress bar element, use the Inse rt >  Nav iga tion > Progress Bar menu item or the
Nav iga tion > Progress Bar toolbar button.

Settings

Behavior

Indicate Select completion - Show indication of the
completion status of the project.
location - Show indication of the current
location in the outline of the project.

Progress Root Select project - Show global progress in the project.
current chapter - Show local progress in the
current chapter.

Show Percentage Select When on, the progress bar shows a numeric
presentation of the done percentage.

Percent Done

The percent done element is the segment of the progress bar showing the relative amount done
throughout the course. The percent done element's contents can not be edited, but it's visual appearance
can be customized.

Percent Not Done

The percent not done element is the segment of the progress bar showing the relative amount of the
course that is yet to be done. The percent done element's contents can not be edited, but it's visual
appearance can be customized.
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5.8.8 Navigation Locator

Navigation locators show the current page number and the total number of pages.

Navigation locator elements are generic elements, consisting of text and two variable elements:

Page No., showing the current page number, is a variable element with <Value> set to page
number.

Total Pages, showing the total count of pages in the course, is a variable element with <Value> set
to total pages.

The text of the navigation locator can be modified as in any other generic element, and variables can be
added or removed for customization.

To insert a navigation locator element, use the Inse rt >  Nav iga tion > Nav iga tion Loca tor menu item or
the Nav iga tion > Nav iga tion Loca tor toolbar button.

Settings

Behavior

Mode Select project - Show global progress in the project.
current chapter - Show local progress in the
current chapter.

5.8.9 Timer

Timers allow one of several actions to trigger, after a specific amount of time has passed since the
document has been first viewed.

Timer elements contain a timer message element.

To insert a timer element, use the Inse rt >  Nav iga tion > T im er menu item or the Nav iga tion > T im er
toolbar button.

Settings

Behavior

Duration Unit The time from the first viewing of the
document, after which the action specified by
<Timer Action> will be executed. When auto,
inherits the test properties if available.

Timer Action Select Defines the action to execute once the timer
has elapsed.
auto - Inherits the test properties, when
available. Otherwise, does nothing.
check question - Check the question in the
document.
next - Navigate to the next document in the
outline.
check and next - Check the question in the
document, and then navigate to the next
document in the outline.
custom - Navigate to the document specified
by <Navigate To>.
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none - Take no action.

Navigate To Resource The document to navigate to once the timer
has elapsed. Only relevant when <Timer
Action> is custom.

Navigate Delay Unit The time after the timer has elapsed before
navigating to <Navigate To>. Only relevant
when <Timer Action> is custom.

Reset on Navigation Select When on, resets the timer when navigating
away from the page.

Appearance

Visible Select When off, the timer isn't visible on screen, but
the <Timer Action> is still executed after the
timer has elapsed.

Mode Select Defines the visual appearance of the timer.
Only relevant when <Visible> is true.
digital - A digital clock.
horizontal - A horizontal bar.
vertical - A vertical bar.
boxed - A growing box.

Count Mode Select The direction to count in, either down or up.

Show Message Select When on, shows the timer message element
once the timer has elapsed. Only relevant when
<Visible> is true.

Update Interval Unit The time between each visual update to the
timer. Only relevant when <Visible> is true.

Timer Message

The timer message element is a generic element, which is shown when the timer has elapsed. The timer
message is only shown if <Show Message> is true, and <Visible> is true.

5.8.10Tree Menu

Tree menus show a traversable menu of the project outline in the form of a tree.

Tree menu elements consist of one or more: menu chapter elements, menu page elements, menu
container elements, current marker elements, and done marker elements.

To insert a tree menu element, use the Inse rt >  Nav iga tion > Tree  Menu menu item or the Nav iga tion >
Tree  Menu toolbar button.

Style

Style Rules
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Mouse Over Chapter Style Style Rule Used for menu chapter elements when the
mouse is over them.

Mouse Over Page Style Style Rule Used for menu page elements when the mouse
is over them.

Current Chapter Style Style Rule Used for chapter elements when they are the
current chapter.

Current Style Style Rule Used for page elements when they are the
current page.

Done Style Style Rule Used for page elements when the page is done.

Settings

Location

Menu Root Select Defines which document will be considered as
the root of the menu. Any documents higher
than the menu root will not be shown as part of
the menu.
project - The root of the project.
current location - The current document.
parent location - The parent of the current
document.
mixed - The current document if it's a chapter,
or the parent document otherwise.
custom - A custom document, specified by
<Custom Root>.

Custom Root Resource The document to consider as the root of the
menu. Only relevant when <Menu Root> is 
custom.

Initial Appearance

Levels Select The number of levels to show (threshold)
beneath the root level.
all - Show any number of levels.

Start State Select collapsed - Initiates the tree with all chapters
in collapsed state.
expanded - Initiates the tree with all chapters
in expanded state.
expand one level - Initiates the tree with one
level of chapters in expanded state, and the
rest in collapsed state.
expand two levels - Initiates the tree with
two levels of chapters in expanded state, and
the rest in collapsed state.

Show Select all - Show any type of documents.
chapters - Show only chapter documents.

Auto Expand Select Automatically expand the menu to show the
current page.

Auto Scroll Select Automatically scroll the menu to show the
current page.

Show Empty Chapters Select When off, empty chapters are hidden from the
menu.

Hide Unvisited Select When on, documents which have not yet been
visited are hidden from the menu.

Behavior

Collapsible Select When on, chapters can be collapsed to hide the
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documents underneath them.

Toggle Sibling Select When on, expanding a chapter collapses all its
sibling chapters.

Disable Navigation Select When on, the menu is for display purposes
only, and cannot be used for navigation.

Markers

Current Marker Select Defines whether the current marker is shown.

Done Marker Select Defines whether the done marker is shown.

Started Marker Select Defines whether the started marker is shown.

Mark Current Chapter Select all parents - Mark all parents of the current
page as the current chapter.
highest parent - Mark only the highest parent
of the current page as the current chapter.
nearest parent - Mark only the nearest
parent of the current page as the current
chapter.

Compact Tree Menu

The compact tree menu is a modified tree menu, which is styled to be simple and compact.

To insert a compact tree menu element, use the Inse rt >  Nav iga tion > Com pact Tree  Menu menu item or
the Nav iga tion > Com pact Tree  Menu toolbar button.

Menu Chapter

Each chapter of the project's outline is represented by a menu chapter element. Customizing the visual
appearance of one menu chapter element will alter the visual appearance of all menu chapter elements
throughout the menu.

When <Collapsible> is true, and the chapter contains other documents, pressing the menu chapter
element collapses or expands (hides or shows, accordingly) the documents underneath the chapter.
Otherwise, pressing the menu chapter element navigates to the chapter.

Menu Page

Each page of the project's outline is represented by a menu page element. Customizing the visual
appearance of one menu page element will alter the visual appearance of all menu page elements
throughout the menu.

Pressing a menu page element navigates to the page.

Menu Container

Menu container elements are used for each branch in the menu's hierarchy.

Current Marker

The current marker element is a generic element, which is used to mark the current document in the
menu. Current markers are only shown when <Mark / Current> is true.

Started Marker

The started marker element is a generic element, which is used to mark a chapter which has been
started but not completed. Started markers are only shown when <Mark / Started> is true.
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Done Marker

The current marker element is a generic element, which is used to mark which of the documents in the
menu are done. Done markers are only shown when <Mark / Done> is true.

5.8.12One-Level Menu

One-level menus show a traversable menu of one level of the project's outline.

One-level menu elements consist of one or more: menu chapter elements, menu page elements, derived
chapter elements, derived page elements,  menu blockelements, menu container elements, current
marker elements, and done marker elements.

To insert a one-level menu element, use the Inse rt >  Nav iga tion > One-Leve l Menu menu item or the
Nav iga tion > One-Leve l Menu toolbar button.

Style

Style Rules

Mouse Over Sub-Chapter Style Rule Used for derived chapter elements when the
mouse is over them.

Mouse Over Sub-Page Style Rule Used for derived page elements when the
mouse is over them.

Mouse Over Chapter Style Style Rule Used for menu chapter elements when the
mouse is over them.

Mouse Over Page Style Style Rule Used for menu page elements when the mouse
is over them.

Current Chapter Style Style Rule Used for chapter elements when they are the
current chapter.

Current Style Style Rule Used for page elements when they are the
current page.

Done Style Style Rule Used for page elements when the page is done.

Settings

Location

Menu Root Select Defines which document will be considered as
the root of the menu. Any documents higher
than the menu root will not be shown as part of
the menu.
project - The root of the project.
current location - The current document.
parent location - The parent of the current
document.
mixed - The current document if it's a chapter,
or the parent document otherwise.
custom - A custom document, specified by
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<Custom Root>.

Custom Root Resource The document to consider as the root of the
menu. Only relevant when <Menu Root> is 
custom.

Initial Appearance

Layout Select columns - Shows a column for each branch in
the root level, with its derived documents
underneath it.
rows - Shows a row for each branch in the root
level, with its derived documents side-by-side.
bars - Shows a list of all the documents.
pop menu - Shows a list of all the documents
in the root level, with each branch opening a
list of derived documents.
drop down - Shows a column for each branch
in the root level, with its derived documents
dropping down from it.

Start State Select collapsed - Initiates the tree with all chapters
in collapsed state.
expanded - Initiates the tree with all chapters
in expanded state.
expand one level - Initiates the tree with one
level of chapters in expanded state, and the
rest in collapsed state.
expand two levels - Initiates the tree with
two levels of chapters in expanded state, and
the rest in collapsed state.

Show Select all - Show any type of documents.
pages - Show only page documents.
chapters - Show only chapter documents.

Auto Expand Select Automatically expand the menu to show the
current page.

Auto Scroll Select Automatically scroll the menu to show the
current page.

Show Empty Chapters Select When off, empty chapters are hidden from the
menu.

Hide Unvisited Select When on, documents which have not yet been
visited are hidden from the menu.

Behavior

Collapsible Select When on, chapters can be collapsed to hide the
documents underneath them.

Toggle Sibling Select When on, expanding a chapter collapses all its
sibling chapters.

Disable Navigation Select When on, the menu is for display purposes
only, and cannot be used for navigation.

Markers

Current Marker Select Defines whether the current marker is shown.

Done Marker Select Defines whether the done marker is shown.

Started Marker Select Defines whether the started marker is shown.

Mark Current Chapter Select all parents - Mark all parents of the current
page as the current chapter.
highest parent - Mark only the highest parent
of the current page as the current chapter.
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nearest parent - Mark only the nearest
parent of the current page as the current
chapter.

Menu Chapter

Each chapter of the root level's outline is represented by a menu chapter element. Customizing the
visual appearance of one menu chapter element will alter the visual appearance of all menu chapter
elements throughout the menu.

When <Collapsible> is true, and the chapter contains other documents, pressing the menu chapter
element collapses or expands (hides or shows, accordingly) the documents underneath the chapter.
Otherwise, pressing the menu chapter element navigates to the chapter.

Menu Page

Each page of the root level's outline is represented by a menu page element. Customizing the visual
appearance of one menu page element will alter the visual appearance of all menu page elements
throughout the menu.

Pressing a menu page element navigates to the page.

Derived Chapter

Each chapter underneath the root level is represented by a derived chapter element. Customizing the
visual appearance of one derived chapter element will alter the visual appearance of all derived chapter
elements throughout the menu.

Pressing a derived chapter element navigates to the chapter.

Derived Page

Each page underneath the root level is represented by a derived page element. Customizing the visual
appearance of one derived page element will alter the visual appearance of all derived page elements
throughout the menu.

Pressing a derived page element navigates to the page.

Menu Block

Menu blocks elements are used for each branch underneath the root level.

Menu Container

Menu container elements are used to hold documents underneath each chapter inside each menu block.

Current Marker

The current marker element is a generic element, which is used to mark the current document in the
menu. Current markers are only shown when <Mark / Current> is true.

Started Marker

The started marker element is a generic element, which is used to mark a chapter which has been
started but not completed. Started markers are only shown when <Mark / Started> is true.

Done Marker

The current marker element is a generic element, which is used to mark which of the documents in the
menu are done. Done markers are only shown when <Mark / Done> is true.

5.9 Activities

Activities are interactive elements, which are used for tests and for creating other interactive
experiences for learners. Activities are the most complex of elements, and are usually made of several
different types of elements.

Each of the following pages represents an activity, and list each of the sub-elements it consists of, and
their respective properties.
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Multiple Choice
Point Click
Drag Drop
Hot Spots
Fill Blank
Hot Word
Survey
Feedback
Get a Hint

5.9.1 Multiple Choice

Multiple choice activities consist of a question element, one or more answer elements, a check answer
button, and a feedback element.

To insert a multiple choice activity, use the Inse rt >  Multip le  Cho ice menu item or the Inse rt Multip le
Cho ice toolbar button.

Style

Bullets

Normal Bullet Media Used for answer bullets in its normal state.

Pressed Bullet Media Used for selected answer bullets.

Right Bullet Media Used for answer bullets marked as correct.

Wrong Bullet Media Used for answer bullets marked as wrong.

Style Rules

Answer Normal Style Rule Used for an answer in its normal state.

Answer Over Style Rule Used for an answer when the mouse is over it.

Answer Pressed Style Rule Used for an answer when its selected.

Answer Right Style Rule Used for an answer which is marked as correct.

Answer Wrong Style Rule Used for an answer which is marked as wrong.

Settings

Behavior

Shuffle Answers Select When on, randomizes the order of answers.

Immediate Check Select When on, the answer is checked immediately
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when an answer is selected, and the check
answer button is hidden.

Limit Answer Count Select When on, limits the amount of possible answers
to the number of correct answers.

Misc

Description Text Description of the activity, to be sent to the
LMS along with the result.

Point Click

Point click activities are modified multiple choice activities, with <Immediate Check> set to true by
default. Point click activities can be used for quickly creating questions where one answer out of several
options should be pressed for a correct answer.

To insert a point click activity, use the Inse rt >  Po int C lick menu item.

Question

A question of the multiple choice activity is a generic element. A multiple choice activity can only have
one question, and it should not be removed. To edit the question, simply edit the question element's
content.

Answer

An answer of the multiple choice activity is a generic element. To add additional answers, use the Modify
> Add Answer menu item. To remove an answer, simply select and remove it using the Edit >  Rem ove
menu item, or the Delete key.

An answer is considered correct when <Correct> is true, and all answers are incorrect by default. One
or more answers can be set as correct.

Settings

Answer

Correct Select Marks the answer as correct or incorrect.
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5.9.3 Drag Drop

Drag drop activities consist of one or more pairs of drag item elements and drop area elements, a check
answer button and a feedback element. A drag item is considered correct when dropped on a drop area
that shares its index.

To insert a drag drop activity, use the Inse rt >  Drag Drop menu item or the Inse rt Drag Drop toolbar
button.

Usually, drag items and drop areas go in pairs. To add such a pair, use the Modify  > Add Drag Drop Pa ir
menu item. However, each "pair" can have any number of drag items or drop areas.

To add a drag item to an existing pair, choose an element of the pair and use the Modify  > Add Drag
Item  To Pa ir menu item. To add a drop area to an existing pair, choose an element of the pair and use
the Modify  > Add Drop A rea  To  Pa ir menu item.

Dummy drag items and drop areas are ones which have an index of -1. Such dummy items aren't
involved in the score calculation of the activity.

Style

Drag Drop

Drag Opacity Number The opacity level (0-100) of the drag items
while dragging.

Animate Correction Select When on, animates drag items when showing
the correction.

Correction Animation
Duration

Unit The time (in milliseconds) for the correction
animation to take. Only relevant when
<Animation Correction> is true.

Style Rules

Dragging Style Style Rule Used for a drag item while it's being dragged.

Dropped Style Style Rule Used for a drag item after it has been dropped
in place.

Settings

Behavior

Shuffle Drag Items Select When on, randomizes the order of drag items.

Shuffle Drop Areas Select When on, randomizes the order of drop areas.

Reject Mismatched Drops Select When on, items dropped over a mismatched
drop area will be rejected.
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On Drop Align To Select center - Dropped items will align to the center
of the drop area.
top-left - Dropped items will align to the top-
left of the drop area.

Force Correction Order Select Enforces the order in which to fix the items
when showing correction, according to their
order property.

Allow Drop Over Select Allows dragging items over a drop area which
already has an item attached to it.

Misc

Description Text Description of the activity, to be sent to the
LMS along with the result.

Drag Item

A drag item is a generic element. To remove a drag item, simply select and remove it using the Edit >
Rem ove menu item, or the Delete key.

Style

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the drag item.

Dragging Style Style Rule Used for the drag item while it's being dragged.

Dropped Style Style Rule Used for the drag item after it has been
dropped in place.

Settings

Drag Item

Drag Item Index Number The index of the drag item, linking it to one or
more corresponding drop areas. none creates
a dummy drag item, which isn't taken into
consideration in the score calculation for the
activity.

Drop Area

A drop area is a generic element. To remove a drop area, simply select and remove it using the Edit >
Rem ove menu item, or the Delete key.

Style

Drop Area

Opacity Number The opacity level (0-100) of the drop area.

Settings

Drop Area

Drop Area Index Number The index of the drop area, linking it to one or
more corresponding drag items. none creates
a dummy drop area, which isn't taken into
consideration in the score calculation for the
activity.

Correction Order Number The order in which to fix the items when
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showing correction, when <Force Correction
Order> is true.

5.9.4 Fill Blank

Fill blank activities consist of a question element with one or more fill blank item elements, a check
answer button, and a feedback element. Fill blank activities allow  providing one or more writeable or
selectable blanks, which needs to filled correctly to complete the activity.

To insert a fill blank activity, use the Inse rt >  Fill B lank menu item or the Inse rt Fill B lank toolbar button.

Settings

Behavior

Shuffle Options Select When on, randomizes the order of the options
of selectable blanks.

Misc

Description Text Description of the activity, to be sent to the
LMS along with the result.

Question

The question element of the Fill Blank activity consists of the question along with the blanks of the
activity. A fill blank activity can only contain one question, but a question can contain any number of
blanks. 

The question element should generally not be removed. To add the question element in case of a
removal, use the Modify  > Add Question menu item.

Fill Blank Item

Blanks are inline to the question, which means they are embedded along with the text of the question, to
easily maintain the flow of the text. To add an inline blank to the question, you must first enter the
question's content editing mode. To remove a blank, simply select and remove it using the Edit >
Rem ove menu item, or the Delete key.

A blank can be of two types: a writeable blanks, and a selectable blanks.

Settings

Fill Blank Item

Case Sensitive Select When on, the entered answer must have the
exact same case as the provided options.
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Writeable Blank

Writeable blanks are open inputs which can be filled by the viewer. A writeable blank has a list of one or
more options, which are considered as correct values for that blank. To add a writeable blank, when
editing the question's content, at the position you wish to add the blank use the Modify  > Add W riteable
B lank menu item.

Selectable Blank

Selectable blanks provide the viewer with a list of options to choose from, in which one or more options
can be correct. To add a selectable blank, when editing the question's content, at the position you wish to
add the blank use the Modify  > Add Se lectable  B lank menu item.

Options

Each blank has an option list, which is visible when selecting the blank. To add an option, you must first
select the blank you wish to add the option to. To remove an option, simply select and remove it using
the Edit >  Rem ove menu item, or the Delete key.

An option can be of the following types: a blank option, a blank range, and a blank mask.

Blank Option

A blank option is a normal option. To edit a blank option's value, edit its text. To add a blank option, use
the Modify  > Add Option menu item.

Settings

Blank Option

Correct Select Marks the option as a correct or incorrect
answer.

Blank Range

A range option allows for a value within a certain range to be considered correct. A range option is only
relevant for writeable blanks. To add a range option, use the Modify  > Add Range  Option menu item.

Settings

Blank Range

Lower Bound Number The lower bound of the range to be considered
as a correct value.

Higher Bound Number The higher bound of the range to be considered
as a correct value.

Blank Mask

A range option allows for a value which matches a certain mask to be considered correct. A mask option
is only relevant for writeable blanks. To add a mask option, use the Modify  > Add Mask  Option menu
item.

Settings

Blank Mask

Mask Text A wildcard mask to be considered as a correct
value. A regular expression can be used,
enclosed in forward slashes.
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5.9.5 Hot Spots

Hot spots elements consist of one or more pairs of hot spot elements and hot popup elements. A hot
popup is shown when the hot spot's event is triggered, according to its <Hot Event>.

To insert a hot spots element, use the Inse rt >  Hot Spots menu item or the Inse rt Hot Spots toolbar
button.

Usually, hot spots and hot popups go in pairs. To add such a pair, use the Modify  > Add Hot Spot Pa ir
menu item. However, each "pair" can have any number of hot spots or hot popups.

To add a hot spot to an existing pair, choose an element of the pair and use the Modify  > Add Hot Spot
To  Pa ir menu item. To add a hot popup to an existing pair, choose an element of the pair and use the
Modify  > Add Hot Popup To  Pa ir menu item.

Style

Hot Spots

Hide Mode Select effect - Use an effect (if defined) when hiding
hot popups.
plain - Hide hot popups without any effects.

Style Rules

Visited Style Style Rule Used once a hot spot has been shown.

Active Style Style Rule Used while a hot spot is active.

Settings

Behavior

Exclusive Popups Select When on, only one hot popup of this activity
can be active at a time.

Play Mode Select every time - Hot popups are reset to their
initial state every time the document is visited.
first time - Hot popups remain in their last
shown state when the document is revisited.

Hot Spot

A hot spot is a generic element. To remove a hot spot, simply select and remove it using the Edit >
Rem ove menu item, or the Delete key.

Style

Hot Spot

Opacity Number The opacity level (0-100) of the hot spot.

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the hot spot.

Visited Style Style Rule Used once a hot spot has been shown.
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Active Style Style Rule Used while a hot spot is active.

Settings

Behavior

Event Select mouseover - The hot popup is shown when
the mouse is over the hot spot, and hidden
when it leaves.
click - The hot popup is shown/hidden each
time the hot spot is pressed.
timer - The hot popup is shown/hidden on a
timer, according to <Timer Show Interval> and
<Timer Hide Interval>.

Toggle Select When on, the hot popup is shown/hidden each
time the defined <Hot Event> is triggered.
When off, the hot popup is never hidden.

Hide All Popups Select When on, hides all other popups when being
shown.

Hide Spot on Event Select When on, hides the hot spot after being
triggered for the first time.

Timer Show Interval Unit When <Hot Event> is timer, the interval
before showing the hot popup.

Timer Hide Interval Unit When <Hot Event> is timer, the interval
before hiding the hot popup, after showing it.

Spot Index Number The index of the hot spot, linking it to one or
more corresponding hot popups.

Hot Popup

A hot popup is a generic element, available for edit when the hot spot associated with it is selected (see
also Modify  > Design-T im e  V iew). To remove a hot popup, simply select and remove it using the Edit >
Rem ove menu item, or the Delete key.

Style

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the hot popup.

Settings

Behavior

Hide Event Select The event upon which to hide the hot popup
(additionally to the behavior implied by <Hot
Event>).
none - No hiding.
click - Hide the hot popup when it is clicked.
mouseenter - Hide the hot popup when the
mouse goes over it.
mouseleave - Hide the hot popup when the
mouse goes out of it.

Initial State Select The starting state of the hot popup, either 
visible or hidden.

Hot Popup Index Number The index of the hot popup, linking it to one or
more corresponding hot spots.

Navigation
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Lock Next Navigation Select When on, prevents from navigating to the next
page before the hot popup is triggered.

Hot Popup Close Button

The hot popup close button gives a formal and clear way of closing the hot popup. To add a hot popup
close button to a hot popup, use the Modify  > Add Hot Popup C lose  Button menu item. To remove it,
simply select it and remove it using the Edit >  Rem ove menu item, or the Delete key.

5.9.6 Hot Word

Hot words are inline elements, which allow easily adding interactivity embedded in a text paragraph. Hot
words consist of a hot word element, and a hot word popup element which is shown when the hot word's
event is triggered, according to its <Hot Event>.

Hot words are similar to Hot Spots, but serve a specific purpose of triggering hot word popups on
interaction with a segment of text.

To insert a hot word, select a segment of text, and use the Inse rt >  Hot W ord menu item. Inserting a hot
word without selecting a segment of text will append a hot word to the current text.

Style

Hot Word

Hide Mode Select effect - Use an effect (if defined) when hiding
hot word popups.
plain - Hide hot word popups without any
effects.

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the hot word.

Visited Style Style Rule Used once the hot word has been shown.

Active Style Style Rule Used when the hot word is active.

Settings

Hot Word

Event Select mouseover - The hot word popup is shown/
hidden when the mouse is over/out the hot
spot.
click - The hot word popup is shown/hidden
when the hot spot is pressed.

Hide All Popups Select When on, hides all other popups when being
shown.

Link

Link To Text A URL to open when pressing the hot word.
Setting a URL voids the normal functionality of
the hot word, and the hot word popup is never
shown.

Window Name Text The name of the window to open the <Link To>
URL in. If no window name is given, the URL
will be opened in a new window. Only relevant
when a URL is set.

Hot Word Popup
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A hot popup is a generic element, available for edit when the hot word associated with it is selected.

5.9.7 Survey

Surveys enable the author to collect opinions and other information from the learners. Surveys consist of
one or more survey item elements, an optional final message element, and a send button element.

To insert a survey, use the Inse rt >  Survey menu item.

Style

Rating Images

On Image Media Used for rating stars in their active state.

Off Image Media Used for rating stars in their inactive state.

Edit Image Media Used for rating stars when they're being set.

Settings

Behavior

Star Count Number Number of stars (3-10) in the rating element,
or the max rating, equivalent to the rating
<Star Count>.

Store Items Scores Select When on, individual items' scores are stored
when storing the survey.

Store Survey Total Score Select When on, the total score of all participating
items is stored when storing the survey.

Store Survey Average Score Select When on, the average score of all participating
items is stored when storing the survey.

Misc

Description Text Description of the activity, to be sent to the
LMS along with the result.

Survey Item

A question participating in the survey, can either be a rating item or an open text item. To rearrange
items in the survey, use the Modify  > Move  Item  Up and Modify  > Move  Item  Down menu items. To
remove items from the survey, simply remove them using the Edit >  Rem ove menu item or the Delete
key.

Rating items consist of a question and a rating element and allow the learners to score the question,
within a specified range. To add a rating item to the survey, use the Modify  > Add Rating Item menu
item.

Open text items consist of a question a text area and allow the learners to freely express themselves on
the question. To add an open text item to the survey, use the Modify  > Add Open Tex t Item menu item.

Final Message

A generic element (like box) which can be used to provide a final message to the learner upon
completing the survey. The final message element can be removed, simply by removing it using the Edit
> Rem ove menu item or the Delete key.
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5.9.8 Feedback

The feedback element is a part of all assessment activities.
Upon checking the answer of an activity, the feedback element
provides the learners with immediate feedback on the accuracy
of their answer.

Feedback elements consist of one or more feedback items,
along with several optional buttons. The appearance and
contents of each of these can be customized, similarly to other
generic elements. The feedback element features are
configured via the properties pane, and the Modify  > Feedback
menu.

Settings

Behavior

Attempts Number The number of incorrect attempts possible for
this activity.

Auto Fix Select When on, automatically corrects the answer
after the last incorrect attempt.

Appearance

Match Size Select When on, automatically resizes the feedback
element to match its contents.

Hide Mode Select effect - Use an effect (if defined) when hiding
the feedback.
plain - Hide the feedback without any effects.

Navigation

Lock Next Navigation Select When on, prevents from navigating to the next
page before the attempts have been
exhausted.

Right Feedback

Shown when the answer is correct. To add a right feedback item, use the Modify  > Add R ight Feedback
menu item.

Wrong Feedback

Shown when the answer is incorrect. To add a wrong feedback item, use the Modify  > Add W rong
Feedback menu item.

Settings

Behavior

When Select On which attempt to show the feedback, either 
first attempt, second attempt, second
attempt and on, third attempt, third
attempt and on, last attempt or any
attempt.

Partial Feedback

Shown when the answer is partially correct. To add a partial feedback item, use the Modify  > Add Partia l
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Feedback menu item.

Settings

Behavior

When Select On which attempt to show the feedback, either 
first attempt, second attempt, second
attempt and on, third attempt, third
attempt and on, last attempt or any
attempt.

Final Feedback

Shown after the last attempt. To add a final feedback item, use the Modify  > Add Fina l Feedback menu
item.

Custom Feedback

Shown when a custom condition is met. To add a custom feedback item, use the Modify  > Add Custom
Feedback menu item.

Settings

Behavior

Condition Condition A combination of conditions upon which to show
the custom feedback item.

When Select On which attempt to show the feedback, either 
first attempt, second attempt, second
attempt and on, third attempt, third
attempt and on, last attempt or any
attempt.

Range Feedback

Shown when the number of correct answers is in the specified range. To add a range feedback item, use
the Modify  > Add Range  Feedback menu item.

Settings

Behavior

Lower Bound Number The lower bound of the range of correct
answers.

Higher Bound Number The higher bound of the range of correct
answers.

When Select On which attempt to show the feedback, either 
first attempt, second attempt, second
attempt and on, third attempt, third
attempt and on, last attempt or any
attempt.

Close Button

Shown on every attempt. Hides the feedback element. To add a close button, use the Modify  > Add
C lose  Button menu item.

Style
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Behavior

Mouse Over Style Style Rule Used when the mouse is over the button.

Retry Button

Shown on every incorrect attempt but the last. Hides the feedback element an allows for another
attempt. To add a retry button, use the Modify  > Add Try  Aga in Button menu item.

Style

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the button.

Settings

Behavior

Reset Question Select When on, the question gets reset when the
retry button is pressed.

Fix Button

Shown on the last incorrect attempt. Fixes the activity to show the correct answers. To add a fix button,
use the Modify  > Add Show Correction Button menu item.

Style

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the button.

Settings

Behavior

Hide Feedback Select When on, the feedback is hidden when the fix
button is pressed.

Check Button

The check button resides outside of the feedback element, but is connected to it. Validates the answers
of the activity, and gives feedback accordingly.

Style

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the button.

5.9.9 Get a Hint

Hints are helper elements, which are added to existing activities to provide helpful hints to learners.

Hint elements contain a hint popup element.

A hint element can be added to the following elements:

Multiple choice, by selecting a multiple choice element and using the Modify  > Add Hint menu item.

Drag drop, by selecting a drag drop element and using the Modify  > Add Hint menu item.

Fill blank, by selecting a fill blank element and using the Modify  > Add Hint menu item.
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Style

Get a Hint

Hide Mode Select effect - Use an effect (if defined) when hiding
the hint popup.
plain - Hide the hint popup without any effects.

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the hint button.

Visited Style Style Rule Used once the hint has been shown.

Active Style Style Rule Used when the hint is visible.

Settings

Behavior

Hint Event Select mouseover - The hint popup is shown/hidden
when the mouse is over/out the hint.
click - The hint popup is shown/hidden when
the hint is pressed.

Score Decrease Unit The factor (in percents) by which to decrease
the learner's score, once they view the hint. A
value of 0 means the score will not be
decreased.

Show Once Select When on, the hint will only be shown once.

Available After Unit The amount of time after which the hint will be
available for viewing.

Show Button Select effect - Use an effect (if defined) when
showing the hint button.
plain - Show the hint button without any
effects.

Hint Popup

A hint popup is a generic element, available for edit when the hint button associated with it is selected.
The hint popup is shown according to the hint <Hint Event>, and should contain any helpful hint to help
the player solve the question at hand.

5.10 Other

The following elements don't fit in any of the other categories.

Variable
Test Feedback
User Identification
Narration
Sequence Manager

5.10.1Variable

Variable elements are text elements which show a dynamic value according to <Value>.

To insert a variable element, use the Inse rt >  Variab le menu item.
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Settings

Variable

Value Select See information below for the list of options for
<Value>.

Value options

The options available for <Value> may be extended according to the element the variable element is
nested in. Following is a table of each element, and the options it adds.

All Elements

project title Title of the project, as specified in the project properties.

location title Title of the current document, as specified in the document
properties.

page number Number of the current page out of the total pages in the course.

total pages Total number of pages in the course.

total done Total number of pages done in the course.

chapter page number Number of the current page out of the total pages in the chapter.

chapter total pages Total number of pages in the chapter.

chapter total done Total number of pages done in the chapter.

current global score Current overall score throughout the course.

first name Learner's first name, as reported by the LMS.

last name Learner's last name, as reported by the LMS.

middle name Learner's middle name, as reported by the LMS.

last global score Last overall score throughout the course.

last status Last overall status of the course.

total hours Hour part of the total amount of time spent by the viewer on the
course.

total minutes Minute part of the total amount of time spent by the viewer on the
course.

session hours Hour part of the amount of time spent by the viewer on the
current session.

session minutes Minute part of the amount of time spent by the viewer on the
current session.

user identification User identification, as supplied by the User Identification element.

Multiple Choice

correct answers Number of answers answered correctly.

incorrect answers Number of answers answered wrong.

total answers Total number of supplied answers.

attempts left Number of attempts left.

current attempt Number of the current attempt.

total attempts Total number of attempts available.
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Drag Drop

correct answers Number of answers answered correctly.

total answers Total number of supplied answers.

attempts left Number of attempts left.

current attempt Number of the current attempt.

total attempts Total number of attempts available.

Fill Blank

correct answers Number of answers answered correctly.

incorrect answers Number of answers answered wrong.

total answers Total number of supplied answers.

attempts left Number of attempts left.

current attempt Number of the current attempt.

total attempts Total number of attempts available.

Test Feedback

test title Title of the current test, as specified in the document properties.

total questions Total number of questions in the test.

total answers Total number of answers provided in the test.

correct answers Total number of correct answers in the test.

incorrect answers Total number of incorrect answers in the test.

partial answers Total number of partial answers in the test.

total score Total score achieved in the test.

pass score Pass score defined for the test, as specified in the test settings.

Blog Post

post title Title of the post.

post author Author of the post.

post date Date of the post's submission.

post tags Tags assigned to the post.

post text Textual contents of the post.

post index Index of the post within the list.

comment count Number of comments on the post.

Blog Comment Post

comment author Author of the comment.

comment date Date of the comment's submission.

comment text Textual contents of the comment.

comment index Index of the comment within the list.
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Blog Recent Posts

post title Title of the post.

post author Author of the post.

post date Date of the post's submission.

post index Index of the post within the list.

Blog Recent Comments

post title Title of the post which has been commented on.

comment author Author of the comment.

comment date Date of the comment's submission.

comment text Textual contents of the comment.

comment index Index of the comment within the list.

Blog Archive

post title Title of the post.

post author Author of the post.

post date Date of the post's submission.

post index Index of the post within the list.

Blog Categories

tag label Label of the tag.

post count Number of posts associated with the tag.

Blog Tag Cloud

tag label Label of the tag.

post count Number of posts associated with the tag.

Blog Top Rated

post title Title of the post.

post author Author of the post.

post date Date of the post's submission.

post index Index of the post within the list.

rating score Average score for the post.

rating votes Total number of votes for the post.

Rating

rating score Average score.

rating votes Total number of votes.

BACKUP
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Values of first name, last name, middle name, total hours, and total minutes all depend on
values supplied by a SCORM compliant LMS.

5.10.2Test Feedback

The test feedback element is used to show feedback about a test once it's finished. Test feedback
elements consist of one or more feedback items, along with several optional buttons. The appearance
and contents of each of these can be customized, similarly to other generic elements. The feedback
element features are configured via the properties pane, and the Modify > Test Feedback menu.

To insert a test feedback element, use the Inse rt >  Test Feedback menu item. For a test feedback
element to operate, it must be linked to its relevant test via the <Linked Test> property.

Settings

Test Feedback

Linked Test Resource Links the test feedback element to its relevant
test.

Test Summary

Lists global statistics for the test.

Settings

Behavior

Condition Condition A combination of conditions upon which to show
the test summary feedback.

When Select On which attempt to show the feedback, either 
first attempt, second attempt, second
attempt and on, third attempt, third
attempt and on, last attempt or any
attempt.

Sections Summary

Lists each section of the test and its statistics.

Settings
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Behavior

Condition Condition A combination of conditions upon which to show
the sections summary feedback.

When Select On which attempt to show the feedback, either 
first attempt, second attempt, second
attempt and on, third attempt, third
attempt and on, last attempt or any
attempt.

Test Details

Lists each question in the test and its score.

Settings

Behavior

Condition Condition A combination of conditions upon which to show
the results details feedback.

When Select On which attempt to show the feedback, either 
first attempt, second attempt, second
attempt and on, third attempt, third
attempt and on, last attempt or any
attempt.

Appearance

Activate Review Links Select When on, each of the listed answers can be
used to navigate back to their corresponding
document.

Show Correct Answers Select When on, lists answers which are marked as
correct.

Show Incorrect Answers Select When on, lists answers which are marked as
incorrect.

Show Partial Answers Select When on, lists answers which are marked as
partial.

Custom Test Feedback

A custom feedback shown on a pre-set condition combination.

Settings

Behavior

Condition Condition A combination of conditions upon which to show
the test custom feedback.

When Select On which attempt to show the feedback, either 
first attempt, second attempt, second
attempt and on, third attempt, third
attempt and on, last attempt or any
attempt.

Navigation

Redirect To Resource If present, the document to navigate to when
the condition is matched and the custom
feedback is shown.

Test Results
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Shows the final score of the test.

Settings

Behavior

Condition Condition A combination of conditions upon which to show
the test results feedback.

When Select On which attempt to show the feedback, either 
first attempt, second attempt, second
attempt and on, third attempt, third
attempt and on, last attempt or any
attempt.

Test Passed

Shows the pass score of the test, only shown if the test is passed.

Settings

Navigation

Redirect To Resource If present, the document to navigate to when
the is passed.

Test Failed

Shows the pass score of the test, only shown if the test is failed.

Settings

Navigation

Redirect To Resource If present, the document to navigate to when
the is failed.

Review Test

A button for reviewing the test, only shown when Allow Review in the test properties is on.

Style

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the button.

Settings

Behavior

Condition Condition A combination of conditions upon which to show
the review button.

When Select On which attempt to show the feedback, either 
first attempt, second attempt, second
attempt and on, third attempt, third
attempt and on, last attempt or any
attempt.

Retake Test

A button for retaking the test.
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Style

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the button.

Settings

Behavior

Condition Condition A combination of conditions upon which to show
the re-test button.

Navigation

Target Resource The document to navigate to when pressing the
button. If none set, defaults to the first page of
the <Linked Test>.

5.10.3User Identification

User identification is used to identify the learner when basic student tracking is used. User identification
can be based on any identifier wanted. A user identification element consists of a label, a text field, and
an error message. To specify which identifier is wanted, change the text of the label.

To insert a user identification element, use the Inse rt >  Use r Identifica tion menu item.

Settings

Behavior

Mandatory Select When on, user identification is required to leave
the document it is on.

User Id Label

A descriptive text of the wanted identifier.

Text Field

An input for the user identification.

User Id Error

An error message shown when <Mandatory> is on, and user identification is not filled.

5.10.4Narration

While the narration itself is managed through the Sequence Manager, there are several helper elements
which can be added to enhance the narration experience for the learner.

Narration On/Off

Allows the learner to mute and restore narration throughout the course. The effect of this button is
global; after being muted in one page, narration will remain muted in all other pages unless it is restored
by the learner.
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Style

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the button.

Muted Style Style Rule Used when narration is muted.

Closed Captioning

A generic element (like box) which can be used to provide closed captioning throughout the course.
Closed captioning elements are unique, in that they are hidden by default and are only shown if
activated by the learner using Closed Captioning On/Off button.

Closed Captioning On/Off

Allows the learner to activate and deactivate closed captioning throughout the course. The effect of this
button is global; after being activated in one page, closed captioning will remain activated in all other
pages unless it is deactivated by the learner.

Style

Style Rules

Mouse Over Style Style Rule Used when the mouse is over the button.

Active Style Style Rule Used when closed captioning is active.

5.10.5Sequence Manager

The sequence manager manages the sequential aspects of the document, like effects and narration. The
sequence manager is a virtual element, and is not visible in runtime.

To add sequencing to a document, use the Too ls > Sequence  Manager... menu item, or press the
Sequence Manager toolbar button. If elements are selected when first applying the sequence manager,
these will be the elements that participate in the sequence. If no elements are selected, the top-most
elements in the document hierarchy will participate in the sequence.

To configure the global sequence settings, either select the sequence manager element and use the 
property grid, or use the Sequence Manager dialog.

A sequence manager element can also be added automatically when applying effects or narration to the
document or one of its elements. To learn more about adding sequences to the document, read about 
sequencing and effects.

Style

Sequencing

Active Select When on, the effect sequence is enabled.

Effect Type Select Type of effect to play by default.

Effect Duration Unit Duration for each step of the effect sequence.

Delay Unit Delay between each step of the effect
sequence. Only relevant when <Effect Trigger>
is timer or either.

Order Select The order of steps of the effect sequence.
Either determined by the positions of the
elements on screen, random, or custom
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which is specified by their order in the 
Sequence Manager dialog.

Trigger Select timer - The sequence is advanced by a timer,
controlled by <Effect Start After>, <Effect
Duration> and <Effect Step>.
moue click - The sequence is advanced by
mouse clicks - each step is delayed until the
mouse is pressed.

Hide Mode Select Determines how elements are hidden after
being shown by the sequence manager.
none - Elements are not hidden.
effect - Elements are hidden by using the
effect.
effect, interlaced - Elements are hidden by
using the effect, while the next element gets
shown.
plain - Elements are hidden without an effect.

Start After Unit Delay after showing the page before starting
the effect sequence. Only relevant when
<Effect Trigger> is timer or either.

Play Mode Select every time - Effect sequence is played every
time the document is viewed.
first time - Effect sequence is only played the
first time the document is viewed.

Loop Select When on, the effect sequence is repeated
infinitely.

Settings

Navigation

Lock Next Navigation Select When on, prevents from navigating to the next
page until the sequence has finished playing.

Participating Elements

Each element which can be part of an effect sequence, is also given the following properties:

Style

Sequencing

Effect Active Select When on, the element participates in the effect
sequence.

Effect Type Select Type of effect for the element.

Settings

Narration

Narration Media An audio file containing narration for the
element, to be played along with the effect and
be timed accordingly.

Narration Volume Number Determines the volume of the narration, with 
100 being full volume, and 0 being muted.
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5.11 Mind Games

Game elements are a special type of elements, which have a high degree of flexibility both in their
options and their visual appearance.

Games can be inserted via the game picker, which can be opened using the Inse rt >  Mind G am es >
G am e P icke r... menu item or the G am e P icke r toolbar button. The game picker also shows a thumbnail
of the game, along with a short description of the game and its key attributes.

The following properties are common to all games:

Settings

Behavior

Replayable Select When off, the start game button is hidden after
the game is started, and the game cannot be
restarted at any point.

Recycle Questions Select When on, questions are recycled once the
learner exhausts the question list (and the
game isn't over). When off, the game is ended
once the learner exhausts the question list.

Force One Attempt Select When on, a single attempt is forced on the
game's questions.

Show Continue Select always - Show the Continue button at all
times, allowing the learner to proceed before
answering the question.
after answer - Only show the Continue button
after the learner has answered the question.
auto continue - Don't show the Continue
button, and automatically continue after the
question has been answered.

Appearance

Show Score Select When on, score is displayed along with the
game.

Show Results Select When on, the results layer is shown after has
ended.

Sound Effects

Sound (default) Select Determines the initial state of sounds in the
game. When off, sounds are initially muted.

Background Media Audio file to play as background music
throughout the entire game. The volume for
this sound can be set via <Volume /
Background>.

Background Volume Number The volume, in percents, for the background
music.

Start Media Audio file to play when the game is started.

Question Media Audio file to play when a question is shown.

Correct Media Audio file to play when a question is answered
correctly.

Incorrect Media Audio file to play when a question is answered
incorrectly.

Win Media Audio file to play when the game is won.



Elements 146

©  2010 Com posica  Ltd.

Lose Media Audio file to play when the game is lost.

Each of the following pages represents a game, and lists the game-specific settings, allowing to further
customize the game to your personal needs.

Master Plumber
Space Bubbles
High Hops
Rescue Mission
Game Show

5.11.1Master Plumber

The goal of this game is to align the pipes correctly, so they will carry the fluid from one end to the other
and not spill at any point along the way.

The game starts with the pipes in randomized directions. The player clicks on a pipe in order to rotate it.
Some pipes are broken and marked with a wrench icon. In order to fix a broken pipe and rotate it the
player needs to answer a question correctly. If a pipe has not been fixed, the question will simply
transfer to the next level. Once the player believes the pipes are properly aligned, the valve can be
opened by clicking on it, and start the flow of fluid.

Levels can be loaded from pre-made presets, using <Levels Presets>. Levels can be further customized
using the level editor, which can be opened via <Levels Designer>. In the level editor, levels can either
be created from scratch, or single levels can be imported from the level presets.

Game attributes:

Win: The player wins by completing all questions and passing the test, or by completing all levels
(configurable).

Lose: The player loses when time runs out, or the test is failed.

Playability: Intermediate or advanced strategy/skills required to play the game, depending on
levels.

Test score: Questions that the player did not reach before the game ended will not be counted as
part of the test.

In the Game layer there is  a Solve button, allowing the player to immediately solve the pipe route. This  feature is  useful

if the des igner would like to give the player the option to only answer the ques tions  without solving the puzzle. This

element will appear in run-time, unless  it's  manually removed.

To insert a muster plumber game, use the Inse rt >  Mind G am es > Maste r P lum ber m enu item  or the
G am e P icke r > Maste r P lum ber toolbar menu item. Alternatively, you can use the game picker, which
can be opened using the Inse rt >  Mind G am es > G am e P icke r... menu item or the G am e P icke r toolbar
button.

Settings

Behavior

Questions per Level Number The number of questions (wrenches) to display
in each level. When set to 0, <Cycle Levels>
should be set to false.

Levels Preset Select Allows to choose one of the pre-made level
sets. Choosing a presets overwrites any level
data in <Levels Designer>.
user defined - Allows you to design your own
set of levels, via <Levels Designer>.
blank - Resets the level data to a blank set.

Levels Designer Special A special property, which opens the level editor
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when clicked. The property displays the
number of levels in the active set. Changing
the level data via the editor automatically sets
<Levels Preset> to user defined.

When Spilled Select When failing a level (the fluid was spilled along
the way), the game should:
next level - continue to the next level,
regardless.
same level - let the player try the same level
again.

Cycle Levels Select When on, levels are cycled when all levels have
been exhausted and questions still remain.
When off, the game is ended once all levels
have been exhausted.

Level Time (sec) Select The time available for the player to complete
each level. After the time has elapsed, the
valve is automatically opened and the fluid
starts flowing.

Appearance

Machine Type Select The visual appearance of the machine
generating the fluid. A setting of mixed cycles
through the different machines each level.

Tile Type Number The visual appearance of the tiles.

Tile Opacity Number The opacity level (0-100) of the tiles.

Pipes Color Color The color of the pipes.

Joints Color Color The color of the joints connecting between the
pipes.

Fluid Color Color The color of the fluid running through the pipes.

Liquid Speed Select The speed of the fluid running through the
pipes, once its starts pumping.

Sound Effects

Rotate Media Audio file to play when a pipe is rotated.

Valve Media Audio file to play when the valve is opened.

Success Media Audio file to play when the level has been
completed successfully.

Failure Media Audio file to play when the level has failed
(fluid has spilled along the way).

5.11.2Space Bubbles

This is a traditional 'bubbles' game, the goal is to pop all bubbles (in this case, stars or dices) and/or
answer all questions. The player aims a cannon and fires it by clicking. If the fired item creates a cluster
of at least 3 items of the same type, the cluster explodes. Some stars have questions attached to them.
When attempting to explode a star with a question, the player is prompted with a question. A question
star cannot be exploded unless the question attached to it is answered correctly.

Game attributes:

Win: The player wins by exploding all items and/or answering all questions (see <Win Condition>).
It's possible for a player to win the game, but still fail the test.

Lose: The player loses when time runs out, questions run out, or the items are stacked too low. It's
possible for a player to lose the game, but still pass the test.

Playability: Intermediate strategy/skills required to play the game.

Test score: Questions that the player did not reach before the game ended will not be counted as
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part of the test.

To insert a space bubbles game, use the Inse rt >  Mind G am es > G am e Show m enu item  or the  G am e
P icke r > G am e Show toolbar menu item. Alternatively, you can use the game picker, which can be
opened using the Inse rt >  Mind G am es > G am e P icke r... menu item or the G am e P icke r toolbar button.

Settings

Behavior

Questions Number The number of questions to attach to stars.

Win Condition Select clear all questions - The game is won when
all questions have been cleared.
clear all stars - The game is won when all the
stars have been cleared.

When Wrong Select Upon answering a question incorrectly:
keep cluster - The rest of the cluster doesn't
explode along with the question star.
explode cluster - The rest of the cluster
explodes, leaving only the question star.

Missed Before Penalty Row Number The number of "missed" shots (shots which
don't generate explosions) before a penalty
row is added. A successful hit resets the
counter. A value of 0 disables penalty rows.

Appearance

Galaxy Select The visual appearance of the stars.

Star Sprites Select The number of different star sprites to use (a
lower number will imply an easier game).

Stars per Row Number The number of stars per each row.

Rows Number The number of rows of stars.

Show Background Select When off, the default background is hidden and
the visual appearance of the game can be
customized.

Sound Effects

Explode Media Audio file to play when a cluster explodes.

Fire Media Audio file to play when a star is fired.

5.11.3High Hops

The player guides a frog from the left bank of the pond to the right by hopping from one lily pad to the
next. The player clicks on a lily pad to hop to, and needs to answer a question correctly to remain on the
chosen lily pad.

Game attributes:

Win: The player wins by reaching the right bank. It's possible for a player to win the game, but still
fail the test.

Lose: The player loses when time runs out, questions run out, or lily pads run out. It's possible for a
player to lose the game, but still pass the test.

Playability: Basic strategy/skills required to play the game.

Test score: Questions that the player did not reach before the game ended will not be counted as
part of the test.

Special features: The game can be played by two groups/people playing against each other.
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To insert a high hops game, use the Inse rt >  Mind G am es > High Hops m enu item  or the  G am e P icke r >
High Hops toolbar menu item. Alternatively, you can use the game picker, which can be opened using
the Inse rt >  Mind G am es > G am e P icke r... menu item or the G am e P icke r toolbar button.

Settings

Behavior

Attempts Number Set the number of attempts per step (lily pad).

Players Select The number of players to play the game,
either one or two. When set to two, the lily
pads on screen will be numbered to aid
collaborative play.

Appearance

Steps per Row Number The number of lily pads in a row.

Steps per Column Number The number of lily pads in a column.

Frog Color Select The player frog color, either red or purple.

Show Ripples Select When on, ripples will be shown around the lily
pads the player can jump to on each step.

Show Pool Select When off, the pool is transparent allowing
customization of the game's appearance.

Sound Effects

Hop Media Audio file to play when the frog hops between
lily pads.

5.11.4Rescue Mission

The goal of this game is to rescue the penguin from the hole in the ice by stacking fish under it. A fish
comes to the penguin's aid when the player answers a question correctly. The top-most fish will vanish
when the player answers a question incorrectly.

Game attributes:

Win: The player wins by completing all questions and passing the test.

Lose: The player loses when when time runs out, the test is failed, or the penguin isn't rescued (see
<Drown Mode>).

Playability: No strategy/skills required to play the game.

Test score: Questions that the player did not reach before the game ended will be counted as
mistakes in the test.

To insert a rescue mission game, use the Inse rt >  Mind G am es > Rescue  Miss ion m enu item  or the
G am e P icke r > Rescue  Miss ion toolbar menu item. Alternatively, you can use the game picker, which can
be opened using the Inse rt >  Mind G am es > G am e P icke r... menu item or the G am e P icke r toolbar
button.

Settings

Behavior

Drown Mode Select Determines whether the penguin drowns if the
player fails to answer the question at the
bottom of the sea.

Switch Question Number The number of switch question lifelines made
available to the player.
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50:50 Number The number of 50:50 lifelines (reduces the
number of answers by 50%) made available to
the player.

Appearance

Landscape Select The visual appearance of the background. A
setting of mixed cycles through the different
landscape each level.

Fish Type Select The visual appearance of the fish stacked
under the penguin. A setting of mixed chooses
a different fish type each round.

Sea Custom Select When on, uses <Sea / Color> to determine the
color of the sea.

Sea Color Color A custom color to use for the sea. Only
relevant when <Sea / Custom> is true.

Sound Effects

Level Media Audio file to play when the player moves up a
level.

5.11.5Game Show

This is a gameshow-type trivia game, the player simply answers questions in order to get ahead in the
game.

Game attributes:

Win: The player wins by completing all questions and passing the test.

Lose: The player loses when time runs out, or the test is failed.

Playability: No strategy/skills required to play the game.

Test score: Questions that the player did not reach before the game ended will be counted as
mistakes in the test.

Special features: The player may use special lifelines, including "switch the question" and "fifty-
fifty".

When you insert an ac tivity to a game show ques tion page, make sure you set the ac tivity s ize to take only half of the

sc reen (as  the other half is  taken by the game's  hos t).

To insert a game show game, use the Inse rt >  Mind G am es > G am e Show m enu item  or the  G am e
P icke r > G am e Show toolbar menu item. Alternatively, you can use the game picker, which can be
opened using the Inse rt >  Mind G am es > G am e P icke r... menu item or the G am e P icke r toolbar button.

Settings

Behavior

Switch Question Number The number of switch question lifelines made
available to the player.

50:50 Number The number of 50:50 lifelines (reduces the
number of answers by 50%) made available to
the player.

Appearance

Game Host Select The visual appearance of the game host.

Sound Effects

Continue Media Audio file to play when the player continues to
the next question.
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6.1 Composica doesn't start

Popup blockers

Popup blockers can prevent Composica from starting properly. If trying to launch Composica from the 
Composica Dashboard does not open a new window, make sure any popup blockers you might have are
disabled, or have been set to allow popups. Some common popup blockers are the Windows XP SP2
popup blocker, and blockers provided by Internet Explorer toolbars.

Anti-Virus applications

Different anti-virus applications might wrongly identify Composica as a security risk, and interfere with
its normal operation. If you're experiencing trouble, try temporarily disabling your anti-virus services,
and consult your system administrator.

Internet Explorer security

Internet Explorer's strict security policy might prevent some features from working properly. You're
advised to add Composica to Internet Explorer's Trusted sites list.

6.2 Spell checker can't run

The spell checker requires access to certain system components, that might be blocked by Internet
Explorer's default security settings. To grant Composica the required permissions, you might need to add
it to Internet Explorer's Trusted s ite s list.

Trusted sites

To add Composica to Internet Explorer's Trusted sites list, follow these steps:

1.  Open a new Internet Explorer window.

2.  Choose the Tools > Internet Options... menu item.

3.  Select the Security tab.

4.  Select the Trusted sites icon.

5.  Important: Make sure the Security Level is set to "Low".

6.  Press the Sites... button.

7.  Make sure the "Require server verification (https:) for all sites in this zone" checkbox is not checked.

8.  Enter the URL of Composica in the "Add this Web site to the zone" field.

9.  Press the Add button.

10.  Press the OK button to close the Trusted sites dialog, and click OK again to close the Internet
Options dialog.

You should now see the  Trusted s ite s icon at the bottom of Internet Explorer when starting
Composica.

These s teps  may differ between different Internet Explorer vers ions . For more information, refer to the M ic rosoft Internet

Explorer manual.

If you've followed these steps, and the spell checker still reports a security error, please make sure you
have Microsoft Word installed, as Composica depends on it being installed for its spell checking
capabilities.
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